Handboek Annuleren

Frame-voor-frame-animaties in Animate

  1. Adobe Animate-handboek
  2. Inleiding tot Animate
    1. Nieuw in Animate
    2. Visuele verklarende woordenlijst
    3. Systeemvereisten voor Animate
    4. Animate-sneltoetsen
    5. Werken met meerdere bestandstypen in Animate
  3. Animatie
    1. Grondbeginselen voor animaties in Animate
    2. Frames en hoofdframes gebruiken in Animate
    3. Frame-voor-frame-animaties in Animate
    4. Werken met klassieke tussenvoegingsanimaties in Animate
    5. De tool Penseel
    6. Hulplijnen voor bewegingen
    7. Bewegings-tween en ActionScript 3.0
    8. Over tussenvoegingsanimaties met beweging
    9. Animaties met bewegings-tweens
    10. Een animatie met bewegings-tween maken
    11. Eigenschapshoofdframes gebruiken
    12. Een positie animeren met een tween
    13. Bewegings-tweens bewerken in de Bewegingseditor
    14. Het bewegingspad van een tween-animatie bewerken
    15. Bewegings-tweens manipuleren
    16. Aangepaste versnellingen toevoegen
    17. Voorinstellingen voor beweging maken en toepassen
    18. Animatietween-reeksen instellen
    19. Werken met als XML-bestanden opgeslagen bewegings-tweens
    20. Bewegings-tweens en klassieke tweens
    21. Tussenvoegingen met vormen
    22. De tool Bone-animatie gebruiken in Animate
    23. Werken met structuren voor personages in Animate
    24. Maskeerlagen gebruiken in Adobe Animate
    25. Werken met scènes in Animate
  4. Interactiviteit
    1. Knoppen maken met Animate
    2. Animate-projecten converteren naar andere documentindelingen
    3. HTML5 Canvas-documenten maken en publiceren in Animate
    4. Interactiviteit toevoegen met codefragmenten in Animate
    5. Aangepaste HTML5-componenten maken
    6. Componenten in HTML5 Canvas gebruiken
    7. Maken van aangepaste componenten: Voorbeelden
    8. Codefragmenten voor aangepaste componenten
    9. Tips en trucs: Adverteren met Animate
    10. Ontwerp en publicatie van virtual reality
  5. Werkruimte en workflow
    1. Penselen maken en beheren
    2. Google-lettertypen gebruiken in HTML5 Canvas-documenten
    3. Creative Cloud Libraries en Adobe Animate gebruiken
    4. Het werkgebied en het deelvenster Tools voor Animate gebruiken
    5. Workflow en werkruimte in Animate
    6. Weblettertypen gebruiken in HTML5 Canvas-documenten
    7. Tijdlijnen en ActionScript
    8. Werken met meerdere tijdlijnen
    9. Voorkeuren instellen
    10. Deelvensters voor ontwerp in Animate gebruiken
    11. Tijdlijnlagen maken met Animate
    12. Animaties exporteren voor mobiele apps en game-engines
    13. Objecten verplaatsen en kopiëren
    14. Sjablonen
    15. Zoeken en vervangen in Animate
    16. Ongedaan maken, Opnieuw en het deelvenster Historie
    17. Sneltoetsen
    18. De tijdlijn gebruiken in Animate
    19. HTML-extensies maken
    20. Optimalisatieopties voor afbeeldingen en geanimeerde GIF-bestanden
    21. Exportinstellingen voor afbeeldingen en GIF-bestanden
    22. Deelvenster Elementen in Animate
  6. Multimedia en video
    1. Grafische objecten transformeren en combineren in Animate
    2. Symboolinstanties maken in Animate en ermee werken
    3. Afbeeldingen overtrekken
    4. Geluid gebruiken in Adobe Animate
    5. SVG-bestanden exporteren
    6. Videobestanden maken voor gebruik in Animate
    7. Een video toevoegen in Animate
    8. Objecten tekenen en maken met Animate
    9. Lijnen en vormen omvormen
    10. Streken, verlopen en vullingen met Animate CC
    11. Werken met Adobe Premiere Pro en After Effects
    12. Deelvensters voor kleuren in Animate CC
    13. Flash CS6-bestanden openen met Animate
    14. Werken met klassieke tekst in Animate
    15. Illustraties opnemen in Animate
    16. Geïmporteerde bitmaps in Animate
    17. 3D-afbeeldingen
    18. Werken met symbolen in Animate
    19. Lijnen en vormen tekenen met Adobe Animate
    20. Werken met bibliotheken in Animate
    21. Geluiden exporteren
    22. Objecten selecteren in Animate CC
    23. Werken met Illustrator AI-bestanden in Animate
    24. Overvloeimodi toepassen
    25. Objecten rangschikken
    26. Taken automatiseren met het menu Opdrachten
    27. Meertalige tekst
    28. De camera gebruiken in Animate
    29. Grafische filters
    30. Geluid en ActionScript
    31. Tekenvoorkeuren
    32. Tekenen met de pen
  7. Platforms
    1. Animate-projecten converteren naar andere documentindelingen
    2. Ondersteuning voor aangepaste platforms
    3. HTML5 Canvas-documenten maken en publiceren in Animate
    4. Een WebGL-document maken en publiceren
    5. Toepassingen verpakken voor AIR voor iOS
    6. AIR voor Android-toepassingen publiceren
    7. Publiceren voor Adobe AIR voor desktop
    8. Publicatie-instellingen voor ActionScript
    9. Tips en trucs: ActionScript organiseren in een toepassing
    10. ActionScript gebruiken met Animate
    11. Toegankelijkheid in de Animate-werkruimte
    12. Scripts schrijven en beheren
    13. Ondersteuning voor aangepaste platforms inschakelen
    14. Overzicht van ondersteuning voor aangepaste platforms
    15. Werken met plug-in voor ondersteuning voor aangepaste platforms
    16. Foutopsporing in ActionScript 3.0
    17. Ondersteuning voor aangepaste platforms inschakelen
  8. Exporteren en publiceren
    1. Bestanden exporteren uit Animate CC
    2. OAM-publicatie
    3. SVG-bestanden exporteren
    4. Afbeeldingen en video's exporteren met Animate
    5. AS3-documenten publiceren
    6. Animaties exporteren voor mobiele apps en game-engines
    7. Geluiden exporteren
    8. Tips en trucs: Tips voor het maken van inhoud voor mobiele apparaten
    9. Tips en trucs: Videoconventies
    10. Tips en trucs: Richtlijnen voor het ontwerpen van SWF-toepassingen
    11. Tips en trucs: Structuur geven aan FLA-bestanden
    12. Beste werkwijzen voor het optimaliseren van FLA-bestanden voor Animate
    13. Publicatie-instellingen voor ActionScript
    14. Publicatie-instellingen opgeven voor Animate
    15. Projectorbestanden exporteren
    16. Afbeeldingen en geanimeerde GIF-bestanden exporteren
    17. HTML-publicatiesjablonen
    18. Werken met Adobe Premiere Pro en After Effects
    19. Snel uw animaties delen en publiceren
  9. Problemen oplossen
    1. Opgeloste problemen
    2. Bekende problemen

 

Frame-voor-frame animaties maken

Een frame-voor-frame animatie wijzigt de inhoud van het Werkgebied in elk frame. Het is het meest geschikt voor complexe animaties waarin een afbeelding in elk frame verandert in plaats van eenvoudig door het Werkgebied te bewegen. Bij frame-voor-frame animaties neemt de bestandsgrootte sneller toe dan bij getweende animaties. In frame-voor-frame animaties worden de waarden voor elk voltooid frame opgeslagen in Animate.

Wanneer u een frame-voor-frame animatie wilt maken, definieert u elk frame als een hoofdframe en maakt u voor elk frame een andere afbeelding. Elk nieuw hoofdframe bevat aanvankelijk dezelfde inhoud als het voorafgaande hoofdframe, zodat u de frames in de animatie stapsgewijs kunt wijzigen.

  1. Klik op de naam van een laag om deze actief te maken en selecteer een frame in de laag waar de animatie moet starten.
  2. Wanneer de frame nog geen hoofdframe is, selecteert u Invoegen > Tijdlijn > Hoofdframe.
  3. Maak de illustraties voor het eerste frame van de reeks. U kunt hiervoor de gereedschappen Tekenen gebruiken, afbeeldingen vanaf het klembord plakken of een bestand importeren.
  4. Om een hoofdframe toe te voegen waarvan de inhoud precies hetzelfde als het eerste hoofdframe is, klikt u op het volgende frame aan de rechterkant in dezelfde rij. Kies Invoegen > Tijdlijn > Hoofdframe, of klik met de rechtermuisknop (Windows) of control-klik (Macintosh) en kies Hoofdframe invoegen.

  5. Wijzig de inhoud van dit frame in het werkgebied om het volgende deel van de animatie te maken.
  6. Herhaal de stappen 4 en 5 totdat u de gewenste beweging hebt gemaakt en uw frame-voor-frame animatiereeks kunt voltooien.
  7. Selecteer Besturing > Afspelen of klik op de afspeelknop in Bediening (Venster > Werkbalken > Bediening) om de animatiereeks te testen.

Frame-voor-frame animaties maken door klassieke of bewegings-tweens om te zetten

U kunt een klassieke tween of bewegings-tween-reeks omzetten in een frame-voor-frame animatie. In een frame-voor-frame animatie bevat elk frame aparte hoofdframes (niet eigenschapshoofdframes) die ieder een aparte instantie van het symbool waarop animatie is toegepast bevatten. Frame-voor-frame animatie bevat geen geïnterpoleerde eigenschapswaarden.

  1. Klik met de rechtermuisknop (Windows) of klik terwijl u Ctrl ingedrukt houdt (Macintosh) op de tween-reeks die u wilt omzetten en kies Omzetten naar frame-voor-frame animatie in het contextmenu.

Overtrekken gebruiken

Normaal gesproken wordt van een animatiereeks één frame tegelijkertijd in het werkgebied weergegeven. Als u frame-voor-frame-animaties wilt tekenen, plaatsen en bewerken, biedt de overtrekfunctie een handige referentie door de inhoud van de vorige en de volgende frames in het werkgebied weer te geven. Het frame onder de afspeelkop wordt in kleur weergegeven en met behulp van kleur- en alphawaarden wordt onderscheid gemaakt tussen frames in het verleden en toekomstige frames. 

De vorige en de volgende overtrekframes hebben standaardkleurtinten. Gebruik de optie Geavanceerde instellingen om deze kleuren aan te passen.

Overtrekken in- en uitschakelen

  • Klik op de knop voor semitransparante lagen  om deze lagen in of uit te schakelen.
  • Als u frames wilt uitsluiten of juist wilt opnemen, klikt u in de kop van de tijdlijn met de rechtermuisknop op een overtrekframe binnen het overtrekbereik.
  • Klik en houd de muisknop ingedrukt op de knop voor overtrekken om de opties weer te geven en te selecteren.

Geavanceerde instellingen voor overtrekken

Klik op de muisknop en houd deze ingedrukt op de knop voor overtrekken en selecteer Geavanceerde instellingen.

Bereik aanpassen

Kleuren aanpassen voor de overtrekweergave

  1. Selecteer Overtrekframe op de tijdlijnbalk om de kleur van overtrekframes te aan te passen.
  2. Klik op de muisknop en houd deze ingedrukt op de knop voor overtrekken en selecteer Geavanceerde instellingen .
  3. Wijzig de kleurtint van het vorige frame en van toekomstige frames.

Kader- en opvulmodus

Dekking aanpassen

  1. Als u de dekking van een overtrekkader aan weerszijden van het actieve frame wilt moduleren, klikt u op de schuifregelaar Begindekking en sleept u de regelaar naar de gewenste waarde.

  2. Als u de Delta van elk overtrekframe wilt verkleinen met een bepaald percentage, sleept u de schuifregelaar Verkleinen met.

Alleen hoofdframes weergeven

  1. Selecteer Overtrekframe op de tijdlijnbalk om de kleur van overtrekframes te aan te passen.
  2. Selecteer Bewerken > Voorkeuren.
  3. Kies de kleurstaalknoppen van de optie Overtrekkleur om de kleuren van de frames in het verleden, heden en de toekomst aan te passen en in te stellen.
     

Ankermarkeringen

Verschillende frames van een animatie gelijktijdig weergeven in het werkgebied

Klik op de knop Overtrek . Alle frames tussen de markeringen Begin overtrek en Einde overtrek (in de kop van de tijdlijn) worden samengevoegd tot één frame in het documentvenster.

Overtrekmarkeringen

Overtrekken met kleuren

Dankzij de kleurcodering voor overtrekken kunt u gemakkelijker onderscheid maken tussen de afgelopen (verleden), huidige en toekomstige frames. Hoe verder een overtrekframe is verwijderd van het actieve frame, hoe transparanter het frame wordt weergegeven.

Overtrekken op de tijdlijn

Overtrekfunctie met kleurcodering voor de afgelopen, huidige en toekomstige frames

Contourmodus voor overtrekken

Kleuren aanpassen voor de overtrekweergave

  1. Selecteer Overtrekframe op de tijdlijnbalk om de kleur van overtrekframes te aan te passen.
  2. Selecteer Bewerken > Voorkeuren.
  3. Kies de kleurstaalknoppen van de optie Overtrekkleur om de kleuren van de frames in het verleden, heden en de toekomst aan te passen en in te stellen.
     
Opmerking:

De kleurcode is ook van toepassing op de contourmodus.

Tijdlijnmodus voor overtrekken

Aangepast overtrekken

  • Wanneer u de positie van een van de overtrekmarkeringen wilt wijzigen, sleept u de betreffende aanwijzer naar een nieuwe locatie. Normaal gesproken worden de overtrekmarkeringen verplaatst met de aanwijzer van het huidige frame. Gebruik Ctrl/Command + om de positie aan beide zijden te vergroten of te verkleinen.
  • Klik op de knop Meerdere frames bewerken  wanneer u alle frames tussen overtrekmarkeringen wilt bewerken. Normaal gesproken kunt u met overtrekken alleen het huidige frame bewerken. U kunt de inhoud van elk frame tussen de overtrekmarkeringen weergeven en bewerken.
  • Als u het herhalingsbereik over de tijdlijn naar een willekeurige positie wilt verplaatsen die de positie van de afspeelkop omvat, kunt u de markeertekens in de tijdlijn gebruiken om de Shift-toets ingedrukt te houden en het bereik te slepen. 
  • Om de bereikmarkeringen in te stellen, gebruikt u de Shift-toets en sleept u de bereikmarkeringen of het herhalingsbereik met behulp van de markeringen over de Tijdlijn. 
Opmerking:

Vergrendelde lagen (aangegeven met een slotpictogram) worden niet weergegeven wanneer overtrekken is ingeschakeld. De lagen die u niet wilt overtrekken, kunt u vergrendelen of verbergen om verwarring door een groot aantal afbeeldingen te voorkomen.

Een voorvertoning van uw werk bekijken

Als u de overtrekvoortgang wilt bekijken, plaatst u de muis over het hele bereik in de tijdlijn. Uw animatie wordt afgespeeld in gekleurde contouren waarin de wijzigingen exact worden voorvertoond. 

 Adobe

Krijg sneller en gemakkelijker hulp

Nieuwe gebruiker?

Adobe MAX 2024

Adobe MAX
De creativiteitsconferentie

14–16 oktober Miami Beach en online

Adobe MAX

De creativiteitsconferentie

14–16 oktober Miami Beach en online

Adobe MAX 2024

Adobe MAX
De creativiteitsconferentie

14–16 oktober Miami Beach en online

Adobe MAX

De creativiteitsconferentie

14–16 oktober Miami Beach en online