Werken met symbolen in Animate

  1. Adobe Animate-handboek
  2. Inleiding tot Animate
    1. Nieuw in Animate
    2. Visuele verklarende woordenlijst
    3. Systeemvereisten voor Animate
    4. Animate-sneltoetsen
    5. Werken met meerdere bestandstypen in Animate
  3. Animatie
    1. Grondbeginselen voor animaties in Animate
    2. Frames en hoofdframes gebruiken in Animate
    3. Frame-voor-frame-animaties in Animate
    4. Werken met klassieke tween-animaties in Animate
    5. De tool Penseel
    6. Hulplijnen voor bewegingen
    7. Bewegings-tween en ActionScript 3.0
    8. Informatie over animaties met bewegings-tween
    9. Animaties met bewegings-tweens
    10. Een animatie met bewegings-tween maken
    11. Eigenschapshoofdframes gebruiken
    12. Een positie animeren met een tween
    13. Bewegings-tweens bewerken in de Bewegingseditor
    14. Het bewegingspad van een tween-animatie bewerken
    15. Bewegings-tweens manipuleren
    16. Aangepaste versnellingen toevoegen
    17. Voorinstellingen voor beweging maken en toepassen
    18. Animatietween-reeksen instellen
    19. Werken met als XML-bestanden opgeslagen bewegings-tweens
    20. Bewegings-tweens en klassieke tweens
    21. Vormen tweenen
    22. De tool Bone-animatie gebruiken in Animate
    23. Werken met structuren voor personages in Animate
    24. Maskeerlagen gebruiken in Adobe Animate
    25. Werken met scènes in Animate
  4. Interactiviteit
    1. Knoppen maken met Animate
    2. Animate-projecten converteren naar andere documentindelingen
    3. HTML5 Canvas-documenten maken en publiceren in Animate
    4. Interactiviteit toevoegen met codefragmenten in Animate
    5. Aangepaste HTML5-componenten maken
    6. Componenten in HTML5 Canvas gebruiken
    7. Maken van aangepaste componenten: Voorbeelden
    8. Codefragmenten voor aangepaste componenten
    9. Tips en trucs: Adverteren met Animate
    10. Ontwerp en publicatie van virtual reality
  5. Werkruimte en workflow
    1. Penselen maken en beheren
    2. Google-lettertypen gebruiken in HTML5 Canvas-documenten
    3. Creative Cloud Libraries en Adobe Animate gebruiken
    4. Het werkgebied en het deelvenster Tools voor Animate gebruiken
    5. Workflow en werkruimte in Animate
    6. Weblettertypen gebruiken in HTML5 Canvas-documenten
    7. Tijdlijnen en ActionScript
    8. Werken met meerdere tijdlijnen
    9. Voorkeuren instellen
    10. Deelvensters voor ontwerp in Animate gebruiken
    11. Tijdlijnlagen maken met Animate
    12. Animaties exporteren voor mobiele apps en game-engines
    13. Objecten verplaatsen en kopiëren
    14. Sjablonen
    15. Zoeken en vervangen in Animate
    16. Ongedaan maken, Opnieuw en het deelvenster Historie
    17. Sneltoetsen
    18. De tijdlijn gebruiken in Animate
    19. HTML-extensies maken
    20. Optimalisatieopties voor afbeeldingen en geanimeerde GIF-bestanden
    21. Exportinstellingen voor afbeeldingen en GIF-bestanden
    22. Deelvenster Elementen in Animate
  6. Multimedia en video
    1. Grafische objecten transformeren en combineren in Animate
    2. Symboolinstanties maken in Animate en ermee werken
    3. Afbeeldingen overtrekken
    4. Geluid gebruiken in Adobe Animate
    5. SVG-bestanden exporteren
    6. Videobestanden maken voor gebruik in Animate
    7. Een video toevoegen in Animate
    8. Werken met videoactiepunten
    9. Objecten tekenen en maken met Animate
    10. Lijnen en vormen omvormen
    11. Streken, verlopen en vullingen met Animate CC
    12. Werken met Adobe Premiere Pro en After Effects
    13. Deelvensters voor kleuren in Animate CC
    14. Flash CS6-bestanden openen met Animate
    15. Werken met klassieke tekst in Animate
    16. Illustraties opnemen in Animate
    17. Geïmporteerde bitmaps in Animate
    18. 3D-afbeeldingen
    19. Werken met symbolen in Animate
    20. Lijnen en vormen tekenen met Adobe Animate
    21. Werken met bibliotheken in Animate
    22. Geluiden exporteren
    23. Objecten selecteren in Animate CC
    24. Werken met Illustrator AI-bestanden in Animate
    25. Patronen toepassen met het sproeipenseel
    26. Overvloeimodi toepassen
    27. Objecten rangschikken
    28. Taken automatiseren met het menu Opdrachten
    29. Meertalige tekst
    30. De camera gebruiken in Animate
    31. Animate gebruiken met Adobe Scout
    32. Werken met Fireworks-bestanden
    33. Grafische filters
    34. Geluid en ActionScript
    35. Tekenvoorkeuren
    36. Tekenen met de pen
  7. Platforms
    1. Animate-projecten converteren naar andere documentindelingen
    2. Ondersteuning voor aangepaste platforms
    3. HTML5 Canvas-documenten maken en publiceren in Animate
    4. Een WebGL-document maken en publiceren
    5. Toepassingen verpakken voor AIR voor iOS
    6. AIR voor Android-toepassingen publiceren
    7. Publiceren voor Adobe AIR voor desktop
    8. Publicatie-instellingen voor ActionScript
    9. Tips en trucs: ActionScript organiseren in een toepassing
    10. ActionScript gebruiken met Animate
    11. Tips en trucs: Richtlijnen voor toegankelijkheid
    12. Toegankelijkheid in de Animate-werkruimte
    13. Scripts schrijven en beheren
    14. Ondersteuning voor aangepaste platforms inschakelen
    15. Overzicht van ondersteuning voor aangepaste platforms
    16. Toegankelijke inhoud maken
    17. Werken met plug-in voor ondersteuning voor aangepaste platforms
    18. Foutopsporing in ActionScript 3.0
    19. Ondersteuning voor aangepaste platforms inschakelen
  8. Exporteren en publiceren
    1. Bestanden exporteren uit Animate CC
    2. OAM-publicatie
    3. SVG-bestanden exporteren
    4. Afbeeldingen en video's exporteren met Animate
    5. AS3-documenten publiceren
    6. Animaties exporteren voor mobiele apps en game-engines
    7. Geluiden exporteren
    8. QuickTime-videobestanden exporteren
    9. Afspelen van externe video met ActionScript beheren
    10. Tips en trucs: Tips voor het maken van inhoud voor mobiele apparaten
    11. Tips en trucs: Videoconventies
    12. Tips en trucs: Richtlijnen voor het ontwerpen van SWF-toepassingen
    13. Tips en trucs: Structuur geven aan FLA-bestanden
    14. Beste werkwijzen voor het optimaliseren van FLA-bestanden voor Animate
    15. Publicatie-instellingen voor ActionScript
    16. Publicatie-instellingen opgeven voor Animate
    17. Projectorbestanden exporteren
    18. Afbeeldingen en geanimeerde GIF-bestanden exporteren
    19. HTML-publicatiesjablonen
    20. Werken met Adobe Premiere Pro en After Effects
    21. Snel uw animaties delen en publiceren

Informatie over symbolen

Een symbool is een afbeelding, knop of filmclip die u één keer maakt in de Animate-ontwerpomgeving (voorheen Flash Professional CC) of met de klassen SimpleButton (AS 3.0) en MovieClip. U kunt het symbool vervolgens in uw document of in andere documenten hergebruiken.

Een symbool kan een illustratie bevatten die u vanuit een andere toepassing kunt importeren. Elk symbool dat u maakt, wordt automatisch onderdeel van de bibliotheek voor het huidige document.

Een instantie is een kopie van een symbool dat zich in het werkgebied bevindt of dat binnen een ander symbool is genest. Een instantie kan van het bovenliggende symbool verschillen in kleur, grootte en functie. Wanneer u het symbool bewerkt, worden alle bijbehorende instanties bijgewerkt, maar wanneer u effecten op een instantie van een symbool toepast, wordt alleen die betreffende instantie bijgewerkt.

Door symbolen in uw documenten te gebruiken, wordt de bestandsgrootte aanzienlijk verkleind. Het opslaan van meerdere instanties van een symbool neemt minder opslagruimte in beslag dat het opslaan van meerdere kopieën van de inhoud van het symbool. U kunt de bestandsgrootte van uw documenten bijvoorbeeld verkleinen door statische afbeeldingen, zoals achtergrondafbeeldingen, om te zetten in symbolen en deze vervolgens opnieuw te gebruiken. Het gebruik van symbolen kan ook het afspelen van SWF-bestanden versnellen, een symbool hoeft namelijk slechts één keer naar Flash® Player te worden gedownload.

U kunt symbolen tussen documenten als gezamenlijke bibliotheekelementen delen tijdens het ontwerpen of bij uitvoering. Voor gezamenlijke elementen bij uitvoering kunt u elementen in een brondocument koppelen aan elk gewenst aantal doeldocumenten, zonder dat u de elementen in het doeldocument importeert. Voor gezamenlijke elementen bij uitvoering kunt u een symbool bijwerken met of vervangen door elk gewenst ander symbool dat op uw lokale netwerk beschikbaar is.

Wanneer u bibliotheekelementen importeert die dezelfde naam hebben als elementen die al in de bibliotheek staan, kunt u naamgevingsconflicten voorkomen zonder per ongeluk bestaande elementen te overschrijven.

U vindt aanvullende, inleidende instructies over symbolen in deze bronnen:

Typen symbolen

Elk symbool heeft een unieke tijdlijn en een uniek werkgebied, compleet met lagen. U kunt frames, hoofdframes en lagen aan een symbool Tijdlijn toevoegen, net als bij de hoofdtijdlijn. Wanneer u een symbool maakt, kiest u het symbooltype.

  • Gebruik grafische symbolen voor statische afbeeldingen en om herbruikbare stukken animatie te maken die aan de hoofdtijdlijn zijn verbonden. Grafische symbolen werken in synchronisatie met de hoofdtijdlijn. Interactieve besturingselementen en geluiden werken niet in de animatiereeks van een grafisch symbool. Grafische symbolen voegen minder toe aan de FLA-bestandsgrootte dan knoppen of filmclips, omdat ze geen tijdlijn hebben.

  • Gebruik knopsymbolen om interactieve knoppen te maken die reageren op muisklikken, rollovers of andere handelingen. U definieert de afbeeldingen die aan diverse knoptoestanden zijn gekoppeld en wijst vervolgens handelingen toe aan een knopinstantie. Zie Gebeurtenissen afhandelen in de ActionScript 3.0-ontwikkelaarsgids voor meer informatie.

  • Gebruik filmclipsymbolen om herbruikbare stukken animatie te maken. Filmclips hebben een eigen tijdlijn met meerdere frames die onafhankelijk is van de hoofdtijdlijn. U kunt ze beschouwen als geneste tijdlijnen binnen een hoofdtijdlijn die interactieve besturingselementen, geluiden en zelfs andere filmclipinstanties kunnen bevatten. U kunt ook filmclipinstanties binnen de tijdlijn van een knopsymbool plaatsen om bewegende knoppen te maken. Bovendien zijn filmclips scriptbaar met ActionScript®.

  • Gebruik lettertypesymbolen om een lettertype te exporteren en te gebruiken in andere Animate-documenten.

    Animate biedt ingebouwde componenten, filmclips met gedefinieerde parameters, die u kunt gebruiken om gebruikersinterface-elementen aan uw documenten toe te voegen (zoals knoppen, selectievakjes of schuifbalken). Zie Over ActionScript 3.0-componenten in ActionScript 3.0-componenten gebruiken voor meer informatie.

    Opmerking: Als u een voorvertoning van een animatie in componentinstanties en schaling van 9-delig geschaalde filmclips wilt zien in de Animate-ontwerpomgeving, selecteert u Besturing > Live voorvertoning inschakelen.

Symbolen maken

U kunt een symbool maken via geselecteerde objecten in het werkgebied, een leeg symbool maken en de inhoud ervan maken of importeren in symboolbewerkmodus en u kunt lettertypesymbolen maken in Animate. Symbolen kunnen alle functionaliteit hebben die Animate kan maken, inclusief animatie.

Door symbolen te gebruiken die animatie bevatten, kunt u Animate-toepassingen maken met veel beweging en toch de bestandsgrootte minimaliseren. U kunt overwegen animatie te maken in een symbool met een herhalende of cyclische handeling, zoals de op- en neergaande beweging van de vleugels van een vogel.

Wanneer u symbolen aan uw document wilt toevoegen, moet u gezamenlijke bibliotheekelementen gebruiken tijdens het ontwerpen of bij uitvoering.

Geselecteerde elementen omzetten in een symbool

  1. Selecteer een element of diverse elementen in het werkgebied. Ga als volgt te werk:
    • Selecteer Wijzigen > Omzetten in symbool.

    • Sleep de selectie naar het deelvenster Bibliotheek.

    • Klik met de rechtermuisknop (Windows) of houd de Control-toets ingedrukt en klik (Macintosh) op Omzetten in symbool in het contextmenu.

  2. Typ in het dialoogvenster Omzetten in symbool de naam van het symbool en selecteer het gedrag.
  3. Klik in het registratieraster om het registratiepunt van het symbool te positioneren.
  4. Klik op OK.

    Animate voegt het symbool toe aan de bibliotheek. De selectie in het werkgebied wordt een instantie van het symbool. Wanneer u een symbool hebt gemaakt, kunt u het in de symboolbewerkmodus bewerken. Kies hiertoe Bewerken > Symbolen bewerken. U kunt een symbool ook binnen het werkgebied bewerken via Bewerken > Op plaats bewerken. U kunt ook het registratiepunt van een symbool wijzigen.

Leeg symbool maken

  1. Ga als volgt te werk:
    • Selecteer Invoegen > Nieuw symbool.

    • Klik op de knop Nieuw symbool linksonder in het deelvenster Bibliotheek.

    • Selecteer Nieuw symbool in het menu Bibliotheekopties in de rechterbovenhoek van het deelvenster Bibliotheek.

  2. Typ in het dialoogvenster Nieuw symbool maken de naam van het symbool en selecteer het gedrag.
  3. Klik op OK.

    Animate voegt het symbool toe aan de bibliotheek en activeert de symboolbewerkmodus. In de symboolbewerkmodus wordt de naam van het symbool boven de linkerbovenhoek van het werkgebied weergegeven en geeft een kruisdraad het registratiepunt van het symbool aan.

  4. Wanneer u symboolinhoud wilt maken, gebruikt u de tijdlijn, tekent u met het gereedschap Tekenen, importeert u media of maakt u instanties van andere symbolen.
  5. U kunt als volgt de documentbewerkmodus activeren:
    • Klik op de knop Vorige.

    • Selecteer Bewerken > Document bewerken.

    • Klik op de scènenaam in de bewerkbalk.

      Wanneer u een symbool maakt, wordt het registratiepunt in het midden van het venster geplaatst in symboolbewerkmodus. U kunt de symboolinhoud in het venster plaatsen ten opzichte van het registratiepunt. Wanneer u het registratiepunt wilt wijzigen, wanneer u een symbool bewerkt, verplaatst u het symbool ten opzichte van het registratiepunt.

  6. In de sectie ActionScript-koppeling kunt u kiezen om te exporteren voor ActionScript door het selectievakje Exporteren voor ActionScript in te schakelen. De Klasse en Basisklasse worden automatisch weergegeven (u kunt de namen van de klassen wijzigen). Animate zoekt naar klassendefinities in een extern AS-bestand of een gekoppeld SWC-bestand. Als de klassendefinities niet worden gevonden in deze locaties, genereert Animate automatisch klassenbestanden. Zie dit artikel voor meer informatie.

(Alleen Animate ) Meerdere symbolen wisselen

Met de optie Symbool wisselen kunt u symbolen omwisselen voor geselecteerde symbolen of bitmaps

  1. Selecteer meerdere symbolen in het werkgebied van uw Animate-document.

  2. Klik op Wisselen in het deelvenster Eigenschappen.
  3. In het dialoogvenster Symbool wisselen selecteert u het symbool dat u wilt gebruiken ter vervanging van alle geselecteerde symbolen/bitmaps.
  4. Klik op OK.

Animatie in het werkgebied omzetten in een filmclip symbool

Wanneer u een animatiereeks in het werkgebied opnieuw wilt gebruiken, of deze als een instantie wilt manipuleren, moet u de reeks selecteren en opslaan als een filmclipsymbool.

  1. Selecteer op de hoofdtijdlijn elk frame in elke laag van de animatie in het werkgebied dat u wilt gebruiken. Zie Frames in de tijdlijn invoegen voor informatie over het selecteren van frames.
  2. U kunt als volgt de frames kopiëren:
    • Klik met de rechtermuisknop (Windows) of houd de Control-toets ingedrukt en klik (Macintosh) op een van de geselecteerde frames en selecteer Frames kopiëren in het contextmenu. Selecteer Knippen wanneer u de reeks wilt verwijderen nadat u deze hebt omgezet in een filmclip.

    • Selecteer Bewerken > Tijdlijn > Frames kopiëren. Selecteer Frames knippen wanneer u de reeks wilt verwijderen nadat u deze hebt omgezet in een filmclip.

  3. Maak de selectie ongedaan en zorg dat niets in het werkgebied is geselecteerd. Selecteer Invoegen > Nieuw symbool.
  4. Geef het symbool een naam. Selecteer de optie Filmclip bij Type en klik op OK.
  5. Klik in de tijdlijn op frame 1 op laag 1 en selecteer Bewerken >Tijdlijn > Frames plakken.

    Met deze handeling worden de frames (en alle lagen en laagnamen) die u uit de hoofdtijdlijn hebt gekopieerd, in de tijdlijn van dit filmclipsymbool geplakt. Elke animatie, knop of interactiviteit uit de frames die u hebt gekopieerd, wordt nu een onafhankelijke animatie (een filmclipsymbool) dat u opnieuw kunt gebruiken.

  6. U kunt als volgt de documentbewerkmodus activeren:
    • Klik op de knop Vorige.

    • Selecteer Bewerken > Document bewerken.

    • Klik op de scènenaam in de bewerkbalk boven in het werkgebied.

Symbolen dupliceren

Door een symbool te dupliceren kunt u een bestaand symbool gebruiken als startpunt voor het maken van een symbool.

U kunt ook instanties gebruiken om versies van het symbool met een verschillend uiterlijk te maken.

Symbool dupliceren via het deelvenster Bibliotheek

  1. Selecteer een symbool in het deelvenster Bibliotheek en ga als volgt te werk:
    • Klik met de rechtermuisknop (Windows) of houd de Control-toets ingedrukt en klik (Macintosh) op Dupliceren in het contextmenu.

    • Selecteer Dupliceren in het menu Bibliotheekopties.

Symbool dupliceren door een instantie te selecteren

  1. Selecteer een instantie van het symbool in het werkgebied.
  2. Selecteer Wijzigen > Symbool > Symbool dupliceren.

    Het symbool wordt gedupliceerd en de instantie wordt vervangen door een instantie van het gedupliceerde symbool.

Symbolen bewerken

Wanneer u een symbool bewerkt, werkt Animate alle instanties van dat symbool in uw document bij. U kunt het symbool als volgt bewerken:

  • In context met de andere objecten in het werkgebied met de opdracht Op plaats bewerken. Andere objecten worden gedimd (inactief) zodat u deze kunt onderscheiden van het symbool dat u bewerkt. De naam van het symbool dat u bewerkt, wordt in de bewerkbalk boven in het werkgebied weergegeven, rechts van de huidige scènenaam.

  • Gebruik de opdracht Bewerken in nieuw venster in een afzonderlijk venster. Door een symbool in een afzonderlijk venster te bewerken, kunt u het symbool en de hoofdtijdlijn tegelijkertijd bekijken. De naam van het symbool dat u bewerkt, wordt in de bewerkbalk boven in het werkgebied weergegeven.

    U kunt het symbool bewerken door de werkgebiedweergave te veranderen in een weergave van alleen het symbool met de symboolbewerkmodus. De naam van het symbool dat u bewerkt, wordt in de bewerkbalk boven in het werkgebied weergegeven, rechts van de huidige scènenaam.

    Wanneer u een symbool bewerkt, werkt Animate alle instanties van het symbool in het gehele document bij om uw wijzigingen door te voeren. Tijdens het bewerken van een symbool kunt u een van de gereedschappen Tekenen gebruiken, media importeren of instanties van andere symbolen maken.

  • Wijzig het registratiepunt van een symbool (het punt met de coördinaten 0, 0) via een symboolbewerkmethode.

 

Symbool op plaats bewerken

  1. Ga als volgt te werk:
    • Dubbelklik op een instantie van het symbool in het werkgebied.

    • Selecteer een instantie van het symbool in het werkgebied, klik met de rechtermuisknop (Windows) of houd de Control-toets ingedrukt en klik (Macintosh) op Op plaats bewerken.

    • Selecteer een instantie van het symbool in het werkgebied en selecteer vervolgens Bewerken > Op plaats bewerken.

  2. Bewerk het symbool.
  3. U kunt als volgt de modus Op plaats bewerken afsluiten en teruggaan naar de documentbewerkmodus:
    • Klik op de knop Vorige.

    • Selecteer de huidige scènenaam in het menu Scène in de bewerkbalk.

    • Selecteer Bewerken > Document bewerken.

    • Dubbelklik buiten de symboolinhoud.

U kunt als volgt een symbool in een nieuw venster bewerken

  1. Selecteer een instantie van het symbool in het werkgebied, klik met de rechtermuisknop (Windows) of houd de Control-toets ingedrukt en klik (Macintosh) op Bewerken in nieuw venster.
  2. Bewerk het symbool.
  3. Klik op het afsluitenvakje rechtsboven (Windows) of linksboven (Macintosh) om het nieuwe venster te sluiten en klik in het hoofdvenster van het document om verder te gaan met het bewerken van het hoofddocument.

Symbool bewerken in symboolbewerkmodus

  1. U kunt als volgt het symbool selecteren:
    • Dubbelklik in het deelvenster Bibliotheek op het pictogram van het symbool.

    • Selecteer een instantie van het symbool in het werkgebied, klik met de rechtermuisknop (Windows) of houd de Control-toets ingedrukt en klik (Macintosh) op Bewerken in het contextmenu.

    • Selecteer een instantie van het symbool in het werkgebied en selecteer vervolgens Bewerken > Symbolen bewerken.

    • Selecteer het symbool in het deelvenster Bibliotheek en selecteer vervolgens Bewerken in het menu Bibliotheekopties of klik met de rechtermuisknop (Windows) of houd de Control-toets ingedrukt en klik (Macintosh) op het symbool in het deelvenster Bibliotheek en selecteer Bewerken.

  2. Bewerk het symbool.
  3. U kunt als volgt de symboolbewerkmodus afsluiten en teruggaan naar de documentbewerkmodus:
    • Klik op de knop Terug links van de bewerkbalk boven in het werkgebied.

    • Selecteer Bewerken > Document bewerken.

    • Klik op de scènenaam in de bewerkbalk boven in het werkgebied.

    • Dubbelklik buiten de symboolinhoud.

Adobe-logo

Aanmelden bij je account