Dynamic Link

  1. Adobe Premiere Pro User Guide
  2. Beta releases
    1. Beta Program Overview
    2. Premiere Pro Beta Home
    3. Features in Beta
      1. New import & export in Premiere Pro (Beta)
      2. FAQ | New import and export in Premiere Pro (Beta)
  3. Getting started
    1. Get started with Adobe Premiere Pro
    2. What's new in Premiere Pro
    3. Release Notes | Premiere Pro
    4. Keyboard shortcuts in Premiere Pro
    5. Accessibility in Premiere Pro
  4. Hardware and operating system requirements
    1. Hardware recommendations
    2. System requirements
    3. GPU and GPU Driver requirements
    4. GPU Accelerated Rendering & Hardware Encoding/Decoding
  5. Creating projects
    1. Creating projects
    2. Open projects
    3. Move and delete projects
    4. Work with multiple open projects
    5. Work with Project Shortcuts
    6. Backward compatibility of Premiere Pro projects
    7. Open and edit Premiere Rush projects in Premiere Pro
    8. Best Practices: Create your own project templates
  6. Workspaces and workflows
    1. Workspaces
    2. Working with Panels
    3. Windows touch and gesture controls
    4. Use Premiere Pro in a dual-monitor setup
  7. Capturing and importing
    1. Capturing
      1. Capturing and digitizing footage
      2. Capturing HD, DV, or HDV video
      3. Batch capturing and recapturing
      4. Setting up your system for HD, DV, or HDV capture
    2. Importing
      1. Transferring and importing files
      2. Importing still images
      3. Importing digital audio
    3. Importing from Avid or Final Cut
      1. Importing AAF project files from Avid Media Composer
      2. Importing XML project files from Final Cut Pro 7 and Final Cut Pro X
    4. Supported file formats
    5. Digitizing analog video
    6. Working with timecode
  8. Editing
    1. Sequences
      1. Create and change sequences
      2. Add clips to sequences
      3. Rearrange clips in a sequence
      4. Find, select, and group clips in a sequence
      5. Edit from sequences loaded into the Source Monitor
      6. Simplify sequences
      7. Rendering and previewing sequences
      8. Working with markers
      9. Scene edit detection
    2. Video
      1. Create and play clips
      2. Trimming clips
      3. Synchronizing audio and video with Merge Clips
      4. Render and replace media
      5. Undo, history, and events
      6. Freeze and hold frames
      7. Working with aspect ratios
    3. Audio
      1. Overview of audio in Premiere Pro
      2. Audio Track Mixer
      3. Adjusting volume levels
      4. Editing, repairing and improving audio using Essential Sound panel
      5. Monitor clip volume and pan using Audio Clip Mixer
      6. Audio balancing and panning
      7. Advanced Audio - Submixes, downmixing, and routing
      8. Audio effects and transitions
      9. Working with audio transitions
      10. Apply effects to audio
      11. Measure audio using the Loudness Radar effect
      12. Recording audio mixes
      13. Editing audio in the timeline
      14. Audio channel mapping in Premiere Pro
      15. Use Adobe Stock audio in Premiere Pro
    4. Advanced editing
      1. Multi-camera editing workflow
      2. Editing workflows for feature films
      3. Set up and use Head Mounted Display for immersive video in Premiere Pro
      4. Editing VR
    5. Best Practices
      1. Best Practices: Mix audio faster
      2. Best Practices: Editing efficiently
  9. Video Effects and Transitions
    1. Overview of video effects and transitions
    2. Effects
      1. Types of effects in Premiere Pro
      2. Apply and remove effects
      3. Effect presets
      4. Automatically reframe video for different social media channels
      5. Color correction effects
      6. Change duration and speed of clips
      7. Adjustment Layers
      8. Stabilize footage
    3. Transitions
      1. Applying transitions in Premiere Pro
      2. Modifying and customizing transitions
      3. Morph Cut
  10. Graphics, Titles, and Animation
    1. Graphics and titles
      1. Create titles and motion graphics
      2. Applying text gradients in Premiere Pro
      3. Using Motion Graphics templates for titles
      4. Replace images or videos in Motion Graphics templates
      5. Use data-driven Motion Graphics templates
      6. Best Practices: Faster graphics workflows
      7. Add Responsive Design features to your graphics
      8. Working with captions
      9. Speech to Text
      10. Speech to Text in Premiere Pro | FAQ
      11. Upgrade Legacy titles to Source Graphics
    2. Animation and Keyframing
      1. Adding, navigating, and setting keyframes
      2. Animating effects
      3. Use Motion effect to edit and animate clips
      4. Optimize keyframe automation
      5. Moving and copying keyframes
      6. Viewing and adjusting effects and keyframes
  11. Compositing
    1. Compositing, alpha channels, and adjusting clip opacity
    2. Masking and tracking
    3. Blending modes
  12. Color Correction and Grading
    1. Overview: Color workflows in Premiere Pro
    2. Get creative with color using Lumetri looks
    3. Adjust color using RBG and Hue Saturation Curves
    4. Correct and match colors between shots
    5. Using HSL Secondary controls in the Lumetri Color panel
    6. Create vignettes
    7. Looks and LUTs
    8. Lumetri scopes
    9. Display Color Management
    10. HDR for broadcasters
    11. Enable DirectX HDR support
  13. Exporting media
    1. Workflow and overview for exporting
    2. Quick export
    3. Exporting for the Web and mobile devices
    4. Export a still image
    5. Exporting projects for other applications
    6. Exporting OMF files for Pro Tools
    7. Export to Panasonic P2 format
    8. Exporting to DVD or Blu-ray Disc
    9. Best Practices: Export faster
  14. Working with other Adobe applications
    1. After Effects and Photoshop
    2. Dynamic Link
    3. Audition
    4. Prelude
  15. Organizing and Managing Assets
    1. Working in the Project panel
    2. Organize assets in the Project panel
    3. Playing assets
    4. Search assets
    5. Creative Cloud Libraries
    6. Sync Settings in Premiere Pro
    7. Using Productions
    8. How clips work across projects in a Production
    9. Consolidate, transcode, and archive projects
    10. Managing metadata
    11. Best Practices
      1. Best Practices: Working with Productions
      2. Best Practices: Learning from broadcast production
      3. Best Practices: Working with native formats
  16. Improving Performance and Troubleshooting
    1. Set preferences
    2. Reset preferences
    3. Working with Proxies
      1. Proxy overview
      2. Ingest and Proxy Workflow
    4. Check if your system is compatible with Premiere Pro
    5. Premiere Pro for Apple silicon
    6. Eliminate flicker
    7. Interlacing and field order
    8. Smart rendering
    9. Control surface support
    10. Best Practices: Working with native formats
    11. Knowledge Base
      1. Green and pink video in Premiere Pro or Premiere Rush
      2. How do I manage the Media Cache in Premiere Pro?
      3. Fix errors when rendering or exporting
      4. Troubleshoot issues related to playback and performance in Premiere Pro
  17. Monitoring Assets and Offline Media
    1. Monitoring assets
      1. Using the Source Monitor and Program Monitor
      2. Using the Reference Monitor
    2. Offline media
      1. Working with offline clips
      2. Creating clips for offline editing
      3. Relinking offline media

 

Learn how to share media assets between Premiere Pro and After Effects quickly and efficiently by using the Dynamic Link workflow.

In the past, sharing media assets among post-production applications required you to render and export your work from one application before importing it into another. This workflow was inefficient and time-consuming. If you wanted to change the original asset, you rendered and exported the asset again. Multiple rendered and exported versions of an asset consume disk space, and they can lead to file-management challenges.

Dynamic Link offers an alternative to this workflow. You can create dynamic links between After Effects and Premiere Pro. Creating a dynamic link is as simple as importing any other type of asset. Dynamically linked assets appear with unique icons and label colors to help you identify them. Dynamic links are saved in projects generated by these applications.

Dynamic Link performance

A linked clip can refer to a complex source composition. Actions you perform on the complex source composition require additional processing time. After Effects takes time to apply the actions and make the final data available to Adobe Premiere Pro. In some cases, the additional processing time delays preview or playback.

To reduce playback delays, do one of the following:

  • take the linked composition offline

  • disable a linked clip to temporarily stop referencing a composition

  • render the composition and replace the dynamically linked composition with the rendered file.When you work with some Premiere Pro clips (for example, clips with resource-intensive VFX footage), the clips may not play back smoothly. If you see that a clip has not properly played back, use the Clip > Render and Replace command to improve its performance. To know more about the Render and Replace feature, see Render and replace compositions.

If you commonly work with complex source compositions, try adding RAM or a faster processor.

הערה:

A linked After Effects composition will not support Render Multiple Frames Simultaneously multiprocessing. See Improve performance by optimizing memory, cache, and multiprocessing settings.

Create and link to After Effects compositions with Dynamic Link

You can create After Effects compositions, and dynamically link to them, from Adobe Premiere Pro. You can also dynamically link to existing After Effects compositions from Adobe Premiere Pro.

Create a composition from clips in Adobe Premiere Pro

You can replace selected clips in Adobe Premiere Pro with a dynamically linked After Effects composition based on those clips. The new composition inherits the sequence settings from Adobe Premiere Pro.

  1. In a sequence, select the clips you want in the composition.
  2. Right-click any of the selected clips.
  3. Select Replace With After Effects Composition.

Create a dynamically linked composition from Adobe Premiere Pro

Creating a new dynamically linked composition from Adobe Premiere Pro launches After Effects. After Effects then creates a project and composition with the dimensions, pixel aspect ratio, frame rate, and audio sample rate of the originating project. (If After Effects is already running, it creates a composition in the current project.) The new composition name is based on theAdobe Premiere Pro or Encore project name, followed by Linked Comp [x].

  1. In Adobe Premiere Pro, choose File > Adobe Dynamic Link > New After Effects Composition.

  2. If the After Effects > Save As dialog box appears, enter a name and location for the After Effects project, and click Save.

    הערה:

    When you create a dynamically linked After Effects composition, the composition duration is set to 30 seconds. To change the duration, select the composition in After Effects, choose Composition > Composition Settings. Click the Basic tab, and specify a new value for Duration.

Issues linking to an After Effects composition? Check out this video by our expert.

For best results, match composition settings (such as dimensions, pixel aspect ratio, and frame rate) to the settings in the Adobe Premiere Pro project.

  1. Do one of the following:
    • In Adobe Premiere Pro, choose File > Adobe Dynamic Link > Import After Effects Composition. Choose an After Effects project file (.aep), and then choose one or more compositions.

    • In Adobe Premiere Pro, choose an After Effects project file and click Open. Then choose a composition in the displayed dialog box and click OK.

    • Drag one or more compositions from the After Effects Project panel to the Adobe Premiere Pro Project panel or the Encore Project panel.

    • Drag an After Effects project file into the Adobe Premiere Pro Project panel. If the After Effects project file contains multiple compositions, the Import Composition dialog box opens.

הערה:

You can link to a single After Effects composition multiple times in a single Adobe Premiere Pro project. 

Delete a dynamically linked composition or clip

You can delete a linked composition from an Adobe Premiere Pro project at any time, even if the composition is used in a project. You can also delete linked clips from the timeline of an Adobe Premiere Pro sequence at any time.

  1. In Adobe Premiere Pro, select the linked composition or clip and press the Delete key.

Modify a dynamically linked composition in After Effects

Use the Edit Original command in Adobe Premiere Pro to modify a linked After Effects composition. Once the composition is open in After Effects, you can change the composition without having to use the Edit Original command again.

  1. Select the After Effects composition in the Adobe Premiere Pro  Project panel, or choose a linked clip in the Timeline, and choose Edit > Edit Original.

  2. Change the composition in After Effects. Then, switch back to Adobe Premiere Pro to view your changes.

The changes made in After Effects appear in Adobe Premiere Pro. Adobe Premiere Pro stops using any preview files rendered for the clip before the changes.

הערה:

You can change the name of the composition in After Effects after creating a dynamic link to it from Adobe Premiere Pro. Adobe Premiere Pro does not update the linked composition name in the Project panel. Adobe Premiere Pro does retain the dynamic link, however.

Create an After Effects composition from clips in Premiere Pro

You can replace a selection of clips in a sequence in Premiere Pro with an After Effects composition based on those clips. The composition inherits the sequence settings from Premiere Pro and maintains a dynamic link to After Effects. You can edit the composition in Premiere Pro or in After Effects.

  1. In a sequence, select the clips you want in the composition.
  2. Right-click any of the selected clips.
  3. Select Replace With After Effects Composition.

Offline compositions and Dynamic Link

Adobe Premiere Pro display dynamically linked compositions as offline in any of the following circumstances:

  • You’ve renamed, moved, or deleted the After Effects project that contains the composition.

  • You’ve purposely taken the composition offline.

  • You’re working with a project trimmed by the Adobe Premiere Pro Project Manager. Project Manager does not move the After Effects source compositions to the trimmed project folder. Move the composition manually.

Offline compositions appear with an Offline icon in the Adobe Premiere Pro Project panel. If you’re working with an offline composition, you can relink it to the original After Effects composition. You can also choose to relink a linked composition to a different source composition.

Take a dynamically linked composition offline

If you are experiencing jerky playback, you can take a dynamically linked composition offline. When you take a composition offline, you sever the dynamic link with After Effects. The linked composition is replaced in the Project panel with an offline composition.

הערה:

You can temporarily suppress a linked clip in Adobe Premiere Pro by selecting the clip and choosing Clip > Enable. To relink the clip, choose Clip > Enable again (a check mark next to the command indicates that the clip is enabled).

  1. In Premiere Pro, select the composition in the Project panel.
  2. Choose Project > Make Offline.

In Adobe Premiere Pro, right-click the composition and choose Link Media. In the displayed dialog box, select an After Effects project. Adobe Premiere Pro automatically relinks the composition.

 

לוגו של Adobe

כניסה לחשבון