Naudotojo vadovas Atšaukti

After Effects and Photoshop

  1. Adobe Premiere Pro User Guide
  2. Beta releases
    1. Beta Program Overview
    2. Premiere Pro Beta Home
  3. Getting started
    1. Get started with Adobe Premiere Pro
    2. What's new in Premiere Pro
    3. Release Notes | Premiere Pro
    4. Keyboard shortcuts in Premiere Pro
    5. Accessibility in Premiere Pro
    6. Long Form and Episodic Workflow Guide
  4. Hardware and operating system requirements
    1. Hardware recommendations
    2. System requirements
    3. GPU and GPU Driver requirements
    4. GPU Accelerated Rendering & Hardware Encoding/Decoding
  5. Creating projects
    1. Start a new project
    2. Open projects
    3. Move and delete projects
    4. Work with multiple open projects
    5. Work with Project Shortcuts
    6. Backward compatibility of Premiere Pro projects
    7. Open and edit Premiere Rush projects in Premiere Pro
    8. Best Practices: Create your own project templates
  6. Workspaces and workflows
    1. Workspaces
    2. FAQ | Import and export in Premiere Pro
    3. Working with Panels
    4. Windows touch and gesture controls
    5. Use Premiere Pro in a dual-monitor setup
  7. Capturing and importing
    1. Capturing
      1. Capturing and digitizing footage
      2. Capturing HD, DV, or HDV video
      3. Batch capturing and recapturing
      4. Setting up your system for HD, DV, or HDV capture
    2. Importing
      1. Transfer files
      2. Importing still images
      3. Importing digital audio
    3. Importing from Avid or Final Cut
      1. Importing AAF project files from Avid Media Composer
      2. Importing XML project files from Final Cut Pro 7 and Final Cut Pro X
    4. Supported file formats
    5. Digitizing analog video
    6. Working with timecode
  8. Editing
    1. Sequences
      1. Create and change sequences
      2. Add clips to sequences
      3. Rearrange clips in a sequence
      4. Find, select, and group clips in a sequence
      5. Edit from sequences loaded into the Source Monitor
      6. Simplify sequences
      7. Rendering and previewing sequences
      8. Working with markers
      9. Source patching and track targeting
      10. Scene edit detection
    2. Video
      1. Create and play clips
      2. Trimming clips
      3. Synchronizing audio and video with Merge Clips
      4. Render and replace media
      5. Undo, history, and events
      6. Freeze and hold frames
      7. Working with aspect ratios
    3. Audio
      1. Overview of audio in Premiere Pro
      2. Audio Track Mixer
      3. Adjusting volume levels
      4. Edit, repair, and improve audio using Essential Sound panel
      5. Automatically duck audio
      6. Remix audio
      7. Monitor clip volume and pan using Audio Clip Mixer
      8. Audio balancing and panning
      9. Advanced Audio - Submixes, downmixing, and routing
      10. Audio effects and transitions
      11. Working with audio transitions
      12. Apply effects to audio
      13. Measure audio using the Loudness Radar effect
      14. Recording audio mixes
      15. Editing audio in the timeline
      16. Audio channel mapping in Premiere Pro
      17. Use Adobe Stock audio in Premiere Pro
    4. Advanced editing
      1. Multi-camera editing workflow
      2. Set up and use Head Mounted Display for immersive video in Premiere Pro
      3. Editing VR
    5. Best Practices
      1. Best Practices: Mix audio faster
      2. Best Practices: Editing efficiently
      3. Editing workflows for feature films
  9. Video Effects and Transitions
    1. Overview of video effects and transitions
    2. Effects
      1. Types of effects in Premiere Pro
      2. Apply and remove effects
      3. Effect presets
      4. Automatically reframe video for different social media channels
      5. Color correction effects
      6. Change duration and speed of clips
      7. Adjustment Layers
      8. Stabilize footage
    3. Transitions
      1. Applying transitions in Premiere Pro
      2. Modifying and customizing transitions
      3. Morph Cut
  10. Graphics, Titles, and Animation
    1. Graphics and titles
      1. Overview of the Essential Graphics panel
      2. Create a title
      3. Create a shape
      4. Align and distribute text and shapes
      5. Check spelling and Find and Replace
      6. Apply gradients to text and shapes
      7. Add Responsive Design features to your graphics
      8. Use Motion Graphics templates for titles
      9. Replace images or videos in Motion Graphics templates
      10. Use data-driven Motion Graphics templates
      11. Best Practices: Faster graphics workflows
      12. Working with captions
      13. Speech to Text
      14. Speech to Text in Premiere Pro | FAQ
      15. Retiring the Legacy Titler in Premiere Pro | FAQ
      16. Upgrade Legacy titles to Source Graphics
    2. Animation and Keyframing
      1. Adding, navigating, and setting keyframes
      2. Animating effects
      3. Use Motion effect to edit and animate clips
      4. Optimize keyframe automation
      5. Moving and copying keyframes
      6. Viewing and adjusting effects and keyframes
  11. Compositing
    1. Compositing, alpha channels, and adjusting clip opacity
    2. Masking and tracking
    3. Blending modes
  12. Color Correction and Grading
    1. Overview: Color workflows in Premiere Pro
    2. Auto Color
    3. Get creative with color using Lumetri looks
    4. Adjust color using RGB and Hue Saturation Curves
    5. Correct and match colors between shots
    6. Using HSL Secondary controls in the Lumetri Color panel
    7. Create vignettes
    8. Looks and LUTs
    9. Lumetri scopes
    10. Display Color Management
    11. HDR for broadcasters
    12. Enable DirectX HDR support
  13. Exporting media
    1. Export video
    2. Export Preset Manager
    3. Workflow and overview for exporting
    4. Quick export
    5. Exporting for the Web and mobile devices
    6. Export a still image
    7. Exporting projects for other applications
    8. Exporting OMF files for Pro Tools
    9. Export to Panasonic P2 format
    10. Export settings
      1. Export settings reference
      2. Basic Video Settings
      3. Encoding Settings
    11. Best Practices: Export faster
  14. Collaboration: Frame.io, Productions, and Team Projects
    1. Collaboration in Premiere Pro
    2. Frame.io
      1. Install and activate Frame.io
      2. Use Frame.io with Premiere Pro and After Effects
      3. Frequently asked questions
    3. Productions
      1. Using Productions
      2. How clips work across projects in a Production
      3. Best Practices: Working with Productions
    4. Team Projects
      1. What's New in Team Projects
      2. Get started with Team Projects
      3. Create a Team Project
      4. Add and manage media in Team Projects
      5. Collaborate with Team Projects
      6. Share and manage changes with Team Project collaborators
      7. Archive, restore, or delete Team Projects
  15. Working with other Adobe applications
    1. After Effects and Photoshop
    2. Dynamic Link
    3. Audition
    4. Prelude
  16. Organizing and Managing Assets
    1. Working in the Project panel
    2. Organize assets in the Project panel
    3. Playing assets
    4. Search assets
    5. Creative Cloud Libraries
    6. Sync Settings in Premiere Pro
    7. Consolidate, transcode, and archive projects
    8. Managing metadata
    9. Best Practices
      1. Best Practices: Learning from broadcast production
      2. Best Practices: Working with native formats
  17. Improving Performance and Troubleshooting
    1. Set preferences
    2. Reset preferences
    3. Working with Proxies
      1. Proxy overview
      2. Ingest and Proxy Workflow
    4. Check if your system is compatible with Premiere Pro
    5. Premiere Pro for Apple silicon
    6. Eliminate flicker
    7. Interlacing and field order
    8. Smart rendering
    9. Control surface support
    10. Best Practices: Working with native formats
    11. Knowledge Base
      1. Known issues
      2. Fixed issues
      3. Fix Premiere Pro crash issues
      4. Green and pink video in Premiere Pro or Premiere Rush
      5. How do I manage the Media Cache in Premiere Pro?
      6. Fix errors when rendering or exporting
      7. Troubleshoot issues related to playback and performance in Premiere Pro
  18. Monitoring Assets and Offline Media
    1. Monitoring assets
      1. Using the Source Monitor and Program Monitor
      2. Using the Reference Monitor
    2. Offline media
      1. Working with offline clips
      2. Creating clips for offline editing
      3. Relinking offline medInstia

Get the most out of your post-production editing in Premiere Pro by using various other Adobe applications, like After Effects, and Photoshop.

You can use various other Adobe applications to enhance or modify the assets used in a Premiere Pro project. Also, you can use Premiere Pro to edit projects begun in other applications.

Edit a clip in its original application

In Premiere Pro, the Edit Original command opens clips in the applications associated with their file types. You can edit clips in the associated applications. Premiere Pro automatically incorporates the changes into the current project without replacing files. Similarly, Premiere Pro sequences placed in other applications, such as Adobe After Effects can be opened with the host product’s Edit Original command.

  1. Select a clip in either the Project panel or Timeline panel.
  2. Choose Edit > Edit Original.
    Pastaba:

    You can export a movie from Premiere Pro with the data necessary for the Edit Original command. In the Export Movie Settings dialog box, choose Project from the Embedding options menu.

Copy between After Effects and Premiere Pro

  • From the After Effects Timeline panel, you can copy layers based on audio or video footage items (including solids) and paste them into the Adobe Premiere Pro Timeline panel.

  • From the Adobe Premiere Pro Timeline panel, you can copy assets (any items in a track) and paste them into the After Effects Timeline panel.

  • From either After Effects or Adobe Premiere Pro, you can copy and paste footage items to the other’s Project panel.

    note: You can’t, however, paste footage items from the After Effects Project panel into the Adobe Premiere Pro Timeline panel.

If you want to work with all clips or a single sequence from an Adobe Premiere Pro project, use the Import command instead to import the project into After Effects.

Pastaba:

Use Adobe Dynamic Link to create dynamic links, without rendering, between new or existing compositions in After Effects and Adobe Premiere Pro. For more information, see Adobe Dynamic Link.

Copy from After Effects to Adobe Premiere Pro

You can copy a layer based on a footage item from an After Effects composition and paste it into an Adobe Premiere Pro sequence. Adobe Premiere Pro converts these layers to clips in the sequence and copies the source footage item to its Project panel. If the layer contains an effect that is also used by Adobe Premiere Pro, Adobe Premiere Pro converts the effect and all of its settings and keyframes.

You can also copy nested compositions, Photoshop layers, solid-color layers, and audio layers. Adobe Premiere Pro converts nested compositions to nested sequences, and solid-color layers to color mattes. You cannot copy shape, text, camera, light, or adjustment layers to Adobe Premiere Pro.

  1. Start Adobe Premiere Pro (you must start Adobe Premiere Pro before you copy the layer in After Effects).

  2. Select a layer (or layers) from the After Effects Timeline panel.
    Pastaba:

    If you select multiple layers and the layers don’t overlap in After Effects, they’re placed on the same track in Adobe Premiere Pro. On the other hand, if the layers overlap in After Effects, the order in which you select them determines the order of their track placement in Adobe Premiere Pro. Each layer is placed on a separate track, and the last selected layer appears on Track 1. For example, if you select layers from top to bottom, the layers appear in the reverse order in Adobe Premiere Pro, with the bottom-most layer on Track 1.

  3. Choose Edit > Copy.
  4. In Adobe Premiere Pro, open a sequence in the Timeline panel.
  5. Move the current-time indicator to the desired location, and choose either Edit > Paste or Edit > Paste Insert.

Results of pasting into Premiere Pro

When you paste a layer into an Adobe Premiere Pro sequence, keyframes, effects, and other properties in the copied layer are converted as follows:

After Effects item

Converted to in Adobe Premiere Pro

Notes

Audio volume property

Channel Volume filter

Blending modes

Blending modes supported by Adobe Premiere Pro are converted

Effect properties and keyframes

Effect properties and keyframes, if the effect also exists in Adobe Premiere Pro

Adobe Premiere Pro lists unsupported effects as offline in the Effect Controls panel. Some After Effects effects have the same names as those in Adobe Premiere Pro, but since they’re actually different effects, they aren’t converted.

Expressions

Not converted

Layer markers

Clip markers

Masks and mattes

Not converted

Stereo Mixer effect

Channel Volume filter

Time Remap property

Time Remapping effect

Time Stretch property

Speed property

Speed and time stretch have an inverse relationship. For example, 200% stretch in After Effects converts to 50% speed in Adobe Premiere Pro.

Transform property values and keyframes

Motion or Opacity values and keyframes

The keyframe type—Bezier, Auto Bezier, Continuous Bezier, or Hold—is retained.

Source settings for R3D source files

Source settings for R3D source files

Copy from Adobe Premiere Pro to After Effects

You can copy a video or audio asset from an Adobe Premiere Pro sequence and paste it into an After Effects composition. After Effects converts assets to layers and copies the source footage items into its Project panel. If the asset contains an effect that is also used by After Effects, After Effects converts the effect and all of its settings and keyframes.

You can copy color mattes, stills, nested sequences, and offline files, too. After Effects converts color mattes into solid-color layers and converts nested sequences into nested compositions. When you copy a Photoshop still image into After Effects, After Effects retains the Photoshop layer information. You cannot paste Adobe Premiere Pro titles into After Effects, but you can paste text with attributes from the Adobe Premiere Titler into After Effects.

  1. Select an asset from the Adobe Premiere Pro Timeline panel.
  2. Choose Edit > Copy.

  3. In After Effects, open a composition in the Timeline panel.
  4. With the Timeline panel active, choose Edit > Paste. The asset appears as the topmost layer in the Timeline panel.

    Pastaba:

    To paste the asset at the current-time indicator, place the current-time indicator and press Ctrl+Alt+V (Windows) or Command+Option+V (Mac OS).

Results of pasting into After Effects

When you paste an asset into an After Effects composition, keyframes, effects, and other properties in a copied asset are converted as follows:

Adobe Premiere Pro asset

Converted to in After Effects

Notes

Audio track

Audio layers

Audio tracks that are either 5.1 surround or greater than 16‑bit aren’t supported. Mono and stereo audio tracks are imported as one or two layers.

Bars and tone

Not converted

Blending modes

Converted

Clip marker

Layer marker

Color mattes

Solid-color layers

Crop filter

Mask layer

Frame Hold

Time Remap property

Motion or Opacity values and keyframes

Transform property values and keyframes

Keyframe type—Bezier, Auto Bezier, Continuous Bezier, or Hold—is retained.

Sequence marker

Markers on a new solid-color layer

To copy sequence markers, you must either copy the sequence itself or import the entire Adobe Premiere Pro project as a composition.

Speed property

Time Stretch property

Speed and time stretch have an inverse relationship. For example, 50% speed in Adobe Premiere Pro is converted to 200% stretch in After Effects.

Time Remapping effect

Time Remap property

Titles

Not converted

Universal counting leaders

Not converted

Video and audio transitions

Opacity keyframes (Cross dissolve only) or solid-color layers

Video effect properties and keyframes

Effect properties and keyframes, if the effect also exists in After Effects

After Effects doesn’t display unsupported effects in the Effect Controls panel.

Volume and Channel Volume audio filters

Stereo mixer effect

Other audio filters are not converted.

Source settings for R3D source files

Source settings for R3D source files

Pastaba:

When you import a Premiere Pro project into After Effects, features are converted in the same manner as they are converted when copying from Premiere Pro to After Effects.

Work with Photoshop and Premiere Pro

If you use Photoshop to create still images, you can use Premiere Pro to make them move and change. You can animate an entire image or any of its layers.

You can edit individual frames of video and image sequence files in Photoshop. In addition to using any Photoshop tool to edit and paint on video, you can also apply filters, masks, transformations, layers styles, and blending modes. You can paint using the Clone Stamp, Pattern Stamp, Healing Brush, or Spot Healing Brush. You can also edit video frames using the Patch tool.

In Photoshop, with the Clone Stamp, you can sample a frame from a video layer and paint with the sampled source onto another video frame. As you move to different target frames, the source frame changes relative to the frame from which you initially sampled.

After making edits, you can save the video as a PSD file, or you can render it as a QuickTime movie or image sequence. You can import any of these back into Premiere Pro for further editing.

If you use Premiere Pro to create movies, you can use Photoshop to refine the individual frames of those movies. In Photoshop, you can do any of the following:

  • Remove unwanted visual elements.

  • Draw on individual frames.

  • Use the superior selection and masking tools to divide a frame into elements for animation or compositing.

Comparative advantages for specific tasks

The strengths of Premiere Pro lie in its numerous video editing features. You can use it to combine Photoshop files with video clips, audio clips, and other assets. You can use the Photoshop files, for example, as titles, graphics, and masks.

In contrast, Photoshop has excellent tools for painting, drawing, and selecting portions of an image. The Photoshop Quick Selection tool and Magnetic Lasso tool make it easy to create a mask from a complex shape. Rather than hand-drawing a mask in Premiere Pro, consider doing this work in Photoshop. Similarly, if you are applying several paint strokes by hand to get rid of dust, consider using the Photoshop paint tools.

The animation and video features in Photoshop Extended include simple keyframe-based animation. Premiere Pro, however, provides quite a bit more keyframe control over various properties.

Premiere Pro can import and export still images in many formats. For greatest versatility, however, use the native Photoshop PSD format when transferring individual frames or still image sequences from Photoshop to Premiere Pro.

When you import a PSD file into Premiere Pro, you can choose whether to import it as a flattened image, or with its layers separate and intact.

It is often a good idea to prepare a still image in Photoshop before importing it into Premiere Pro. Examples of such preparation include correcting color, scaling, and cropping. It is often better to change a source image in Photoshop than to have Premiere Pro perform the same operation many times per second as it renders each frame for previews or final output.

In Photoshop, you can create a PSD document that is set up correctly for a specific video output type. From the New File dialog box, select a Film & Video preset. In Premiere Pro, you can create a PSD document that matches your composition and sequence settings. Choose File > New > Photoshop File.

You can no longer exchange PSD video files with Photoshop, however, you can render a movie directly from Photoshop and then import it back into Premiere Pro. For example, you can create a QuickTime movie from Photoshop that can then be imported into Premiere Pro.

Premiere Pro works internally with colors in an RGB (red, green, blue) color space. If you want to edit video clips you create in Photoshop in Premiere Pro, create the clips in RGB.

If you want to broadcast the final movie it is best to ensure, in Photoshop, that the colors in your image are broadcast-safe. Assign the appropriate destination color space—for example, SDTV (Rec. 601)—to the document in Photoshop.

Create and edit Photoshop files

You can create a still Photoshop file that automatically inherits the pixel and frame aspect ratio settings of your Premiere Pro project. You can also edit any still image file in a Premiere Pro project in Photoshop.

Create a Photoshop file in a project

  1. Choose File > New > Photoshop File.

    Photoshop opens with a new blank still image. The pixel dimensions match the project’s video frame size, and image guides show the title-safe and action-safe areas for the project.

Edit a still image file in Photoshop

From within a project, you can open an image file in most formats that Adobe Photoshop supports. Premiere Pro does not import files in CMYK or LAB color formats.

  1. Select a still-image clip in either the Project panel or Timeline panel.

  2. Choose Edit > Edit In Adobe Photoshop.

    The file opens in Photoshop. When you save the file, changes are available in the Premiere Pro project.

„Adobe“ logotipas

Prisijunkite prie savo paskyros