Optymalizacja wydajności

Chcesz poprawić wydajność programu Adobe Lightroom Classic? Wypróbuj niektóre z tych sugestii. 

Aby uzyskać najlepsze rezultaty, należy przyjąć podejście holistyczne. Przeczytaj wszystkie sugestie tutaj. Należy rozważyć, które z nich należy wdrożyć w kontekście konfiguracji komputera. Należy również wziąć pod uwagę typy używanych plików i Twój sposób pracy. Każdy przypadek jest inny i wymaga innej kombinacji technik, aby uzyskać jak największą wydajność programu Lightroom Classic.

Zoptymalizuj swój sprzęt i system operacyjny

Dokonaj aktualizacji do najnowszej wersji programu Lightroom Classic

W programie Lightroom Classic, wybierz kolejno opcje Pomoc > Sprawdź aktualizacje.

Przekraczanie minimalnych wymagań systemowych

Minimalne wymagania systemowe do uruchomienia programu Lightroom Classic to po prostu minimum niezbędne do jego działania. Zwłaszcza większa ilość pamięci RAM i szybszy procesor mogą przynieść znaczące korzyści pod względem wydajności. Wymagania różnią się w zależności od następujących czynników:

  • Rodzaje plików, z którymi się pracuje
  • Ich rozmiary
  • Całkowita liczba obrazów w katalogu
  • Zakres punktowych pędzli korygujących lub lokalnych (malowanych pędzlem) zastosowanych do obrazów

Do opcji, które mogą pomóc zwiększyć wydajność, należą:

  • 64-bitowy, wielordzeniowy procesor (w celu uzyskania najlepszej wydajności — do sześciu rdzeni; dodatkowa moc jest szczególnie ważna w przypadku korzystania z wielu monitorów lub monitorów o wysokiej rozdzielczości, które wymagają większej mocy)
  • 12 GB pamięci RAM (zalecane); Co najmniej 4 GB pamięci RAM, więcej, jeśli jednocześnie korzystasz z programu Photoshop
  • Szybkie dyski twarde, zwłaszcza do katalogów i podglądów

Dowiedz się, jakie są wymagania systemowe dla używanej wersji programu Lightroom Classic.

Aby poznać szczegóły konfiguracji systemu, w programie Lightroom Classic wybierz kolejno opcje Pomoc > Informacje o systemie.

Uruchamianie programu Lightroom Classic na komputerach z co najmniej 12 GB pamięci RAM

Aby uzyskać najlepszą wydajność, zaleca się uruchamianie programu Lightroom Classic na komputerach wyposażonych w co najmniej 12 GB pamięci RAM.  Wykorzystanie zalecanej ilości pamięci RAM zapewnia znaczną poprawę wydajności, zwłaszcza podczas importowania i eksportowania zdjęć, przechodzenia pomiędzy zdjęciami w widoku lupki oraz tworzenia obrazów HDR i panoram.

Korzystanie z szybkiego dysku twardego

Do najprostszej pracy wystarczy szybki (7200 obr./min) wewnętrzny dysk Serial-ATA. W przypadku bardziej wymagających przepływów pracy należy rozważyć zastosowanie macierzy RAID.

Przechowywanie katalogów, plików obrazów i podglądów na dysku zewnętrznym jest wygodne, jeśli pracujesz z tym samym katalogiem na wielu komputerach. Może to jednak negatywnie wpłynąć na wydajność programu Lightroom. Jeśli musisz przechowywać pliki na zewnątrz, upewnij się, że masz szybkie łącze. Na przykład użyj połączenia Thunderbolt, USB 3.0 (nie USB 1.0 lub 2.0) lub eSATA. Aby uzyskać jak najlepszą wydajność, podłącz dysk zewnętrzny do zgodnego portu zapewniającego najwyższą przepustowość ze wszystkich dostępnych portów. Przepustowości różnych portów opisano poniżej:

  • Thunderbolt = 10 GB/s
  • eSATA = 600 MB/s
  • PCIe = 500 MB/s
  • USB3 = 400 MB/s
  • USB2 = 35 MB/s

 

Uwaga:

Pliki katalogów nie mogą być przechowywane na dyskach sieciowych, ale zdjęcia można przechowywać na dysku sieciowym. Jednakże, dyski sieciowe (dysk twardy o dostępie za pośrednictwem sieci) charakteryzują się mniejszą szybkością transferu danych. Dlatego przełączanie modułów lub przechodzenie z jednego pliku do drugiego w programie Lightroom może zająć więcej czasu.

Upewnij się, że masz wystarczająco duży dysk twardy i wystarczającą ilość wolnego miejsca

Praca ze zbyt małą ilością wolnego miejsca na dysku twardym może powodować niską wydajność. Upewnij się, że dysk twardy, na którym przechowywany jest katalog programu Lightroom Classic, podglądy i pliki obrazów, jest wolny w co najmniej 20%.

Zapoznaj się z wymaganiami systemowymi programu Lightroom Classic, aby dowiedzieć się, jaka minimalna ilość wolnego miejsca na dysku twardym jest wymagana dla danej wersji programu Lightroom Classic.

Zaktualizuj sterownik karty graficznej

Użyj kompatybilnego procesora graficznego (zwanego także kartą graficzną, kartą wideo lub GPU). Należy pamiętać o aktualizowaniu oprogramowania sterownika graficznego.

Jeśli procesor graficzny komputera jest niekompatybilny z programem Lightroom, usuń zaznaczenie pola wyboru Użyj procesora graficznego w programie Lightroom Classic (macOS) / Edytuj (Win) > Preferencje > Wydajność.

Szczegółowe informacje można znaleźć w sekcji Rozwiązywanie problemów z procesorem graficznym (GPU) w programie Lightroom Classic i odpowiedzi na najczęściej zadawane pytania.

Uruchamianie programu Lightroom Classic w trybie 64-bitowym (Lightroom 4 i 3)

Jeśli uruchomisz program Lightroom Classic w trybie 64-bitowym, będzie on miał dostęp do ponad 2 GB pamięci RAM, co jest limitem dla 32-bitowych systemów operacyjnych. Zapewnienie programowi Lightroom Classic dostępu do więcej niż 4 GB pamięci RAM może znacznie poprawić wydajność.

Program Lightroom Classic działa w trybie 64-bitowym automatycznie, jeśli jest zainstalowany na komputerze wyposażonym w 64-bitowy system operacyjny. Aby sprawdzić, czy program działa w trybie 64-bitowym, należy wykonać następujące czynności:

Sprawdź, czy program Lightroom Classic jest uruchomiony w trybie 64-bitowym w systemie Windows

  1. Uruchom program Lightroom Classic i spójrz na pasek tytułu aplikacji.

  2. Sprawdź, czy w tytule pojawia się „x64”.

Sprawdź, czy program Lightroom Classic jest uruchomiony w trybie 64-bitowym w systemie Mac OS

  1. W aplikacji Finder przejdź do folderu Aplikacje i kliknij Adobe Lightroom 3.

  2. Naciśnij Command+I.

  3. W opcjach ogólnych upewnij się, że opcja Otwórz w trybie 32-bitowym jest odznaczona.

Jeśli używasz programu Photoshop z programem Lightroom Classic, sprawdź ustawienia pamięci RAM w programie Photoshop

Aby określić najlepsze ustawienia pamięci RAM dla swojego komputera, zapoznaj się z sekcjami Maksymalne wykorzystanie pamięci RAM i Użycie pamięci w następującej Nocie technicznej. Aby zmienić ustawienia pamięci w programie Photoshop, wybierz kolejno: Apple > Preferencje > Wydajność (Mac OS) lub Edycja > Preferencje > Wydajność (Windows).

Wyświetlacze o wysokiej rozdzielczości

Rysowanie na ekranie może być powolne, gdy program Lightroom wykorzystuje cały ekran monitora o wysokiej rozdzielczości. Wyświetlacz o wysokiej rozdzielczości ma rozdzielczość natywną bliską 2560 x 1600 i jest spotykany w monitorach 30-calowych oraz MacBookach Retina. Aby zwiększyć wydajność na takich monitorach, należy zmniejszyć rozmiar okna programu Lightroom Classic lub użyć widoków 1:2 lub 1:3 w panelu Nawigator.

Użyj optymalnych ustawień w programie Lightroom Classic

Zatrzymaj „Synchronizację z programem Lightroom” podczas edycji w programie Lightroom Classic

Synchronizacja obrazów wykorzystuje zasoby procesora i systemu do tworzenia podglądów oraz wysyłania/pobierania obrazów z usługi Creative Cloud. Tymczasowo wstrzymaj działanie funkcji Synchronizacja z programem Lightroom podczas importowania i edytowania zdjęć na komputerze. Następnie uruchom ponownie funkcję Synchronizacja z programem Lightroom i pozostaw aplikację otwartą przez noc, aby proces synchronizacji mógł być kontynuowany i zakończony.

Celowo renderuj podglądy 1:1

Program Lightroom Classic wykorzystuje podglądy do wyświetlania miniatur zdjęć w widoku siatki, widoku lupy oraz w modułach wywoływanie, pokaz slajdów, wydruku i sieci.

Podczas importowania zdjęć można wybrać jeden z trzech typów podglądu o stopniowo wzrastającej jakości:

Minimalne: Te podglądy to małe podglądy JPEG o niskiej rozdzielczości osadzone w zdjęciach, generowane przez kamerę. Są one najszybszym typem podglądu do utworzenia. W widokach taśmy filmowej i siatki modułu biblioteki tymczasowo używane są minimalne podglądy, dopóki program Lightroom nie wyrenderuje standardowych rozmiarów podglądów dla tych miniatur.

Osadzone i pomocnicze: Te podglądy są większe, również generowane przez kamerę, a ich tworzenie trwa nieco dłużej niż podglądy minimalne.

Standardowe: Program Lightroom Classic tworzy standardowe podglądy. Do ich przetwarzania wykorzystywany jest program Camera Raw. W związku z tym czasami wyglądają one inaczej niż podglądy minimalne lub osadzone, zwłaszcza jeśli zastosowano korekty w module wywoływania. W zależności od używanego wyświetlacza można określić wymagany rozmiar podglądu standardowego. Standardowe podglądy wykorzystywane są w miniaturkach widoku taśmy filmowej i siatki, a także w obszarach podglądu i zawartości modułów pokazu slajdów, druku i sieci.

1:1: Te podglądy stanowią 100% rzeczywistego obrazu pikseli i podobnie jak podglądy standardowe są przetwarzane przez silnik programu Camera Raw. Gdy program Lightroom Classic generuje podglądy 1:1, generuje również podglądy minimalne i standardowe, więc wszystkie trzy są dostępne dla programu w razie potrzeby. Ponieważ przetwarzanych jest tak wiele danych, tworzenie podglądu 1:1 może zająć sporo czasu. Za każdym razem, gdy w module Biblioteka ustawiane jest powiększenie 1:1 lub większe, program Lightroom Classic używa podglądu 1:1.

Do wyświetlania zdjęć i pracy z nimi program Lightroom Classic wymaga podglądu standardowego lub 1:1, w zależności od zadania. Jeśli podczas importowania zaznaczysz, że program Lightroom Classic ma generować tylko podglądy minimalne lub wbudowane, automatycznie utworzy on podglądy standardowe i 1:1 podczas pracy w programie. Proces ten utrudnia działanie. Aby zwiększyć wydajność i zmniejszyć zakłócenia, należy zarządzać czasem i sposobem renderowania podglądów 1:1. Renderuj je podczas importowania lub przeznacz czas na ich ręczne renderowanie.

Aby renderować podglądy 1:1 podczas importowania, należy użyć panelu Obsługa plików w oknie importu. Wybierz kolejno opcje Renderuj podglądy > 1:1. Mimo że generowanie wysokiej jakości podglądów 1:1 podczas importu spowalnia proces importowania, sprawia ono, że program Lightroom Classic lepiej reaguje, gdy zaczynasz pracę w module Biblioteka.

Alternatywą, jeśli chcesz przyspieszyć proces importowania, jest renderowanie minimalnych lub standardowych podglądów podczas importowania. Następnie w dowolnym momencie można zaznaczyć wiele zdjęć w widoku siatki w module Biblioteka i wybrać kolejno opcje Biblioteka > Podgląd > Renderuj podgląd 1:1. Pozwól, aby program Lightroom Classic przetworzył obrazy przed rozpoczęciem pracy nad nimi.

Podgląd w standardowym rozmiarze powinien być jak najmniejszy

Ponieważ renderowanie standardowych podglądów wymaga czasu, nie należy zmuszać programu Lightroom Classic do pracy ponad siły. Utrzymywanie małych rozmiarów standardowych podglądów pomaga również zmniejszyć rozmiar pamięci podręcznej pliku podglądu, co zwiększa wydajność i pozwala zaoszczędzić miejsce na dysku twardym.

Aby standardowe podglądy zachowały niewielkie rozmiary, należy określić odpowiedni rozmiar i jakość w oknie dialogowym Ustawienia katalogu:

  1. Wybierz polecenie Edycja > Ustawienia katalogu (Windows) lub Lightroom Classic > Ustawienia katalogu (Mac OS), a następnie wybierz Obsługa plików.

  2. W przypadku opcji Standardowy rozmiar podglądu wybierz wartość najbliższą najdłuższej krawędzi rozdzielczości ekranu, ale nie krótszą od niej. Na przykład, jeśli rozdzielczość ekranu wynosi 1920 x 1200 pikseli, wybierz kolejno opcje Standardowy rozmiar podglądu > 2048 pikseli.

  3. W przypadku opcji Jakość podglądu wybierz wartość Niska lub Średnia, co odpowiada niskiemu lub średniemu zakresowi skali jakości dla plików JPEG.

Uwaga:

Im większego monitora używasz (i im wyższa jego rozdzielczość), tym więcej pracy wymaga program Lightroom, aby obliczyć podgląd i zaktualizować piksele podczas wprowadzania poprawek. Jeśli podczas korzystania z dużych monitorów występują spowolnienia wydajności, spróbuj zmniejszyć rozdzielczość wyświetlacza za pomocą Panelu sterowania wyświetlaniem (Windows) lub Preferencji systemowych wyświetlania (Mac OS). 

Utrzymuj podglądy 1:1 tak długo, jak to możliwe

Ponieważ podglądy 1:1 mogą szybko zabierać miejsce na dysku, program Lightroom Classic umożliwia regularne usuwanie ich z dysku — co dzień, tydzień lub miesiąc. Za każdym razem, gdy je odrzucasz, program Lightroom Classic musi utworzyć je na nowo, gdy będziesz ich potrzebować — nawet jeśli tylko powiększasz obraz w widoku lupki.

Jeśli miejsce na dysku nie stanowi problemu, należy jak najdłużej utrzymywać podglądy 1:1, aby zoptymalizować wydajność. W obszarze Obsługa plików okna dialogowego Ustawienia katalogu wybierz opcję Automatycznie odrzuć podglądy 1:1: > Po 30 dniach lub Nigdy.

Należy jednak pamiętać, że plik zawierający podglądy, plik [Nazwa katalogu] Previews.lrdata, może urosnąć, jeśli opcja usuwania podglądów jest ustawiona na Nigdy lub 30 dni. Plik ten znajduje się w tym samym pliku co plik katalogu. Jeśli ta opcja jest ustawiona na „Nigdy”, a na dysku twardym występują problemy z niskim poziomem pojemności, należy sprawdzić rozmiar tego pliku. Należy go usunąć, jeśli stanie się zbyt duży.

Przechowuj katalog i pamięć podręczną podglądu w tym samym folderze

Domyślnie program Lightroom Classic przechowuje plik pamięci podręcznej podglądu, [Nazwa katalogu] Previews.lrdata, w tym samym folderze co plik katalogu, [Nazwa katalogu].lrcat. Jeśli przeniesiesz plik katalogu lub zapiszesz go oddzielnie od pamięci podręcznej, program Lightroom Classic będzie musiał zregenerować podglądy. Dlatego należy trzymać je razem.

Informacje na temat domyślnej lokalizacji katalogu, podglądu i innych plików programu Lightroom Classic można znaleźć na stronie Plik preferencji i inne lokalizacje plików.

Pozostaw wyłączoną funkcję automatycznego zapisu XMP

Domyślnie zmiany dokonane w plikach w programie Lightroom Classic — na przykład dodanie słów kluczowych lub usunięcie efektu czerwonych oczu — są zapisywane razem ze zdjęciem w katalogu programu Lightroom Classic.  Jednak aby inne aplikacje, takie jak Adobe Bridge i Camera Raw, mogły rozpoznać te zmiany, są one zapisywane jako dane XMP (extensible metadata platform). Dane te są dołączone do pliku obrazu.

W programie Lightroom edycje mogą być zapisywane w formacie XMP automatycznie lub ręcznie. Jeśli regularnie przełączasz się pomiędzy programami Lightroom Classic, Adobe Bridge i Camera Raw, najwygodniej jest automatycznie zapisywać zmiany w formacie XMP. W ten sposób nie trzeba się nad tym zastanawiać. Aplikacje są zawsze zsynchronizowane, zawsze odzwierciedlają bieżące edycje w programie Lightroom Classic, a w programie Bridge i Lightroom Classic nie są wyświetlane ikony ani identyfikatory niedopasowania metadanych.

Automatyczne zapisywanie zmian może jednak znacząco obniżyć wydajność programu Lightroom Classic. Jeśli nie pracujesz z wieloma aplikacjami, rozważ wyłączenie preferencji automatycznego zapisu. Zmiany są nadal zapisywane w katalogu, a podczas drukowania lub eksportowania zdjęć z programu Lightroom Classic zmiany są widoczne na wydruku.

Aby wyłączyć funkcję automatycznego zapisu XMP, należy wykonać następujące czynności:

  1. Wybierz polecenie Edycja > Ustawienia katalogu (Windows) lub Lightroom > Ustawienia katalogu (Mac OS).

  2. Kliknij kartę Metadane i usuń zaznaczenie opcji Automatycznie zapisuj zmiany w XMP.

Nawet jeśli funkcja automatycznego zapisu XMP jest wyłączona, w każdej chwili można ręcznie zapisać zmiany metadanych w poszczególnych plikach. Aby uzyskać więcej informacji, zobacz Podstawy metadanych i działania.

Zoptymalizuj katalog

Program Lightroom Classic nieustannie zapisuje zmiany w pliku katalogowym (.lrcat). Jeśli wydajność pracy spada, zoptymalizuj katalog programu Lightroom Classic, wybierając polecenie Plik > Optymalizuj katalog. Optymalizacja katalogu nakazuje programowi Lightroom Classic zbadanie struktury danych w katalogu i upewnienie się, że jest ona zwięzła.

Aby jeszcze bardziej zoptymalizować wydajność i poprawić stabilność katalogu, po zamknięciu programu Lightroom Classic i utworzeniu kopii zapasowej katalogu należy wybrać opcje Sprawdź integralność przed utworzeniem kopii zapasowej i Optymalizuj katalog po utworzeniu kopii zapasowej. Procesy te zajmują trochę czasu, ale mogą pomóc w utrzymaniu sprawnego działania katalogu. 

Zwiększ rozmiar pamięci podręcznej programu Camera Raw

Za każdym razem, gdy przeglądasz lub edytujesz surowe obrazy w module wywoływania, program Lightroom Classic generuje aktualne podglądy w wysokiej jakości. Jako podstawę wykorzystuje on oryginalne dane obrazu, a następnie aktualizuje podgląd w celu uwzględnienia wszelkich zastosowanych obróbek lub korekt. Proces ten przebiega nieco szybciej, jeśli oryginalne dane obrazu znajdują się w pamięci podręcznej programu Camera Raw. Program Lightroom Classic sprawdza, czy w pamięci podręcznej znajdują się oryginalne dane obrazu, i może pominąć wczesne etapy przetwarzania, jeśli tak rzeczywiście jest.

Domyślnie program Lightroom Classic ustawia pamięć podręczną programu Camera Raw na 1 GB. Jeśli zwiększysz rozmiar pamięci podręcznej, będzie ona mogła przechowywać więcej danych obrazu, co przyspieszy generowanie podglądu tych obrazów. Niektórzy użytkownicy programu Lightroom Classic uważają, że zwiększenie pamięci podręcznej programu Camera Raw do 20 GB lub więcej może znacznie przyspieszyć działanie modułu wywoływania. Aby zwiększyć rozmiar pamięci podręcznej programu Camera Raw, wykonaj następujące czynności:

  1. Wybierz opcję Lightroom Classic > Preferencje (Mac OS) lub Edytuj > Preferencje (Windows).

  2. Kliknij kartę Obsługa plików.

  3. W obszarze Ustawienia pamięci podręcznej Camera Raw poeksperymentuj z ustawieniem wartości Maksymalny rozmiar na 10,0 GB lub więcej.

Aby jeszcze bardziej przyspieszyć działanie pamięci podręcznej, należy przechowywać ją na szybkim dysku twardym. Aby określić lokalizację pamięci podręcznej programu Camera Raw, wykonaj następujące czynności:

  1. Wybierz opcję Lightroom Classic > Preferencje (Mac OS) lub Edytuj > Preferencje (Windows).

  2. Kliknij kartę Obsługa plików.

  3. W obszarze Ustawienia pamięci podręcznej Camera Raw kliknij przycisk Wybierz i przejdź do lokalizacji, w której ma być przechowywana pamięć podręczna.

Narzędzie do usuwania plam, korekty lokalne i panel Historia

Narzędzie Usuwanie plam i Pędzel do lokalnych korekcji nie są przeznaczone do wykonywania setek lub tysięcy korekt. Jeśli obraz zawiera wiele (setki) miejscowych poprawek, warto rozważyć użycie programu do edycji opartego na pikselach, takiego jak Photoshop.

Jeśli wprowadzono wiele poprawek, sprawdź panel Historia. Panel Historia nie posiada ograniczeń i nie jest usuwany, chyba że zostanie to określone. Jeśli tworzysz wiele korekt lokalnych lub punktowych, historia może być długa, co może spowolnić działanie całego programu Lightroom Classic.

Wyczyść panel Historia, klikając znak X znajdujący się po prawej stronie nagłówka panelu Historia.

Kolejność operacji rozwijania

Najlepsza kolejność operacji wywoływania w celu zwiększenia wydajności jest następująca:

  1. Punktowy pędzel korygujący.
  2. Korekty geometrii, takie jak profile Korekcji obiektywu oraz Korekcje ręczne, w tym korekcje geometrii obrazu przy użyciu suwaka Pionowo.
  3. Globalne korekty niedetaliczne, takie jak Ekspozycja i Balans bieli. W razie potrzeby można również dokonać tych poprawek w pierwszej kolejności.
  4. Korekty lokalne, takie jak Filtr gradientu i pociągnięcia Pędzla dopasowania.
  5. Korekcje szczegółów, takie jak Redukcja szumu i Wyostrzanie.

Uwaga: Wcześniejsze przeprowadzenie punktowego pędzla korygującego zwiększa dokładność pędzla korygującego i zapewnia zgodność granic korygowanych obszarów z lokalizacją plamki.

Unikaj korekt, które nie są potrzebne

Sugestia ta dotyczy w szczególności korekt lokalnych. Każdy suwak, który został zmieniony podczas stosowania korekt lokalnych lub filtra gradientu, jest stosowany do całej korekty. Każda z opcji zużywa zasoby i może wpływać na wydajność.

Podczas stosowania korekt lokalnych i gradientów należy upewnić się, że wszystkie wybrane korekty są potrzebne.

Jeśli pociągnięcie pędzlem lub gradient nie są potrzebne do wykonania określonego typu korekty, ustaw ich suwak na zero.

Należy także unikać stosowania niepotrzebnych korekt globalnych, zwłaszcza opcji, które zużywają zasoby, takich jak Redukcja szumu, Wyostrzanie i Korekcje obiektywu.

Niektóre suwaki mają domyślnie ustawioną wartość, która powoduje ich domyślne włączenie. W przypadku opcji bardziej zasobochłonnych zero powoduje wyłączenie suwaka.

Opcje powiększania/zmniejszania

Jeśli opcje powiększenia Dopasuj i Wypełnij działają wolno, spróbuj użyć opcji 1:2, 1:3 lub 1:4 w panelu Nawigator.

Której wersji procesu użyć

Wersja procesu 2012 wymaga więcej zasobów niż wersja procesu 2010, więc w niektórych przypadkach może być wolniejsza. Należy jednak zrównoważyć wzrost wydajności z edycją i jakością obrazu dostępną w wersji procesu 2012.

Usunięcie pamięci podręcznej podglądu programu Lightroom Classic

Choć zdarza się to rzadko, czasami może wystąpić jeden lub większa liczba z poniższych problemów. W takim przypadku konieczne może być usunięcie pliku pamięci podręcznej podglądu:

  • Dysk twardy zostaje niespodziewanie zapełniony.
  • W programie Lightroom Classic pojawia się błąd dotyczący pamięci podręcznej.
  • Na zdjęciach pojawiają się artefakty, takie jak linie, kropki lub nieoczekiwane kolorowe obszary.

Plik zawierający dane miniatur i podglądów nosi nazwę [Nazwa_katalogu] Previews.lrdata i znajduje się w tym samym folderze co katalog.

Miniatury, małe podglądy i podglądy 1:1 (w pełnym rozmiarze) są przechowywane w pliku Previews.lrdata. W preferencjach programu Lightroom Classic można określić, kiedy należy usuwać największe podglądy, czyli podglądy 1:1. Po usunięciu podglądów 1:1 zmniejsza się rozmiar pliku Previews.lrdata. Jeśli nie usuniesz podglądów 1:1, plik z podglądami może stać się bardzo duży. 

Domyślnym ustawieniem czasu usuwania dużych podglądów 1:1 jest jeden tydzień. Rozmiar pliku podglądu jest zmniejszany podczas usuwania tych dużych podglądów, ale cały plik nie jest usuwany, chyba że zostanie usunięty ręcznie. Plik nie staje się ogromny, chyba że rzadko lub nigdy nie usuwasz podglądów 1:1. To, czy ma to wpływ na Twój dysk twardy, zależy od ilości wolnego miejsca na dysku. Częstotliwość usuwania podglądów 1:1 można zmienić, wybierając kolejno opcje Edycja > Ustawienia katalogu > Obsługa plików (Windows) lub Lightroom Classic > Ustawienia katalogu > Obsługa plików (Mac OS). 

Uwaga: Nie należy mylić pliku Previews.lrdata omawianego w tej nocie technicznej z plikiem [Nazwa_katalogu] Smart Previews.lrdata, który zawiera wszystkie inteligentne podglądy. W przypadku bardzo ograniczonej ilości miejsca na dysku twardym może być konieczne usunięcie tego pliku. Jeśli ilość miejsca na dysku twardym jest na tyle mała, że pojawiają się błędy związane z niską ilością miejsca na dysku twardym, należy opróżnić kosz, zarchiwizować niektóre pliki i/lub uporządkować dane tak, aby było więcej wolnego miejsca na dysku twardym.

Jeśli usuniesz plik Previews.lrdata, podglądy będą tworzone na nowo dla każdego folderu lub kolekcji otwieranej w programie Lightroom Classic, dlatego przy pierwszej pracy w folderze wystąpi pewne opóźnienie podczas ponownego tworzenia podglądu.

Jeśli opcja Automatycznie odrzuć podglądy 1:1 jest ustawiona na Nigdy lub Po 30 dniach, plik podglądu może stać się bardzo duży. Może on zajmować wiele GB miejsca. Jeśli dysk twardy nagle się zapełni, należy sprawdzić rozmiar tego pliku. Następnie można usunąć ten plik. 

W programie Lightroom Classic może pojawić się błąd wskazujący na problem z pamięcią podręczną; jest to kolejny moment, w którym warto usunąć plik previews.lrdata.

Jeśli obrazy są wyświetlane z artefaktami, takimi jak kolorowe linie, kolorowe kropki lub obszary o nieoczekiwanych kolorach, plik podglądu może być uszkodzony, a jedynym sposobem naprawienia tego problemu jest usunięcie pliku previews.lrdata. 

Należy pamiętać, że jeśli w katalogu znajdują się podglądy obrazów, które zostały zarchiwizowane, zostaną one utracone. 

Jeśli usunięcie pliku Previews.lrdata nie rozwiąże problemu, spróbuj wyczyścić plik pamięci podręcznej programu Camera Raw. 

  1. W programie Lightroom wybierz polecenie Edycja > Preferencje > Obsługa plików (Windows) lub Lightroom > Preferencje > Obsługa plików (Mac OS).
  2. Kliknij przycisk Wyczyść pamięć podręczną w obszarze Ustawienia pamięci podręcznej Camera Raw.

Można również zmienić lokalizację tej pamięci podręcznej, klikając przycisk Wybierz. Należy pamiętać, że ta pamięć podręczna jest używana tylko przez moduł wywoływania.

Zmniejszanie liczby ustawień wstępnych

Dodawanie ustawień wstępnych do programu Lightroom Classic (utworzonych przez użytkownika lub inną firmę) może obniżyć wydajność, ponieważ moduł wywoływania generuje miniatury w panelu Nawigator dla każdego ustawienia wstępnego. Jest to najbardziej widoczne, gdy użytkownik ma 2000 lub większą liczbę ustawień wstępnych. Aby uniknąć tego typu spowolnień, należy ograniczyć liczbę ustawień wstępnych załadowanych do programu Lightroom Classic do tych, które są najczęściej używane.

Przeprowadzaj regularną konserwację systemu

Bieżące aktualizowanie programu Lightroom Classic

Aktualizacje usuwają błędy i mogą poprawić wydajność. Upewnij się, że używasz najnowszej aktualizacji swojej wersji programu Lightroom Classic. Wybierz kolejno opcje Pomoc > Sprawdź aktualizacje.

Zamknij niepotrzebne aplikacje i elementy startowe

Inne otwarte aplikacje i elementy startowe zmniejszają ilość pamięci dostępnej dla programu Lightroom. Wyłącz niepotrzebne aplikacje, elementy startowe i rozszerzenia, a następnie udostępnij więcej pamięci dla programu Lightroom Classic.

Podczas pracy w programie Lightroom Classic należy również tymczasowo wyłączyć oprogramowanie antywirusowe lub zabezpieczające, które wykonuje skanowanie w czasie rzeczywistym lub automatyczne tworzenie kopii zapasowych. Instrukcje dotyczące wyłączania funkcji oprogramowania antywirusowego lub zabezpieczającego można znaleźć w dokumentacji oprogramowania antywirusowego lub zabezpieczającego.

Oczyszczanie dysku (Windows)

Podczas pracy w aplikacji system Windows przechowuje na dysku twardym tymczasową kopię pliku z danymi. Wiele aplikacji tworzy pliki .tmp, a następnie usuwa je po zamknięciu aplikacji. Awarie lub błędy systemowe mogą jednak uniemożliwić aplikacji usunięcie tych plików, co powoduje, że zajmują one miejsce na dysku i stwarzają problemy. Od czasu do czasu uruchom Oczyszczanie dysku, aby usunąć tymczasowe pliki i inne pliki, które nie są używane.

  1. Windows:  Kliknij przycisk Start, wpisz Oczyszczanie dysku w polu wyszukiwania i wybierz opcję Oczyszczanie dysku z listy programów.

  2. W razie potrzeby wybierz dysk, który ma zostać wyczyszczony.

  3. Wybierz pliki tymczasowe oraz inne pliki, które chcesz usunąć.

  4. Kliknij przycisk OK.

Defragmentacja dysku twardego

Dodawanie, usuwanie i przenoszenie plików na dysku twardym powoduje, że dostępne miejsce na dysku nie jest już pojedynczym, ciągłym blokiem. Jeśli w systemie nie ma wystarczającej ilości ciągłego miejsca, fragmenty plików są zapisywane w różnych miejscach na dysku twardym. Program Lightroom Classic dłużej czyta i zapisuje zdefragmentowany plik niż plik zapisany w lokalizacji ciągłej.

Podczas defragmentacji dysku twardego należy pamiętać o wybraniu opcji naprawiania błędów dysku i odzyskiwania uszkodzonych sektorów. Instrukcje dotyczące defragmentacji twardych dysków w systemie Windows można znaleźć w następujących tematach Pomocy firmy Microsoft:

Ogólnie rzecz biorąc, dyski twarde w systemie Mac OS nie wymagają defragmentacji. System Mac OS X automatycznie defragmentuje małe pliki. W celu przeprowadzenia dokładniejszej defragmentacji lub rozwiązania problemów z dyskiem twardym w systemie Mac OS należy użyć narzędzia Apple Disk Utility. Można też użyć narzędzia innej firmy, takiego jak Micromat Tech Tool Pro. Zapoznaj się z Informacjami o optymalizacji dysku w systemie Mac OS X w witrynie wsparcia firmy Apple.

Zainstaluj najnowsze aktualizacje systemu OS

Aktualizacje systemu Windows lub macOS poprawiają jego wydajność oraz poziom zgodności z aplikacjami.

Dodatki Service Pack dla systemu Windows i inne aktualizacje można uzyskać w witrynie firmy Microsoft. Aby uzyskać pomoc przy zainstalowaniu dodatków Service Pack i innych aktualizacji, skontaktuj się z działem pomocy technicznej firmy Microsoft.

Aby uzyskać uaktualnienia systemu Mac OS X, wybierz opcję Uaktualnienia oprogramowania z menu Apple. Aby uzyskać pomoc przy zainstalowaniu aktualizacji, skontaktuj się z działem pomocy technicznej firmy Apple.

Uwaga:

W celu zagwarantowania zgodności przed zainstalowaniem aktualizacji systemu sprawdź wymagania systemowe oprogramowania firmy Adobe. (Sprawdź również informacje na temat oprogramowania lub sprzętu innych firm, używanego razem z oprogramowaniem firmy Adobe). Jeśli aktualizacji nie ma na liście, skontaktuj się z firmą Adobe lub z producentem określonego oprogramowania lub sprzętu.

Logo Adobe

Zaloguj się na swoje konto