Podręcznik użytkownika Anuluj

Optymalizacja wydajności programu Photoshop

  1. Podręcznik użytkownika programu Photoshop
  2. Wprowadzenie do programu Photoshop
    1. Dream it. Make it.
    2. Nowości w programie Photoshop
    3. Edytowanie pierwszego zdjęcia
    4. Tworzenie dokumentów
    5. Photoshop | Częste pytania
    6. Wymagania systemowe programu Photoshop
    7. Poznaj program Photoshop
  3. Program Photoshop a inne produkty i usługi firmy Adobe
    1. Korzystanie z kompozycji programu Illustrator w programie Photoshop
    2. Korzystanie z plików programu Photoshop w programie InDesign
    3. Materiały Substance 3D w programie Photoshop
    4. Używanie rozszerzenia Capture w programie Photoshop
  4. Photoshop na tablet iPad (brak dostępu w Chinach)
    1. Photoshop na tablet iPad | Częste pytania
    2. Zapoznanie z przestrzenią roboczą
    3. Wymagania systemowe | Photoshop na tablet iPad
    4. Tworzenie, otwieranie i eksportowanie dokumentów
    5. Dodawanie zdjęć
    6. Korzystanie z warstw
    7. Rysowanie i malowanie przy użyciu pędzli
    8. Tworzenie zaznaczeń i dodawanie masek
    9. Retuszowanie kompozycji
    10. Korzystanie z warstw dopasowania
    11. Dopasowanie odcieni kompozytów przy użyciu krzywych
    12. Stosowanie przekształceń
    13. Kadrowanie i obracanie obrazów kompozytowych
    14. Obracanie, przesuwanie, powiększanie i zerowanie obszaru roboczego
    15. Korzystanie z warstw tekstowych
    16. Korzystanie z programów Photoshop i Lightroom
    17. Pobieranie brakujących czcionek w programie Photoshop na tablecie iPad
    18. Tekst w języku japońskim w programie Photoshop na tablecie iPad
    19. Zarządzanie ustawieniami aplikacji
    20. Skróty i gesty dotykowe
    21. Skróty klawiaturowe
    22. Edytowanie rozmiaru obrazu
    23. Nadawanie na żywo podczas tworzenia w programie Photoshop na tablecie iPad
    24. Retuszowanie niedoskonałości za pomocą narzędzia Pędzel korygujący
    25. Tworzenie pędzli w rozszerzeniu Capture i używanie ich w programie Photoshop na tablet iPad
    26. Praca z plikami Camera Raw
    27. Tworzenie i używanie obiektów inteligentnych
    28. Modyfikowanie ekspozycji obrazów przy użyciu funkcji rozjaśniania i ściemniania
    29. Polecenia dopasowań automatycznych w programie Photoshop na tablet iPad
    30. Rozmazywanie obszarów obrazów w programie Photoshop na tablet iPad
    31. Zwiększanie i zmniejszanie nasycenia obrazów przy użyciu narzędzia Gąbka
    32. Wypełnienie z uwzględnieniem zawartości na tablecie iPad
  5. Photoshop w Internecie (brak dostępu w Chinach)
    1. Częste pytania
    2. Wymagania systemowe
    3. Skróty klawiaturowe
    4. Obsługiwane typy plików
    5. Wprowadzenie do przestrzeni roboczej
    6. Otwieranie plików w chmurze i korzystanie z nich
    7. Funkcje oparte na generatywnej sztucznej inteligencji
    8. Podstawowe pojęcia związane z edytowaniem
    9. Szybkie operacje
    10. Korzystanie z warstw
    11. Retuszowanie obrazów i usuwanie niedoskonałości
    12. Szybkie zaznaczanie
    13. Ulepszenia obrazów dzięki warstwom dopasowania
    14. Przesuwanie, przekształcanie i kadrowanie obrazów
    15. Rysowanie i malowanie
    16. Korzystanie z warstw tekstowych
    17. Współpraca z innymi przez Internet
    18. Zarządzanie ustawieniami aplikacji
    19. Generowanie obrazów
    20. Generowanie tła
    21. Obraz odniesienia
  6. Photoshop (beta) (brak dostępu w Chinach)
    1. Pierwsze kroki z wersjami beta aplikacji Creative Cloud
    2. Photoshop (beta) na komputer
    3. Generowanie obrazów z opisów tekstowych
    4. Generowanie tła z opisów tekstowych
  7. Generatywna sztuczna inteligencja (brak dostępu w Chinach)
    1. Częste pytania dotyczące generatywnej sztucznej inteligencji w programie Photoshop
    2. Wypełnienie generatywne w programie Photoshop na komputer
    3. Rozszerzenie generatywne w programie Photoshop na komputer
    4. Narzędzie Wypełnienie generatywne w programie Photoshop na tablet iPad
    5. Narzędzie Rozszerzenie generatywne w programie Photoshop na tablet iPad
    6. Funkcje oparte na SI w programie Photoshop w Internecie
  8. Autentyczność zawartości (brak dostępu w Chinach)
    1. Poświadczenia zawartości w programie Photoshop
    2. Identyfikacja i pochodzenie tokenów NFT
    3. Łączenie kont na potrzeby uznania udziału w pracy twórczej
  9. Pliki w chmurze (brak dostępu w Chinach)
    1. Pliki w chmurze — Photoshop | Częste pytania
    2. Pliki w chmurze — Photoshop | Pytania dotyczące obiegów pracy
    3. Zarządzanie plikami w chmurze i korzystanie z nich przy użyciu programu Photoshop
    4. Zwiększanie ilości przestrzeni dyskowej dla programu Photoshop
    5. Nie można utworzyć ani zapisać pliku w chmurze
    6. Rozwiązywanie błędów z plikami w chmurze programu Photoshop
    7. Zbieranie dzienników synchronizacji plików w chmurze
    8. Zapraszanie innych do edytowania plików w chmurze
    9. Udostępnianie plików i komentowanie w aplikacji
  10. Przestrzeń robocza
    1. Podstawy pracy z przestrzenią roboczą
    2. Preferencje
    3. Szybsza nauka dzięki panelowi Odkrywanie w programie Photoshop
    4. Tworzenie dokumentów
    5. Umieszczanie plików
    6. Domyślne skróty klawiaturowe
    7. Dostosowywanie skrótów klawiszowych
    8. Galerie narzędzi
    9. Preferencje wydajności
    10. Korzystanie z narzędzi
    11. Ustawienia predefiniowane
    12. Siatka i linie pomocnicze
    13. Gesty dotykowe
    14. Używanie paska Touch Bar w programie Photoshop
    15. Funkcje dotykowe i dostosowywanie obszarów roboczych
    16. Zapowiedzi technologii
    17. Metadane i uwagi
    18. Funkcje dotykowe i dostosowywanie obszarów roboczych
    19. Umieszczanie obrazów programu Photoshop w innych aplikacjach
    20. Miarki
    21. Pokazywanie i ukrywanie dodatków niedrukowanych
    22. Określanie kolumn dla obrazu
    23. Cofanie i historia
    24. Panele i menu
    25. Rozmieszczanie elementów za pomocą przyciągania
    26. Określanie położenia przy użyciu narzędzia Miarka
  11. Projektowanie stron internetowych, materiałów ekranowych i aplikacji
    1. Photoshop dla projektantów
    2. Obszary kompozycji
    3. Podgląd urządzenia
    4. Kopiowanie kodu CSS z warstw
    5. Cięcie stron internetowych na plasterki
    6. Opcje HTML dotyczące plasterków
    7. Modyfikowanie układu plasterków
    8. Korzystanie z grafiki internetowej
    9. Tworzenie internetowych galerii zdjęć
  12. Podstawowe informacje o obrazie i kolorach
    1. Zmienianie rozmiarów obrazów
    2. Korzystanie z obrazów rastrowych i wektorowych
    3. Rozmiar a rozdzielczość obrazu
    4. Pozyskiwanie obrazów z aparatów fotograficznych i skanerów
    5. Tworzenie, otwieranie i importowanie obrazów
    6. Wyświetlanie obrazów
    7. Błąd nieprawidłowego znacznika JPEG | Otwieranie obrazów
    8. Wyświetlanie wielu obrazów
    9. Dostosowywanie próbników kolorów i próbek
    10. Obrazy HDR
    11. Dopasowywanie kolorów na obrazie
    12. Konwertowanie obrazów z jednego trybu kolorów na inny
    13. Tryby kolorów
    14. Wymazywanie części obrazu
    15. Tryby mieszania
    16. Wybieranie kolorów
    17. Dostosowywanie tablic kolorów indeksowanych
    18. Informacje o obrazie
    19. Filtry zniekształcania są niedostępne
    20. Informacje o kolorach
    21. Dopasowania kolorowe i monochromatyczne przy użyciu kanałów
    22. Wybieranie kolorów w panelach Kolor i Próbki
    23. Próbka
    24. Tryb kolorów (tryb obrazu)
    25. Poświata kolorowa
    26. Dodawanie warunkowej zmiany trybu do operacji
    27. Dodawanie próbek z arkuszy CSS HTML i plików SVG
    28. Głębia bitowa i preferencje
  13. Warstwy
    1. Podstawy pracy z warstwami
    2. Bezpieczna edycja
    3. Tworzenie warstw i grup oraz zarządzanie nimi
    4. Zaznaczanie, grupowanie i łączenie warstw
    5. Umieszczanie obrazów w ramkach
    6. Krycie warstw i mieszanie
    7. Warstwy masek
    8. Stosowanie filtrów inteligentnych
    9. Kompozycje warstw
    10. Przenoszenie, układanie i blokowanie warstw
    11. Maskowanie warstw przy użyciu masek wektorowych
    12. Zarządzanie warstwami i grupami
    13. Efekty i style warstw
    14. Edytowanie masek warstw
    15. Wyodrębnianie zasobów
    16. Odsłanianie warstw przy użyciu masek przycinających
    17. Generowanie zasobów obrazów z warstw
    18. Korzystanie z obiektów inteligentnych
    19. Tryby mieszania
    20. Łączenie kilku obrazów w portret grupowy
    21. Łączenie obrazów przy użyciu automatycznego mieszania warstw
    22. Wyrównywanie i rozmieszczanie warstw
    23. Kopiowanie kodu CSS z warstw
    24. Wczytywanie zaznaczeń z warstwy lub obramowania maski warstw
    25. Odcinanie w celu odkrycia zawartości innych warstw
  14. Zaznaczenia
    1. Podstawy zaznaczania
    2. Zaznaczanie elementów kompozycji
    3. Przestrzeń robocza zaznaczania i maskowania
    4. Zaznaczanie narzędziami do zaznaczania prostokątnego
    5. Zaznaczanie przy użyciu narzędzi Lasso
    6. Dopasowywanie zaznaczeń pikseli
    7. Przenoszenie, kopiowanie i usuwanie zaznaczonych pikseli
    8. Tworzenie tymczasowej szybkiej maski
    9. Zaznaczanie zakresu kolorów na obrazie
    10. Konwertowanie pomiędzy ścieżkami i krawędziami zaznaczenia
    11. Podstawy stosowania kanałów
    12. Zapisywanie zaznaczeń i masek kanału alfa
    13. Zaznaczanie ostrych obszarów obrazu
    14. Powielanie, dzielenie i scalanie kanałów
    15. Obliczenia dotyczące kanałów
  15. Dopasowywanie obrazów
    1. Zastępowanie kolorów obiektu
    2. Wypaczenie perspektywy
    3. Redukcja rozmyć wywołanych potrząśnięciami aparatu
    4. Przykłady użycia narzędzia Pędzel korygujący
    5. Eksportowanie tablic wyszukiwania kolorów
    6. Dopasowywanie ostrości i rozmycia obrazu
    7. Omówienie dopasowań kolorów
    8. Stosowanie dopasowania Jasność/Kontrast
    9. Dopasowywanie szczegółów cieni i obszarów oświetlonych
    10. Dopasowanie Poziomy
    11. Dopasowywanie barwy i nasycenia
    12. Dopasowanie jaskrawości
    13. Dopasowywanie nasycenia koloru na obszarach obrazu
    14. Szybkie dopasowania tonalne
    15. Stosowanie do obrazów specjalnych efektów kolorów
    16. Ulepszanie obrazu przy użyciu korekt balansu kolorów
    17. Obrazy HDR
    18. Wyświetlanie histogramów i wartości pikseli
    19. Dopasowywanie kolorów na obrazie
    20. Kadrowanie i prostowanie zdjęć
    21. Konwertowanie obrazów kolorowych na czarno-białe
    22. Warstwy dopasowań i wypełnień
    23. Dopasowywanie krzywych
    24. Tryby mieszania
    25. Przygotowywanie obrazów do druku
    26. Dopasowywanie kolorów i odcieni obrazu przy użyciu kroplomierzy Poziomy i Krzywe
    27. Dopasowywanie ekspozycji i tonowania obrazu HDR
    28. Rozjaśnianie lub ściemnianie obszarów obrazu
    29. Dopasowania koloru selektywnego
  16. Adobe Camera Raw
    1. Wymagania systemowe wtyczki Camera Raw
    2. Nowości we wtyczce Camera Raw
    3. Wprowadzenie do wtyczki Camera Raw
    4. Tworzenie obrazów panoramicznych
    5. Obsługiwane obiektywy
    6. Efekty winiety, ziarnu i usuwania zmętnienia atmosferycznego we wtyczce Camera Raw
    7. Domyślne skróty klawiaturowe
    8. Automatyczna korekcja perspektywy we wtyczce Camera Raw
    9. Filtr promieniowy we wtyczce Camera Raw
    10. Zarządzanie ustawieniami wtyczki Camera Raw
    11. Otwieranie, przetwarzanie i zapisywanie obrazów we wtyczce Camera Raw
    12. Naprawa obrazów za pomocą ulepszonego narzędzia Usuwanie plam we wtyczce Camera Raw
    13. Obracanie, kadrowanie i dopasowywanie obrazów
    14. Dopasowywanie renderowania koloru we wtyczce Camera Raw
    15. Wersje procesu we wtyczce Camera Raw
    16. Wprowadzanie lokalnych dopasowań we wtyczce Camera Raw
  17. Naprawianie i przywracanie obrazów
    1. Usuwanie obiektów ze zdjęć przy użyciu funkcji Wypełnij z uwzględnieniem zawartości
    2. Uwzględniające zawartość narzędzia Łatka i Przesuwanie
    3. Retuszowanie i naprawianie zdjęć
    4. Korygowanie zniekształceń i szumu na obrazie
    5. Podstawowe czynności pozwalające rozwiązać większość problemów
  18. Ulepszanie i przekształcanie obrazów
    1. Zastępowanie nieba na obrazach
    2. Przekształcanie obiektów
    3. Dopasowywanie kadrowania, obrotów i obszaru roboczego
    4. Kadrowanie i prostowanie zdjęć
    5. Tworzenie i edytowanie obrazów panoramicznych
    6. Wypaczanie obrazów, kształtów i ścieżek
    7. Punkt zbiegu
    8. Skalowanie z uwzględnieniem zawartości
    9. Przekształcanie obrazów, kształtów i ścieżek
  19. Rysowanie i malowanie
    1. Malowanie wzorków symetrycznych
    2. Rysowanie prostokątów i modyfikowanie opcji obrysu
    3. Informacje o rysowaniu
    4. Rysowanie i edytowanie kształtów
    5. Narzędzia do malowania
    6. Tworzenie i modyfikowanie pędzli
    7. Tryby mieszania
    8. Dodawanie koloru do ścieżek
    9. Edytowanie ścieżek
    10. Malowanie za pomocą pędzla mieszającego
    11. Pędzle predefiniowane
    12. Gradienty
    13. Interpolacja gradientów
    14. Wypełnianie oraz obrysowywanie zaznaczeń, warstw i ścieżek
    15. Rysowanie narzędziami Pióro
    16. Tworzenie wzorków
    17. Generowanie wzorku przy użyciu wtyczki Tworzenie wzorku
    18. Zarządzanie ścieżkami
    19. Zarządzanie bibliotekami i wzorkami predefiniowanymi
    20. Rysowanie lub malowanie przy użyciu tabletów graficznych
    21. Tworzenie pędzli z teksturami
    22. Dodawanie dynamicznych elementów do pędzli
    23. Gradient
    24. Malowanie stylizowanych pociągnięć pędzlem przy użyciu narzędzia Artystyczny pędzel historii
    25. Malowanie wzorkiem
    26. Synchronizacja ustawień predefiniowanych między urządzeniami
    27. Migracja ustawień predefiniowanych, operacji i ustawień
  20. Tekst
    1. Dodawanie i edytowanie tekstu
    2. Jednolity mechanizm tekstowy
    3. Korzystanie z czcionek SVG OpenType
    4. Formatowanie znaków
    5. Formatowanie akapitów
    6. Tworzenie efektów tekstowych
    7. Edytowanie tekstu
    8. Odstępy między wierszami i między znakami
    9. Tekst arabski i hebrajski
    10. Czcionki
    11. Rozwiązanie problemów z czcionkami
    12. Tekst azjatycki
    13. Tworzenie tekstu
  21. Filtry i efekty
    1. Korzystanie z galerii rozmyć
    2. Podstawowe informacje dotyczące filtrów
    3. Dokumentacja efektów filtrów
    4. Dodawanie efektów świetlnych
    5. Korzystanie z filtra Adaptacyjny szeroki kąt
    6. Korzystanie z filtra Farba olejna
    7. Korzystanie z filtra Formowanie
    8. Efekty i style warstw
    9. Stosowanie określonych filtrów
    10. Smużenie obszarów obrazu
  22. Zapisywanie i eksportowanie
    1. Zapisywanie plików w programie Photoshop
    2. Eksportowanie plików w programie Photoshop
    3. Obsługiwane formaty plików
    4. Zapisywanie plików w formatach graficznych
    5. Przenoszenie projektów między programami Photoshop i Illustrator
    6. Zapisywanie i eksportowanie materiałów wideo i animacji
    7. Zapisywanie plików PDF
    8. Technologia ochrony praw autorskich Digimarc
  23. Zarządzanie kolorami
    1. Omówienie zarządzania kolorami
    2. Utrzymywanie spójności kolorów
    3. Ustawienia kolorów
    4. Bichromia
    5. Korzystanie z profilów kolorów
    6. Zarządzanie kolorami dokumentów przeznaczonych do wyświetlania w Internecie
    7. Zarządzanie kolorami w dokumentach podczas drukowania
    8. Zarządzanie kolorami w przypadku obrazów importowanych
    9. Próby kolorów
  24. Projektowanie stron internetowych, materiałów ekranowych i aplikacji
    1. Photoshop dla projektantów
    2. Obszary kompozycji
    3. Podgląd urządzenia
    4. Kopiowanie kodu CSS z warstw
    5. Cięcie stron internetowych na plasterki
    6. Opcje HTML dotyczące plasterków
    7. Modyfikowanie układu plasterków
    8. Korzystanie z grafiki internetowej
    9. Tworzenie internetowych galerii zdjęć
  25. Wideo i animacja
    1. Edytowanie materiałów wideo w programie Photoshop
    2. Edytowanie warstw wideo i animacji
    3. Omówienie zagadnień dotyczących wideo i animacji
    4. Wyświetlanie podglądu wideo i animacji
    5. Malowanie klatek na warstwach wideo
    6. Importowanie plików wideo i sekwencji obrazów
    7. Tworzenie animacji poklatkowych
    8. Creative Cloud 3D Animation (zapowiedź)
    9. Tworzenie animacji z osią czasu
    10. Tworzenie obrazów do materiałów wideo
  26. Drukowanie
    1. Drukowanie obiektów 3D
    2. Drukowanie w programie Photoshop
    3. Drukowanie z zastosowaniem zarządzania kolorami
    4. Stykówki i prezentacje PDF
    5. Drukowanie zdjęć w układzie pakietu obrazów
    6. Drukowanie kolorów dodatkowych
    7. Profesjonalne drukowanie obrazów
    8. Poprawianie jakości wydruków w kolorze z programu Photoshop
    9. Rozwiązywanie problemów z drukowaniem | Photoshop
  27. Automatyzacja
    1. Tworzenie operacji
    2. Tworzenie grafiki zależnej od danych
    3. Korzystanie ze skryptów
    4. Przetwarzanie wsadowe plików
    5. Odtwarzanie operacji i zarządzanie nimi
    6. Dodawanie operacji warunkowych
    7. Informacje o operacjach i panelu Operacje
    8. Nagrywanie narzędzi w operacjach
    9. Dodawanie warunkowej zmiany trybu do operacji
    10. Zestaw narzędzi do tworzenia wtyczek i skryptów interfejsu programu Photoshop
  28. Rozwiązywanie problemów
    1. Rozwiązane problemy 
    2. Znane problemy
    3. Optymalizacja wydajności programu Photoshop
    4. Podstawowe rozwiązywanie problemów
    5. Rozwiązywanie problemów z awariami i zawieszeniami
    6. Usuwanie błędów programu
    7. Rozwiązywanie problemu z zapełnionym dyskiem magazynującym
    8. Rozwiązywanie problemów z GPU i sterownikiem graficznym
    9. Znajdowanie brakujących narzędzi
    10. Photoshop — 3D | Często zadawane pytania dotyczące wycofanych funkcji

Jeśli program Photoshop działa na komputerze wolniej niż jest to oczekiwane, wypróbuj porady i techniki opisane w tym dokumencie

  Wycofanie funkcji 3D z programu Photoshop

Funkcje 3D w programie Photoshop zostaną usunięte w przyszłych aktualizacjach. Zachęcamy użytkowników funkcji 3D do korzystania z nowej kolekcji Adobe Substance 3D, która obejmuje nową generację narzędzi 3D firmy Adobe. Więcej informacji na temat wycofania funkcji 3D z programu Photoshop można znaleźć tutaj: Photoshop 3D | Często zadawane pytania dotyczące wycofanych funkcji 3D.

Ogólna procedura zwiększania wydajności

Konfiguracja każdego użytkownika jest inna i wymaga innej kombinacji technik, aby uzyskać jak największą wydajność programu Photoshop. Korzystając z propozycji podanych w niniejszym artykule, przemyśl, które rozwiązania chcesz zastosować odnośnie swojej konfiguracji komputerowej, typów używanych plików i konkretnych obiegów pracy. Istnieją cztery podstawowe sposoby wpływające na wydajność programu Photoshop — optymalizacja konfiguracjioptymalizacja systemu operacyjnego do współpracy z programem Photoshopustawianie preferencji związanych z wydajnością oraz dostrajanie funkcji programu Photoshop.

Najprostszym, darmowym sposobem na polepszenie wydajności jest ustawienie preferencji programu Photoshop i dostrojenie jego funkcji odpowiednio do swojej pracy i typu plików, na których zazwyczaj pracujesz.

Skrajnym rozwiązaniem mającym na celu poprawę wydajności jest inwestycja w szybszy i wydajniejszy sprzęt.Komputer musi spełniać minimalne wymagania systemowe, aby program Photoshop działał na nim optymalnie. Używanie programu Photoshop na za słabym lub nieobsługiwanym sprzęcie — na przykład na komputerze z niezgodnym GPU — może spowodować problemy z wydajnością. 

Ustawianie preferencji związanych z wydajnością

Obejrzyj to krótkie wideo, aby dowiedzieć się, jak szybko zoptymalizować preferencje związane z wydajnością w programie Photoshop.

Program Photoshop udostępnia zestaw preferencji (Preferencje > Wydajność), które pomagają zoptymalizować użytkowanie zasobów komputera, np. pamięci, pamięci tymczasowej, procesora grafiki, monitorów itp. W zależności podstawowego zastosowania programu Photoshop i rodzaju dokumentów zwykle używanych do pracy, mogą mieć zastosowanie różne połączenia tych ustawień.

Dodatkowe ustawienia, takie jak Dyski magazynujące dostępne w innych zakładkach okna dialogowego Preferencji, mogą mieć bezpośredni wpływ na szybkość pracy komputera i jego stabilność.

Preferencje wydajności programu Photoshop

Dopasowywanie przydzielania pamięci przez program Photoshop

Możesz poprawić wydajność, zwiększając ilość pamięci/REM przypisanej do programu Photoshop. W obszarze Użycie pamięci w oknie dialogowym preferencji Wydajności (Preferencje > Wydajność) podane jest, ile pamięci RAM jest dostępne dla programu Photoshop. Wyświetlony jest tam również idealny zakres przypisanej pamięci dla programu Photoshop dla danego systemu.

Domyślnie program Photoshop zużywa 70% dostępnej pamięci RAM.

  1. Zwiększ ilość pamięci RAM przypisanej do programu Photoshop, zmieniając wartość w polu Program Photoshop ma używać. Ewentualnie dostosuj suwakiem Użycie pamięci.
  2. Uruchom ponownie program Photoshop, aby zastosować zmiany.

Aby znaleźć idealną alokację pamięci RAM dla Twojego systemu, zmieniaj ją stopniowo o 5% i obserwuj wydajność na wskaźniku wydajności. 

Nie zalecamy przypisywanie więcej niż 85% pamięci komputera dla programu Photoshop. Takie postępowanie wpływa na wydajność, nie pozostawiając pamięci dla innych kluczowych aplikacji systemowych.

Uwaga:

Jeżeli pojawią się błędy typu brak pamięci RAM lub brak pamięci w programie Photoshop, spróbuj zwiększyć ilość pamięci RAM przypisanej do programu Photoshop. Jednak zbyt duża ilość przypisanej pamięci RAM dla programu Photoshop (>85%) może wpływać na wydajność innych uruchomionych aplikacji, powodując niestabilność systemu. 

Najlepszym rozwiązaniem dla tego programu jest zwiększenie ilości pamięci RAM komputera. Skontaktuj się z producentem komputera, aby uzyskać informacje na temat specyfikacji i zgodności pamięci RAM.

Dopasowywanie poziomów buforowania

Podstawy bufora

Program Photoshop używa buforowania obrazu, aby przyspieszyć odrysowywanie dokumentów o wysokiej rozdzielczości w czasie pracy z tymi programami. Możesz określić maksymalnie osiem poziomów danych buforowanego obrazu i wybrać jeden z czterech dostępnych rozmiarów kafelków pamięci podręcznej.

Podwyższenie poziomów bufora polepsza reakcję programu Photoshop podczas pracy, lecz obrazy będą dłużej wczytywane. Rozmiar kafelków pamięci podręcznej określa ilość danych, na których w danej chwili operuje program Photoshop. Większe rozmiary kafelków przyspieszają kompleksowe operacje, takie jak filtry wyostrzające. Mniejsze zmiany, takie jak pociągnięcia pędzlem, reagują szybciej, gdy używane są mniejsze rozmiary kafelków.

Ustawienia przedefiniowane bufora

W Preferencjach wydajności dostępne są trzy ustawienia domyślne buforowania. Wybierz jedne, które pasują do podstawowego zastosowania/celu programu Photoshop:

  • Projektowanie stron internetowych/Interfejsu użytkownika: Wybierz tę opcję, jeśli używasz programu Photoshop do projektowania stron internetowych, aplikacji lub ekranów. Ta opcja nadaje się do dokumentów, które posiadają liczne warstwy z zasobami o niskiej lub średniej ilości pikseli.
  • Domyślny/Zdjęcia: Wybierz tę opcję, jeśli używasz programu Photoshop głównie do retuszowania lub edytowania obrazów o średnim rozmiarze. Na przykład, użyj tej opcji, jeśli zwykle edytujesz zdjęcia pochodzące z telefonu komórkowego lub z aparatu cyfrowego.
  • Rozmiary o bardzo dużej ilości pikseli: Wybierz tę opcję, jeśli dużo pracujesz z dużymi dokumentami w programie Photoshop, na przykład zdjęciami panoramicznymi, matowymi obrazami itp.

Poziomy bufora

Aby mieć lepszą kontrolę, można ręcznie określić poziomy bufora; wartość domyślna to 4.

  • Jeżeli korzystasz ze względnie małych plików — około 1 megapiksela lub 1 280 na 1 024 pikseli — i wielu warstw (przynajmniej 50), ustaw poziom bufora na 1 lub 2. Ustawienie poziomów bufora na 1 wyłącza buforowanie obrazu; buforowany jest wyłącznie bieżący obraz na ekranie.
  • Jeżeli korzystasz z plików o większych wymiarach w pikselach — przynajmniej 50 megapikseli — ustaw poziom bufora powyżej 4. Wyższe poziomy bufora przyspieszają odrysowywanie.
Uwaga:

Przy poziomie bufora 1 niektóre funkcje programu Photoshop nie dostarczają wyników o wysokiej jakości.

Ograniczanie stanów historii

Możesz zaoszczędzić miejsce na dysku magazynującym i polepszyć wydajność poprzez ograniczenie liczby stanów historii, które program Photoshop zapisuje w panelu Historia. Ilość zaoszczędzonego miejsca różni się w zależności od liczby pikseli, przy których dochodzi do zmiany operacji. Na przykład statystyka historii na podstawie małego pociągnięcia pędzla lub operacji z zachowaniem oryginałów, takich jak tworzenie lub modyfikowanie warstwy dopasowania, zużywa mało miejsca. Z drugiej strony stosowanie filtra do całego obrazu zużywa o wiele więcej miejsca.

Program Photoshop może zaoszczędzić do 1000 stanów historii; liczbą domyślną jest 50.

Aby zmniejszyć tę liczbę, przejdź do okna dialogowego Preferencje wydajności.W sekcji Historia i bufor
ustaw liczbę stanów historii na niższą wartość.

Określanie ustawień procesora graficznego (GPU)

Najlepszym sposobem na optymalizację przyspieszenia procesora GPU, który przyspiesza odrysowania ekranu, jest stałe aktualizowanie sterownika karty graficznej.  Aby uzyskać instrukcje aktualizowania sterowników kart wideo

Zapoznaj się z artykułem Aktualizacja sterowników graficznych.

Aby uzyskać więcej informacji o użyciu przez program Photoshop procesora graficznego, testowanych kartach i minimalnych wymaganiach dotyczących procesora graficznego i wyświetlacza. 

Zapoznaj się z artykułem Photoshop GPU i karta graficzna — najczęściej zadawane pytania.

Preferencje GPU

Program Photoshop udostępnia określone ustawienia GPU zarówno w sekcji Wydajność, jak i 3D w oknie dialogowym Preferencje.

Ustawienia w sekcji Preferencje > Wydajność

Jeśli karta graficzna zostanie wykryta w systemie, jej nazwa i model pojawią się w sekcji Wykryte procesory graficzne w obszarze Ustawienia procesora graficznego sekcji Wydajność.

Dodatkowe ustawienia zaawansowane:

  • Użyj funkcji OpenCL: Wyłącz tę opcję, jeśli funkcje Galeria rozmyć, Inteligentne wyostrzenie, Wybierz obszar ogniskowej lub Rozmiar obrazu z ustawieniem Zachowaj szczegóły nie działają zgodnie z oczekiwaniami.
  • Linie pomocnicze i ścieżki wygładzania: Wyłącz, jeśli linie i ścieżki są zbyt grube lub zbyt szerokie
  • Wyświetlacz 30-bitowy: Włącz, aby poprawić odwzorowanie kolorów na monitorze obsługującym wyświetlanie 30-bitowe.
Wyłączanie trybu OpenCL

Uwaga:

Włączenie technologii OpenCL może polepszyć wydajność, jeżeli korzystasz z następujących funkcji programu Photoshop:

  • Galeria rozmycia — rozmycie pola, przesłony, nachylenia/przesunięcia, ścieżki, obrotu (przyspieszenie OpenCL)
  • Inteligentne wyostrzenie (redukcja szumu — przyspieszenie OpenCL)
  • Zaznaczanie i maskowanie (przyspieszenie OpenCL)

Ustawienia w sekcji Preferencje > 3D

Sekcja 3D okna dialogowego wydajności zawiera suwak VRAM, podobny do sterowania pamięcią, który znajduje się w sekcji Wydajność. Użyj suwaka, aby określić górny limit pamięci RAM wideo (VRAM) dostępnej dla silnika 3D programu Photoshop. Całkowita wartość procentowa całej dostępnej pamięci VRAM. Ustawienie 100% spowoduje zarezerwowanie całej pamięci VRAM na potrzeby systemu operacyjnego. Większa wartość wspomoże ogólną wydajność 3D, ale może konkurować z innymi aplikacjami obsługiwanymi przez GPU.

Użycie pamięci w kontekście grafiki 3D

Zarządzanie dyskami magazynującymi

Uwaga:

Jeśli nie można uruchomić programu Photoshop z powodu zapełnienia dysku magazynującego, przytrzymaj klawisze Command + Option (macOS) lub Control + Alt (Windows) przy uruchamianiu, aby ustawić nowy dysk magazynujący.

Kiedy pracujesz kreatywnie w programie Photoshop, może wystąpić błąd dysku magazynującego, który uniemożliwia ukończenie jakiegoś zadania. Ale co to jest dysk magazynujący?

Więcej informacji o zarządzaniu preferencjami dysków magazynujących i ich zalecanych ustawieniach znajdziesz w artykule Konfigurowanie dysków magazynujących.

Więcej informacji o błędach w przypadku dysków magazynujących znajdziesz w artykule Rozwiązywanie problemów z dyskiem magazynującym w programie Photoshop.

Wskaźnik wydajności

Obserwuj wskaźnik wydajności, aby monitorować wydajność podczas pracy w programie Photoshop.Kliknij menu podręczne na dole okna obrazu i wybierz opcję Wydajność z wyskakującego menu.

Jeżeli wartość wskaźnika jest poniżej 100%, program Photoshop zużył całą dostępną pamięć RAM i używa teraz dysku magazynującego, co spowalnia wydajność. Jeżeli wydajność spadła poniżej 90%, alokuj więcej pamięci RAM do programu Photoshop w preferencjach wydajności. Alternatywnie możesz zwiększyć pamięć RAM komputera.

Wskaźnik wydajności

Dopasowanie funkcji programu Photoshop do wydajności

Wyłączanie linijek i nakładek

Widoczne linijki i nakładki (takie jak siatki, kawałki lub inteligentne linie pomocnicze) mogą spowalniać niektóre operacje, takie jak malowanie, transformacje i przeciąganie warstw na obszarze roboczym.

  • Aby wyłączyć linijki, w menu Widok usuń zaznaczenie opcji Linijki.
  • Aby wyłączyć nakładki, wybierz polecenie Widok> Pokaż > Brak lub wyłącz poszczególne elementy.

Patrz: Pokazywanie i ukrywanie dodatków niedrukowanych.

Praca w ramach ograniczeń wielkości pliku

Bardzo duże pliki są często przyczyną problemów z wydajnością.

Program Photoshop obsługuje pliki o maksymalnej wielkości 300 000 x 300 000 pikseli, poza plikami PDF, które są ograniczone do 30 000 x 30 000 pikseli i 200 x 200 cali. Program Camera Raw obsługuje obrazy o maksymalnej szerokości lub długości 65 000 pikseli i maksymalnie 512 megapikseli.

Obsługiwane wielkości plików w programie Photoshop:

  • Pliki PSD: 2 GB
  • Pliki TIFF: 4 GB
  • Pliki PSB: 4 eksabajty (4 096 petabajtów lub 4 miliony terabajtów)
  • Pliki PDF: 10 GB (strony są ograniczone do maksymalnej wielkości 200 cali)

Zamknij zbędne okna dokumentów

Jeżeli pojawi się komunikat o błędzie „Brak pamięci RAM” lub jeśli program Photoshop działa powoli, może to być spowodowane zbyt dużą liczbą otwartych obrazów. Jeżeli otwartych jest kilka okien, zamknij niektóre z nich.

Zmniejszanie liczby ustawień wstępnych

Aby ograniczyć używaną przez program Photoshop ilość miejsca na dysku magazynującym, zmniejsz liczbę wczytywanych ustawień wstępnych. Wzory i końcówki pędzli należą do największych ustawień wstępnych. Zapisz ustawienia wstępne, których obecnie nie potrzebujesz, w pliku ustawień wstępnych, a następnie usuń je i wczytuj tylko wtedy, kiedy ich potrzebujesz.

Więcej informacji na temat zarządzeniem ustawieniami predefiniowanymi znajdziesz w artykule Ustawienia predefiniowane.

Minimalizowanie lub wyłączanie miniaturek podglądu panelu

Przy każdej zmianie dokumentu program Photoshop aktualizuje wszystkie miniaturki widoczne w panelach Warstwy i Kanały. Ta aktualizacja może mieć wpływ na czas reakcji w przypadku szybkiego malowania, przenoszenia lub poruszania warstw. Im więcej miniaturek jest widocznych, tym bardziej wyraźny jest ten efekt.

Aby zminimalizować lub wyłączyć podglądy miniaturek, kliknij menu panelu i wybierz polecenie Opcje panelu. Zaznacz mniejszy rozmiar miniaturki i wybierz opcję Brak, a następnie kliknij przycisk OK.

Zmiana opcji zgodności plików

Jeżeli nie musisz pracować na plikach PSD i PSB w starszych wersjach programu Photoshop lub w aplikacjach, które nie obsługują warstw, możesz wyłączyć funkcję zgodności plików, aby przyspieszyć zapisywanie dokumentów:

  1. W panelu Preferencje > Obsługa plików, dla 16-bitowych i 32-bitowych dokumentów PSD i PSB wybierz opcję Wyłącz kompresję plików PSD i PSB.

  2. W menu Maksymalizuj zgodność plików PSD i PSB wybierz opcję Zapytaj lub Nigdy.

Praca w trybie obrazu 8-bitowego

Program Photoshop może wykonywać wiele operacji na obrazach 16-bitowych i 32-bitowych. Obrazy te wymagają jednak więcej pamięci, miejsca do magazynowania i czasu do przetwarzania niż obrazy 8-bitowe.

Aby przekonwertować obraz na 8 bitów na kanał, wybierz opcję Obraz > Tryb > 8 bitów/kanał.

Więcej informacji znajdziesz w artykule Głębia bitowa i preferencje.

Uwaga:

Przekształcanie na 8 bitów na kanał usunie dane z obrazu. Zachowaj kopię oryginalnego obrazu 16-bitowego lub 32-bitowego zanim przekształcisz go na 8 bitów na kanał.

Wyłączanie podglądu czcionki

Aby przyspieszyć przetwarzanie czcionek w programie Photoshop, wyłącz listę podglądu czcionki, wybierając opcję Tekst > Rozmiar podglądu czcionki > Brak.

Zmniejszanie rozdzielczości obrazu

Im większa rozdzielczość obrazu, tym więcej pamięci i miejsca na dysku program Photoshop wymaga do wyświetlania, przetwarzania i wydrukowania obrazu. W zależności od ostatecznego wyniku, wyższa rozdzielczość obrazu niekoniecznie gwarantuje wyższą ostateczną jakość obrazu, lecz może spowalniać wydajność, zużywać dodatkowe miejsce na dysku magazynującym i spowalniać drukowanie. Optymalna rozdzielczość obrazu zależy od sposobu wyświetlania lub drukowania obrazów. 

W przypadku obrazów wyświetlanych na ekranie uwzględnij łączną wielkość w pikselach. Aby zmniejszyć wymiary dowolnego obrazu, wybierz opcję Obraz > Rozmiar obrazu. Upewnij się, że w oknie dialogowym Rozmiar obrazu wybrano opcję Ponowne próbkowanie. Podaj nową wartość szerokości i wysokości. Podanie jednej z tych wartości zmieni obie.

Zwiększenie rozdzielczości drukowanych obrazów powyżej około 360 DPI przyniesie co najwyżej minimalne korzyści. Jeżeli produkujesz wiele wydruków, spróbuj znaleźć rozdzielczość, która daje optymalny wynik. Aby zmniejszyć rozdzielczość dowolnego obrazu, wybierz opcję Obraz > Rozmiar obrazu. W oknie dialogowym Rozmiar obrazu zaznacz opcję Zmień próbkowanie. Zmień wartości szerokości i wysokości tak, aby odzwierciedlały fizyczny rozmiar drukowanego dokumentu. Następnie zmniejsz wartość rozdzielczości i kliknij przycisk OK.

Jeżeli zamierzasz zwiększyć rozdzielczość obrazu do drukowania zamiast ją zmniejszyć, przeprowadź tę operację jako jeden z ostatnich kroków przed wydrukowaniem obrazu. W ten sposób nie musisz przetwarzać wszystkich dodatkowych informacji we wcześniejszych krokach.

Czyszczenie pamięci

Możesz poprawić wydajność systemu poprzez zwolnienie nieużywanej pamięci lub miejsca na dysku magazynującym w programie Photoshop, aby udostępnić je innym programom. Aby to zrobić, wybierz jedną z poniższych opcji:

  • Edycja > Wyczyść > Wszystko
  • Edycja > Wyczyść > Cofnij
  • Przytrzymaj klawisz Option (macOS) lub Alt (Windows) i wybierz opcję Informacje o programie Photoshop

Jeżeli inne programy starają się aktywnie alokować lub używać pamięć, zwolnienie pamięci w programie Photoshop polepszy wydajność. Zwolnienie pamięci na dysku magazynującym będzie korzystne, jeżeli brakuje miejsca na woluminie dysku. Jeżeli zwolniono dużą ilość pamięci lub miejsca na dysku, następnym razem duże pliki programu będą się wolniej otwierać, gdy program Photoshop będzie alokował miejsce.

Jeżeli chcesz, aby program Photoshop zawsze używał mniej pamięci, wybierz opcję Edycja > Preferencje > Wydajność (Windows) lub Photoshop > Preferencje > Wydajność (macOS) i przesuń suwak użycia pamięci w lewo.

Zapoznaj się z tematem Dostosowanie użycia pamięci.

Uwaga:

Zarejestrowanie zmiany przez monitory aktywności, menedżery zadań i narzędzia dysku może potrwać kilka sekund. W przypadku niektórych narzędzi należy wyraźnie zażądać aktualizacji.

Czyszczenie schowka

Zawartość schowka może zajmować dużo miejsca w przypadku kopiowania i wklejania danych w dużych dokumentach. Po wklejeniu elementy te nie są do niczego potrzebne. Aby zwolnić pamięć RAM używaną przez dane obrazu w schowku, wybierz opcję Edycja > Wyczyść > Schowek.

Uwaga:

Polecenia Wyczyść nie można cofnąć.

Korzystanie z galerii filtrów

Galeria filtrów pozwala na przetestowanie jednego lub kilku filtrów na obrazie przed zastosowaniem efektów, co może znacznie zaoszczędzić czas i pamięć.

Zobacz Omówienie galerii filtrów.

Przeciąganie pomiędzy plikami zamiast kopiowania i wklejania

Przeciąganie warstw lub plików jest bardziej wydajne niż kopiowanie i wklejanie. W trakcie przeciągania omijany jest schowek i dane są przesyłane bezpośrednio. Kopiowanie i wklejanie może potencjalnie angażować więcej transferu danych i jest mniej wydajne.

Zapisywanie plików TIFF bez kompresji do formatu ZIP

Aby zwiększyć prędkość podczas eksportu plików TIFF, nie wybieraj kompresji ZIP. (Dzięki kompresji ZIP tworzone są jednak pliki TIFF o najmniejszych rozmiarach).

Nie eksportuj schowka

Opcja Eksportuj schowek powoduje, że program Photoshop udostępnia zawartość schowka innym programom. Jeżeli kopiujesz dużą ilość danych w programie Photoshop, ale nie będziesz ich kopiować do innych aplikacji, zaoszczędź czas poprzez wyłączenie tej opcji:

  1. Wybierz opcję Photoshop > Preferencje > Ogólne (macOS) lub Edycja > Preferencje > Ogólne (Windows).

  2. Odznacz opcję Eksportuj schowek.

  3. Kliknij przycisk OK.

Wyłączanie panelu Biblioteki

  1. Z menu rozwijanego Biblioteki wybierz polecenie Zamknij.

  2. Uruchom ponownie program Photoshop.

Wyłączanie Generatora

  1. Wybierz polecenia Edycja > Preferencje > Wtyczki.

  2. Usuń zaznaczenie opcji Włącz Generator.

  3. Kliknij przycisk OK.

Tworzenie kompozycji w programie Photoshop

Komponowanie (tworzenie kompozycji) to proces łączenia wielu elementów wizualnych w pojedynczą ramkę reprezentującą dokument. Wewnętrzny mechanizm komponowania programu Photoshop oblicza swoje dane tysiące razy podczas używania programu i nieustannie wyświetla wszystkie zmiany wprowadzone na obrazie jako pojedynczą kompozycję.

Komponowanie wielowątkowe

W wersji programu Photoshop 22.3 (kwiecień 2022 r.) można aktywować komponowanie wielowątkowe, wybierając opcję Preferencje > Wydajność i zaznaczając pole wyboru Komponowanie wielowątkowe. Aby ta zmiana zaczęła obowiązywać, nie trzeba uruchamiać ponownie programu Photoshop.

Komponowanie wielowątkowe

Wszelkie warstwy dopasowania, maski warstw, tryby mieszania, filtry, style i efekty wymagają dodatkowego przetwarzania dokumentu, co stopniowo spowalnia działanie programu Photoshop. Czasami po dodaniu wielu warstw i efektów można zauważyć, że zawartość ekranu wolniej reaguje na przeciąganie suwaków. Komponowanie wielowątkowe to mechanizm usprawniający zadania związane z tworzeniem kompozycji wymagające CPU i GPU. Obliczenia są dzielone na mniejsze części, które mogą być wykonywane równolegle. Często skraca to czas obliczeń w porównaniu do stosowania jednego wątku (wykonywania obliczeń po kolei).

Wolne reagowanie programu Photoshop podczas obróbki dokumentów może mieć wiele przyczyn, jednak przyspieszenie komponowania dzięki mechanizmowi wielowątkowemu (o 100–250%) bardzo pozytywnie wpływa na płynność działania środowiska.

Jeśli zauważysz błędy rysowania zawartości, które mogą wiązać się z komponowaniem wielowątkowym, możesz włączyć tę funkcję w kategorii Preferencje > Wydajność. Jeśli masz pytanie lub chcesz się podzielić pomysłem dotyczącym tego ustawienia, daj nam znać w społeczności użytkowników programu Adobe Photoshop. Zachęcamy do dzielenia się opiniami.

Uwaga:

Funkcja komponowania wielowątkowego zastępuje wyświetlane dawniej ostrzeżenie o mechanizmie komponowania starszego typu. To ostrzeżenie nie jest już potrzebne, dlatego zostało usunięte.

Komponowanie z przyspieszaniem GPU

W programie Photoshop 22.3 (kwiecień 2022 r.) dodano mechanizm komponowania oparty na GPU. Poprawia on płynność działania niektórych operacji na warstwach dokumentów. Komponowanie przy użyciu GPU jest dostępne tylko pod warunkiem, że program Photoshop prawidłowo wykrywa GPU przy uruchamianiu. Aby to sprawdzić, przejdź do kategorii Preferencje > Wydajność i upewnij się, że GPU widnieje w sekcji Ustawienia procesora graficznego i jest zaznaczona opcja Używaj procesora graficznego.

Aby wyświetlić pole wyboru przełączania komponowania przy użyciu GPU, kliknij przycisk Ustawienia zaawansowane.

Komponowanie przy użyciu GPU

W przypadku mniej złożonych dokumentów, które zawierają niewiele warstw i dopasowań na warstwach (np. trybów mieszania czy warstwy dopasowania) przełączanie trybów mieszania czy widoczności warstw może nie wpływać zauważalnie na wydajność. W miarę wzrostu złożoności dokumentów mechanizm komponowania programu Photoshop musi przetwarzać więcej danych w tym samym czasie, przez co wyświetlanie wyników zmian na ekranie może być opóźnione. Bardzo złożone dokumenty mogą powodować zauważalne opóźnienia między użyciem funkcji a przesunięciem zawartości warstw czy zmianą krycia na ekranie. Komponowanie przy użyciu GPU pozwala programowi Photoshop szybciej przetwarzać kompozycje, co zapewnia jego płynniejsze działanie.

Jeśli podczas edytowania przy użyciu warstw wystąpią nieoczekiwane wyniki, możesz wyłączyć komponowanie przy użyciu GPU, aby potencjalnie wyeliminować problem. 

Masz pytanie lub pomysł?

Zapytaj społeczność

Jeśli masz pytanie lub chcesz się podzielić pomysłem, dołącz do nas na forum użytkowników programu Adobe Photoshop. Zachęcamy do dzielenia się opiniami.


Adobe

Pomoc dostępna szybciej i łatwiej

Nowy użytkownik?

Adobe MAX 2024

Adobe MAX
The Creativity Conference

14–16 października, plaża Miami Beach i online

Adobe MAX

The Creativity Conference

14–16 października, plaża Miami Beach i online

Adobe MAX 2024

Adobe MAX
The Creativity Conference

14–16 października, plaża Miami Beach i online

Adobe MAX

The Creativity Conference

14–16 października, plaża Miami Beach i online