Find and group effects

Standard effects are listed in the Effects panel and are organized into two main bins, Video Effects and Audio Effects. Within each bin, Premiere Pro lists effects by type in nested bins. For example, the Blur and Sharpen bin contains effects that defocus an image, such as Gaussian Blur and Directional Blur.

Find audio effects in bins named for the type of audio clips they support: mono, stereo, or 5.1.

You can also locate an effect by typing the effect name in the Contains box.

To open the Effects panel, choose Window > Effects, or click the Effects tab.

Karl Soule explains the meanings of the icons for 32-bit (32-bpc) and YUV effects in a pair of articles from his Adobe blog:

Filter effects by type

Three buttons appear under the search field toward the upper left of the Effects panel. These buttons act as filters for three types of effects:

When you toggle one of these buttons on, only effects and transitions of its type are shown in the list of effects below. You can toggle one or more of these buttons to filter the list of effects for any combination of attributes.

Note:

Acceleration is available for an accelerated effect only when a supported video card is installed. If a supported video card is not installed, the Accelerated Effects filter button still functions. The Accelerated Effects badge is shown in a disabled state to indicate that acceleration is not available.

Create bins of favorite effects

  1. In the Effects panel, click the New Custom Bin button , or choose New Custom Bin from the Effects panel menu. A new Custom bin appears in the Effects panel. You can rename it.
  2. Drag effects to the Custom bin. A copy of the effect is listed in the Custom bin. You can create additional Custom bins, which are numbered.
  3. To rename the custom bin, click the existing name to select the folder, click it again to select the name field, and type the new name.

Remove a Custom bin

  1. In the Effects panel, select a Custom bin and do one of the following:
    • Click the Delete Custom Items button .

    • Choose Delete Custom Items from the Effects panel menu.

    • Press Delete.

    • Press Backspace.

    Note:

    You can remove Custom bins only from the Effects panel.

  2. Click OK.

Apply effects to clips

You can apply one or more Standard effects to a clip by dragging effect icons from the Effects panel to a clip in the Timeline panel. Alternatively, select the clip and double-click an effect in the Effects panel to apply it. You can apply the same effect multiple times, using different settings each time.

You can apply Standard effects to more than one clip at a time by first selecting all the clips you want to affect.

You can also temporarily disable any effect, which suppresses the effect without removing it, or you can remove the effect completely.

To view and adjust effects for a selected clip, use the Effect Controls panel. Alternatively, you can view and adjust effects for a clip in the Timeline panel by expanding its track and selecting the proper viewing options.

By default, when you apply an effect to a clip, the effect is active for the duration of the clip. However, you can make an effect start and stop at specific times or make the effect more or less intense by using keyframes.

  1. Do one of the following:
    • To apply one or more effects to a single clip, select and drag the effects to the clip in the Timeline.

    • To apply one or more effects to more than one clip, first select the clips. Control-click (Windows) or Command-click (Mac OS) each of the desired clips in the Timeline. Then, drag one effect or a selected group of effects to any of the selected clips.

    • Select a clip, and then double click the effect.

    To apply an audio effect, drag the effect to an audio clip or the audio portion of a video clip. You cannot apply audio effects to a clip when Show Track Volume or Show Track Keyframes is enabled for the Audio track.

    Note:

    If the clip is selected in the Timeline panel, you can drag the effect directly to the Effect Controls panel.

  2. In the Effect Controls panel, click the triangle to show options for any effect, and then specify the option values.

Copy and paste clip effects

You can easily copy and paste effects from one clip to one or more other clips. For example, you can apply identical color correction to a series of clips shot in similar lighting conditions. You can copy effects from a clip in one track of a sequence and paste them onto clips in another track. You do not have to target the destination track.

You can copy and paste individual effects in the Effect Controls panel. You can also copy all effect values (including keyframes for Fixed and Standard effects) from a clip in any sequence. You can paste these values to another clip in any sequence using the Paste Attributes command. With Paste Attributes, effects intrinsic to the source clip—Motion, Opacity, Time Remapping, and Volume—replace those effects in the destination clips. All other effects (including keyframes) are added to the list of effects already applied to the destination clips.

If the effect includes keyframes, these keyframes appear at comparable positions in the target clip, starting at the beginning of the clip. If the target clip is shorter than the source clip, keyframes are pasted beyond the target clip Out point. To view these keyframes, move the clip Out point to a time later than the location of the keyframe, or deselect the Pin To Clip option.

Note:

You can also copy and paste keyframes from one effect parameter to another compatible effect parameter. See Copy and paste keyframes.

  1. In the Timeline panel, select the clip that contains the effect or effects you want to copy.

  2. (Optional) To select one or more effects to copy, in the Effect Controls panel, select the effect you want to copy. Shift-click to select multiple effects. To select all effects, skip this step.
  3. Choose Edit > Copy.
  4. In the Timeline panel, select the clip to which you want to paste the effect and choose one of the following:

    • To paste one or more effects, choose Edit > Paste.

    • To paste all effects, choose Edit > Paste Attributes.

Remove selected effects from a clip

  1. Select a clip in the Timeline panel. To make sure that only one clip is selected, click an empty space in the Timeline, then click the clip. Click a spot in the time ruler above the selected clip to move the current-time indicator to that location.

  2. In the Effect Controls panel, select the effect or effects you want to remove. To select more than one, Ctrl-click (Windows), or Command-click (Mac OS) the effects.

    Note:

    You cannot remove Fixed effects: Motion, Opacity, Time Remapping, or Volume.

  3. Do one of the following:
    • Press Delete or Backspace.

    • Choose Remove Selected Effect from the Effect Controls panel menu.

Remove all effects from a clip

  1. Select a clip in the Timeline panel. To make sure that only one clip is selected, click an empty space in the Timeline, then click the clip. Click a spot in the time ruler above the selected clip to move the current-time indicator to that location.

  2. Do one of the following:
    • From the Effect Controls panel menu, choose Remove Effects

    • Select Clip > Remove Effects

    • Right-click a clip in a Timeline panel, and select Remove Effects.

  3. in the Remove Effects dialog box, select the types of effects you want to remove, and click OK.

All selected applied effect types are removed from the clip and all selected intrinsic effects are returned to their default settings.

Disable or enable effects in a clip

  • Select one or more effects in the Effect Controls panel, and do one of the following:
    • Click the Effect button to disable effects.

    • Click an empty Effect button box to enable effects.

    • Deselect or select the Effect Enabled command in the Effect Controls panel menu.

    Note:

    You can create a custom keyboard shortcut for the Effect Enabled command. This will toggle an effect on and off. 

Use FX badges

An FX badge is an icon in the Timeline that lets you easily identify if an effect has been applied to a clip. Click the Settings icon in the Timeline and select Show FX badges to display the badges in the Timeline.

Premiere Pro offers FX badges in different colors. Just by looking at the badge color, you can determine if you have applied an effect, modified an intrinsic effect, and so on.  

Use FX badges
A. Gray FX badge B. Purple FX badge C. Yellow FX badge D. Green FX badge 
Use FX badges
Red underlined FX badge

FX badge color
Denotes
Gray No effect applied (default badge color)
Purple Non-intrinsic effect applied (like, color correction, blur)
Yellow Intrinsic effect modified (like, position, scale, opacity)  
Green   Intrinsic effect modified and additional effect applied
Red underline Master Clip effect applied

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy