Создание изображений, управляемых данными

Последнее обновление 2 нояб. 2026 г.

Используйте переменные и наборы данных, чтобы создать несколько версий шаблона с разным текстом и изображениями.

Графика на основе данных позволяет создавать несколько вариантов изображения из одного шаблона: вы определяете, какие элементы изменяются, и предоставляете содержимое для замены с помощью наборов данных.

Этот технологический процесс применяется, когда нужно создать несколько версий дизайна с разным текстом, изображениями или видимостью слоев, например Web-баннеры для разных продуктов, именные сертификаты или локализованные маркетинговые материалы.В шаблоне нужно использовать отдельные слои для каждого элемента, который требуется изменять.Дополнительные сведения об импорте наборов данных из внешних текстовых файлов см. в соответствующей статье об импорте наборов данных.

Photoshop поддерживает три типа переменных, которые управляют различными аспектами шаблона.Переменные видимости определяют, отображается ли содержимое слоя.Text Replacement — переменные, которые заменяют строки в текстовых слоях.Pixel Replacement — переменные, которые заменяют пиксели слоя содержимым из файлов изображений.К одному шаблону можно применить несколько типов переменных и связать несколько слоев с одной переменной для согласованных изменений.

Определите переменные для элементов шаблона

Выберите Image > Variables > Define.

В меню Layer выберите слой, который содержит нужное для изменения содержимое.

Выберите один или несколько типов переменных: Visibility, Text Replacement или Pixel Replacement.

Введите имя в поле Name, используя буквы, символы подчеркивания, двоеточия, точки или дефисы без пробелов.

Выберите метод масштабирования (Fit, Fill, As Is или Conform) для переменных Pixel Replacement.

Выберите положение выравнивания и установите флажок Clip To Bounding Box.

Повторите действие для дополнительных слоев и затем выберите OK.

Слои, содержащие переменные, отображаются в диалоговом окне со звездочкой рядом с именем.Чтобы переименовать переменную, вернитесь в меню Image > Variables > Define, выберите слой и введите новое имя в поле Name.Чтобы связать несколько слоев с одной переменной, выберите существующее имя переменной в раскрывающемся меню Name при определении переменных для дополнительных слоев.

Создавайте и управляйте наборами данных

Выберите Image > Variables > Data Sets.

Выберите значок нового набора данных, чтобы создать набор данных на основе текущих значений.

Выберите переменную в меню Name.

Измените данные переменной.

  • Для переменных Видимость: выберите Видимый или Невидимый
  • Для переменных Замена пикселей: выберите Файл и укажите изображение для замены
  • Для переменных Замена текста: введите текст в поле Значение.

Повторите действие для каждой переменной набора данных.

Создайте дополнительные наборы данных для каждого нужного варианта дизайна.

По завершении нажмите «ОК».

Просмотрите, как каждый набор данных влияет на дизайн: перейдите в Изображение > Применить набор данных, выберите набор данных из списка и нажмите Применить.Также можно установить флажок Предварительный просмотр в диалоговом окне Наборы данных, чтобы видеть изменения, не закрывая окно.

Используйте значки со стрелками в диалоговом окне Наборы данных для перехода между наборами данных.Чтобы изменить существующий набор данных, выберите его в меню Набор данных и измените значения переменных.Чтобы удалить набор данных, выберите его и нажмите значок удаления.

Создание выходных файлов из наборов данных

Выберите Файл > Экспорт > Наборы данных в виде файлов.

Введите базовое имя для создаваемых файлов в поле имени.

Выберите Папка и укажите папку назначения.

Выберите в списке наборы данных для экспорта.

Нажмите OK, чтобы создать файлы.

Photoshop создает отдельные файлы PSD для каждого набора данных, объединяя базовое имя с именем набора данных.Каждый файл содержит шаблон с примененными значениями набора данных.

Применение набора данных непосредственно к шаблону (Изображение > Применить набор данных) приводит к перезаписи исходного документа.Всегда работайте с копией или экспортируйте наборы данных в виде файлов.