Создание композиций слоев и управление ими

Последнее обновление 2 нояб. 2026 г.

Фиксируйте несколько вариантов дизайна в одном файле с помощью снимков видимости, положения и внешнего вида слоев.

Композиции слоев позволяют демонстрировать клиентам несколько вариантов дизайна без создания отдельных файлов для каждой версии.

Композиция слоев — это снимок панели Слои в определенный момент.Используйте Композиции слоев, когда нужно показать разные варианты макета, цветовые схемы или расположение контента в одном документе. Каждая композиция может записывать видимость слоев (отображение или скрытие слоев), положение слоев, внешний вид слоев (стили и режимы наложения), а также выбор композиций слоев Smart Object.Композиции слоев лучше всего подходят для изучения альтернативных вариантов дизайна перед завершением работы над композицией.

Создать новую композицию слоев

Выберите Окно > Композиции слоев, чтобы открыть панель Композиции слоев .

Расположите слои так, чтобы отразить состояние дизайна, которое вы хотите зафиксировать.

Выберите кнопку Создать новую композицию слоев в нижней части панели Композиции слоев .

Введите понятное название и, если нужно, комментарии в диалоговом окне Новая композиция слоев .

Выберите свойства слоев для записи: Видимость, Положение, Внешний вид (Стиль слоя) или Выбор композиции слоев для смарт-объектов.

Нажмите OK.

Выбранные параметры становятся настройками по умолчанию для будущих Композиций слоев.

Совет

Чтобы продублировать существующую композицию, перетащите ее на параметр Создать новую композицию слоев на панели Композиции слоев.

Применение и просмотр композиций слоев

Откройте панель Композиции слоев, выбрав Окно > Композиции слоев.

Выберите Применить композицию слоев в контекстном меню Композиции слоев.

Используйте элементы управления Предыдущий и Следующий в нижней части панели, чтобы просматривать все композиции или конкретные по очереди.

Выберите параметр Применить композицию слоев, чтобы восстановить документ.

Обновить композицию слоев

Выберите композицию слоев, которую нужно обновить, на панели Композиции слоев .

Внесите изменения в видимость, положение или внешний вид слоев на панели «Слои».

Если нужно изменить свойства, которые записывает композиция, выберите Параметры композиции слоев в меню панели Композиции слоев .

Нажмите кнопку «Обновить композицию слоев» в нижней части панели «Композиции слоев».

Использование композиций слоев в смарт-объектах

Если поместить документ, содержащий композиции слоев, в другой документ в виде смарт-объекта, можно получить доступ к этим композициям слоев без открытия исходного файла.Это позволяет переключаться между вариантами дизайна на уровне смарт-объекта.

Выберите слой смарт-объекта на панели «Слои» документа.

Откройте панель «Свойства», выбрав Окно > Свойства.

В меню «Композиция слоев» на панели «Свойства» выберите композицию слоев, которую нужно отобразить.

Меню композиций слоев на панели свойств в Adobe Photoshop, отображающее список композиций слоев с соответствующими параметрами.

Смарт-объект обновляется, чтобы отобразить выбранную композицию, сохраняя при этом все трансформации и эффекты, примененные к нему.

Очистка предупреждений для композиций слоев

Значок предупреждения появляется рядом с композицией слоев, если вы удаляете, объединяете или преобразуете слои, на которые ссылается эта композиция.Такую композицию больше не удастся полностью восстановить до исходного состояния.

Чтобы просмотреть конкретную проблему, выберите значок предупреждения рядом с именем композиции.

Выберите «Очистить» в сообщении, чтобы удалить предупреждение и сохранить остальные свойства слоя.

Щелкните правой кнопкой мыши значок предупреждения и выберите «Очистить предупреждение композиции слоев», чтобы удалить одно предупреждение, или «Очистить все предупреждения композиций слоев», чтобы удалить все предупреждения сразу.

Вы также можете обновить композицию до текущего состояния или игнорировать предупреждение, если отсутствующая информация о слое вам не нужна.

Удаление композиции слоя

Выберите композицию слоя на панели «Композиции слоев».

Выберите значок удаления в нижней части панели или перетащите композицию на значок удаления.

В качестве альтернативного метода выберите «Удалить композицию слоев» в меню панели.

Экспорт композиций слоев в файлы

Выберите Файл > Экспорт > «Композиции слоев в файлы».

Выберите папку назначения в диалоговом окне.

Выберите формат файла для экспортируемых композиций.

Выберите Run, чтобы создать отдельные файлы для каждой композиции слоев.

Каждая композиция слоев экспортируется в отдельный файл, имя которого включает название композиции.