Поиск и анализ отчетов о сбоях Adobe Photoshop на macOS

Последнее обновление 2 нояб. 2026 г.

Узнайте, как найти журналы сбоев, определить проблемные плагины или шрифты и извлечь диагностическую информацию из технических отчетов в Adobe Photoshop.

Когда Adobe Photoshop дает сбой на macOS, система автоматически создает отчет о сбое с технической информацией об ошибке. Эти отчеты помогают определить, что вызвало сбой — плагины, шрифты или внутренние проблемы.

Если Photoshop неожиданно закрывается, всегда отправляйте отчет о сбое в Adobe через диалоговое окно отчета о сбое. Если вы укажете свой адрес электронной почты, Adobe сможет уведомить вас о решениях известных проблем. Вы также можете поделиться отчетами о сбоях на форумах сообщества Photoshop или на сайте для отправки отчетов об ошибках, чтобы получить помощь от сообщества.

Примечание

Сбой (полное закрытие приложения) отличается от зависания (приложение перестает отвечать, но остается открытым). Для зависших приложений используйте статью Как получить Process Sample или Spindump на macOS.

Поиск и чтение отчетов о сбоях

Отчеты о сбоях хранятся в скрытой системной папке на macOS, доступ к которой требует определенных действий.

Откройте Finder и в строке меню выберите Переход > Переход к папке.

Введите ~/Library/Logs/DiagnosticReports и выберите Переход.

Найдите файлы, название которых начинается с «Adobe Photoshop», за которым следуют дата и время.

Дважды щелкните самый последний отчет о сбое, чтобы открыть его в Console, либо перетащите его в TextEdit для просмотра.

Либо откройте Console через «Программы» > «Утилиты», выберите «Отчеты о сбоях» на боковой панели и найдите записи Adobe Photoshop.

Отчет о сбое открывается как обычный текстовый файл с технической информацией, разбитой на разделы.

Определение распространенных причин сбоев

В следующих решениях рассматриваются наиболее распространённые причины сбоев, упорядоченные по частоте возникновения.

Заголовок отчета

Заголовок отчета содержит основную информацию о сбое. Обратите внимание на следующие ключевые элементы:

Информация о процессе: указывает, какое приложение дало сбой, и путь установки

Дата/время. Показывает, когда произошёл сбой, чтобы сопоставить его с вашими действиями

Версия ОС: отображает версию macOS — убедитесь, что ваша система обновлена до последней версии

Тип кода. Указывает архитектуру процессора (ARM-64 для Apple Silicon, X86-64 для Intel)

Поток со сбоем. Указывает, какой поток завершился со сбоем — этот номер соответствует подробному разделу ниже

В разделе потока со сбоем самые верхние строки показывают, что делал Photoshop перед сбоем.

Сбои, связанные с плагинами

Устаревшие или несовместимые плагины сторонних производителей могут вызывать сбои, а раздел потока со сбоем показывает, какой плагин является причиной.

Откройте отчет о сбое и найдите строку «Crashed Thread» («Поток со сбоем») в верхней части отчета — запомните номер потока, в котором произошел сбой.

Прокрутите вниз до раздела, соответствующего этому номеру потока.

Просмотрите первые 5–10 строк трассировки стека на наличие идентификаторов плагинов сторонних производителей, например com.company.pluginname, или ссылок на платформы, не относящиеся к Adobe.

Если вы обнаружили ссылку на плагин, переместите этот плагин из папки Applications/Adobe Photoshop [version]/Plug-ins в другое место.

Перезапустите Photoshop, чтобы проверить, устраняет ли удаление плагина сбой.

Обратитесь к разработчику плагина за обновленной версией, совместимой с вашими версиями Photoshop и macOS.

Примечание

В трассировке стека ссылки на плагины отображаются перед собственным кодом Adobe.

Сбои, связанные со шрифтами

Поврежденные файлы шрифтов или утилиты управления шрифтами могут вызывать сбой текстового модуля Photoshop (CoolType) при запуске или при обращении к инструментам работы с текстом.

Откройте отчет о сбое и найдите в разделе потока со сбоем слова «CoolType», «font» (шрифт) или «ATS».

Найдите строки с com.adobe.CoolType, после которых следуют имена функций, такие как CTInit.

Проверьте трассировку стека на наличие плагинов управления шрифтами сторонних производителей, таких как com.extensis.AutoActivationPlugin.

Отключите или обновите программное обеспечение для управления шрифтами.

Используйте Font Book в macOS (Applications > Font Book), чтобы проверить шрифты: выберите all fonts, затем выберите File > Validate Fonts.

Удалите или поместите в карантин все проблемные шрифты, обнаруженные при проверке.

Для комплексного устранения проблем со шрифтами используйте статью Устранение проблем со шрифтами в Photoshop.

Сбои во внутреннем коде

Если поток со сбоем показывает только адреса com.adobe.Photoshop в виде шестнадцатеричных чисел без читаемых имен функций, значит сбой произошел во внутреннем коде Photoshop, анализ которого требует участия инженеров Adobe.

  • Убедитесь, что отчет о сбое содержит раздел системной информации в верхней части (версия ОС, тип кода, дата/время).
  • Отправьте отчет о сбое через диалоговое окно Adobe Crash Reporter, которое появляется после сбоев.
  • Укажите в отправляемой форме ваш адрес электронной почты, чтобы Adobe могла сообщить вам о решениях известных проблем.
  • Подробно опишите, что вы делали в момент сбоя, в поле для комментариев в программе отправки отчетов о сбоях.
  • Проверьте наличие обновлений Photoshop в разделе Help > Updates (Справка > Обновления) — там могут быть исправления для вашего типа сбоя.
  • Поделитесь отчетом о сбое на форумах сообщества Photoshop, чтобы получить дополнительную помощь.
Примечание

Для анализа нерешенных сбоев по их адресам инженерам Adobe требуются внутренние символы отладки.

Дополнительные ресурсы для устранения неполадок

Если сбои продолжаются после анализа отчетов о сбоях и применения указанных выше решений, обратитесь к разделу Основные шаги по устранению неполадок — там есть подробные рекомендации по решению большинства проблем, включая сброс настроек, устранение неполадок с GPU и диагностику на уровне системы.