使用手冊 取消

建立表格

  1. InDesign 使用者指南
  2. 了解 InDesign
    1. InDesign 簡介
      1. InDesign 中的新增功能
      2. 系統需求
      3. 常見問題
      4. 使用 Creative Cloud 資料庫
    2. 工作區
      1. 工作區基本介紹
      2. 工具箱
      3. 設定偏好設定
      4. 觸控工作區
      5. 預設鍵盤快速鍵
      6. 文件復原和還原
      7. Capture 延伸功能
  3. 建立文件及調整文件版面
    1. 文件和頁面
      1. 建立文件
      2. 使用上層頁面
      3. 使用文件頁面
      4. 設定頁面大小、邊界和出血
      5. 使用檔案與範本
      6. 建立書冊檔案
      7. 新增基本編排頁碼
      8. 為頁面、章節和區段編號
      9. 轉換 QuarkXPress 和 PageMaker 文件
      10. 共用內容
      11. 了解基本受管理檔案的工作流程
      12. 儲存文件
    2. 格點
      1. 格點
      2. 設定格點格式
    3. 版面輔助
      1. 尺標
  4. 加入內容
    1. 文字
      1. 將文字新增至框架
      2. 串連文字
      3. InDesign 的阿拉伯文和希伯來文功能
      4. 建立路徑文字
      5. 項目符號和編號
      6. 字符和特殊字元
      7. 文字排版方式
      8. 文字變數
      9. 產生 QR 碼
      10. 編輯文字
      11. 對齊文字
      12. 將文字繞排在物件周圍
      13. 錨定物件
      14. 連結內容
      15. 格式化段落
      16. 格式化字元
      17. 尋找/變更
      18. 拼字檢查和語言字典
    2. 印刷樣式
      1. 在 InDesign 中使用字體
      2. 字距微調和字距調整
    3. 設定文字格式
      1. 設定文字格式
      2. 定位點與縮排
    4. 審核文字
      1. 追蹤並檢閱修訂
      2. 在 InDesign 中新增編輯註解
      3. 讀入 PDF 注釋
    5. 新增參照
      1. 建立目錄
      2. 註腳
      3. 建立索引
      4. 章節附註
      5. 標題
    6. 樣式
      1. 段落和字元樣式
      2. 物件樣式
      3. 首字放大和輔助樣式
      4. 使用樣式
      5. 行距
    7. 表格
      1. 設定表格格式
      2. 建立表格
      3. 表格和儲存格樣式
      4. 選取和編輯表格
      5. 表格線條與填色
    8. 互動性
      1. 超連結
      2. 動態 PDF 文件
      3. 書籤
      4. 按鈕
      5. 表單
      6. 動畫
      7. 交互參照
      8. 設定 PDF 結構
      9. 頁面切換效果
      10. 影片和聲音
      11. 表單
    9. 圖形
      1. 了解路徑和形狀
      2. 以鉛筆工具繪圖
      3. 使用筆型工具繪圖
      4. 套用線條 (筆畫) 設定 
      5. 複合路徑和形狀
      6. 編輯路徑
      7. 剪裁路徑
      8. 變更轉角外觀
      9. 對齊和均分物件
      10. 連結和嵌入圖形
      11. 整合 AEM 資產
    10. 顏色和透明度
      1. 套用顏色
      2. 使用讀入圖形的顏色
      3. 使用色票
      4. 混合油墨
      5. 色調
      6. 了解特別色和印刷色
      7. 混合顏色
      8. 漸層
      9. 平面化透明圖稿
      10. 新增透明度效果
  5. 共用
    1. 分享與協作        
    2. 共用以供審核
    3. 審核共用的 InDesign 文件
    4. 管理意見 
  6. 發佈
    1. 轉存和發佈
      1. Publish Online
      2. 將內容轉存為 EPUB
      3. Adobe PDF 選項
      4. 將內容轉存為 HTML
      5. 轉存為 Adobe PDF
      6. 轉存為 JPEG 格式
      7. 轉存 HTML
      8. DPS 和 AEM Mobile 概觀
    2. 列印
      1. 列印手冊
      2. 印表機的標記和出血
      3. 列印文件
      4. 油墨、分色與網線數
      5. 疊印
      6. 建立 PostScript 和 EPS 檔案
      7. 交付前先預檢檔案
      8. 列印縮圖與過大的文件
      9. 為服務供應商準備 PDF
      10. 準備列印分色
  7. 延伸 InDesign
    1. 自動
      1. 資料合併
      2. 增效模組
      3. InDesign 的 Capture 延伸功能
      4. 指令碼

表格是由許多列與欄的儲存格所組成。儲存格就像是文字框,您可以在其中新增文字、錨定框架或其他表格。在 Adobe InDesign CS5 中建立表格,或從其他應用程式轉存表格。

註解:

如果要在 Adobe InCopy 中建立、編輯和格式化表格,請確認是在「版面」檢視中執行這些動作。

建立表格

表格是由許多列與欄的儲存格所組成。儲存格就像是文字框,您可以在其中新增文字、內嵌圖形或其他表格。您可以從頭建立新表格,或從現有文字轉換表格。您也可以將表格嵌入表格中。

建立表格時,新表格會填入容器文字框的寬度。插入點在行的起點時,表格便會插入在同一行上,而插入點在行中時,表格便會插入在下一行上。

表格就如同內嵌圖形一樣,會隨著周圍的文字移動。例如,當表格上方的文字大小點數變更,或新增、刪除文字時,表格會在串連框架間移動。不過,表格無法在路徑文字框架中出現。

Michael Murphy 在注意您的表格風格中提供建立和格式化表格的文章。

InfiniteSkills.com 的 Jeff Witchell 提供視訊示範: 設定表格的基礎概念

重新建立表格

當您在 InDesign 中建立表格時,可選擇在現有文字框中建立表格 (使用「插入表格」選項)。或者,您也可以建立表格,並允許 InDesign 建立外圍文字框 (使用「建立表格」選項)。

使用「插入表格」選項

  1. 若要在現有文字框中繪製表格,請使用文字工具,然後將插入點移至想要讓表格出現之處。

  2. 選擇「表格 > 插入表格」。

    註解:

    如果游標目前不在文字框中,則無法使用「建立表格」選項。

  3. 指定列數和欄數。
  4. 如果表格內容會延續一個以上的欄或框架,請指定想要重複資訊的表頭與表尾列數。
  5. (選擇性) 指定表格樣式。
  6. 按一下「確定」。

    出現的新表格會與文字框等寬。

使用「建立表格」選項

當您使用「建立表格」選項建立表格時,不需要先在文件中建立文字框。一旦在文件上繪製表格,InDesign 就會建立與該表格相等大小的文字框。

  1. 選擇「表格 > 建立表格」。

    註解:

    如果游標目前在文字框中,則可以使用「插入表格」選項。

  2. 指定列數和欄數。
  3. 如果表格內容會延續一個以上的欄或框架,請指定想要重複資訊的表頭與表尾列數。
  4. (選擇性) 指定表格樣式。
  5. 按一下「確定」。
  6. 使用「表格」游標繪製您需要的表格。

    InDesign 會建立與所繪製區域同等大小的文字框,並將表格放在該文字框之中。

表格列高是由指定的表格樣式所決定。例如,表格樣式可能會使用儲存格樣式,格式化表格的不同部分。如果任何儲存格樣式包含段落樣式,段落樣式的行距值會決定該區域的列高。如果未使用段落樣式,文件的預設印刷邊界會決定列高。(印刷邊界是基於行距值。在此內容中,印刷邊界是選取文字中反白標示的近似高度)。

從現有文字建立表格

在您將文字轉換成表格前,請確認文字已正確地設定。

  1. 準備轉換文字前,請插入定位點、逗號、段落換行符號或其他字元來分隔欄。另外也需插入定位點、逗號、段落換行符號或其他字元來分隔列(在許多實例中,文字不需編輯就可轉換成表格)。
  2. 使用「文字」工具 ,選取要轉換為表格的文字。
  3. 選擇「表格 > 將文字轉換為表格」。
  4. 同時在「欄分隔元」和「列分隔元」中,指示新的列和欄開始的位置。選擇「定位點」、「逗號」或「段落」,或在「欄分隔元」和「列分隔元」欄位中輸入如分號 (;) 這類字元 (任何輸入的字元會在下次從文字建立表格時顯示於選單中)。
  5. 如果指定的欄和列分隔元相同,請另行指示您要表格包含的欄數。
  6. (選擇性) 指定表格樣式以格式化表格。
  7. 按一下「確定」。

如果表格中任一列的項目少於欄數,會以空白儲存格填滿列。

將表格嵌入表格中

  1. 執行下列任一項作業:
    • 選取想要嵌入的儲存格或表格,然後選擇「編輯 > 剪下 (或拷貝)」。 將插入點置入想要顯示表格的儲存格中,然後選擇「編輯 > 貼上」。

    • 在儲存格內按一下,選擇「表格 > 插入表格」,指定列數和欄數,然後按一下「確定」。

  2. 視需要調整儲存格內縮(請參閱格式化表格中的文字。)

如果表格是在儲存格中建立的,您將無法使用滑鼠選取表格溢排在儲存格邊界外的任何部分。不過,您可以將列或欄放大,或將插入點置入表格的第一個部分,並使用鍵盤快速鍵移動插入點來選取文字。

從其他應用程式讀入表格

當您使用「置入」指令讀入包含表格的 Microsoft Word 文件或 Microsoft Excel 試算表時,讀入的資料為可編輯的表格。您可以使用「讀入選項」對話框控制格式設定。

另外也可以將 Excel 試算表或 Word 表格中的資料貼入 InDesign 或 InCopy 文件。「剪貼簿處理」偏好設定會決定如何格式化從另一個應用程式貼入的文字。如果選取「僅文字」,資訊會顯示為未格式化的定位點分隔文字,您接著可將其轉換為表格。如果選取「所有資訊」,貼上的文字會顯示在格式化表格中。

如果從另一個應用程式將文字貼入現有表格中,請插入足夠的列和欄以容納貼入的文字、選取「剪貼簿處理」偏好設定中的「僅文字」選項,並確認至少選取一個儲存格 (除非要將貼上的表格嵌入儲存格中)。

如果要更深入控制讀入的表格格式,或要維護試算表格式,請使用「置入」指令讀入表格。如果要維護試算表的連結,請在「檔案處理」偏好設定中選取「置入文字和試算表檔案時建立連結」選項。

註解:

您可以選取某個範圍內的表格儲存格,然後拷貝和貼上其中的標記文字。如果要在取代內容的同時保留格式,這個技巧是一個很好的方式。例如,假設您要更新月刊中格式表格的內容,其中一項可能的做法就是連結到 Excel 試算表。不過,如果您的內容來自其他來源,就可以拷貝內含新內容的標記文字,然後在經過格式化的 InDesign 表格中選取某個範圍內的儲存格,最後再貼上。

將文字新增至表格

您可將文字、錨定物件、XML 標記和其他表格新增至表格儲存格。除非設定固定列高,否則表格列的高度會增加以容納更多文字行。不過您無法將註腳新增至表格。

  1. 使用「文字」工具 ,執行下列任一項作業:
    • 將插入點置入儲存格,並輸入文字。按下 Enter 鍵或 Return 鍵,在相同的儲存格中建立新的段落。按 Tab 鍵會往下一個儲存格移動 (在最後一個儲存格中按 Tab 鍵則會插入新的一列)。按 Shift+Tab 往上一個儲存格移動。

    • 拷貝文字,將插入點放置在儲存格中,然後選擇「編輯 > 貼上」。

    • 將插入點放在要新增文字的儲存格中,選擇「檔案 > 置入」,然後按兩下文字檔案。

將圖形新增至表格

  1. 將插入點置入要新增影像的表格儲存格內。

  2. 執行下列任一項作業:
    • 選擇「檔案 > 置入」,然後選取一或多個圖形檔案。
    • 從「CC 程式庫」面板中的「圖形」類別選取及拖放一或多個圖形。

    如此一來,您便可以在噴槍工具上使用影像。

  3. 若要置入影像,請按一下表格儲存格內部。

  4. 執行下列任一項作業:
註解:

您無法從 CC Libraries 面板中的「圖形」類別選取及拖放 InDesign 程式碼片段。

當您要新增比儲存格大的圖形時,儲存格高度會伸展以容納圖形,但儲存格的寬度不會變更,所以圖形可能會超出儲存格的右側。 如果置入圖形的列設定為固定高度,高於列高的圖形將導致儲存格溢排

註解:

如果要避免溢排儲存格,請將影像置入表格以外的地方、調整影像大小,然後將影像貼入表格儲存格。

您也可以使用以下方法將影像置入表格儲存格內:

  • 選擇「物件 > 錨定物件 > 插入」,然後指定設定。您之後可以將圖形新增到錨定物件中。
  • 拷貝圖形或框架、放置插入點,然後選擇「編輯 > 貼上」。

新增表格表頭與表尾

建立長表格時,表格可能會跨越超過一個以上的欄、框架或頁面。您可以使用表頭或表尾在表格中各部分的頂端或底部重複資訊。

您可以在建立表格時新增表頭與表尾列;也可以使用「表格選項」對話框新增表頭與表尾列,並變更其在表格中的外觀。另外,您還可以將內文列轉換為表頭或表尾列。

表頭列會重複出現在每個框架中

註解:

如果要為表格按順序編號,例如「Table 1A」、「Table 1B」,請在表格表頭或表尾新增變數。(請參閱建立圖和表格的跟續標題。)

  1. 選取表格頂端的列來建立表頭列,或選取表格底部的列來建立表尾列。
  2. 選擇「表格 > 轉換列 > 為表頭 (或為表尾)」。
  1. 將插入點置入表格中,然後選擇「表格 > 表格選項 > 表頭與表尾」。
  2. 指定表頭或表尾列數。在表格的頂端或底部可以新增空白列。
  3. 指定表頭或表尾中的資訊要在每個文字欄中顯示 (如果文字框有一個以上的欄)、每框架顯示一次,或每頁僅顯示一次。
  4. 如果不要表頭資訊出現在表格的第一列,請選取「略過第一個」。 如果不要表尾資訊出現在表格的最後一列,請選取「略過最後一個」。

    如果要指出表頭或表尾是連續的,則「略過第一個」選項特別有用。例如,對於跨多重頁面的表格,您可能希望表頭文字是「表 2 (續)」。由於您不希望「(續)」出現在表格的開頭處,可選取「略過第一個」,並在表格的第一列中直接輸入表 2

  5. 按一下「確定」。

您可以執行數個功能來建立類似的列和欄,或是複製列和欄。

您主要可以對表格的列和欄執行以下功能:

  • 將表格中的列和欄拖放至同一表格中的其他位置。
  • 複製列和欄。
  • 將列和欄貼在其他列/欄之前或之後。
  • 將列的內容複製至欄,或將欄的內容複製至列。

拖放與複製列/欄

您可以將表格中的列和欄移動至同一表格中的其他位置。請依照下列步驟拖放及複製列/欄。

  1. 選取要拖放至其他列或欄的列或欄。請確定已選取整列或整欄。未選取整列或整欄將無法拖放。

  2. 將游標移至所選列,此時會顯示特別的游標表示可以移動選取的部分

  3. 現在可以拖放項目列了。您可以變換欄和列的位置。拖曳列只可放置為列,拖曳欄只可放置為欄。

    拖放列和欄

    在圖中,將列換個位置後,總列數仍保持和之前一樣,也就是只有三列。

    註解:

    拖放只能在同一表格中進行。

  4. 若要複製列和欄,請在選取列或欄後按住 Alt 鍵 (Win) 或 Opt 鍵 (Mac)。可拖放連續選取的多個列或欄。

  5. 拖放選取的列或欄至想要的位置。總列數或總欄數會增加,因為複製了選取的項目。

    您也可以從表頭列和表尾列複製內容到內文列 (藉由按住 Alt/Opt 鍵)。 同樣地,您也可以重複內文列,並將其轉換為表頭和表尾列。

除非是使用 alt/opt 鍵來複製列,否則您只能在表頭區段內拖放表頭列 (僅適用於有多個表頭列的情況)。除非是使用 alt/opt 鍵來複製列,否則不能將內文列拖放至表頭區段。

複製列/欄並在前後貼上

您可以複製選取的列,並貼在該列之前或之後。使用「貼到之前/之後」工作流程時,也可以複製表格中的列/欄然後貼到其他表格

  1. 選取列/欄。

  2. 選取目標列或欄。

  3. 選取「表格 > 貼到之前/貼到之後」。

  1. 執行下列任一項作業:
    • 將插入點置入表頭或表尾列,然後選擇「表格 > 轉換列 > 為內文」。

    • 選擇「表格 > 表格選項 > 表頭與表尾」,然後指定不同的表頭列和表尾列數。

Adobe 標誌

登入您的帳戶