Esportare le preferenze dell’applicazione

È possibile scegliere tra le preferenze per utenti esperti e quelle per principianti. È anche possibile esportare in un singolo file le impostazioni dell’applicazione, comprese quelle della barra degli strumenti, le scelte rapide da tastiera e altre impostazioni. Questo permette di trasferire le preferenze da un dispositivo a un altro, con la semplice esportazione e importazione di un file.

Esportare le preferenze dell’applicazione
Esportare le preferenze
Esporta preferenze: consente di esportare tutte le impostazioni o solo alcune, per trasferirle ad altri dispositivi o condividerle con altri utenti

Esportazione di immagini e grafica

Sequenza PNG

Potete esportare una serie di file di immagine da un singolo simbolo di clip filmato, pulsante o simbolo grafico della Libreria o dello stage. Durante l’esportazione, Animate (già Flash Professional ) crea un file di immagine separato per ciascun fotogramma del simbolo. Se eseguite l'esportazione dallo stage, eventuali trasformazioni (ad esempio, una modifica in scala) applicate all'istanza del simbolo vengono conservate anche nell'immagine di output.

Per esportare una sequenza PNG:

  1. Selezionate un singolo simbolo di clip filmato, pulsante o simbolo grafico nella libreria o sullo stage.

  2. Fate clic su di esso con il pulsante destro del mouse e scegliete Esporta sequenza PNG.

    select-png-sequence
  3. Nella finestra di dialogo Salva con nome, scegliete una posizione per il file di output e fate clic su OK.

     

  4. Nella finestra di dialogo Esporta sequenza PNG, impostate le opzioni desiderate.

    export-pngsequence

    Larghezza - La larghezza dell'immagine di output. Potete ridimensionare l'output modificando questo valore. L'impostazione predefinita corrisponde alla larghezza del contenuto del simbolo.

    Altezza - L'altezza dell'immagine di output. Potete ridimensionare l'output modificando questo valore. L'impostazione predefinita corrisponde all'altezza del contenuto del simbolo

    Risoluzione - La risoluzione dell'output dell'immagine. Il valore predefinito è 72 dpi.

    Colori - La profondità di bit dell'immagine di output. Potete selezionare 8, 24 o 32 bit. Il valore predefinito è 32 bit, che supporta la trasparenza. Se selezionate 24 bit o 8 bit, che non supportano la trasparenza, l'impostazione Sfondo cambia in Stage. Vedete di seguito.

    Sfondo - Il colore da utilizzare come colore di sfondo per l'immagine di output. Questa impostazione è disponibile solo se l'opzione Colori è impostata su 8 o 24 bit. Se l'opzione Colori è impostata su 32 bit, lo sfondo dell'immagine è sempre trasparente. Se l'opzione Colori è impostata su 8 o 24 bit, per l'opzione Sfondo viene utilizzato per impostazione predefinita il colore dello stage. Con immagini a 8 o 24 bit, potete modificare l'impostazione in Opaco e selezionare un colore per lo sfondo dal selettore colore. In alternativa, potete scegliere un valore alfa per lo sfondo e creare una trasparenza.

    Smussa - Consente di applicare una smussatura ai margini dell'immagine di output. Disattivate questa opzione se non utilizzate uno sfondo trasparente e le immagini possono essere collocate su un colore di sfondo diverso dal colore corrente dello stage.

  5. Fate clic su Esporta per esportare la sequenza PNG.

Esporta GIF animata

Potete esportare i file GIF animata in Animate mediante la procedura seguente:

  1. Selezionate File > Esporta > Esporta GIF animata

    Viene visualizzata una finestra di dialogo. 

    export-animated-gif
  2. Scegliete le opzioni desiderate nella finestra di dialogo e fate clic su Fine per esportare l'animazione come file GIF animata.

    animated-gif-dialog

    È anche possibile esportare il file come immagine GIF statica scegliendo File > Esporta > Esporta immagine.

Esportare immagini ed elementi grafici in CC Libraries

Per esportare immagini o elementi grafici in CC Libraries, selezionate Finestra > CC Libraries

Viene visualizzata la finestra CC Libraries. 

add-to-cc-library

Fate clic sull'icona + nell'angolo inferiore sinistro della finestra CC Libraries, selezionate le immagini o i file grafici e fate clic su Aggiungi.

Formato grafico FXG (obsoleto in Animate)

I file FXG

Il formato FXG è un formato file GIF per la piattaforma Animate/Flash. Basato su un sottoinsieme di MXML, il linguaggio di programmazione basato su XML usato dal framework Flex. Il formato FXG permette ai designer e agli sviluppatori di collaborare in maniera più efficiente consentendo loro di scambiare contenuto grafico con la massima fedeltà. I designer possono creare elementi grafici utilizzando gli strumenti di design di Adobe ed esportarli nel formato FXG. Potete quindi utilizzare il file FXG in strumenti quali Adobe Flash Builder e Adobe Flash Catalyst per sviluppare applicazioni ed esperienze Internet ricche di contenuto.

Quando si crea un file FXG, la grafica vettoriale viene memorizzata direttamente all’interno del file. Gli elementi per i quali non esiste un tag corrispondente in FXG vengono esportati come grafica bitmap a cui si fa quindi riferimento nel file FXG. Questi includono bitmap, alcuni filtri, alcuni metodi fusione, gradienti, maschere e 3D. Alcuni di questi effetti possono essere esportati in formato FXG, ma non possono essere importati dall'applicazione che apre il file FXG.

Quando si esporta un file contenente immagini vettoriali e bitmap utilizzando l’esportazione con export FXG, viene creata una cartella distinta insieme con il file FXG. Il nome della cartella è <nome file.assets> e contiene le immagini bitmap associate al file FXG.

Per ulteriori informazioni sul formato file FXG, vedete la Specifica FXG 2.0.

Limitazioni per l'esportazione in FXG

Animate consente di selezionare uno o più oggetti dello stage per esportarli in FXG. Durante l'esportazione nel formato FXG, i nomi degli oggetti e dei livelli vengono mantenuti.

Per il salvataggio nel formato FXG sono previste le seguenti limitazioni:

  • Griglie in scala 9: esportabili, ma leggibili solo in Adobe Illustrator.

  • Suono e video: non esportabili.

  • Componenti: non esportabili.

  • Interpolazioni e animazioni con più fotogrammi: non esportabili, ma un fotogramma selezionato viene esportato come oggetto statico.

  • Font incorporati: non esportabili.

  • Simboli di pulsanti: Animate esporta solo lo stato Su dei pulsanti.

  • Proprietà 3D: non esportabili.

  • Proprietà di cinematica inversa (IK): non esportabili.

  • Attributi del testo: alcuni attributi non possono essere esportati.

Esportare contenuto Animate in formato FXG

In Animate sono disponibili due modi per esportare contenuto in formato FXG:

  • Per esportare oggetti dello stage in formato FXG, selezionateli e scegliete Esporta > Esporta selezione, quindi selezionate il formato FXG dal menu Tipo di file.

  • Per salvare l'intero stage in formato FXG, scegliete Esporta > Esporta immagine, quindi selezionate Adobe FXG dal menu Tipo di file.

Sequenza JPEG e Immagine JPEG

Queste opzioni corrispondono alle Impostazioni pubblicazione per JPEG. Tuttavia, l'opzione Adatta a schermo adatta l'immagine esportata alla dimensione del contenuto Animate così come appare sullo schermo. Adatta a filmato adatta l'immagine JPEG al contenuto Animate e mantiene le proporzioni dell'immagine originale.

Sequenza PNG e Immagine PNG

Le impostazioni di esportazione PNG sono simili a quelle di pubblicazione PNG (anch'esse applicabili), con le seguenti eccezioni:

Dimensioni

Imposta le dimensioni dell'immagine bitmap esportata in base al numero di pixel immessi nei campi Larghezza e Altezza.

Risoluzione

Consente di immettere una risoluzione in punti per pollice (dpi). Per usare la risoluzione dello schermo e mantenere le proporzioni dell'immagine originale, selezionate Adatta a schermo.

Colori

Corrisponde all'opzione Profondità bit della scheda Impostazioni pubblicazione PNG. Imposta il numero di bit per pixel da utilizzare nella creazione dell'immagine. Per un'immagine a 256 colori, selezionate 8 bit; per migliaia di colori, selezionate 24 bpc; per migliaia di colori con trasparenza (32 bpc), selezionate 24 bpc con alfa. A una profondità di bit maggiore corrispondono dimensioni del file superiori.

Includi

Consente di scegliere di esportare l'area minima dell'immagine o di specificare le dimensioni del documento intero.

Nota:

Le dimensioni del file GIF esportato non possono superare i 4000 pixel. Tale limitazione di dimensioni è applicabile alle versioni di successive a CS6.

Nota:

L'opzione Dithering colori uniformi non funziona se è selezionata l'opzione 256 colori. Pertanto, il dithering non viene applicato all'immagine GIF se la combinazione di colori selezionata per il GIF è 256 colori.

(Dichiarato obsoleto in Animate) Immagine bitmap (BMP)

Consente di creare immagini bitmap da utilizzare in altre applicazioni. La finestra di dialogo Esporta delle bitmap contiene le seguenti opzioni:

Dimensioni

Imposta le dimensioni dell'immagine bitmap esportata in pixel. Le dimensioni specificate hanno sempre le stesse proporzioni dell'immagine originale.

Risoluzione

Imposta la risoluzione dell'immagine bitmap esportata in punti per pollice (dpi); la larghezza e l'altezza cambiano automaticamente in base alle dimensioni del disegno. Per impostare la risoluzione in modo che sia uguale a quella del monitor, selezionate Adatta a schermo.

Profondità colore

Specifica il numero di bit dell'immagine. Alcune applicazioni Windows non supportano la nuova profondità di 32 bit per canale (bpc) per le immagini bitmap. In caso di problemi con il formato a 32 bpc, utilizzate il formato a 24 bpc.

Attenua

Applica l'antialiasing alla bitmap esportata. L'antialiasing produce un'immagine bitmap di qualità superiore, ma può creare un alone di pixel grigi intorno a un'immagine posizionata su uno sfondo colorato. Deselezionate questa opzione se appare un alone.

Documento Animate (SWF)

Per posizionare il contenuto Animate in un'altra applicazione, ad esempio Dreamweaver, esportate l'intero documento come file SWF. Animate consente di esportare il file SWF utilizzando le impostazioni correnti in Impostazioni pubblicazione per il file FLA.

Esportazione di video HD con Adobe Media Encoder

Animate consente di esportare interpolazioni, simboli e grafica sotto forma di video in alta definizione di vari formati. La funzione di esportazione video è stata ottimizzata per offrire integrazione diretta con Adobe Media Encoder.

In Animate, è possibile scegliere un formato video supportato da AME e le sue preimpostazioni e, se si seleziona la relativa opzione, il video viene quindi inserito nella coda e persino elaborato automaticamente in AME. Al termine dell’elaborazione, si riceve una notifica.

Inoltre, è possibile esportare tutte le scene o una scena specifica da riprodurre in ciclo continuo, e per una specifica scena si possono esportare tutti i fotogrammi o uno specifico intervallo di fotogrammi.

I video HD esportati con Animate possono essere usati con applicazioni abilitate per le comunicazioni, per videoconferenze, streaming e condivisione.

Per impostazione predefinita, Animate è in grado di esportare solo file QuickTime Movie (.MOV). La funzione di esportazione richiede l'installazione dell'ultima versione di QuickTime Player, in quanto Animate sfrutta le librerie di QuickTime per l'esportazione dei file MOV.

Il flusso di lavoro di esportazione video HD è stato ridisegnato, in quanto Animate è ora integrato con Adobe Media Encoder. Ora consente di convertire file MOV in diversi altri formati. Dal canto suo, Adobe Media Encoder è stato ottimizzato per presentare solo formati di esportazione pertinenti al contenuto Animate. Per ulteriori informazioni sulla codifica e l’esportazione di video con Adobe Media Encoder, consultate Codificare ed esportare video e audio.

Nota:

Adobe Media Encoder viene installato automaticamente quando installate Animate dall’applicazione Creative Cloud desktop.

Differenza tra il flusso di lavoro esportazione video precedente e il più recente

Il nuovo flusso di lavoro è diverso dal flusso di lavoro di esportazione video di CS6 e delle versioni precedenti.

Le principali differenze sono:

  • Integrazione con Adobe Media Encoder: Animate è ora integrato con Adobe Media Encoder 7.0, mentre le versioni precedenti non dipendevano da AME.
  • Formati di esportazione: Animate può esportare solo filmati QuickTime.
  • Video HD: Animate consente di esportare video HD.

Inoltre, il flusso di lavoro di CS6 presentava i seguenti problemi:

  • Il flusso di esportazione MOV mediante QuickTime era soggetto a errori e consumava molta memoria.
  • Il flusso di esportazione AVI non supportava i clip filmato

In Animate, i problemi di cui sopra sono stati risolti, così come il problema della perdita di fotogrammi. Con il flusso di lavoro basato su Adobe Media Encoder, potete esportare contenuti in file MOV direttamente da Animate. Con il nuovo flusso di lavoro basato su AME, potete esportare contenuto Animate in file MOV e successivamente utilizzare AME per convertire i file MOV in qualsiasi altro formato.

L'esportazione inizia dal fotogramma 2

A seconda di come è strutturata la linea temporale, il video esportato può essere il risultato di uno degli scenari seguenti:

  1. Se è presente più di un fotogramma sulla linea temporale principale, l'esportazione ha inizio dal fotogramma 2.
  2. Se è presente un solo fotogramma sulla linea temporale principale, l'esportazione include il fotogramma 1.
  3. Se è presente più di un fotogramma sulla linea temporale principale e viene aggiunto del codice ActionScript o un suono al fotogramma 1, questo non viene chiamato.

Esportazione di video HD

Prima di iniziare l'esportazione, procedete come segue:

  • Installate QuickTime
  • Impostate la velocità fotogrammi su un valore uguale o inferiore a 60 fps. Per maggiori informazioni, consultate Fondamenti delle animazioni.
  1. Create o aprite un file FLA.

  2. Selezionate File > Esporta > Esporta video.

    Esportare file video
    Finestra di dialogo Esporta video
  3. Nella finestra di dialogo Esporta video, i valori Larghezza rendering e Altezza rendering sono impostati sui valori di larghezza e altezza definiti per le dimensioni dell'opzione Stage.

  4. Nella finestra di dialogo Esporta video impostate le opzioni desiderate:

    • Dimensione rendering L e A: specificate le dimensioni di rendering in base alla risoluzione alla quale desiderate esportare il contenuto, per video HD o normale. Impostate valori uguali per la Larghezza e l’Altezza dello stage. Se volete modificare i valori Larghezza rendering e Altezza rendering, modificate le dimensioni dello stage di conseguenza. Animate mantiene le proporzioni in base alle dimensioni dello stage.
    • Ignora colore stage (genera canale alfa): crea un canale alfa utilizzando il colore dello stage. Il canale alfa viene codificato come traccia trasparente. È quindi possibile sovrapporre il filmato QuickTime esportato sopra l'altro contenuto in modo da variarne il colore di sfondo o la scena.
    • Converti video in Adobe Media Encoder: selezionate questa opzione per convertire il file MOV esportato in un formato diverso mediante AME. Se selezionate questa opzione, AME viene avviato dopo che Animate ha completato l'esportazione del video.
    • Percorso video esportato: specificate o selezionate il percorso in cui volete esportare il video.
    • Interrompi esportazione: specificate quando Animate interrompe l'esportazione.
      • All’ultimo fotogramma: selezionate questa opzione per interrompere all’ultimo fotogramma.
    Interruzione dell’esportazione quando si arriva all’ultimo fotogramma
    Interruzione dell’esportazione quando si arriva all’ultimo fotogramma
    • Interrompi esportazione: specificate quando Animate interrompe l’esportazione.
      • Dopo: selezionate questa opzione e specificare dopo quanto tempo volete interrompere l’esportazione. Questa opzione consente di esportare sezioni del video separatamente.
    Interruzione dell’esportazione dopo 1 minuto e 15 secondi
    Interruzione dell’esportazione dopo 1 minuto e 15 secondi
    Interruzione dell’esportazione dopo 3 minuti
    Interruzione dell’esportazione dopo 3 minuti
  5. Fate clic su Esporta. Se avete selezionato l'opzione Converti video in Adobe Media Encoder, AME viene avviato e il file MOV esportato è disponibile in una nuova coda. Per ulteriori informazioni sulla codifica e l’esportazione di video con Adobe Media Encoder, consultate Codificare ed esportare video e audio.


Esportazione di una sequenza SVG

Con l’aggiornamento delle impostazioni Esporta, è possibile esportare la linea temporale corrente come Sequenza SVG. Fate clic su File > Esporta > Esporta filmato... e, nel menu a discesa Salva come tipo, selezionate Sequenza SVG.

Esportare una sequenza SVG
Esportare una sequenza SVG

Esportare risorse con animazione in video, GIF animate e altro ancora

Animate offre un processo di pubblicazione efficiente per l’esportazione di risorse con animazione in GIF animate, video e altri formati. Per saperne di più su come esportare le animazioni, seguite l’esercitazione riportata alla fine di questo esempio ed effettuate le seguenti operazioni.

  1. Scegliete File > Esporta > Esporta video.

  2. Nella finestra di dialogo Esporta video, specificate le seguenti opzioni:

    • Dimensione rendering: queste impostazioni devono corrispondere rispettivamente ai valori Larghezza e Altezza dello stage.
    • Ignora colore stage (genera canale alfa): consente di creare un canale alfa utilizzando il colore dello stage.
    • Converti video in Adobe Media Encoder: consente di convertire il file MOV esportato in un formato diverso.
    • Interrompi esportazione : scegliete l’opzione richiesta per terminare l’esportazione.
    • Sfoglia: immettete il percorso in cui esportare il video.
  3. Fate clic su Esporta.

Come esportare le risorse con animazioni in video, GIF animate e altri formati.

Come esportare le risorse con animazioni in video, GIF animate e altri formati.
Guardate questo video per capire come esportare i video come GIF animate e in altri formati.

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online