Informazioni sui filtri

Panoramica sui filtri

I filtri (effetti grafici) consentono di aggiungere effetti visivi particolari a testo, pulsanti e clip filmato. Una caratteristica esclusiva di Animate consiste nella possibilità di utilizzare le interpolazioni di movimento per animare i filtri applicati.

I metodi di fusione di Animate consentono di creare immagini composite. La creazione di effetti compositi consiste nel variare la trasparenza o l'interazione di colori fra due o più oggetti sovrapposti. I metodi di fusione, inoltre, offrono un certo controllo dell'opacità di oggetti e immagini. Potete utilizzare i metodi di fusione di Animate per creare evidenziazioni o effetti ombra che consentono di vedere i dettagli di un'immagine sottostante, oppure per colorare un'immagine priva di saturazione.

Informazioni sui filtri animati

I filtri possono essere animati nella linea temporale. Gli oggetti dei singoli fotogrammi chiave uniti da un'interpolazione avranno i parametri dei filtri corrispondenti interpolati nei fotogrammi intermedi. Se un filtro non ha un filtro corrispondente (dello stesso tipo) all'estremità opposta dell'interpolazione, viene automaticamente aggiunto un filtro corrispondente per fare in modo che l'effetto si trovi alla fine della sequenza di animazione.

Per evitare un funzionamento non corretto delle interpolazioni di movimento in caso di assenza di un filtro a un'estremità dell'interpolazione, o nel caso di filtri applicati in un ordine diverso a ciascuna estremità, Animate esegue i controlli seguenti:

  • Se applicate un'interpolazione di movimento a un clip filmato a cui sono applicati dei filtri, quando inserite un fotogramma chiave all'estremità dell'interpolazione, il clip filmato ha automaticamente gli stessi filtri, con lo stesso ordine di impilamento, sia sul primo che sull'ultimo fotogramma dell'interpolazione.

  • Se si posizionano clip filmato su due fotogrammi diversi con filtri diversi e viene applicata un'interpolazione di movimento tra i fotogrammi, il clip filmato con il maggior numero di filtri viene elaborato per primo. Animate a questo punto confronta i filtri applicati al primo clip filmato con i filtri utilizzati dal secondo filmato. Se non vengono trovati filtri corrispondenti nel secondo clip filmato, Animate crea un filtro finto senza alcun parametro e del colore dei filtri esistenti.

  • Se esiste un'interpolazione di movimento tra due fotogrammi chiave e aggiungete un filtro a un oggetto presente in uno di essi, Animate aggiunge automaticamente un filtro finto al clip filmato quando raggiunge il fotogramma chiave situato all'altra estremità dell'interpolazione.

  • Se esiste un'interpolazione di movimento tra due fotogrammi chiave e rimuovete un filtro da un oggetto presente in uno di essi, Animate rimuove automaticamente il filtro corrispondente dal clip filmato quando raggiunge il fotogramma chiave situato all'altra estremità dell'interpolazione.

  • Se i parametri del filtro vengono impostati in modo non omogeneo tra l'inizio e la fine di un'interpolazione di movimento, Animate applica ai fotogrammi interpolati le impostazioni del filtro del fotogramma iniziale. Si parla di impostazioni non omogenee quando i seguenti parametri sono impostati in modo diverso all'inizio e alla fine dell'interpolazione: foratura, ombra interna, bagliore interno, tipo di bagliore con gradiente e smussatura con gradiente.

    Ad esempio, se utilizzate il filtro ombra esterna per creare un'interpolazione di movimento e applicate un'ombra esterna con foratura al primo fotogramma dell'interpolazione e un'ombra interna all'ultimo fotogramma, Animate corregge automaticamente l'uso scorretto del filtro nell'interpolazione di movimento. In questo caso, Animate applica le impostazioni del filtro utilizzate nel primo fotogramma dell'interpolazione, vale a dire un'ombra esterna con foratura.

Informazioni sui filtri e sulle prestazioni di Flash Player

Il tipo, il numero e la qualità dei filtri applicati agli oggetti possono incidere sulle prestazioni dei file SWF durante la riproduzione. Più filtri applicate agli oggetti, maggiore è la quantità di calcoli che Adobe® Flash® Player deve elaborare per visualizzare correttamente gli effetti visivi creati. Per questa ragione, Adobe® consiglia di applicare un numero limitato di filtri ai singoli oggetti.

Tutti i filtri sono provvisti dei controlli che consentono di regolare l'intensità e la qualità di applicazione. L'uso di valori più bassi consente di ottenere prestazioni migliori sui computer più lenti. Se create un contenuto da riprodurre su un'ampia gamma di computer o se non siete certi della potenza di elaborazione a disposizione del pubblico di destinazione, impostate un livello di qualità basso per ottimizzare le prestazioni di riproduzione.

Informazioni sui filtri Pixel Bender

Adobe Pixel Bender™ è un linguaggio di programmazione sviluppato da Adobe che consente agli utenti di creare filtri, effetti e metodi di fusione personalizzati da utilizzare in Animate e After Effects. Pixel Bender è indipendente dall'hardware ed è progettato in modo che possa essere e eseguito in modo efficace e automatico su diverse architetture GPU e CPU.

Gli sviluppatori che usano Pixel Bender possono creare i filtri scrivendo codice Pixel Bender e salvandolo in un file di testo con estensione pbj. Una volta scritto, il filtro Pixel Bender può essere utilizzato da qualsiasi documento Animate. Usate ActionScript® 3.0 per caricare il filtro e utilizzare i relativi controlli.

Per ulteriori informazioni sull'uso di Pixel Bender in ActionScript, consultate la Guida per gli sviluppatori di ActionScript 3.0.

Lee Brimelow ha pubblicato vari esempi pratici di Pixel Bender nel suo blog all'indirizzo http://theflashblog.com/?cat=44.

Le seguenti esercitazioni video (in inglese) illustrano l'uso dei filtri Pixel Bender in Animate:

Operazioni con i filtri

Funzione migliorata in Animate CC

Ogni volta che a un oggetto viene applicato un nuovo filtro, il filtro viene aggiunto all'elenco dei filtri di quell'oggetto nella finestra di ispezione Proprietà. Potete aggiungere più filtri a un oggetto così come rimuovere i filtri applicati in precedenza. Potete applicare i filtri solo a testo, pulsanti, clip filmato, componenti e oggetti clip compilati.

Potete creare una libreria di impostazioni filtro che consente di applicare con facilità lo stesso filtro o la stessa serie di filtri a un oggetto. Animate memorizza le preimpostazioni dei filtri creati nella sezione Filtri della finestra di ispezione Proprietà nel menu Filtri > Preimpostazioni.

Con Flash Professional CS6 e versioni precedenti, l'applicazione dei filtri era limitata ai simboli di clip filmato e di pulsanti. Con Animate CC è ora possibile applicarli anche ai clip compilati e ai componenti dei clip filmato. In questo modo potete aggiungere vari effetti direttamente ai componenti, con uno o due clic del mouse, migliorando sensibilmente il look delle vostre applicazioni. Con Flash CS6, per aggiungere filtri e altri effetti ai componenti era necessario includerli in un simbolo di clip filmato. Ovvero:

  1. Create o aggiungete un componente sullo stage.
  2. Fate clic sul componente con il pulsante destro del mouse e selezionate Converti in simbolo.
Con CS6 (e versioni precedenti) era possibile aggiungere filtri e vari altri tipi di effetti solo dopo aver racchiuso il componente all'interno di un simbolo. Tuttavia, si trattava più che altro di un ripiego e non di una procedura ottimale consigliata.
 
Ora, con Animate CC, è possibile aggiungere vari filtri ai componenti utilizzando direttamente le opzioni Filtri, Effetti colore e Impostazioni visualizzazione disponibili nel pannello Proprietà. Per comprendere meglio questo importante miglioramento, consideriamo l'esempio seguente:
 
Aggiunta di un filtro smussatura a un componente Button
 
  1. Create o aggiungete un pulsante sullo stage dal pannello Componenti, quindi selezionate il pulsante.
  2. Nel pannello Proprietà, fate clic sul pulsante di elenco a discesa nella sezione Filtri e selezionate il filtro Smussato. Vengono visualizzate le proprietà e i valori del filtro Smussato.
  3. Modificate o impostate i valori richiesti per le proprietà desiderate. Ad esempio, Sfocatura X, Sfocatura Y, Intensità, Ombra, ecc. Noterete che gli effetti vengono riprodotti istantaneamente al pulsante selezionato.
Il menu Aggiungi filtro nella finestra di ispezione Proprietà

Applicare o rimuovere un filtro

  1. Selezionate un oggetto testo, pulsante o clip filmato a cui applicare un filtro o dal quale rimuovere un filtro.
  2. Nella sezione Filtri del pannello Proprietà, effettuate una delle operazioni seguenti:

    • Per aggiungere un filtro, fate clic sul pulsante e selezionate un filtro. Provate le varie impostazioni fino a che non ottenete l'aspetto desiderato.

    • Per rimuovere un filtro, selezionate il filtro da rimuovere nell'elenco dei filtri applicati e fate clic sul pulsante Rimuovi filtro . Potete eliminare e cambiare il nome di tutti i valori preimpostati.

Copiare e incollare un filtro

  1. Selezionate l'oggetto da cui copiare un filtro, quindi selezionate il pannello Filtri.
  2. Selezionate un filtro da copiare e fate clic sul pulsante . Nell'elenco a discesa, fate clic su Copia filtro selezionato. Per copiare tutti i filtri, scegliete Copia tutti i filtri.

  3. Selezionate l'oggetto a cui desiderate applicare il filtro, quindi fate clic sul pulsante. Nell'elenco a discesa, fate clic su Incolla filtri.

Applicare un filtro preimpostato a un oggetto

  1. Selezionate l'oggetto a cui desiderate applicare un filtro preimpostato, quindi selezionate la scheda Filtro.
  2. Fate clic sul pulsante per aprire l'elenco a discesa.

  3. Nell'elenco delle preimpostazioni disponibili in fondo all'elenco a discesa, selezionate il filtro preimpostato che desiderate applicare.

Nota:

quando una preimpostazione filtro viene applicata a un oggetto, gli eventuali filtri già applicati all'oggetto selezionato vengono sostituiti dal filtro o dai filtri usati nella preimpostazione da Animate.

Attivare o disattivare un filtro applicato a un oggetto

  1. Per impostazione predefinita, tutti i filtri risultano abilitati. Fate clic sull'icona accanto al nome del filtro per disabilitare il filtro nell'elenco Filtri. Fate clic sul pulsante X accanto al nome del filtro per abilitarlo.

    Nota:

    per attivare o disattivare lo stato degli altri filtri dell'elenco, fate clic tenendo premuto il tasto Alt (Windows) o il tasto Opzione (Macintosh) sull'icona di attivazione. Se fate clic sull'icona di disattivazione tenendo premuto il tasto Alt, il filtro selezionato viene attivato mentre tutti gli altri filtri dell'elenco vengono disattivati.

Attivare o disattivare tutti i filtri applicati a un oggetto

  1. Fate clic sul pulsante e selezionate Attiva tutto o Disattiva tutto dal menu a discesa.

    Nota:

    per attivare o disattivare tutti i filtri dell'elenco, fate clic tenendo premuto il tasto Ctrl sull'icona di attivazione o sull'icona di disattivazione dell'elenco Filtri.

Creare librerie di filtri preimpostati

Potete salvare le impostazioni filtro sotto forma di librerie di filtri preimpostati che possono essere facilmente applicati a clip filmato e oggetti di testo. Questi filtri preimpostati possono essere anche condivisi con altri utenti, semplicemente fornendo loro il file di configurazione del filtro. Il file di configurazione del filtro è un file XML che viene salvato nella cartella Configuration di Animate nel percorso seguente:

 

  • Windows 7 e 8: C:\Utenti\nomeutente\AppData\Local\Adobe\Flash CC\lingua\Configuration
  • (solo Flash Professional CS6 e versioni precedenti) Windows XP: C:\Documents and Settings\nomeutente\Impostazioni locali\Dati applicazioni\Adobe\Flash CS6\lingua\Configuration\Filters\filtername.xml
  • (solo Flash Professional CS6 e versioni precedenti) Windows Vista: C:\Utenti\nomeutente\Impostazioni locali\Dati applicazioni\Adobe\Flash CS6\lingua\Configuration\Filters\filtername.xml
  • Macintosh: Macintosh HD/Utenti/nome utente/Library/Supporto applicazioni/Adobe/Flash CC /lingua/Configuration/Filters/filtername.xml

Creare una libreria di filtri con impostazioni predefinite

  1. Applicate il filtro o i filtri a qualsiasi oggetto selezionato.

  2. Fate clic sul pulsante per aggiungere un nuovo filtro.

  3. Selezionate il filtro e fate clic sul pulsante , quindi scegliete Salva come preimpostazione.

  4. Immettete un nome nella finestra di dialogo Salva preimpostazione come e fate clic su OK.

Rinominare un filtro preimpostato

  1. Fate clic sul pulsante e aggiungete un nuovo filtro.

  2. Selezionate il filtro e fate clic sul pulsante . Fate clic su Modifica preimpostazioni.

  3. Fate doppio clic sul nome della preimpostazione da modificare.

  4. Immettete un nuovo nome per la preimpostazione e fate clic su OK.

Eliminare un filtro preimpostato

  1. Fate clic sul pulsante e aggiungete un nuovo filtro.

  2. Selezionate il filtro e fate clic sul pulsante .

  3. Fate clic su Modifica preimpostazioni.

  4. Nella finestra di dialogo Modifica preimpostazioni, selezionate la preimpostazione da rimuovere e fate clic su Elimina.

Applicazione di filtri

Applicare un'ombra esterna

Il filtro Ombra esterna simula l'effetto di un'ombra proiettata da un oggetto su una superficie.

Testo con filtro Ombra esterna

Per un esempio di ombra esterna con un'interpolazione classica, consultate la pagina degli esempi di Animate all'indirizzo www.adobe.com/go/learn_fl_samples_it. Scaricate e decomprimete il file zip Samples e accedete alla directory Graphics\AnimatedDropShadow.

  1. Selezionate l'oggetto a cui applicare l'ombra esterna.
  2. Nella sezione Filtri della finestra di ispezione Proprietà, fate clic sul pulsante e selezionate Ombra esterna.

  3. Modificate le impostazione del filtro:
    • Per impostare la larghezza e l'altezza dell'ombra esterna, impostate i valori Sfocatura X e Y.
    • Per impostare la luminosità dell'ombra, impostate il valore Intensità. I valori più alti corrispondono a una minore luminosità dell'ombra e viceversa.
    • Selezionate il livello di qualità dell'ombra esterna. Una qualità alta si avvicina a una sfocatura gaussiana. Una qualità bassa permette di ottimizzare le prestazioni di riproduzione.
    • Per impostare un'angolatura per l'ombra, immettete un valore.
    • Per impostare la distanza dell'ombra dall'oggetto, impostate il valore Distanza.
    • Selezionate Foratura per nascondere l'oggetto di origine e visualizzare solo l'ombra esterna sull'immagine sottoposta a foratura.
    • Per applicare l'ombra entro i contorni dell'oggetto, selezionate Ombra interna.
    • Per nascondere l'oggetto e visualizzare solo la sua ombra, selezionate Nascondi oggetto. L'opzione Nascondi oggetto consente di creare più facilmente un'ombra dall'aspetto realistico.
    • Per aprire il selettore Colore e impostare il colore dell'ombra, fate clic sul controllo Colore.

Creare un'ombra esterna inclinata

Inclinazione del filtro Ombra esterna per ottenere un'ombra dall'aspetto più realistico

  1. Selezionate l'oggetto con l'ombra da inclinare.
  2. Duplicate (selezionando Modifica > Duplica) l'oggetto di origine.
  3. Selezionate l'oggetto duplicato e inclinatelo mediante lo strumento Trasformazione libera (Elabora > Trasforma > Ruota e inclina).
  4. Applicate il filtro Ombra esterna all'oggetto testo o clip filmato duplicato. (Risulterà già applicato se l'oggetto duplicato presenta già un'ombra esterna.)
  5. Nel pannello Filtri, selezionate Nascondi oggetto per nascondere l'oggetto duplicato mantenendone visibile l'ombra.
  6. Selezionate Elabora > Disponi > Sposta dietro per posizionare l'oggetto duplicato e la relativa ombra dietro l'oggetto originale che è stato duplicato.
  7. Regolate le impostazioni del filtro Ombra esterna e l'angolatura dell'ombra esterna inclinata finché non ottenete l'aspetto desiderato.

Applicare una sfocatura

Il filtro Sfocatura sfuma i bordi e i dettagli degli oggetti. L'applicazione della sfocatura a un oggetto può far sì che questo appaia come se fosse posizionato dietro ad altri oggetti, oppure farlo sembrare in movimento.

Testo con filtro Sfocatura

  1. Selezionate un oggetto a cui applicare una sfocatura, quindi selezionate Filtri.
  2. Fate clic sul pulsante e selezionate Sfocatura.

  3. Modificate le impostazioni del filtro nella scheda Filtro:
    • Per impostare la larghezza e l'altezza della sfocatura, impostate i valori Sfocatura X e Y.
    • Selezionate il livello di qualità della sfocatura. Una qualità alta si avvicina a una sfocatura gaussiana. Una qualità bassa permette di ottimizzare le prestazioni di riproduzione.

Applicare un bagliore

Il filtro Bagliore consente di applicare un colore attorno ai bordi di un oggetto.

Testo con filtro Bagliore

  1. Selezionate un oggetto a cui applicare un bagliore, quindi selezionate Filtri.
  2. Fate clic sul pulsante e selezionate Bagliore.

  3. Modificate le impostazioni del filtro nella scheda Filtro:
    • Per impostare la larghezza e l'altezza del bagliore, impostate i valori Sfocatura X e Y.
    • Per aprire il selettore Colore e impostare il colore del bagliore, fate clic sul controllo Colore.
    • Per impostare la nitidezza del bagliore, impostate il valore Intensità.
    • Selezionate Foratura per nascondere l'oggetto di origine e visualizzare solo il bagliore sull'immagine sottoposta a foratura.
    Uso del filtro Bagliore con l'opzione Foratura

    • Per applicare il bagliore entro i contorni dell'oggetto, selezionate Bagliore interno.
    • Selezionate il livello di Qualità del bagliore. Una qualità alta si avvicina a una sfocatura gaussiana. Una qualità bassa permette di ottimizzare le prestazioni di riproduzione.

Applicare una smussatura

La smussatura applica una sorta di evidenziazione all'oggetto che fa sì che questo appaia ricurvo, o arrotondato, verso l'alto, sulla superficie di sfondo.

Testo con smussatura

  1. Selezionate un oggetto a cui applicare una smussatura, quindi selezionate Filtri.
  2. Fate clic sul pulsante e selezionate Smussatura.

  3. Modificate le impostazioni del filtro nella scheda Filtro:
    • Per impostare il tipo di smussatura, selezionatene uno dal menu Tipo.
    • Per impostare la larghezza e l'altezza della smussatura, impostate i valori Sfocatura X e Y.
    • Selezionate un colore per l'evidenziazione e l'ombra della smussatura dalla tavolozza a comparsa dei colori.
    • Per impostare l'opacità della smussatura senza che ne venga modificata la larghezza, impostate il valore Intensità.
    • Per cambiare l'angolatura dell'ombra proiettata dal bordo smussato, impostate il valore Angolo.
    • Per definire la larghezza della smussatura, immettete un valore per Distanza.
    • Selezionate Foratura per nascondere l'oggetto di origine e visualizzare solo la smussatura sull'immagine sottoposta a foratura.

Applicare un bagliore con gradiente

Il filtro Bagliore con gradiente produce un effetto di alone/bagliore a cui viene applicato un colore a gradiente. Il bagliore con gradiente richiede la selezione di un colore all'inizio del gradiente con un valore Alfa pari a 0. La posizione di questo colore non può essere modificata, il colore sì.

Testo con bagliore con gradiente

  1. Selezionate un oggetto a cui applicare un bagliore con gradiente.
  2. Nella sezione Filtri della finestra di ispezione Proprietà, fate clic sul pulsante e selezionate Bagliore con gradiente.

  3. Modificate le impostazioni del filtro nella scheda Filtro:
    • Dal menu a comparsa Tipo, selezionate il tipo di bagliore che desiderate applicare all'oggetto.
    • Per impostare la larghezza e l'altezza del bagliore, impostate i valori Sfocatura X e Y.
    • Per impostare l'opacità del bagliore senza che ne venga modificata la larghezza, impostate il valore Intensità.
    • Per cambiare l'angolatura proiettata dal bagliore, impostate il valore Angolo.
    • Per impostare la distanza dell'ombra dall'oggetto, impostate il valore Distanza.
    • Selezionate Foratura per nascondere l'oggetto di origine e visualizzare solo il bagliore con gradiente sull'immagine sottoposta a foratura.
    • Specificate il colore a gradiente per il bagliore. Un gradiente contiene due o più colori che si dissolvono o si fondono uno nell'altro. Il colore che viene selezionato per l'inizio del gradiente è il colore alfa.
    • Per modificare un colore del gradiente, selezionate uno dei puntatori sotto la barra di definizione del gradiente, quindi fate doppio clic sull'area del colore desiderato visualizzata sotto la barra del gradiente nel Selettore colore. Lo scorrimento di questi puntatori regola il livello e la posizione del colore nel gradiente.
    • Per aggiungere un puntatore al gradiente, fate clic sulla barra di definizione del gradiente o sotto di essa. Potete aggiungere fino a 15 puntatori di colore, che consentono di creare un gradiente con un massimo di 15 transizioni di colore. Per riposizionare un puntatore sul gradiente, trascinatelo lungo la barra di definizione del gradiente. Per rimuovere un puntatore, trascinatelo verso il basso, fuori della barra di definizione del gradiente.
    • Selezionate il livello di qualità del bagliore con gradiente. Una qualità alta si avvicina a una sfocatura gaussiana. Una qualità bassa permette di ottimizzare le prestazioni di riproduzione.

Applicare una smussatura con gradiente

L'applicazione di una smussatura con gradiente fa sì che l'oggetto appaia in rilievo rispetto allo sfondo, con un colore a gradiente sulla superficie della smussatura. La smussatura con gradiente richiede la selezione di un colore al centro del gradiente con un valore Alfa pari a 0.

  1. Selezionate un oggetto a cui applicare una smussatura con gradiente.

  2. Nella sezione Filtri della finestra di ispezione Proprietà, fate clic sul pulsante e selezionate Smussatura con gradiente.

  3. Modificate le impostazioni del filtro nella scheda Filtro:

    • Dal menu a comparsa Tipo, selezionate il tipo di smussatura che desiderate applicare all'oggetto.

    • Per impostare la larghezza e l'altezza della smussatura, impostate i valori Sfocatura X e Y.

    • Per specificare l'entità della smussatura senza modificarne la larghezza, immettete un valore in Intensità.

    • Per impostare l'angolatura della sorgente luminosa, immettete un valore in Angolo.

    • Selezionate Foratura per nascondere l'oggetto di origine e visualizzare solo la smussatura con gradiente sull'immagine sottoposta a foratura.

    • Specificate il colore a gradiente per la smussatura. Un gradiente contiene due o più colori che si dissolvono o si fondono uno nell'altro. Il puntatore centrale controlla il colore alfa del gradiente. Potete modificare il colore del puntatore alfa, ma non spostare il colore nel gradiente.

      Per modificare un colore del gradiente, selezionate uno dei puntatori sotto la barra di definizione del gradiente, quindi fate doppio clic sull'area del colore desiderato visualizzata sotto la barra del gradiente nel Selettore colore. Per regolare il livello e la posizione del colore nel gradiente, fate scorrere questi puntatori.

      Per aggiungere un puntatore al gradiente, fate clic sulla barra di definizione del gradiente o sotto di essa. Potete aggiungere fino a 15 puntatori di colore, che consentono di creare un gradiente con un massimo di 15 transizioni di colore. Per riposizionare un puntatore sul gradiente, trascinatelo lungo la barra di definizione del gradiente. Per rimuovere un puntatore, trascinatelo verso il basso, fuori della barra di definizione del gradiente.

Applicare il filtro Regola colore

Il filtro Regola colore consente di controllare con precisione gli attributi di colore dell'oggetto selezionato, ad esempio contrasto, luminosità, saturazione e tonalità.

  1. Selezionate un oggetto per cui modificare il colore.
  2. Nella sezione Filtri della finestra di ispezione Proprietà, fate clic sul pulsante e selezionate Regola colore.

  3. Immettete i valori per gli attributi di colore. Di seguito sono riportati gli attributi e i valori corrispondenti:

    Contrasto

    Regola le evidenziazioni, le ombre e i mezzitoni di un'immagine.

    Luminosità

    Regola la luminosità di un'immagine.

    Saturazione

    Regola l'intensità di un colore.

    Tonalità

    Regola la tonalità di un colore.

  4. Per riportare tutte le regolazioni del colore sul valore 0 e ripristinare lo stato originario dell'oggetto, fate clic sul pulsante Ripristina filtro.

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online