Panoramica

Adobe Animate offre diverse possibilità per l’utilizzo del suono. Potete creare suoni che vengano riprodotti continuamente, indipendentemente dalla linea temporale, oppure utilizzare la linea temporale per sincronizzare l’animazione con una colonna sonora. Associate dei suoni ai pulsanti per renderli più interattivi oppure create un effetto di dissolvenza in entrata e in uscita per ottenere una colonna sonora più ricercata.

In Animate esistono due tipi di suoni: suoni associati agli eventi e audio in streaming. La riproduzione di un suono associato a un oggetto inizia quando è scaricato completamente e continua finché non viene interrotta dall’utente. L’audio in streaming invece inizia a essere riprodotto non appena sono stati scaricati dati sufficienti per i primi fotogrammi e viene sincronizzato con la linea temporale per la riproduzione su un sito Web.

Se create dei contenuti Animate per dispositivi mobili, potete includere audio per dispositivi nel file SWF pubblicato. L’audio per dispositivi viene codificato nei formati audio nativi supportati dal dispositivo, quali MIDI, MFi e SMAF.

Potete utilizzare librerie condivise per collegare un suono a più documenti. È anche possibile utilizzare l’evento onSoundComplete di ActionScript® 2.0 o soundComplete di ActionScript® 3.0 per attivare un evento al termine della riproduzione di un suono.

Potete caricare i suoni e controllarne la riproduzione utilizzando comportamenti predefiniti o componenti multimediali; questi ultimi offrono anche un controller per le operazioni di interruzione, pausa, riavvolgimento e così via. Potete anche utilizzare ActionScript 2.0 o 3.0 per caricare suoni in modo dinamico.

Per ulteriori informazioni, vedete attachSound (metodo Sound.attachSound) e loadSound (metodo Sound.loadSound) nella Guida di riferimento di ActionScript 2.0 o Classe Sound nella Guida di riferimento del linguaggio e dei componenti ActionScript 3.0.

Nota:

ActionScript 2.0 e ActionScript 1.0 non sono supportati in Animate.

Importazione di suoni

Per inserire file audio in Animate potete importarli nella libreria o direttamente nello stage.

L’opzione File > Importa > Importa nella libreria consente di inserire l’audio solo nella libreria e non nella linea temporale.

Quando importate un file audio utilizzando l’opzione File > Importa > Importa nello stage o trascinandolo direttamente nella linea temporale, l’audio viene inserito nel fotogramma attivo del livello attivo. Se trascinate più file audio, un solo file audio sarà importato, in quanto un fotogramma può contenere solo un file audio. 

Per importare file audio, utilizzate uno dei seguenti metodi:

  • Per importare un file audio nella libreria, selezionate File > Importa > Importa nella libreria, quindi selezionate il file audio da importare.
  • Per importare un file audio nello stage, selezionate File > Importa > Importa nello stage, quindi selezionate il file audio da importare. 
  • Trascinate il file audio direttamente sullo stage.
import-sounds

Nota:

Potete anche trascinare un suono da una libreria comune alla libreria del documento corrente.

Animate memorizza l’audio nella libreria insieme alle bitmap e ai simboli. È necessaria una sola copia del file audio per utilizzare lo stesso suono in diversi modi nel documento.

Per condividere l’audio tra diversi documenti Animate, inseritelo in librerie condivise.

Animate comprende una libreria Suoni, con numerosi suoni da utilizzare come effetti. Per aprire la libreria Suoni, selezionate Finestra > Librerie comuni > Suoni. Per impostare un suono dalla libreria Suoni in un file Animate, trascinatelo dalla libreria Suoni al pannello Libreria del file Animate. Potete anche trascinare i suoni dalla libreria Suoni ad altre librerie condivise.

I suoni possono occupare una notevole quantità di spazio sul disco e nella memoria RAM. I dati audio mp3, tuttavia, vengono compressi e sono di dimensioni inferiori ai dati audio WAV o AIFF. Generalmente, quando si usano file WAV o AIFF, è meglio usare audio mono a 16-22 kHz (l’audio stereo usa il doppio di dati rispetto all’audio mono), ma Animate può importare audio a 8 o 16 bit con frequenza di campionamento di 11, 22 o 44 kHz. L’audio registrato in formati che non sono multipli di 11 kHz (ad esempio 8, 32 o 96 kHz) viene ricampionato al momento dell’importazione in Animate. Animate può convertire l’audio a frequenze di campionamento inferiori al momento dell’esportazione.

Se si desidera aggiungere effetti all’audio in Animate, è preferibile importare l’audio a 16 bit. Se disponete di poca RAM, usate clip audio brevi oppure scegliete l’audio a 8 bit anziché a 16 bit.

Nota:

Per importare o riprodurre suoni in Animate, non è necessario preinstallare QuickTime o iTunes.

Formati di file audio supportati

I seguenti formati di file audio possono essere importati in Animate:

  • Adobe Sound (.asnd). Si tratta del formato audio nativo di Adobe® Soundbooth™.

  • Wave (.wav)

  • AIFF (.aif, .aifc)

  • mp3

    Potete anche importare questi altri formati audio:

  • Sound Designer® II (.sd2)

  • Sun AU (.au, .snd)

  • FLAC (.flac)

  • Ogg Vorbis (.ogg, .oga)

Nota:

  • Il formato ASND è un formato di file audio non distruttivo nativo di Soundbooth. I file ASND possono contenere dati con effetti che potete modificare in un secondo momento, sessioni multitraccia di Soundbooth e istantanee che consentono di ripristinare uno stato precedente del file ASND.
  • I doctype WebGL e HTML5 Canvas supportano solo i formati file MP3 e WAV.

Aggiunta di audio in Animate

Aggiunta di audio direttamente dal computer alla linea temporale

Potete importare l’audio direttamente dal computer alla linea temporale utilizzando uno dei seguenti metodi:

  • Selezionate File > Importa > Importa nello stage, quindi selezionate il file audio da importare.
  • Trascinate il file audio sullo stage o linea temporale. 

Tenete presente che potete aggiungere un solo file audio per volta. Se trascinate più file audio contemporaneamente, nella linea temporale verrà importato un solo file audio.

Aggiunta di audio dalla libreria alla linea temporale

Potete aggiungere un suono a un documento utilizzando la libreria oppure caricare un suono in un file SWF in fase di runtime mediante il metodo loadSound dell’oggetto Sound. Per ulteriori informazioni, consultate Sound Class nella guida di riferimento di ActionScript 3.0.

  1. Se non è già stato importato, importate l’audio nella libreria.
  2. Selezionate Inserisci > Linea temporale > Livello.

    timeline-layer
  3. Con il nuovo livello audio selezionato, trascinate il suono dal pannello Libreria allo stage. Il suono viene aggiunto al livello corrente.

    Potete posizionare più suoni su un livello o su livelli contenenti altri oggetti. Si consiglia, tuttavia, di posizionare ogni suono in un livello separato. Ogni livello agisce come un canale audio separato. I suoni presenti sui diversi livelli vengono combinati al momento della riproduzione del file SWF.

  4. Nella linea temporale, selezionate il primo fotogramma che contiene il file audio.
  5. Selezionate Finestra > Proprietà e fate clic sulla freccia nell’angolo in alto a destra per espandere la finestra di ispezione Proprietà.

  6. Nella finestra di ispezione Proprietà, selezionate il file audio dal menu a comparsa Audio.
  7. Selezionate un effetto dal menu a comparsa Effetto:

    Nessuno

    Non viene applicato alcun effetto al file audio. Selezionate questa opzione per eliminare effetti applicati precedentemente.

    Canale sinistro/Canale destro

    Riproduce l’audio rispettivamente solo nel canale sinistro o destro.

    Dissolv. da sinistra a destra/Dissolv. da destra a sinistra

    Sposta l’audio da un canale all’altro.

    Dissolvenza in entrata

    Aumenta gradualmente il volume di un suono nel corso della sua durata.

    Dissolvenza in uscita

    Riduce gradualmente il volume di un suono nel corso della sua durata.

    Personalizzata

    Consente di creare i punti di entrata e uscita del suono personalizzati utilizzando la finestra di dialogo Modifica involucro.

    Nota:

    Gli effetti non sono supportati nei documenti WebGL e HTML5 Canvas.

  8. Selezionate un’opzione di sincronizzazione dal menu a comparsa Sincronizza:

    Event

    Sincronizza il suono con l’occorrenza di un evento. Un suono associato a un evento audio viene riprodotto quando viene visualizzato il relativo fotogramma chiave iniziale e viene riprodotto interamente, indipendentemente dall’indicatore di riproduzione nella linea temporale, anche se il file SWF si interrompe. I suoni associati agli eventi vengono mixati quando si riproduce il file SWF pubblicato.

    Se durante la riproduzione di un suono associato a un evento viene creata una nuova istanza del suono, ad esempio se l’utente fa nuovamente clic sul pulsante o se l’indicatore di riproduzione supera il fotogramma chiave iniziale del suono, la prima istanza del suono continua a essere riprodotta e contemporaneamente inizia la riproduzione di un’altra istanza. Tenete presente questo aspetto quando utilizzate suoni più lunghi, perché potrebbero sovrapporsi e causare effetti audio indesiderati.

    Avvio

    Determina lo stesso comportamento di Evento, ad eccezione del fatto che se la riproduzione del suono è già iniziata, non viene riprodotta una nuova istanza.

    Interrompi

    Interrompe la riproduzione del suono specificato.

    Stream

    Sincronizza l’audio per la riproduzione su un sito Web. Animate forza l’animazione a procedere di pari passo con l’audio in streaming. Se Animate non può disegnare i fotogrammi di animazione abbastanza velocemente, alcuni fotogrammi verranno saltati. Diversamente dai suoni associati agli eventi, la riproduzione dell’audio in streaming si blocca se si interrompe il file SWF. Inoltre, l’audio in streaming non può mai essere riprodotto per una durata maggiore della lunghezza dei fotogrammi che occupa. L’audio in streaming viene mixato quando si pubblica il file SWF.

    Un esempio di audio in streaming è la voce di un personaggio di un’animazione che viene riprodotta in più fotogrammi.

    Animate memorizza le opzioni di sincronizzazione audio nella finestra di ispezione Proprietà. Se è selezionato un suono nella sezione Suono della finestra di ispezione Proprietà e tentate quindi di impostare un altro suono su un nuovo fotogramma chiave nella finestra di ispezione Proprietà, Animate riutilizza le opzioni di sincronizzazione Flusso o Evento del suono precedente.

    Nota:

    Se utilizzate un suono mp3 come audio in streaming, dovete ricomprimere il suono per l’esportazione. Potete scegliere di esportare l’audio come file mp3 con le stesse impostazioni di compressione stabilite per l’importazione.

    L’impostazione di streaming non è supportata nei documenti WebGL e HTML5 Canvas.

  9. Immettete un valore in Ripeti per specificare il numero di volte che l’audio deve essere ripetuto, oppure selezionate Ripetizione ciclica per ripetere l’audio continuamente.

    Per la riproduzione continua, immettete un valore sufficientemente elevato per riprodurre l’audio per un periodo prolungato. Ad esempio, per riprodurre un suono di 15 secondi per 15 minuti, immettete 60. La ripetizione ciclica di audio in streaming è sconsigliata. Se impostate la ripetizione ciclica di audio in streaming, al file vengono aggiunti dei fotogrammi e le sue dimensioni aumentano del numero di volte impostato per la ripetizione ciclica dell’audio.

  10. Per provare il suono, trascinate l’indicatore di riproduzione sui fotogrammi contenenti l’audio o usate i comandi del Controller o del menu Controllo.

Rimozione dell’audio dalla linea temporale

  1. Nel livello della linea temporale contenente il suono, selezionate un fotogramma che contiene anch’esso il suono.
  2. Nella finestra di ispezione Proprietà, passate alla sezione Audio e selezionate Nessuno dal menu Nome.

    Animate eliminerà il suono dal livello della linea temporale.

Aggiunta di un suono a un pulsante

Potete associare suoni ai diversi stati di un simbolo di pulsante. Poiché i suoni vengono memorizzati con il simbolo, sono presenti per tutte le istanze del simbolo.

  1. Selezionate il pulsante nel pannello Libreria.
  2. Selezionate Modifica dal menu del pannello nell’angolo superiore destro del pannello.
  3. Nella linea temporale del pulsante, aggiungete un livello per il suono (Inserisci > Linea temporale > Livello).

  4. Nel livello relativo al suono, create un fotogramma chiave normale o vuoto che corrisponda allo stato del pulsante a cui desiderate aggiungere il suono.

    Fate clic su Inserisci > Linea temporale > Fotogramma chiave oppure Inserisci > Linea temporale > Fotogramma chiave vuoto.

    Ad esempio, per aggiungere un suono che venga riprodotto quando fate clic sul pulsante, create un fotogramma chiave nel fotogramma contrassegnato dall’etichetta Giù.

    insert-keyframes
  5. Fate clic sul fotogramma chiave appena creato.
  6. Selezionate Finestra > Proprietà .

  7. Nella finestra di ispezione Proprietà, selezionate un file audio dal menu a comparsa Audio.
  8. Selezionate Evento dal menu a comparsa Sincronizza.

    Per associare un suono diverso a ognuno dei fotogrammi chiave del pulsante, create un fotogramma chiave vuoto e aggiungete un altro file audio per ogni fotogramma chiave. Potete inoltre usare lo stesso file audio e applicare un effetto audio diverso per ogni fotogramma chiave del pulsante.

Sincronizzare un suono con un’animazione

Per sincronizzare un suono con un’animazione, dovete fare iniziare e terminare il suono in corrispondenza di fotogrammi chiave.

  1. Aggiungete un suono nel rispettivo livello della linea temporale (vedete le istruzioni precedenti).
  2. Per sincronizzare il suono con un evento della scena, create un fotogramma chiave iniziale per il suono che corrisponda al fotogramma chiave dell’evento nella scena che deve attivare il suono. Potete selezionare una qualsiasi delle opzioni di sincronizzazione sopra descritte (vedete Aggiungere un suono alla linea temporale).
  3. Create un fotogramma chiave nella linea temporale del livello audio in corrispondenza del fotogramma in cui desiderate che termini il suono. Nella linea temporale appare una rappresentazione del file audio.
  4. Selezionate Finestra > Proprietà e fate clic sulla freccia nell’angolo in alto a destra per espandere la finestra di ispezione Proprietà.

  5. Nella finestra di ispezione Proprietà, selezionate lo stesso suono dal menu a comparsa Audio.
  6. Sempre nella finestra di ispezione Proprietà, selezionate Interrompi dal menu a comparsa Sincronizza.

    Quando riproducete il file SWF, l’audio si interrompe una volta raggiunto il fotogramma chiave finale.

  7. Per riprodurre il suono, trascinate l’indicatore di riproduzione nella linea temporale.

Modifica dell’audio

Modifica dell’audio in Animate

In Animate potete definire il punto iniziale di un suono o controllarne il volume durante la riproduzione, oppure cambiare il punto in cui inizia e termina la riproduzione del suono. Questo accorgimento può essere utile per ridurre le dimensioni dei file audio eliminando sezioni inutilizzate.

  1. Aggiungete un suono a un fotogramma o selezionate un fotogramma che contiene già un suono.
  2. Selezionate Finestra > Proprietà .

    windows-properties
  3. Fate clic sul pulsante Modifica sul lato destro della finestra di ispezione Proprietà.
  4. Effettuate una delle seguenti operazioni:
    • Per modificare i punti iniziale e finale di un suono, trascinate i relativi controlli nella finestra Modifica involucro.

    • Per cambiare l’involucro audio, trascinate le maniglie dell’involucro per cambiare i livelli in diversi punti dell’audio. Le linee dell’involucro indicano il volume del suono quando viene riprodotto. Per creare maniglie dell’involucro addizionali (fino a otto), fate clic sulle linee. Per rimuovere una maniglia dell’involucro, trascinatela fuori dalla finestra.

    • Per visualizzare nella finestra un periodo più o meno lungo del suono, fate clic sul pulsante Ingrandisci o Riduci.

    • Per cambiare le unità di tempo da secondi a fotogrammi e viceversa, fate clic sul pulsante Secondi o Fotogrammi.

  5. Per ascoltare il suono modificato, fate clic sul pulsante Riproduci.

Modificare un suono in Soundbooth

Se è installato Adobe Soundbooth, potete utilizzarlo per modificare i suoni importati nel file Animate. Una volta apportate le modifiche in Soundbooth, quando salvate il file e sovrascrivete l’originale, le modifiche vengono automaticamente riprodotte nel file Animate.

Se modificate il nome o il formato del file audio dopo la modifica, dovrete reimportarlo in Animate.

Nota:

Soundbooth è disponibile solo su computer Windows e su computer Macintosh basati su Intel®.®

Per importare un suono importato in Soundbooth:

  1. Fate clic con il pulsante destro del mouse (Windows) o fate clic tenendo premuto Ctrl (Macintosh) sul suono nel pannello Libreria.
  2. Selezionate Modifica in Soundbooth dal menu di scelta rapida. Il file viene aperto in Soundbooth.
  3. Modificate il file in Soundbooth.
  4. Al termine delle modifiche, salvate il file. Per salvare le modifiche in un formato non distruttivo, scegliete il formato ASND. Se salvate il file in un formato diverso dall’originale, dovete reimportare il file audio in Animate.

  5. Ritornate ad Animate per visualizzare la versione modificata del file audio nel pannello Libreria.

Nota:

Non potete modificare i suoni dalla libreria Suoni (Finestra > Librerie comuni > Suoni) con il comando Modifica in Soundbooth. Per modificare questi suoni in Soundbooth, aprite Soundbooth e selezionate il suono dal pannello relativo al centro risorse. Modificate il suono, quindi importatelo in Animate.

Dividete o ripetete ciclicamente l’audio sulla linea temporale

Divisione dell’audio sulla linea temporale

Potete dividere il flusso audio incorporato sulla linea temporale utilizzando il menu di scelta rapida Dividi audio. Dividi audio permette di mettere in pausa l’audio quando occorre e successivamente di riprendere la riproduzione, dal punto in cui era stata interrotta, su un fotogramma successivo della linea temporale. Potete scegliere di dividere il flusso audio in più parti mantenendone gli effetti.

Per dividere una clip audio sulla linea temporale e mantenerne gli effetti:

  1. Selezionate File > Importa > Importa nella libreria

  2. Selezionate la clip audio e importatela nella libreria.

  3. Create un nuovo livello sulla linea temporale e aggiungete la clip a tale livello. 

  4. In Proprietà > Audio, selezionate l’effetto.

    audio_split
  5. In Sincronizza, selezionate tipo di sincronizzazione Flusso.

    sound-properties-stream
  6. Fate clic con il pulsante destro del mouse sul fotogramma in cui desiderate dividere l’audio, quindi fate clic su Dividi audio

    Split-audio

    Nota:

    Gli effetti audio vengono mantenuti anche se l’audio viene spostato o impostato su un valore diverso di intervallo di tempo o estensione di fotogrammi.

Impostare un suono a ciclo continuo sulla linea temporale

L’audio a ciclo continuo viene ripetuto continuamente su una serie di fotogrammi sulla linea temporale. Con l’opzione “Ciclo continuo” attivata nella linea temporale, potete riprodurre in modalità continua l’audio in streaming entro un intervallo di fotogrammi, con altre animazioni.

Per creare audio a ciclo continuo, attivate l’opzione Ciclo continuo nella linea temporale:

Audio
Pulsante Ripetizione continua dell’audio nella linea temporale

Uso dei suoni in Flash Lite

Adobe® Flash® Lite supporta due tipi di suoni: l’audio Animate standard, come quello utilizzato nelle applicazioni Animate desktop, e l’audio per dispositivi. Flash Lite 1.0 supporta solo l’audio per dispositivi; Flash Lite 1.1 e 2.x supportano sia l’audio standard che l’audio per dispositivi.

L’audio per dispositivi viene archiviato nel file SWF pubblicato nel formato audio nativo (ad esempio, MIDI o MFi); durante la riproduzione, Flash Lite trasmette i dati audio al dispositivo, che a sua volta decodifica e riproduce il suono. Poiché non è possibile importare in Animate la maggior parte dei formati audio per dispositivi, dovete importare una versione proxy del file audio in un formato supportato (ad esempio MP3 o AIFF), che viene poi sostituita dall’audio per dispositivi esterno che avete specificato.

Potete usare l’audio per dispositivi solo come audio associato agli eventi e non potete sincronizzarlo con la linea temporale come i suoni standard.

Flash Lite 1.0 e 1.1 non supportano le funzioni seguenti, disponibili nella versione desktop di Flash® Player:

  • L’oggetto Sound di ActionScript

  • Caricamento di file mp3 esterni

  • L’opzione di compressione audio Voce

Per ulteriori informazioni, vedete “Operazioni con audio, video e immagini” in Sviluppo di applicazioni Flash Lite 2.x o “Operazioni con i suoni” in Sviluppo di applicazioni Flash Lite 1.x.

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online