Creazione e gestione di script

  1. Guida utente di Adobe Animate
  2. Introduzione ad Animate
    1. Novità di Animate
    2. Glossario visivo
    3. Requisiti di sistema per Animate
    4. Scelte rapide da tastiera di Animate
    5. Utilizzare diversi tipi di file in Animate
  3. Animazione
    1. Concetti di base sulle animazioni in Animate
    2. Come utilizzare i fotogrammi e i fotogrammi chiave in Animate
    3. Animazione fotogramma per fotogramma in Animate
    4. Come utilizzare le animazioni con interpolazione classica in Animate
    5. Strumento Pennello
    6. Guida di movimento
    7. Interpolazione di movimento e ActionScript 3.0
    8. L’animazione con interpolazione di movimento
    9. Animazioni con interpolazione di movimento
    10. Creazione di un’animazione con interpolazione di movimento
    11. Utilizzo dei fotogrammi chiave di proprietà
    12. Animare la posizione con un'interpolazione
    13. Come modificare le interpolazioni di movimento con l'Editor movimento
    14. Modifica del tracciato di movimento di un’animazione con interpolazione
    15. Manipolazione delle interpolazioni di movimento
    16. Aggiunta di andamenti personalizzati
    17. Creazione e applicazione di preimpostazioni di movimento
    18. Impostazione delle estensioni di interpolazione per l’animazione
    19. Operazioni con le interpolazioni di movimento salvate come file XML
    20. Interpolazioni di movimento e classiche a confronto
    21. Interpolazione di forme
    22. Utilizzare lo strumento di animazione Osso in Animate
    23. Utilizzare il rigging dei personaggi in Animate
    24. Come utilizzare i livelli maschera in Adobe Animate
    25. Come utilizzare le scene in Animate
  4. Interattività
    1. Come creare pulsanti con Animate
    2. Convertire progetti Animate in altri formati di tipi di documenti
    3. Creare e pubblicare documenti HTML5 Canvas in Animate
    4. Aggiungere interattività con gli snippet di codice in Animate
    5. Creazione di componenti HTML5 personalizzati
    6. Utilizzo dei componenti in HTML5 Canvas
    7. Creazione di componenti personalizzati: esempi
    8. Snippet di codice per componenti personalizzati
    9. Best practice - Pubblicità con Animate
    10. Creazione e pubblicazione di contenuti in realtà virtuale
  5. Area di lavoro e flusso di lavoro
    1. Creazione e gestione dei pennelli artistici
    2. Utilizzo di Google Fonts nei documenti HTML5 Canvas
    3. Utilizzo di Creative Cloud Libraries con Adobe Animate
    4. Utilizzare il pannello Strumenti e Stage per Animate
    5. Flusso di lavoro e area di lavoro di Animate
    6. Utilizzo di font Web nei documenti HTML5 Canvas
    7. Linee temporali e ActionScript
    8. Operazioni con più linee temporali
    9. Impostare le preferenze
    10. Uso dei pannelli di creazione di Animate
    11. Creare livelli della linea temporale con Animate
    12. Esportare animazioni per dispositivi mobili e motori grafici
    13. Spostamento e copia degli oggetti
    14. Modelli
    15. Trova e sostituisci in Animate
    16. Annulla, Ripeti e il pannello Cronologia
    17. Scelte rapide da tastiera
    18. Come utilizzare la linea temporale in Animate
    19. Creazione di estensioni HTML
    20. Opzioni di ottimizzazione per immagini e GIF animati
    21. Impostazioni per l’esportazione di immagini e file GIF
    22. Pannello Risorse in Animate
  6. File multimediali e video
    1. Trasformazione e combinazione di oggetti grafici in Animate
    2. Creazione e utilizzo di istanze di simboli in Animate
    3. Ricalco immagine
    4. Come utilizzare l’audio in Adobe Animate
    5. Esportazione di file SVG
    6. Creare file video da utilizzare in Animate
    7. Come aggiungere un video in Animate
    8. Operazioni con i cue point video
    9. Disegnare e creare oggetti con Animate
    10. Rimodellare linee e forme
    11. Tratti, riempimenti e gradienti con Animate CC
    12. Utilizzo di Adobe Premiere Pro e After Effects
    13. Pannelli per il colore in Animate CC
    14. Apertura di file Flash CS6 con Animate
    15. Utilizzare il testo classico in Animate
    16. Inserimento di grafica in Animate
    17. Bitmap importate in Animate
    18. Grafica 3D
    19. Utilizzo dei simboli in Animate
    20. Disegnare linee e forme con Adobe Animate
    21. Utilizzare le librerie in Animate
    22. Esportazione di suoni
    23. Selezione degli oggetti in Animate CC
    24. Utilizzare i file AI di Illustrator in Animate
    25. Applicare pattern con lo strumento Pennello spray
    26. Applicazione di metodi di fusione
    27. Disposizione degli oggetti
    28. Automazione delle operazioni con il menu Comandi
    29. Testo in più lingue
    30. Utilizzo della funzione Videocamera di Animate
    31. Utilizzo di Animate con Adobe Scout
    32. Operazioni con file di Fireworks
    33. Filtri grafici
    34. Suono e ActionScript
    35. Preferenze di disegno
    36. Disegno con lo strumento Penna
  7. Piattaforme
    1. Convertire progetti Animate in altri formati di tipi di documenti
    2. Supporto piattaforme personalizzate
    3. Creare e pubblicare documenti HTML5 Canvas in Animate
    4. Creazione e pubblicazione di un documento WebGL
    5. Come creare pacchetti di applicazioni per AIR per iOS
    6. Pubblicazione di applicazioni AIR for Android
    7. Pubblicazione per Adobe AIR per desktop
    8. Impostazioni di pubblicazione ActionScript
    9. Procedure ottimali - Organizzazione del codice ActionScript in un’applicazione
    10. Come utilizzare ActionScript con Animate
    11. Best practice - Linee guida per l’accessibilità
    12. Accessibilità dell’area di lavoro di Animate
    13. Creazione e gestione di script
    14. Abilitazione del supporto per piattaforme personalizzate
    15. Panoramica di Supporto piattaforme personalizzate
    16. Creazione di contenuto accessibile
    17. Operazioni con i plug-in di Supporto piattaforme personalizzate
    18. Debug di ActionScript 3.0
    19. Abilitazione del supporto per piattaforme personalizzate
  8. Esportazione e pubblicazione
    1. Come esportare i file da Animate CC
    2. Pubblicazione OAM
    3. Esportazione di file SVG
    4. Esportazione di elementi grafici e video con Animate
    5. Pubblicazione di documenti AS3
    6. Esportare animazioni per dispositivi mobili e motori grafici
    7. Esportazione di suoni
    8. Esportare i file video QuickTime
    9. Controllo della riproduzione dei video esterni mediante ActionScript
    10. Best practice - Suggerimenti per la creazione di contenuti per dispositivi mobili
    11. Best practice - Convenzioni per i contenuti video
    12. Best practice - Linee guida per la creazione di applicazioni SWF
    13. Best practice - Strutturazione dei file FLA
    14. Best practice per ottimizzare i file FLA per Animate
    15. Impostazioni di pubblicazione ActionScript
    16. Specificare le impostazioni di pubblicazione per Animate
    17. Esportazione di file proiettore
    18. Esportare immagini e GIF animati
    19. Modelli di pubblicazione HTML
    20. Utilizzo di Adobe Premiere Pro e After Effects
    21. Condividere e pubblicare rapidamente le animazioni

Formattare il codice

Potete formattare e applicare rientri al codice in modo automatico quando digitate. Se utilizzate la mappatura dei caratteri dinamica, avete la garanzia che per il testo multilingue vengano utilizzati i caratteri corretti.

Impostare le opzioni di Formattazione automatica

  1. Effettuate una delle seguenti operazioni:
    • Nel menu del pannello  nell’angolo in alto a destra del pannello Azioni, selezionate Preferenze.

    • Selezionate Modifica > Preferenze (Windows) o Animate > Preferenze (Macintosh) nella finestra Script.

  2. Nella finestra di dialogo Preferenze, selezionate Formattazione automatica.
  3. Selezionate le opzioni di formattazione automatica desiderate.

    Le impostazioni effettuate nella finestra Opzioni formattazione automatica vengono applicate automaticamente al codice che scrivete, ma non al codice esistente, a cui dovete applicare le impostazioni manualmente.

Formattare il codice in base alle impostazioni di Formattazione automatica

  • Fate clic su Formattazione automatica  nella barra degli strumenti del pannello Azioni o della finestra Script.
  • Nel menu del pannello visualizzato nell'angolo superiore destro del pannello Azioni, selezionate Formattazione automatica.
  • Premete Ctrl+Maiusc+F (Windows) o Comando+Maiusc+F (Macintosh).
  • Nella finestra Script, selezionate Strumenti > Formattazione automatica.

Usare la mappatura dei caratteri dinamica

  1. Per attivare o disattivare la mappatura dei caratteri dinamica, selezionate o deselezionate Usa mappatura caratteri dinamica nella finestra di dialogo Preferenze.

    Per impostazione predefinita, la mappatura dei caratteri dinamica è disattivata, in quanto aumenta il tempo richiesto per la creazione dello script. Se lavorate con testo in più lingue, attivate la mappatura dei caratteri dinamica per garantire l'uso dei caratteri corretti.

Usare il rientro automatico

  1. Per attivare o disattivare il rientro automatico, selezionate o deselezionate Rientro automatico nella finestra di dialogo Preferenze.

    Quando il rientro automatico è attivo, al testo digitato dopo un segno di parentesi aperta “(“ o “{“ viene automaticamente applicato un rientro in base alle impostazioni definite in Dimensione tabulazioni nelle preferenze di ActionScript.

    Negli script è possibile applicare un rientro a una riga selezionandola e premendo il tasto Tab. Per rimuovere il rientro, selezionate la riga e premete il Maiusc+Tab.

Sezioni di commenti nel codice

I commenti del codice sono parti di codice che vengono ignorate dal compilatore ActionScript. Una riga di commento illustra lo scopo del codice oppure disattiva temporaneamente del codice, senza eliminarlo. Potete commentare una riga di codice iniziandola con la doppia barra (//). Il compilatore ignora il testo su quella riga che segue la doppia barra. Potete anche commentare blocchi di codice più grandi posizionando una barra e un asterisco (/*) all'inizio del blocco e un asterisco e una barra (*/) alla fine del blocco.

Potete digitare questi marcatori manualmente oppure utilizzare i pulsanti nella parte superiore del pannello Azioni o della finestra Script per aggiungerli.

Commentare una riga di codice

  1. Posizionate il punto di inserimento all'inizio della riga o in corrispondenza del carattere in cui desiderate iniziare il commento.
  2. Fate clic con il pulsante destro e selezionate Commento. Potete anche usare le scelte rapide da tastiera Ctrl + M (Windows) o Comando + M oppure selezionare Modifica > Selezione commento.

Una doppia barra (//) viene collocata nel punto di inserimento.

Commentare più righe di codice

  1. Selezionate le righe da commentare. (La prima e l'ultima riga della selezione possono essere righe parziali).
  2. Fate clic con il pulsante destro e selezionate Commento. Potete anche usare le scelte rapide da tastiera Ctrl + M (Windows) o Comando + M oppure selezionare Modifica > Selezione commento.

I caratteri di blocco di commento vengono inseriti all'inizio (/*) e alla fine (*/) della selezione.

Nota:

Se sono presenti commenti tra le righe di testo selezionate, verrà applicato un commento di riga a tutte le righe selezionate.

Rimuovere un commento

  1. Posizionate il punto di inserimento nella riga contenente il commento oppure selezionate il blocco di codice commentato.
  2. Fate clic con il pulsante destro e selezionate Rimuovi commento. Potete anche usare le scelte rapide da tastiera Ctrl + Maiusc + M (Windows) o Comando + Maiusc + M oppure selezionare Modifica > Rimuovi commento da selezione.

Usare la colorazione della sintassi

In ActionScript, come in tutti i linguaggi, la sintassi identifica il modo in cui gli elementi vengono combinati tra loro per produrre un significato. Se la sintassi di ActionScript è scorretta, lo script non funziona.

Per evidenziare gli errori di sintassi, impostate il codice di colorazione delle parti dello script. Potete, ad esempio, impostare la preferenza di colorazione della sintassi in modo che le parole chiave vengano visualizzate in blu. Durante la scrittura del codice, se si digita var, la parola var viene visualizzata in blu. Se invece per errore si digita vae, la parola vae resta in nero, consentendo di riconoscere immediatamente l'errore di digitazione.

Effettuate una delle seguenti operazioni:

  • Selezionate Modifica > Preferenze (Windows) oppure Animate > Preferenze (Macintosh) e fate clic su Editor di codice nell’elenco Categoria, quindi specificate le impostazioni Colori sintassi.

  • Con il punto di inserimento nel pannello Script, premete Ctrl+U in Windows o Comando+U in Macintosh.

Nota:

quando create script nel pannello Azioni, i comandi che non sono supportati dalla versione del lettore di destinazione vengono visualizzati in giallo nella casella degli strumenti Azioni. Ad esempio, se la versione SWF di Flash Player è impostata su Flash 7, gli elementi di ActionScript che sono supportati solo in Flash Player 8 vengono visualizzati in giallo nella casella degli strumenti Azioni.

Uso degli elenchi degli identificatori e delle parole chiave in fase di runtime

All’avvio di Animate, gli elenchi degli identificatori e delle parole chiave vengono letti dal file delle risorse e memorizzati in cache. Oltre a questa operazione di lettura, il programma cerca anche ulteriori parole chiave e identificatori nella cartella Preferenze. Potete aggiungere parole chiave e identificatori supplementari inserendo dei "file .txt" nelle seguenti cartelle:

  • C:\Utenti\<nome utente>[AppData]\Roaming\Adobe\Animate\13.0[ActionscriptKeywords]\

  • C:\Utenti\<nome utente>[AppData]\Roaming\Adobe\Animate\13.0[ActionscriptIdentifiers]\

  • C:\Utenti\<nome utente>[AppData]\Roaming\Adobe\Animate\13.0[JavascriptKeywords]\

  • C:\Utenti\<nome utente>[AppData]\Roaming\Adobe\Animate\13.0[JavascriptIdentifiers]\

Uso dei numeri di riga e del ritorno a capo automatico

Con i numeri di riga è più facile scorrere nel codice e analizzarlo nella fase di modifica. L'impostazione del ritorno a capo automatico evita la necessità di scorrere orizzontalmente in righe di codice lunghe, in particolare quando si lavora nell'ambiente di creazione o con basse risoluzioni di schermo.

Attivare o disattivare i numeri di riga

  • Nella finestra Script, selezionate Visualizza > Numeri di riga.
  • Premete Ctrl+Maiusc+L (Windows) oppure Comando+Maiusc+L (Macintosh).

Evidenziare una riga specifica

  • Nella finestra Script, selezionate Modifica > Vai alla riga.

Attivare o disattivare la funzione di a capo automatico

  • Nella finestra Script, selezionate Visualizza > A capo automatico.
  • Premete Ctrl+Maiusc+B (Windows) oppure Comando+Maiusc+B (Macintosh).

Visualizzare i caratteri nascosti

Nel codice ActionScript i caratteri come gli spazi, le tabulazioni e le interruzioni di riga sono nascosti. Potreste avere la necessità di visualizzarli; ad esempio, dovete trovare e sostituire gli spazi a doppio byte che non fanno parte di un valore stringa, in quanto provocano errori di compilazione.

  • Premete Ctrl+Maiusc+8 (Windows) oppure Comando+Maiusc+8 (Macintosh).

I simboli seguenti sono usati per visualizzare i caratteri nascosti.

Carattere nascosto

Simbolo

Spazio a byte singolo

.

Spazio a doppio byte

l

Tabulazione

>>

Interruzione di riga


Cercare testo in uno script

Lo strumento Trova consente di cercare e sostituire le stringhe di testo negli script.

Nota:

per eseguire una ricerca in tutti gli script di un documento Animate, utilizzate Esplora filmato.

Cercare testo

  1. Nel pannello Azioni o nella finestra Script, selezionate Trova  oppure premete Ctrl+F (Windows) o Comando+F (Macintosh).
  2. Inserite la stringa di ricerca.
  3. Fate clic su Trova successivo.

Cercare e sostituire testo in uno script

  1. Nel pannello Azioni o nella finestra Script, selezionate Trova  oppure premete Ctrl+F (Windows) o Comando+F (Macintosh).
  2. Inserite la stringa di ricerca.
  3. Nella casella Sostituisci, immettete la nuova stringa.
  4. Fate clic su Trova successivo.
  5. Per sostituire la stringa fate clic su Sostituisci oppure, per sostituire tutte le occorrenze della stringa, fate clic su Sostituisci tutto.

(Dichiarato obsoleto in Animate) Ripetere una ricerca nel pannello Azioni

  1. Nel menu del pannello  nell’angolo in alto a destra del pannello Azioni, selezionate Trova di nuovo.

(Dichiarato obsoleto in Animate) Ripetere una ricerca nella finestra Script

  1. Scegliete Modifica > Trova di nuovo.

(Dichiarato obsoleto in Animate) Controllare la sintassi e la punteggiatura

Potete eseguire un controllo rapido del codice ActionScript senza pubblicare il file FLA.

Quando si controlla la sintassi, viene eseguita la verifica dello script corrente. Se questo script chiama delle classi ActionScript, queste vengono a loro volta verificate. Eventuali altri script presenti nel file FLA non vengono verificati.

Per i file ActionScript 2.0, il comando Controlla sintassi esegue il codice attraverso il compilatore, generando errori di sintassi e del compilatore.

Per i file ActionScript 3.0, Controlla sintassi genera solo errori di sintassi. Per generare errori del compilatore, ad esempio errori di mancata corrispondenza del tipo, valori restituiti non corretti o errori ortografici nei nomi di variabili o metodi, utilizzate il comando Controllo > Prova.

Controllare la sintassi

Per verificare la sintassi, effettuate una delle seguenti operazioni:

  • Fate clic su Controlla sintassi  nel pannello Azioni o nella finestra Script.
  • Fate clic nel riquadro dello script, quindi premete Ctrl+T (Windows) o Comando+T (Macintosh). Il riquadro dello script diventa attivo quando fate clic o scrivete al suo interno. Se è attivo un oggetto sullo stage, viene invece aperto il pannello Trasforma.

Gli errori di sintassi vengono elencati nel pannello Errori del compilatore.

Nota:

nella finestra Script di un file di classe ActionScript esterno, il percorso di classe globale (AS2) o il percorso di origine (AS3) incide sul controllo della sintassi. A volte possono essere generati errori anche se il percorso di classe globale o il percorso di origine è corretto, perché il compilatore non dispone di informazioni sulla classe compilata.

Controllare la correttezza della punteggiatura

  1. Fate clic tra le parentesi graffe {}, quadre [] o tonde () all'interno dello script.
  2. Premete Ctrl+' (apostrofo) (Windows) o Comando+' (apostrofo) (Macintosh). Il testo tra parentesi graffe, quadre o tonde viene evidenziato; è quindi possibile verificare che per la parentesi aperta sia presente la relativa parentesi chiusa.

(Dichiarato obsoleto in Animate) Importare ed esportare gli script

Potete importare uno script nel pannello Azioni o nella finestra Script. Potete anche esportare gli script dal pannello Azioni a file ActionScript esterni. Quando usate la finestra Script, l'esportazione non è necessaria perché potete invece salvare il file AS.

Se il testo degli script non ha l'aspetto desiderato quando aprite o importate un file, modificate l'impostazione relativa alla codifica per le importazioni.

Importare un file AS esterno

  1. Nel riquadro Script, posizionate il punto di inserimento dove desiderate collocare la prima riga dello script esterno.
  2. Effettuate una delle seguenti operazioni:
    • Nel pannello Azioni, selezionate Importa script dal menu del pannello, oppure premete Ctrl+Maiusc+I (Windows) o Comando+Maiusc+I (Macintosh).

    • Nella finestra Script, selezionate File > Importa script, oppure premete Ctrl+Maiusc+I (Windows) o Comando+Maiusc+I (Macintosh).

Esportare uno script dal pannello Azioni

  1. Selezionate lo script da esportare. Selezionate Esporta script dal menu del pannello Azioni, oppure premete Ctrl+Maiusc+X (Windows) o Comando+Maiusc+X (Macintosh).
  2. Salvate il file ActionScript (AS).

Impostare le opzioni di codifica testo

  1. Selezionate Modifica > Preferenze (Windows) oppure Animate > Preferenze (Macintosh) e fate clic su ActionScript nell’elenco Categoria.

  2. Impostate una o più delle opzioni seguenti:

    Apri/Importa

    Selezionate Codifica UTF-8 per aprire o importare i file utilizzando la codifica Unicode, oppure selezionate Codifica predefinita per aprire o importare i file utilizzando la codifica della lingua corrente del sistema.

    Salva/Esporta

    Selezionate Codifica UTF-8 per salvare o esportare i file utilizzando la codifica Unicode, oppure selezionate Codifica predefinita per salvare o esportare i file utilizzando la codifica della lingua corrente del sistema.

Attivare o disattivare l'avviso per la codifica di esportazione

  1. Selezionate Modifica > Preferenze (Windows) oppure Animate > Preferenze (Macintosh) e fate clic su Avvertenze nell’elenco Categoria.

  2. Selezionate o deselezionate Avverti dei conflitti di codifica nell'esportazione dei file ActionScript.

(Dichiarato obsoleto in Animate) Codifica per script importati ed esportati

Potete impostare le preferenze ActionScript in modo che sia specificato il tipo di codifica da utilizzare per i file ActionScript importati o esportati. UTF-8 è un formato Unicode a 8 bit, che consente di includere nel file testo in più lingue; la codifica predefinita è la forma di codifica supportata dalla lingua corrente utilizzata dal sistema, denominata anche tabella codici tradizionale.

Nota:

se viene utilizzata un'applicazione non in lingua italiana in un sistema in lingua italiana, il comando Prova filmato non verrà eseguito correttamente se in una parte del file SWF sono presenti caratteri che non è possibile rappresentare con lo schema di codifica MBCS (Multibyte Character Set). I percorsi della lingua giapponese, ad esempio, funzionano in un sistema in lingua giapponese, ma non in un sistema in lingua italiana. Accertatevi di utilizzare nomi di percorso in lingua italiana sui sistemi in italiano. Tutte le aree dell'applicazione che utilizzano il lettore Prova filmato sono soggette a questa limitazione.

Bloccare gli script nel pannello Azioni

Utilizzate la funzione Blocca lo script per fissare schede di singoli script nel canvas Script e per spostarle di conseguenza. Questa funzione è utile se non avete organizzato il codice all’interno del file FLA in una posizione centrale o se utilizzate più script.

Potete bloccare uno script per mantenere la posizione del codice aperto nel pannello Azioni e alternare tra i diversi script aperti. Questa funzione può essere particolarmente utile nel debug. 

Potete inoltre sbloccare uno script o sbloccare tutti gli script per sbloccare uno script selezionato o tutti gli script dal pannello Azioni.

Nella figura seguente, lo script associato alla posizione corrente nella linea temporale si trova nel fotogramma 1 del livello denominato Cleanup (la posizione corrente nella linea temporale viene indicata nella scheda più a sinistra). Lo script è inoltre bloccato come indicato nella scheda più a destra. I seguenti due script sono bloccati:

  • Nel fotogramma 1 
  • Nel fotogramma 15 del livello denominato Intro

Utilizzate le scelte rapide da tastiera o fate clic sulle schede per spostarvi tra gli script bloccati. Tali spostamenti tra i vari script bloccati non modificano la posizione corrente nella linea temporale. Se nel Navigatore Actionscript è selezionato un nuovo script, il fotogramma attivo diventa il primo, ovvero il Fotogramma 1.

Nota:

Se il contenuto visualizzato nel riquadro dello script non cambia per riflettere la posizione selezionata sulla linea temporale, è possibile che nel riquadro dello script sia visualizzato uno script bloccato. Fate clic sulla scheda del fotogramma corrente in alto a sinistra nel riquadro dello script per visualizzare lo script associato alla posizione corrente della linea temporale.

Script bloccato

Bloccare uno script

  1. Fate clic sulla linea temporale in modo che lo script venga visualizzato in una delle schede in basso a sinistra del riquadro Script nel pannello Azioni.

  2. Effettuate una delle seguenti operazioni:
    • Fate clic sull’icona della puntina da disegno a destra della scheda.
    • Selezionate Visualizza > Blocca script per bloccare lo script.

     

Sbloccare tutti gli script

  1. Selezionate lo script bloccato nel pannello Azioni.

  2. Selezionate Visualizza > Sblocca lo script per sbloccare lo script selezionato dal pannello Azioni.

  3. Selezionate Visualizza > Sblocca tutti gli script per sbloccare tutti gli script dal pannello Azioni.

Opzioni Sblocca

Tasti di scelta rapida per gli script bloccati

Quando il punto di inserimento è nel riquadro dello script, utilizzate i seguenti tasti di scelta rapida per lavorare con gli script bloccati.

Azione

Windows 

Macintosh

Blocca lo script

Ctrl+Maiusc+= (segno uguale)

Comando+Maiusc+=

Sblocca lo script

Ctrl+Maiusc+- (segno meno)

Comando+Maiusc+-

Inserire percorsi target

Molte delle azioni create nello script hanno lo scopo di incidere sui clip filmato, i pulsanti e altre istanze di simboli. Potete fare riferimento alle istanze di simboli in una linea temporale del codice, inserendo un percorso target, vale a dire l'indirizzo dell'istanza che si vuole usare come destinazione. Potete impostare un percorso assoluto o un percorso relativo. Un percorso assoluto contiene l'intero indirizzo dell'istanza, un percorso relativo contiene solo la parte dell'indirizzo che differisce dall'indirizzo dello script stesso nel file FLA e non funziona se lo script viene spostato in una diversa posizione.

  1. Fate clic su un'azione dello script nel pannello Azioni.
  2. Fate clic su Percorso target  .
  3. Inserite il percorso dell'istanza target oppure selezionatelo nell'elenco.
  4. Selezionate Assoluto o Relativo come opzione del percorso target.

Usare i suggerimenti sul codice

Quando si lavora nel pannello Azioni o nella finestra Script, il software è in grado di rilevare il tipo di azione che state eseguendo e visualizzare un suggerimento sul codice. Esistono due tipi di suggerimento sul codice: le descrizioni dei comandi, che contengono la sintassi completa di quell'azione, e un menu a comparsa nel quale sono elencati gli elementi ActionScript possibili, come nomi di proprietà e metodi (definito anche forma di completamento del codice).

I suggerimenti sul codice sono attivi per impostazione predefinita. Quando impostate le preferenze, potete disattivare i suggerimenti sul codice o determinarne la velocità di visualizzazione. Quando i suggerimenti sul codice sono disattivati nelle preferenze, è comunque possibile attivare manualmente la visualizzazione di un suggerimento sul codice per un comando specifico.

Nota:

Se non è possibile visualizzare i suggerimenti sul codice per una variabile o un oggetto creato in ActionScript 2.0 ma i suggerimenti sono attivati nelle preferenze di ActionScript, verificate di aver assegnato un suffisso corretto alla variabile o all’oggetto oppure di aver utilizzato la tipizzazione forte per la variabile o l’oggetto.

Attivazione dei suggerimenti sul codice

Potete attivare i suggerimenti sul codice in diversi modi:

Tipizzazione forte degli oggetti

Quando utilizzate ActionScript 2.0 e adottate la tipizzazione forte dei dati per una variabile basata su una classe incorporata, ad esempio Button, Array e così via, il riquadro dello script visualizza i suggerimenti sul codice per la variabile. Ad esempio, supponete di digitare le due righe seguenti di codice:

var foo:Array = new Array(); 
foo.

Non appena viene digitato il punto (.), Animate visualizza un elenco di metodi e proprietà disponibili per gli oggetti Array in un menu a comparsa, in quanto la variabile è stata digitata come un array.

Suffissi e suggerimenti sul codice

Se utilizzate ActionScript 1.0 o desiderate visualizzare i suggerimenti sul codice per gli oggetti creati senza tipizzazione forte, è necessario aggiungere un suffisso al nome di ogni oggetto al momento della sua creazione. Ad esempio, il suffisso che attiva il suggerimento del codice per la classe Camera è _cam. Supponete di digitare il codice seguente: var my_array = new Array(); var my_cam = Camera.get();

Se digitate my_cam seguito da un punto, vengono visualizzati i suggerimenti sul codice per l'oggetto Camera.

Per gli oggetti che vengono visualizzati sullo stage, utilizzate il suffisso nella casella Nome istanza della finestra di ispezione Proprietà. Ad esempio, per visualizzare i suggerimenti sul codice per gli oggetti MovieClip, utilizzate la finestra di ispezione Proprietà per assegnare i nomi di istanza con il suffisso _mc a tutti gli oggetti MovieClip. Quindi, ogni volta che digitate il nome di istanza seguito da un punto, vengono visualizzati i suggerimenti sul codice.

var my_array = new Array(); 
var my_cam = Camera.get();
Nota:

Sebbene i suffissi non siano obbligatori per l'attivazione dei suggerimenti sul codice se utilizzate la tipizzazione forte dei dati per un oggetto, il loro utilizzo regolare facilita la comprensione del codice.

La tabella seguente elenca i suffissi di attivazione dei suggerimenti sul codice in ActionScript 2.0.

Tipo di oggetto

Suffisso variabile

Array

_array

Button

_btn

Camera

_cam

Colore

_color

ContextMenu

_cm

ContextMenuItem

_cmi

Date

_date

Error

_err

LoadVars

_lv

LocalConnection

_lc

Microphone

_mic

MovieClip

_mc

MovieClipLoader

_mcl

PrintJob

_pj

NetConnection

_nc

NetStream

_ns

SharedObject

_so

Suono

_sound

String

_str

TextField

_txt

TextFormat

_fmt

Video

_video

XML

_xml

XMLNode

_xmlnode

XMLSocket

_xmlsocket

Commenti e suggerimenti sul codice

Potete inoltre usare i commenti di ActionScript per specificare la classe di un oggetto per i suggerimenti sul codice. Nell'esempio seguente un commento indica ad ActionScript che la classe dell'istanza theObject è Object e così via.

// Object theObject;// Array theArray;// MovieClip theMC;

Se successivamente digitate theMC seguito da un punto, vengono visualizzati suggerimenti sul codice contenenti l'elenco dei metodi e delle proprietà di MovieClip. Se digitate theArray seguito da un punto, vengono visualizzati suggerimenti sul codice contenenti l'elenco dei metodi e delle proprietà di Array e così via.

Invece di questa tecnica, però, Adobe consiglia l'uso della tipizzazione forte dei dati oppure dei suffissi, perché queste due tecniche attivano automaticamente i suggerimenti, rendendo il codice più comprensibile.

Definire le impostazioni delle preferenze per i suggerimenti sul codice automatici

  • Nel pannello Azioni o nella finestra Script, selezionate Modifica > Preferenze (Windows) o Animate > Preferenze (Macintosh), fate clic su Editor di codice nell’elenco Categoria, quindi abilitate o disabilitate Suggerimenti codice.

(Dichiarato obsoleto in Animate) Specificare un ritardo per i suggerimenti sul codice

  1. Selezionate Modifica > Preferenze (Windows) o Animate > Preferenze (Macintosh) nel pannello Azioni o nella finestra Script.

  2. Fate clic su ActionScript nell'elenco Categoria,
  3. Quindi utilizzate il cursore per selezionate un valore per il ritardo in secondi.

Usare i suggerimenti sul codice sotto forma di descrizioni comandi

  1. Visualizzare i suggerimenti sul codice digitando una parentesi tonda aperta “(“ dopo un elemento che richiede parentesi (ad esempio il nome di un metodo, un comando if o do..while e così via).
    Le parentesi aperte richiamano i suggerimenti sul codice

  2. Immettete un valore per il parametro.

    Nel caso di più parametri, separare i valori utilizzando la virgola. Per funzioni o istruzioni, quali il ciclo for, separare i parametri con punto e virgola.

    Con comandi di overload (funzioni o metodi che possono essere richiamati con diversi set di parametri), quali gotoAndPlay() o for, viene visualizzato un indicatore che consente di selezionare il parametro da impostare. Fate clic sui piccoli pulsanti freccia o premete Ctrl+freccia Sinistra e Ctrl+freccia Destra per selezionare il parametro.

    Suggerimento sul codice con più serie di parametri

  3. Per chiudere il suggerimento sul codice, effettuate una delle seguenti operazioni:
    • Digitate un segno di parentesi chiusa “)”.

    • Fate clic al di fuori dell'istruzione.

    • Premete il tasto Esc.

Usare i suggerimenti sul codice sotto forma di menu

  1. Visualizzate il suggerimento sul codice digitando un punto dopo il nome della variabile o dell'oggetto.
    Suggerimenti sul codice sotto forma di menu

  2. Per spostarvi tra i suggerimenti sul codice, usate i tasti Freccia su e Freccia giù.
  3. Per selezionare una voce di menu, premete il tasto Invio o Tab oppure fate doppio clic sull'elemento.
  4. Per chiudere il suggerimento sul codice, effettuate una delle seguenti operazioni:
    • Selezionate una delle voci di menu.

    • Fate clic sopra o sotto la finestra.

    • Digitate una parentesi chiusa “)” se in precedenza avete digitato una parentesi aperta “(”.

    • Premete il tasto Esc.

Visualizzare manualmente un suggerimento sul codice

  1. Fate clic all'interno del codice in una posizione per cui è possibile visualizzare i suggerimenti, ad esempio:
    • Dopo il punto (.) che segue un'istruzione o un comando dove è necessario immettere una proprietà o un metodo

    • Tra le parentesi [()] nel nome di un metodo

  2. Effettuate una delle seguenti operazioni:
    • Per abilitare manualmente i suggerimenti sul codice, selezionate Visualizza > Mostra suggerimento sul codice.

    • Premete Ctrl+Barra spaziatrice (Windows) o Comando+Barra spaziatrice (Macintosh).

Suggerimenti sul codice per le classi personalizzate

Quando create classi ActionScript 3.0 personalizzate, Animate le analizza e determina quali oggetti, proprietà e metodi esse includono, dopo di che è in grado di fornire suggerimenti sul codice quando scrivete codice che fa riferimento alle classi personalizzate. Il completamento del codice delle classi personalizzate è automatico per qualunque classe che associate a qualsiasi altro codice mediante il comando import.

I suggerimenti sul codice permettono agli sviluppatori di lavorare più velocemente perché non devono ricordare tutti gli oggetti, le proprietà e i metodi utilizzati da una classe. A loro volta, i designer possono lavorare con classi che non hanno scritto personalmente perché non devono necessariamente avere una conoscenza di prima mano dei meccanismi di funzionamento di una classe.

I suggerimenti sul codice includono:

  • Suggerimenti per i riferimenti di classe nidificati

    Quando scrivete dei riferimenti nidificati, la disponibilità immediata di suggerimenti sul codice è estremamente utile.

  • Suggerimenti sul codice per "this"

    Quando scrivete "this" in un file di classe, vengono visualizzati i suggerimenti per quella classe specifica.

  • Suggerimenti sul codice per "new+<spazio>"

    Quando digitate “new+<spazio>”, Animate visualizza un elenco di classi e pacchetti disponibili.

  • Suggerimenti sul codice per "import"

    Quando digitate “import+<spazio>”, Animate visualizza un elenco di tutti i pacchetti incorporati e personalizzati.

  • Suggerimenti per le librerie personalizzate

    Quando aggiungete una libreria SWC al percorso di libreria o al percorso di libreria esterno, Animate abilita i suggerimenti sul codice per tutte le classi incluse nel file SWC.

Logo Adobe

Accedi al tuo account