Come utilizzare i fotogrammi e i fotogrammi chiave in Animate

  1. Guida utente di Adobe Animate
  2. Introduzione ad Animate
    1. Novità di Animate
    2. Glossario visivo
    3. Requisiti di sistema per Animate
    4. Scelte rapide da tastiera di Animate
    5. Utilizzare diversi tipi di file in Animate
  3. Animazione
    1. Concetti di base sulle animazioni in Animate
    2. Come utilizzare i fotogrammi e i fotogrammi chiave in Animate
    3. Animazione fotogramma per fotogramma in Animate
    4. Come utilizzare le animazioni con interpolazione classica in Animate
    5. Strumento Pennello
    6. Guida di movimento
    7. Interpolazione di movimento e ActionScript 3.0
    8. L’animazione con interpolazione di movimento
    9. Animazioni con interpolazione di movimento
    10. Creazione di un’animazione con interpolazione di movimento
    11. Utilizzo dei fotogrammi chiave di proprietà
    12. Animare la posizione con un'interpolazione
    13. Come modificare le interpolazioni di movimento con l'Editor movimento
    14. Modifica del tracciato di movimento di un’animazione con interpolazione
    15. Manipolazione delle interpolazioni di movimento
    16. Aggiunta di andamenti personalizzati
    17. Creazione e applicazione di preimpostazioni di movimento
    18. Impostazione delle estensioni di interpolazione per l’animazione
    19. Operazioni con le interpolazioni di movimento salvate come file XML
    20. Interpolazioni di movimento e classiche a confronto
    21. Interpolazione di forme
    22. Utilizzare lo strumento di animazione Osso in Animate
    23. Utilizzare il rigging dei personaggi in Animate
    24. Come utilizzare i livelli maschera in Adobe Animate
    25. Come utilizzare le scene in Animate
  4. Interattività
    1. Come creare pulsanti con Animate
    2. Convertire progetti Animate in altri formati di tipi di documenti
    3. Creare e pubblicare documenti HTML5 Canvas in Animate
    4. Aggiungere interattività con gli snippet di codice in Animate
    5. Creazione di componenti HTML5 personalizzati
    6. Utilizzo dei componenti in HTML5 Canvas
    7. Creazione di componenti personalizzati: esempi
    8. Snippet di codice per componenti personalizzati
    9. Best practice - Pubblicità con Animate
    10. Creazione e pubblicazione di contenuti in realtà virtuale
  5. Area di lavoro e flusso di lavoro
    1. Creazione e gestione dei pennelli artistici
    2. Utilizzo di Google Fonts nei documenti HTML5 Canvas
    3. Utilizzo di Creative Cloud Libraries con Adobe Animate
    4. Utilizzare il pannello Strumenti e Stage per Animate
    5. Flusso di lavoro e area di lavoro di Animate
    6. Utilizzo di font Web nei documenti HTML5 Canvas
    7. Linee temporali e ActionScript
    8. Operazioni con più linee temporali
    9. Impostare le preferenze
    10. Uso dei pannelli di creazione di Animate
    11. Creare livelli della linea temporale con Animate
    12. Esportare animazioni per dispositivi mobili e motori grafici
    13. Spostamento e copia degli oggetti
    14. Modelli
    15. Trova e sostituisci in Animate
    16. Annulla, Ripeti e il pannello Cronologia
    17. Scelte rapide da tastiera
    18. Come utilizzare la linea temporale in Animate
    19. Creazione di estensioni HTML
    20. Opzioni di ottimizzazione per immagini e GIF animati
    21. Impostazioni per l’esportazione di immagini e file GIF
    22. Pannello Risorse in Animate
  6. File multimediali e video
    1. Trasformazione e combinazione di oggetti grafici in Animate
    2. Creazione e utilizzo di istanze di simboli in Animate
    3. Ricalco immagine
    4. Come utilizzare l’audio in Adobe Animate
    5. Esportazione di file SVG
    6. Creare file video da utilizzare in Animate
    7. Come aggiungere un video in Animate
    8. Operazioni con i cue point video
    9. Disegnare e creare oggetti con Animate
    10. Rimodellare linee e forme
    11. Tratti, riempimenti e gradienti con Animate CC
    12. Utilizzo di Adobe Premiere Pro e After Effects
    13. Pannelli per il colore in Animate CC
    14. Apertura di file Flash CS6 con Animate
    15. Utilizzare il testo classico in Animate
    16. Inserimento di grafica in Animate
    17. Bitmap importate in Animate
    18. Grafica 3D
    19. Utilizzo dei simboli in Animate
    20. Disegnare linee e forme con Adobe Animate
    21. Utilizzare le librerie in Animate
    22. Esportazione di suoni
    23. Selezione degli oggetti in Animate CC
    24. Utilizzare i file AI di Illustrator in Animate
    25. Applicare pattern con lo strumento Pennello spray
    26. Applicazione di metodi di fusione
    27. Disposizione degli oggetti
    28. Automazione delle operazioni con il menu Comandi
    29. Testo in più lingue
    30. Utilizzo della funzione Videocamera di Animate
    31. Utilizzo di Animate con Adobe Scout
    32. Operazioni con file di Fireworks
    33. Filtri grafici
    34. Suono e ActionScript
    35. Preferenze di disegno
    36. Disegno con lo strumento Penna
  7. Piattaforme
    1. Convertire progetti Animate in altri formati di tipi di documenti
    2. Supporto piattaforme personalizzate
    3. Creare e pubblicare documenti HTML5 Canvas in Animate
    4. Creazione e pubblicazione di un documento WebGL
    5. Come creare pacchetti di applicazioni per AIR per iOS
    6. Pubblicazione di applicazioni AIR for Android
    7. Pubblicazione per Adobe AIR per desktop
    8. Impostazioni di pubblicazione ActionScript
    9. Procedure ottimali - Organizzazione del codice ActionScript in un’applicazione
    10. Come utilizzare ActionScript con Animate
    11. Best practice - Linee guida per l’accessibilità
    12. Accessibilità dell’area di lavoro di Animate
    13. Creazione e gestione di script
    14. Abilitazione del supporto per piattaforme personalizzate
    15. Panoramica di Supporto piattaforme personalizzate
    16. Creazione di contenuto accessibile
    17. Operazioni con i plug-in di Supporto piattaforme personalizzate
    18. Debug di ActionScript 3.0
    19. Abilitazione del supporto per piattaforme personalizzate
  8. Esportazione e pubblicazione
    1. Come esportare i file da Animate CC
    2. Pubblicazione OAM
    3. Esportazione di file SVG
    4. Esportazione di elementi grafici e video con Animate
    5. Pubblicazione di documenti AS3
    6. Esportare animazioni per dispositivi mobili e motori grafici
    7. Esportazione di suoni
    8. Esportare i file video QuickTime
    9. Controllo della riproduzione dei video esterni mediante ActionScript
    10. Best practice - Suggerimenti per la creazione di contenuti per dispositivi mobili
    11. Best practice - Convenzioni per i contenuti video
    12. Best practice - Linee guida per la creazione di applicazioni SWF
    13. Best practice - Strutturazione dei file FLA
    14. Best practice per ottimizzare i file FLA per Animate
    15. Impostazioni di pubblicazione ActionScript
    16. Specificare le impostazioni di pubblicazione per Animate
    17. Esportazione di file proiettore
    18. Esportare immagini e GIF animati
    19. Modelli di pubblicazione HTML
    20. Utilizzo di Adobe Premiere Pro e After Effects
    21. Condividere e pubblicare rapidamente le animazioni

Panoramica

I documenti di Adobe Animate suddividono gli intervalli di tempo in fotogrammi in modo simile ai filmati. I fotogrammi stanno alla base delle animazioni e definiscono il tempo e movimento di ciascun segmento. Il numero totale di fotogrammi nel filmato e la velocità con cui vengono riprodotti determinano la durata totale del filmato. Una breve descrizione di alcuni dei concetti sui fotogrammi è illustrata di seguito per riferimento.

Fotogrammi

Nella linea temporale, i fotogrammi consentono di organizzare e controllare il contenuto del documento. I fotogrammi devono essere collocati nella linea temporale nell'ordine in cui desiderate che gli oggetti in essi contenuti vengano visualizzati nel contenuto finito.

Fotogramma chiave

Un fotogramma chiave è un fotogramma in corrispondenza del quale compare una nuova istanza di simbolo nella linea temporale. Può anche essere un fotogramma chiave che include codice ActionScript® programmato per controllare un aspetto del documento. Potete aggiungere un fotogramma chiave vuoto alla linea temporale come segnaposto per simboli da inserire in un secondo tempo oppure lasciarlo esplicitamente vuoto.

Utilizzando il fotogramma chiave potrete impostare una posizione, aggiungere punti di ancoraggio, azioni, commenti e così via. 

Estensione

La selezione di fotogrammi basata sull'estensione permette di selezionare con un singolo clic un intervallo di fotogrammi compresi tra due fotogrammi chiave.

Estensione di fotogrammi statici

In un'estensione di fotogrammi statici, lo stesso contenuto è disponibile per l'intera durata dell'estensione. Potete usare questo tipo di estensione per visualizzare degli elementi grafici per una specifica quantità di tempo. 

Estensione di fotogrammi interpolati

In un'estensione di fotogrammi interpolati, il contenuto di ciascun fotogramma cambia all'interno dell'estensione. Potete usare questo tipo di estensione per le animazioni. 

Aggiungere o inserire fotogrammi nella linea temporale

  • Per inserire un nuovo fotogramma, selezionate Inserisci > Linea temporale > Fotogramma (F5).

  • Per creare un fotogramma chiave, selezionate Inserisci > Linea temporale > Fotogramma chiave (F6) oppure fate clic con il pulsante destro del mouse (Windows) o tenendo premuto il tasto Ctrl (Macintosh) sul fotogramma in cui desiderate inserire un fotogramma chiave, quindi selezionate Inserisci fotogramma chiave dal menu di scelta rapida.

  • Per creare un fotogramma chiave vuoto, selezionate Inserisci > Linea temporale > Fotogramma chiave vuoto oppure fate clic con il pulsante destro del mouse (Windows) o tenendo premuto il tasto Ctrl (Macintosh) sul fotogramma in cui desiderate inserire il fotogramma chiave, quindi selezionate Inserisci fotogramma chiave vuoto dal menu di scelta rapida.

Effetti sui fotogrammi

I filtri e gli effetti colori in passato erano applicabili solo ai clip filmati e ai simboli grafici. Ora, con i livelli avanzati, i filtri e gli effetti colori possono essere applicati a uno o più fotogrammi selettivi, che a loro volta si applicano all’intero contenuto, tra cui forme, oggetti di disegno, simboli grafici e così via. Gli effetti di livello possono anche essere interpolati utilizzando le interpolazioni classiche, di forma e IK tutti i fotogrammi.

Per ulteriori informazioni, consultate Applicazione degli effetti di livello.

Selezionare ed etichettare fotogrammi nella linea temporale

In Animate potete selezionare i fotogrammi in due modi. Potete anche etichettare i fotogrammi per organizzarli in contenuti. 

Animate offre due metodi per selezionare i fotogrammi nella linea temporale. Con la selezione basata su fotogrammi (predefinita) selezionate i singoli fotogrammi nella linea temporale. Con la selezione basata sull'estensione, facendo clic su uno dei fotogrammi di una sequenza si seleziona l'intera sequenza, da un fotogramma chiave al successivo. 

Selezionare fotogrammi nella linea temporale

Selezione di uno o più fotogrammi

  • Fate clic sul fotogramma per selezionarlo. 
  • Per selezionare più fotogrammi adiacenti, trascinate il cursore sui fotogrammi oppure fate clic su di essi tenendo premuto il tasto Maiusc.

  • Per selezionare più fotogrammi non adiacenti, fate clic sui fotogrammi aggiuntivi tenendo premuto il tasto Ctrl (Windows) o il tasto Comando (Macintosh).

  • Per selezionare tutti i fotogrammi nella linea temporale, selezionate Modifica > Linea temporale > Seleziona tutti i fotogrammi.

Selezione dei fotogrammi in base all'estensione

Come prerequisito, potete specificare la selezione basata sull'estensione nella linea temporale di Animate facendo clic sull'icona dell'hamburger in alto a destra e selezionando la voce di menu Selezione basata su estensione

  • Per selezionare un'intera estensione di fotogrammi (interpolazione di movimento o cinematica inversa), fate clic su un fotogramma. 
  • Per selezionare più estensioni, fate clic su ciascuna di esse tenendo premuto il tasto Maiusc.

Etichettare fotogrammi nella linea temporale

Potete etichettare i fotogrammi nella linea temporale per organizzarli più facilmente. Potete anche etichettare un fotogramma per fare riferimento a tale fotogramma in ActionScript. In tal modo, se riorganizzate la linea temporale e spostate l'etichetta su un numero di fotogramma differente, il codice ActionScript farà ancora riferimento all'etichetta del fotogramma e non dovrà essere aggiornato.

Le etichette possono essere applicate solo ai fotogrammi chiave. È buona norma creare un livello separato nella linea temporale per contenere tutte le etichette di fotogramma. L'uso di un livello distinto per le etichette consente di organizzare meglio il contenuto e i fotogrammi chiave. 

Per aggiungere un'etichetta al fotogramma:

  1. Selezionate il fotogramma da etichettare nella linea temporale.

  2. Con il fotogramma selezionato, immettete il nome dell'etichetta nella sezione Etichetta della finestra di ispezione Proprietà. Premete Invio.

  3. Come linea guida, create un livello distinto per tutte le etichette nel fotogramma. 

Abilitare la selezione di fotogrammi basata sull'estensione

La selezione di fotogrammi basata sull'estensione permette di selezionare con un singolo clic un intervallo di fotogrammi compresi tra due fotogrammi chiave.

  1. Fate clic sull'icona dell'hamburger in alto a destra nella sezione della linea temporale. 

    Viene visualizzato un menu a comparsa. 

  2. Selezionate Selezione basata su estensione dal menu a comparsa. 

Distribuisci a fotogrammi chiave

L'opzione Distribuisci a fotogrammi chiave consente di distribuire più oggetti (simboli e bitmap) presenti sullo stage ciascuno a un fotogramma chiave distinto.

  1. Selezionate più oggetti su un livello dello stage.
  2. Fate clic con il pulsante destro del mouse in un punto qualsiasi dello stage e selezionate Distribuisci a fotogrammi chiave.

Copiare, incollare, eliminare o spostare un fotogramma o una sequenza di fotogrammi

Un fotogramma chiave e l’estensione di fotogrammi normali che lo seguono rappresentano una sequenza di fotogrammi chiave. La linea temporale può contenere un qualsiasi numero di sequenze di fotogrammi chiave.

Per copiare o incollare un fotogramma o una sequenza di fotogrammi, effettuate una delle seguenti operazioni:

Copiare o incollare un fotogramma o una sequenza di fotogrammi

  • Selezionate il fotogramma o la sequenza e selezionate Modifica > Linea temporale > Copia fotogrammi. Selezionate il fotogramma o la sequenza da sostituire e selezionate Modifica > Linea temporale > Incolla fotogrammi.

  • Fate clic tenendo premuto il tasto Alt (Windows) o il tasto Opzione (Macintosh) su un fotogramma chiave e trascinatelo nella posizione in cui desiderate incollarlo.

Eliminare un fotogramma o una sequenza di fotogrammi

Eliminare un fotogramma, la sequenza di fotogrammi o un fotogramma chiave

Selezionate il fotogramma o la sequenza e selezionate Modifica > Linea temporale > Rimuovi fotogramma, oppure fate clic con il pulsante destro del mouse (Windows) o tenendo premuto il tasto Ctrl (Macintosh) sul fotogramma o la sequenza e selezionate Rimuovi fotogramma dal menu di scelta rapida.

I fotogrammi circostanti rimangono invariati.

Eliminare un fotogramma chiave

Selezionate il fotogramma chiave e selezionate Modifica > Linea temporale > Cancella fotogramma chiave, oppure fate clic con il pulsante destro del mouse (Windows) o tenendo premuto il tasto Ctrl (Macintosh) sul fotogramma chiave e selezionate Cancella fotogramma chiave dal menu di scelta rapida.

Spostare un fotogramma chiave o una sequenza di fotogrammi

Per spostare un fotogramma chiave o una sequenza di fotogrammi e il relativo contenuto, trascinate il fotogramma chiave o la sequenza nella posizione desiderata.

Modificare la lunghezza di una sequenza di fotogrammi statici

Trascinate a sinistra o a destra il primo o l'ultimo fotogramma dell'estensione tenendo premuto il tasto Ctrl (Windows) o il tasto Comando (Macintosh).

Per cambiare la lunghezza di una sequenza di animazione fotogramma per fotogramma, vedete Creazione di animazioni fotogramma per fotogramma.

Visualizzare in anteprima il contenuto del fotogramma nella linea temporale

Scegliete Anteprima nel menu del pannello Linea temporale, in alto a destra nel pannello.

In ciascun fotogramma chiave della linea temporale potete visualizzare un'anteprima in miniatura degli elementi inclusi nel fotogramma.

Logo Adobe

Accedi al tuo account