ライセンス LAN サーバー設定の管理

最終更新日 : 2024年12月16日

機能制限ライセンス LAN アクティベーションは、インターネットに接続されていない安全なネットワークを維持している企業向けのアドビのライセンス方法です。 機能制限ライセンス LAN サーバー(LAN サーバーとも呼ばれます)をまだ設定していない場合は、まずこちらで説明されている手順を実行してください。 以下の各セクションでは、LAN サーバーの管理方法とトラブルシューティングについて詳しく説明します。

サーバー構成ツールのダウンロード

以下の各セクションで説明する LAN サーバーの管理コマンドや手順には、サーバー構成ツールを使用する必要があります。 まだダウンロードしていない場合は、Adobe Admin Console からこのツールをダウンロードしてください。

Admin Console で、パッケージ/ツールに移動します。

ご利用のオペレーティングシステムに適したサーバー構成ツールをダウンロードします。

サーバー構成ツールのダウンロード

ダウンロードされたサーバー構成ツール(.zip)を LAN サーバーマシンに移動します。

ダウンロードした zip ファイルの内容を LAN サーバーマシン上に展開します。

以下のコマンドを実行するには、Linux ターミナルまたは Windows PowerShell を使って、サーバー構成ツール(zip ファイル)から展開したフォルダーに移動します。

サーバーの起動

サーバーが停止していて、再度起動する必要がある場合は、以下のコマンドを入力して Enter キーを押します。

  • Windows PowerShell:
    .\scripts\adobe-lan-server.ps1 start
  • Linux ターミナル:
    ./scripts/adobe-lan-server.sh start

サーバーの停止

例えば、サーバーのデータベースをバックアップする必要がある場合や、サーバーに問題がある場合は、以下のコマンドでサーバーを停止することができます。

  • Windows PowerShell:
    .\scripts\adobe-lan-server.ps1 stop
  • Linux ターミナル:
    ./scripts/adobe-lan-server.sh stop

サーバーの起動(Windows サービスとして)

Windows サービスが停止していて、再度起動する必要がある場合は、\scripts フォルダーに移動して、次のように入力します。

  • Windows PowerShell:
    .\adobeLanService.ps1 -Start

Windows サービスの停止

サーバーのデータベースをバックアップする必要がある場合や、サーバーに問題がある場合は、\scripts フォルダーに移動し、次のコマンドを使用して Windows サービスを停止することができます。

  • Windows PowerShell:
    .\adobeLanService.ps1 -Stop
メモ

サーバーを停止すると、次のようになります。

  • 関連するすべてのサービスが停止します。
  • サーバーの内部データベースのバックアップは、次の場所に作成されます。
    <現在の作業ディレクトリ>/backup/backup.zip

サーバーの再起動

サーバーを再起動するには、次のコマンドを使用します。

  • Windows PowerShell:
    .\scripts\adobe-lan-server.ps1 restart
  • Linux ターミナル:
    ./scripts/adobe-lan-server.sh restart
メモ

現在停止している場合は、Restart コマンドでサーバーを起動できます。

サーバーを再起動すると、サーバーの内部データベースのバックアップが次の場所に作成されます。

<現在の作業ディレクトリ>/backup/backup.zip.

Windows サービスの削除

Windows Services コンソールから Windows サービスを削除するには、\scripts フォルダーに移動して次のコマンドを実行します。

  • Windows PowerShell:
    .\adobeLanService.ps1 -Remove

サーバーステータスの確認

LAN サーバーインスタンスのステータスを確認するには、次のコマンドを使用します。

  • Windows PowerShell:
    .\scripts\adobe-lan-server.ps1 status
  • Linux ターミナル:
    ./scripts/adobe-lan-server.sh status

バックアップデータベース(埋め込みのみ)

デフォルトでは、サーバーを停止すると、アプリケーションの一貫したデータベースのバックアップが実行されます。 このバックアップは、次のフォルダーに保存されます。<現在の作業ディレクトリ>/backup/backup.zip.

ただし、次のコマンドを使用して、サーバーデータベースを手動でバックアップできます。

  • Windows PowerShell:
    .\scripts\adobe-lan-server.ps1 backup -f <zip_file_name>
  • Linux ターミナル:
    ./scripts/adobe-lan-server.sh backup -f <zip_file_name>
メモ

上記のコマンドは、埋め込みデータベースのファイルコピーを指定された名前で作成し、データベースを zip ファイルにアーカイブします。

バックアップデータベースの復元(埋め込みのみ)

LAN サーバーの実行中に問題が発生した場合は、以前のバックアップから内部データベースを復元して、サーバーのトラブルシューティングを行うことができます。

  • Windows PowerShell:
    .\scripts\adobe-lan-server.ps1 restore -f <previously backed up zip_file_name>
  • Linux ターミナル:
    ./scripts/adobe-lan-server.sh restore -f <previously backed up zip_file_name>
メモ

サーバーが現在実行中の場合、Restore コマンドを実行するとサーバーが停止します。 その場合、サーバーを再度起動する必要があります。

LAN サーバーの管理に使用するコマンドに加えて、次の操作もできます。

通知の管理

LAN サーバーをセットアップした後、サーバーの更新情報をメールで送信するように設定できます。 サーバー(SMTP)とメールの設定を管理するには、以下の手順を実行します。

LAN サーバーで、https://localhost:8463 に移動します。

「メール設定」タブに移動し、必要な SMTP 設定を指定します。

Email settings - LAN server

「通知設定」タブで、メール通知を受け取るプライマリおよびセカンダリのメールアドレスを指定します。

メールアドレスを指定します

サーバーの再認証

AN サーバーインスタンスのアクティベーション期間は、ATO の作成日から最長 365 日であり、お客様企業がアドビと交わした契約の終了日までとなります。

LAN サーバーインスタンスのアクティベーション期間が終了した後、LAN アクティベーションパッケージでデプロイされたエンドユーザーマシンにライセンスを適用するためには、サーバーの再認証が必要です。

LAN サーバーで https://localhost:8463 に移動し「サーバー設定」タブに進みます。

「認証ファイルを生成」をクリックします。

「LAN サーバー設定」タブ

認証ファイルがローカルディスクにダウンロードされます。

Admin Console で、パッケージ/サーバーに進みます。

サーバーリスト

各サーバーの認証有効期限を書き留めておいてください インスタンスの認証有効期限までに再認証する必要があります。

有効期限が近付いている、または既に期限が切れているサーバーインスタンスで「再認証」をクリックします。

上記のステップ 2 で生成された新しい認証ファイルをアップロードし、「完了」をクリックします。 

認証ファイルのアップロード

ATO ファイルがローカルディスクにダウンロードされます。

LAN サーバーで https://localhost:8463 に移動し「サーバー設定」タブに進みます。

上記のステップ 5 の最後にダウンロードした ATO ファイルをアップロードします。

ATO ファイルをアップロード

「エンタイトルメントを承認」ダイアログで、サーバーに関連したエンタイトルメントを点検して、「承認」をクリックします。

再認証したサーバーインスタンスの「認証有効期限」の日付が更新され、再認証した日から 365 日後の日付が表示されるようになります。

LAN サーバーの詳細の編集

LAN サーバーインスタンスを設定した後、DNS アドレスやポート番号などのサーバーの詳細情報を編集できます。

Admin Console で、パッケージ/サーバーに進みます。

サーバーリスト

サーバーの行項目をクリックし、右側のペインで「編集」をクリックします。

設定画面で、必要に応じて、次のフィールドを編集します。

  • LAN サーバーの「DNS アドレス」と「ポートロケーション」
  • クライアントがライセンスサーバーにアクセスせずに稼働できる時間を指定するには、「LAN タイムアウト」を設定します。
  • 追加ライセンス数が購入された割り当てを超えた場合でも追加ライセンスを有効化できるようにするには、ソフトクォータを選択します。
  • 追加ライセンス数が購入された割り当てを超えた場合に追加ライセンスを有効化できないようにするには、ハードクォータ(ETLA のみ)を選択します。
メモ

指定するサーバーロケーションへクライアントが必ずアクセスできるようにします。 そうでない場合、クライアントのマシンではライセンスアクティベーションができません。

組織名を記入して「次へ」をクリックします。

ユーザーにはそれがメッセージで組織名として表示されます。

現在のサーバーでホストする製品を選び、「次へ」をクリックします。

エンドユーザーエンタイトルメントは選択する製品に基づいています。

使用権限を選択してください

「完成」画面では、サーバー用の名前を特定し、サーバー情報を点検し、「サーバーを作成」をクリックします。

サーバーを作成

サーバーの作成が完了すると、ATO ファイルがコンピューターにダウンロードされます。

LAN サーバーで https://localhost:8463 に移動し「サーバー設定」タブに進みます。

上記のステップ 6 でダウンロードした ATO ファイルをアップロードします。

ATO ファイルをアップロード

「エンタイトルメントを承認」ダイアログで、サーバーに関連したエンタイトルメントを点検して、「承認」をクリックします。

LAN サーバーを編集する場合は、LAN アクティベーションパッケージを作成してから、エンドユーザーのマシンに再デプロイする必要があります。
LAN アクティベーションパッケージを再デプロイするには、次のいずれかの方法を使用します:

外部データベースに接続するサーバーのサポート

外部データベース接続の一部として、以下の設定が行われていることを確認します。

メモ

正しく設定されていない場合、データベースへの接続に失敗し、サーバーが起動しなくなる可能性があります。

データベースとスキーマの作成

セットアップスクリプトまたは AdobeFRLLanService スクリプトを実行する前に、データベースとスキーマを作成します(Microsoft SQL Server の場合のみ)。 また、セットアップスクリプトにデータベース名とデータベーススキーマの詳細を入力する際に、必ず同じ値を指定してください。

新規データベースユーザーの作成

新しく作成したデータベースとスキーマに対して、新しいデータベースユーザーを作成することをお勧めします。 また、新しいデータベースとスキーマに必要なすべての権限(特に CRUD 操作権限)が、この新しいデータベースユーザーに付与されていることを確認してください。 新しいユーザーのアクセス権限をこの新しいデータベースのみに制限します。 新しいユーザー資格情報は、サーバーのセットアップ中に指定します

データベースサーバーでのリモート接続の有効化

データベースサーバーと LAN サーバーが別のマシンでホストされている場合は、データベースサーバーでリモート接続を有効にする必要があります。 また、データベースにリモートで接続およびアクセスするための権限をデータベースユーザーに与える必要があります。

リモート接続用データベースポートのブロックの解除

データベースサーバーがホストされているマシン上の任意の TCP ポートへの外部通信が、ファイアウォールによってブロックされることがあります。 解決方法:

Windows の場合:データベースサーバーが稼働している TCP ポートに対してインバウンドルールが作成されていることを確認します。

CentOS の場合:iptables コマンドを使用して、TCP ポートのブロックを解除します。

データベースサーバーとの SSL 通信

セットアップスクリプトで、SSL を使用してデータベースサーバーに接続する必要がある場合は、データベースサーバーで SSL が有効になっていることを確認します。

SSL 証明書の更新

LAN サーバーで使用している SSL 証明書の有効期限が切れている場合は、以下の手順で証明書を更新します。

次のいずれかのコマンドを使用して、LAN サーバーを停止します。

  • Windows PowerShell:
    .\scripts\adobe-lan-server.ps1 stop
  • Linux ターミナル:
    ./scripts/adobe-lan-server.sh stop

Windows サーバーを使用している場合は、次のコマンドを使用して Windows サービスを停止します。

.\adobeLanService.ps1 -Stop

次のものを手元に用意してください。

以前使用した名前、エイリアス、パスワード、キーストアファイル

新しい名前、エイリアス、パスワード、キーストアファイル

次のコマンドを使用してエイリアスを変更します。

keytool -changealias -alias <以前のエイリアス> -destalias <新しいエイリアス> -keypass <キーストアパスワード> -keystore <以前のキーストア名> -storetype <PKCS12|JKS>  -v

次のコマンドを使用してパスワードを変更します。

keytool -storepasswd -new -keystore <キーストア名> -storepass <キーストアパスワード> -storetype <PKCS12|JKS>  -v

上記のコマンドを実行すると、新しいキーストアパスワードを指定するように求められます。

バックアップを保持するには、以前のキーストアファイルの名前を変更します。

例えば、名前を次のように変更します<キーストア> .old。

次のいずれかのコマンドを使用して、LAN サーバーを起動します。

  • Windows PowerShell:
    .\scripts\adobe-lan-server.ps1 start
  • Linux ターミナル:
    ./scripts/adobe-lan-server.sh start

Windows サーバーを使用している場合は、次のコマンドを使用して Windows サービスを起動します。

.\adobeLanService.ps1 -Start

https://localhost:8463 にアクセスし、新しいキーストアファイルを使用してサーバーが稼働していることを確認します。

LAN サーバーのトラブルシューティング

LAN サーバーは、定期的に再起動することをお勧めします。 これにより、サーバーデータベースの最新のバックアップが維持されます。 また、停止サイクルと再起動サイクルの間に、データベースを定期的に手動でバックアップすることもできます。

以下のエラーを解決するには、データベースを以前にバックアップしたバージョンに復元する必要があります。

- org.h2.jdbc.JdbcSQLException: Encryption error in file null
- org.springframework.jdbc.support.MetaDataAccessException: Could not get Connection for extracting meta-data;
nested exception is org.springframework.jdbc.CannotGetJdbcConnectionException: Failed to obtain JDBC Connection;
nested exception is org.h2.jdbc.JdbcSQLException: Encryption error in file null [90049-197]

データベースを復元するには:

サーバーの停止:

  • Windows PowerShell:
    .\scripts\adobe-lan-server.ps1 stop
  • Linux ターミナル:
    ./scripts/adobe-lan-server.sh stop

サーバーデータベースを以前にバックアップしたバージョンに復元します。

  • Windows PowerShell:
    .\scripts\adobe-lan-server.ps1 restore -f <previously backed up zip_file_name>
  • Linux ターミナル:
    ./scripts/adobe-lan-server.sh restore -f <previously backed up zip_file_name>

サーバーの起動:

  • Windows PowerShell:
    .\scripts\adobe-lan-server.ps1 start
  • Linux ターミナル:
    ./scripts/adobe-lan-server.sh start

エンドユーザーマシンのライセンスがアクティブ化されていない場合:

  • エンドユーザーマシンが LAN サーバーマシンに接続できることを確認します。
  • Adobe Admin Console で、LAN サーバーの DNS アドレスとポート番号を確認し、これらが LAN サーバーに使用しているマシンと一致していることを確認します。 上記の「LAN サーバーの詳細の編集」セクションを参照してサーバーの詳細情報を確認し、必要に応じて編集します。
  • エンドユーザーのマシンがサーバーに接続できるが、ライセンスをアクティベートできない場合は、サーバーが自己署名 SSL 証明書使用しているかどうかを確認してください。 サーバーが自己署名 SSL 証明書を使用している場合(非推奨):
    1. エンドユーザーマシンで動作しているアドビアプリケーションを終了します。
    2. 自己署名証明書をエンドユーザーマシンにインストールします。
    3. 自己署名証明書をインストールした後、アプリケーションを再起動します。

エンドユーザーは、LAN アクティベーションパッケージを介してインストールされたアプリケーションを起動すると、次のエラーが表示されます。

Windows 7、64 ビットでアプリを起動中のエラー

このエラーは、LAN アクティベーションパッケージが Windows 7、64 ビットマシンにインストールされていて、LAN サーバーに自己署名 SSL 証明書が設定されている場合に発生します。

この問題が発生するのは、クライアントマシンが設定した LAN サーバーに接続できないことが原因です。

解決策:

この問題を解決するには、クライアントマシンで自己署名証明書を設定する際に、SAN(Subject Alternative Name)に LAN サーバーの DNS 名を指定する必要があります。

以下は、自己署名証明書を生成するためのコマンドラインの例です。

C:\keytool.exe" -genkeypair -alias adminService -keyalg RSA -keysize 4096 -sigalg SHA512withRSA -ext SAN=dns:10.42.66.139,ip:127.0.0.1,ip:::1 -keystore adminService.jks -validity 3650

SAN パラメータには DNS 用の 2 つのエントリがあることに注意してください。 1 つは localhost、もう 1 つは LAN サーバー DNS 用です。 Windows 7 マシンで自己署名証明書を生成する場合は、SAN の DNS サーバーエントリが必須です。

PowerShell スクリプトを実行すると、次のエラーが発生する場合があります。

信頼された発行元からのスクリプトのみを実行してください

問題を解決するには、次の手順を実行します。

回避策 1

PowerShell で、この発行者からのスクリプトを「常に」実行するよう求められますが、これを「常に」許可します。

  1. Windows エクスプローラーで、このエラーが発生したときに実行した PowerShell スクリプトに移動します。
  2. ファイルを右クリックして、プロパティ/デジタル署名を選択します。
  3. 署名を選択し、詳細/証明書を表示をクリックします。
  4. 「詳細」タブを選択し、「ファイルにコピー」をクリックします。
  5. ファイルの拡張子を .CER にして保存します。
  6. Certificates MMC Snapin を使用して、このファイルをローカルマシンの Trusted Publishers Certificate Store に読み込みます。

回避策 2

昇格した PowerShell で、次のコマンドを使用して、実行ポリシーを「RemoteSigned」または「無制限」に設定します。

Set-ExecutionPolicy RemoteSigned
または
Set-ExecutionPolicy Unrestricted

既知の問題

アドビは、これらの問題やその他の問題が発生した場合、できる限り早急に対処するよう努めています。

クライアントマシンで LAN アクティベーションパッケージをアンインストールしても、Admin Console や LAN Server Management Console の機能制限ライセンス数に反映されません。