Profundidad de color y color de rango dinámico alto

Profundidad de color (o profundidad de bits) es el número de bits por canal (bpc) usado para representar el color de un píxel. Cuantos más bits tenga cada canal RGB (rojo, verde y azul), más colores puede representar cada píxel.

En After Effects puede trabajar en color de 8, 16 ó 32 bpc.

Además de la profundidad de bits de color, una característica independiente de los números utilizados para representar valores de píxel es que pueden ser números enteros o números de coma flotante. Los números de coma flotante pueden representar un rango mucho mayor de números con el mismo número de bits. En After Effects, los valores de píxel de 32 bpc son valores de coma flotante.

Los píxeles de 8 bpc pueden tener valores para cada canal de color desde 0 (negro) a 255 (color puro saturado). Los píxeles de 16 bpc pueden tener valores para cada canal de color desde 0 (negro) a 32.768 (color puro saturado). Si los tres canales de color tienen el valor de color puro máximo, el resultado es el blanco. Los píxeles de 32 bpc pueden tener valores por debajo de 0.0 y por encima de 1.0 (color puro saturado), por lo que un color de 32 bpc en After Effects es también un color de rango dinámico alto (HDR). Los valores HDR pueden ser mucho más brillantes que el blanco.

Ajuste de la profundidad de color y modificación de los ajustes de color y pantalla

El ajuste de la profundidad de color para un proyecto determina la profundidad de bits para los valores de color en un proyecto.

Para establecer la profundidad de color para un proyecto, realice lo siguiente:

  • Mantenga pulsado Alt (Windows) u Opción (Mac OS) y haga clic en el botón Ajustes del proyecto del panel Proyecto.

  • Seleccione Archivo > Ajustes del proyecto o haga clic en el botón Ajustes de proyecto del panel Proyecto y seleccione una profundidad de color en el menú Profundidad.

Puede especificar una profundidad de color para cada elemento de procesamiento, que anule la profundidad de color del proyecto al procesarlo para la salida final. Puede especificar también la profundidad de color que desea utilizar para cada elemento de salida en los ajustes del módulo de salida. (Consulte Ajustes de procesamiento y Módulos de salida y Ajustes de módulos de salida.)

Nota:

Para cambiar el formato en el que aparecen los valores de color en el panel Información y en algunos controles de efectos, seleccione una opción como Porcentaje o Web en el menú del panel Información. La selección de Visualización automática de colores alterna entre 8, 16 y 32 bpc, dependiendo de la profundidad de color del proyecto.

Aunque muchos efectos pueden funcionar con todas las profundidades de color, algunos solo funcionan con profundidades más bajas. Puede definir el panel Efectos y ajustes preestablecidos para que solo muestre los efectos que funcionen con la profundidad de color de proyecto actual. (Consulte Panel Efectos y ajustes preestablecidos.)

Ventajas comparativas de cada profundidad de color

El rango dinámico (proporción entre las regiones oscuras y claras) del mundo físico supera con mucho el rango de la visión humana y de las imágenes que se imprimen en papel o muestran en un monitor. Los valores de color de 8 bpc y 16 bpc de rango dinámico bajo pueden representar niveles de RGB solo de blanco a negro, lo que supone únicamente un pequeño segmento del rango dinámico en el mundo real.

Con Rango dinámico alto (HDR), los valores de color de coma flotante de 32 bpc pueden representar niveles de brillo muy superiores al blanco, incluidos objetos tan brillantes como una llama o el sol.

Efecto Resplandor y efecto Desenfoque gaussiano aplicados a una imagen de un proyecto de 32 bpc y de 16 bpc
Efecto Resplandor y efecto Desenfoque gaussiano aplicados a una imagen de un proyecto de 32 bpc (izquierda) y a un proyecto de 16 bpc (derecha)

Defina la profundidad de color del proyecto a 32 bpc para trabajar con material de archivo HDR o para trabajar con valores que superen el rango (valores por encima de 1 (blanco) que no son compatibles con el modo de 8 o de 16 bpc). Los valores que superan el rango mantienen la intensidad de los resaltes, lo que resulta útil para efectos sintéticos tales como luces, desenfoques y resplandores al igual que para trabajar con material de archivo HDR. El margen que se ofrece al trabajar en 32 bpc evita muchas tipos de pérdidas de datos durante operaciones como corrección de color y conversión de perfiles de color.

Aunque se utilice material de archivo de 8 bpc y se creen películas en formatos de 8 bpc, es posible obtener mejores resultados si la profundidad de color del proyecto es de 16 ó 32 bpc. Si se trabaja en una profundidad de bit mayor, se consigue una mayor precisión de los cálculos y se reducen en gran medida los efectos de cuantificación, como sucede con las bandas en degradados.

Nota:

Simplemente aumentado la profundidad de color en un proyecto, no se eliminarán los degradados si el formato de salida tiene una profundidad de bits baja. Para eliminar los problemas de bandas, After Effects introduce el tramado de colores cuando estos se convierten a colores de 8 bpc, incluyendo cuando se procesa y se exporta con un formato de 8 bpc. Este tramado no se introduce para las previsualizaciones. Para aplicar el tramado en las previsualizaciones, utilice un efecto 8 bpc que no realice ninguna operación como, por ejemplo, el efecto Aritmética con los valores predeterminados, en una capa de ajuste.

Dado que los fotogramas de 16 bpc utilizan la mitad de memoria que los fotogramas de 32 bpc, el procesamiento de previsualizaciones de un proyecto de 16 bpc es más rápido y las previsualizaciones pueden ser más largas que en un proyecto de 32 bpc. Los fotogramas de 8 bpc utilizan incluso menos memoria, aunque el equilibrio entre calidad y rendimiento es evidente en algunas imágenes con una profundidad de color de proyecto de 8 bpc.

Consideraciones especiales a la hora de trabajar con color de rango dinámico alto

Puede utilizar el efecto HDR Compander para comprimir el rango dinámico de una capa con un elemento de material de archivo HDR como su origen. De este modo, podrá utilizar herramientas que no admiten color HDR, como efectos de 8 bpc y de 16 bits. Una vez haya terminado, use HDR Compander para deshacer la compresión de rango dinámico. El efecto Compresión resaltada HDR le permite comprimir los valores de resaltado en una imagen HDR para incluirla en el intervalo de valores de una imagen de rango dinámico.

Debido a que únicamente se puede ver un subconjunto de valores de luminancia en una escena del mundo real, en una imagen HDR de un monitor, a veces es necesario ajustar la exposición, la cantidad de luz capturada en una imagen, cuando se trabaja con una imagen HDR. El ajuste de la exposición de una imagen HDR es como el ajuste de la exposición al fotografiar una escena en el mundo real, lo que permite extraer detalles de las zonas oscuras y las zonas brillantes. Puede utilizar el efecto Exposición para cambiar los valores de color de una capa en la salida final, o puede ajustar simplemente la exposición en un visor específico con fines de previsualización.

Nota:

Debido a que algunas operaciones, entre las que se incluyen los modos de fusión, desenfoques, resplandores, se comportan de modo diferente en modo de 32 bpc en comparación con el modo de 8 ó 16 bpc, el aspecto de la composición puede ser muy diferente cuando se cambie entre ajustes del proyecto de rango dinámico alto y bajo.

Recursos adicionales sobre el color de rango dinámico

Chris Meyer explica qué color HDR de coma flotante y de 32 bpc resulta adecuado en una descripción general en vídeo en el sitio web Lynda.com.

Andrew Kramer proporciona un tutorial de vídeo en su sitio web Video Copilot (en inglés) en el que se muestran las ventajas del uso del color de 32 bpc con desenfoque de movimiento.

En su sitio web fnord, Brendan Bolles explica cómo utilizar el efecto Convertidor de perfiles de color y los perfiles de color de película para ajustar colores y llevar a cabo la asignación de tonos para hacer que una imagen HDR aparezca como si se filmara en una pelí­cula con imágenes en movimiento.

Selección de un color o edición de un degradado

En muchos contextos, puede hacer clic en el botón para activar la herramienta cuentagotas, o bien hacer clic en una muestra de color para abrir un selector de color. Si utiliza el Selector de color de Adobe, puede activar también el cuentagotas del cuadro de diálogo Selector de color de Adobe.

Si hace clic en una muestra de degradado (Degradado lineal o Degradado de relleno) para un trazo o relleno en una capa de forma, se abre el Selector de color de Adobe como Editor de degradado, con controles adicionales para editar degradados incluidos en la parte superior del cuadro de diálogo. También puede hacer clic en Editar degradado en el panel Línea de tiempo para abrir el Editor de degradado.

Andrew Devis muestra cómo modificar los rellenos de degradado y los trazos de las capas de formas, y otras opciones en un vídeo en el sitio Web de Creative COW.

Nota:

El método de expresión sampleImage es otra forma de muestrear valores de color. Utilice este método para usar valores de color de píxeles específicos como entradas en una expresión. (Consulte los atributos y métodos generales de la capa (referencia de expresión).)

Editor de degradado pantalla
A. Detención de opacidad B. Detención de color C. Punto medio de opacidad D. Cuentagotas E. Rectángulo de color nuevo F. Rectángulo de color original 

Selección de un selector de color

  • Para elegir el color del sistema, seleccione Edición > Preferencias > General (Windows) o After Effects > Preferencias > General (Mac OS) y marque la casilla Utilizar el selector de color del sistema.
  • Para utilizar el Selector de color de Adobe, mantenga desactivada la casilla Utilizar el selector de color del sistema y seleccione Ventana > Extensiones > Temas de Adobe Color.

Nota:

Jeff Almasol proporciona la secuencia de comandos PickerSwitcher en su sitio web redefinery, que alterna el ajuste Utilizar el selector de color del sistema. Utilice esta secuencia de comandos cuando prefiera emplear el Selector de color de Adobe para determinadas tareas y el selector del color del sistema para otras y desee una forma rápida de cambiar este ajuste. 

Selección de un color para la herramienta Cuentagotas

  1. Haga clic en el botón Cuentagotas y mueva el puntero hasta el píxel que desea muestrear. La muestra de color próxima al botón Cuentagotas cambia dinámicamente al color bajo el Cuentagotas.
  2. Realice una de las operaciones siguientes:
    • Para seleccionar el color de un solo píxel, haga clic en el píxel.

    • Para muestrear el promedio de color de un área de 5 x 5 píxeles, presione la tecla Control (Windows) o Comando (Mac OS) y haga clic en el área.

    Nota:

    Cuando se muestrea desde dentro del fotograma de la composición del panel Composición, el cuentagotas ignora por defecto el color de fondo de la composición y muestrea únicamente los canales de color rectos. Para muestrear canales de color premultiplicados con el color de fondo de la composición, presione Mayús cuando haga clic con el cuentagotas. Al presionar Mayús con el cuentagotas se muestrean los colores conforme aparecen en el fotograma de composición en el panel Composición.

Nota:

Presione la tecla Escape para desactivar el cuentagotas.

Selección de un color con Selector de color de Adobe

En el Selector de color de Adobe, puede elegir los colores mediante uno de los modelos de color o utilizar el regulador de colores y el campo de color para elegir el color.

Están disponibles los modelos de color siguientes:

  • HSB
  • RGB
  • Lab
  • CMYK
  • Valor hexadecimal

Utilice el regulador de color para elegir un color:

  • Arrastre los triángulos a lo largo del regulador de color o haga clic dentro de un regulador de color para ajustar los colores mostrados en el espectro de color.
  • Haga clic o arrastre dentro del espectro de color cuadrado grande para seleccionar un color. Un marcador circular indica la ubicación del color en el espectro de color.
  1. Haga clic en Ventana > Extensiones > Temas de Adobe Color para mostrar el Selector de color de Adobe.

  2. (Opcional) Para evitar que los paneles se actualicen con los resultados de su selección de color hasta que acepte el color haciendo clic en Aceptar, anule la selección Previsualización del cuadro de diálogo Selector de color. La opción Previsualización no está disponible en todos los contextos.

    Nota:

    Es conveniente seleccionar Previsualización para ver los resultados de las selecciones de color antes de asignarlas, pero esto puede reducir también el rendimiento ya que las imágenes nuevas se procesan para la previsualización en el panel Composición o en el panel Capa.

  3. Especifique los valores de los componentes en los cuadros de texto. Seleccione el componente que desea utilizar para mostrar el espectro de color:

    HSB

    Para HSB, especifique el tono (H) como un ángulo de 0° a 360°, que se corresponde con una posición en la rueda de color. Especifique la saturación (S) y el brillo (B) como porcentajes (de 0 a 100).

    H

    Muestra todos los tonos en el regulador de color. Cuando se selecciona un tono en el regulador de color, se muestran el rango de saturación y brillo del tono seleccionado en el espectro de color; la saturación aumenta de izquierda a derecha y el brillo aumenta de abajo a arriba.

    S

    Muestra todos los tonos del espectro de color; el brillo máximo se encuentra en la parte superior del espectro, y va bajando hasta el valor mínimo, en la parte inferior. El regulador de color muestra el color seleccionado en el espectro con su máxima saturación en la parte superior y su mínima saturación en la parte inferior.

    B

    Muestra todos los tonos del espectro de color desde la máxima saturación, en la parte superior del espectro, hasta la saturación mínima, en la parte inferior. El regulador de color muestra el color seleccionado en el espectro de color con su brillo máximo en la parte superior y su brillo mínimo en la parte inferior.

    RGB

    Para RGB, especifique los valores de componente. Puede definir colores con valores por debajo del rango y por encima del rango (fuera del rango entre 0 y 1) en un proyecto HDR.

    R

    Muestra el componente de color rojo en el regulador de color, con su brillo máximo en la parte superior y su brillo mínimo en la parte inferior. Cuando el regulador de color se define en el brillo mínimo, el espectro de color muestra los colores creados por los componentes de color verde y azul. Al utilizar el regulador de color para aumentar el brillo del rojo, se mezcla más rojo en los colores mostrados en el espectro de color.

    G

    Muestra el componente de color verde en el regulador de color, con su brillo máximo en la parte superior y su brillo mínimo en la parte inferior. Cuando el regulador de color se define en el brillo mínimo, el espectro de color muestra los colores creados por los componentes de color rojo y azul. Al utilizar el regulador de color para aumentar el brillo del verde, se mezcla más verde en los colores mostrados en el espectro de color.

    B

    Muestra el componente de color azul en el regulador de color, con su brillo máximo en la parte superior y su brillo mínimo en la parte inferior. Cuando el regulador de color se define en el brillo mínimo, el espectro de color muestra los colores creados por los componentes de color verde y rojo. Al utilizar el regulador de color para aumentar el brillo del azul, se mezcla más azul en los colores mostrados en el espectro de color.

    CMYK

    Especifique el valor de cada componente como un porcentaje de cian, magenta, amarillo y negro en el campo de texto para obtener un color específico.  

    Lab

    L

    Denota la luminancia de un color (de 0 a 100)

    a

    La cantidad de rojo o verde en un color (de -128 a +127)

    b

    La cantidad de azul o amarillo de en un color (de -128 a +127)

    Valor hexadecimal

    Especifique valores en formato hexadecimal. Los números pueden variar desde #000000 a #ffffff. Por ejemplo, #000000 representa negro y #ffffff representa blanco.

Edición de degradados

Un degradado se define con detenciones de color y detenciones de opacidad. Cada detención tiene una ubicación a lo largo del degradado y un valor para color u opacidad. Los valores entre detenciones están interpolados. De forma predeterminada, la interpolación es lineal, pero puede arrastrarse el punto medio de opacidad o el punto medio de color entre dos detenciones para modificar la interpolación.

  • Para agregar una detención de color o detención de opacidad, haga clic debajo o encima de la barra de degradado del cuadro de diálogo Editor de degradado.
  • Para quitar una detención, arrástrela hacia fuera de la barra de degradado o seleccione la detención y haga clic en Eliminar.
  • Para editar el valor de una detención, selecciónela y ajuste el valor de Opacidad o utilice los controles del Selector de color de Adobe por debajo de los controles del editor de degradado.
  • Para seleccionar un tipo de degradado, haga clic en el botón Degradado lineal o Degradado radial en la esquina superior izquierda del cuadro de diálogo Editor de degradado.

Nota:

Utilice la propiedad Estilo para seleccionar un tipo de degradado para el estilo de capa Superposición de degradado.  

Tutorial de aprendizaje

Puede crear y guardar temas de color, examinar y buscar temas existentes y navegar por los temas guardados con su perfil de Adobe Creative Cloud. Consulte este tutorial para aprender a utilizar Adobe Color en After Effects.

Corrección, ajuste y gradación de color

Al montar una composición, a menudo es necesario ajustar o corregir los colores de una o más capas. Estos ajustes se pueden realizar por varias razones. Ejemplos:

  • Necesita hacer que parezca como si varios elementos de material de archivo se disparasen en las mismas condiciones para que puedan componerse o editarse conjuntamente.

  • Necesita ajustar los colores de una toma para que parezca que se ha filmado por la noche en lugar de durante el día.

  • Necesita ajustar la exposición de una imagen para recuperar los detalles de los resaltes sobreexpuestos.

  • Necesita mejorar un color de un disparo porque tendrá que componer sobre él un elemento gráfico con ese color.

  • Necesita restringir los colores a un rango determinado como, por ejemplo, el rango de emisión segura.

Los términos corrección de color y gradación de color se suelen emplear de manera intercambiable, mientras que el término gradación de color se utiliza en algunas ocasiones para hacer referencia de forma unívoca a los ajustes de color realizados con propósitos creativos en lugar de en la corrección de problemas de color. El término corrección de color se utiliza en un sentido amplio y general en After Effects.

After Effects incorpora varios efectos para la corrección del color, incluido el efecto Curvas, el efecto Niveles y otros efectos de la categoría de efectos Corrección de color. También se puede utilizar el efecto Aplicar LUT de color para aplicar las asignaciones de color en una tabla de búsqueda con el fin de realizar correcciones de color. (Consulte Efectos de corrección de color y Efecto Aplicar LUT de color).

Puede utilizar el plugin Camera Raw para corregir y ajustar imágenes fijas en JPEG, TIFF y varios formatos RAW de cámara.

El plugin Synthetic Aperture Color Finesse incluido en After Effects incorpora herramientas de corrección de color excelentes. After Effects CC y CS6 incluyen Synthetic Aperture Color Finesse 3. (Consulte Recursos para Synthetic Aperture Color Finesse).

Recursos adicionales sobre el ajuste y corrección de color

Este artículo del blog de Adobe recopila varios tutoriales de vídeo y otros recursos para la corrección y gradación de color en After Effects y Premiere Pro.

John Dickinson proporciona ayudas visuales en su sitio web Motionworks que ilustran cómo utilizar los efectos Curvas y Niveles para los ajustes de color:

Este vídeo de la serie After Effects: Learn by Video (After Effects: aprendizaje por vídeo) muestra cómo combinar el seguimiento del movimiento y la rotoscopia para aislar y corregir el color de la cara de un actor de forma selectiva.

El ajuste preestablecido de animación Rebel CC es una herramienta sencilla de corrección del color de estilo telecine para dar color o gradación a la película. Este ajuste preestablecido de animación utiliza expresiones para controlar el efecto Niveles (Controles individuales). Para obtener más información y descargar el ajuste preestablecido de animación, consulte el blog ProLost de Stu Maschwitz (en inglés).

Stu Maschwitz incluye una entrada en su blog ProLost (en inglés), donde se analiza la corrección de color para tonos de piel y se incluyen vínculos a algunos recursos sobre configuraciones de prueba que muestran distintos tonos de piel en un vectorescopio.

Mark Christiansen ofrece sugerencias y técnicas detalladas para la corrección, ajuste y coincidencia de color en el capítulo “Color Correction in Adobe After Effects” (Corrección de color en Adobe After Effect) de After Effects Studio Techniques, en el sitio web Peachpit Press.

Uso de histogramas para ajustar el color

Los histogramas son una representación del número de píxeles en cada valor de luminancia de una imagen. Los histogramas que tienen valores distintos de cero para cada valor de luminancia indican una imagen que aprovecha todo el rango tonal. Los histogramas que no utilizan todo el rango tonal corresponden a una imagen apagada sin contraste.

Una de las tareas más habituales de corrección del color consiste en ajustar una imagen para repartir el valor de los píxeles equitativamente de izquierda a derecha en el histograma, en lugar de tenerlos acumulados en uno u otro lado. El hecho de aplicar el efecto Niveles y ajustar sus propiedades Blanco de entrada y Negro de entrada en el histograma es una manera sencilla y eficaz de llevar a cabo esta tarea en muchas imágenes.

Histograma de una imagen en la que no se utiliza todo el rango tonal
Histograma de una imagen en la que no se utiliza todo el rango tonal

Reguladores de entrada desplazados para que la salida utilice todo el rango tonal
Reguladores de entrada desplazados para que la salida utilice todo el rango tonal

Histograma que muestra el recorte de resaltes
Histograma que muestra el recorte de resaltes

Histograma que muestra el recorte de sombras
Histograma que muestra el recorte de sombras

Panel Ámbitos de Lumetri

El panel Ámbitos de Lumetri proporciona ámbitos de video incorporados para mostrar las propiedades de color del vídeo. Los ámbitos de vídeo incluyen:

  • Vectorescopios
  • Histogramas
  • Exposición
  • Forma de onda
Ámbitos de vídeo en el panel Ámbitos de Lumetri
Ámbitos de vídeo en el panel Ámbitos de Lumetri

Cada fotograma de vídeo está formado por píxeles y cada píxel incluye las propiedades de color, que pueden clasificarse como crominancia, luminancia y saturación. Se pueden evaluar las propiedades de color para corregir el color del vídeo y para asegurar la coherencia entre las tomas.

Compatibilidad de Ámbitos de Lumetri para el flujo de trabajo de emisión

El panel Ámbitos de Lumetri está diseñado para el flujo de trabajo de colores de emisión. El panel mide los colores en los espacios de color Rec. 601, Rec. 709 y Rec. 2020. Para abrir los espacios de color, haga clic con el botón derecho en el panel Ámbitos de Lumetri y seleccione Espacio de color

  • Rec. 601: el espacio de color se utiliza para codificar señales de vídeo analógico en formato de vídeo digital.
  • Rec. 709: el espacio de color se utiliza para los flujos de trabajo normales de HDTV.
  • Rec 2020: el espacio de color se utiliza para HDR y UHDTV (UHD 4k y UHD 8k).

Si ha definido un espacio de color diferente para el proyecto de After Effects, los ámbitos representan el aspecto de la composición en función del espacio de color, pero transformado en el espacio de color (601, 709 o 2020) definido en el panel Ámbitos de Lumetri.

Para obtener más información sobre el flujo de trabajo de color de emisión, consulte Colores de emisión segura

Espacio de trabajo para trabajar con las herramientas de color

After Effects ahora incluye un nuevo espacio de trabajo denominado Color para trabajar con el panel Ámbitos de Lumetri y el efecto Lumetri Color. Para abrir el espacio de trabajo, seleccione el menú Ventana > Espacio de trabajo.

Apertura del espacio de trabajo para trabajar con las herramientas de color
Apertura del espacio de trabajo para trabajar con las herramientas de color

Sincronización del panel del visor actual

El panel Ámbitos de Lumetri analiza y muestra los cambios realizados en el panel del visor actual. Mide el color desde el panel Composición, Capa o Material de archivo actual. Puede cambiar el visor actual para ver los distintos resultados. Para bloquear la visualización de Ámbitos de Lumetri a un panel de visor específico, active la opción Visor principal de ese panel de visor. Por ejemplo, cuando se modifican las curvas de color RGB de la composición, la forma de onda selecciona el color y muestra la información de cambio de color.

Para obtener más información sobre los paneles, consulte Paneles y espacios de trabajo.

Antes de utilizar los ámbitos de Lumetri para leer la información de color
Antes de utilizar los ámbitos de Lumetri para leer la información de color

Después de realizar cambios en la composición conforme a la información de color de Ámbitos de Lumetri
Después de realizar cambios en la composición conforme a la información de color de Ámbitos de Lumetri


El panel Ámbitos de Lumetri en After Effects

El panel Ámbitos de Lumetri en After Effects
Vea este vídeo para conocer las mejoras de color que se pueden aplicar con el panel Ámbitos de Lumetri en After Effects

El panel Ámbitos de Lumetri de After Effects es idéntico al panel Ámbitos de Lumetri de Premiere Pro. Para obtener más información sobre el panel, consulte Ámbitos de Lumetri en Premiere Pro.

Recursos para Synthetic Aperture Color Finesse

El plugin Synthetic Aperture Color Finesse incluido en After Effects incorpora herramientas de corrección de color excelentes. Synthetic Aperture ofrece tutoriales e información adicional sobre el uso de Color Finesse en su sitio web.

Color Finesse instala su documentación en la subcarpeta del plugin en la carpeta Plugins. After Effects incluye Synthetic Aperture Color Finesse 3. (Consulte Plugins).

Modelos y espacios de color

Un modelo de color es una forma de describir un color mediante el uso de números para que los equipos puedan utilizarlos. El modelo de color utilizado en After Effects es el modelo RGB, en el que cada color se describe en términos de cantidades de luz roja, verde y azul sumadas para crear el color. Otros modelos de color incluyen CMYK, HSB, YUV y XYZ.

Un espacio de color es una variante de un modelo de color. Un espacio de color se distingue mediante una gama (gama de colores), gama de colores (primarios), un punto blanco y una respuesta de tono. Por ejemplo, dentro del modelo de color RGB hay varios espacios de color entre los que se incluyen, en orden decreciente de tamaño de gama, ProPhoto RGB, Adobe RGB, sRGB IEC61966-2,1 y Apple RGB. Aunque cada uno de estos espacios de color define el color mediante los tres mismos ejes (R, G y B), sus gamas y curvas de respuesta de tono son diferentes.

Aunque muchos dispositivos utilizan el rojo, el verde y el azul para registrar y expresar el color, los componentes tienen diferentes características; por ejemplo, el azul de una cámara no es exactamente igual al de otra cámara. Cada dispositivo que registra o expresa color tiene su propio espacio de color. Cuando una imagen pasa de un dispositivo a otro, los colores de la imagen pueden parecer distintos ya que cada dispositivo interpreta los valores RGB en su propio espacio de color.

La administración de color utiliza perfiles de color para convertir los colores de un espacio de color a otro, de forma que parezcan iguales de un dispositivo a otro.

Gamma y respuesta de tono

La respuesta de tono de un espacio de color es la relación de la intensidad de la luz con la señal que crea o registra (percibe) la luz.

El sistema visual humano no responde linealmente a la luz. Dicho de otro modo, nuestra percepción del nivel de claridad de una luz no se duplica cuando nuestros ojos reciben el doble de fotones en un momento determinado. Del mismo modo, los elementos en pantalla de un monitor CRT no emiten luz que tenga el doble de brillo cuando se aplica un gran voltaje. La relación de la intensidad de la luz con respecto a la intensidad de la señal para un dispositivo de visualización se expresa mediante una función de potencia. El exponente de esta función de potencia se denomina gamma. En general, la relación de la intensidad de la luz con respecto a la intensidad de la señal para un dispositivo de entrada es la inversa a la relación para un dispositivo de salida, aunque los valores de gamma pueden variar entre los dispositivos de entrada y de salida a fin de adaptar la diferencia entre la iluminación de la escena y la iluminación del entorno de visualización.

Nota:

Con el desplazamiento del regulador de medios tonos (como el control de Gamma del efecto Niveles) en un histograma de corrección de color se obtiene el mismo resultado que al modificar la gamma, cambiando la curva de respuesta de tono sin mover el punto blanco. Con la modificación de la curva del efecto Curvas también cambia la respuesta de tono, aunque no necesariamente con una curva de gamma.

Charles Poynton ofrece un excelente conjunto de recursos en su sitio web sobre gammas y otras tecnologías del color.

Respuesta de tono lineal: cuando gamma es igual a 1

La elevación de cualquier número a la potencia 1 da como resultado el número original. Una gamma de 1,0 se utiliza para expresar el comportamiento de la luz en el mundo natural, fuera del contexto de sistemas de percepción no lineales. A veces se dice que un sistema con una gamma de 1 funciona con luz lineal, mientras que un sistema codificado con una gamma diferente de 1 para que coincida con el sistema visual humano se considera perceptual.

Si ha habilitado la gestión de color (especificando un espacio de color de trabajo), puede realizar todas las operaciones de color en una luz lineal alineando el espacio de color de trabajo. Un espacio de color alineado utiliza los mismos puntos primarios y blancos que la versión no lineal; la curva de respuesta de tono se convierte en una línea recta.

Nota:

Muchas operaciones de composición como, por ejemplo, combinación de colores con modos de fusión, se benefician al llevarse a cabo en un espacio de color lineal. Para las fusiones de color más naturales y realistas, se trabaja en un espacio de color lineal. Si no ha habilitado la administración de color, puede seguir realizando operaciones de fusión con una gamma de 1,0. (Consulte Alineado de un espacio de trabajo y habilitación de la fusión lineal.)

Gamma de sistema, gamma de dispositivo y diferencia entre escena y entorno de visualización

El valor de gamma para todo un sistema—desde la captura, a través de la producción, para mostrarse en el entorno de visualización—es el producto de los valores de gamma utilizado para cada una de las fases del sistema. Este producto no siempre es 1, como sucedería si las operaciones realizadas para la codificación coincidieran exactamente (invertidas) con las operaciones realizadas para la descodificación. Un motivo para que un valor gamma de sistema sea distinto a 1, es que suele existir una diferencia entre las condiciones de iluminación en las que se captura una escena y las condiciones de iluminación en las que se visualiza. (Tenga en cuenta que normalmente las películas se ven en un entorno de luz tenue, aunque las películas no se ruedan, por norma general, en un entorno de luz tenue.)

Por ejemplo, la gamma de dispositivo para una cámara HD es aproximadamente 1/1,9, y la gamma de dispositivo para una pantalla HD es aproximadamente 2,2. Si multiplicamos estos valores, se obtiene una gamma de sistema de aproximadamente 1,15, lo que resulta apropiado para las condiciones algo tenues de visualización de la televisión en una sala de estar típica. La gamma de sistema para la producción de imágenes en movimiento es mucho más alta (aproximadamente 1,5-2,5) para dar cabida al entorno de visualización mucho más oscuro de una sala de cine. La gamma para el negativo de la película es aproximadamente 1/1,7 y la gamma para la película de proyección es aproximadamente 3–4.

Los perfiles de color se definen como de referencia en escena si las curvas de respuesta a tonos se basan en las condiciones de la escena típica. Los perfiles de color se definen como de referencia en salida si las curvas de respuesta a tonos se basan en las condiciones del entorno de visualización típico.

De forma predeterminada, cuando se utiliza la administración de color, After Effects ajusta automáticamente el contraste de imágenes al realizar la conversión entre los perfiles de color a los que se hace referencia en escena y en salida. Esta conversión automática (ajuste del estado de la imagen) se basa en los valores de gamma especificados en el estándar de vídeo HDTV.

  • Para deshabilitar esta transformación de color automática, anule la selección de Compensar perfiles de referencia en escena en el cuadro de diálogo Ajustes del proyecto (Archivo > Ajustes del proyecto).

La función Compensar perfiles de referencia en escena también existe en Adobe Photoshop CS4 y posterior, pero no se incluye en otras aplicaciones. Para que los colores coincidan con los de otras aplicaciones, (incluido After Effects CS3 y versiones anteriores), deshabilite esta conversión automática. Al abrir un proyecto creado en After Effects CS3 o versiones anteriores, la opción Compensar perfiles de referencia en escena aparece deseleccionada.

Cada instancia del efecto Convertidor de perfiles de color también puede configurarse para compensar los perfiles de referencia en escenas, para no compensar los perfiles de referencia en escenas o utilizar el ajuste indicado en la opción Compensar perfiles de referencia en escenas. (Consulte Efecto Convertidor de perfiles de color).

Para obtener información adicional sobre la compensación para perfiles de referencia en escena, consulte esta entrada del blog de Todd Kopriva y Peter Constable (en inglés) en el sitio web de Adobe.

QuickTime y gamma en proyectos sin administración de color

After Effects 7.0 y versiones anteriores utilizaban códecs QuickTime para descodificar los diversos tipos de elementos multimedia; asimismo, los ajustes de gamma realizados por QuickTime en Windows eran distintos a los ajustes de gamma realizados en equipos Mac OS. Los ajustes de gamma realizados por After Effects CS3 y posterior se diferencian de los ajustes de gamma realizados por estos códecs QuickTime. Los ajustes de gamma realizados por After Effects CS3 y posterior en Windows son los mismos que los ajustes de gamma realizados por After Effects CS3 y posterior en equipos Mac OS. Asimismo, al no utilizar los códecs QuickTime, After Effects conserva los valores por encima del rango en los proyectos de 32 bpc.

Seleccione Aplicar ajustes de gamma QuickTime anteriores de After Effects en el cuadro de diálogo Ajustes del proyecto para lograr alguno de los resultados siguientes:

  • Evitar variaciones del color cuando se trabaja con proyectos creados en After Effects 7.0 o anterior

  • Hacer coincidir los colores de un proyecto creado en After Effects 7.0 o anterior

  • Garantizar que los colores del panel Composición coinciden con los colores del reproductor QuickTime

La opción Aplicar ajustes de gamma QuickTime anteriores de After Effects está seleccionada por defecto para los proyectos creados en After Effects 7.0 o anterior. Deberá crear nuevos proyectos sin esta opción seleccionada.

Esta obra está autorizada con arreglo a la licencia de Reconocimiento-NoComercial-CompartirIgual 3.0 Unported de Creative Commons.  Los términos de Creative Commons no cubren las publicaciones en Twitter™ y Facebook.

Avisos legales   |   Política de privacidad en línea