Guía del usuario Cancelar

Procesamiento automático y en red

  1. Guía del usuario de After Effects
  2. Versiones beta
    1. Descripción general del programa beta
    2. Comunidad beta de After Effects
    3. Funciones de la versión beta
      1. Panel Propiedades (beta)
  3. Introducción
    1. Introducción a After Effects
    2. Novedades de After Effects 
    3. Notas de la versión | After Effects
    4. Requisitos del sistema para After Effects
    5. Métodos abreviados de teclado en After Effects
    6. Formatos de archivo admitidos | After Effects
    7. Recomendaciones de hardware
    8. After Effects para Apple Silicon
    9. Planificación y configuración
    10. Configuración e instalación
  4. Espacios de trabajo
    1. Elementos generales de la interfaz de usuario
    2. Familiarización con la interfaz de After Effects
    3. Flujos de trabajo
    4. Espacios de trabajo, paneles y visores
  5. Proyectos y composiciones
    1. Proyectos
    2. Conceptos básicos sobre composiciones
    3. Precomposición, anidamiento y preprocesamiento
    4. Ver información de rendimiento detallada con el Perfilador de composición
    5. Procesador de composición de Cinema 4D
  6. Importación de material de archivo
    1. Preparación e importación de imágenes fijas
    2. Importación desde After Effects y Adobe Premiere Pro
    3. Importación e interpretación de vídeo y de audio
    4. Preparación e importación de archivos de imagen 3D
    5. Importación e interpretación de elementos de material de archivo
    6. Uso de elementos de material de archivo
    7. Detección de puntos de edición con Detección de edición de escena
    8. Metadatos XMP
  7. Texto y gráficos
    1. Texto
      1. Formato de caracteres y el panel Carácter
      2. Efectos de texto
      3. Creación y edición de capas de texto
      4. Aplicación de formato a párrafos y el panel Párrafo
      5. Extrusión de capas de texto y formas
      6. Animación del texto
      7. Ejemplos y recursos para animación de texto
      8. Plantillas de texto interactivo
    2. Gráficos animados
      1. Trabajar con plantillas de gráficos animados en After Effects
      2. Uso de expresiones para crear listas desplegables en plantillas de gráficos animados
      3. Trabajo con propiedades esenciales para crear plantillas de gráficos animados
      4. Reemplazo de imágenes y vídeos en plantillas de gráficos animados y propiedades esenciales
  8. Dibujo, pintura y trazados
    1. Descripción general de las capas de forma, trazados y gráficos vectoriales
    2. Herramientas de pintura: Pincel, Tampón de clonar y Borrador
    3. Estrechamiento de trazos de forma
    4. Atributos de forma, operaciones de pintura y operaciones de trazado para capas de forma
    5. Uso del efecto de forma Desplazar trazados para modificar formas
    6. Creación de formas
    7. Creación de máscaras
    8. Elimine objetos de sus vídeos desde el panel Relleno según el contenido
    9. Pincel tipo rotoscopia y Perfeccionar mate
  9. Capas, marcadores y cámara
    1. Selección y organización de capas
    2. Modos de fusión y estilos de capas
    3. Capas 3D
    4. Propiedades de capa
    5. Creación de capas
    6. Administración de capas
    7. Marcadores de capa y marcadores de composición
    8. Cámaras, luces y puntos de interés
  10. Animación, fotogramas clave, seguimiento del movimiento y efecto de clave
    1. Animación
      1. Conceptos básicos sobre animaciones
      2. Animación con herramientas de marioneta
      3. Administración y animación de trazados de formas y máscaras
      4. Animación de formas de Sketch y Capture con After Effects
      5. Herramientas de animación varias
      6. Trabajo con animación basada en datos
    2. Fotograma clave
      1. Interpolación de fotogramas clave
      2. Ajuste, selección y eliminación de fotogramas clave
      3. Edición, desplazamiento y copia de fotogramas clave
    3. Seguimiento de movimiento
      1. Seguimiento y estabilización del movimiento
      2. Seguimiento de caras
      3. Seguimiento de máscara
      4. Referencia de máscara
      5. Velocidad
      6. Ampliación del tiempo y reasignación del tiempo
      7. Unidades de visualización de tiempo y código de tiempo
    4. Incrustación
      1. Incrustación
      2. Efectos de incrustación
  11. Transparencia y composición
    1. Descripción general y recursos sobre composición y transparencia
    2. Canales alfa, máscaras y mates
  12. Ajuste del color
    1. Conceptos básicos sobre colores
    2. Uso de la extensión Temas de Adobe Color
    3. Gestión de color
    4. Efectos de corrección de color
  13. Ajustes preestablecidos de animación y efectos
    1. Información general de efectos y ajustes preestablecidos de animación
    2. Lista de efectos
    3. Efectos de simulación
    4. Efectos de Estilizar
    5. Efectos de audio
    6. Efectos de distorsión
    7. Efectos de perspectiva
    8. Efectos de canal
    9. Efectos de generación
    10. Efectos de transición
    11. El efecto Reparación de obturación de desplazamiento
    12. Efectos Desenfocar y Enfocar
    13. Efectos de canal 3D
    14. Efectos de utilidad
    15. Efectos mate
    16. Efectos Ruido y Granulado
    17. Efecto Mejora de conservación de detalles
    18. Efectos obsoletos
  14. Expresiones y automatización
    1. Expresión
      1. Conceptos básicos sobre expresiones
      2. Comprensión del lenguaje de expresión
      3. Uso de los controles de expresión
      4. Diferencias de sintaxis entre los motores de expresiones de JavaScript y ExtendScript heredado
      5. Edición de expresiones
      6. Errores de expresiones
      7. Uso del editor de expresiones
      8. Uso de expresiones para editar y acceder a las propiedades de texto
      9. Referencia del lenguaje de expresión
      10. Ejemplos de expresiones
    2. Automatización
      1. Automatización
      2. Scripts
  15. Vídeo inmersivo, RV y 3D
    1. Construcción de entornos de RV en After Effects
    2. Aplicar efectos de vídeo envolvente
    3. Herramientas de composición para vídeos de VR/360
    4. Seguimiento del movimiento de la cámara 3D
    5. Trabajo en espacios de diseño 3D
    6. Herramientas de transformación Gizmo 3D
    7. Haga más cosas con la animación 3D
    8. Previsualización de los cambios en diseños 3D en tiempo real con el motor en tiempo real
    9. Adición de diseño interactivo a los gráficos 
  16. Vistas y previsualizaciones
    1. Previsualización
    2. Previsualización de vídeo con Mercury Transmit
    3. Modificación y utilización de vistas
  17. Procesamiento y exportación
    1. Principios básicos del procesamiento y la exportación
    2. Exportación de un proyecto de After Effects como un proyecto de Adobe Premiere Pro
    3. Conversión de películas
    4. Procesamiento de varios fotogramas
    5. Procesamiento automático y en red
    6. Procesamiento y exportación de imágenes fijas y secuencias de imágenes fijas
    7. Uso del códec de GoPro CineForm en After Effects
  18. Uso de otras aplicaciones
    1. Dynamic Link y After Effects
    2. Uso de After Effects y otras aplicaciones
    3. Sincronización de la configuración en After Effects
    4. Bibliotecas Creative Cloud en After Effects
    5. Plugins
    6. Cinema 4D y Cineware
  19. Colaboración: Frame.io y Team Projects
    1. Colaboración en Premiere Pro y After Effects
    2. Frame.io
      1. Instalación y activación de Frame.io
      2. Uso de Frame.io con Premiere Pro y After Effects
      3. Preguntas frecuentes
    3. Team Projects
      1. Introducción a Team Projects
      2. Creación de un proyecto de equipo
      3. Colaboración con Team Projects
  20. Memoria, almacenamiento y rendimiento
    1. Memoria y almacenamiento
    2. Mejora del rendimiento
    3. Preferencias
    4. Requisitos de la GPU y del controlador de la GPU para After Effects

Procesamiento automático con Aerender

El archivo ejecutable aerender.exe es un programa que cuenta con una interfaz de línea de comandos con la cual se puede automatizar el procesamiento. El archivo ejecutable se ubica en la misma carpeta que la aplicación principal de After Effects. Las ubicaciones predeterminadas de este archivo son las siguientes:

  • Windows: \Archivos de programa\Adobe\Adobe After Effects CC\Support Files

  • Mac OS: /Aplicaciones/Adobe After Effects CC

La aplicación aerender se puede utilizar para realizar operaciones de procesamiento en varios equipos como parte de una granja de procesamiento o bien, se puede emplear en un solo equipo como parte de una operación por lotes.

Se puede utilizar el programa introduciendo el comando aerender en la línea de comandos (o en una secuencia de comandos por lotes), seguido por una serie de argumentos adicionales. Algunos de los argumentos son opciones muy sencillas que no tienen argumentos por sí mismas (por ejemplo, -reuse), mientras que otras incluyen argumentos propios (como -project project_path).

Nota:

Introduzca el comando aerender -help para mostrar la información de uso.

La versión y el número de compilación de la aplicación se escriben en la salida estándar (stdout).

El procesamiento puede realizarse con una instancia de After Effects que ya esté en ejecución o mediante una instancia iniciada recientemente. De manera predeterminada, aerender inicia una nueva instancia de After Effects, aunque ya haya una abierta. Si desea utilizar la instancia que ya tiene abierta, utilice el argumento –reuse.

Este comando de ejemplo indica a After Effects que procese los fotogramas del 1 al 10 de Composition_1 de project_1.aep en una secuencia numerada de archivos de Photoshop utilizando un procesamiento con múltiples equipos:

aerender -project c:\projects\project_1.aep -comp “Composition_1” -s 1 -e 10
-RStemplate “Multi-Machine Settings” -OMtemplate “Multi-Machine Sequence”
-output c:\output\project_1\frames[####].psd

Para procesar solo Composition_1 en un archivo especificado, introduzca este comando:

aerender -project c:\projects\project_1.aep -comp “Composition_1” -output c :\output\project_1\project_1.avi

Para procesar todos los elementos de la cola de procesamiento con los ajustes actuales del archivo de proyecto, introduzca el siguiente comando:

aerender -project c:\projects\project_1.aep

Argumento

Descripción

“-h”

"–help"

Imprime el mensaje de uso.

"–version"

muestra el número de versión de aerender en la consola. No realiza el procesamiento

"–v verbose_flag"

donde verbose_flag especifica el tipo de mensajes notificados. Los valores posibles son ERRORS (solo imprime errores fatales y de problemas) o ERRORS_AND_PROGRESS (imprime también el progreso del procesamiento).

–reuse

utilice este indicador si desea probar y reutilizar una instancia de AE que ya esté ejecutándose para realizar el procesamiento. De manera predeterminada, aerender iniciará una nueva instancia de After Effects, aunque ya haya una abierta. Sin embargo, si AE ya se está ejecutando y se proporciona el indicador "-reuse", aerender le pedirá a la instancia de AE que ya está ejecutándose que realice el procesamiento. Cada vez que aerender abre una nueva instancia de AE, se le indicará que se deje de utilizar AE cuando se complete el procesamiento; de lo contrario, no saldrá de AE. Asimismo, las preferencias se escribirán en el archivo al salir cuando se especifique el indicador "-reuse"; de lo contrario, no se escribirá.

"–mem_usage image_cache_percentmax_mem_percent"

donde image_cache_percent especifica el porcentaje máximo de memoria que se utiliza para almacenar en memoria caché imágenes/material de archivo ya procesadas y max_mem_percent especifica el porcentaje total de memoria que puede utilizar After Effects.

"-mfr mfr_flag max_cpu_percent" donde mfr_flag ("ON"|"OFF") especifica si se debe utilizar el procesamiento de varios fotogramas y max_cpu_percent (1-100) especifica el porcentaje máximo de potencia de CPU que se va a usar durante el procesamiento. Puesto que el procesamiento de varios fotogramas tiene la capacidad de utilizar el 100 % de la capacidad de la CPU, puede optar por limitar la potencia de la CPU, de manera que se puedan usar otras aplicaciones. max_cpu_percent se ignorará cuando mfr_flag se establezca en desactivado.

"–project project_path"

donde project_path es una ruta de archivos o URI que especifica el archivo de proyecto que se va a abrir. Si no se proporciona ninguno, aerender funcionará con el proyecto que esté abierto. Si no hay ningún proyecto abierto y no se proporciona ninguno, se producirá un error.

"–comp comp_name"

donde comp_name especifica una composición que se va a procesar. Si la composición ya está en la cola de procesamiento y en un estado en el que se puede poner en cola, (solo) se procesará la primera instancia que se puede poner en espera en la cola de procesamiento. Si la composición está en el proyecto, pero no en la cola de procesamiento, se añade a la cola y se procesa. Si no se proporciona ningún argumento -comp, aerender procesa toda la cola de procesamiento tal como está. En este caso (sin -comp), los únicos otros argumentos utilizados serán: -project, -log, -v, -mem_usage, and -close; se ignorarán los argumentos -RStemplate, -OMtemplate, -output, -s, -e, e -i.

"–s start_frame"

start_frame es el primer fotograma que se va a procesar. El valor predeterminado es el fotograma inicial del archivo.

"–e end_frame"

end_frame es el último fotograma que se va a procesar. Tenga en cuenta que es "inclusivo" y se procesará el fotograma final.

"–i increment"

donde increment es el número de fotogramas que se avanza antes de procesar otro fotograma. Un valor 1 (predeterminado) resulta en un procesamiento normal de todos los fotogramas. Los incrementos más altos repetirán lo mismo (incremento de fotogramas-1) veces y, a continuación, procesarán uno nuevo, con lo que el ciclo se volverá a iniciar. Los valores más altos dan lugar a procesamientos más rápidos, pero el resultado es un movimiento más agitado. El valor predeterminado es 1.

"–OMtemplate output_module_template"

donde output_module_template es el nombre de una plantilla que se aplicará al módulo de salida. Si la plantilla no existe, se trata de un error. El valor predeterminado es usar la plantilla ya definida para el módulo de salida.

"–RStemplate render_settings_template"

donde render_settings_template es el nombre de una plantilla que se va a aplicar al elemento de la cola de procesamiento. Si la plantilla no existe, se trata de un error. El valor predeterminado es usar la plantilla de procesamiento ya definida para el elemento.

"–output output_path"

donde output_path es una ruta de archivo o un URI que especifica el archivo de procesamiento de destino. El valor predeterminado es la ruta de acceso que ya está en el archivo de proyecto.

"–log log_file_path"

donde log_file_path es una ruta de archivo o URI que especifica la ubicación del archivo de registro. El valor predeterminado es stdout.

"–sound sound_flag"

donde sound_flag especifica si se va a reproducir o no un sonido cuando se complete el procesamiento. Los valores posibles son "ON" u "OFF". El valor predeterminado es "OFF".

"–close close_flag"

donde close_flag especifica si se debe o no cerrar el proyecto cuando finalice el procesamiento y si se deben guardar los cambios. Si close_flag es DO_NOT_SAVE_CHANGES, el proyecto se cerrará sin guardar los cambios. Si close_flag es SAVE_CHANGES, el proyecto se cerrará y se guardarán los cambios. Si close_flag es DO_NOT_CLOSE el proyecto se quedará abierto; sin embargo, el proyecto se queda abierto únicamente si se utiliza una instancia de AE que ya esté ejecutándose, ya que las nuevas invocaciones de AE siempre deben cerrarse y salir al terminar. El valor predeterminado es DO_NOT_SAVE_CHANGES.

"-rqindex index_in_render_queue"

donde index_in_render_queue especifica el elemento de la cola de procesamiento que se va a procesar. Las opciones que tienen sentido al procesar un único elemento de cola de procesamiento están disponibles como con el indicador -comp.

"-continueOnMissingFootage"

No detenga el procesamiento en el material de archivo que falta. Registre y procese con las barras de color de los marcadores de posición.

En su sitio web de secuencias de comando para After Effects, Lloyd Alvarez ofrece una secuencia de comandos que selecciona los elementos de la cola de procesamiento que están listos para procesar y los envía para su procesamiento en segundo plano con aerender.

Procesamiento en red con carpetas de inspección y motores de procesamiento

Utilizando varios equipos conectados a través de una red, se pueden procesar una o más composiciones de un proyecto en una fracción del tiempo que necesitaría un solo equipo. Para el procesamiento en red es necesario copiar el proyecto y los archivos de origen en una carpeta de red y, a continuación, iniciar el procesamiento del proyecto. Una red de sistemas utilizados de forma conjunta para procesar una sola composición se denomina en ocasiones granja de procesamiento.

El procesamiento en granja es el uso de una red de sistemas de forma conjunta para procesar una sola composición. Puede configurarlo para que funcione con versiones de solo procesamiento de After Effects denominadas motores de procesamiento.

Los motores de procesamiento pueden instalarse de la misma forma que la versión completa de la aplicación. Para ejecutar el motor de procesamiento, use el acceso directo del motor de procesamiento de Adobe After Effects en la carpeta Adobe After Effects CC. Para obtener más información, vea la Configuración e instalación de la misma composición.

No se puede utilizar una carpeta de inspección y varios motores de procesamiento para procesar simultáneamente un archivo de película único. Sin embargo, con el procesamiento en granja se pueden utilizar varios motores para procesar una película como una secuencia de archivos de imágenes fijas. Posteriormente se puede utilizar una acción de postprocesamiento para crear un único archivo de película a partir de la secuencia de imágenes fijas. Para obtener más información, consulte Acciones de postprocesamiento.

Consideraciones acerca de la red

Cuando trabaje con varios motores de procesamiento en múltiples sistemas, tenga en cuenta las siguientes directrices:

  • Siempre que sea posible, identifique las carpetas utilizando rutas de archivo absolutas para que se puedan identificar correctamente para todos los motores de procesamiento. Si identifica las carpetas con rutas de archivo absolutas, puede significar asignar unidades de red en una letra de unidad particular para todos los equipos (por ejemplo, H:\renders\watch\). Evite utilizar rutas relativas (por ejemplo, \\renders\watch).

  • Todos los equipos Macintosh que supervisan la carpeta de inspección deben tener un nombre único. Los nombres predeterminados de los equipos a menudo son idénticos, por lo que debería cambiar el nombre de sus equipos para que no utilicen el nombre predeterminado.

  • Asegúrese de que todos los servidores y los clientes (equipos que supervisan la carpeta de inspección) tengan discos duros con nombres únicos.

  • No utilice el mismo equipo para prestar servicio a una carpeta de inspección y para ejecutar After Effects en modo Carpeta de inspección. Utilice un servidor dedicado que sea accesible para todos motores de procesamiento que prestan servicio a la carpeta de inspección.

  • No realice el procesamiento en modo Carpeta de inspección ni lo inicie en la raíz de un volumen o en una carpeta compartida que aparezca como raíz cuando se visualiza desde otro equipo. En su lugar, especifique una subcarpeta. Tampoco debe utilizar caracteres ASCII superior ni guiones en los nombres de archivo. En caso de procesamiento en múltiples equipos, After Effects incluye una plantilla de muestreo de varios equipos que se puede utilizar como punto de partida.

Nota:

Al procesar en una red que incluye volúmenes que utilizan diferentes redes o sistemas operativos, como Windows, Mac OS, Novell y UNIX, asegúrese de especificar archivos de salida mediante una convención de nombres de archivo compatible con todos los volúmenes de procesamiento o de destino.

Consideraciones acerca del proyecto

Asegúrese de que instala todas las fuentes, los efectos y los codificadores (compresores) utilizados en el proyecto en todos los equipos que supervisan la carpeta de inspección. Si un equipo que supervisa la carpeta de inspección no puede encontrar fuentes, efectos o codificadores utilizados en un proyecto, se producirá un error en el procesamiento.

Cuando se instala un motor de procesamiento de After Effects en un equipo, este contiene todos los plugins incluidos en After Effects. Si una composición utiliza un plugin de otro fabricante, este deberá estar presente en todos los sistemas que procesen la composición. Sin embargo, la compatibilidad con el procesamiento en red varía entre los distintos fabricantes de plugins. Antes de configurar una red para procesar efectos creados mediante plugins de terceros, consulte la documentación del plugin o póngase en contacto con el fabricante para obtener respuestas a las siguientes preguntas:

  • ¿El contrato de licencia del plugin permite instalar varias copias en una red para procesamiento?

  • ¿Existe alguna limitación o consejo adicional que se aplique al uso de ese plugin para el procesamiento en red?

Consideraciones acerca de la carpeta Recopilar archivos

Cuando se utiliza el comando Archivo > Recopilar archivos, los archivos relacionados con un proyecto se copian en una misma carpeta. Esta carpeta incluye una copia del proyecto, un archivo de control de procesamiento (RCF) y otros archivos, en función de las opciones que se hayan seleccionado en el cuadro de diálogo Recopilar archivos. Si guarda la carpeta Recopilar archivos en un equipo en red que no sea un servidor, no ejecute el motor de procesamiento en ese equipo. Evite guardar la carpeta Recopilar archivos en un disco local, el nivel raíz de un disco (tal como C: en Windows o el disco duro de Macintosh en Mac OS), o en una carpeta compartida, ya que para cada motor de procesamiento puede significar una ubicación diferente. Todos los motores de procesamiento deben interpretar la ruta de la misma forma.

Nota:

Una vez que los archivos recopilados aparecen en la carpeta de inspección, todos los motores de procesamiento de supervisión iniciarán el procesamiento automáticamente. Si lo prefiere, puede utilizar el comando Recopilar archivos para almacenar composiciones y el material de archivo de origen en una ubicación especificada y, a continuación, iniciar el procesamiento de la carpeta de inspección más adelante. De este modo los proyectos se procesan en orden alfabético en lugar de hacerlo en el orden en el que se guardaron en la ubicación.

Control de dependencias de procesamiento de una carpeta de inspección

Cuando el procesamiento se realiza a través de una red se pueden controlar las dependencias de procesamiento mediante la definición de las opciones de Acción de postprocesamiento. Cuando se definen estas opciones, After Effects confirma que todos los elementos que se deben procesar están preparados y disponibles. Por ejemplo, si un elemento depende de otro para procesarse, y el primero no ha terminado de procesarse o ha recibido un error, el segundo no se procesará.

Este proceso se puede utilizar para procesar una única película QuickTime o AVI desde el procesamiento de una carpeta de inspección. La película se crea en un solo sistema.

Nota:

En este procedimiento se supone que ya ha creado una carpeta de inspección de múltiples sistemas.

  1. En el panel Cola de procesamiento, arrastre el módulo de salida al panel Proyecto. After Effects crea un marcador de posición para la salida de ese elemento.
  2. Vuelva a arrastrar el marcador al panel Cola de procesamiento.
  3. Defina los ajustes de procesamiento y los ajustes del módulo de salida para el marcador, y haga clic en Procesar.

Inicio en el modo carpeta de inspección

El modo carpeta de inspección solo se aplica al procesamiento desde una carpeta del equipo local.

  • Para iniciar After Effects automáticamente en modo carpeta de inspección, guarde un proyecto con el nombre de archivo Watch This Folder.aep. After Effects inspecciona la carpeta que contenga el proyecto al abrir ese proyecto.
  • Para iniciar After Effects en modo carpeta de inspección al arrancar el equipo, cree un método abreviado (MS Windows) o alias (Mac OS) en el proyecto Watch This Folder.aep y muévalo a la carpeta Inicio (MS Windows) o a la carpeta Items de Arranque (Mac OS). After Effects inspecciona la carpeta que contenga el proyecto al abrir ese proyecto.
  • (Solo Windows) Para iniciar After Effects en modo carpeta de inspección desde la línea de comandos, seleccione Inicio > Ejecutar y, a continuación, escriba el comando siguiente (modifique la ruta de la aplicación con el nombre exacto de la carpeta donde se instaló After Effects y sustituya C:\[temp] por la ruta de la carpeta de inspección): "C:\Archivos de programa\Adobe\Adobe After Effects CC\Support Files\afterfx.exe" -wf C:\[temp]
Nota:

Para iniciar el motor de procesamiento de After Effects en lugar de la versión completa de la aplicación, utilice la opción -re con el comando.

Nota:

También puede usar esta línea de comandos en archivos por lotes.

Procesamiento en granja: procesamiento de una secuencia de imágenes fijas en varios sistemas

El procesamiento en granja es el uso de una red de sistemas de forma conjunta para procesar una sola composición. Puede configurarlo para que funcione con versiones de solo procesamiento de After Effects denominadas motores de procesamiento. El procesamiento en granja ayuda a reducir el tiempo que un solo sistema tarda en exportar una composición. Se pueden emplear varios sistemas y varias copias de After Effects para procesar una composición en una red. Se pueden emplear varios sistemas para procesar solo secuencias de imágenes fijas, pero no se pueden emplear para procesar una única película.

Aharon Rabinowitz incluye un tutorial en vídeo en el sitio web Creative COW, que explica los pasos necesarios para procesar una secuencia de imagen fija con varios sistemas.

Configuración de la red

Siga el procedimiento que se muestra en la imagen para comprender los requisitos de configuración de la red.

Configuración de procesamiento en red

A. Sistema con una versión completa de After Effects B. Guarda un proyecto y todos sus archivos fuente en una carpeta de un servidor C. Sistemas con el motor de procesamiento instalado D. Abre el proyecto, procesa una secuencia de fotogramas fijos y guarda el resultado en una carpeta de salida designada en el servidor 

Puede utilizar varios equipos para el procesamiento. En general, como más equipos utilice, más rápido será el procesamiento. Sin embargo, si se utilizan demasiados sistemas en una red ocupada, el tráfico de la red puede retardar todo el proceso. Se puede detectar una desaceleración de la red mediante la observación del tiempo dedicado a la fase Compresión y escritura en la sección Procesamiento actual del panel Cola de procesamiento.

Nota:

Adobe no proporciona asistencia técnica para configuración general de la red; consulte con el administrador de la red.

Procesamiento de una secuencia de imágenes fijas con varios sistemas

Aspectos importantes en el procesamiento de una secuencia de imágenes fijas con varios sistemas: 

  • para procesar una secuencia de imágenes fijas con varios sistemas, puede utilizar el número de sistemas que desee. 
  • Al procesar una secuencia de imágenes fijas con varios sistemas, el procesamiento comienza aproximadamente al mismo tiempo en cada copia de After Effects. 
  • Si los elementos de procesamiento en cola están establecidos en Omitir archivos existentes (una opción de configuración del procesamiento), el proceso omite los fotogramas existentes o en curso. 
  • Varios sistemas pueden procesar el proyecto simultáneamente, escribiendo la secuencia de imágenes fijas en una misma carpeta.

Para procesar una secuencia de imágenes fijas, siga estos pasos:

  1. instale After Effects en todos los sistemas utilizados para procesar el proyecto. Asegúrese de que están instaladas las mismas fuentes en todos los sistemas.

    Nota:

    No se deben compartir plugins en una red. Asegúrese de que dispone de una copia de la carpeta de plugins en todos los sistemas que están ejecutando After Effects. Cuando esté utilizando plugins de terceros, asegúrese de que están disponibles los mismos plugins en todos los sistemas y que tiene suficientes licencias.

  2. Abra el proyecto en un sistema y seleccione Composición > Añadir a la cola de procesamiento.

  3. En el panel Cola de procesamiento, especifique un formato en el área Módulo de salida y seleccione una carpeta en el área Salida a. Esta carpeta debe estar disponible para los todos sistemas que se estén procesando.

  4. En el panel Cola de procesamiento, seleccione Omitir archivos existentes (permitir procesamiento en varios sistemas) en la sección Ajustes de procesamiento para evitar que varios sistemas procesen los mismos fotogramas. Si utiliza Omitir archivos existentes, no use varios módulos de salida para un elemento de procesamiento.

  5. Guarde el proyecto en el sistema en el que lo haya abierto en el paso 2.
  6. En cada equipo que procese, abra y guarde el proyecto. De este modo se garantiza que After Effects registre las nuevas rutas relativas en todos los sistemas en el paso siguiente.
  7. A menos que la red pueda gestionar transferencias de archivos grandes rápidamente, copie el archivo del proyecto y todo el material de archivo de origen en cada sistema que esté realizando el procesamiento.
  8. Abra el panel Cola de procesamiento en cada sistema y haga clic en Procesar. No es necesario iniciar el procesamiento en todos los sistemas simultáneamente, pero para asegurarse de que la carga de trabajo sea igual, inícielos aproximadamente al mismo tiempo. Cuando cada sistema termina de procesar un fotograma, After Effects busca en la carpeta Salida el siguiente fotograma sin procesar e inicia de nuevo el procesamiento.

  9. Puede detener e iniciar un equipo en cualquier momento. Sin embargo, si detiene un sistema y no lo vuelve a iniciar, es posible que no se termine de procesar el fotograma que estaba en curso. Si se detienen uno o varios equipos durante el procesamiento, iniciar uno de ellos asegura que se procesen todos los fotogramas de la secuencia.

Ejecutar Aerender en el modo sin derechos de autor

After Effects CS5.5 tuvo que serializarse en equipos de solo procesamiento debido a problemas con las licencias. En After Effects CS6 y versiones posteriores, ahora puede ejecutar aerender o utilizar las carpetas de inspección en el modo sin derechos de autor, para lo que no se requiere la serialización.

Para asegurarse de que After Effects se está ejecutando en el modo sin derechos de autor, coloque el archivo vacío llamado ae_render_only_node.txt en la siguiente ubicación:

  1. Instale After Effects en el equipo de solo procesamiento.

    • Ubicaciones de Mac:

      /Usuarios/<username>/Documentos/

      /Usuarios/Compartido/Adobe/

    • Ubicaciones de Windows:

      C:\Usuarios\<username> \Documentos

      C:\Usuarios\Public\Documentos\Adobe

Ajustes de segmentos

Los ajustes de segmentos se encuentran en la categoría de preferencias de salida.

Nota:

Seleccione Edición > Preferencias > Salida (Windows) o After Effects > Preferencias > Salida (Mac OS).

After Effects puede procesar archivos de película y secuencias en segmentos que se limitan a un número especificado de archivos o mediante tamaño de archivo. Esto resulta útil a la hora de preparar una película para un medio como, por ejemplo, CD-ROM, para el que puede ser necesario limitar el tamaño de archivo o carpeta en bloques de 650 MB o menos. Utilice el valor Segmentar archivos de película de solo vídeo en para definir el tamaño máximo de los segmentos en megabytes. Utilice Segmentar secuencias en para definir el número máximo de archivos de imágenes fijas que deben guardarse en una carpeta.

Si va a exportar una película que supera el tamaño de archivo máximo para el esquema de formato del disco duro, puede definir el valor Segmentar archivos de película de solo vídeo en, en un valor inferior a este máximo. Los discos duros formateados para Windows se pueden formatear con los esquemas FAT, FAT32 o NTFS. El tamaño de archivo máximo del esquema FAT es 2 GB, y el tamaño de archivo máximo en el esquema FAT32 es 4 GB. El tamaño máximo para un archivo para NTFS es grande (aproximadamente 16 terabytes), así que es poco probable que alcance este límite con una sola película.

Únicamente se pueden segmentar las películas que no contienen audio. Si un módulo de salida incluye audio, la preferencia Segmentar archivos de película de solo vídeo en se omite para ese elemento.

La preferencia Segmentar secuencias en se omite para todos los elementos de procesamiento para los que la opción Omitir archivos existentes está seleccionada en los ajustes de procesamiento. Consulte Referencia de ajustes de procesamiento.

Nota:

After Effects no procesará ni exportará una película segmentada en el directorio raíz (p. ej., C:\). Para procesar y exportar una película segmentada, seleccione un directorio de salida distinto al directorio raíz. Consulte Especificación de nombres de archivo y ubicaciones para el resultado del procesamiento.

Logotipo de Adobe

Inicia sesión en tu cuenta

[Feedback V2 Badge]