Acerca de los gráficos vectoriales y las imágenes rasterizadas

Los gráficos vectoriales están compuestos de líneas y curvas definidas por objetos matemáticos llamados vectores, que describen una imagen de acuerdo con sus características geométricas. Algunos ejemplos de elementos gráficos vectoriales en After Effects son los trazados de máscara, las formas de las capas de formas y el texto en las capas de texto.

Las imágenes rasterizadas (denominadas a veces imágenes de mapas de bits ) utilizan una cuadrícula rectangular de elementos de imagen (píxeles) para representar imágenes. A cada píxel se le asigna una ubicación y un valor de color específicos. El material de archivo de vídeo, las secuencias de imágenes transferidas desde una película y cualquier otro tipo de imágenes importadas en After Effects son imágenes rasterizadas.

Los gráficos vectoriales conservan la nitidez de los bordes y no pierden detalles cuando se modifica el tamaño puesto que son independientes de la resolución. Gracias a esta particularidad, los gráficos vectoriales constituyen una buena elección para los elementos visuales, como los logotipos, que se utilizarán en diferentes tamaños.

Ejemplo de un gráfico vectorial con distintos niveles de ampliación
Ejemplo de un gráfico vectorial con distintos niveles de ampliación

Las imágenes rasterizadas constan de un número fijo de píxeles y, por tanto, dependen de la resolución. Las imágenes rasterizadas pueden perder detalle y verse dentadas (pixeladas) cuando se amplían.

Ejemplo de una imagen rasterizada con diferentes niveles de ampliación
Ejemplo de una imagen rasterizada con diferentes niveles de ampliación

Algunas imágenes se crean como gráficos vectoriales en otra aplicación pero se convierten a píxeles (se rasterizan) cuando se importan en After Effects. Si una capa se rasteriza continuamente, After Effects reconvierte los gráficos vectoriales a píxeles cuando se modifica el tamaño de la capa, conservando la nitidez de los bordes. Los gráficos vectoriales de los archivos SWF, PDF, EPS e Illustrator se pueden rasterizar continuamente.

El tutorial de vídeo "¿Qué son las imágenes rasterizadas y los gráficos vectoriales?" de Aharon Rabinowitz, parte de las series Multimedia 101 del sitio web Creative COW, ofrece una introducción general a la rasterización de imágenes y los gráficos vectoriales.

Acerca de los trazados

Varias características de After Effects (incluidos máscaras, formas, trazos de pintura y trazados de movimiento) se basan en el concepto de trazado. Las herramientas y técnicas para crear y editar estos distintos tipos de trazado se superponen, pero cada tipo de trazado tiene sus propias características exclusivas.

Un trazado de máscara se compone de segmentos y vértices. Los segmentos son las líneas o curvas que conectan los vértices. Los vértices definen dónde comienza y termina cada segmento de un trazado. Algunas aplicaciones de Adobe utilizan los términos punto de anclaje y punto de trazado para referirse a los vértices.

Es posible modificar la forma de un trazado arrastrando sus vértices, los controles de dirección del extremo de cada una de las líneas de dirección del vértice (o tangentes) o el propio segmento del trazado.

Cuando un trazado sale de un vértice, el ángulo y la longitud de la línea de dirección saliente de ese vértice determina el trazado. A medida que el trazado se acerca al vértice siguiente, resultará menos influenciado por la línea de dirección saliente del vértice anterior y más influenciado por la línea de dirección entrante del vértice siguiente.

Componentes del trazado
Componentes del trazado

A. Vértice seleccionado B. Vértice seleccionado C. Vértices no seleccionados D. Segmento de trazado curvado E. Línea de dirección (tangente) F. Control de dirección 

Los trazados pueden tener dos tipos de puntos de vértices: puntos de borde y puntos suaves. En un punto suave, los segmentos del trazado se conectan formando una curva suave; las líneas de dirección entrantes y salientes se encuentran en la misma línea. En un punto de borde, un trazado cambia repentinamente de dirección; las líneas de dirección entrantes y salientes se encuentran en líneas diferentes. Puede dibujar un trazado utilizando cualquier combinación de puntos de vértice y de curva. Si dibuja el tipo de punto equivocado, podrá modificarlo posteriormente.

Puntos de un trazado
Puntos de un trazado

A. Cuatro puntos de borde B. Cuatro puntos suaves C. Combinación de puntos de vértice y de curva 

Cuando se desplaza una línea de dirección de un punto suave, las curvas a ambos lados del punto se ajustan simultáneamente. En cambio, cuando se desplaza una línea de dirección en un punto de borde, sólo se ajusta la curva que se encuentra en el mismo lado del punto que la línea de dirección.

Ajuste de líneas de dirección en un punto suave (izquierda) y un punto de borde (derecha)
Ajuste de líneas de dirección en un punto suave (izquierda) y un punto de borde (derecha)

Un trazado puede ser abierto o cerrado Un trazado abierto tiene un punto inicial que no coincide con su punto final; por ejemplo, una línea recta es un trazado abierto. Un trazado cerrado es continuo y no tiene principio ni final; por ejemplo, un círculo es un trazado cerrado.

Puede dibujar máscaras de formas geométricas comunes - incluyendo polígonos, elipses y estrellas - con las herramientas de formas o puede utilizar la herramienta Pluma para dibujar un trazado arbitrario. Los trazados dibujados con la herramienta Pluma son trazados Bézier manuales o trazados RotoBézier. La principal diferencia entre RotoBézier y Bézier manual es que en las máscaras RotoBézier las líneas de dirección se calculan automáticamente, lo que las hace más rápidas y sencillas de dibujar.

Cuando se utilizan las herramientas de forma (Rectángulo, Rectángulo redondeado, Elipse, Polígono o Estrella) para dibujar un trazado de forma en una capa de formas, se puede crear uno o dos tipos de trazados: trazados de formas paramétricas o trazado de formas Bézier. (Consulte Acerca de las formas y las capas de formas).

Se pueden enlazar trazados de máscaras, trazados de trazos de pintura y trazados de formas Bézier utilizando expresiones. También puede copiar y pegar entre trazados de máscara, trazados de trazo de pintura, trazados de forma Bézier, trazados de movimiento y trazados de Adobe Illustrator, Photoshop y Adobe Fireworks. (Consulte Creación de formas y máscaras).

Para los trazados de formas, se puede utilizar la operación Combinar trazados (similar a los efectos del Localizador de trazados de Adobe Illustrator) para combinar varios trazados en uno solo. (Consulte Opciones de Combinar trazados).

Si desea que el texto o un efecto sigan un trazado, este debe ser un trazado de máscara.

Un trazado no tiene apariencia visual por sí mismo; en esencia, se trata de un conjunto de información sobre cómo colocar o modificar otros elementos visuales. Para que un trazado sea visible, aplíquele un trazo. En el caso de un trazado de máscara, aplique el efecto Trazo. En el caso de un trazado para un objeto de capa de formas, el comportamiento predeterminado es crear un trazado con un grupo de propiedades de trazo (atributo), después del grupo de propiedades de trazado en el panel Línea de tiempo.

Un color o degradado aplicado al área interior de área definida por un trazado es un relleno.

Nota:

Para especificar el tamaño de los controles de dirección de curva Bézier y los vértices para las máscaras y formas, seleccione Editar > Preferencias > General (Windows), o bien, After Effects > Preferencias > General (Mac OS) y edite el valor Tamaño del punto de trazado.

Acerca de las formas y las capas de formas

Las capas de formas contienen objetos gráficos vectoriales denominados formas. De manera predeterminada, una forma consta de un trazado, un trazo y un relleno. (Consulte Acerca de los trazados y Trazos y rellenos para formas).

Las capas de formas se crean dibujando con las herramientas de formas o la herramienta Pluma en el panel Composición. (Consulte Creación de formas y máscaras).

Los trazados de forma tienen dos variedades: trazados de formas paramétricas y los trazados de formas Curva. Los trazados de formas paramétricas se definen numéricamente mediante propiedades que se pueden modificar y animar después de la fase de dibujo, en el panel Línea de tiempo. Los trazados de formas Bézier se definen mediante una serie de vértices (puntos de trazados) y segmentos que se pueden modificar en el panel Composición. Con los trazados de formas Bézier se trabaja de la misma forma que con los trazados de máscaras. Todos los trazados de máscaras son trazados Bézier.

Se puede modificar una forma aplicando operaciones de trazados, como son Ondular trazados y Fruncir y engordar. Para aplicar un trazo a un trazado o aplicar relleno de color al área definida por un trazado, se emplean operaciones de pintura. (Consulte Atributos de forma, operaciones de pintura y operaciones de trazado para capas de formas).

Los trazados de formas, las operaciones de pintura y las operaciones de trazado de las formas se denominan colectivamente atributos de formas. Los atributos se agregan utilizando el menú Agregar del panel Herramientas o del panel Línea de tiempo. Cada atributo de forma se representa como un grupo de propiedades en el panel Línea de tiempo, con propiedades que se pueden animar, exactamente igual que con cualquier otra propiedad de capa. (Consulte Acerca de la animación, fotogramas clave y expresiones).

La profundidad de bits de color de una capa de forma es la misma que la del proyecto en su conjunto: 8, 16 o 32 bpc. (Consulte Profundidad de color y color de rango dinámico alto).

Las capas de formas no se basan en elementos del material de archivo. Las capas que no se basan en elementos del material de archivo se denominan en ocasiones capas sintéticas. Las capas de texto también son sintéticas y también se componen de objetos de gráficos vectoriales, de modo que muchas de las reglas y directrices que se aplican a las capas de texto, se aplican a las capas de formas. Por ejemplo, no se puede abrir una capa de formas en el panel Capas, como tampoco se puede abrir una capa de texto.

Nota:

Puede guardar las formas que más le gusten como ajustes predeterminados de animación. (Consulte Almacenamiento de un ajuste preestablecido de animación).

Recursos en línea para capas de forma

Para ver un tutorial de vídeo sobre cómo crear capas de forma a partir de capas vectoriales, visite la página de tutoriales de aprendizaje.

Trish y Chris Meyer ofrecen una introducción a las capas de forma en un pasaje en PDF del capítulo “Shape Layers” (Capas de forma) perteneciente a su libro Creación de gráficos de movimiento con After Effects (5ª edición)

Chris Zwar incluye un ajuste preestablecido de animación en su sitio web que crea una forma de cruz de destino utilizando una única capa de forma, con una gran variedad de propiedades personalizadas que facilitan y simplifican el control y la modificación de la animación.

Orden de grupos y de procesamiento para formas y atributos de forma

A pesar de que de manera predeterminada una forma consta de un solo trazado, un solo trazo y un solo relleno (organizados de arriba a abajo en el panel Línea de tiempo), buena parte del rendimiento y la flexibilidad de las capas de formas se debe a la posibilidad de agregar y reorganizar los atributos de forma y crear formas compuestas más complejas.

Se puede agrupar formas o atributos de formas que se encuentran en el mismo nivel de agrupación dentro de una misma capa de formas.

Un grupo es un conjunto de atributos de formas: trazados, rellenos, trazos, operaciones de trazados y otros grupos. Cada grupo posee su propio modo de combinación y su propio conjunto de propiedades de transformación. Ensamblando formas en grupos, se puede trabajar con varias formas simultáneamente. Por ejemplo, se puede ampliar o reducir la escala de todas las formas del grupo en la misma medida o se puede aplicar el mismo trazo a todas las formas. Incluso se pueden situar formas individuales o atributos de formas individuales dentro de sus propios grupos para aislar las transformaciones. Por ejemplo, agrupando sólo el trazado, se puede modificar la escala de un trazado sin modificar la de su trazo.

Cuando se agrega un atributo de forma utilizando el menú Agregar en el panel Herramientas o Línea de tiempo, se agrega el atributo dentro del grupo que está seleccionado. Se puede arrastrar grupos y atributos para reorganizarlos en el panel Línea de tiempo. Reorganizando y agrupando formas y atributos de formas, se puede alterar el orden de renderización con respecto a otras formas y atributos de formas.

Orden de grupos y de procesamiento para formas y atributos de forma
A. Dos formas en un grupo B. Dos trazados en una forma compuesta C. Trazado circular con ondulación de trazados D. Un trazo aplicado a todos los trazados que están sobre él E. Trazado en estrella en un grupo aparte F. Un relleno aplicado a todos los trazados que están sobre él G. Un trazado con dos trazos 

Orden de renderización de formas dentro de una capa de formas

Las reglas de renderización de una capa de formas son similares a las reglas de renderización de una composición que contiene composiciones anidadas:

  • En un grupo, la forma de la parte inferior del orden de apilamiento del panel Línea de tiempo es la que se renderiza primero.

  • Todas las operaciones de trazado de un grupo se llevan a cabo antes de las operaciones de pintura. Esto significa, por ejemplo, que el trazo sigue las distorsiones del trazado introducidas por la operación de trazado Ondular trazados. Las operaciones de trazado en un grupo se llevan a cabo de arriba a abajo. (Consulte Modificar formas con operaciones de trazado).

  • Las operaciones de trazado en un grupo se llevan a cabo desde abajo hacia arriba en el orden de apilamiento del panel Línea de tiempo. Esto significa, por ejemplo, que un trazo se renderiza por encima de (delante de) un trazo que aparezca después en el panel Línea de tiempo. Para omitir este comportamiento predeterminado para un relleno o trazo específico, seleccione Sobre anterior en mismo grupo en la propiedad Compuesto del relleno o del trazo, en el panel Línea de tiempo. (Consulte Trazos y rellenos para formas).

Las operaciones de trazado y las operaciones de pintura se aplican a todos los trazados que tengan encima en el mismo grupo.

Propiedades de transformación para grupos de formas y trazados de formas

Cada grupo posee su propio grupo de propiedades de transformación. Este grupo se representa en el panel Línea de tiempo con un grupo de propiedades llamado Transformar: [nombre del grupo] y en el panel Composición se representa mediante un cuadro punteado con controles. Se puede agrupar un trazado aparte y transformar únicamente el trazado utilizando su nuevo grupo de propiedades de transformación.

La introducción de un grupo de propiedades de transformación adicional resulta muy útil, por ejemplo, para crear un movimiento complejo, como podría ser girar alrededor de un punto de anclaje mientras existe un desplazamiento por una órbita. Las transformaciones de un grupo afectan a todas las formas del grupo; como ocurre en las relaciones de emparentamiento entre capas. (Consulte Capas primarias y secundarias).

Cada trazado de forma posee, además, propiedades intrínsecas relacionadas con la posición y la forma del trazado. En el caso de los trazados de formas paramétricas, estas propiedades (como son Posición y Tamaño) están relacionadas con los parámetros en el panel Línea de tiempo. En cuanto a los trazados de formas Bézier, estas propiedades se definen para todos los vértices, pero no están contenidas en las propiedades de trazados. Cuando se modifica un trazado Bézier utilizando el cuadro delimitador de transformación libre, se modifican las propiedades intrínsecas de los vértices que constituyen el trazado. (Consulte Acerca de las formas y las capas de formas).

Agrupar formas o atributos de formas

  1. Seleccione una o más formas o atributos de formas y realice una de las operaciones siguientes:
    • Seleccione Capa > Agrupar formas.
    • Presione Ctrl+G (Windows) o Comando+G (Mac OS).

Cuando se agrupan formas, se sitúa el punto de anclaje del grupo en el centro del cuadro delimitador del grupo.

Desagrupar formas o atributos de formas

  1. Seleccione un solo grupo y realice una de las siguientes acciones:
    • Seleccione Capa > Desagrupar formas.
    • Presione Ctrl+Mayús+G (Windows) o Comando+Mayús+G (Mac OS).

Creación de un grupo de formas vacío

  1. Seleccione Grupo (vacío) en el menú Agregar del panel Herramientas o en el panel Línea de tiempo.

Esta obra está autorizada con arreglo a la licencia de Reconocimiento-NoComercial-CompartirIgual 3.0 Unported de Creative Commons.  Los términos de Creative Commons no cubren las publicaciones en Twitter™ y Facebook.

Avisos legales   |   Política de privacidad en línea