Nota: Para obtener más información sobre la compatibilidad al utilizar Dynamic Link entre las distintas versiones de Premiere Pro y After Effects, consulte el artículo de la base de conocimiento, Uso de Dynamic Link entre las distintas versiones de Premiere Pro y After Effects.

De un experto: flujos de trabajo creativos de Dynamic Link con Premiere Pro y After Effects

De un experto: flujos de trabajo creativos de Dynamic Link con Premiere Pro y After Effects
Maxim Jago

Anteriormente, para compartir recursos de medios entre aplicaciones de postproducción era necesario procesar y exportar el trabajo desde una aplicación antes de importarlo en otra. Se trataba de un flujo de trabajo poco eficaz y en el que se perdía mucho tiempo. Si deseaba hacer cambios en el recurso original, era preciso volver a procesar y exportar el recurso. Múltiples versiones procesadas y exportadas de un recurso consumen espacio del disco y pueden generar dificultades para gestionar los archivos.

Dynamic Link ofrece una alternativa a este flujo de trabajo. Se pueden crear vínculos dinámicos entre After Effects y Adobe Premiere Pro. Crear un vínculo dinámico es tan sencillo como importar cualquier otro tipo de recurso. Los recursos con vínculos dinámicos aparecen con iconos únicos y colores de etiquetas que ayudan a identificarlos. Los vínculos dinámicos se guardan en proyectos generados por dichas aplicaciones.

Se pueden crear nuevas composiciones de After Effects y vincularlas de forma dinámica desde Adobe Premiere Pro. Asimismo, puede vincularlas dinámicamente a composiciones existentes de After Effects desde Adobe Premiere Pro.

Creación de una composición a partir de clips en Adobe Premiere Pro

Puede sustituir los clips seleccionados en Adobe Premiere Pro con una composición de After Effects enlazada dinámicamente basada en esos clips. La nueva composición hereda los ajustes de la secuencia de Adobe Premiere Pro.

  1. Abra Premiere Pro y seleccione los clips que desee reemplazar.

  2. Haga clic con el botón secundario en cualquiera de los clips seleccionados.
  3. Seleccione Reemplazar con composición de After Effects.

    Se abre After Effects (si no estaba abierto) y se crea una nueva composición vinculada.

Creación de una composición vinculada dinámicamente desde Adobe Premiere Pro

Al crear una nueva composición vinculada dinámicamente desde Adobe Premiere Pro, se inicia After Effects. A continuación, After Effects crea un proyecto y una composición con las dimensiones, la proporción de píxeles, la velocidad de fotogramas y la frecuencia de muestreo de audio del proyecto original. (Si After Effects ya se está ejecutando, crea una nueva composición en el proyecto actual.) El nombre de la nueva composición se basa en el nombre del proyecto de Adobe Premiere Pro, seguido de Comp. vinculada [x].

  1. En Adobe Premiere Pro, seleccione Archivo > Adobe Dynamic Link > Nueva composición de After Effects. En la versión de 2014 de Premiere Pro se pueden importar composiciones con el Navegador de medios. Consulte las secciones siguientes en Premiere Pro para obtener más información:

  2. Si aparece el cuadro de diálogo Guardar como de After Effects, introduzca un nombre y una ubicación para el proyecto de After Effects, y haga clic en Guardar.

    Nota:

    Al crear una composición vinculada dinámicamente en After Effects, la duración de la composición se fija en 30 segundos. Para modificar la duración, seleccione la composición en After Effects y elija Composición > Ajustes de composición. Haga clic en la ficha Básico y especifique un nuevo valor para Duración.

Para obtener resultados óptimos, haga que los ajustes de composición (como las dimensiones, la proporción de píxeles y la velocidad de fotogramas) coincidan con los del proyecto de Adobe Premiere Pro.

  1. Realice una de las acciones siguientes:
    • En Adobe Premiere Pro, seleccione Archivo > Adobe Dynamic Link > Importar composición de After Effects. Seleccione un archivo de proyecto de After Effects (.aep) y, a continuación, elija una o varias composiciones.

    • En Adobe Premiere Pro, seleccione un archivo de proyecto de After Effects y haga clic en Abrir. A continuación, seleccione una composición en el cuadro de diálogo que aparece y haga clic en Aceptar.

    • Arrastre una o más composiciones del panel Proyecto de After Effects al panel Proyecto de Adobe Premiere Pro.

    • Arrastre un archivo de proyecto de After Effects al panel Proyecto de Premiere Pro. Si el archivo de proyecto de After Effects contiene varias composiciones, se abre el cuadro de diálogo Importar composición.

Nota:

Puede vincular una sola composición de After Effects en un solo proyecto de Adobe Premiere Pro muchas veces.

Modificación de una composición de Dynamic Link en After Effects

En Adobe Premiere Pro, utilice el comando Editar original para modificar una composición vinculada de After Effects. Una vez que la composición esté abierta en After Effects, puede cambiar la composición sin tener que volver a utilizar el comando Editar original.

  1. Seleccione la composición de After Effects en Adobe Premiere Pro, o bien elija un clip vinculado en la línea de tiempo y seleccione Editar > Editar original.

  2. Cambie la composición en After Effects. A continuación, vuelva a Adobe Premiere Pro para ver los cambios.

Los cambios realizados en After Effects aparecen en Adobe Premiere Pro. Adobe Premiere Pro deja de utilizar los archivos de previsualización representados para el clip antes de los cambios.

Nota:

Puede cambiar el nombre de la composición en After Effects después de crear un vínculo dinámico a esta desde Adobe Premiere Pro. Adobe Premiere Pro no actualizará el nombre de la composición vinculada en el panel Proyecto. Sin embargo, Adobe Premiere Pro conserva el vínculo dinámico.

Eliminación de una composición o un clip de Dynamic Link

Se puede eliminar una composición vinculada de un proyecto de Adobe Premiere Pro en cualquier momento, aunque se esté utilizando en un proyecto.

Los clips vinculados desde la línea de tiempo se pueden eliminar en cualquier momento de una secuencia o línea de tiempo de Adobe Premiere Pro.

  1. En Adobe Premiere Pro, seleccione la composición o el clip vinculados y pulse la tecla Supr.

Al crear una secuencia de Adobe Premiere Pro en After Effects se inicia Adobe Premiere Pro. A continuación, Adobe Premiere Pro crea un proyecto y una secuencia con las dimensiones, la proporción de píxeles, la frecuencia de fotogramas y la velocidad de muestreo de audio del proyecto original. (Si Adobe Premiere Pro ya se está ejecutando, crea una secuencia en el proyecto actual.)

  1. En After Effects, seleccione Archivo > Adobe Dynamic Link > Nueva secuencia de Premiere Pro.

Para obtener mejores resultados, haga coincidir los ajustes de la secuencia y del proyecto en Adobe Premiere Pro (como las dimensiones, la proporción de píxeles y la velocidad de fotogramas) con los del proyecto de After Effects.

Realice una de las acciones siguientes:

  • En After Effects, seleccione Archivo > Adobe Dynamic Link > Importar secuencia de Premiere Pro. Elija un proyecto de Adobe Premiere Pro y, a continuación, elija una o varias secuencias.

  • Arrastre una o varias secuencias desde el panel Proyecto de Adobe Premiere Pro hasta el panel Proyecto de After Effects.

Un clip vinculado puede hacer referencia a una composición de origen compleja. Las acciones que se llevan a cabo en la composición de origen requieren tiempo de procesamiento adicional según la complejidad. After Effects aplica las acciones y coloca los datos finales a disposición de Adobe Premiere Pro con la caché de rendimiento global y las funciones de la caché de disco persistente. Estas funciones mejoran el rendimiento de After Effects con los fotogramas almacenados en caché cuando Premiere Pro solicita los fotogramas.

Para reducir los retrasos en la reproducción, siga uno de estos procedimientos:

  • Desconecte la composición vinculada

  • Deshabilite un clip vinculado para que temporalmente no haga referencia a una composición

  • Sustituya la composición vinculada dinámicamente por el archivo procesado mediante la función Procesar y reemplazar en Premiere Pro (Clip > Procesar y reemplazar).  

Si normalmente trabaja con composiciones de origen complejas, agregue RAM o actualice a un procesador más rápido.

Nota:

Una composición vinculada de After Effects no será compatible con el procesamiento múltiple de Procesar múltiples marcos a la vez de forma simultánea. Consulte Mejorar el rendimiento optimizando la configuración de memoria, caché y multiprocesamiento.

Exportar a Adobe Media Encoder

Para codificar composiciones de After Effects, debe agregarlas a la cola de codificación en Adobe Media Encoder y, a continuación, seleccionar ajustes preestablecidos o crear su propia configuración personalizada de procesamiento. En After Effects, puede añadir una composición a la cola de Media Encoder con una de las siguientes opciones:

  • Archivo > Exportar > Añadir a la cola de Media Encoder
  • Composición > Añadir a la cola de Media Encoder

Cuando agrega una composición o un proyecto a la cola de Adobe Media Encoder, After Effects ejecuta Adobe Media Encoder con composiciones enumeradas en la cola.

En los siguientes artículos se explica el proceso de codificación:

Esta obra está autorizada con arreglo a la licencia de Reconocimiento-NoComercial-CompartirIgual 3.0 Unported de Creative Commons.  Los términos de Creative Commons no cubren las publicaciones en Twitter™ y Facebook.

Avisos legales   |   Política de privacidad en línea