Utilice este documento para obtener información sobre los conceptos básicos de la composición en After Effects

Acerca de las composiciones

Una composición es el marco para una película. Cada composición dispone de su propia línea de tiempo. Una composición típica incluye varias capas que representan diversos componentes, como elementos de material de archivo de vídeo y audio, texto animado y gráficos vectoriales, imágenes fijas y luces. Para agregar un elemento de material de archivo a una composición, se crea una capa cuyo origen es el elemento de material de archivo. Las capas de una composición se organizan dentro de un espacio y un tiempo y se montan a través de funciones de transparencia para determinar qué partes de las capas subyacentes se muestran a través de las capas situadas encima de ellas. (Consulte Capas y propiedades y Transparencia y composición).

Las composiciones de After Effects son similares a los clips de película en Flash Professional o a una secuencia de Premiere Pro.

Puede procesar una composición para crear los fotogramas de una película de salida final, que se codifica y exporta a cualquier tipo de formato. (Consulte Conceptos básicos del procesamiento y la exportación).

Los proyectos sencillos suelen incluir una sola composición; los proyectos complejos suelen incluir cientos de composiciones para organizar la gran cantidad de material de archivo o los numerosos efectos.

A veces, en la interfaz de usuario de After Effects, para el término composición se utiliza la abreviatura comp.

En el panel Proyecto hay una entrada por cada composición. Haciendo doble clic en la entrada de una composición en el panel Proyecto se abre la composición en su propio panel Línea de tiempo. Para seleccionar una composición en el panel Proyecto, haga clic con el botón derecho del ratón (Windows) o mantenga presionada la tecla Control y haga clic (Mac OS) en el panel Composición de la composición o en el panel Línea de tiempo, y elija Revelar composición en proyecto desde el menú contextual.

Utilice el panel Composición para previsualizar una composición y modificar su contenido de forma manual. El panel Composición contiene el fotograma de la composición y una zona de trabajo situada fuera del fotograma que se puede utilizar para introducir o sacar capas del fotograma de la composición. Las partes de las capas que no se encuentran en el fotograma de la composición se muestran como contornos rectangulares. En las previsualizaciones y el resultado final solo se procesa el área dentro del fotograma de la composición.

El fotograma de composición del panel Composición en After Effects es similar al escenario en Flash Professional.

Cuando trabaje con un proyecto complejo, tal vez le resulte más fácil organizar el proyecto anidando composiciones (es decir, incluyendo una o más composiciones dentro de otra). Puede crear una composición a partir de cualquier número de capas precomponiéndolas. Después de realizar cambios en ciertas capas de la composición, puede precomponer dichas capas y preprocesar la precomposición, sustituyéndola por una película procesada. (Consulte Precomposición, anidamiento y preprocesamiento).

Puede desplazarse en una jerarquía de composiciones anidadas con el navegador y el minidiagrama de flujo de la composición (consulte Apertura y desplazamiento en composiciones anidadas).

Utilice el panel Diagrama de flujo para ver la estructura de una composición compleja o red de composiciones.

Botón Línea de tiempo

 Haga clic en este botón situado en la parte inferior del panel Composición para activar el panel Línea de tiempo de la composición actual.

Nota:

Presione la tecla de la barra invertida (\) para conmutar entre el panel Composición y el panel Línea de tiempo de la composición actual.

Botón Comp

 Haga clic en este botón situado en la esquina superior derecha del panel Línea de tiempo para activar el panel Composición de la composición actual.

Botón Diagrama de flujo

 Haga clic en este botón situado en la parte inferior del panel Composición para activar el panel Diagrama de flujo de la composición actual.

Creación de una composición

Puede modificar los ajustes de composición en cualquier momento. Sin embargo, lo ideal es especificar los ajustes (p. ej., tamaño de fotograma y relación de aspecto de fotograma) al crear la composición, con el resultado final en mente. Como ciertos cálculos de After Effects se basan en estos ajustes de la composición, una modificación a posteriori durante el flujo de trabajo puede afectar al resultado final.

Nota:

Algunos ajustes de la composición se pueden anular durante el procesamiento para obtener el resultado final. Por ejemplo, se pueden utilizar tamaños de fotograma distintos para la misma película. Para obtener más información, consulte Ajustes de procesamiento y Módulos de salida y sus ajustes.

Cuando se crea una composición y no se modifican los ajustes del cuadro de diálogo Ajustes de composición, se aplican a la nueva composición los ajustes configurados para la composición anterior.

Nota:

Las composiciones nuevas no heredan los ajustes anteriores de Conservar velocidad de fotogramas cuando estén anidados o en la cola de procesamiento y Conservar resolución cuando estén anidadas.

Jeff Almasol incluye un script en su sitio Web redefinery que crea y guarda un nuevo proyecto para cada composición seleccionada en el proyecto actual. Si se selecciona una carpeta en el panel Proyecto al crear una nueva composición, esta se coloca en la carpeta seleccionada.

Creación de una composición y configuración manual de los ajustes de la composición

  1. Seleccione Composición > Nueva composición, o presione Ctrl+N (Windows) o Comando+N (Mac OS).

Creación de una composición a partir de un solo elemento de material de archivo

  1. Arrastre el elemento de material de archivo al botón Crear nueva composición situado en la parte inferior del panel Proyecto o elija Archivo > Nueva comp. a partir de selección.

    Los ajustes de la composición, incluido el tamaño de fotograma (alto y ancho) y la proporción de aspecto de píxeles, se configuran automáticamente para adaptarse a las características del elemento de material de archivo.

Creación de una sola composición a partir de varios elementos de material de archivo

  1. Seleccione los elementos de material de archivo en el panel Proyecto.
  2. Arrastre los elementos de material de archivo seleccionados al botón Crear nueva composición situado en la parte inferior del panel Proyecto o seleccione Archivo > Nueva comp. a partir de selección.
  3. Seleccione Composición única y configure otros ajustes del cuadro de diálogo Nueva composición a partir de selección:

    Utilizar dimensiones desde

    Elija el elemento de material de archivo cuyos ajustes de composición deban utilizarse para la composición nueva, incluido el tamaño de fotograma (alto y ancho) y la proporción de aspecto de píxeles.

    Duración de imagen fija

    Se trata de la duración de las imágenes fijas que se van a agregar.

    Agregar a la cola de procesamiento (MS Windows)/Añadir a la cola de procesamiento (Mac OS)

    Agregue la nueva composición a la cola de procesamiento.

    Capas de secuencia, Superposición, Duración y Transición

    Organice las capas en una secuencia, superpóngalas en el tiempo de forma opcional, ajuste la duración de las transiciones y seleccione un tipo de transición.

Creación de varias composiciones a partir de varios elementos de material de archivo

  1. Seleccione los elementos de material de archivo en el panel Proyecto.
  2. Arrastre los elementos de material de archivo seleccionados al botón Crear nueva composición situado en la parte inferior del panel Proyecto o seleccione Archivo > Nueva comp. a partir de selección.
  3. Seleccione Varias composiciones y configure otros ajustes del cuadro de diálogo Nueva composición a partir de selección:

    Duración de imagen fija

    Se trata de la duración de las composiciones creadas a partir de imágenes fijas.

    Agregar a la cola de procesamiento (MS Windows)/Añadir a la cola de procesamiento (Mac OS)

    Agregue las nuevas composiciones a la cola de procesamiento.

Nota:

Si selecciona varios elementos de material de archivo, aparece el cuadro de diálogo Nueva composición a partir de selección. Puede elegir crear una composición única con todos los elementos de material de archivo o una composición para cada elemento de material de archivo.

Selección de la composición
Selección de la composición

Duplicación de una composición

  1. Seleccione la composición en el panel Proyecto.
  2. Elija Editar > Duplicar o presione Control + D (Windows) o Comando + D (Mac OS).

Panel Línea de tiempo

Cada composición dispone de su propio panel Línea de tiempo. El panel Línea de tiempo se utiliza para realizar muchas tareas, p. ej., animar propiedades de capas, organizar capas en el tiempo y ajustar modos de fusión. Las capas situadas al final del apilado de capas en el panel Línea de tiempo se procesan primero y (en el caso de las capas de imágenes 2D) aparecen más al fondo en el panel Composición y en la composición final.

Nota:

Para avanzar por los paneles Línea de tiempo, presione Alt+Mayús+punto (.) (Windows) u Opción+Mayús+punto (.) (Mac OS). Para retroceder por los paneles Línea de tiempo, presione Alt+Mayús+coma (,) (Windows) u Opción+Mayús+coma (,) (Mac OS).

El tiempo actual de una composición se indica en el indicador de tiempo actual (CTI), la línea roja vertical del gráfico de tiempo. El tiempo actual de una composición también aparece en la visualización del tiempo actual, en la esquina superior izquierda del panel Línea de tiempo. Para obtener más información sobre el desplazamiento del indicador del tiempo actual, consulte Mover el indicador de tiempo actual.

El lado izquierdo del panel Línea de tiempo está compuesto por columnas de controles de capas. El lado derecho del panel Línea de tiempo (el gráfico de tiempo) contiene una regla de tiempo, marcadores, fotogramas clave, expresiones, barras de duración para las capas (en el modo de barras de capas) y el editor de gráficos (en el modo del editor de gráficos).

Timeline Panel AE

Nota:

Presione la tecla de la barra invertida (\) para conmutar entre el panel Composición y el panel Línea de tiempo de la composición actual.

Ajustes de composición

Puede introducir los ajustes de la composición de forma manual o utilizar los ajustes preestablecidos para configurar automáticamente el tamaño de fotograma (alto y ancho), la proporción de aspecto de píxeles y la velocidad de fotogramas para muchos formatos de salida habituales. También puede crear y guardar sus propios ajustes preestablecidos personalizados para su uso posterior. Los ajustes de composición Resolución, Código de tiempo de inicio (o Fotograma de inicio), Duración y Avanzado no se guardan con los ajustes preestablecidos de la composición.

Nota:

El límite de duración de una composición es de tres horas. Puede utilizar elementos de material de archivo de más de tres horas pero, una vez transcurrido dicho periodo, el tiempo no se indicará correctamente. El tamaño de composición máximo es también 30 000 x 30 000 píxeles. Una imagen de 8 bpc de 30 000 x 30 000 requiere aproximadamente 3,5 GB; el tamaño de composición máximo puede ser inferior, en función del sistema operativo y la RAM disponible.

Uso de los ajustes de la composición

  • Para abrir el cuadro de diálogo Ajustes de composición y cambiar los ajustes de la composición, realice una de las siguientes acciones:

    • Seleccione una composición en el panel Proyecto o active el panel Línea de tiempo o Composición de la composición deseada y, a continuación, elija Composición > Ajustes de composición, o presione Ctrl + K (Windows) o Comando + K (Mac OS).

    • Haga clic con el botón derecho (Windows) o mantenga presionada la tecla Control y haga clic (Mac OS) en una composición en el panel Proyecto o en el panel Composición de la composición, y seleccione Ajustes de composición en el menú contextual.

  • Para guardar un ajuste preestablecido de composición personalizado, ajuste los valores Ancho, Alto, Proporción de aspecto de píxeles y Velocidad de fotogramas en el cuadro de diálogo Ajustes de composición, y haga clic en el botón Guardar .

  • Para eliminar un ajuste preestablecido de composición, selecciónelo en el menú Ajustes preestablecidos en el cuadro de diálogo Ajustes de composición, y haga clic en el botón Eliminar .

  • Para restaurar los ajustes preestablecidos de la composición predeterminada, presione Alt (Windows) u Opción (Mac OS) y haga clic en el botón Eliminar o en el botón Guardar en el cuadro de diálogo Ajustes de composición.

Nota:

Los ajustes preestablecidos personalizados de composición no se pueden mover de un sistema a otro, ya que están incorporados en el archivo de preferencias.

  • Para escalar toda la composición, seleccione Archivo > Scripts > Scale composition.jsx.

Nota:

Asegúrese de que todas las capas de la composición seleccionada estén desbloqueadas o la secuencia de comandos no funcionará.

Jeff Almasol proporciona una secuencia de comandos en su sitio Web redefinery para establecer la velocidad de fotogramas y la duración de la composición actual y de todas las composiciones anidadas en la misma.

Christopher Green incluye una secuencia de comandos (Selected_Comps_Changer.jsx) en su sitio web (en inglés) con la que se pueden modificar los ajustes de composición para las composiciones seleccionadas en el panel Proyecto.

Ajustes básicos de la composición

Código de tiempo de inicio o fotograma de inicio

Código de tiempo o número de fotograma asignado al primer fotograma de la composición. Este valor no afecta al procesamiento; simplemente indica desde dónde se debe comenzar a contar.

Color de fondo

Utilice la muestra de color o el cuentagotas para seleccionar un color de fondo de la composición. (Consulte Selección de un color o edición de un degradado).

Nota: cuando agrega una composición a otra (anidamiento), se conserva el color de fondo de la composición que contiene a la otra y el fondo de la composición anidada se convierte en transparente. Para mantener el color de fondo de la composición anidada, cree una capa de color sólido para utilizarla como capa de fondo en la composición anidada.

Para obtener información sobre la configuración específica de composición básica, consulte las secciones relacionadas

Ajustes avanzados de la composición

Anclaje

Haga clic en un botón de flecha para anclar las capas a un borde o una esquina de la composición cuando se redimensione.

Conservar resolución cuando estén anidados y Conservar velocidad de fotogramas cuando estén anidados o en la cola de procesamiento

Para que una composición conserve su propia resolución o velocidad de fotogramas en lugar de heredar los ajustes de la composición contenedora. Por ejemplo, si ha utilizado deliberadamente una velocidad de fotogramas lenta en una composición para crear un efecto de animación manual entrecortada, debe conservar la velocidad de fotogramas de dicha composición cuando la anide. Del mismo modo, los efectos de rotoscopia pueden parecer desatinados si se convierten a una resolución o a una velocidad de fotogramas distinta. Utilice este ajuste en lugar del efecto estroboscópico, que es menos eficaz.

Ajustes de desenfoque de movimiento

  • Ángulo del obturador: el ángulo del obturador se mide en grados y simula la exposición permitida por un obturador mientras gira. El ángulo del obturador utiliza la velocidad de fotogramas del material de archivo para determinar la exposición simulada, la cual afecta a la cantidad de desenfoque de movimiento. Por ejemplo, si escribe 90° (25% de 360°) para un material de archivo de 24 fps, se crea una exposición efectiva de 1/96 de un segundo (25% de 1/24 de un segundo). Si escribe 1º apenas se aplicará desenfoque de movimiento, y si escribe 720º se aplicará un alto grado de desenfoque.
  • Fase del obturador: la fase del obturador se mide siempre en grados. Define un desplazamiento que determina cuándo se abre el obturador en relación al comienzo de cada fotograma. El ajuste de este valor puede ayudar si un objeto con un desenfoque de movimiento aplicado parece retrasarse en relación a la posición del objeto sin desenfoque de movimiento aplicado.
  • Muestras por fotograma: el número mínimo de muestras. Este mínimo es el número de muestras por fotograma para las que After Effects no es capaz de determinar una velocidad de muestreo adaptativo basado en un movimiento de capa. Esta velocidad de muestra se emplea para capas 3D y capas de forma.
  • Límite de muestras adaptable: el número máximo de muestras.

Para obtener información sobre ajustes de composición avanzados específicos que no figuren aquí, consulte las secciones relacionadas:

Ajustes del procesador 3D

Puede utilizar las opciones de la ficha del procesador 3D para elegir el procesador 3D más adecuado para su composición. Puede elegir entre los siguientes procesadores en el menú Procesador:

  • Classic 3D
  • CINEMA 4D
  • 3D con trazo de rayo

La funcionalidad 3D del Procesador de composición CINEMA 4D y del procesador 3D con trazo de rayo es casi idéntica con la extrusión de texto en 3D y capas de formas y la curvatura de otras capas 3D (sólidos, material de archivo, etc.) en los planos curvados. Sin embargo, los resultados procesados pueden ser diferentes porque generan resultados con distintos procesadores y admiten conjuntos de funciones distintos. Por ejemplo, hay algunas diferencias en las opciones de material de capa 3D y otros comportamientos de la capa. 

El Procesador de composición CINEMA 4D procesa las capas 3D que incluyen el texto y las formas extruidas y los planos 2D curvos para facilitar el proceso de animar texto y logotipos 3D desde cero. El rendimiento del procesador de CINEMA 4D es mucho más rápido que el rendimiento únicamente mediante CPU del procesador 3D con trazo de rayo.

Ficha del procesador 3D
Ficha del procesador 3D

Procesador Classic 3D

Classic 3D es el procesador tradicional predeterminado. Las capas se colocan como planos en un espacio 3D.

Opciones del procesador de composición CINEMA 4D

Calidad: el nivel de calidad definido en el regulador afecta a los parámetros que determinan el modo en el que el Procesador de composición Cinema 4D dibuja las capas 3D. Puede ver los parámetros resultantes del procesador en los recuadros Opciones, Suavizado y Reflejo. El ajuste Calidad facilita la elección de una combinación equilibrada de velocidad de procesamiento y calidad de representación 3D aceptable sin necesidad de comprender y modificar los diversos parámetros de calidad de procesamiento.

Los siguientes parámetros se modifican cuando se ajusta el regulador Calidad:

  • Umbral de rayos: este valor contribuye a optimizar el tiempo de procesamiento. 
  • Profundidad de rayos: la profundidad de rayos determina en cuántos objetos transparentes (o áreas que se han hecho invisibles mediante el canal alfa) puede penetrar el procesador. 
  • Profundidad del reflejo: cuando un rayo se envía a la escena, las superficies reflectantes pueden reflejarlo. Cuanto mayor sea la Profundidad del reflejo, mayor será la incidencia de los rayos en la escena y más se procesarán los resultados.
  • Profundidad de la sombra: la profundidad de la sombra se comporta de forma similar a la profundidad del reflejo. El ajuste de profundidad de la sombra define la profundidad de la sombra con la que se vuelven a calculan los rayos visibles de la sombra. 

Suavizado: la geometría es el ajuste de suavizado predeterminado que alisa todos los bordes del objeto (automáticamente con los subpíxeles 16x16).

Reflejo: el muestreo de la capa es el ajuste de reflejo predeterminado que define la calidad de los reflejos mates.

Cuando se selecciona CINEMA 4D en el cuadro desplegable Procesador, la columna Habilitado muestra las opciones 3D que se encuentran activas y la columna Deshabilitado, muestra las opciones 3D que no están disponibles.

Opciones del Procesador CINEMA 4D
Opciones del Procesador CINEMA 4D

Para elegir el nivel de calidad de procesamiento 3D, haga clic en el botón Opciones después de seleccionar CINEMA 4D como procesador y defina la calidad con el regulador Calidad. Los valores de Umbral de rayos, Profundidad de rayos, Profundidad del reflejo, Profundidad de la sombra, Filtro de suavizado y Reflejo cambian en consecuencia.

Configuración del regulador Calidad
Configuración del regulador Calidad

After Effects instala un procesador predeterminado en el equipo. Puede cambiar el procesador a una versión completa de pago de CINEMA 4D, si lo tiene instalado.

El editor predeterminado es la última versión instalada de CINEMA 4D o de CINEMA 4D Lite.

Para seleccionar otra instalación de CINEMA 4D, haga clic en Elija la instalación y seleccione la ruta de acceso al programa de instalación en los cuadros Procesamiento y Edición.

Elija la instalación de CINEMA 4D
Elija la instalación de CINEMA 4D

Opciones del procesador 3D con trazo de rayo

Haga clic en el botón Opciones para iniciar el cuadro de diálogo Opciones del procesador 3D con trazo de rayo. También puede presionar Ctrl (Windows) o Comando (Mac OS) y hacer clic en el botón Indicador de procesador actual en la esquina superior derecha del panel Composición para abrir el cuadro de diálogo.

En él podrá elegir:

  • Calidad de trazado por rayos: Haga clic en los ajustes de calidad de trazado por rayos para cambiarlos según el flujo de trabajo.
    • Si elige un valor elevado para la calidad de trazado por rayos, se reducirá el ruido pero se prolongará el tiempo de procesamiento.
      La calidad del trazado por rayos controla el número de rayos disparados por píxel (por ejemplo, un valor de 4 dispara 16 rayos o 4x4 rayos, 8 dispara 64 rayos).
    • Un número mayor produce píxeles más exactos pero requiere más tiempo de cálculo.
    • Un valor de 1 proporciona un mejor rendimiento, pero no habrá ningún desenfoque de reflejo (por ejemplo, siempre será nítido), sombra suave, profundidad de campo o desenfoque de movimiento.

Al aumentar el valor de Calidad de trazado por rayos, no se aumenta la nitidez, pero se reduce el ruido inherente al muestreo de punto. Utilice el valor mínimo que produzca una cantidad aceptable de ruido o ningún ruido.

  • Filtro de suavizado: controla el método de cálculo del promedio de rayos disparados por píxel. Ninguno dispara todos los rayos dentro de los límites de un píxel, mientras que las otras opciones extienden la cuadrícula de rayos disparados parcialmente entre los píxeles adyacentes para producir un mejor promedio. Cuadro, Tienda y Cubic (no bicúbico) se muestran en orden de calidad, de mejor a peor.
    • Ninguno
    • Cuadro
    • Tienda
    • Cubic

El filtro de suavizado controla la cantidad de desenfoque. Ninguno ofrece la mejor nitidez pero los bordes de la captura de proyección pueden tener un aspecto dentado. El desenfoque de Cuadro, Triángulo y Cubic ofrecen resultados más borrosos.

Nota:

Las capas 3D con trazo de rayo utilizan la Calidad de trazado por rayos para controlar el aspecto de desenfoque de movimiento.

El cálculo de profundidad de campo en el 3D con trazo de rayo es más exacto que en Classic 3D (y anteriormente en 3D avanzado).

Imágenes en miniatura de la composición

Puede elegir el fotograma de la composición que desee visualizar como imagen en miniatura (fotograma de póster) en la composición del panel Proyecto. De forma predeterminada, la imagen en miniatura es el primer fotograma de la composición, con las partes transparentes en negro.

  • Para definir la imagen en miniatura de una composición, desplace el indicador de tiempo actual hasta el fotograma deseado en el panel Línea de tiempo de la composición y elija Composición > Establecer tiempo añadido.
  • Para agregar una cuadrícula de transparencia a la vista de imágenes en miniatura, elija Cuadrícula de transparencia para imágenes en miniatura en el menú del panel Proyecto.
  • Para ocultar las imágenes en miniatura en el panel Proyecto, elija Editar > Preferencias > Visualización (Windows) o After Effects > Preferencias > Visualización (Mac OS) y seleccione Deshabilitar miniaturas en el panel Proyecto.

Esta obra está autorizada con arreglo a la licencia de Reconocimiento-NoComercial-CompartirIgual 3.0 Unported de Creative Commons.  Los términos de Creative Commons no cubren las publicaciones en Twitter™ y Facebook.

Avisos legales   |   Política de privacidad en línea