New features overview

Introduction to Adobe Premiere Pro CS6

Introduction to Adobe Premiere Pro CS6
Al Mooney, Product Manager for Professional Video Products, provides an introduction to Adobe Premiere Pro CS6.
Al Mooney

Redesigned, customizable user interface

New default workspace

Premiere Pro CS6 has a new default editing workspace with larger Source and Program monitors (a configuration referred to as "2-up"). This view allows you to view high-definition video much more easily in this workspace.

To return to the standard editing workspace found in Premiere Pro CS5.5 and earlier, choose Window > Workspace > Editing (CS5.5).

Resources:

Redesigned Source and Program Monitors

The Source and Program monitors have been redesigned to be more customizable.

  • Customizable button bar.
  • Timecode numbers can be toggled on or off (also available in the Timeline).
  • Pop-up menu for direct access to playback resolution.
  • Setting button for easier access to monitor settings.

Resources:

Redesigned Project panel

The Project Panel has been redesigned with these features:

  • Resizable clip thumbnails.
  • Clip thumbnails maximized to use space more efficiently.
  • In thumbnail view, scrub clips by dragging the mouse across a thumbnail. This technique is called "hover scrubbing".
  • In thumbnail view, clips can be selected and scrubbed with the Clip Playhead, or by using the JKL and Spacebar keyboard shortcuts.
  • Mark In and Out points on clips as you are scrubbing, or on the fly as you are playing back by using the JKL and Spacebar keyboard shortcuts.
  • A usage icon can be used to navigate to clips in sequences.

Resources:

Timecode panel

A panel that displays oversized timecode, and feet+frames is now available in Premiere Pro CS6.

To view the Timecode panel, choose Window > Timecode.

Resources:

Primary edit display in Cinema mode

Put either the Program monitor or the Source monitor into full-screen, “cinema” mode on your system’s primary display.

To toggle Cinema mode on and off, press the Ctrl key and the Accent key, and then click either the Source monitor or Program monitor. Press the keyboard shortcuts once more to return to the interface.

Resources:

Dropped Frame indicator

Both the Source and the Program monitor now have the option to display an icon that indicates if frames are being dropped during playback.

Resources:

Trackpad gesture support for Mac OS

Use trackpad gestures to navigate the Timeline and other panels in Premiere Pro using the MacBook Pro's trackpad or the Apple Magic Trackpad.   

Resources:

Editing workflow improvements

Mercury Playback Engine improvements

  • The Adobe Mercury Transmit feature enables third-party capture cards to plug directly in to the performance of the Mercury Playback Engine. The feature gives you access to CUDA acceleration and enhanced support for SDI I/O and professional broadcast monitoring.
  • New support for the OpenCL-based AMD Radeon HD 6750M, and 6770 graphics cards makes the Mercury Playback Engine (Hardware) available on certain Apple MacBook Pro computers.
  • More CUDA-based video cards are approved for the Mercury Playback Engine. For an up-to-date list of supported cards, see: www.adobe.com/go/64bitsupport

Resources:

Efficient ingest and logging with Adobe Prelude

Ingest clips using Adobe Prelude. Then log clips and create subclips, markers, In and Out points, searchable notes, metadata, and rough cuts. You can bring the data from the Prelude project right into Premiere Pro.

Note: Adobe Prelude is a separate application.

Resources:

Multicam improvements

You can now use more than four camera angles in multicam editing. You are limited in number of angles only by the power of your computer. It's also easier to create multicam sequences.

Resources:

Improved trimming

There are powerful new options for quickly selecting and shifting edit points using the mouse, new keyboard shortcuts, or the numeric keypad. JKL dynamic trimming is supported, as well. The new Trim Mode provides a two-up display showing the outgoing and incoming frames right inside the Program monitor. Timeline trimming has also been improved with a keyboard driven workflow.

To open Trim mode, double-click any edit point.

Resources:

Continuous playback

The Timeline transport now continues playback unless the user specifically issues a Stop command. This feature supports real-time adjustment of common editing actions.

Resources:

New functionality for clip markers

Clip markers have been improved with color labels and the ability to span a duration of time. Functionality previously available only in sequence markers is now available in clip markers. Customize markers in the redesigned Marker dialog box. View all of your clip markers in the new Markers panel.

Resources:

Improved Adobe Dynamic Link

Improved Dynamic Link, including performance enhancements, and removal of the limitation of Dynamic Link to only work within a suite (for example, Dynamic Link will now work between CS6 applications purchased as individual products).

Resources:

Smart rendering

In Premiere Pro CS6 (6.0.1), smart rendering capability has been added for Long GOP MPEG2 OP1a exports, where the original material is a matching long GOP MPEG2 OP1a or XDCAM EX file. Smart rendering in Premiere Pro CS6 (6.0.1) accelerates MXF render times for long GOP MPEG2 essences, while avoiding recompression.

Resources:

Support for growing files

Growing files are video files which grow in duration after they are ingested. Premiere Pro CS6 now supports growing files for the following codecs:

  • AVCI50/100
  • IMX30/40/50
  • RDD9-compliant XDCAM HD 50/35/25/18
  • QuickTime wrapped files in these formats are supported in Premiere Pro CS6 (6.0.2), and later

Resources:

Audio workflow improvements

Redesigned Audio Mixer

The Audio Mixer panel has been redesigned to include the following features.

  • Select between two visual metering modes.
  • Double-click a fader to return it to 0dB.
  • Separate dB scales for the meters and faders.
  • A context menu for meter options in the panel menu. 

Resources:

Redesigned Audio Meter panel

The Audio Meter panel has been redesigned to be more accurate, customizable, and easier to use. The Audio Meter panel offers these features:

  • Meters auto layout horizontally or vertically
  • Meters scale as needed
  • New Solo buttons for each channel
  • Audio Meter panel now meters the Source Monitor content
  • Several options for displaying audio

Resources:

New audio track functionality

Mono and stereo audio tracks are no longer separate. A new kind of audio track, called "Standard" can contain both stereo and mono clips.

Resources:

Improved audio channel functionality in Source monitor

In the Source monitor, you can now view clips with multiple audio channels, including grouped clips, or merged clips.

Resources:

Use timecode from master audio in merged clips

A new DSLR workflow allows you to use the timecode from an audio master clip to be used when you create a merged clip. You can also choose to omit the source camera audio when creating a merged clip.

Resources:

Effects enhancements and workflow improvements

Adjustment layers

Adjustment layers, used in products like Photoshop and After Effects, are now available in Premiere Pro CS6. Adjustment layers are useful for many things, including greater control in color correction.

To add an adjustment layer to your project, select the Project panel and then choose File > New Adjustment Layer.

Resources:

Warp Stabilizer effect

Formerly available only in After Effects CS5.5 (and later), Warp Stabilizer is a CUDA accelerated effect that allows you to smooth out shaky, handheld footage.

Locate the effect in the Effects panel, Effects > Distort > Warp Stabilizer.

Resources:

Rolling Shutter Repair effect

Use the Rolling Shutter Repair effect for fixing clips with rolling shutter artifacts.

Locate the effect in the Effects panel, then choose Effects > Distort > Rolling Shutter Repair.

Resources:

Redesigned 3-Way Color Corrector effect

The 3-Way Color Corrector effect is more intuitive. Tools are easier to find and use.

The 3-Way Color Corrector is located in the Effects panel. Choose Effects > Color Correction > 3-Way Color Corrector.

Resources:

Adobe SpeedGrade Color Correction

Export sequences to Adobe SpeedGrade to professionally color-grade your work.

To export your sequence to SpeedGrade, select it in the Project panel, and then choose File > Send to Adobe SpeedGrade. You can also export an EDL from Premiere Pro and import it into SpeedGrade and reconnect the clips.

Note: Adobe SpeedGrade is a separate application.

Resources:

Premiere Pro CS6 updates

Premiere Pro CS6 (6.0.3) update (Windows only)
The Premiere Pro CS6 (6.0.3) update is a Windows-only update that contains an important change to the code signing to address the following issues:

  • Security certificate updates
  • Certificate revocation FAQ
  • Adobe to revoke code signing certificate
  • Guidance for IT administrators | Adobe certificate revocation

This issue also affects Windows versions of Adobe Prelude and Adobe Media Encoder.
See this blog post for information about the The Premiere Pro CS6 (6.0.3) update.

Premiere Pro CS6 (6.0.2) update
The Premiere Pro CS6 (6.0.2) update includes the following changes and updates:

  • Numerous bug fixes.
  • Windows 8 certification.
  • Updates for HiDPI display, which improves appearance on computers that use Retina Display, such as MacBook Pro computers.
  • Added GPUs to the list of those that Premiere Pro CS6 will use for GPU processing: GT 650M (which is in the newer MacBook Pro computers) and GTX 680.

See this blog post for information and full details about the The Premiere Pro CS6 (6.0.2) update.

Premiere Pro CS6 (6.0.1) update
The Premiere Pro CS6 (6.0.1) update includes the following changes and updates:

  • Numerous bug fixes
  • Improved performance using OpenCL, especially when used on Mac OSX v10.7.4 or later.
  • Added encoding presets with additional bit-rate settings for XDCAM HD.
  • Added Automatic Peak File Generation preference in the Audio category for turning off automatic peak file generation for imported audio.
  • When this preference is disabled, importing audio or opening projects will not cause peak files to be generated.
  • Enabled “smart rendering” and added Enable Smart Rendering Codec setting to the Video tab of the MXF OP1a exporters for XDCAM HD and XDCAM EX to enable or disable smart rendering for these formats.
  • Added support for import of files and use of growing files from Sony XDCAM deck (XDSPE2000).

See this blog post for information and full details about the The Premiere Pro CS6 (6.0.1) update.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy