Руководство пользователя Отмена

Работа со смарт-объектами

  1. Руководство пользователя Photoshop
  2. Введение в Photoshop
    1. Мечтайте об этом. Сделайте это.
    2. Новые возможности Photoshop
    3. Редактирование первой фотографии
    4. Создание документов
    5. Photoshop | Часто задаваемые вопросы
    6. Системные требования Photoshop
    7. Перенос наборов настроек, операций и настроек
    8. Знакомство с Photoshop
  3. Photoshop и сервисы Adobe
    1. Photoshop и Adobe Stock
    2. Библиотеки Creative Cloud Libraries
    3. Библиотеки Creative Cloud в Photoshop
    4. Работа в Photoshop с использованием Touch Bar
    5. Работа с графическим объектом Illustrator в Photoshop
    6. Работа со встроенным расширением Capture в Photoshop
    7. Сетка и направляющие
    8. Создание операций
    9. Отмена и история операций
    10. Комбинации клавиш по умолчанию
    11. Возможности работы с сенсорными жестами и настраиваемые рабочие среды
  4. Photoshop на iPad
    1. Photoshop на iPad | Общие вопросы
    2. Знакомство с рабочей средой
    3. Системные требования | Photoshop на iPad
    4. Создание, открытие и экспорт документов
    5. Добавление фотографий
    6. Работа со слоями
    7. Рисование и раскрашивание кистями
    8. Выделение участков и добавление масок
    9. Ретуширование композиций
    10. Работа с корректирующими слоями
    11. Настройка тональности композиции с помощью слоя «Кривые»
    12. Применение операций трансформирования
    13. Обрезка и поворот композиций
    14. Поворот, панорамирование, масштабирование и восстановление холста
    15. Работа с текстовыми слоями
    16. Работа с Photoshop и Lightroom
    17. Получение отсутствующих шрифтов в Photoshop на iPad
    18. Японский текст в Photoshop на iPad
    19. Управление параметрами приложения
    20. Сенсорные ярлыки и жесты
    21. Комбинации клавиш
    22. Изменение размера изображения
    23. Прямая трансляция творческого процесса в Photoshop на iPad
    24. Исправление недостатков с помощью восстанавливающей кисти
    25. Создание кистей в Capture и их использование в Photoshop
    26. Работа с файлами Camera Raw
    27. Создание и использование смарт-объектов
    28. Коррекция экспозиции изображений с помощью инструментов «Осветлитель» и «Затемнитель»
  5. Бета-версия веб-приложения Photoshop
    1. Часто задаваемые вопросы | Бета-версия веб-приложения Photoshop 
    2. Общие сведения о рабочей среде
    3. Системные требования | Бета-версия веб-приложения Photoshop
    4. Комбинации клавиш | Бета-версия веб-приложения Photoshop
    5. Поддерживаемые форматы файлов | Бета-вервия веб-приложения Photoshop
    6. Открытие облачных документов и работа с ними
    7. Совместная работа с заинтересованными сторонами
    8. Ограниченные возможности редактирования облачных документов
  6. Облачные документы
    1. Облачные документы Photoshop | Часто задаваемые вопросы
    2. Облачные документы Photoshop | Вопросы о рабочем процессе
    3. Работа с облачными документами и управление ими в Photoshop
    4. Обновление облачного хранилища для Photoshop
    5. Не удается создать или сохранить облачный документ
    6. Устранение ошибок с облачными документами Photoshop
    7. Сбор журналов синхронизации облачных документов
    8. Общий доступ к облачным документам и их редактирование
    9. Общий доступ к файлам и комментирование в приложении
  7. Рабочая среда
    1. Основные сведения о рабочей среде
    2. Создание документов
    3. Работа в Photoshop с использованием Touch Bar
    4. Поддержка Microsoft Dial в Photoshop
    5. Галерея инструментов
    6. Установки производительности
    7. Использование инструментов
    8. Сенсорные жесты
    9. Возможности работы с сенсорными жестами и настраиваемые рабочие среды
    10. Обзорные версии технологии
    11. Метаданные и комментарии
    12. Быстрая публикация своих творений
    13. Помещение изображений Photoshop в другие приложения
    14. Установки
    15. Комбинации клавиш по умолчанию
    16. Линейки
    17. Отображение или скрытие непечатных вспомогательных элементов
    18. Указание колонок для изображения
    19. Отмена и история операций
    20. Панели и меню
    21. Помещение файлов
    22. Позиционирование элементов с привязкой
    23. Позиционирование с помощью инструмента «Линейка»
    24. Наборы настроек
    25. Настройка комбинаций клавиш
    26. Сетка и направляющие
  8. Разработка содержимого для Интернета, экрана и приложений
    1. Photoshop для дизайна
    2. Монтажные области
    3. Просмотр на устройстве
    4. Копирование CSS из слоев
    5. Разделение веб-страниц на фрагменты
    6. Параметры HTML для фрагментов
    7. Изменение компоновки фрагментов
    8. Работа с веб-графикой
    9. Создание веб-фотогалерей
  9. Основные сведения об изображениях и работе с цветом
    1. Изменение размера изображений
    2. Работа с растровыми и векторными изображениями
    3. Размер и разрешение изображения
    4. Импорт изображений из камер и сканеров
    5. Создание, открытие и импорт изображений
    6. Просмотр изображений
    7. Ошибка «Недопустимый маркер JPEG» | Открытие изображений
    8. Просмотр нескольких изображений
    9. Настройка палитр цветов и образцов цвета
    10. HDR-изображения
    11. Подбор цветов на изображении
    12. Преобразование между цветовыми режимами
    13. Цветовые режимы
    14. Стирание фрагментов изображения
    15. Режимы наложения
    16. Выбор цветов
    17. Внесение изменений в таблицы индексированных цветов
    18. Информация об изображениях
    19. Фильтры искажения недоступны
    20. Сведения о цвете
    21. Цветные и монохромные коррекции с помощью каналов
    22. Выбор цветов на панелях «Цвет» и «Образцы»
    23. Образец
    24. Цветовой режим (или режим изображения)
    25. Цветовой оттенок
    26. Добавление изменения цветового режима в операцию
    27. Добавление образцов из CSS- и SVG-файлов HTML
    28. Битовая глубина и установки
  10. Слои
    1. Основные сведения о слоях
    2. Обратимое редактирование
    3. Создание слоев и групп и управление ими
    4. Выделение, группировка и связывание слоев
    5. Помещение изображений в кадры
    6. Непрозрачность и наложение слоев
    7. Слои-маски
    8. Применение смарт-фильтров
    9. Композиции слоев
    10. Перемещение, упорядочение и блокировка слоев
    11. Маскирование слоев при помощи векторных масок
    12. Управление слоями и группами
    13. Эффекты и стили слоев
    14. Редактирование слоев-масок
    15. Извлечение ресурсов
    16. Отображение слоев с помощью обтравочных масок
    17. Формирование графических ресурсов из слоев
    18. Работа со смарт-объектами
    19. Режимы наложения
    20. Объединение нескольких фрагментов в одно изображение
    21. Объединение изображений с помощью функции «Автоналожение слоев»
    22. Выравнивание и распределение слоев
    23. Копирование CSS из слоев
    24. Загрузка выделенных областей на основе границ слоя или слоя-маски
    25. Просвечивание для отображения содержимого других слоев
    26. Слой
    27. Сведение
    28. Совмещенные изображения
    29. Фон
  11. Выделения
    1. Рабочая среда «Выделение и маска»
    2. Быстрое выделение областей
    3. Начало работы с выделениями
    4. Выделение при помощи группы инструментов «Область»
    5. Выделение при помощи инструментов группы «Лассо»
    6. Выбор цветового диапазона в изображении
    7. Настройка выделения пикселей
    8. Преобразование между контурами и границами выделенной области
    9. Основы работы с каналами
    10. Перемещение, копирование и удаление выделенных пикселей
    11. Создание временной быстрой маски
    12. Сохранение выделенных областей и масок альфа-каналов
    13. Выбор областей фокусировки в изображении
    14. Дублирование, разделение и объединение каналов
    15. Вычисление каналов
    16. Выделение
    17. Ограничительная рамка
  12. Коррекции изображений
    1. Деформация перспективы
    2. Уменьшение размытия в результате движения камеры
    3. Примеры использования инструмента «Восстанавливающая кисть»
    4. Экспорт таблиц поиска цвета
    5. Корректировка резкости и размытия изображения
    6. Общие сведения о цветокоррекции
    7. Применение настройки «Яркость/Контрастность»
    8. Коррекция деталей в тенях и на светлых участках
    9. Корректировка «Уровни»
    10. Коррекция тона и насыщенности
    11. Коррекция сочности
    12. Настройка насыщенности цвета в областях изображения
    13. Быстрая коррекция тона
    14. Применение специальных цветовых эффектов к изображениям
    15. Улучшение изображения при помощи корректировки цветового баланса
    16. HDR-изображения
    17. Просмотр гистограмм и значений пикселей
    18. Подбор цветов на изображении
    19. Кадрирование и выпрямление фотографий
    20. Преобразование цветного изображения в черно-белое
    21. Корректирующие слои и слои-заливки
    22. Корректировка «Кривые»
    23. Режимы наложения
    24. Целевая подготовка изображений для печатной машины
    25. Коррекция цвета и тона с помощью пипеток «Уровни» и «Кривые»
    26. Коррекция экспозиции и тонирования HDR
    27. Фильтр
    28. Размытие
    29. Осветление или затемнение областей изображения
    30. Избирательная корректировка цвета
    31. Замена цветов объекта
  13. Adobe Camera Raw
    1. Системные требования Camera Raw
    2. Новые возможности Camera Raw
    3. Введение в Camera Raw
    4. Создание панорам
    5. Поддерживаемые объективы
    6. Виньетирование, зернистость и удаление дымки в Camera Raw
    7. Комбинации клавиш по умолчанию
    8. Автоматическая коррекция перспективы в Camera Raw
    9. Обратимое редактирование в Camera Raw
    10. Инструмент «Радиальный фильтр» в Camera Raw
    11. Управление настройками Camera Raw
    12. Обработка, сохранение и открытие изображений в Camera Raw
    13. Совершенствование изображений с улучшенным инструментом «Удаление точек» в Camera Raw
    14. Поворот, обрезка и изменение изображений
    15. Корректировка цветопередачи в Camera Raw
    16. Краткий обзор функций | Adobe Camera Raw | Выпуски за 2018 г.
    17. Обзор новых возможностей
    18. Версии обработки в Camera Raw
    19. Внесение локальных корректировок в Camera Raw
  14. Исправление и восстановление изображений
    1. Удаление объектов с фотографий с помощью функции «Заливка с учетом содержимого»
    2. Заплатка и перемещение с учетом содержимого
    3. Ретуширование и исправление фотографий
    4. Коррекция искажений изображения и шума
    5. Основные этапы устранения неполадок для решения большинства проблем
  15. Преобразование изображений
    1. Трансформирование объектов
    2. Настройка кадрирования, поворотов и холста
    3. Кадрирование и выпрямление фотографий
    4. Создание и редактирование панорамных изображений
    5. Деформация изображений, фигур и контуров
    6. Перспектива
    7. Использование фильтра «Пластика»
    8. Масштаб с учетом содержимого
    9. Трансформирование изображений, фигур и контуров
    10. Деформация
    11. Трансформирование
    12. Панорама
  16. Рисование и живопись
    1. Рисование симметричных орнаментов
    2. Варианты рисования прямоугольника и изменения обводки
    3. Сведения о рисовании
    4. Рисование и редактирование фигур
    5. Инструменты рисования красками
    6. Создание и изменение кистей
    7. Режимы наложения
    8. Добавление цвета в контуры
    9. Редактирование контуров
    10. Рисование с помощью микс-кисти
    11. Наборы настроек кистей
    12. Градиенты
    13. Градиентная интерполяция
    14. Заливка и обводка выделенных областей, слоев и контуров
    15. Рисование с помощью группы инструментов «Перо»
    16. Создание узоров
    17. Создание узора с помощью фильтра «Конструктор узоров»
    18. Управление контурами
    19. Управление библиотеками узоров и наборами настроек
    20. Рисование при помощи графического планшета
    21. Создание текстурированных кистей
    22. Добавление динамических элементов к кистям
    23. Градиент
    24. Рисование стилизованных обводок с помощью архивной художественной кисти
    25. Рисование с помощью узора
    26. Синхронизация наборов настроек на нескольких устройствах
  17. Текст
    1. Работа со шрифтами OpenType SVG
    2. Форматирование символов
    3. Форматирование абзацев
    4. Создание эффектов текста
    5. Редактирование текста
    6. Интерлиньяж и межбуквенные интервалы
    7. Шрифт для арабского языка и иврита
    8. Шрифты
    9. Поиск и устранение неполадок, связанных со шрифтами
    10. Азиатский текст
    11. Создание текста
    12. Ошибка Text Engine при использовании инструмента «Текст» в Photoshop | Windows 8
    13. Универсальный компоновщик для азиатской письменности
    14. Добавление и редактирование текста в Photoshop
  18. Видео и анимация
    1. Видеомонтаж в Photoshop
    2. Редактирование слоев видео и анимации
    3. Общие сведения о видео и анимации
    4. Предварительный просмотр видео и анимации
    5. Рисование кадров в видеослоях
    6. Импорт видеофайлов и последовательностей изображений
    7. Создание анимации кадров
    8. 3D-анимация Creative Cloud (предварительная версия)
    9. Создание анимаций по временной шкале
    10. Создание изображений для видео
  19. Фильтры и эффекты
    1. Использование фильтра «Пластика»
    2. Использование эффектов группы «Галерея размытия»
    3. Основные сведения о фильтрах
    4. Справочник по эффектам фильтров
    5. Добавление эффектов освещения
    6. Использование фильтра «Адаптивный широкий угол»
    7. Фильтр «Масляная краска»
    8. Эффекты и стили слоев
    9. Применение определенных фильтров
    10. Растушевка областей изображения
  20. Сохранение и экспорт
    1. Сохранение файлов в Photoshop
    2. Экспорт файлов в Photoshop
    3. Поддерживаемые форматы файлов
    4. Сохранение файлов в других графических форматах
    5. Перемещение проектов между Photoshop и Illustrator
    6. Сохранение и экспорт видео и анимации
    7. Сохранение файлов PDF
    8. Защита авторских прав Digimarc
  21. Печать
    1. Печать 3D-объектов
    2. Печать через Photoshop
    3. Печать и управление цветом
    4. Контрольные листы и PDF-презентации
    5. Печать фотографий в новом макете раскладки изображений
    6. Печать плашечных цветов
    7. Дуплексы
    8. Печать изображений на печатной машине
    9. Улучшение цветной печати в Photoshop
    10. Устранение неполадок при печати | Photoshop
  22. Автоматизация
    1. Создание операций
    2. Создание изображений, управляемых данными
    3. Сценарии
    4. Обработка пакета файлов
    5. Воспроизведение операций и управление ими
    6. Добавление условных операций
    7. Сведения об операциях и панели «Операции»
    8. Запись инструментов в операциях
    9. Добавление изменения цветового режима в операцию
    10. Набор средств разработки пользовательского интерфейса Photoshop для внешних модулей и сценариев
  23. Управление цветом
    1. Основные сведения об управлении цветом
    2. Обеспечение точной цветопередачи
    3. Настройки цвета
    4. Работа с цветовыми профилями
    5. Управление цветом документов для просмотра в Интернете
    6. Управление цветом при печати документов
    7. Управление цветом импортированных изображений
    8. Выполнение цветопробы
  24. Подлинность контента
    1. Подробнее об учетных данных для содержимого
    2. Идентичность и происхождение токенов NFT
    3. Подключение учетных записей для творческой атрибуции
  25. 3D-объекты и технические изображения
    1. 3D в Photoshop | Распространенные вопросы об упраздненных 3D-функциях
    2. 3D-анимация Creative Cloud (предварительная версия)
    3. Печать 3D-объектов
    4. 3D-рисование
    5. Усовершенствование панели «3D» | Photoshop
    6. Основные понятия и инструменты для работы с 3D-графикой
    7. Рендеринг и сохранение 3D-объектов
    8. Создание 3D-объектов и анимаций
    9. Стеки изображений
    10. Процесс работы с 3D-графикой
    11. Измерения
    12. Файлы формата DICOM
    13. Photoshop и MATLAB
    14. Подсчет объектов на изображении
    15. Объединение и преобразование 3D-объектов
    16. Редактирование 3D-текстур
    17. Коррекция экспозиции и тонирования HDR
    18. Настройки панели «3D»

Понятие смарт-объектов

Смарт-объекты — это слои, содержащие данные изображения из растровых или векторных изображений, таких как файлы Photoshop или Illustrator. Смарт-объекты сохраняют первоначальное содержимое изображения со всеми исходными характеристиками, позволяя производить обратимое редактирование слоя.

В Photoshop можно встроить содержимое изображения в документ Photoshop. В Photoshop можно также создавать связанные смарт-объекты, содержимое которых формируется ссылками на внешние файлы изображений. Содержимое связанного смарт-объекта меняется при изменении исходного файла изображения.

Связанные смарт-объекты отличаются от дублированных экземпляров одного смарт-объекта в рамках одного документа Photoshop. При работе со связанными смарт-объектами можно использовать общий исходный файл в нескольких документах Photoshop — с этой концепцией веб-дизайнеры уже хорошо знакомы.

Преимущества смарт-объектов

С помощью смарт-объектов можно:

  • Выполнять обратимые трансформации. Можно масштабировать, поворачивать, наклонять, деформировать слой или применять к нему перспективное преобразование или заказную деформацию без потери исходных данных изображения или качества, потому что трансформации не затрагивают исходные данные.

  • Работать с векторными данными, такими как векторные иллюстрации из Illustrator, которые иначе были бы растрированы в Photoshop.

  • Выполнять обратимую фильтрацию. В любое время можно изменить параметры фильтров, примененных к смарт-объектам.

  • Редактирование смарт-объекта автоматически отражается на всех связанных с ним экземплярах.

  • Примените слой-маску, связанную или не связанную со слоем смарт-объекта.

  • Попробуйте различные оформления, используя подстановочные изображения низкого разрешения, которые позднее будут заменены на окончательные версии.

Нельзя выполнить операции, которые изменяют данные пикселов (такие как рисование, осветление, затемнение или клонирование), непосредственно в слое смарт-объекта до тех пор, пока он не будет преобразован в обычный слой и растрирован. Для проведения операций, которые изменяют данные пикселов, можно редактировать содержимое смарт-объекта, клонировать новый слой поверх слоя смарт-объекта, редактировать дубликаты смарт-объекта или создать новый слой.

Примечание.

При трансформации смарт-объекта, к которому применены смарт-фильтры, Photoshop отключит фильтры до тех пор, пока преобразование не будет закончено. Фильтры применятся вновь после окончания трансформации. См. раздел Применение смарт-фильтров.

Преимущества смарт-объектов Photoshop
Обычный слой и смарт-объект на панели «Слои». Значок в правом нижнем углу миниатюры указывает на смарт-объект.

Смарт-объект на панели «Слои» в Photoshop
Связанный смарт-объект на панели «Слои» (Photoshop)

Создание встроенных смарт-объектов

Встроенные смарт-объекты можно создавать различными способами: с помощью команды «Открыть как смарт-объект», поместив файл (Photoshop CS6) или поместив файл как встроенный (Photoshop, Photoshop CS6), вставляя данные из Illustrator или преобразуя один или несколько слоев Photoshop в смарт-объекты.

  1. Выполните одно из следующих действий.
    • (Photoshop) В меню «Файл» выберите команду «Поместить встроенные» для импорта файлов как смарт-объектов в открытый документ Photoshop.
    • В меню «Файл» выберите команду «Открыть как смарт-объект», выберите файл и нажмите кнопку «Открыть».
    • (Photoshop CS6) В меню «Файл» выберите команду «Поместить» для импорта файлов как смарт-объектов в открытый документ Photoshop.
    Примечание.

    Несмотря на то что можно размещать JPEG-файлы, лучше использовать файлы в формате PSD, TIFF или PSB, так как это позволит добавлять слои, изменять пикселы и повторно сохранять изображение без потери качества. (Сохранение измененного JPEG-файла требует выполнить сведение слоев и повторное сжатие изображения, приводя к потере качества.)

    • Чтобы преобразовать выделенный слой в смарт-объект, выберите «Слой» > «Смарт-объекты» > «Преобразовать в смарт-объект».
    • Чтобы импортировать файл как смарт-объект в документ Photoshop, в приложении Bridge в меню «Файл» выберите команду «Поместить» > «В Photoshop».
    • Выберите один или несколько слоев и в меню «Слой» выберите команду «Смарт-объекты» > «Преобразовать в смарт-объект». Слои объединяются в смарт-объект.

    • Перетащите слои или объекты PDF или Adobe Illustrator в документ Photoshop.

    • Вставьте иллюстрацию из Illustrator в документ Photoshop и в диалоговом окне «Вклеить» выберите «Смарт-объект». Для большей гибкости включите поддержку форматов — как PDF, так и AICB (без поддержки прозрачности) в разделе «Обработка файлов» диалога «Установки» программы Adobe Illustrator.

Создание связанных смарт-объектов | Photoshop

Примечание.

Функция «Связанные смарт-объекты» доступна в Photoshop версии 14.2 (январь 2014 г.) и более поздних.

В Photoshop можно создавать связанные смарт-объекты. Содержимое связанного смарт-объекта обновляется при изменении исходного файла изображения. Связанные смарт-объекты особенно удобны при работе в команде или в тех случаях, когда ресурсы необходимо повторно использовать в других проектах.

Выполните следующие действия для создания связанного смарт-объекта:

  1. Выберите пункт меню «Файл» > «Поместить связанные».
  2. Выберите подходящий файл и нажмите кнопку Поместить.

Связанный смарт-объект будет создан и отображен на панели Слои со значком ссылки ().

Примечание.

Можно также создать связанный смарт-объект в открытом документе: для этого перетащите соответствующий файл, удерживая следующую клавишу:

(Windows) клавишу Alt
(Mac OS) клавишу Opt

Чтобы изменить это поведение по умолчанию, выключите параметр Установки > Общие > Всегда создавать смарт-объекты при размещении.

Уменьшение размера файла с помощью связанных смарт-объектов

Так как связанные смарт-объекты используют внешние файлы, а не встроенные исходные файлы в содержащем документе, их применение позволяет значительно уменьшить размер файла. Хотя связанные смарт-объекты не сохраняют исходный файл в содержащем документе, они все равно включают растрированную масштабированную версию данных изображения из исходного файла. В некоторых случаях размер этих данных может быть намного больше размера исходного файла, и тогда об уменьшении размера речи не идет.

Обновление связанных смарт-объектов

Если внешний исходный файл меняется в тот момент, когда открыт документ Photoshop, ссылающийся на него, соответствующий связанный смарт-объект обновляется автоматически. Однако при открытии документа Photoshop, содержащего несинхронизованные связанные смарт-объекты, для их обновления требуются следующие действия:

  • Щелкните правой кнопкой мыши слой связанного смарт-объекта и выберите пункт Обновить измененное содержимое.
  • Выберите пункт меню Слой > Смарт-объекты > Обновить измененное содержимое.

Связанные смарт-объекты, исходные изображения которых были изменены, визуально выделяются на панели Слои:

Несинхронизованные связанные смарт-объекты Photoshop, выделенные на панели «Слои»
Так обозначаются несинхронизованные связанные смарт-объекты на панели «Слои».

Примечание.

Чтобы обновить все связанные смарт-объекты в текущем документе Photoshop, можно выбрать пункт меню Слой > Смарт-объекты > Обновить все измененное содержимое.

Выделенные на панели «Слои» связанные смарт-объекты Photoshop, у которых отсутствуют внешние исходные файлы
Так на панели «Слои» обозначаются связанные смарт-объекты, у которых отсутствуют внешние исходные файлы.

Примечание.

Когда Photoshop обнаруживает изменения в связанных смарт-объектах или обновляет связанный смарт-объект, обрабатывается только сам связанный файл. Ссылки, вложенные в смарт-объекты, не обновляются.

Чтобы обработать связанный смарт-объект с отсутствующим внешним исходным файлом, выполните следующие действия.

  1. Щелкните правой кнопкой мыши значок слоя связанного смарт-объекта и выберите Исправить неработающую ссылку.
  2. Перейдите к новой папке отсутствующего объекта.
  3. Нажмите кнопку Поместить.

Просмотр свойств связанных смарт-объектов

Выберите слой связанного смарт-объекта на панели Слои, затем выберите Окно > Свойства.

Отображаются следующие свойства:

  • Путь к внешнему исходному файлу для связанного смарт-объекта
  • Размер связанного смарт-объекта и координаты расположения (X, Y)

На панели «Свойства» можно выполнить следующие действия.

  • Редактирование содержимого внешнего файла изображения. При необходимости Photoshop открывает внешнее приложение для обработки исходного файла изображения. Например, Photoshop открывает Adobe Illustrator, если внешний исходный файл имеет расширение .ai.
  • Встраивание связанного смарт-объекта в текущий документ.

Встраивание связанных смарт-объектов

Выполните одно из следующих действий.

  • Щелкните правой кнопкой мыши слой связанного смарт-объекта на панели Слои и установите флажок Встроить связанные.
  • Выберите пункт меню Слой > Смарт-объекты > Встроить связанные.
  • На панели Свойства нажмите кнопку Встроить.
Примечание.

Выберите пункт меню Слой > Смарт-объекты > Встроить все связанные, чтобы встроить все связанные смарт-объекты в документ Photoshop.

Упаковка связанных смарт-объектов

Можно упаковать связанные смарт-объекты в документ Photoshop, чтобы сохранить их исходные файлы в папке на компьютере. Копия документа Photoshop сохраняется вместе с исходными файлами в папке.

  1. Выберите Файл > Упаковать.
  2. Выберите папку, в которую требуется поместить исходные файлы и копию документа Photoshop.

Вместе с ними упаковываются все связанные смарт-объекты (аудио или видео) в документе.

Примечание.

Необходимо сохранить файл перед упаковкой связанных смарт-объектов, которые в нем содержатся.

Нахождение связанных файлов в Photoshop

Photoshop всегда выполняет поиск связанных файлов в последнем известном относительном местоположении. Если связанный файл отсутствует в этом местоположении, Photoshop выполняет его поиск:

  • В последнем известном абсолютном местоположении
  • С использованием сохраненного псевдонима (только в ОС Mac OS)
  • В той же папке, что и содержащий документ

Такое поведение позволяет перемещать, копировать и открывать для общего доступа папки и файлы проекта с минимальным риском появления неработающих ссылок.

Примечание.

Диалоговое окно «Обработать отсутствующие ресурсы» всегда отображает последний известный абсолютный путь к отсутствующим исходным файлам.

Преобразование встроенного смарт-объекта в связанный смарт-объект

Можно преобразовать встроенный смарт-объект в связанный смарт-объект. Трансформации, фильтры и другие эффекты, примененные к встроенному смарт-объекту, сохраняются в процессе преобразования.

Выполните следующие действия.

  1. Выберите слой встроенного смарт-объекта в документе Photoshop.
  2. Выберите Слой > Смарт-объекты > Преобразовать в смарт-объект.
  3. Выберите папку на компьютере, в которую требуется сохранить исходный файл. Введите имя файла, включая поддерживаемое расширение. Например, link_file.jpg.

Фильтрация панели «Слои» по смарт-объектам | Photoshop

  1. На панели «Слои» выберите Смарт-объекты из всплывающего меню фильтрации.
Фильтрация слоев по смарт-объектам в Photoshop
Фильтрация слоев по смарт-объектам

  1. Щелкните один из следующих значков:
  •     Фильтрация по актуальным связанным смарт-объектам
  •     Фильтрация по несинхронизированным связанным смарт-объектам
  •     Фильтрация по отсутствующим связанным смарт-объектам
  •     Фильтрация по встроенным смарт-объектам
Примечание.

Можно использовать переключатель (), чтобы отключить фильтрацию слоев.

Создание дубликата встроенного смарт-объекта

  1. На панели «Слои» выберите слой смарт-объекта и выполните одно из следующих действий.
    • Для создания дубликата смарт-объекта, который связан с оригиналом, в меню «Слой» выберите команду «Новый» > «Скопировать на новый слой» или перетащите слой смарт-объекта на значок «Новый слой» в нижней части панели «Слои». Изменения, вносимые в оригинал, будут отражаться на копии и наоборот.

    • Чтобы создать дубликат смарт-объекта, не связанный с оригиналом, в меню «Слой» выберите команду «Новый» > «Новый смарт-объект через копирование». Изменения, вносимые в оригинал, не отразятся на копии.

    Новый смарт-объект появится на панели «Слои» с тем же именем, как у оригинала, и дополнением «копия».

Редактирование содержимого смарт-объекта

При редактировании смарт-объекта исходный файл открывается либо в Photoshop (если содержимое — растровые данные или файл Camera Raw), либо в приложении, которое по умолчанию обрабатывает данный формат (например, Adobe Illustrator или Adobe Acrobat). При сохранении изменений в исходном содержимом они отражаются на всех связанных экземплярах смарт-объекта в документе Photoshop.

  1. Выберите смарт-объект на панели «Слои» и выполните одно из следующих действий.
    • В меню «Слой» выберите команду «Смарт-объекты» > «Редактировать содержимое».
    • Дважды щелкните миниатюру смарт-объекта на панели «Слои».
    • На панели Свойства нажмите кнопку Редактировать содержимое.
  2. Нажмите «ОК», чтобы закрыть диалоговое окно.
  3. Внесите изменения в исходное содержимое файла, затем выберите «Файл» > «Сохранить».

    Photoshop обновит смарт-объект, чтобы отразить внесенные изменения. (Если изменения не видны, нужно активировать окно документа, содержащего смарт-объект.)

Замена содержимого смарт-объекта

Можно заменить данные изображения в одном смарт-объекте или в нескольких связанных экземплярах. Эта функция позволяет быстро обновлять визуальное оформление или заменять подстановочные изображения с низким разрешением на окончательные версии.

Примечание.

При замене смарт-объекта все операции масштабирования, деформации и эффекты, примененные к первому смарт-объекту, сохраняются.

  1. Выберите смарт-объект, затем в меню «Слой» выберите команду «Смарт-объекты» > «Заменить содержимое».
  2. Выберите файл, который необходимо использовать, и нажмите кнопку «Поместить».
  3. Нажмите кнопку ОК.

    Новое содержимое будет помещено в смарт-объект.

Преобразование встроенного или связанного смарт-объекта в слои

Реализовано в выпуске Photoshop 21.0 (ноябрь 2019 г.)

Можно преобразовать встроенный или связанный смарт-объект обратно в его компонентные слои непосредственно в документе Photoshop. Если в если в смарт-объекте много слоев, слои распаковываются в новую группу слоев панели слоев. Преобразования и интеллектуальные фильтры в смарт-объектах, содержащих более одного слоя, не сохраняются при распаковке. 

Преобразование смарт-объекта в компонентные слои
Преобразование смарт-объекта в компонентные слои

  1. Выберите слой смарт-объекта на панели Слои.

  2. Выполните одно из следующих действий.

    • Правой кнопкой мыши (Windows) или удерживая клавишу CONTROL (Mac) щелкните слой смарт-объекта и выберите Преобразовать в слои в контекстном меню. 
    • В строке меню выберите Слой > Смарт-объекты > Преобразовать в слои.
    • На панели Свойства щелкните Преобразовать в слои.
    • В меню параметров панели Слои выберите Преобразовать в слои
  3. Слои распаковываются в группу слоев на панели Слои.

Растрировать встроенный или связанный смарт-объект

Содержимое смарт-объекта можно растрировать в обычный слой, если вам больше не нужно редактировать данные смарт-объекта. После растрирования смарт-объекта трансформации, деформации и фильтры, примененные к нему, изменять нельзя.

Выберите смарт-объект, затем выберите Слой > Смарт-объекты > Растрировать.  

Примечание.

Если необходимо повторно создать смарт-объект, выберите заново его исходные слои и начните сначала. Новый смарт-объект не сохранит трансформации, примененные к исходному смарт-объекту.

Экспорт содержимого встроенного смарт-объекта

  1. Выберите смарт-объект на панели «Слои», затем в меню «Слой» выберите команду «Смарт-объекты» > «Экспортировать содержимое».

  2. Выберите расположение для содержимого смарт-объекта и нажмите кнопку «Сохранить».

    Photoshop экспортирует смарт-объект в исходном формате, в котором он был помещен (JPEG, AI, TIF, PDF или другие форматы). Если смарт-объект был создан из слоев, он экспортируется в формате PSB.

Сброс преобразований смарт-объектов

Если вы преобразовали смарт-объект, все внесенные изменения можно отменить, выполнив одно из следующих действий: 

  • Щелкните правой кнопкой мыши слой смарт-объекта и выберите Сбросить трансформирование
  • Выберите Слой > Смарт-объекты > Сбросить трансформирование
Логотип Adobe

Вход в учетную запись