关于反向运动

反向运动 (IK) 是一种使用骨骼对对象进行动画处理的方式,这些骨骼按父子关系链接成线性或枝状的骨架。当一个骨骼移动时,与其连接的骨骼也发生相应的移动。

使用反向运动可以方便地创建自然运动。若要使用反向运动进行动画处理,只需在时间轴上指定骨骼的开始和结束位置。Animate 会自动在起始帧和结束帧之间对骨架中骨骼的位置进行内插处理。

可通过以下方法使用 IK:

  • 使用形状作为多块骨骼的容器。例如,您可以向蛇的图画中添加骨骼,以使其逼真地爬行。您可以在“对象绘制”模式下绘制这些形状。

  • 将元件实例链接起来。例如,您可以将显示躯干、手臂、前臂和手的影片剪辑链接起来,以使其彼此协调而逼真地移动。每个实例都只有一个骨骼。

正在活动的骨骼工具动画
 

骨骼样式

Animate 可以使用 4 种方式在舞台上绘制骨骼:

  • 纯色。这是默认样式。
  • 线框。此方法在纯色样式遮住骨骼下的插图太多时很有用。
  • 线。对于较小的骨架很有用。
  • 无。隐藏骨骼,仅显示骨骼下面的插图。


若要设置骨骼样式,请在时间轴中选择 IK 范围,然后从“属性”面板的“选项”部分中的“样式”菜单中选择样式。

注意:如果将“骨骼样式”设置为“无”并保存文档,Animate 在下次打开该文档时会自动将骨骼样式更改为“线”。

姿势图层

当您向元件实例或形状中添加骨骼时,Animate 会在时间轴中为它们创建一个新图层。此新图层称为姿势图层。Animate 向时间轴中现有的图层之间添加姿势图层,以使舞台上的对象保持以前的堆叠顺序。

向元件添加骨骼

可以向影片剪辑、图形和按钮实例添加 IK 骨骼。若要使用文本,请首先将其转换为元件。添加骨骼之前,元件实例可能位于不同的图层上。Animate 会将它们添加到姿势图层上。

注意:您还可以将文本拆分(“修改”>“分离”)为单独的形状,并对各形状使用骨骼。

在链接对象时,请考虑想要创建的父子关系,例如,从肩膀到肘部再到腕部。

  1. 在舞台上创建元件实例。要在以后节省时间,请对实例进行排列,以使其接近您想要的立体构型。

  2. 从“工具”面板中选择骨骼工具。

    工具栏中的骨骼工具
    工具栏中的骨骼工具

  3. 单击您想要设置为骨架根骨的元件实例。单击您想要将骨骼附加到元件的点。

     

    默认情况下,Animate 会在鼠标单击的位置创建骨骼。若要使用更精确的方法添加骨骼,请对 IK 骨骼工具关闭“自动设置变形点”(“编辑”>“首选参数”>“绘制”)。在“自动设置变形点”处于关闭状态时,当从一个元件到下一元件依次单击时,骨骼将对齐到元件变形点。

  4. 将鼠标拖动至另一个元件实例,然后在您想要附加该实例的点处松开鼠标按键。

  5. 要向该骨架添加其他骨骼,请从第一个骨骼的尾部拖动鼠标至下一个元件实例。

     

    如果您关闭“贴紧至对象”(“视图”>“贴紧”>“贴紧至对象”),则可以更加轻松地准确放置尾部。

  6. 要创建分支骨架,请单击您希望分支由此开始的现有骨骼的头部。然后,拖动鼠标以创建新分支的第一个骨骼。

     

    骨架可以具有所需数量的分支。

    注意:分支不能连接到其他分支(其根部除外)。

  7. 要调整已完成骨架的元素的位置,请拖动骨骼或实例自身。

    • 拖动骨骼会移动其关联的实例,但不允许该实例相对于其骨骼旋转。
    • 拖动实例允许它移动以及相对于其骨骼旋转。
    • 拖动分支中间的实例可导致父级骨骼通过连接旋转而相连。子级骨骼在移动时没有连接旋转。

    在创建骨架之后,您仍然可以向该骨架添加来自不同图层的新实例。在将新骨骼拖动到新实例后,Animate 会将该实例移动到骨架的姿势图层。

向形状添加骨骼

可以将骨骼添加到同一图层的单个形状或一组形状。无论哪种情况,您都必须首先选择所有形状,然后才能添加第一个骨骼。添加骨骼之后,Animate 会将所有形状和骨骼转换为一个 IK 形状对象,并将该对象移至一个新的姿势图层。

在将骨骼添加到一个形状后,该形状将具有以下限制:

  • 不能将一个 IK 形状与其外部的其他形状进行合并。
  • 不能使用任意变形工具旋转、缩放或倾斜该形状。
  • 不建议编辑形状的控制点。
  1. 在舞台上创建填充的形状。

    形状可以包含多个颜色和笔触。编辑形状,以便它们尽可能接近其最终形式。向形状添加骨骼后,用于编辑形状的选项变得更加有限。

    如果形状太复杂,Animate 在添加骨骼之前会提示您将其转换为影片剪辑。

  2. 在舞台上选择整个形状。

    如果该形状包含多个颜色区域或笔触,请围绕该形状拖动选择矩形,以确保选择整个形状。

  3. 在“工具”面板中选择骨骼工具。

  4. 使用骨骼工具,在该形状内单击并拖动到该形状内的另一个位置。

  5. 若要添加其他骨骼,请从第一个骨骼的尾部拖动到形状内的其他位置。

    第二个骨骼将成为根骨骼的子级。按照要创建的父子关系的顺序,将形状的各区域与骨骼链接在一起。例如,从肩膀到肘部再到腕部进行链接。

  6. 要创建分支骨架,请单击您希望分支由此开始的现有骨骼的头部。然后,拖动鼠标以创建新分支的第一个骨骼。

    骨架可以具有所需数量的分支。

    注意:分支不能连接到其他分支(其根部除外)。

  7. 若要移动骨架,请使用选取工具选择 IK 形状对象,然后拖动任何骨骼以移动它们。

在形状成为 IK 形状时,它具有以下限制:

  • 不能再对该形状变形(缩放或倾斜)。
  • 不能向该形状添加新笔触。仍可以向形状的现有笔触添加控制点或从中删除控制点。
  • 不能就地(通过在舞台上双击它)编辑该形状。
  • 形状具有自己的注册点、变形点和边框。

舞台用控件

使用舞台用控件,您可以借助显示有旋转范围和精确控制的参考线的帮助,在舞台上方便地进行旋转和平移调整。使用舞台用控件,您还可以继续在舞台上工作,而无需返回属性检查器去调整旋转。

舞台用控件使用指南
舞台用控件使用指南

在图像工作中使用骨骼工具舞台用控件的方法如下所示:
  1. 要开始使用舞台用控件,请选择骨骼并使用骨骼头部。 
  2. 要查看舞台用控件,请翻转骨骼的头部。头部会出现一个圆圈,里面是一个四向箭头(即一个加号,表示 X 和 Y 轴)。箭头表示平移属性,圆圈表示旋转属性。
  3. 单击骨骼头部,选择圆圈可编辑旋转属性,单击加号可编辑平移属性。 
  4. 要想随时看到旋转和平移用的交互手柄,可翻转骨骼的头部。 
  5. 单击旋转或平移选项时,用于设置约束的舞台用控件便会显示。 

使用旋转控件

旋转控件指南
旋转控件指南

要使用旋转控件,方法如下:

  1. 单击骨骼头部可看到旋转和平移工具。
  2. 翻转并单击表示旋转工具的圆圈。圆圈会变为红色。
  3. 单击锁定图标可启用自由旋转。锁定图标会变为一个圆点。
  4. 将光标从中心移开,将显示旋转半径的一端。单击旋转的起始点。
  5. 在圆圈内再次移动光标,可选择旋转半径的另一端。单击希望该点所落的位置。
  6. 单击圆圈,以确认半径定义。

注意:编辑已经定义好的旋转时,可通过单击边线并拖动的方式扩大或缩小边框。

使用平移控件

平移控件指南
平移控件指南

可以按如下方式使用平移控件:

  1. 翻转带有四向箭头的加号并单击它,以选择平移控件。
  2. 单击锁定图标可启用平移控件。锁定图标会变为一个圆点。
  3. 单击箭头并将其拖动到想要将移动范围扩展到的位置。

编辑 IK 骨架和对象

如果姿势图层包括时间轴的第一个帧之后的姿势,则无法编辑 IK 骨架。在编辑之前,请从时间轴中删除位于骨架的第一个帧之后的任何附加姿势。

如果只是调整骨架的位置以达到动画处理目的,则可以在姿势图层的任何帧中进行位置更改。Animate 会将该帧转换为姿势帧。

选择骨骼和关联的对象

  • 若要选择单个骨骼,请使用选取工具单击该骨骼。按住 Shift 并单击可选择多块骨骼。
  • 若要将所选内容移动到相邻骨骼,请在属性检查器中单击“父级”、“子级”或“下一个/上一个同级”按钮。
  • 要选择骨架中的所有骨骼,请双击某个骨骼。
  • 若要选择整个骨架并显示骨架的属性及其姿势图层,请单击姿势图层中包含骨架的帧。
  • 若要选择 IK 形状,请单击该形状。
  • 要选择连接到某个骨骼的元件实例,请单击该实例。

重新定位骨骼和关联的对象

  • 若要重新定位线性骨架,请拖动骨架中的任何骨骼。如果骨架包含已连接的元件实例,则还可以拖动实例。这样,您可以相对于实例的骨骼旋转该实例。
  • 要调整骨架的某个分支的位置,请拖动该分支中的任意骨骼。
  • 该分支中的所有骨骼都将移动。骨架的其他分支中的骨骼不会移动。
  • 若要将某个骨骼与其子级骨骼一起旋转而不移动父级骨骼,请在按住 Shift 的同时拖动该骨骼。
  • 若要将某个 IK 形状移动到舞台上的新位置,请在属性检查器中选择该形状并更改其 X 和 Y 属性。还可以按住 Alt (Windows) 或 Option (Macintosh) 拖动该形状。

删除骨骼

请执行下列操作之一:

  • 若要删除单个骨骼及其所有子级,请单击该骨骼并按 Delete 键。
  • 通过按住 Shift 单击每个骨骼可以选择要删除的多个骨骼。
  • 若要从时间轴的某个 IK 形状或元件骨架中删除所有骨骼,请在时间轴中右键单击 IK 骨架范围,并从上下文菜单中选择“删除骨架”。
  • 若要从舞台上的某个 IK 形状或元件骨架中删除所有骨骼,请双击骨架中的某个骨骼以选择所有骨骼。然后按 Delete 键。IK 形状将恢复为正常形状。

相对于关联的形状或元件移动骨骼

  • 若要移动 IK 形状内骨骼任一端的位置,请使用部分选取工具拖动骨骼的一端。

注意如果 IK 范围中有多个姿势,则无法使用部分选取工具。在编辑之前,请从时间轴中删除位于骨架的第一个帧之后的任何附加姿势。

  • 要移动元件实例内的骨骼关节、头部或尾部的位置,请移动实例的变形点。使用任意变形工具。骨骼将随变形点移动。
  • 若要移动单个元件实例而不移动任何其他链接的实例,请在按住 Alt (Windows) 或 Command (Macintosh) 的同时拖动该实例,或者使用任意变形工具拖动它。连接到实例的骨骼将变长或变短,以适应实例的新位置。

编辑 IK 形状

使用部分选取工具,可以在 IK 形状中添加、删除和编辑轮廓的控制点。

  • 若要移动骨骼的位置而不更改 IK 形状,请拖动骨骼的端点。
  • 若要显示 IK 形状边界的控制点,请单击形状的笔触。
  • 若要移动控制点,请拖动该控制点。
  • 若要添加新的控制点,请单击笔触上没有任何控制点的部分。
  • 若要删除现有的控制点,请通过单击来选择它,然后按 Delete 键。

注意:不能对 IK 形状变形(缩放或倾斜)。

将骨骼绑定到形状点

默认情况下,形状的控制点连接到距离它们最近的骨骼。您可以使用绑定工具编辑单个骨骼和形状控制点之间的连接。这样,您可以对笔触在各骨骼移动时如何扭曲进行控制,以获得更好的结果。当骨架移动时,如果形状的笔触没有按照您希望的那样扭曲,此时该技术很有用。

您可以将多个控制点绑定到一个骨骼,也可以将多个骨骼绑定到一个控制点。

  • 若要加亮显示已连接到骨骼的控制点,请使用绑定工具单击该骨骼。

    已连接的点以黄色加亮显示,而选定的骨骼以红色加亮显示。仅连接到一个骨骼的控制点显示为方形。连接到多个骨骼的控制点显示为三角形。

  • 要向所选骨骼添加控制点,请在按住 Shift 的同时单击某个未加亮显示的控制点。

    也可以通过在按住 Shift 的同时拖动选择要添加到选定骨骼的多个控制点。

  • 若要从骨骼中删除控制点,请在按住 Ctrl (Windows) 或 Option (Macintosh) 的同时单击以黄色加亮显示的控制点。

    也可以通过在按住 Ctrl (Windows) 或 Option (Macintosh) 的同时拖动删除选定骨骼中的多个控制点。

  • 若要加亮显示已连接到控制点的骨骼,请使用绑定工具单击该控制点。

    已连接的骨骼以黄色加亮显示,而选定的控制点以红色加亮显示。

  • 若要向选定的控制点添加其他骨骼,请在按住 Shift 的同时单击骨骼。

  • 若要从选定的控制点中删除骨骼,请在按住 Ctrl (Windows) 或 Option (Macintosh) 的同时单击以黄色加亮显示的骨骼。

约束 IK 骨骼的运动

若要创建 IK 骨架的更多逼真运动,可以控制特定骨骼的运动自由度。例如,您可以约束手臂的两个骨骼,以使肘部不会向错误的方向弯曲。

默认情况下,创建骨骼时会为每个 IK 骨骼指定固定的长度。骨骼可以围绕其父关节旋转,也可以沿 X 轴和 Y 轴旋转。但是,除非您启用了 X 轴或 Y 轴运动,否则它们不能以需要它们的父级骨骼更改长度的方式移动。默认情况下会启用骨骼旋转,而禁用 X 和 Y 轴运动。

您也可以限制骨骼的运动速度,在骨骼中创建重量效果。

在包含多串相互连接的骨骼的骨架中,您不能约束该骨架的任何分支中最后一个关节的运动。要产生最后一个关节受约束的外观,请将骨骼与影片剪辑结合使用,将最后一个骨骼连接至一个将其 alpha 属性设置为零的影片剪辑。然后,约束倒数第二个骨骼而不是最后一个骨骼。

示例:

  • 对于胳膊,可以约束肘部的旋转角度,使其不能旋转到前臂的正常运动范围之外。

  • 若要让人物沿舞台移动,请打开根骨骼上的 X 或 Y 平移。使用 X 和 Y 平移时关闭旋转可以获得更准确的移动。

在选定一个或多个骨骼后,可以在属性检查器中设置这些属性。

  • 要使选定的骨骼可以沿 X 轴或 Y 轴移动并更改其父级骨骼的长度,请在属性检查器的“联接X 平移”或“联接: Y 平移”部分中选择“启用”。

    将显示一个垂直于关节上骨骼的双向箭头,指示已启用 X 轴运动。将显示一个平行于关节上骨骼的双向箭头,指示已启用 Y 轴运动。当禁用骨骼的旋转时,为骨骼同时启用 X 和 Y 平移可简化对骨骼进行定位的任务。

  • 要限制沿 X 轴或 Y 轴启用的运动量,请在属性检查器的“联接X 平移”或“联接Y 平移”部分中选择“约束”,然后输入骨骼可以移动的最小距离和最大距离。

  • 若要禁用选定骨骼绕连接的旋转,请在属性检查器的“连接旋转”部分中取消选中“启用”复选框。

    默认情况下会选中此复选框。

  • 若要约束骨骼的旋转,请在属性检查器的“连接旋转”部分中输入旋转的最小度数和最大度数。

    旋转度数相对于父级骨骼。在骨骼连接的顶部将显示一个指示旋转自由度的弧形。

  • 要使选定的骨骼相对于其父级骨骼固定,请禁用旋转以及 X 轴和 Y 轴平移。

    骨骼将变得不能弯曲,并跟随其父级的运动。

  • 若要限制选定骨骼的运动速度,请在属性检查器的“连接速度”字段中输入一个值。

    连接速度为骨骼提供了粗细效果。最大值 100% 表示对速度没有限制。

向骨骼中添加弹簧属性

两个骨骼属性可用于将弹簧属性添加到 IK 骨骼中。骨骼的“强度”和“阻尼”属性通过将动态物理集成到骨骼 IK 系统中,使 IK 骨骼体现真实的物理移动效果。借助这些属性,可以更轻松地创建更逼真的动画。“强度”和“阻尼”属性可使骨骼动画效果逼真,并且动画效果具有高可配置性。最好在向姿势图层添加姿势之前设置这些属性。

强度:弹簧强度。值越高,创建的弹簧效果越强。

阻尼:弹簧效果的衰减速率。值越高,弹簧属性减小得越快。如果值为 0,则弹簧属性在姿势图层的所有帧中保持其最大强度。

要启用弹簧属性,请选择一个或多个骨骼,并在属性检查器的“弹簧”部分设置“强度”值和“阻尼”值。强度越高,弹簧就变得越坚硬。阻尼决定弹簧效果的衰减速率,因此阻尼值越高,动画结束得越快。

要禁用“强度”和“阻止”属性,请在时间轴中选择姿势图层并在属性检查器的“弹簧”部分中取消选中“启用”复选框。这样您就可以在舞台上查看在姿势图层中定义的姿势(不具有弹簧属性效果)。

当使用弹簧属性时,下列因素将影响骨骼动画的最终效果。尝试调整其中每个因素以达到您所需的最终效果。

  • “强度”属性值。

  • “阻尼”属性值。

  • 姿势图层中姿势之间的帧数。

  • 姿势图层中的总帧数。

  • 姿势图层中最后姿势与最后一帧之间的帧数。

对骨架进行动画处理

对 IK 骨架进行动画处理的方式与 Animate 中的其他对象不同。对于骨架,只需向姿势图层添加帧并在舞台上重新定位骨架即可创建关键帧。姿势图层中的关键帧称为姿势。由于 IK 骨架通常用于动画目的,因此每个姿势图层都自动充当补间图层。

但是,IK 姿势图层不同于补间图层,因为无法在姿势图层中对除骨骼位置以外的属性进行补间。若要对 IK 对象的其他属性(如位置、变形、色彩效果或滤镜)进行补间,请将骨架及其关联的对象包含在影片剪辑或图形元件中。然后可以使用“插入”>“补间动画”命令和“动画编辑器”面板,对元件的属性进行动画处理。

也可以在运行时使用 ActionScript 3.0 对 IK 骨架进行动画处理。如果计划使用 ActionScript 对骨架进行动画处理,则无法在时间轴中对其进行动画处理。骨架只能在姿势图层中具有一个姿势,且该姿势必须位于姿势图层中显示该骨架的第一个帧中。

在动画期间隐藏编辑控件

让所有舞台用控件始终为启用状态,可能会不小心改变骨架的位置和属性。为动画创建骨骼和骨架之后,可以通过选中属性检查器中的“隐藏骨架编辑控件和提示”复选框,关闭骨架编辑控件和提示。

在时间轴中对骨架进行动画处理

IK 骨架存在于时间轴中的姿势图层上。若要在时间轴中对骨架进行动画处理,请通过右键单击姿势图层中的帧再选择“插入姿势”来插入姿势。使用选取工具更改骨架的配置。Animate 将在姿势之间的帧中自动内插骨骼的位置。

  1. 在时间轴中,根据需要向骨架的姿势图层添加帧,以便为要创建的动画留出空间。

    通过右键单击 (Windows) 或按住 Option 单击 (Macintosh) 姿势图层中任何现有帧右侧的帧,然后选择“插入帧”,可以添加帧。稍后可以随时添加或删除帧。

  2. 若要向姿势图层中的帧添加姿势,请执行下列操作之一:
    • 将播放头放在要添加姿势的帧上,然后在舞台上重新定位骨架。

    • 右键单击 (Windows) 或按住 Option 单击 (Macintosh) 姿势图层中的帧,然后选择“插入姿势”。

    • 将播放头放在要添加姿势的帧上,然后按 F6 键。

    Animate 将向当前帧中的姿势图层插入姿势。帧中的菱形姿势标记指示新姿势。

  3. 在单独的帧中添加其他姿势,以完成您满意的动画。
  4. 若要在时间轴中更改动画长度,请将鼠标光标悬停在骨架的最后一个帧上,直到显示调整大小光标。然后将姿势图层的最后一个帧拖到右侧或左侧以添加或删除帧。

    Animate 将依照图层持续时间更改的比例调整姿势帧的位置,并在中间重新内插这些帧。若要在时间轴中调整骨架范围的大小而不影响姿势帧的位置,请在按住 Shift 的同时拖动骨架范围的最后一帧。

完成后,在时间轴中拖拽播放头以预览动画。您可以看到骨架位置在姿势帧之间进行了内插。

您可以随时在姿势帧中调整骨架的位置或添加新的姿势帧。

编辑骨架中姿势的位置

可以通过以下方式编辑姿势的位置:

  • 若要将某个姿势移至新位置,请在按住 Ctrl (Windows) 或 Command (Macintosh) 的同时单击一个姿势,然后将该姿势拖到骨架中的新位置。

  • 若要将某个姿势复制到新位置,请在按住 Ctrl (Windows) 或 Command (Macintosh) 的同时单击一个姿势,然后在按住 Alt (Windows) 或 Option (Macintosh) 的同时将该姿势拖到骨架中的新位置。

  • 剪切、复制和粘贴。按住 Ctrl (Windows) 或 Command (Macintosh) 单击要剪切或复制的姿势,并从上下文菜单中选择“剪切姿势”或“复制姿势”。

    然后按住 Ctrl (Windows) 或 Command (Macintosh) 单击骨架范围中要将姿势粘贴到的帧,并从上下文菜单中选择“粘贴姿势”。

向 IK 对象属性应用附加补间效果

要向除骨骼位置之外的 IK 对象属性应用补间效果,请将该对象包含在影片剪辑或图形元件中。

  1. 选择 IK 骨架及其所有的关联对象。

    对于 IK 形状,只需单击该形状即可。对于链接的元件实例集,可以在时间轴中单击姿势图层,或者围绕舞台上所有的链接元件拖动一个选取框。

  2. 右键单击 (Windows) 或按住 Ctrl 并单击 (Macintosh) 所选内容,然后从上下文菜单中选择“转换为元件”。
  3. 在“转换为元件”对话框中,输入元件的名称,然后从“类型”菜单中选择“影片剪辑”或“图形”。单击“确定”。

    Animate 将创建一个元件,该元件自己的时间轴包含骨架的姿势图层。

  4. 若要在 FLA 文件的主时间轴上使用新元件,请将该元件从库拖动到舞台。

    现在,可以向舞台上的新元件实例添加补间动画效果。

可以将包含 IK 骨架的元件嵌入在所需数量的其他嵌入元件图层中,以创建所需的效果。

使用 ActionScript 3.0 为运行时动画准备骨架

您可以使用 ActionScript 3.0 来控制连接至形状或影片剪辑实例的 IK 骨架。然而,您无法使用 ActionScript 来控制连接至图形或按钮元件实例的骨架。

使用 ActionScript 只能控制具有单个姿势的骨架。具有多个姿势的骨架只能在时间轴中控制。

  1. 使用选取工具,选择姿势图层中包含骨架的帧。
  2. 在属性检查器中,从“类型”菜单中选择“运行时”。

现在,可以在运行时使用 ActionScript 3.0 处理层次结构。

默认情况下,属性检查器中的骨架名称与姿势图层名称相同。在 ActionScript 中使用此名称以指代骨架。可以在属性检查器中更改该名称。

向 IK 动画添加缓动

缓动就是调整各个姿势前后的帧中的动画速度,以产生更加逼真的运动效果。

  1. 选择姿势图层中两个姿势帧之间的帧,或选择一个姿势帧。
    • 中间帧缓动会影响选定帧左侧和右侧的姿势帧之间的帧。
    • 姿势帧:缓动会影响选定姿势和图层中下一个姿势之间的帧。
  2. 在属性检查器中,从“缓动”菜单中选择缓动类型。 
    • 简单缓动:四种缓动,用于减慢选定帧之前或之后与其紧邻的帧中的运动速度。
    • 起始和终止缓动:减慢紧接前一个姿势帧的帧及位于下一个姿势帧之前且与其相邻的帧中的运动速度。
  3. 注意:在使用补间动画时,可以在动画编辑器中使用同样的这些缓动类型。在时间轴中选择补间动画时,可以在动画编辑器中查看每种缓动的曲线。

  4. 在属性检查器中,为缓动强度输入一个值。

    默认强度是 0,即表示无缓动。最大值是 100,它表示对姿势帧之前的帧应用最明显的缓动效果。最小值是 -100,它表示对上一个姿势帧之后的帧应用最明显的缓动效果。完成后,在舞台上预览已缓动的运动。在时间轴中两个已应用缓动的姿势帧之间拖拽播放头。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略