如何在 Animate 中使用帧和关键帧

  1. Adobe Animate 用户指南
  2. Animate 简介
    1. Animate 新增功能
    2. 图示术语表
    3. Animate 系统要求
    4. Animate 键盘快捷键
    5. 在 Animate 中使用多种文件类型
  3. 动画
    1. Animate 动画基础知识
    2. 如何在 Animate 中使用帧和关键帧
    3. 在 Animate 中使用逐帧动画
    4. 如何在 Animate 中使用传统补间动画
    5. 画笔工具
    6. 运动辅助线
    7. 补间动画和 ActionScript 3.0
    8. 关于补间动画
    9. 补间动画
    10. 创建补间动画
    11. 使用属性关键帧
    12. 用补间对位置进行动画处理
    13. 如何使用动画编辑器编辑补间动画
    14. 编辑补间动画的运动路径
    15. 处理补间动画
    16. 添加自定义缓动
    17. 创建和应用动画预设
    18. 设置动画的补间范围
    19. 处理另存为 XML 文件的补间动画
    20. 补间动画与传统补间
    21. 形状补间
    22. 在 Animate 中使用骨骼工具动画
    23. 在 Animate 中处理角色 Rig
    24. 如何在 Adobe Animate 中使用遮罩层
    25. 如何在 Animate 中使用场景
  4. 交互性
    1. 如何使用 Animate 创建按钮
    2. 将 Animate 项目转换为其它文档类型格式
    3. 在 Animate 中创建和发布 HTML5 Canvas 文档
    4. 在 Animate 中通过代码片段添加交互性
    5. 创建自定义 HTML5 组件
    6. 使用 HTML5 Canvas 中的组件
    7. 创建自定义组件:示例
    8. 自定义组件的代码片段
    9. 最佳做法 - 使用 Animate 制作广告
    10. 虚拟现实创作和发布
  5. 工作区和工作流
    1. 创建和管理画笔
    2. 在 HTML5 Canvas 文档中使用 Google 字体
    3. 使用 Creative Cloud Libraries 和 Adobe Animate
    4. 使用 Animate 的舞台和工具面板
    5. Animate 工作流程和工作区
    6. 在 HTML5 Canvas 文档中使用 Web 字体
    7. 时间轴和 ActionScript
    8. 使用多个时间轴
    9. 设置首选参数
    10. 使用 Animate 创作面板
    11. 使用 Animate 创建时间轴图层
    12. 导出移动应用程序和游戏引擎的动画
    13. 移动和复制对象
    14. 模板
    15. 在 Animate 中查找和替换
    16. 撤消、重做和历史记录面板
    17. 键盘快捷键
    18. 如何在 Animate 中使用时间轴
    19. 创建 HTML 扩展
    20. 图像和动画 GIF 的优化选项
    21. 图像和 GIF 的导出设置
    22. Animate 中的资源面板
  6. 多媒体与视频
    1. 在 Animate 中变形和合并图形对象
    2. 在 Animate 中创建并使用元件实例
    3. 图像描摹
    4. 如何在 Adobe Animate 中使用声音
    5. 导出 SVG 文件
    6. 创建用于 Animate 中的视频文件
    7. 如何在 Animate 中添加视频
    8. 使用视频提示点
    9. 使用 Animate 绘制和创建对象
    10. 改变线条和形状
    11. Animate CC 中的笔触、填充和渐变
    12. 使用 Adobe Premiere Pro 和 After Effects
    13. Animate CC 中的颜色面板
    14. 使用 Animate 打开 Flash CS6 文件
    15. 在 Animate 中使用传统文本
    16. 向 Animate 中置入图稿
    17. 在 Animate 中导入的位图
    18. 3D 图形
    19. 在 Animate 中使用元件
    20. 使用 Adobe Animate 绘制线条和形状
    21. 在 Animate 中使用库
    22. 导出声音
    23. 在 Animate CC 中选择对象
    24. 在 Animate 中使用 Illustrator AI 文件
    25. 使用喷涂刷工具应用图案
    26. 应用混合模式
    27. 排列对象
    28. 使用“命令”菜单自动处理任务
    29. 多语言文本
    30. 在 Animate 中使用摄像头
    31. 将 Animate 与 Adobe Scout 一起使用
    32. 使用 Fireworks 文件
    33. 图形滤镜
    34. 声音和 ActionScript
    35. 绘制首选参数
    36. 用钢笔工具绘图
  7. 平台
    1. 将 Animate 项目转换为其它文档类型格式
    2. 自定义平台支持
    3. 在 Animate 中创建和发布 HTML5 Canvas 文档
    4. 创建和发布 WebGL 文档
    5. 如何打包 AIR for iOS 应用程序
    6. 发布 AIR for Android 应用程序
    7. 发布用于桌面的 Adobe AIR
    8. ActionScript 发布设置
    9. 最佳做法 - 管理应用程序中的 ActionScript
    10. 如何在 Animate 中使用 ActionScript
    11. 最佳做法 - 辅助功能指南
    12. Animate 工作区中的辅助功能
    13. 编写和管理脚本
    14. 启用自定义平台支持
    15. 自定义平台支持概述
    16. 创建辅助内容
    17. 使用自定义平台支持插件
    18. 调试 ActionScript 3.0
    19. 启用自定义平台支持
  8. 导出和发布
    1. 如何从 Animate CC 导出文件
    2. OAM 发布
    3. 导出 SVG 文件
    4. 使用 Animate 导出图形和视频
    5. 发布 AS3 文档
    6. 导出移动应用程序和游戏引擎的动画
    7. 导出声音
    8. 导出 QuickTime 视频文件
    9. 使用 ActionScript 控制外部视频播放
    10. 最佳做法 - 移动设备内容创建技巧
    11. 最佳做法 - 视频惯例
    12. 最佳做法 - SWF 应用程序创作指南
    13. 最佳做法 - 构造 FLA 文件
    14. 在 Animate 中优化 FLA 文件的最佳做法
    15. ActionScript 发布设置
    16. 指定 Animate 的发布设置
    17. 导出放映文件
    18. 导出图像和动画 GIF
    19. HTML 发布模板
    20. 使用 Adobe Premiere Pro 和 After Effects
    21. 快速分享和发布动画

概述

Adobe Animate 文档将时长划分为类似于胶片的帧。帧是动画的核心,指定每一段的时间和运动。影片中帧的总数和播放速度共同决定了影片的总长度。以下提供了帧中一些概念的简短描述,供您参考。

在时间轴中,可使用这些帧来组织和控制文档的内容。您在时间轴中放置帧的顺序将决定帧内对象在最终内容中的显示顺序。

关键帧

关键帧是指新元件实例显示在时间轴上的帧。关键帧也可以指,包含用于控制文档某些方面的 Actionscript 代码的帧。您还可以将空白关键帧添加到时间轴中作为计划稍后添加的元件的占位符,或者直接将该帧保留为空。

使用关键帧,您可以设置位置,添加锚点、动作、评论等。 

范围

使用基于范围的帧选择,您只需单击一次即可选择两个关键帧之间的一组帧。

静态帧范围

在静态帧范围内,相同的内容可用于整个范围持续时间。在您需要显示固定时间量的图形时,即可使用这种类型的范围。 

补间帧范围

在补间帧范围内,请在每个帧范围内进行内容更改。您可以使用此类型的动画范围。 

在时间轴中添加或插入帧

  • 若要插入新帧,请选择“插入”>“时间轴”>“帧”(F5)。

  • 若要创建关键帧,请选择“插入”>“时间轴”>“关键帧” (F6),或者右键单击 (Windows) 或按住 Ctrl 单击 (Macintosh) 要在其中放置关键帧的帧,然后从上下文菜单中选择“插入关键帧”

  • 若要创建空白关键帧,请选择“插入”>“时间轴”>“空白关键帧”,或者右键单击 (Windows) 或按住 Ctrl 再单击 (Macintosh) 要在其中放置关键帧的帧,然后从上下文菜单中选择“插入空白关键帧”

帧上的效果

滤镜和色彩效果过去仅适用于影片剪辑和图形元件。利用高级图层,滤镜和色彩效果现在可应用于一个选定帧,从而应用至该帧内得所有内容,包括形状、绘制对象、图形元件等。此外,也可使用传统、形状和跨帧 IK 补间对图层效果进行补间。

有关更多信息,请参阅应用图层效果

在时间轴中选择和标记帧

您可以使用 Animate 提供的两种方法选择帧。您还可以标记帧以组织其内容。 

Animate 提供两种用于在时间轴中选择帧的不同方法。在基于帧的选择(默认情况)中,可以在时间轴中选择单个帧。在基于整体范围的选择中,在单击一个关键帧到下一个关键帧之间的任何帧时,整个帧序列都将被选中。 

在时间轴中选择帧

选择单个或多个帧

  • 若要选择一个帧,请单击该帧。 
  • 若要选择多个连续的帧,请在帧上拖动鼠标,或按住 Shift 并单击其他帧。

  • 若要选择多个不连续的帧,请在按住 Ctrl (Windows) 或 Command (Macintosh) 的同时单击其他帧。

  • 若要选择时间轴中的所有帧,请选择“编辑”>“时间轴”>“选择所有帧”

基于范围的帧选择

作为基于范围的选择的前提条件,您可以通过单击右上角的汉堡图标,然后选择“基于范围的选择”菜单项,来在 Animate 时间轴中指定基于范围的选择。 

  • 要选择整个帧范围(补间动画或反向运动),请单击帧。 
  • 若要选择多个范围,请在按住 Shift 键的同时单击每个范围。

为时间轴中的帧添加标签

您可以为时间轴中的帧添加标签作为帮助组织其内容的一种方式。还可以为一个帧添加标签以便在 ActionScript 中按其标签引用该帧。这样,如果重新排列时间轴并将该标签移至其他帧编号,ActionScript 仍可引用该帧标签而无需更新。

帧标签只能应用于关键帧。最佳做法是在时间轴中创建一个单独的图层来包含帧标签。使用标签的单独图层可以更好地组织内容和关键帧。 

若要添加帧标签,请按以下步骤操作:

  1. 选择要在时间轴中为其添加标签的帧。

  2. 选中该帧之后,在“属性”检查器的“标签”部分输入标签名称。按 Enter 或 Return。

  3. 作为一种最佳做法,应在帧中创建所有标签的单独图层。 

启用基于整体范围的帧选择

使用基于范围的帧选择,您只需单击一次即可选择两个关键帧之间的一组帧。

  1. 单击时间轴部分右上角的汉堡图标。 

    将显示一个弹出菜单。 

  2. 从弹出菜单中选择“基于范围的选择”。 

分发到关键帧

使用“分发到关键帧”选项可以将舞台上的多个对象(元件和位图)分发到每个单独的关键帧。

  1. 选择舞台上任一图层的多个对象。
  2. 右键单击舞台上的任何位置,然后选择“分布到关键帧”

复制、粘贴、删除或移动帧或帧序列

关键帧和其之后的常规帧范围称为关键帧序列。时间轴可以包含任意数量的关键帧序列。

要复制或粘贴帧或帧序列,请执行以下操作之一:

复制或粘贴帧或帧序列

  • 选择帧或序列并选择“编辑”>“时间轴”>“复制帧”。选择要替换的帧或序列,然后选择“编辑”>“时间轴”>“粘贴帧”

  • 按住 Alt (Windows) 或按住 Option (Macintosh) 将一个关键帧拖动到要复制到的位置。

删除帧或帧序列

删除帧、帧序列或关键帧

选择帧或序列并选择“编辑”>“时间轴”>“删除帧”,或者右键单击 (Windows) 或按住 Ctrl 再单击 (Macintosh) 帧或序列,从上下文菜单中选择“删除帧”。

周围的帧保持不变。

删除关键帧

选择关键帧并选择“编辑”>“时间轴”>“清除关键帧”,或者右键单击 (Windows) 或按住 Ctrl 再单击 (Macintosh) 关键帧并从上下文菜单中选择“清除关键帧”

移动关键帧或帧序列

选择一个关键帧或帧序列,然后将该关键帧或帧序列拖到所需的位置。

更改静态帧序列的长度

在按住 Ctrl (Windows) 或 Command (Macintosh) 的同时向左或向右拖动范围的开始或结束帧。

若要更改逐帧动画序列的长度,请参阅创建逐帧动画

在时间轴中预览帧内容

从时间轴面板右上角的时间轴面板选项菜单中选择“预览”。

在时间轴的每个关键帧中,您可以查看关键帧中各项的缩略图预览。

Adobe 徽标

登录到您的帐户