用户指南 取消(C)

使用 Adobe Premiere Pro 和 After Effects

  1. Adobe Animate 用户指南
  2. Animate 简介
    1. Animate 新增功能
    2. 图示术语表
    3. Animate 系统要求
    4. Animate 键盘快捷键
    5. 在 Animate 中使用多种文件类型
  3. 动画
    1. Animate 动画基础知识
    2. 如何在 Animate 中使用帧和关键帧
    3. 在 Animate 中使用逐帧动画
    4. 如何在 Animate 中使用传统补间动画
    5. 画笔工具
    6. 运动辅助线
    7. 补间动画和 ActionScript 3.0
    8. 关于补间动画
    9. 补间动画
    10. 创建补间动画
    11. 使用属性关键帧
    12. 用补间对位置进行动画处理
    13. 如何使用动画编辑器编辑补间动画
    14. 编辑补间动画的运动路径
    15. 处理补间动画
    16. 添加自定义缓动
    17. 创建和应用动画预设
    18. 设置动画的补间范围
    19. 处理另存为 XML 文件的补间动画
    20. 补间动画与传统补间
    21. 形状补间
    22. 在 Animate 中使用骨骼工具动画
    23. 在 Animate 中处理角色 Rig
    24. 如何在 Adobe Animate 中使用遮罩层
    25. 如何在 Animate 中使用场景
  4. 交互性
    1. 如何使用 Animate 创建按钮
    2. 将 Animate 项目转换为其它文档类型格式
    3. 在 Animate 中创建和发布 HTML5 Canvas 文档
    4. 在 Animate 中通过代码片段添加交互性
    5. 创建自定义 HTML5 组件
    6. 使用 HTML5 Canvas 中的组件
    7. 创建自定义组件:示例
    8. 自定义组件的代码片段
    9. 最佳做法 - 使用 Animate 制作广告
    10. 虚拟现实创作和发布
  5. 工作区和工作流
    1. 创建和管理画笔
    2. 在 HTML5 Canvas 文档中使用 Google 字体
    3. 使用 Creative Cloud Libraries 和 Adobe Animate
    4. 使用 Animate 的舞台和工具面板
    5. Animate 工作流程和工作区
    6. 在 HTML5 Canvas 文档中使用 Web 字体
    7. 时间轴和 ActionScript
    8. 使用多个时间轴
    9. 设置首选参数
    10. 使用 Animate 创作面板
    11. 使用 Animate 创建时间轴图层
    12. 导出移动应用程序和游戏引擎的动画
    13. 移动和复制对象
    14. 模板
    15. 在 Animate 中查找和替换
    16. 撤消、重做和历史记录面板
    17. 键盘快捷键
    18. 如何在 Animate 中使用时间轴
    19. 创建 HTML 扩展
    20. 图像和动画 GIF 的优化选项
    21. 图像和 GIF 的导出设置
    22. Animate 中的资源面板
  6. 多媒体与视频
    1. 在 Animate 中变形和合并图形对象
    2. 在 Animate 中创建并使用元件实例
    3. 图像描摹
    4. 如何在 Adobe Animate 中使用声音
    5. 导出 SVG 文件
    6. 创建用于 Animate 中的视频文件
    7. 如何在 Animate 中添加视频
    8. 使用视频提示点
    9. 使用 Animate 绘制和创建对象
    10. 改变线条和形状
    11. Animate CC 中的笔触、填充和渐变
    12. 使用 Adobe Premiere Pro 和 After Effects
    13. Animate CC 中的颜色面板
    14. 使用 Animate 打开 Flash CS6 文件
    15. 在 Animate 中使用传统文本
    16. 向 Animate 中置入图稿
    17. 在 Animate 中导入的位图
    18. 3D 图形
    19. 在 Animate 中使用元件
    20. 使用 Adobe Animate 绘制线条和形状
    21. 在 Animate 中使用库
    22. 导出声音
    23. 在 Animate CC 中选择对象
    24. 在 Animate 中使用 Illustrator AI 文件
    25. 使用喷涂刷工具应用图案
    26. 应用混合模式
    27. 排列对象
    28. 使用“命令”菜单自动处理任务
    29. 多语言文本
    30. 在 Animate 中使用摄像头
    31. 将 Animate 与 Adobe Scout 一起使用
    32. 使用 Fireworks 文件
    33. 图形滤镜
    34. 声音和 ActionScript
    35. 绘制首选参数
    36. 用钢笔工具绘图
  7. 平台
    1. 将 Animate 项目转换为其它文档类型格式
    2. 自定义平台支持
    3. 在 Animate 中创建和发布 HTML5 Canvas 文档
    4. 创建和发布 WebGL 文档
    5. 如何打包 AIR for iOS 应用程序
    6. 发布 AIR for Android 应用程序
    7. 发布用于桌面的 Adobe AIR
    8. ActionScript 发布设置
    9. 最佳做法 - 管理应用程序中的 ActionScript
    10. 如何在 Animate 中使用 ActionScript
    11. 最佳做法 - 辅助功能指南
    12. Animate 工作区中的辅助功能
    13. 编写和管理脚本
    14. 启用自定义平台支持
    15. 自定义平台支持概述
    16. 创建辅助内容
    17. 使用自定义平台支持插件
    18. 调试 ActionScript 3.0
    19. 启用自定义平台支持
  8. 导出和发布
    1. 如何从 Animate CC 导出文件
    2. OAM 发布
    3. 导出 SVG 文件
    4. 使用 Animate 导出图形和视频
    5. 发布 AS3 文档
    6. 导出移动应用程序和游戏引擎的动画
    7. 导出声音
    8. 导出 QuickTime 视频文件
    9. 使用 ActionScript 控制外部视频播放
    10. 最佳做法 - 移动设备内容创建技巧
    11. 最佳做法 - 视频惯例
    12. 最佳做法 - SWF 应用程序创作指南
    13. 最佳做法 - 构造 FLA 文件
    14. 在 Animate 中优化 FLA 文件的最佳做法
    15. ActionScript 发布设置
    16. 指定 Animate 的发布设置
    17. 导出放映文件
    18. 导出图像和动画 GIF
    19. HTML 发布模板
    20. 使用 Adobe Premiere Pro 和 After Effects
    21. 快速分享和发布动画

将 Adobe Premiere Pro 与 Adobe Animate 一起使用

Adobe Premiere Pro 是一款专业的视频编辑工具。如果您使用 Adobe Animate 为网站或移动设备设计交互式内容,则可以使用 Adobe Premiere Pro 来编辑这些项目的影片。Adobe Premiere Pro 为您提供了各种可精确到帧级的视频编缉专业工具,其中包括用于优化要在计算机屏幕和移动设备上播放的视频文件的工具。

Adobe Animate 是一种用于将视频素材合并到用于 Web 和移动设备的演示文稿中的工具。Adobe Animate 在技术和创意方面的优势可让您将视频与数据、图形、声音和交互式控制融为一体。FLV 是几乎任何人都可以查看的格式,允许您将视频放在网页上。

如果使用其它标准格式导出视频文件,Adobe Animate 可以在富媒体应用程序中对视频进行编码。Adobe Animate 使用最新的压缩技术,能够以较小的文件大小提供最佳品质的文件。

将 Animate 与 After Effects 一起使用

如果使用 Adobe® Animate® 创建视频或动画,则可以使用 After Effects 来编辑和优化视频。例如,可以从 Animate 将动画和应用程序导出为 QuickTime 影片。然后可使用 After Effects 来编辑和优化视频。

对于一些共有概念,Animate 和 After Effects 使用了不同的术语,包括以下内容:

  • After Effects 中的“合成图像”与 Animate 中的“影片剪辑”类似。

  • “合成”面板中的“合成帧”与 Animate 中的“舞台”类似。

  • After Effects 中的“项目”面板与 中的“库”面板类似。

  • After Effects 中的“项目文件”与 Animate 中的“FLA 文件”类似。

  • 您可以从 After Effects 呈现和导出影片;您可以从 Animate 发布 SWF 文件。

从 Animate 导出 QuickTime 视频

如果使用 Animate 创建动画或应用程序,则可以使用 Animate 中的“文件”>“导出”>“导出影片”命令将其导出为 QuickTime 影片。对于 Animate 动画,您可以优化动画的视频输出。对于 Animate 应用程序,Animate 将在应用程序运行时渲染其视频,从而使用户能够对其进行操作。这样,您就可以捕捉要包括在视频文件中的应用程序分支或状态。

在 Animate 中导入和发布视频

将 FLV 文件导入 Animate 时,可以使用不同的方法(如脚本或 Animate 组件)来控制视频周围的可视界面。例如,可加入回放控件或其他图形。也可以在 FLV 文件上添加图形图层以获得合成结果。

复合图形、动画和视频

Animate 和 After Effects 均包含很多用于执行复杂的视频和图形合成操作的功能。具体选用哪个应用程序取决于您的个人喜好以及要创建的最终输出类型。

在这两个应用程序中,Animate 更面向于 Web,并且最终文件较小。Animate 还允许对动画进行运行时控制。After Effects 面向视频和影片制作,提供了丰富多样的视觉效果,用于创建视频文件作为最终输出。

这两个应用程序都可以用来创建原始图形和动画。它们都使用时间轴,并且提供了脚本功能以按编程方式控制动画。After Effects 包含的效果更多;而将这两种脚本环境相比,Animate 的 ActionScript® 语言更强大。

两个应用程序都允许将图形放在单独的图层中以进行合成。可以根据需要打开或关闭这些图层。两个应用程序还允许对各个图层上的内容应用效果。

在 Animate 中,合成不会直接影响视频内容;它们仅影响视频在 Flash Player 中回放时的外观。相比之下,在 After Effects 中使用导入的视频进行合成时,导出的视频文件实际上包含着合成的图形和效果。

由于在 After Effects 中,所有绘制和绘画都是在与导入视频无关的图层上完成的,因此它始终是非破坏性的。Animate 则具有破坏性和非破坏性两种绘制模式。

将 SWF 文件导入到 After Effects

Animate 具有一套独特的矢量图形工具,可以完成很多在 After Effects 或 Adobe® Illustrator® 中无法完成的绘制任务。您可以将 SWF 文件导入到 After Effects 中,与其它视频进行合成,或者作为具有创意效果的视频进行呈现。未保留交互内容和脚本动画。保留了关键帧定义的动画。

导入到 After Effects 中的每个 SWF 文件都将拼合到一个连续栅格化的图层中,并保留其 Alpha 通道。连续栅格化意味着图形在进行放大时会保持清晰。使用这种导入方法,您可以在 After Effects 中将 SWF 文件的根图层或对象用作平滑呈现的元素,从而让每个工具发挥出最佳功能。

“高级图层”模式(“修改”>“文档...”>“模式”)现在默认启用,在此模式中,每个图层均作为影片剪辑发布。在开启“高级图层”模式时发布并导入到 After Effects 的 SWF 文件与导入的影片剪辑具有相同的限制。

指定 .swf 文件的发布设置时,可选择生成兼容的 SWF 文件,该文件可提取摄像头效果、图层深度并通过父子关系传递到 After Effects。在“发布设置”对话框中,选择“After Effects 优化”选项。此外,将 FLA 拖放到 After Effects 中时,此选项默认启用,以便在 After Effects 中保留其原有的高级图层功能。

发布设置
发布设置

将 Animate FLA 文件导入 After Effects 中

现在,您可以将 Animate FLA 文件导入到 After Effects 中,与视频进行合成,或者使用其他创意效果将其渲染为视频。After Effects 可以使用插件与 Animate 交互。 

  1. 通过 Creative Cloud 应用程序安装 Animate 19.0 和 After Effects 16.0。 

  2. 启动 After Effects 并创建项目。

  3. 转到菜单“文件”>“导入”>“文件...”

  4. 选择·sample.fla 文件,然后单击“导入”

    请使用任意 AS3 .fla 文件作为 sample.fla 文件。

  5. “导入首选项”对话框中,浏览到所有图层 FLA 文件的生成位置,然后单击“确定”

    默认情况下,会使用已保存 FLA 文件的位置。

    如果选择“导入音频”选项,则 FLA 中的主时间轴上的音频将导出为 .mp3 或 .wav 声音文件。此音频已作为单独的图层导入 After Effects。

    所有图层都导入到 After Effects 中的合成内。合成中的图层顺序与 Animate 中使用的顺序类似。

    在导入期间会忽略图层效果和摄像头滤镜(如果使用)。

创建具有后期特效的动画

无后期特效的动画是不完整的。后期特效可为视频带来额外的精确度和视觉效果。想要了解如何导入动画文件并创建后期特效。在本示例结尾观看教程并按照这些步骤操作。

  1. 单击“文件”>“导入”,选择所需的 Animate CC 文档,然后单击“确定”

  2. 单击“效果”>“生成”并选择所需效果。

Adobe 徽标

登录到您的帐户