关于滤镜

滤镜概述

使用滤镜(图形效果),可以为文本、按钮和影片剪辑增添丰富的视觉效果。Animate 所独有的一个功能是可以使用补间动画让应用的滤镜动起来。

使用 Animate 混合模式,可以创建复合图像。复合是改变两个或两个以上重叠对象的透明度或者颜色相互关系的过程。 混合模式也为对象和图像的不透明度增添了控制尺度。 可以使用 Animate 混合模式来创建用于透显下层图像细节的加亮效果或阴影,或者对不饱和的图像涂色。

关于动画滤镜

可以在时间轴中动画显示滤镜。由一个补间接合的不同关键帧上的各个对象,都有在中间帧上补间的相应滤镜的参数。 如果某个滤镜在补间的另一端没有相匹配的滤镜(相同类型的滤镜),则会自动添加匹配的滤镜,以确保在动画序列的末端出现该效果。

为了防止在补间一端缺少某个滤镜或者滤镜在每一端以不同的顺序应用时,补间动画不能正常运行,Animate 会执行以下操作:

  • 如果将补间动画应用于已应用了滤镜的影片剪辑,则在补间的另一端插入关键帧时,该影片剪辑在补间的最后一帧上自动具有它在补间开头所具有的滤镜,并且层叠顺序相同。

  • 如果将影片剪辑放在两个不同帧上,每个影片剪辑应用不同滤镜,且两帧之间又应用了补间动画,则 Animate 首先处理带滤镜最多的影片剪辑。然后,Animate 会比较应用于第一个影片剪辑和第二个影片剪辑的滤镜。如果在第二个影片剪辑中找不到匹配的滤镜,Animate 会生成一个不带参数并具有现有滤镜颜色的虚拟滤镜。

  • 如果两个关键帧之间存在补间动画并且向其中一个关键帧中的对象添加了滤镜,则 Animate 会在到达补间另一端的关键帧时自动为影片剪辑添加一个虚拟滤镜。

  • 如果两个关键帧之间存在补间动画并且从其中一个关键帧中的对象上删除了滤镜,则 Animate 会在到达补间另一端的关键帧时自动从影片剪辑中删除匹配的滤镜。

  • 如果补间动画起始处和结束处的滤镜参数设置不一致,Animate 会将起始帧的滤镜设置应用于插补帧。以下参数在补间起始和结束处设置不同时会出现不一致的设置:挖空、内侧阴影、内侧发光以及渐变发光的类型和渐变斜角的类型。

    例如,如果使用投影滤镜创建补间动画,在补间的第一帧上应用挖空投影,而在补间的最后一帧上应用内侧阴影,则 Animate 会更正补间动画中滤镜使用的不一致现象。 在这种情况下,Animate 会应用补间的第一帧上所用的滤镜设置,即挖空投影。

关于滤镜和 Flash Player 的性能

应用于对象的滤镜类型、数量和质量会影响 SWF 文件的播放性能。应用于对象的滤镜越多,Adobe® Flash® Player 要正确显示创建的视觉效果所需的处理量也就越大。 Adobe® 建议对一个给定对象只应用有限数量的滤镜。

每个滤镜都包含控件,可以调整所应用滤镜的强度和质量。 在运行速度较慢的计算机上,使用较低的设置可以提高性能。 如果要创建要在一系列不同性能的计算机上播放的内容,或者不能确定观众可使用的计算机的计算能力,请将质量级别设置为“低”,以实现最佳的播放性能。

关于 Pixel Bender 滤镜

Adobe Pixel Bender™ 是 Adobe 开发的一种编程语言,用户可以使用该语言创建自定义滤镜、效果和混合模式,以用于 Animate 和 After Effects。Pixel Bender 与硬件无关,旨在自动高效地运行于各种 GPU 和 CPU 体系结构之上。

Pixel Bender 开发人员通过编写 Pixel Bender 代码并将代码保存在文件扩展名为 pbj 的文本文件中来创建滤镜。一旦编写完成,Pixel Bender 滤镜便可以由任何 Animate 文档使用。使用 ActionScript® 3.0 可加载滤镜并使用其控件。

有关在 ActionScript 中使用 Pixel Bender 的详细信息,请参阅 ActionScript 3.0 开发人员指南

Lee Brimelow 已在其博客中发布了几个很有帮助的 Pixel Bender 示例,博客地址为 http://theflashblog.com/?cat=44。

下列视频教程演示如何在 Animate 中使用 Pixel Bender 滤镜:

使用滤镜

Animate CC 中的增强功能

对象每添加一个新的滤镜,在属性检查器中,就会将其添加到该对象所应用的滤镜的列表中。 可以对一个对象应用多个滤镜,也可以删除以前应用的滤镜。 您可以将滤镜仅应用于文本、按钮、影片剪辑、组件及已编译的剪辑对象。

可以创建滤镜设置库,轻松地将同一个滤镜或滤镜集应用于对象。 Animate 存储您在属性检查器的“滤镜”部分中创建的滤镜预设(在“滤镜”>“预设”菜单中创建)。

对于 Flash Professional CS6 和更早版本,滤镜的应用仅限于影片剪辑和按钮元件。而对于 Animate CC,如今还可以将滤镜额外应用于已编译的剪辑和影片剪辑组件。这样您通过单击(或双击)一个按钮,便可直接向组件添加各种效果,使应用程序看起来更为直观。而对于 Flash CS6,要向组件添加滤镜或其他效果,您必须将效果“封装”在一个影片剪辑元件中。操作如下:

  1. 在舞台上创建或添加一个组件。
  2. 右键单击该组件,然后选择“转换为元件”。
对于 CS6(及更早版本),您可以先将组件封装在一个元件中,然后再添加滤镜或各种其他效果。不过,这只是一种解决办法,并非推荐使用的最佳方式。
 
对于 Animate CC,您可以直接使用“属性”面板中的“滤镜”、“色彩效果”及“显示设置”选项来向组件添加各种滤镜。若想更好地理解这一重要的增强功能,可考察以下示例:
 
向按钮组件添加斜角滤镜
 
  1. 在舞台上通过“组件”面板创建或添加一个按钮,然后选择它。
  2. 在“属性”面板的“滤镜”部分中,单击 按钮下拉列表,然后选择“斜角滤镜”。将显示斜角滤镜的属性和值。
  3. 对任一需要的属性修改或设置相应的值。例如,模糊 X、模糊 Y、强度、阴影等。您会注意到效果将同时反映在选定按钮上。
属性检查器中的“添加滤镜”菜单

应用或删除滤镜

  1. 选择文本、按钮或影片剪辑对象,以应用或删除滤镜。
  2. 在“属性”面板的“滤镜”部分中,执行以下任一操作:

    • 若要添加滤镜,请单击 按钮,然后选择一个滤镜。试验不同的设置,直到获得所需效果。

    • 若要删除滤镜,请从已应用滤镜的列表中选择要删除的滤镜,然后单击“删除滤镜”按钮 。可以删除或重命名任何预设。

复制和粘贴滤镜

  1. 选择要从中复制滤镜的对象,然后选择“滤镜”面板。
  2. 选择要复制的滤镜,然后单击 按钮。在下拉列表中,单击“复制选定的滤镜”。若要复制所有滤镜,请选择“复制所有滤镜”。

  3. 选择要对其应用滤镜的对象,然后单击该按钮。在下拉列表中,单击“粘贴滤镜”。

为对象应用预设滤镜

  1. 选择要应用滤镜预设的对象,然后选择“滤镜”选项卡。
  2. 单击 按钮打开下拉列表。

  3. 从下拉列表底部的可用预设列表中,选择要应用的滤镜预设。

注意:

将滤镜预设应用于对象时,Animate 会将当前应用于所选对象的所有滤镜替换为该预设中使用的滤镜。

启用或禁用应用于对象的滤镜

  1. 所有滤镜默认为启用状态。在滤镜列表中,单击滤镜名称旁边的 图标可禁用滤镜。单击滤镜名称旁边的 X 按钮可启用滤镜。

    注意:

    若要切换该列表中其他滤镜的启用状态,请按住 Alt (Windows) 或 Option (Macintosh) 键单击“滤镜”列表中的启用图标。如果按住 Alt 键单击 图标,将启用选定滤镜,并禁用列表中的所有其他滤镜将。

启用或禁用应用于对象的所有滤镜

  1. 单击 按钮,然后从下拉菜单中选择“启用全部”或“禁用全部”。

    注意:

    若要启用或禁用该列表中的所有滤镜,请在按住 Ctrl 的同时单击“滤镜”列表中的启用或禁用图标。

创建预设滤镜库

可以将滤镜设置保存为预设库,以便轻松应用到影片剪辑和文本对象。 通过向其他用户提供滤镜配置文件,就可以与他们共享您的滤镜预设。 滤镜配置文件是保存在 Animate Configuration 文件夹中的一个 XML 文件,其位置为:

 

  • Windows 7 和 8:C:\Users\用户名\AppData\Local\Adobe\Flash CC\语言\Configuration
  • (仅限 Flash Professional CS6 或更早版本)Windows XP:C:\Documents and Settings\用户名\Local Settings\Application Data\Adobe\Flash CS6\语言\Configuration\Filters\filtername.xml
  • (仅限 Flash Professional CS6 或更早版本)Windows Vista:C:\Users\用户名\Local Settings\Application Data\Adobe\Flash CS6\语言\Configuration\Filters\filtername.xml
  • Macintosh:Macintosh HD/Users/用户名/Library/Application Support/Adobe/Flash CC/语言/Configuration/Filters/filtername.xml

创建带预设设置的滤镜库

  1. 将一个或多个滤镜应用到任一选定对象。

  2. 单击 按钮添加一个新的滤镜。

  3. 选择该滤镜并单击 按钮,然后选择“另存为预设”。

  4. 在“将预设另存为”对话框中,输入此滤镜设置的名称,然后单击“确定”。

重命名滤镜预设

  1. 单击 按钮添加一个新的滤镜。

  2. 选择该滤镜并单击 按钮。单击“编辑预设”。

  3. 双击要修改的预设名称。

  4. 输入新的预设名称,然后单击“确定”。

删除滤镜预设

  1. 单击 按钮添加一个新的滤镜。

  2. 选择该滤镜并单击 按钮。

  3. 单击“编辑预设”。

  4. 在“编辑预设”对话框中,选择要删除的预设,然后单击“删除”。

应用滤镜

应用投影

投影滤镜模拟对象投影到一个表面的效果。

应用投影滤镜的文本

有关应用了传统补间的投影的示例,请参阅“Animate 范例”页,网址:www.adobe.com/go/learn_fl_samples_cn。下载并解压缩 Samples zip 文件,然后浏览到 Graphics\AnimatedDropShadow 目录。

  1. 选择要应用投影的对象。
  2. 在属性检查器的“滤镜”部分中,单击 按钮,然后选择“投影”。

  3. 编辑滤镜的设置:
    • 若要设置投影的宽度和高度,请设置“模糊 X”和“模糊 Y”值。
    • 若要设置阴影暗度,请设置“强度”值。数值越大,阴影就越暗。
    • 选择投影的质量级别。 设置为“高”则近似于高斯模糊。 设置为“低”可以实现最佳的播放性能。
    • 若要设置阴影的角度,请输入一个值。
    • 若要设置阴影与对象之间的距离,请设置“距离”值。
    • 选择“挖空”可挖空(即从视觉上隐藏)源对象,并在挖空图像上只显示投影。
    • 若要在对象边界内应用阴影,请选择“内侧阴影”。
    • 若要隐藏对象并只显示其阴影,请选择“隐藏对象”。 使用“隐藏对象”可以更轻松地创建逼真的阴影。
    • 若要打开颜色选择器并设置阴影颜色,请单击“颜色”控件。

创建倾斜投影

使投影滤镜倾斜以创建一个更逼真的阴影

  1. 选择要倾斜的投影所在的对象。
  2. 重制(选择“编辑”>“重制”)源对象。
  3. 选择对象副本,然后使用任意变形工具(“修改”>“变形”>“旋转与倾斜”)使其倾斜。
  4. 对影片剪辑或文本对象的副本应用投影滤镜。 (如果对象副本已有投影,则已应用投影滤镜。)
  5. 在“滤镜”面板中,选择“隐藏对象”可隐藏对象副本,而对象副本的投影可见。
  6. 选择“修改”>“排列”>“下移一层”可将对象副本及其投影放置在重制操作的原始对象之后。
  7. 调整“投影”滤镜设置和倾斜投影的角度,直到获得所需效果为止。

应用模糊

模糊滤镜可以柔化对象的边缘和细节。 将模糊应用于对象,可以让它看起来好像位于其他对象的后面,或者使对象看起来好像是运动的。

应用模糊滤镜的文本

  1. 选择要应用模糊的对象,然后选择“滤镜”。
  2. 单击 按钮,然后选择“模糊”。

  3. 在“滤镜”选项卡上编辑滤镜设置:
    • 若要设置模糊的宽度和高度,请设置“模糊 X”和“模糊 Y”值。
    • 选择模糊的质量级别。 设置为“高”则近似于高斯模糊。 设置为“低”可以实现最佳的播放性能。

应用发光

使用“发光”滤镜,可以为对象的周边应用颜色。

应用发光滤镜的文本

  1. 选择要应用发光的对象,然后选择“滤镜”。
  2. 单击 按钮,然后选择“发光”。

  3. 在“滤镜”选项卡上编辑滤镜设置:
    • 若要设置发光的宽度和高度,请设置“模糊 X”和“模糊 Y”值。
    • 若要打开颜色选择器并设置发光颜色,请单击“颜色”控件。
    • 若要设置发光的清晰度,请设置“强度”值。
    • 若要挖空(即从视觉上隐藏)源对象并在挖空图像上只显示发光,请选择“挖空”。
    使用带“挖空”选项的发光滤镜

    • 若要在对象边界内应用发光,请选择“内侧发光”。
    • 选择发光的质量级别。 设置为“高”则近似于高斯模糊。 设置为“低”可以实现最佳的播放性能。

应用斜角

应用斜角就是向对象应用加亮效果,使其看起来凸出于背景表面。

应用斜角的文本

  1. 选择要应用斜角的对象,然后选择“滤镜”。
  2. 单击 按钮,然后选择“斜角”。

  3. 在“滤镜”选项卡上编辑滤镜设置:
    • 若要设置斜角的类型,请从“类型”菜单中选择一个斜角。
    • 若要设置斜角的宽度和高度,请设置“模糊 X”和“模糊 Y”值。
    • 从弹出的调色板中,选择斜角的阴影和加亮颜色。
    • 若要设置斜角的不透明度而不影响其宽度,请设置“强度”值。
    • 若要更改斜边投下的阴影角度,请设置“角度”值。
    • 若要定义斜角的宽度,请在“距离”中输入一个值。
    • 若要挖空(即从视觉上隐藏)源对象并在挖空图像上只显示斜角,请选择“挖空”。

应用渐变发光

应用渐变发光,可以在发光表面产生带渐变颜色的发光效果。 渐变发光要求渐变开始处颜色的 Alpha 值为 0。 您不能移动此颜色的位置,但可以改变该颜色。

应用渐变发光的文本

  1. 选择要应用渐变发光的对象。
  2. 在属性检查器的“滤镜”部分中,单击 按钮,然后选择“渐变发光”。

  3. 在“滤镜”选项卡上编辑滤镜设置:
    • 从“类型”弹出菜单中,选择要为对象应用的发光类型。
    • 若要设置发光的宽度和高度,请设置“模糊 X”和“模糊 Y”值。
    • 若要设置发光的不透明度而不影响其宽度,请设置“强度”值。
    • 若要更改发光投下的阴影角度,请设置“角度”值。
    • 若要设置阴影与对象之间的距离,请设置“距离”值。
    • 若要挖空(即从视觉上隐藏)源对象并在挖空图像上只显示渐变发光,请选择“挖空”。
    • 指定发光的渐变颜色。 渐变包含两种或多种可相互淡入或混合的颜色。 选择的渐变开始颜色称为 Alpha 颜色。
    • 若要更改渐变中的颜色,请从渐变定义栏下面选择一个颜色指针,然后单击渐变栏下方紧邻着它显示的颜色空间以显示“颜色选择器”。 滑动这些指针,可以调整该颜色在渐变中的级别和位置。
    • 要向渐变中添加指针,请单击渐变定义栏或渐变定义栏的下方。 若要创建有多达 15 种颜色转变的渐变,请全部添加 15 个颜色指针。 要重新放置渐变上的指针,请沿着渐变定义栏拖动指针。 若要删除指针,请将指针向下拖离渐变定义栏。
    • 选择渐变发光的质量级别。 设置为“高”则近似于高斯模糊。 设置为“低”可以实现最佳的播放性能。

应用渐变斜角

应用渐变斜角可以产生一种凸起效果,使得对象看起来好像从背景上凸起,且斜角表面有渐变颜色。 渐变斜角要求渐变的中间有一种颜色的 Alpha 值为 0。

  1. 选择要应用渐变斜角的对象。

  2. 在属性检查器的“滤镜”部分中,单击 按钮,然后选择“渐变斜角”。

  3. 在“滤镜”选项卡上编辑滤镜设置:

    • 从“类型”弹出菜单上,选择要为对象应用的斜角类型。

    • 若要设置斜角的宽度和高度,请设置“模糊 X”和“模糊 Y”值。

    • 若要影响斜角的平滑度而不影响其宽度,请为“强度”输入一个值。

    • 若要设置光源的角度,请为“角度”输入一个值。

    • 若要挖空(即从视觉上隐藏)源对象并在挖空图像上只显示渐变斜角,请选择“挖空”。

    • 指定斜角的渐变颜色。 渐变包含两种或多种可相互淡入或混合的颜色。 中间的指针控制渐变的 Alpha 颜色。 您可以更改 Alpha 指针的颜色,但是无法更改该颜色在渐变中的位置。

      若要更改渐变中的颜色,请从渐变定义栏下面选择一个颜色指针,然后单击渐变栏下方紧邻着它显示的颜色空间以显示“颜色选择器”。 若要调整该颜色在渐变中的级别和位置,请滑动这些指针。

      要向渐变中添加指针,请单击渐变定义栏或渐变定义栏的下方。 若要创建有多达 15 种颜色转变的渐变,请全部添加 15 个颜色指针。 要重新放置渐变上的指针,请沿着渐变定义栏拖动指针。 若要删除指针,请将指针向下拖离渐变定义栏。

应用调整颜色滤镜

使用“调整颜色”滤镜可以很好地控制所选对象的颜色属性,包括对比度、亮度、饱和度和色相。

  1. 选择要调整其颜色的对象。
  2. 在属性检查器的“滤镜”部分中,单击 按钮,然后选择“调整颜色”。

  3. 为颜色属性输入值。属性和它们的对应值如下:

    对比度

    调整图像的加亮、阴影及中调。

    亮度

    调整图像的亮度。

    饱和度

    调整颜色的强度。

    色相

    调整颜色的深浅。

  4. 若要将所有的颜色调整重置为 0 并使对象恢复其原来的状态,请单击“重置滤镜”。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略