使用库

Animate 文档中的库存储在 Animate 创作环境中创建或在文档中导入的媒体资源。在 Animate 中可以直接创建矢量插图或文本;导入矢量插图、位图、视频和声音;创建元件。元件 是指创建一次即可多次重复使用的图形、按钮、影片剪辑或文本。也可以使用 ActionScript 动态地将媒体内容添加至文档。

库还包含已添加到文档的所有组件。它们可以是编译剪辑,也可以是基于组件的影片剪辑。

在 Animate 中工作时,可以打开任一 Animate 文档的库,将该文件的库项目用于当前文档。可以通过元件的名称或其 ActionScript 链接名称来搜索库中的元件。

您可以在 Animate 应用程序中创建永久的库,只要启动 Animate 就可以使用这些库。Animate 还提供几个含按钮、图形、影片剪辑和声音的范例库。

可以将库资源作为 SWF 文件导出到一个 URL,从而创建运行时共享库。 这样即可从 Animate 文档(使用运行时共享导入元件)链接到这些库资源。

“库”面板(“窗口”>“库”)显示库中所有项目名称的滚动列表,允许您在工作时查看和组织这些元素。 “库”面板中项目名称旁边的图标指示项目的文件类型。

注意:

将对象从 Stage 拖动到“库”面板以便转换为元件的功能已弃用,在 Animate CC 中将不再有效。

跨两个非停靠文档将对象拖动到 Stage 的功能已弃用,在 Animate CC 中将不再有效。

在另一个 Animate 文件中打开库

  1. 从当前文档选择“文件”>“导入”>“打开外部库”。
  2. 定位到要打开的库所属的 Animate 文件,然后单击“打开”。

    所选文件的库在当前文档中打开,并在“库”面板顶部显示文件名。 若要在当前文档中使用所选文件的库中的项目,请将这些项目拖到当前文档的“库”面板或舞台上。

调整库面板大小

  1. 请执行下列操作之一:
    • 拖动面板的右下角。

    • 单击“宽状态”按钮,放大“库”面板以便显示所有列。

    • 单击“窄状态”按钮缩小“库”面板的宽度。

更改列宽

  1. 将指针放在列标题之间并拖动以调整大小。

在库面板中使用文件夹

您可以在“库”面板中使用文件夹来组织项目。当您创建一个新元件时,它会存储在选定的文件夹中。如果没有选定文件夹,该元件就会存储在库的根目录下。

Animate 还会以一种有组织的方式导入动画 GIF 文件,即将其放在库的根文件夹下一个单独的文件夹中,并根据其顺序命名所有相关联的位图。 

创建新文件夹

  1. 单击“库”面板底部的“新建文件夹”按钮

打开或关闭文件夹

  1. 双击文件夹,或选择文件夹再从“库”面板的“面板”菜单中选择“展开文件夹”或“折叠文件夹”。

打开或关闭所有文件夹

  1. 从“库”面板的“面板”菜单中选择“展开所有文件夹”或“折叠所有文件夹”。

在文件夹之间移动项目

  1. 将项目从一个文件夹拖动到另一个文件夹。

    如果新位置中存在同名项目,Animate 会提示您用移动的项目替换它。

对库面板中的项目进行排序

“库”面板的各列列出了项目名称、项目类型、项目在文件中使用的次数、项目的链接状态和标识符(如果项目与共享库相关联或者被导出用于 ActionScript),以及上次修改项目的日期。

您可以在“库”面板中根据任何列按字母数字顺序对项目进行排序。 项目是在文件夹内排序的。

Animate 库会将导入的动画 GIF 文件组织在库的根文件夹下一个单独的文件夹中,并根据其顺序命名所有相关联的位图。 

  1. 单击列标题可以根据该列进行排序。 单击列标题右侧的三角形按钮可以倒转排序顺序。

库资源之间的冲突

如果将一个库资源导入或复制到已经含有同名的不同资源的文档中,则可以选择是否用新项目替换现有项目。此选项适用于所有用于导入或复制库资源的方法。

当您尝试在文档中放置与现有项目冲突的项目时,就会出现“解决库项目”对话框。当您要从源文档中复制一个已在目标文档中存在的项目,并且这两个项目具有不同的修改日期时,就会出现冲突。可通过组织文档库中文件夹内的资源来避免出现命名冲突。如果将某个元件或组件粘贴到文档的舞台上,但现在已有该元件或组件的一个副本(其修改日期与所粘贴元件或组件的修改日期不同),则也会出现该对话框。

如果您选择不替换现有项目,Animate 将会尝试使用现有项目,而不使用正在粘贴的冲突项目。例如,如果复制一个名为“元件 1”的元件,并且将该元件的副本粘贴到文档(其中已包含一个名为“元件 1”的元件)的舞台中,则 Animate 会创建现有“元件 1”的实例。

如果选择替换现有项目,则 Animate 会使用同名的新项目替换现有项目(及其所有实例)。如果您取消导入或复制操作,就会对所有项目取消该操作(不仅仅是那些在目标文档中产生冲突的项目)。

只有相同的库项目类型才能互相替换。 即,不能用一个名为“Test”的位图替换一个名为“Test”的声音。 在这种情况下,新项目的名称后面会附加“Copy”字样,然后再添加到库中。

注意:

使用这种方法替换库项目的操作是无法撤消的。在执行只有通过替换冲突的库项目才能得以解决的复杂粘贴操作之前,请保存 FLA 文件的一个备份。

如果在将库资源导入或复制到文档中时出现“解决库冲突”对话框,请解决命名冲突。

解决库资源之间的命名冲突

  1. 在“解决库冲突”对话框中执行以下操作之一:

    • 若要保留目标文档中的现有资源,请单击“不要替换现有项目”。

    • 若要用同名的新项目替换现有资源及其实例,请单击“替换现有项目”。

使用库项目

当您选择“库”面板中的项目时,“库”面板的顶部会出现该项目的缩略图预览。 如果选定项目是动画或者声音文件,则可以使用库预览窗口或“控制器”中的“播放”按钮预览该项目。

按链接名称搜索库项目

可以通过元件的名称或其 ActionScript 链接名称在库搜索面板中搜索元件。

  • 要搜索某个库项目,可键入元件名称的前几个字母或库项目的 ActionScript 链接名称。键入时,库面板中会显示一个匹配元件的列表。

在当前文档中使用库项目。

  1. 将项目从“库”面板拖动到舞台上。

    该项目就会添加到当前层上。

将舞台上的对象转换为库中的元件

  1. 选择舞台上的对象,右键单击鼠标,然后选择“转换为元件”。

在另一个文档内使用当前文档中的库项目

  1. 将项目从“库”面板或舞台拖入另一个文档的“库”面板或舞台。

从另一个文档复制库项目

  1. 选择包含这些库项目的文档。
  2. 在“库”面板中选择库项目。
  3. 选择“编辑”>“复制”。
  4. 选择要复制这些库项目的目标文档。
  5. 选择该文档的“库”面板。
  6. 选择“编辑”>“粘贴”。

编辑库项目

  1. 在“库”面板中选择项目。
  2. 从“库”面板的“面板”菜单中选择下列一项:
    • 若要在 Animate 中编辑项目,请选择“编辑”。

    • 若要在其他应用程序中编辑项目,请选择“编辑方式”,然后选择一个外部应用程序。

注意:

启动支持的外部编辑器后,Animate 会打开原始的导入文档。

重命名库项目

更改导入文件的库项目名称并不会更改该文件名。

  1. 请执行下列操作之一:
    • 双击项目名称。

    • 选择项目并从“库”面板的“面板”菜单中选择“重命名”。

    • 右键单击 (Windows) 或按住 Control 并单击 (Macintosh) 项目,然后从上下文菜单中选择“重命名”。

  2. 在框中输入新名称。

删除库项目

从库中删除某个项时,也会从文档中删除该项的所有实例或匹配项。

  1. 选择该项,然后单击“库”面板底部的垃圾桶图标。

查找未使用的库项

若要组织文档,您可以查找未使用的库项目并将其删除。

注意:

无需通过删除未用库项来减小 Animate 文档的文件大小,这是因为未用库项并不包含在 SWF 文件中。不过,链接的待导出项目包括在 SWF 文件中。

  1. 请执行下列操作之一:
    • 从“库”面板的“面板”菜单中选择“选择未用项目”。

    • 根据“使用次数”列对库项目进行排序,该列指示某个项目是否在使用。

更新库中的导入文件

如果用外部编辑器修改已导入 Animate 的文件(如位图或声音文件),则可以在 Animate 中更新这些文件,而无需重新导入。 您也可以更新已经从外部 Animate 文档导入的元件。 更新导入文件会以外部文件的内容替换其内容。

注意:可以将导入的动画 GIF 文件组织在库的根文件夹下一个单独的文件夹中,并根据其顺序命名所有相关联的位图。

  1. 在“库”面板中选择导入的文件。
  2. 从“库”面板的“面板”菜单中选择“更新”。

在文档之间复制库资源

可以用各种方法将库从源文档复制到目标文档中。 在创作期间或在运行时,您还可以将元件作为共享库资源在文档之间共享。

如果您尝试复制与目标文档中现有的资源同名的资源,“解决库冲突”对话框会让您选择是要覆盖现有资源还是要保留现有资源并用修改后的名称添加新资源。 组织文件夹内的库资源,以便在文档间复制资源时最大程度地减少可能出现的名称冲突。

通过复制和粘贴来复制库资源

  1. 在源文档的舞台上选择资源。

  2. 选择“编辑”>“复制”。

  3. 使目标文档成为活动文档。

  4. 若要将资源粘贴到可见剪贴板的中心位置,请将指针放在舞台上并选择“编辑”>“粘贴到中心位置”。 若要将资源放置在与源文档中相同的位置,请选择“编辑”>“粘贴到当前位置”。

通过拖动来复制库资源

  1. 在目标文档打开的情况下,在源文档的“库”面板中选择该资源,并将其拖入目标文档的“库”面板中。

通过在目标文档中打开源文档库来复制库资源

  1. 当目标文档处于活动状态时,选择“文件”>“导入”>“打开外部库”。

  2. 选择源文档并单击“打开”。

  3. 将资源从源文档库拖到舞台上或拖入目标文档的库中。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略