在 Animate 中使用逐帧动画

  1. Adobe Animate 用户指南
  2. Animate 简介
    1. Animate 新增功能
    2. 图示术语表
    3. Animate 系统要求
    4. Animate 键盘快捷键
    5. 在 Animate 中使用多种文件类型
  3. 动画
    1. Animate 动画基础知识
    2. 如何在 Animate 中使用帧和关键帧
    3. 在 Animate 中使用逐帧动画
    4. 如何在 Animate 中使用传统补间动画
    5. 画笔工具
    6. 运动辅助线
    7. 补间动画和 ActionScript 3.0
    8. 关于补间动画
    9. 补间动画
    10. 创建补间动画
    11. 使用属性关键帧
    12. 用补间对位置进行动画处理
    13. 如何使用动画编辑器编辑补间动画
    14. 编辑补间动画的运动路径
    15. 处理补间动画
    16. 添加自定义缓动
    17. 创建和应用动画预设
    18. 设置动画的补间范围
    19. 处理另存为 XML 文件的补间动画
    20. 补间动画与传统补间
    21. 形状补间
    22. 在 Animate 中使用骨骼工具动画
    23. 在 Animate 中处理角色 Rig
    24. 如何在 Adobe Animate 中使用遮罩层
    25. 如何在 Animate 中使用场景
  4. 交互性
    1. 如何使用 Animate 创建按钮
    2. 将 Animate 项目转换为其它文档类型格式
    3. 在 Animate 中创建和发布 HTML5 Canvas 文档
    4. 在 Animate 中通过代码片段添加交互性
    5. 创建自定义 HTML5 组件
    6. 使用 HTML5 Canvas 中的组件
    7. 创建自定义组件:示例
    8. 自定义组件的代码片段
    9. 最佳做法 - 使用 Animate 制作广告
    10. 虚拟现实创作和发布
  5. 工作区和工作流
    1. 创建和管理画笔
    2. 在 HTML5 Canvas 文档中使用 Google 字体
    3. 使用 Creative Cloud Libraries 和 Adobe Animate
    4. 使用 Animate 的舞台和工具面板
    5. Animate 工作流程和工作区
    6. 在 HTML5 Canvas 文档中使用 Web 字体
    7. 时间轴和 ActionScript
    8. 使用多个时间轴
    9. 设置首选参数
    10. 使用 Animate 创作面板
    11. 使用 Animate 创建时间轴图层
    12. 导出移动应用程序和游戏引擎的动画
    13. 移动和复制对象
    14. 模板
    15. 在 Animate 中查找和替换
    16. 撤消、重做和历史记录面板
    17. 键盘快捷键
    18. 如何在 Animate 中使用时间轴
    19. 创建 HTML 扩展
    20. 图像和动画 GIF 的优化选项
    21. 图像和 GIF 的导出设置
    22. Animate 中的资源面板
  6. 多媒体与视频
    1. 在 Animate 中变形和合并图形对象
    2. 在 Animate 中创建并使用元件实例
    3. 图像描摹
    4. 如何在 Adobe Animate 中使用声音
    5. 导出 SVG 文件
    6. 创建用于 Animate 中的视频文件
    7. 如何在 Animate 中添加视频
    8. 使用视频提示点
    9. 使用 Animate 绘制和创建对象
    10. 改变线条和形状
    11. Animate CC 中的笔触、填充和渐变
    12. 使用 Adobe Premiere Pro 和 After Effects
    13. Animate CC 中的颜色面板
    14. 使用 Animate 打开 Flash CS6 文件
    15. 在 Animate 中使用传统文本
    16. 向 Animate 中置入图稿
    17. 在 Animate 中导入的位图
    18. 3D 图形
    19. 在 Animate 中使用元件
    20. 使用 Adobe Animate 绘制线条和形状
    21. 在 Animate 中使用库
    22. 导出声音
    23. 在 Animate CC 中选择对象
    24. 在 Animate 中使用 Illustrator AI 文件
    25. 使用喷涂刷工具应用图案
    26. 应用混合模式
    27. 排列对象
    28. 使用“命令”菜单自动处理任务
    29. 多语言文本
    30. 在 Animate 中使用摄像头
    31. 将 Animate 与 Adobe Scout 一起使用
    32. 使用 Fireworks 文件
    33. 图形滤镜
    34. 声音和 ActionScript
    35. 绘制首选参数
    36. 用钢笔工具绘图
  7. 平台
    1. 将 Animate 项目转换为其它文档类型格式
    2. 自定义平台支持
    3. 在 Animate 中创建和发布 HTML5 Canvas 文档
    4. 创建和发布 WebGL 文档
    5. 如何打包 AIR for iOS 应用程序
    6. 发布 AIR for Android 应用程序
    7. 发布用于桌面的 Adobe AIR
    8. ActionScript 发布设置
    9. 最佳做法 - 管理应用程序中的 ActionScript
    10. 如何在 Animate 中使用 ActionScript
    11. 最佳做法 - 辅助功能指南
    12. Animate 工作区中的辅助功能
    13. 编写和管理脚本
    14. 启用自定义平台支持
    15. 自定义平台支持概述
    16. 创建辅助内容
    17. 使用自定义平台支持插件
    18. 调试 ActionScript 3.0
    19. 启用自定义平台支持
  8. 导出和发布
    1. 如何从 Animate CC 导出文件
    2. OAM 发布
    3. 导出 SVG 文件
    4. 使用 Animate 导出图形和视频
    5. 发布 AS3 文档
    6. 导出移动应用程序和游戏引擎的动画
    7. 导出声音
    8. 导出 QuickTime 视频文件
    9. 使用 ActionScript 控制外部视频播放
    10. 最佳做法 - 移动设备内容创建技巧
    11. 最佳做法 - 视频惯例
    12. 最佳做法 - SWF 应用程序创作指南
    13. 最佳做法 - 构造 FLA 文件
    14. 在 Animate 中优化 FLA 文件的最佳做法
    15. ActionScript 发布设置
    16. 指定 Animate 的发布设置
    17. 导出放映文件
    18. 导出图像和动画 GIF
    19. HTML 发布模板
    20. 使用 Adobe Premiere Pro 和 After Effects
    21. 快速分享和发布动画

创建逐帧动画

在逐帧动画中,舞台中每帧的内容都有变化。它最适于图像在每一帧中都发生变化而不只是跨舞台移动的复杂动画。逐帧动画增加文件大小的速度比补间动画快得多。在逐帧动画中,Animate 会存储每个完整帧的值。

若要创建逐帧动画,请将每个帧都定义为关键帧,然后为每个帧创建不同的图像。每个新关键帧最初包含的内容和它前面的关键帧是一样的,因此可以递增地修改动画中的帧。

  1. 单击一个图层名称使之成为活动图层,然后在该图层中选择一个帧作为开始播放动画的帧。
  2. 如果该帧还不是关键帧,请选择“插入”>“时间轴”>“关键帧”。
  3. 在序列的第一个帧上创建插图。可以使用绘画工具、从剪贴板中粘贴图形或导入一个文件。
  4. 若要添加其内容和第一个关键帧中内容相同的关键帧,请单击同一行中右侧的下一个帧。选择“插入”>“时间轴”>“关键帧”,或者右键单击 (Windows) 或按住 Control 单击 (Macintosh),然后选择“插入关键帧”。

  5. 若要开发动画接下来的增量内容,请更改舞台上该帧的内容。
  6. 若要完成逐帧动画序列,请重复执行第 4 步和第 5 步,直到创建了所需的动作。
  7. 若要测试动画序列,请选择“控制”>“播放”或单击“控制器”(“窗口”>“工具栏”>“控制器”)上的“播放”按钮。

通过转换传统补间或补间动画创建逐帧动画

您可以将传统补间或补间动画范围转换为逐帧动画。逐帧动画中的每个帧都包含单独的关键帧(而非属性关键帧),其中的每个关键帧都包含单独的动画元件实例。逐帧动画不包含插补属性值。

  1. 右键单击 (Windows) 或按住 Ctrl 并单击 (Macintosh) 要转换的补间范围,然后从上下文菜单中选择“转换为逐帧动画”。

使用绘图纸外观

通常情况下,在某个时间舞台上仅显示动画序列的一个帧。为了辅助绘制、定位和编辑逐帧的动画,绘图纸外观可以通过在舞台上显示上一帧和下一帧的内容以提供参考。播放头下面的帧以全彩色显示,并采用不同的颜色和 Alpha 来区分过去和未来的帧。 

绘图纸外观的上一帧和下一帧采用默认的色调。要自定义这些颜色,请使用“高级设置”选项。

启用和禁用绘图纸外观

  • 单击“绘图纸外观”按钮 ,可启用和禁用绘图纸外观。
  • 要排除或纳入帧,可在时间轴标头中,右键单击绘图纸外观范围内的任意绘图纸外观帧。
  • 单击“绘图纸外观”按钮 并按住鼠标不放,可查看并选择相应选项。

绘图纸外观中的高级设置

单击“绘图纸外观”按钮 并按住鼠标不放,然后选择“高级设置”

自定义范围

自定义绘图纸外观显示的颜色

  1. 要自定义绘图纸外观帧的颜色,在“时间轴”栏中选择“绘图纸外观帧”
  2. 单击“绘图纸外观”按钮 并按住鼠标不放,然后选择“高级设置”
  3. 修改上一帧和下一帧的色调。

轮廓和填充模式

自定义不透明度

  1. 要调整当前帧两侧绘图纸外观帧的不透明度,请单击并拖动“起始不透明度”滑块。

  2. 如需按百分比减小每个绘图纸帧的变化量,请拖动“减少量”滑块。

仅显示关键帧

  1. 要自定义绘图纸外观帧的颜色,在“时间轴”栏中选择“绘图纸外观帧”
  2. 选择>“编辑”“首选参数”
  3. “绘图纸外观颜色”选项中,选择要自定义的颜色样本按钮,然后设置“过去”、“当前”和“未来”帧的颜色。

锚点标记

在舞台上同时查看动画的多个帧

单击“绘图纸外观”按钮 。在“起始绘图纸外观”和“结束绘图纸外观”标记(在时间轴标题中)之间的所有帧被重叠为“文档”窗口中的一个帧。

绘图纸外观标记

带颜色标记的绘图纸外观

绘图纸外观颜色标记能帮助您区分过去、当前和未来的帧。不与活动帧相挨的绘图纸外观帧的透明度会逐渐降低。

时间轴中的绘图纸外观

显示过去、当前和未来帧的带颜色标记的绘图纸外观

绘图纸外观轮廓模式

自定义绘图纸外观显示的颜色

  1. 要自定义绘图纸外观帧的颜色,在“时间轴”栏中选择“绘图纸外观帧”
  2. 选择>“编辑”“首选参数”
  3. “绘图纸外观颜色”选项中,选择要自定义的颜色样本按钮,然后设置“过去”、“当前”和“未来”帧的颜色。
注意:

颜色代码也适用于轮廓模式。

绘图纸外观时间轴模式

自定义的绘图纸外观

  • 要更改任一“绘图纸外观”标记的位置,将它的指针拖到一个新的位置。通常情况下,绘图纸外观标记和当前帧指针一起移动。按住 Control/Command 同时拖动鼠标可增加或减小两侧的控件的位置。
  • 若要编辑绘图纸外观标记之间的所有帧,请单击“编辑多个帧”按钮 。绘图纸外观通常只允许编辑当前帧。可以显示绘图纸外观标记之间每个帧的内容并进行编辑。
  • 要将时间轴中的循环范围移动到包括播放头位置的任一位置,可使用时间轴中的标记,按住 Shift 键并拖动范围。 
  • 要设置范围标记,可在时间轴中按住 Shift 键拖动范围标记或使用这些标记的循环范围。
     
注意:

启用绘图纸外观后,并不显示锁定图层(带有挂锁图标)。为避免出现大量使人感到混乱的图像,可锁定或隐藏不希望对其使用绘图纸外观的图层。

预览工作成果

要查看绘图纸外观的形成过程,可将鼠标悬停在时间轴的整个范围中。动画将在彩色的轮廓中播放,您可以精确预览各种变化。 

Adobe 徽标

登录到您的帐户