在 Animate 中选择对象

  1. Adobe Animate 用户指南
  2. Animate 简介
    1. Animate 新增功能
    2. 图示术语表
    3. Animate 系统要求
    4. Animate 键盘快捷键
    5. 在 Animate 中使用多种文件类型
  3. 动画
    1. Animate 动画基础知识
    2. 如何在 Animate 中使用帧和关键帧
    3. 在 Animate 中使用逐帧动画
    4. 如何在 Animate 中使用传统补间动画
    5. 画笔工具
    6. 运动辅助线
    7. 补间动画和 ActionScript 3.0
    8. 关于补间动画
    9. 补间动画
    10. 创建补间动画
    11. 使用属性关键帧
    12. 用补间对位置进行动画处理
    13. 如何使用动画编辑器编辑补间动画
    14. 编辑补间动画的运动路径
    15. 处理补间动画
    16. 添加自定义缓动
    17. 创建和应用动画预设
    18. 设置动画的补间范围
    19. 处理另存为 XML 文件的补间动画
    20. 补间动画与传统补间
    21. 形状补间
    22. 在 Animate 中使用骨骼工具动画
    23. 在 Animate 中处理角色 Rig
    24. 如何在 Adobe Animate 中使用遮罩层
    25. 如何在 Animate 中使用场景
  4. 交互性
    1. 如何使用 Animate 创建按钮
    2. 将 Animate 项目转换为其它文档类型格式
    3. 在 Animate 中创建和发布 HTML5 Canvas 文档
    4. 在 Animate 中通过代码片段添加交互性
    5. 创建自定义 HTML5 组件
    6. 使用 HTML5 Canvas 中的组件
    7. 创建自定义组件:示例
    8. 自定义组件的代码片段
    9. 最佳做法 - 使用 Animate 制作广告
    10. 虚拟现实创作和发布
  5. 工作区和工作流
    1. 创建和管理画笔
    2. 在 HTML5 Canvas 文档中使用 Google 字体
    3. 使用 Creative Cloud Libraries 和 Adobe Animate
    4. 使用 Animate 的舞台和工具面板
    5. Animate 工作流程和工作区
    6. 在 HTML5 Canvas 文档中使用 Web 字体
    7. 时间轴和 ActionScript
    8. 使用多个时间轴
    9. 设置首选参数
    10. 使用 Animate 创作面板
    11. 使用 Animate 创建时间轴图层
    12. 导出移动应用程序和游戏引擎的动画
    13. 移动和复制对象
    14. 模板
    15. 在 Animate 中查找和替换
    16. 撤消、重做和历史记录面板
    17. 键盘快捷键
    18. 如何在 Animate 中使用时间轴
    19. 创建 HTML 扩展
    20. 图像和动画 GIF 的优化选项
    21. 图像和 GIF 的导出设置
    22. Animate 中的资源面板
  6. 多媒体与视频
    1. 在 Animate 中变形和合并图形对象
    2. 在 Animate 中创建并使用元件实例
    3. 图像描摹
    4. 如何在 Adobe Animate 中使用声音
    5. 导出 SVG 文件
    6. 创建用于 Animate 中的视频文件
    7. 如何在 Animate 中添加视频
    8. 使用视频提示点
    9. 使用 Animate 绘制和创建对象
    10. 改变线条和形状
    11. Animate CC 中的笔触、填充和渐变
    12. 使用 Adobe Premiere Pro 和 After Effects
    13. Animate CC 中的颜色面板
    14. 使用 Animate 打开 Flash CS6 文件
    15. 在 Animate 中使用传统文本
    16. 向 Animate 中置入图稿
    17. 在 Animate 中导入的位图
    18. 3D 图形
    19. 在 Animate 中使用元件
    20. 使用 Adobe Animate 绘制线条和形状
    21. 在 Animate 中使用库
    22. 导出声音
    23. 在 Animate CC 中选择对象
    24. 在 Animate 中使用 Illustrator AI 文件
    25. 使用喷涂刷工具应用图案
    26. 应用混合模式
    27. 排列对象
    28. 使用“命令”菜单自动处理任务
    29. 多语言文本
    30. 在 Animate 中使用摄像头
    31. 将 Animate 与 Adobe Scout 一起使用
    32. 使用 Fireworks 文件
    33. 图形滤镜
    34. 声音和 ActionScript
    35. 绘制首选参数
    36. 用钢笔工具绘图
  7. 平台
    1. 将 Animate 项目转换为其它文档类型格式
    2. 自定义平台支持
    3. 在 Animate 中创建和发布 HTML5 Canvas 文档
    4. 创建和发布 WebGL 文档
    5. 如何打包 AIR for iOS 应用程序
    6. 发布 AIR for Android 应用程序
    7. 发布用于桌面的 Adobe AIR
    8. ActionScript 发布设置
    9. 最佳做法 - 管理应用程序中的 ActionScript
    10. 如何在 Animate 中使用 ActionScript
    11. 最佳做法 - 辅助功能指南
    12. Animate 工作区中的辅助功能
    13. 编写和管理脚本
    14. 启用自定义平台支持
    15. 自定义平台支持概述
    16. 创建辅助内容
    17. 使用自定义平台支持插件
    18. 调试 ActionScript 3.0
    19. 启用自定义平台支持
  8. 导出和发布
    1. 如何从 Animate CC 导出文件
    2. OAM 发布
    3. 导出 SVG 文件
    4. 使用 Animate 导出图形和视频
    5. 发布 AS3 文档
    6. 导出移动应用程序和游戏引擎的动画
    7. 导出声音
    8. 导出 QuickTime 视频文件
    9. 使用 ActionScript 控制外部视频播放
    10. 最佳做法 - 移动设备内容创建技巧
    11. 最佳做法 - 视频惯例
    12. 最佳做法 - SWF 应用程序创作指南
    13. 最佳做法 - 构造 FLA 文件
    14. 在 Animate 中优化 FLA 文件的最佳做法
    15. ActionScript 发布设置
    16. 指定 Animate 的发布设置
    17. 导出放映文件
    18. 导出图像和动画 GIF
    19. HTML 发布模板
    20. 使用 Adobe Premiere Pro 和 After Effects
    21. 快速分享和发布动画

了解如何使用 Animate 中的选取工具

在 Animate 中,您可以使用指针、部分选取和套索工具来选择对象。选择对象或笔触时,Animate 会用选取框来加亮显示它们。可以只选择对象的笔触,也可以只选择其填充。 可以隐藏选区的加亮显示,这样,在编辑对象时就不会看到加亮显示。

指针、部分选取和套索工具

套索工具的功能键

工具

图标

说明

选取工具 (V)

使用此工具可选择一个整个的对象。单击或拖动对象时,其周围会显示一个矩形选框。 

部分选取工具 (A)

使用此工具可改变动画的运动路径。您可以看到路径上对应于每个位置属性关键帧的控制点和贝塞尔手柄。 

套索工具 (L)

使用此工具可为对象创建一个不规则的选区轮廓。 

多边形工具 (L)

使用此工具可定义一个一系列连续直线构成的选区。要选取此工具,可使套索工具保持在选定状态,然后单击多边形工具。 

魔棒工具 (L)

使用此工具可选择具有相同或类似颜色的位图图形区。要选取此工具,可使套索工具保持在选定状态,然后单击魔棒工具。

修改对象

要修改对象,需要先选中它。您可以将若干个单个对象组成一组,然后作为一个对象来处理。修改线条和形状会改变同一图层中的其他线条和形状。若要防止选中组或元件并意外修改它,请锁定组或元件。

修改对象的属性

您可以使用属性检查器修改对象的笔触和填充属性。当您选择了某个对象时,“属性”检查器会显示以下内容:

  • 对象的笔触和填充、像素尺寸以及对象的变形点的 xy 坐标。
  • 混合选择(如果选择了多个项目)。所选项目组的像素尺寸以及 x 和 y 坐标。

用选取工具选择对象

使用选取工具 可以选择全部对象,方法是单击某个对象或拖动对象,便可将其围在一个矩形选框内。要选择实例、组和文本块,必须将它们围起来。 

注意:

要选择选取工具,还可以按下 V 键。要在其他工具处于活动状态时临时切换到选取工具,请按下 Control 键 (Windows) 或 Command 键 (Macintosh)。有关更多信息,请参阅键盘快捷键。 

要禁用 Shift 键选择功能,可以在 Animate 的常规首选参数中取消选择该选项。请参阅设置 Animate 中的首选参数

选择对象

  • 若要选择笔触、填充、组、实例或文本块,请单击对象。
  • 若要选择连接线,请双击其中一条线。
  • 若要选择填充的形状及其笔触轮廓,请双击填充。
  • 若要选择矩形区域内的对象,请在要选择的一个或多个对象周围拖画出一个选取框。
选取更多对象
  • 若要向选择中添加内容,请按住 Shift 键选取更多对象。
  • 若要选择场景每一层的全部内容,请选择“选择”>“全选”,或者按 Ctrl+A (Windows) 或 Command+A (Macintosh)。“全选”不会选中被锁定、被隐藏或者不在当前时间轴中的图层上的对象。
  • 若要选择一层中关键帧之间的全部内容,请单击时间轴中的一个帧。

全部取消选择

若要取消选择每一层上的全部内容,请选择“编辑”>“取消全选”,或者按下 Control+Shift+A (Windows) 或 Command+Shift+A (Macintosh)。有关更多信息,请参阅键盘快捷键。 

取消选择单个项

若要取消选择一组选定对象中的任一单个项:

  1. 选择选取工具
  2. 按住 Shift 键 
  3. 单击此单个项

单个项可以是任何笔触、填充或绘制对象。 

锁定/解锁

若要锁定或解锁组或元件,请选择组或元件,然后选择“修改”>“排列”>“锁定”。选择“修改”>“排列”>“解除全部锁定”可以解锁所有锁定的组和元件。

使用套索工具绘制不规则选区

您可以使用套索工具来创建一个不规则的选区轮廓。从“工具”中选择它或按 L。根据您设置的首选参数,要选取一个对象,可以选择围住绘制对象或是部分围住它。有关更多信息,请参阅本文中的设置用于选择的首选参数部分。  

  1. 在对象区域周围拖动套索工具 。若要选择对象的内圈,可在其周围拖动不规则套索工具。

  2. 在开始位置附近结束拖动,形成一个环,或者让 Animate 自动闭合成环。Animate 将闭合选区轮廓并加亮显示选中的对象。 

使用套索的多边形工具绘制一个直边选区

使用套索工具的多边形模式功能键,可以定义一个一系列连续直线构成的选区。使套索工具保持在选定状态,然后单击多边形工具。 

  1. 在“工具”面板的选项区中选择套索工具的“多边形模式”功能键

  2. 要设置起始点,单击对象。 

  3. 将指针放在第一条线要结束的地方,然后单击该位置。继续设定其他线段的结束点。

  4. 要闭合选区,双击最后的位置。Animate 将闭合选区轮廓并加亮显示选中的对象。 

绘制一个包含不规则和直边的选区

在使用“套索”工具及其“多边形模式”功能键时,可以在不规则和直边选择模式之间切换。

  1. 取消选择“套索”工具的“多边形模式”功能键。
  2. 要画一条不规则线段,请在舞台上拖动“套索”工具。
  3. 若要设置每条新线段的起点和终点,请按住 Alt 键 (Windows) 或 Option 键 (Macintosh),然后单击该区域。 

    使用此步骤可绘制直边段。 

  4. 要闭合选区,请执行下列操作之一:
    • 松开鼠标按钮。Animate 将闭合选区。 

    • 双击选区线的起始端。

隐藏选区的加亮显示

要查看图稿的最终显示效果,可以在选择和编辑对象时隐藏其加亮显示效果。 

  1. 选择“视图”>“隐藏边缘”。

再次选择“隐藏边缘”选项便可使选区加亮显示。

为所选对象设置自定义边框颜色

您可以自定义舞台上所选对象周围显示的矩形边框的颜色。

  1. 选择“编辑”>“首选参数”(Windows) 或“Animate”>“首选参数”(Macintosh)。

  2. 单击“常规”类别。
  3. 在“加亮颜色”部分中,为每种类型的对象选择一种颜色,然后单击“确定”。

设置用于选择的首选参数

使用指针、部分选取和套索工具选择对象时,只需单击对象即可。使用指针和部分选取工具选择对象时,只需拖动对象周围的矩形选取框即可。使用套索工具选择对象时,只需拖动对象周围的自由形状的选取框即可。选取一个对象后,对象周围会出现一个矩形框。

  1. 选择“编辑”>“首选参数”(Windows) 或“Animate”>“首选参数”(Macintosh)。

  2. 在“首选参数”对话框的“常规”类别中,请执行下列操作之一:
    • 若想仅选择被包围起来的对象和点,请取消选择“接触即选取”和套索工具。位于选择区域内的点会被选中。

    • 若想选择被部分包围起来的对象或组,请选择“接触即选取”和套索工具。

Adobe 徽标

登录到您的帐户