将对象变形

使用“任意变形”工具或“修改”>“变形”菜单中的选项,可以将图形对象以及组、文本块和实例进行变形。根据所选元素的类型,可以变形、旋转、倾斜、缩放或扭曲该元素。 在变形操作期间,可以更改或添加选择内容。

在对对象、组、文本框或实例进行变形时,该项目的“属性”检查器会显示对该项目的尺寸或位置所做的任何更改。

在涉及拖动的变形操作期间会显示一个边框。 该边框是一个矩形(除非用“扭曲”命令或“封套”功能键修改过),矩形的边缘最初与舞台的边缘平行对齐。变形手柄位于每个角和每个边的中点。在拖动时,边框可以预览变形。

移动、重新对齐、更改和跟踪变形点

在变形期间,所选元素的中心会出现一个变形点。 变形点最初与对象的中心点对齐。 您可以移动变形点,将其返回到它的默认位置以及移动默认原点。

对于缩放、倾斜或者旋转图形对象、组和文本块,默认情况下,与被拖动的点相对的点就是原点。 对于示例,默认情况下,变形点是原点。您可以移动变形的默认原点。

  1. 选择任意变形工具 ,或从“修改”>“变形”命令中选择一个。

    开始进行变形之后,您可以在“信息”面板和“属性”检查器中跟踪变形点的位置。

  2. 请执行下列操作之一:
    • 若要移动变形点,请在所选图形对象中拖动变形点。

    • 若要使变形点与元素的中心点重新对齐,请双击变形点。

    • 若要切换缩放或倾斜变形的原点,请在变形期间拖动所选对象控制点的同时按住 Alt 键 (Windows) 或 Option 键 (Macintosh)。

    • 在“信息”面板中,您可以切换注册点和变形点的显示。按钮显示为 ,表示显示的是注册点坐标。单击此按钮后,它会变为 ,表示显示的是变形点坐标。

    dr_info_panel
    坐标网格;“信息”面板,其中包含处于变形模式的“注册/变形点”按钮,并显示选区变形点的 x 和 y 坐标。

使用任意变形工具

可以单独执行某个变形操作,也可以将诸如移动、旋转、缩放、倾斜和扭曲等多个变形操作组合在一起执行。

注意:

“任意变形”工具不能变形元件、位图、视频对象、声音、渐变或文本。 如果多项选择包含以上任意一项,则只有形状对象被扭曲。要将文本块变形,首先要将字符转换成形状对象。

  1. 在舞台上选择图形对象、组、实例或文本块。
  2. 单击“任意变形”工具

    在所选内容的周围移动指针,指针会发生变化,指明哪种变形功能可用。

  3. 若要使所选内容变形,请拖动手柄:
    • 要移动所选内容,将指针放在边框内的对象上,然后将该对象拖动到新位置。 不要拖动变形点。

    • 要设置旋转或缩放的中心,请将变形点拖到新位置。

    • 要旋转所选内容,将指针放在角手柄的外侧,然后拖动。 所选内容即可围绕变形点旋转。 按住 Shift 并拖动可以以 45 度为增量进行旋转。

    • 若要围绕对角旋转,请在按住 Alt (Windows) 或 Option (Macintosh) 的同时拖动。

    • 要缩放所选内容,沿对角方向拖动角手柄可以沿着两个方向缩放尺寸。 按住 Shift 键拖动可以按比例调整大小。

    • 水平或垂直拖动角手柄或边手柄可以沿各自的方向进行缩放。

    • 要倾斜所选内容,将指针放在变形手柄之间的轮廓上,然后拖动。

    • 要扭曲形状,按住 Control 键 (Windows) 或按住 Command 键 (Macintosh) 拖动角手柄或边手柄。

    • 若要锥化对象,将所选的角及其相邻角从它们的原始位置一起移动相同的距离,请同时按住 Shift 和 Ctrl (Windows) 或者 Shift 和 Command (Macintosh),并单击和拖动角手柄。

  4. 若要结束变形操作,请单击所选项目以外的地方。

扭曲对象

对选定的对象进行扭曲变形时,可以拖动边框上的角手柄或边手柄,移动该角或边,然后重新对齐相邻的边。 若要将扭曲限制为锥化,请按住 Shift 拖动角点,这会将该角和相邻角在相反的方向上移动相等的距离。相邻角是指拖动方向所在的轴上的角。 按住 Ctrl (Windows) 或 Command (Macintosh) 拖动边缘上的中间点以自由移动整个边缘。

您可以使用“扭曲”命令扭曲图形对象。 还可以在将对象进行任意变形时扭曲它们。

注意:

“扭曲”命令不能修改元件、图元形状、位图、视频对象、声音、渐变、对象组或文本。如果多项选区包含以上任意一项,则只能扭曲形状对象。若要修改文本,首先要将字符转换为形状对象。

  1. 在舞台上选择一个或多个图形对象。
  2. 选择“修改”>“变形”>“扭曲”

  3. 将指针放到某个变形手柄上然后拖动。
  4. 若要结束变形操作,请单击所选择的一个或多个对象以外的地方。

用封套功能键修改形状

“封套”功能键允许您弯曲或扭曲对象。 封套是一个边框,其中包含一个或多个对象。 更改封套的形状会影响该封套内的对象的形状。 您可以通过调整封套的点和切线手柄来编辑封套形状。

注意:

“封套”功能键不能修改元件、位图、视频对象、声音、渐变、对象组或文本。 如果多项选区包含以上任意一项,则只能扭曲形状对象。若要修改文本,首先要将字符转换为形状对象。

  1. 在舞台上选择形状。
  2. 选择“修改”>“变形”>“封套”

  3. 拖动点和切线手柄修改封套。

缩放对象

缩放对象时可以沿水平方向、垂直方向或同时沿两个方向放大或缩小对象。

  1. 在舞台上选择一个或多个图形对象。

  2. 选择“修改”>“变形”>“缩放”

  3. 请执行下列操作之一:
    • 要沿水平和垂直方向缩放对象,请拖动某个角手柄。 缩放时长宽比例仍旧保持不变。 按住 Shift 键拖动可以进行不一致缩放。

    dr_scale
    • 要沿水平或垂直方向缩放对象,请拖动中心手柄。

    dr_scale2
  4. 若要结束变形操作,请单击所选择的一个或多个对象以外的地方。

    注意:

    在同时增加多个项目的大小时,边框边缘附近的项目可能移动到舞台外面。如果出现这种问题,请选择“视图”>“剪贴板”以查看超出舞台边缘的元素。

使对象旋转和倾斜

旋转对象会使该对象围绕其变形点旋转。 变形点与注册点对齐,默认位于对象的中心,但您可以通过拖动来移动该点。

可以通过以下方法旋转对象:

  • 使用“任意变形”工具 拖动(可以在同一操作中倾斜和缩放对象)。

  • 通过在“变形”面板中指定角度(可以在同一操作中缩放对象)。

通过拖动旋转和倾斜对象

  1. 在舞台上选择一个或多个对象。
  2. 选择“修改”>“变形”>“旋转与倾斜”

  3. 请执行下列操作之一:
    • 拖动角手柄旋转对象。

    • 拖动中心手柄倾斜对象。

  4. 若要结束变形操作,请单击所选择的一个或多个对象以外的地方。

将对象旋转 90 度

  1. 选择一个或多个对象。
  2. 选择“修改”>“变形”>“顺时针旋转 90 度”进行顺时针旋转,或选择“逆时针旋转 90 度”进行逆时针旋转。

倾斜对象

倾斜对象可以通过沿一个或两个轴倾斜对象来使之变形。 您可以通过拖动或在“变形”面板中输入值来倾斜对象。

  1. 选择一个或多个对象。
  2. 选择“窗口”>“变形”

  3. 单击“倾斜”。
  4. 输入水平和垂直角度值。

翻转对象

您可以沿垂直或水平轴翻转对象,而不改变其在舞台上的相对位置。

  1. 选择对象。
  2. 选择“修改”>“变形”>“垂直翻转”或“水平翻转”

还原变形对象

在使用任意变形工具或“变换”面板缩放、旋转和倾斜实例、组和文本时,Animate 会保存对象的原大小和旋转值。这使您可以删除已应用的变形并复位到原始值。

当选择“编辑”>“撤消”时,您仅可以撤消最近的变换。在取消选择对象之前,单击面板中的“取消变换”按钮可以取消所有变换。在取消选择对象后,原始值将丢失,变形将无法取消。

将变形的对象还原到原始状态

  1. 请确保变形的对象仍然处于选中状态。

  2. 请执行下列操作之一:
    • 在“变形”面板中单击“取消变形”按钮 

    • 选择“修改”>“变形”>“取消变形”

用于矢量和栅格内容的雕刻资源

Animate 19.0 版本引入了一个新的资源变形工具。可以使用该资源变形工具在 Animate 中的形状、绘制对象和位图上创建变形手柄。通过使用该资源变形工具拖动变形手柄,可以使形状、绘制对象和位图变形。 

资源变形工具
资源变形工具

使用对象上显示的变形手柄,可以在保持其他区域不受影响的同时,调整或扭曲特定对象区域的形状。在创建第一个变形手柄时,将对所有选定对象进行分组。在插入关键帧时,前一关键帧中的变形手柄将被复制到新的关键帧。

以下所示为使用资源变形工具将鼠标悬停在对象上时出现的部分光标样式,供您参考。

aw21

当对象不支持资源变形工具时,将显示此光标。


aw3

- 此光标表示您可以使用资源变形工具在对象上创建变形手柄。


aw4

- 此光标表示您可以单击变形手柄来改变对象的形状。


Cur_MoveRotate_1_1@2x

此光标表示您可以旋转对象。


使用资源变形工具

  1. 首先,在舞台上创建一个形状或导入一个位图图像。 

  2. 单击工具栏中的资源变形工具。

  3. 将鼠标悬停在形状或绘制对象上时,将出现 符号。然后单击即可添加变形手柄。

    将鼠标悬停在形状或绘制对象上
    将鼠标悬停在形状或绘制对象上
  4. 在形状/绘图对象上,资源变形手柄显示为小的实心圆形。您可以使用尽可能多的手柄来有效地完成形状变形。使用键盘上的 Delete 键删除人偶变形手柄。

    资源变形手柄
    资源变形手柄
  5. 按住 Shift 键并单击人偶变形手柄可选择多个手柄。您可以用资源变形工具拖动手柄,以根据需要使形状变形。

    使用手柄将形状变形
    使用手柄将形状变形
  6. 从两种与变形手柄关联的模式中任选其一。

        a.    开放模式 - 此模式在变形时支持更大的手柄自由度。此模式中的手柄显示为白色实心圆形。

        b.   固定模式 - 此模式在变形时支持较小的手柄自由度。此模式中的手柄显示为黑色实心圆形。

    要在两种模式之间切换,请在按住 Alt 键单击变形手柄。

资源变形教程

资源变形教程
矢量或栅格,使用全新的资源变形工具操作您的角色并轻松创建动画。

编辑基础形状

基础形状是在应用任何变形之前的形状。资源变形作用于基础形状顶部覆盖的网格。您还可以通过切换到选择工具,然后双击已变形的形状来修改基础形状。在基础形状上所做的任何修改都将应用于该形状的所有变形实例。此功能仅适用于矢量形状。

资源变形形状属性
资源变形形状属性

资源变形工具的补间

对于“资源变形”工具,您可以使用传统补间。例如,可以应用“传统补间”为人偶姿势创建补间。 

单击此处了解与传统补间相关的更多信息。

注意:

要为姿势创建补间,应在形状中使用相同的一组手柄。

合并对象

若要通过合并或改变现有对象来创建新形状,请使用“修改”菜单中的“合并对象”命令(“修改”>“合并对象”)。有时,所选对象的堆叠顺序决定了操作方式。

每个命令都应用于特定类型的图形对象,后面将会对这些命令进行说明。合并形状是用设置为合并绘制模式的工具所绘制的形状。绘制对象是用设置为对象绘制模式的工具所绘制的形状。

“合并对象”命令有:

联合

合并两个或多个合并形状或绘制对象。将生成一个“对象绘制”模式形状,它由联合前形状上所有可见的部分组成。将删除形状上不可见的重叠部分。

 

注意:

与使用“组”命令(“修改”>“组”)时不同的是,使用“联合”命令结合在一起的形状无法分离。

交集

创建是两个或多个绘制对象的交集的对象。生成的“对象绘制”形状由合并的形状的重叠部分组成。 将删除形状上任何不重叠的部分。 生成的形状使用堆叠中最上面的形状的填充和笔触。

打孔

删除选定绘制对象的某些部分,这些部分由该对象与排在该对象前面的另一个选定绘制对象的重叠部分定义。将删除绘制对象中由最上面的对象所覆盖的所有部分,并完全删除最上面的对象。所得到的对象仍是独立的,不会合并为单个对象(不同于可将多个对象合并在一起的“联合”或“交集”命令)。

裁切

使用一个绘制对象的轮廓裁切另一个绘制对象。前面或最上面的对象定义裁切区域的形状。将保留下层对象中与最上面的对象重叠的所有部分,而删除下层对象的所有其他部分,并完全删除最上面的对象。所得到的对象仍是独立的,不会合并为单个对象(不同于可合并多个对象的“联合”或“交集”命令)。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略