如何在 Animate 中使用场景

  1. Adobe Animate 用户指南
  2. Animate 简介
    1. Animate 新增功能
    2. 图示术语表
    3. Animate 系统要求
    4. Animate 键盘快捷键
    5. 在 Animate 中使用多种文件类型
  3. 动画
    1. Animate 动画基础知识
    2. 如何在 Animate 中使用帧和关键帧
    3. 在 Animate 中使用逐帧动画
    4. 如何在 Animate 中使用传统补间动画
    5. 画笔工具
    6. 运动辅助线
    7. 补间动画和 ActionScript 3.0
    8. 关于补间动画
    9. 补间动画
    10. 创建补间动画
    11. 使用属性关键帧
    12. 用补间对位置进行动画处理
    13. 如何使用动画编辑器编辑补间动画
    14. 编辑补间动画的运动路径
    15. 处理补间动画
    16. 添加自定义缓动
    17. 创建和应用动画预设
    18. 设置动画的补间范围
    19. 处理另存为 XML 文件的补间动画
    20. 补间动画与传统补间
    21. 形状补间
    22. 在 Animate 中使用骨骼工具动画
    23. 在 Animate 中处理角色 Rig
    24. 如何在 Adobe Animate 中使用遮罩层
    25. 如何在 Animate 中使用场景
  4. 交互性
    1. 如何使用 Animate 创建按钮
    2. 将 Animate 项目转换为其它文档类型格式
    3. 在 Animate 中创建和发布 HTML5 Canvas 文档
    4. 在 Animate 中通过代码片段添加交互性
    5. 创建自定义 HTML5 组件
    6. 使用 HTML5 Canvas 中的组件
    7. 创建自定义组件:示例
    8. 自定义组件的代码片段
    9. 最佳做法 - 使用 Animate 制作广告
    10. 虚拟现实创作和发布
  5. 工作区和工作流
    1. 创建和管理画笔
    2. 在 HTML5 Canvas 文档中使用 Google 字体
    3. 使用 Creative Cloud Libraries 和 Adobe Animate
    4. 使用 Animate 的舞台和工具面板
    5. Animate 工作流程和工作区
    6. 在 HTML5 Canvas 文档中使用 Web 字体
    7. 时间轴和 ActionScript
    8. 使用多个时间轴
    9. 设置首选参数
    10. 使用 Animate 创作面板
    11. 使用 Animate 创建时间轴图层
    12. 导出移动应用程序和游戏引擎的动画
    13. 移动和复制对象
    14. 模板
    15. 在 Animate 中查找和替换
    16. 撤消、重做和历史记录面板
    17. 键盘快捷键
    18. 如何在 Animate 中使用时间轴
    19. 创建 HTML 扩展
    20. 图像和动画 GIF 的优化选项
    21. 图像和 GIF 的导出设置
    22. Animate 中的资源面板
  6. 多媒体与视频
    1. 在 Animate 中变形和合并图形对象
    2. 在 Animate 中创建并使用元件实例
    3. 图像描摹
    4. 如何在 Adobe Animate 中使用声音
    5. 导出 SVG 文件
    6. 创建用于 Animate 中的视频文件
    7. 如何在 Animate 中添加视频
    8. 使用视频提示点
    9. 使用 Animate 绘制和创建对象
    10. 改变线条和形状
    11. Animate CC 中的笔触、填充和渐变
    12. 使用 Adobe Premiere Pro 和 After Effects
    13. Animate CC 中的颜色面板
    14. 使用 Animate 打开 Flash CS6 文件
    15. 在 Animate 中使用传统文本
    16. 向 Animate 中置入图稿
    17. 在 Animate 中导入的位图
    18. 3D 图形
    19. 在 Animate 中使用元件
    20. 使用 Adobe Animate 绘制线条和形状
    21. 在 Animate 中使用库
    22. 导出声音
    23. 在 Animate CC 中选择对象
    24. 在 Animate 中使用 Illustrator AI 文件
    25. 使用喷涂刷工具应用图案
    26. 应用混合模式
    27. 排列对象
    28. 使用“命令”菜单自动处理任务
    29. 多语言文本
    30. 在 Animate 中使用摄像头
    31. 将 Animate 与 Adobe Scout 一起使用
    32. 使用 Fireworks 文件
    33. 图形滤镜
    34. 声音和 ActionScript
    35. 绘制首选参数
    36. 用钢笔工具绘图
  7. 平台
    1. 将 Animate 项目转换为其它文档类型格式
    2. 自定义平台支持
    3. 在 Animate 中创建和发布 HTML5 Canvas 文档
    4. 创建和发布 WebGL 文档
    5. 如何打包 AIR for iOS 应用程序
    6. 发布 AIR for Android 应用程序
    7. 发布用于桌面的 Adobe AIR
    8. ActionScript 发布设置
    9. 最佳做法 - 管理应用程序中的 ActionScript
    10. 如何在 Animate 中使用 ActionScript
    11. 最佳做法 - 辅助功能指南
    12. Animate 工作区中的辅助功能
    13. 编写和管理脚本
    14. 启用自定义平台支持
    15. 自定义平台支持概述
    16. 创建辅助内容
    17. 使用自定义平台支持插件
    18. 调试 ActionScript 3.0
    19. 启用自定义平台支持
  8. 导出和发布
    1. 如何从 Animate CC 导出文件
    2. OAM 发布
    3. 导出 SVG 文件
    4. 使用 Animate 导出图形和视频
    5. 发布 AS3 文档
    6. 导出移动应用程序和游戏引擎的动画
    7. 导出声音
    8. 导出 QuickTime 视频文件
    9. 使用 ActionScript 控制外部视频播放
    10. 最佳做法 - 移动设备内容创建技巧
    11. 最佳做法 - 视频惯例
    12. 最佳做法 - SWF 应用程序创作指南
    13. 最佳做法 - 构造 FLA 文件
    14. 在 Animate 中优化 FLA 文件的最佳做法
    15. ActionScript 发布设置
    16. 指定 Animate 的发布设置
    17. 导出放映文件
    18. 导出图像和动画 GIF
    19. HTML 发布模板
    20. 使用 Adobe Premiere Pro 和 After Effects
    21. 快速分享和发布动画

要按主题组织文档,可以使用场景。例如,可以使用单独的场景用于简介、出现的消息以及片头片尾字幕。尽管使用场景有一些缺陷,在某些情况下(例如创作长篇幅动画时),这些缺陷几乎不会出现。在使用场景时,不再必须管理大量的 FLA 文件,因为每个场景都包含在单个 FLA 文件中。

使用场景类似于使用几个 FLA 文件一起创建一个较大的演示文稿。每个场景都有一个时间轴。文档中的帧都是按场景顺序连续编号的。例如,如果文档包含两个场景,每个场景有十帧,则场景 2 中的帧的编号为 11 到 20。文档中的各个场景将按照“场景”面板中所列的顺序进行播放。当播放头到达一个场景的最后一帧时,播放头将前进到下一个场景。

场景的缺点

发布 SWF 文件时,每个场景的时间轴会合并为 SWF 文件中的一个时间轴。将该 SWF 文件编译后,其行为方式与使用一个场景创建的 FLA 文件相同。由于这种行为,场景会存在一些缺点:

  • 场景会使文档的编辑变得混乱,尤其是在多作者环境中。任何使用该 FLA 文档的人员可能都需要在一个 FLA 文件内搜索多个场景来查找代码和资源。请考虑改为加载外部 SWF 内容或使用影片剪辑。

  • 场景通常会导致 SWF 文件很大。使用场景会使您倾向于将更多的内容放在一个 FLA 文件中,从而产生更大的 FLA 文件和 SWF 文件。

  • 场景将强迫用户连续下载整个 SWF 文件,即使用户不愿或不想观看全部文件。如果不使用场景,则用户可以在浏览 SWF 文件的过程中控制想要下载的内容。

  • 与 ActionScript 结合的场景可能会产生意外的结果。 因为每个场景时间轴都压缩至一个时间轴,所以可能会遇到涉及 ActionScript 和场景的错误,这通常需要进行额外的复杂调试。

控制场景播放

要在每个场景之后停止或暂停文档,或允许用户以非线性方式浏览文档,可以使用 ActionScript。有关详细信息,请参阅 ActionScript

显示场景面板

  1. 选择“窗口”>“其他面板”>“场景”。

添加场景

  1. 选择“插入”>“场景”,或单击“场景”面板中的“添加场景”按钮

删除场景

  1. 单击“场景”面板中的“删除场景”按钮

更改场景的名称

  1. 在“场景”面板中双击场景名称,然后输入新名称。

重制场景

  1. 单击“场景”面板中的“直接重制场景”按钮

更改文档中场景的顺序

  1. 在“场景”面板中将场景名称拖到不同的位置。

查看特定场景

  1. 请执行下列操作之一:
    • 选择“视图”>“转到”,然后从子菜单中选择场景的名称。

    • 单击文档窗口右上角的“编辑场景”按钮,并从弹出菜单中选择场景名称。

Adobe 徽标

登录到您的帐户