概述

Adobe Animate 提供多种使用声音的方式。可以使声音独立于时间轴连续播放,或使用时间轴将动画与音轨保持同步。向按钮添加声音可以使按钮具有更强的互动性,通过声音淡入淡出还可以使音轨更加优美。

Animate 中有两种声音类型:事件声音和流声音(音频流)。事件声音必须完全下载后才能开始播放,除非明确停止,否则它将一直连续播放。 音频流在前几帧下载了足够的数据后就开始播放;音频流要与时间轴同步以便在网站上播放。

如果要为移动设备创建 Animate 内容,则 Animate 还会允许您在发布的 SWF 文件中包含设备声音。设备声音以设备本身支持的音频格式编码,如 MIDI、MFi、或 SMAF。

您可以使用共享库将声音链接到多个文档。 您还可以使用 ActionScript® 2.0 onSoundComplete 事件或 ActionScript® 3.0 soundComplete 事件,在一个声音完成后触发一个事件。

并且您可以使用预先编写的行为或媒体组件来加载声音和控制声音播放;后者(媒体组件)还提供了用于停止、暂停、后退等动作的控制器。 您也可以使用 ActionScript 2.0 或 3.0 动态加载声音。

有关详细信息,请参阅《ActionScript 2.0 语言参考》中的 attachSound(Sound.attachSound 方法)loadSound(Sound.loadSound 方法)《ActionScript 3.0 语言和组件参考》中的 Sound 类

注意:

Animate CC 不支持 ActionScript 2.0 和 ActionScript 1.0。

导入声音

您可以通过将声音文件导入库中或直接导入舞台中的方式,将声音放入 Animate 中。

“文件”>“导入”>“导入到库”菜单选项只是将音频放入库中,而不会将其放到时间轴中。

使用“文件”>“导入”>“导入到舞台”菜单选项或通过将音频文件直接拖放到时间轴的方式导入音频文件时,音频将被放到活动层的活动帧上。拖放多个音频文件时,将只导入一个音频文件,因为一个帧只能包含一个音频。 

要导入音频,可使用以下一种方法:

  • 要将音频文件导入库中,可选择“文件”>“导入”>“导入到库”,然后选择要导入的文件。
  • 要将音频文件导入舞台中,可选择“文件”>“导入”>“导入到舞台”,然后选择要导入的文件。 
  • 将音频文件直接拖放到舞台中。
import-sounds

注意:

也可以将声音从公用库拖入当前文档的库中。

Animate 在库中保存声音以及位图和元件。您只需声音文件的一个副本就可以在文档中以多种方式使用这个声音。

如果想在 Animate 文档之间共享声音,则可以把声音包含在共享库中。

Animate 提供一个“声音”库,其中包含可用作效果的多种有用的声音。若要打开“声音”库,请选择“窗口”>“公用库”>“声音”。若要将“声音”库中的某种声音导入 Animate 文件中,请将此声音从“声音”库中拖动到 Animate 文件的“库”面板。也可以将“声音”库中的声音拖动到其他共享库。

声音要使用大量的磁盘空间和 RAM。 但是,mp3 声音数据经过了压缩,比 WAV 或 AIFF 声音数据小。 通常,使用 WAV 或 AIFF 文件时,最好使用 16-22 kHz 单声(立体声使用的数据量是单声的两倍),但是 Animate 可以导入采样比率为 11 kHz、22 kHz 或 44 kHz 的 8 位或 16 位的声音。 将声音导入 Animate 时,如果声音的记录格式不是 11 kHz 的倍数(例如 8、32 或 96 kHz),将会重新采样。在导出时,Animate 会把声音转换成采样率更低的声音。

如果要向 Animate 中添加声音效果,最好导入 16 位声音。如果 RAM 有限,应使用短的声音剪辑或用 8 位声音而不是 16 位声音。

注意:

要在 Animate 中导入或播放声音,无需预先安装 QuickTime 或 iTunes。

支持的声音文件格式

可以将以下声音文件格式导入 Animate 中:

  • Adobe 声音 (.asnd)这是 Adobe® Soundbooth™ 本身的声音格式。

  • Wave (.wav)

  • AIFF (.aif, .aifc)

  • mp3

    还可以导入以下声音文件格式:

  • Sound Designer® II (.sd2)

  • Sun AU (.au, .snd)

  • FLAC (.flac)

  • Ogg Vorbis (.ogg, .oga)

注意:

  • ASND 格式是 Adobe Soundbooth 的本机音频文件格式,具有非破坏性。ASND 文件可以包含应用了效果的音频数据(稍后可对效果进行修改)、Soundbooth 多轨道会话和快照(允许您回复到 ASND 文件的前一状态)。
  • WebGL 和 HTML5 Canvas 文档类型仅支持 MP3 和 WAV 格式。

添加动画的声音

直接将计算机中的声音添加到时间轴

使用以下一种方法,可以直接将计算机中的音频导入时间轴中:

  • 选择“文件”>“导入”>“导入到舞台”,然后选择要导入的音频文件。
  • 将音频文件拖放到舞台/时间轴。 

注意,系统一次只能添加一个音频文件。拖放多个音频文件时,系统只会将一个音频文件导入时间轴。

将库中的声音添加到时间轴

您可以使用库将声音添加至文档,或者可以在运行时使用 Sound 对象的 loadSound 方法将声音加载至 SWF 文件。 有关详细信息,请参阅《ActionScript 3.0 参考》中的 Sound 类

  1. 如果还没有将声音导入库中,请将其导入库中。
  2. 选择“插入”>“时间轴”>“图层”

    timeline-layer
  3. 选定新建的声音层后,将声音从“库”面板中拖到舞台中。 声音就会添加到当前层中。

    可以把多个声音放在一个图层上,或放在包含其他对象的多个图层上。 但是,建议将每个声音放在一个独立的图层上。 每个图层都作为一个独立的声道。 播放 SWF 文件时,会混合所有图层上的声音。

  4. 在时间轴上,选择包含声音文件的第一个帧。
  5. 选择“窗口”>“属性”,然后单击右下角的箭头以展开属性检查器。

  6. 在“属性”检查器中,从“声音”弹出菜单中选择声音文件。
  7. 从“效果”弹出菜单中选择效果选项:

    不对声音文件应用效果。 选中此选项将删除以前应用的效果。

    左声道/右声道

    只在左声道或右声道中播放声音。

    从左到右淡出/从右到左淡出

    会将声音从一个声道切换到另一个声道。

    淡入

    随着声音的播放逐渐增加音量。

    淡出

    随着声音的播放逐渐减小音量。

    自定义

    允许使用“编辑封套”创建自定义的声音淡入和淡出点。

    注意:

    在 WebGL 和 HTML5 Canvas 文档中不支持这些效果。

  8. 从“同步”弹出菜单中选择“同步”选项:

    Event

    会将声音和一个事件的发生过程同步起来。 当事件声音的开始关键帧首次显示时,事件声音将播放,并且将完整播放,而不管播放头在时间轴上的位置如何,即使 SWF 文件停止播放也会继续播放。当播放发布的 SWF 文件时,事件声音会混合在一起。

    如果事件声音正在播放时声音被再次实例化(例如,用户再次单击按钮或播放头通过声音的开始关键帧),那么声音的第一个实例继续播放,而同一声音的另一个实例同时开始播放。在使用较长的声音时请记住这一点,因为它们可能发生重叠,导致意外的音频效果。

    开始

    与“事件”选项的功能相近,但是如果声音已经在播放,则新声音实例就不会播放。

    停止

    使指定的声音静音。

    同步声音,以便在网站上播放。Animate 会强制动画和音频流同步。如果 Animate 绘制动画帧的速度不够快,它就会跳过帧。与事件声音不同,音频流随着 SWF 文件的停止而停止。 而且,音频流的播放时间绝对不会比帧的播放时间长。 当发布 SWF 文件时,音频流混合在一起。

    音频流的一个示例就是动画中一个人物的声音在多个帧中播放。

    Animate 会记住属性检查器中的音频同步选项。如果声音是从属性检查器的“声音”部分选择的,则在属性检查器中对一个新的帧设置另外一个声音时,Animate 会记住前一个声音的同步选项“流”或“事件”。

    注意:

    如果您使用 mp3 声音作为音频流,则必须重新压缩声音,以便能够导出。 可以将声音导出为 mp3 文件,所用的压缩设置与导入它时的设置相同。

    在 WebGL 和 HTML5 Canvas 文档中不支持流设置。

  9. 为“重复”输入一个值,以指定声音应循环的次数,或者选择“循环”以连续重复声音。

    要连续播放,请输入一个足够大的数,以便在扩展持续时间内播放声音。 例如,若要在 15 分钟内循环播放一段 15 秒的声音,请输入 60。 不建议循环播放音频流。 如果将音频流设为循环播放,帧就会添加到文件中,文件的大小就会根据声音循环播放的次数而倍增。

  10. 若要测试声音,请在包含声音的帧上拖动播放头,或使用“控制器”或“控制”菜单中的命令。

从时间轴上删除一个声音

  1. 在包含声音的时间轴图层上,选中也包含此声音的一个帧。
  2. 在属性检查器中,转至声音部分,从“名称”菜单中选择“无”。

    Animate 将从时间轴图层上删除此声音。

向按钮添加声音

可以将声音和一个按钮元件的不同状态关联起来。 因为声音和元件存储在一起,它们可以用于元件的所有实例。

  1. 在“库”面板中选择按钮。
  2. 从面板右上角的“面板”菜单中选择“编辑”。
  3. 在按钮的时间轴上,添加一个声音层(“插入”>“时间轴”>“图层”)。

  4. 在声音层中,创建常规或空白的关键帧,以对应要向其中添加声音的按钮状态。

    单击“插入”>“时间轴”>“关键帧”“插入”>“时间轴”>“空白关键帧”

    例如,要添加一段单击按钮时播放的声音,可以在标记为“Down”的帧中创建关键帧。

    insert-keyframes
  5. 单击已创建的关键帧。
  6. 选择“窗口”>“ 属性”

  7. 从“属性”检查器的“声音”弹出菜单中选择一个声音文件。
  8. 从“同步”弹出菜单中选择“事件”。

    要将其他声音和按钮的每个关键帧关联在一起,请创建一个空白的关键帧,然后给每个关键帧添加其他声音文件。 也可以使用同一个声音文件,然后为按钮的每一个关键帧应用不同的声音效果。

将声音与动画同步

若要将声音与动画同步,请在关键帧处开始播放和停止播放声音。

  1. 将声音添加到其自身图层的时间轴上(请参阅上面的说明)。
  2. 要将此声音与场景中的事件同步,创建此声音的开始关键帧,它与要触发此声音的场景中的事件关键帧对应。您可以选择上面描述的任意同步选项(请参阅将声音添加到时间轴)。
  3. 在声音层时间轴中要停止播放声音的帧上创建一个关键帧。 在时间轴中显示声音文件的表示形式。
  4. 选择“窗口”>“属性”,然后单击右下角的箭头以展开属性检查器。

  5. 在“属性”检查器的“声音”弹出菜单中,选择同一声音。
  6. 还是在属性检查器中,从“同步”弹出菜单中选择“停止”。

    在播放 SWF 文件时,声音会在结束关键帧处停止播放。

  7. 要播放声音,在时间轴中拖动播放头。

编辑声音

在 Animate 中编辑声音

在 Animate 中,您可以定义声音的起始点,或在播放时控制声音的音量。您还可以改变声音开始播放和停止播放的位置。 这对于通过删除声音文件的无用部分来减小文件的大小是很有用的。

  1. 将声音添加至帧,或选择某个已经包含声音的帧。
  2. 选择“窗口”>“ 属性”

    windows-properties
  3. 单击“属性”检查器右边的“编辑”按钮。
  4. 请执行下列任一操作:
    • 若要改变声音的起始点和终止点,请拖动“编辑封套”中的“开始时间”和“停止时间”控件。

    • 若要更改声音封套,请拖动封套手柄来改变声音中不同点处的级别。 封套线显示声音播放时的音量。 若要创建其他封套手柄(总共可达 8 个),请单击封套线。 若要删除封套手柄,请将其拖出窗口。

    • 若要改变窗口中显示声音的多少,请单击“放大”或“缩小”按钮。

    • 要在秒和帧之间切换时间单位,请单击“秒”和“帧”按钮。

  5. 若要听编辑后的声音,请单击“播放”按钮。

在 Soundbooth 中编辑声音

如果安装了 Adobe Soundbooth,则可以使用 Soundbooth 编辑已导入 Animate 文件中的声音。在 Soundbooth 中做出更改后,若保存更改后的文件并覆盖原始文件,则 Animate 文件中会自动反映这些更改。

如果在编辑声音后更改其文件名或格式,则需要将声音文件重新导入 Animate 中。

注意:

Soundbooth 仅在 Windows 计算机和基于 Intel® 的 Macintosh 上可用。

若要在 Soundbooth 中编辑已导入的声音,请执行下列操作:

  1. 右键单击 (Windows) 或按住 Ctrl 并单击 (Macintosh)“库”面板中的声音。
  2. 从上下文菜单中选择“在 Soundbooth 中编辑”。此文件将在 Soundbooth 中打开。
  3. 在 Soundbooth 中编辑文件。
  4. 在完成更改后,保存文件。若要以非破坏性的格式保存所做更改,请选择 ASND 格式。如果以不同于原始文件的格式保存该文件,则需要将声音文件重新导入到 Animate 中。

  5. 返回 Animate,可在“库”面板中查看声音文件的编辑后版本。

注意:

不能通过 Soundbooth 命令中的“编辑”来编辑声音库(“窗口”>“公用库”>“声音”)中的声音。若要在 Soundbooth 中编辑这些声音,请打开 Soundbooth,然后从“资源中心”面板中选择声音。编辑声音,然后将声音导入 Animate 中。

分割或循环时间轴上的声音

分割时间轴中的声音

可以使用“分割音频”上下文菜单来分割时间轴中嵌入的流音频。分割音频允许用户在需要时暂停音频,然后在时间轴中后面的某帧处从停止点恢复音频播放。

要分割时间轴中的某个音频剪辑:

  1. 选择“文件”>“导入”>“导入到库”

  2. 选择音频剪辑,将其导入库中。

  3. 在时间轴上创建一个新层,将音频剪辑添加到该层。 

  4. “属性”>“声音”下,将“同步类型”选为“流式”。

    sound-properties-stream
  5. 右键单击想要分割音频的帧,然后单击“分割音频”

    Split-audio

在时间轴中循环播放声音

连续重复声音的一小部分的音频循环的方式在时间轴的多个帧。使用时间轴上旋转“循环”选项,您可以与其他帧使动画流之间的音频。

要创建循环,请打开时间轴的循环选项如下所示:

Audio
在时间轴的音频“循环”按钮

在 Flash Lite 中使用声音

Adobe® Flash® Lite 支持两种类型的声音:标准 Animate 声音(如在 Animate 桌面应用程序中使用的声音)和设备声音。Flash Lite 1.0 只支持设备声音;Flash Lite 1.1 和 2.x 同时支持标准声音和设备声音。

设备声音以原有音频格式(如 MIDI 或 MFi)储存在发布的 SWF 文件中;播放时,Flash Lite 将声音数据传递给设备,然后由设备解码并播放声音。 由于无法将大多数的设备音频格式导入 Animate 中,因此改为导入受支持格式(如 mp3 或 AIFF)的代理 声音,它将被替换为指定的外部设备声音。

您可以将设备声音用作事件声音,但无法像标准声音一样将设备声音与时间轴同步。

Flash Lite 1.0 和 Flash Lite 1.1 都不支持 Flash® Player 的台式机版本中提供的以下功能:

  • “ActionScript 声音”对象

  • 加载外部 mp3 文件

  • “语音”音频压缩选项

有关详细信息,请参阅《开发 Flash Lite 2.x 应用程序》中的“使用声音、视频和图像”或《开发 Flash Lite 1.x 应用程序》中的“处理声音”。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略