创建实例

创建元件之后,可以在文档中任何地方(包括在其他元件内)创建该元件的实例。 修改元件时,Animate 会更新元件的所有实例。

可以在属性检查器中为实例提供名称。 在 ActionScript 中使用实例名称来引用实例。 若要用 ActionScript® 来控制实例,请为单个时间轴内的每个实例提供唯一的名称。 

若要指定色彩效果、分配动作、设置图形显示模式或更改新实例的行为,请使用属性检查器。 除非您另外指定,否则实例的行为与元件行为相同。 所做的任何更改都只影响实例,并不影响元件。

创建元件的实例

  1. 在时间轴上选择一个图层。 Animate 只能将实例放在关键帧中,并且总在当前图层上。如果没有选择关键帧,Animate 会将实例添加到当前帧左侧的第一个关键帧上。

    注意:

    关键帧是用来定义动画中的变化的帧。 有关详细信息,请参阅在时间轴中插入帧

  2. 选择“窗口”>“库”。

  3. 将该元件从库中拖到舞台上。

  4. 如果已经创建了图形元件的实例,若要添加将包含该图形元件的帧数,可选择“插入”>“时间轴”>“帧”。

对实例应用自定义名称

  1. 在舞台上选择该实例。

  2. 选择“窗口”>“属性”,并在“实例名称”框中输入一个名称。

编辑实例属性

每个元件实例都各有独立于该元件的属性。 可以更改实例的色调、透明度和亮度;重新定义实例的行为(例如,把图形更改为影片剪辑);并可以设置动画在图形实例内的播放形式。也可以倾斜、旋转或缩放实例,这并不会影响元件。

此外,可以给影片剪辑或按钮实例命名,这样就可以使用 ActionScript 更改其属性。有关详细信息,请参阅学习使用 ActionScript 3.0 中的对象和类。要编辑实例属性,可使用属性检查器(“窗口”>“属性”)。

实例的属性用它来保存。 如果编辑一个元件或将一个实例重新链接到不同的元件,则任何已经更改的实例属性仍将应用于该实例。

设置实例的可见性

通过关闭“可见”属性可以在舞台上显示元件实例。与将元件的 Alpha 属性设置为 0 相比,使用“可见”属性可以提供更快的呈现性能。

“可见”属性需要的 Player 设置是 Flash Player 10.2 或更高版本,并且仅与影片剪辑、按钮和组件实例兼容。

  1. 在舞台上选择该实例。

  2. 在“属性”面板的“显示”部分,取消选择“可见”属性。

更改实例的颜色和透明度

每个元件实例都可以有自己的色彩效果。要设置实例的颜色和透明度选项,请使用属性检查器。属性检查器中的设置也会影响放置在元件内的位图。

当在特定帧中改变一个实例的颜色和透明度时,Animate 会在显示该帧时立即进行这些更改。要进行渐变颜色更改,请应用补间动画。 当补间颜色时,请在实例的开始关键帧和结束关键帧中输入不同的效果设置,然后补间这些设置,以让实例的颜色随着时间逐渐变化。

sy_tint_tween
sy_alpha_tween
补间逐渐地更改实例的颜色或透明度。

注意:

如果对包含多帧的影片剪辑元件应用色彩效果,Animate 会将该效果应用于该影片剪辑元件中的每一帧。

  1. 在舞台上选择该实例,然后选择“窗口”>“属性”。
  2. 在属性检查器中,从“色彩效果”部分的“样式”菜单中选择下列选项之一:

    亮度

    调节图像的相对亮度或暗度,度量范围是从黑 (-100%) 到白 (100%)。若要调整亮度,请单击此三角形并拖动滑块,或者在框中输入一个值。

    色调

    用相同的色相为实例着色。要设置色调百分比(从透明 (0%) 到完全饱和 (100%)),请使用属性检查器中的色调滑块。若要调整色调,请单击此三角形并拖动滑块,或者在框中输入一个值。若要选择颜色,请在各自的框中输入红、绿和蓝色的值;或者单击“颜色”控件,然后从“颜色选择器”中选择一种颜色。

    Alpha

    调节实例的透明度,调节范围是从透明 (0%) 到完全饱和 (100%)。若要调整 Alpha 值,请单击此三角形并拖动滑块,或者在框中输入一个值。

    高级

    分别调节实例的红色、绿色、蓝色和透明度值。对于在位图这样的对象上创建和制作具有微妙色彩效果的动画,此选项非常有用。左侧的控件使您可以按指定的百分比降低颜色或透明度的值。右侧的控件使您可以按常数值降低或增大颜色或透明度的值。

    当前的红、绿、蓝和 Alpha 的值都乘以百分比值,然后加上右列中的常数值,产生新的颜色值。例如,如果当前的红色值是 100,若将左侧的滑块设置为 50% 并将右侧滑块设置为 100%,则会产生一个新的红色值 150 ([100 x .5] + 100 = 150)。

    注意:“效果”面板中的“高级”设置执行函数 (a * y+ b)= x,其中,a 是框左侧设置中指定的百分比,y 是原始位图的颜色,b 是框右侧设置中指定的值,x 是生成的效果(RGB 介于 0 和 255 之间,Alpha 透明度介于 0 和 100 之间)。

    也可以使用 ActionScript ColorTransform 对象来更改实例的颜色。 有关 Color 对象的详细信息,请参阅《ActionScript 2.0 语言参考》《ActionScript 3.0 语言和组件参考》中的 ColorTransform。

将一个实例与另一个实例交换

要在舞台上显示不同的实例,并保留所有原始实例属性(如色彩效果或按钮动作),请为实例分配不同的元件。

例如,假定您正在使用 rat 元件创建一个卡通形象作为影片中的角色,但后来决定将该角色改为 cat。您可以用 cat 元件替换 rat 元件,并让更新的角色显示在所有帧中大致相同的位置上。

为实例分配不同的元件

  1. 在舞台上选择该实例,然后选择“窗口”>“属性”。

  2. 在属性检查器中单击“交换”按钮。

  3. 选择一个元件以替换当前分配给实例的元件。若要重制选定的元件,请单击“重制元件”,然后单击“确定”。

    如果制作的是几个具有细微差别的元件,那么重制使您可以在库中现有元件的基础上创建一个新元件,并将复制工作减到最少。

替换元件的所有实例

  1. 从一个“库”面板中将与待替换元件同名的元件拖到正编辑的 FLA 文件的“库”面板中,然后单击“替换”。 如果库中包含文件夹,则必须将新元件拖动到与所替换的元件相同的文件夹中。

更改实例的类型

若要在 Animate 应用程序中重新定义实例的行为,需要更改其类型。例如,如果一个图形实例包含您想要独立于主时间轴播放的动画,则可以将该图形实例重新定义为影片剪辑实例。

  1. 在舞台上选择该实例,然后选择“窗口”>“属性”。
  2. 从属性检查器的菜单中选择“图形”、“按钮”或“影片剪辑”。

为图形实例设置循环

要确定图形实例内的动画序列在 Animate 应用程序中的播放方式,需要设置“属性”检查器中的选项。

动画图形元件是与放置该元件的文档的时间轴联系在一起的。 相比之下,影片剪辑元件拥有自己独立的时间轴。 因为动画图形元件使用与主文档相同的时间轴,所以在文档编辑模式下显示它们的动画。 影片剪辑元件在舞台上显示为静态对象,并且在 Animate 编辑环境中不会显示为动画。

  1. 在舞台上选择图形实例,然后选择“窗口”>“属性”。
  2. 在属性检查器的“循环”部分中,从“选项”菜单中选择一个动画选项:

    循环

    按照当前实例占用的帧数来循环包含在该实例内的所有动画序列。

    播放一次

    从指定帧开始播放动画序列直到动画结束,然后停止。

    单帧

    显示动画序列的一帧。指定要显示的帧。

  3. 若要指定循环时首先显示的图形元件的帧,请在“第一帧”文本框中输入帧编号。“单帧”选项也可以使用此处指定的帧编号。

帧选择器

使用帧选择器可以直观地预览并选择图形元件的第一帧。在以前的版本中,需要在编辑模式下并在元件内部才能预览帧。此功能增强了一些动画工作流(如嘴形同步)的用户体验。

注意:

帧选择器面板仅适用于图形元件,对于影片剪辑或按钮元件类型都是无效的。要想使用此功能,应确保将资源转换为元件

  1. 选择图形元件 > 属性面板 >循环 > 使用选择器 按钮显示选择器面板,或选择窗口 > 选择器

    Frame Picker_ PI
    帧选择器

  2. 在“帧选择器”面板中,选择“列表”或“缩览图”视图可显示所选图形元件所有帧的预览结果。还可以查看帧编号及其标签。 

    列表 以竖列表视图显示帧。

    缩览图 以网格视图显示帧并在面板大小调整后进行重新调整。

    创建关键帧 使用此选项后,当您从帧选择器面板选择一个位置时,系统会自动创建一个关键帧。

    循环 显示图形的各种循环选项,如循环、播放一次和单个帧。

    滑块箭头 调整预览大小

    滑块向左按钮 视图中显示更多的帧

    滑块向右按钮 视图中显示更少的帧

    筛选帧选项下拉菜单 显示各种筛选帧选项

    list
    列表视图

    thumnail
    缩略图视图

  3. 使用滑块 缩放按钮可调整预览或缩览图大小。将滑块调整到面板的左下角可在视图中查看更多的帧。将滑块移动到右下角则可查看更大的预览。

  4. 单击任一帧,将其设置为所选元件的第一帧。

创建关键帧

帧选择器面板提供一个“创建关键帧”复选框,可用来在帧选择器面板中选择帧时自动创建关键帧。此外,还可以在帧选择器面板中设置图形元件的循环选项。

可以调用帧选择器面板,方法是选择图形元件 > 属性面板 >循环 > 使用选择器按钮来显示选择器面板,或选择窗口 >选择器

CreateKeyframe

帧的筛选选项

Animate 为面板中列出的帧提供筛选选项。您可以按以下条件来筛选:

  • 所有帧 - 显示所有帧。
  • 关键帧 - 仅根据您的选择显示关键帧。
  • 标签 - 仅显示带标签的帧。
filterOptions

自动嘴形同步

自动嘴形同步允许根据所选音频层在时间轴上更轻松、快速地放置合适的嘴形。您可以使用在图形符号内绘制的现有嘴形列表来实现这一点。在图形符号上应用自动嘴形同步时,分析指定的音频图层后,会在与音频发音嘴型匹配的不同位置自动创建关键帧。完成后,您可以根据需要使用常规工作流程和帧选择器进行进一步调整。

发音嘴型是一种可用于指示声音的通用面部图像。 

创建嘴形同步

按照以下步骤开始创建嘴形同步:

  1. 创建图形元件(嘴形)。

    可以在图形元件内绘制所有嘴形/发音嘴型。

  2. 在主时间轴中,将音频导入新图层中。

    注意:

    当音频同步设置设为“流”时,自动嘴形同步效果最佳。

    具有音频图层的示例元件
    具有音频图层的示例元件
  3. 选择嘴图形元件。在“属性检查器”中,单击“嘴形同步”

    属性检查器中的嘴形同步
    属性检查器中的嘴形同步

    此时将出现“创建嘴形同步”对话框。默认情况下,显示 12 种基本类型的发音嘴型,如下方屏幕截图所示:

    创建嘴形同步
    创建嘴形同步
  4. 单击任意发音嘴型以更改其嘴形映射。此时将会显示一个弹出列表,其中包含图形元件内具有的所有嘴形。从弹出列表中选择相应的帧,以将其设为当前的发音嘴型。

    修改每个发音嘴型的嘴形
    修改每个发音嘴型的嘴形
  5. 选择要作为嘴唇同步目标的音频层。单击 “同步”按钮。

    应用嘴形同步之后的时间轴屏幕截图
    应用嘴形同步之后的时间轴屏幕截图

    注意:

    自动嘴形同步将应用于存在所选图形元件的帧间距上。此外,还可以首先选择多个关键帧,然后再将嘴形同步应用于选定帧范围。

  6. 按·Ctrl+Enter 运行文件并预览输出。

    您可以查看动画文件,其中自动生成的嘴部动作还与声音文件同步。

描述自动嘴形同步的视频

描述自动嘴形同步的视频
在此视频中,您可以看到如何创建嘴形同步。

分离元件实例

要断开一个实例与一个元件之间的链接,并将该实例放入一个由未编组的形状和线条构成的集合中,可以分离该实例。此功能对于实质性更改实例而不影响任何其他实例非常有用。

在分离实例之后对该实例源元件的更改不会影响该实例。

  1. 在舞台上选择该实例。
  2. 选择“修改”>“分离”。 此操作将该实例分离成它的几个组件图形元素。
  3. 要修改这些元素,请使用涂色和绘画工具。

获取有关舞台上的实例的信息

属性检查器和“信息”面板显示以下与在舞台上选定的实例相关的信息:

  • 在属性检查器中,您可以查看实例的行为和设置;对于所有实例类型,均可以查看色彩效果设置、位置和大小;对于图形,还可以查看循环模式和包含该图形的第一帧;对于按钮,还可以查看实例名称(如果已分配)和跟踪选项;对于影片剪辑,还可以查看实例名称(如果已分配)。对于位置,属性检查器将显示元件注册点的 xy 坐标。

  • 在“信息”面板中,可以查看实例的大小和位置、实例注册点的位置、实例的红色值 (R)、绿色值 (G)、蓝色值 (B) 和 alpha (A) 值(如果实例有实心填充)以及指针的位置。属性检查器中的“位置和大小”部分显示元件的注册点或变形点的 xy 坐标。可以通过切换来查看注册点或变形点的坐标。

  • 在影片浏览器中,查看当前文档的内容,包括实例和元件。

    在“动作”面板中查看分配给按钮或影片剪辑的所有动作。

获取有关实例的信息

  1. 在舞台上选择该实例。

  2. 显示要使用的属性检查器(“窗口”>“属性”)或面板:

    • 要显示“信息”面板,请选择“窗口”>“信息”。

    • 要显示影片浏览器,请选择“窗口”>“影片浏览器”。

    • 要显示“动作”面板,请选择“窗口”>“动作”。

在影片浏览器中查看选定元件的元件定义

  1. 单击影片浏览器顶部的“显示按钮、影片剪辑和图形”按钮。

  2. 右键单击 (Windows) 或按住 Control 键单击 (Macintosh),然后选择“显示元件实例”和“转到元件定义”;或从影片浏览器右上角的菜单中选择这些选项。

跳到包含选定元件的实例的场景

  1. 显示元件定义。

  2. 右键单击 (Windows) 或按住 Control 键单击 (Macintosh),然后选择“显示影片元素”和“转到元件定义”;或从影片浏览器右上角的菜单中选择这些选项。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略