"Animate CC 中的笔触、填充和渐变"

  1. Adobe Animate 用户指南
  2. Animate 简介
    1. Animate 新增功能
    2. 图示术语表
    3. Animate 系统要求
    4. Animate 键盘快捷键
    5. 在 Animate 中使用多种文件类型
  3. 动画
    1. Animate 动画基础知识
    2. 如何在 Animate 中使用帧和关键帧
    3. 在 Animate 中使用逐帧动画
    4. 如何在 Animate 中使用传统补间动画
    5. 画笔工具
    6. 运动辅助线
    7. 补间动画和 ActionScript 3.0
    8. 关于补间动画
    9. 补间动画
    10. 创建补间动画
    11. 使用属性关键帧
    12. 用补间对位置进行动画处理
    13. 如何使用动画编辑器编辑补间动画
    14. 编辑补间动画的运动路径
    15. 处理补间动画
    16. 添加自定义缓动
    17. 创建和应用动画预设
    18. 设置动画的补间范围
    19. 处理另存为 XML 文件的补间动画
    20. 补间动画与传统补间
    21. 形状补间
    22. 在 Animate 中使用骨骼工具动画
    23. 在 Animate 中处理角色 Rig
    24. 如何在 Adobe Animate 中使用遮罩层
    25. 如何在 Animate 中使用场景
  4. 交互性
    1. 如何使用 Animate 创建按钮
    2. 将 Animate 项目转换为其它文档类型格式
    3. 在 Animate 中创建和发布 HTML5 Canvas 文档
    4. 在 Animate 中通过代码片段添加交互性
    5. 创建自定义 HTML5 组件
    6. 使用 HTML5 Canvas 中的组件
    7. 创建自定义组件:示例
    8. 自定义组件的代码片段
    9. 最佳做法 - 使用 Animate 制作广告
    10. 虚拟现实创作和发布
  5. 工作区和工作流
    1. 创建和管理画笔
    2. 在 HTML5 Canvas 文档中使用 Google 字体
    3. 使用 Creative Cloud Libraries 和 Adobe Animate
    4. 使用 Animate 的舞台和工具面板
    5. Animate 工作流程和工作区
    6. 在 HTML5 Canvas 文档中使用 Web 字体
    7. 时间轴和 ActionScript
    8. 使用多个时间轴
    9. 设置首选参数
    10. 使用 Animate 创作面板
    11. 使用 Animate 创建时间轴图层
    12. 导出移动应用程序和游戏引擎的动画
    13. 移动和复制对象
    14. 模板
    15. 在 Animate 中查找和替换
    16. 撤消、重做和历史记录面板
    17. 键盘快捷键
    18. 如何在 Animate 中使用时间轴
    19. 创建 HTML 扩展
    20. 图像和动画 GIF 的优化选项
    21. 图像和 GIF 的导出设置
    22. Animate 中的资源面板
  6. 多媒体与视频
    1. 在 Animate 中变形和合并图形对象
    2. 在 Animate 中创建并使用元件实例
    3. 图像描摹
    4. 如何在 Adobe Animate 中使用声音
    5. 导出 SVG 文件
    6. 创建用于 Animate 中的视频文件
    7. 如何在 Animate 中添加视频
    8. 使用视频提示点
    9. 使用 Animate 绘制和创建对象
    10. 改变线条和形状
    11. Animate CC 中的笔触、填充和渐变
    12. 使用 Adobe Premiere Pro 和 After Effects
    13. Animate CC 中的颜色面板
    14. 使用 Animate 打开 Flash CS6 文件
    15. 在 Animate 中使用传统文本
    16. 向 Animate 中置入图稿
    17. 在 Animate 中导入的位图
    18. 3D 图形
    19. 在 Animate 中使用元件
    20. 使用 Adobe Animate 绘制线条和形状
    21. 在 Animate 中使用库
    22. 导出声音
    23. 在 Animate CC 中选择对象
    24. 在 Animate 中使用 Illustrator AI 文件
    25. 使用喷涂刷工具应用图案
    26. 应用混合模式
    27. 排列对象
    28. 使用“命令”菜单自动处理任务
    29. 多语言文本
    30. 在 Animate 中使用摄像头
    31. 将 Animate 与 Adobe Scout 一起使用
    32. 使用 Fireworks 文件
    33. 图形滤镜
    34. 声音和 ActionScript
    35. 绘制首选参数
    36. 用钢笔工具绘图
  7. 平台
    1. 将 Animate 项目转换为其它文档类型格式
    2. 自定义平台支持
    3. 在 Animate 中创建和发布 HTML5 Canvas 文档
    4. 创建和发布 WebGL 文档
    5. 如何打包 AIR for iOS 应用程序
    6. 发布 AIR for Android 应用程序
    7. 发布用于桌面的 Adobe AIR
    8. ActionScript 发布设置
    9. 最佳做法 - 管理应用程序中的 ActionScript
    10. 如何在 Animate 中使用 ActionScript
    11. 最佳做法 - 辅助功能指南
    12. Animate 工作区中的辅助功能
    13. 编写和管理脚本
    14. 启用自定义平台支持
    15. 自定义平台支持概述
    16. 创建辅助内容
    17. 使用自定义平台支持插件
    18. 调试 ActionScript 3.0
    19. 启用自定义平台支持
  8. 导出和发布
    1. 如何从 Animate CC 导出文件
    2. OAM 发布
    3. 导出 SVG 文件
    4. 使用 Animate 导出图形和视频
    5. 发布 AS3 文档
    6. 导出移动应用程序和游戏引擎的动画
    7. 导出声音
    8. 导出 QuickTime 视频文件
    9. 使用 ActionScript 控制外部视频播放
    10. 最佳做法 - 移动设备内容创建技巧
    11. 最佳做法 - 视频惯例
    12. 最佳做法 - SWF 应用程序创作指南
    13. 最佳做法 - 构造 FLA 文件
    14. 在 Animate 中优化 FLA 文件的最佳做法
    15. ActionScript 发布设置
    16. 指定 Animate 的发布设置
    17. 导出放映文件
    18. 导出图像和动画 GIF
    19. HTML 发布模板
    20. 使用 Adobe Premiere Pro 和 After Effects
    21. 快速分享和发布动画

创建或编辑渐变填充

渐变是一种多色填充,即一种颜色逐渐转变为另一种颜色。 Animate CC(以前名为 Flash Professional CC)允许您将多达 15 种颜色过渡应用于渐变。创建渐变是在一个或多个对象间创建平滑颜色过渡的好方法。您可以将渐变存储为色板,从而便于将渐变应用于多个对象。Animate 可以创建两种类型的渐变:

线性渐变 是沿着一根轴线(水平或垂直)改变颜色。

放射状渐变 从一个中心焦点向外改变颜色。 可以调整渐变的方向、颜色、焦点位置,以及渐变的其他很多属性。

Animate CC 可对线性和放射状渐变提供额外控制,从而与 Flash Player 配合使用。这些控制称作溢出模式,您可以通过这些模式来指定如何在渐变之外应用颜色。

  1. 若要将渐变填充应用到现有插图,请在舞台中选择一个或多个对象。

  2. 如果看不到“颜色”面板,请选择“窗口”>“颜色”。

  3. 要选择一种颜色显示模式,请从面板菜单选择 RGB(默认设置)或 HSB。

  4. 从“类型”菜单中选择一个渐变类型:

    线性

    创建从起始点到终点沿直线逐渐变化的渐变。

    放射状

    产生从一个中心焦点出发沿环形轨道向外混合的渐变。

    注意:当选择线性或放射状渐变时,如果针对 Flash Player 8 或更高版本发布,则“颜色”面板还包括另外两个选项。首先,“类型”菜单下方将启用“溢出”菜单。 可以使用“溢出”弹出菜单来控制超出渐变限制进行应用的颜色。 其次,将出现渐变定义栏,栏下各指针表示渐变中的颜色。

  5. (可选)从“溢出”菜单中,选择一种溢出模式以应用到渐变:扩展(默认模式)、反射或重复。

  6. (可选)若要创建 SVG(可伸缩的矢量图形)兼容的线性或放射状渐变,请选中“线性 RGB”复选框。在初次应用渐变后如果要将其缩放到不同大小,这将使之显得平滑。

  7. 要更改渐变中的颜色,请在渐变定义栏下选择一个颜色指针(所选颜色指针顶部的三角形将变成黑色)。 然后在渐变栏上方显示的颜色空间窗格中单击。 拖动“亮度”滑块来调整颜色的亮度。

  8. 要向渐变中添加指针,请单击渐变定义栏或渐变定义栏的下方。 为新指针选择一种颜色,如上一步骤所述。

    最多可以添加 15 个颜色指针,从而使您可以创建多达 15 种颜色转变的渐变。

  9. 要重新放置渐变上的指针,请沿着渐变定义栏拖动指针。 将指针向下拖离渐变定义栏可以删除它。

  10. 若要保存渐变,请单击“颜色”面板右上角的三角形,然后从菜单中选择“添加样本”。

    即可将渐变添加到当前文档的“样本”面板中。

  11. 要进行渐变变形,例如实现垂直渐变而非水平渐变,请使用渐变变形工具。有关详细信息,请参阅变形渐变和位图填充

调整笔触颜色和填充颜色

通过使用“工具”面板或属性检查器中的“笔触颜色”和“填充颜色”控件,可以指定图形对象和形状的笔触颜色和填充颜色。

“工具”面板的“笔触颜色”和“填充颜色”部分包含用于激活“笔触颜色”和“填充颜色”框的控件,而这些框又将确定选定对象的笔触或填充是否受到颜色选择的影响。“颜色”部分也包含一些控件,可用于将颜色快速重置为默认值、将笔触颜色和填充颜色设置为“无”以及交换填充颜色和笔触颜色。

属性检查器不仅可让您为图形对象或形状选择笔触颜色和填充颜色,还提供了用于指定笔触宽度和样式的控件。

若要用这些控件来更改现有对象的涂色属性,必须首先在舞台中选择对象。

另请参阅:颜色实时预览

使用“工具”面板调整笔触颜色和填充颜色

“工具”面板“笔触颜色”和“填充颜色”控件可设置用绘画和涂色工具创建的新对象的涂色属性。 若要用这些控件来更改现有对象的涂色属性,必须首先在舞台中选择对象。

  • 单击“笔触颜色”或“填充颜色”控件,然后选择一个颜色样本。

  • 单击弹出窗口中的“系统颜色选择器”按钮,然后选择一种颜色。您也可以将指针悬停于各个颜色上,以便预览颜色应用在形状上的效果。

  • 在框中键入颜色的十六进制值。

  • 若要恢复到默认颜色设置(白色填充和黑色笔触),请单击“工具”面板中的“黑白”按钮。

  • 若要删除任何笔触或填充,请单击“无颜色”按钮。

    注意:“无颜色”按钮只有在创建椭圆或矩形时才会出现。您可以创建没有笔触或填充的对象,但不能对现有对象使用“无颜色”按钮。 而应该选择现有的笔触或者填充然后删除它。

  • 若要在填充和笔触之间交换颜色,请单击“工具”面板中的“交换颜色”按钮。

在改变颜色样本时,Animate CC 允许您实时预览笔触颜色或填充颜色。有关更多信息,请参阅颜色实时预览

使用属性检查器应用纯色填充

  1. 在舞台上选择一个或多个闭合对象。
  2. 选择“窗口”>“属性”。
  3. 若要选择颜色,请单击“填充颜色”控件,然后执行下列操作之一:

    • 从调色板中选择一个颜色样本。
    • 在框中键入颜色的十六进制值。

使用属性检查器选择笔触颜色、样式和粗细

若要更改所选对象的笔触颜色、样式和粗细,请使用“属性”检查器中的“笔触颜色”控件。 对于笔触的样式,可以从 Animate 预先加载的样式中选择,也可以创建自定义样式。若要选择纯色填充,则应使用“属性”检查器中的“填充颜色”控件。

  1. 选择舞台上的一个或多个对象(对于元件,应先双击以进入元件编辑模式)。
  2. 选择“窗口”>“属性”。
  3. 若要选择笔触样式,请单击“样式”菜单并选择一个选项。若要创建自定义样式,请单击属性检查器中的“自定义”,选择“笔触样式”对话框中的选项,然后单击“确定”。
    注意:

    选择非实心笔触样式会增加文件的大小。

  4. 若要选择笔触粗细,请设置“笔触”滑块或在文本框中输入一个数值。
  5. 若要启用笔触提示,请选择“笔触提示”复选框。 笔触提示可在全像素下调整直线锚记点和曲线锚记点,防止出现模糊的垂直或水平线。
  6. 若要设定路径终点的样式,则应选择一个“端点”选项:

    对齐路径终点。

    圆角

    添加一个超出路径端点半个笔触宽度的圆头端点.

    正方形

    添加一个超出路径半个笔触宽度的方头端点.

  7. (可选)如果您正在使用“铅笔”或“刷子”工具绘制线条,并且绘制模式设置为“平滑”,则可以用“平滑”滑块指定 Animate 对所绘线条进行平滑的程度。

    在默认情况下,“平滑”值设置为 50,但您可以指定一个介于 0 到 100 之间的值。 平滑值越大,所得线条就越平滑。

    注意:

    绘制模式设为“伸直”或“墨水”时,禁用“平滑”滑块。

  8. 若要定义两个路径片段的相接方式,则应选择一个“接合”选项。 要更改开放或闭合路径中的转角,请选择一个路径,然后选择另一个接合选项。
    尖角、圆角和斜角接合。

  9. 为了避免尖角接合倾斜,请输入一个尖角限制。

    超过这个值的线条部分将被切成正方形,而非尖角。 例如,如果一个 3 点笔触的尖角限制为 2,则意味着当该点长度是该笔触粗细的两倍时,Animate 将删除限制点。

    应用尖角限制.

调整多个线条或形状的笔触

若要更改一个或多个线条或者形状轮廓的笔触颜色、宽度和样式,请使用墨水瓶工具。对直线或形状轮廓只能应用纯色,而不能应用渐变或位图。

使用墨水瓶工具而不是选择个别的线条,可以更容易地一次更改多个对象的笔触属性。

  1. 从工具栏中选择墨水瓶工具。
  2. 选择一种笔触颜色。
  3. 从属性检查器中选择笔触样式和笔触宽度。
  4. 若要应用对笔触的修改,则应单击舞台中的对象。

复制笔触和填充

您可以用滴管工具从一个对象复制填充和笔触属性,然后立即将它们应用到其他对象。 “滴管”工具还允许您从位图图像取样用作填充。

  1. 若要将笔触或填充区域的属性应用到另一个笔触或填充区域,请选择“滴管”工具,然后单击要应用其属性的笔触或填充区域。

    当您单击一个笔触时,该工具自动变成墨水瓶工具。 当您单击已填充的区域时,该工具自动变成颜料桶工具,并且打开“锁定填充”功能键。

  2. 单击其他笔触或已填充区域以应用新属性。

使用油漆桶工具修改涂色区域

“颜料桶”工具可以用颜色填充封闭区域。 您可以用此工具执行以下操作:

  • 填充空区域,然后更改已涂色区域的颜色。

  • 用纯色、渐变和位图填充进行涂色。

  • 使用颜料桶工具填充不完全闭合的区域。

  • 使用颜料桶工具时,让 Animate 闭合形状轮廓上的空隙。

  1. 从工具栏中选择颜料桶工具。
  2. 选择一种填充颜色和样式。
  3. 单击显示在“工具”面板底部的间隙大小修改键并选择一个间隙大小选项:
    • 如果要在填充形状之前手动封闭空隙,请选择“不封闭空隙”。 对于复杂的图形,手动封闭空隙会更快一些。
    • 选择“关闭”选项可使 Animate 填充有空隙的形状。
    注意:

    如果空隙太大,您可能必须手动封闭它们。

  4. 单击要填充的形状或封闭区域。

油漆桶工具选项

您现在可以使用油漆桶工具来单击并拖动对象的轮廓,以用所选颜色填充它们。您可以在轮廓上的任意方向单击并拖动该工具。油漆桶工具在跨轮廓捕获点时填充颜色。

“油漆桶”属性
“油漆桶”属性

如果选中“填充所有区域”复选框,则拖动时,所有选定区域均会填充颜色。

默认情况下,“填充所有区域”选项处于取消选中状态。在此模式下,油漆桶工具只会填充特定颜色。

未选择“填充所有区域”时(默认)

  • 在此模式下,如果用户在使用油漆桶时单击鼠标,则您会看到颜色被替换。在此案例中,现在我们假设绿色被替换为红色。
  • 当用户拖动图稿时,此选项仅会替换填充为绿色的轮廓。
  • 如果用户拖动的是一个空白的闭合轮廓,则它将被填充为红色。
  • 单击鼠标时,如果底层轮廓为空白,则当用户拖动油漆桶工具时,此选项将会填充空白轮廓。

选择“填充所有区域”时

所有区域将填充为选定颜色。在上述插图案例中,所有区域将填充为红色。

使渐变和位图填充变形

通过调整填充的大小、方向或者中心,可以使渐变填充或位图填充变形。

  1. 从“工具”面板中选择“渐变变形”工具 。如果在“工具”面板中看不到渐变变形工具,请单击并按住任意变形工具,然后从显示的菜单中选择渐变变形工具。
  2. 单击用渐变或位图填充的区域。 系统将显示一个带有编辑手柄的边框。 当指针在这些手柄中的任何一个上面的时候,它会发生变化,显示该手柄的功能。

    中心点

    中心点手柄的变换图标是一个四向箭头。

    焦点

    仅在选择放射状渐变时才显示焦点手柄。 焦点手柄的变换图标是一个倒三角形。

    大小

    大小手柄的变换图标(边框边缘中间的手柄图标)是内部有一个箭头的圆圈。

    旋转

    调整渐变的旋转。 旋转手柄的变换图标(边框边缘底部的手柄图标)是组成一个圆形的四个箭头。

    宽度

    调整渐变的宽度。 宽度手柄(方形手柄)的变换图标是一个双头箭头。

    按下 Shift 可以将线性渐变填充的方向限制为 45° 的倍数。

    放射状渐变控件

    A. 中心点 B. 宽度 C. 旋转 D. 大小 E. 焦点. 

  3. 用下面的任何方法都可以更改渐变或填充的形状:
    • 若要改变渐变或位图填充的中心点位置,请拖动中心点。

    • 若要更改渐变或位图填充的宽度,请拖动边框边上的方形手柄。 (此选项只调整填充的大小,而不调整包含该填充的对象的大小。)

    • 若要更改渐变或位图填充的高度,请拖动边框底部的方形手柄。

    • 若要旋转渐变或位图填充,请拖动角上的圆形旋转手柄。 您还可以拖动圆形渐变或填充边框最下方的手柄。

    • 若要缩放线性渐变或者填充,请拖动边框中心的方形手柄。

    • 若要更改环形渐变的焦点,则应拖动环形边框中间的圆形手柄。

    • 若要倾斜形状中的填充,请拖动边框顶部或右边圆形手柄中的一个。

    • 若要在形状内部平铺位图,请缩放填充。

    注意:

    若要在处理大面积填充或接近舞台边缘的填充时查看所有的手柄,请选择“视图”>“剪贴板”。

锁定渐变或位图以填充舞台

您可以锁定渐变色或位图填充,使填充看起来好像扩展到整个舞台,并且用该填充涂色的对象好像是显示下面的渐变或位图的遮罩。

当您随刷子或颜料桶工具选择了“锁定填充”功能键并用该工具涂色的时候,位图或者渐变填充将扩展覆盖您在舞台中涂色的对象。

使用“锁定填充”功能键可以创建应用于舞台上独立对象的单个渐变或者位图填充的外观。

使用锁定的渐变填充

  1. 选择“刷子”或者“颜料桶”工具,然后选择作为填充的渐变或位图。
  2. 从“颜色”面板的“类型”菜单中,选择“线性”或“放射状”。
  3. 单击“锁定填充”功能键 
  4. 首先对要放置填充中心的区域进行涂色,然后移到其他区域。

使用锁定的位图填充

  1. 选择要用的位图。
  2. 从“颜色”面板的“类型”菜单中选择“位图”。
  3. 选择“刷子”或“颜料桶”工具。
  4. 单击“锁定填充”功能键 
  5. 首先对要放置填充中心的区域进行涂色,然后移到其他区域。
Adobe 徽标

登录到您的帐户