用户指南 取消(C)

如何在 Animate 中使用传统补间动画

  1. Adobe Animate 用户指南
  2. Animate 简介
    1. Animate 新增功能
    2. 图示术语表
    3. Animate 系统要求
    4. Animate 键盘快捷键
    5. 在 Animate 中使用多种文件类型
  3. 动画
    1. Animate 动画基础知识
    2. 如何在 Animate 中使用帧和关键帧
    3. 在 Animate 中使用逐帧动画
    4. 如何在 Animate 中使用传统补间动画
    5. 画笔工具
    6. 运动辅助线
    7. 补间动画和 ActionScript 3.0
    8. 关于补间动画
    9. 补间动画
    10. 创建补间动画
    11. 使用属性关键帧
    12. 用补间对位置进行动画处理
    13. 如何使用动画编辑器编辑补间动画
    14. 编辑补间动画的运动路径
    15. 处理补间动画
    16. 添加自定义缓动
    17. 创建和应用动画预设
    18. 设置动画的补间范围
    19. 处理另存为 XML 文件的补间动画
    20. 补间动画与传统补间
    21. 形状补间
    22. 在 Animate 中使用骨骼工具动画
    23. 在 Animate 中处理角色 Rig
    24. 如何在 Adobe Animate 中使用遮罩层
    25. 如何在 Animate 中使用场景
  4. 交互性
    1. 如何使用 Animate 创建按钮
    2. 将 Animate 项目转换为其它文档类型格式
    3. 在 Animate 中创建和发布 HTML5 Canvas 文档
    4. 在 Animate 中通过代码片段添加交互性
    5. 创建自定义 HTML5 组件
    6. 使用 HTML5 Canvas 中的组件
    7. 创建自定义组件:示例
    8. 自定义组件的代码片段
    9. 最佳做法 - 使用 Animate 制作广告
    10. 虚拟现实创作和发布
  5. 工作区和工作流
    1. 创建和管理画笔
    2. 在 HTML5 Canvas 文档中使用 Google 字体
    3. 使用 Creative Cloud Libraries 和 Adobe Animate
    4. 使用 Animate 的舞台和工具面板
    5. Animate 工作流程和工作区
    6. 在 HTML5 Canvas 文档中使用 Web 字体
    7. 时间轴和 ActionScript
    8. 使用多个时间轴
    9. 设置首选参数
    10. 使用 Animate 创作面板
    11. 使用 Animate 创建时间轴图层
    12. 导出移动应用程序和游戏引擎的动画
    13. 移动和复制对象
    14. 模板
    15. 在 Animate 中查找和替换
    16. 撤消、重做和历史记录面板
    17. 键盘快捷键
    18. 如何在 Animate 中使用时间轴
    19. 创建 HTML 扩展
    20. 图像和动画 GIF 的优化选项
    21. 图像和 GIF 的导出设置
    22. Animate 中的资源面板
  6. 多媒体与视频
    1. 在 Animate 中变形和合并图形对象
    2. 在 Animate 中创建并使用元件实例
    3. 图像描摹
    4. 如何在 Adobe Animate 中使用声音
    5. 导出 SVG 文件
    6. 创建用于 Animate 中的视频文件
    7. 如何在 Animate 中添加视频
    8. 使用视频提示点
    9. 使用 Animate 绘制和创建对象
    10. 改变线条和形状
    11. Animate CC 中的笔触、填充和渐变
    12. 使用 Adobe Premiere Pro 和 After Effects
    13. Animate CC 中的颜色面板
    14. 使用 Animate 打开 Flash CS6 文件
    15. 在 Animate 中使用传统文本
    16. 向 Animate 中置入图稿
    17. 在 Animate 中导入的位图
    18. 3D 图形
    19. 在 Animate 中使用元件
    20. 使用 Adobe Animate 绘制线条和形状
    21. 在 Animate 中使用库
    22. 导出声音
    23. 在 Animate CC 中选择对象
    24. 在 Animate 中使用 Illustrator AI 文件
    25. 使用喷涂刷工具应用图案
    26. 应用混合模式
    27. 排列对象
    28. 使用“命令”菜单自动处理任务
    29. 多语言文本
    30. 在 Animate 中使用摄像头
    31. 将 Animate 与 Adobe Scout 一起使用
    32. 使用 Fireworks 文件
    33. 图形滤镜
    34. 声音和 ActionScript
    35. 绘制首选参数
    36. 用钢笔工具绘图
  7. 平台
    1. 将 Animate 项目转换为其它文档类型格式
    2. 自定义平台支持
    3. 在 Animate 中创建和发布 HTML5 Canvas 文档
    4. 创建和发布 WebGL 文档
    5. 如何打包 AIR for iOS 应用程序
    6. 发布 AIR for Android 应用程序
    7. 发布用于桌面的 Adobe AIR
    8. ActionScript 发布设置
    9. 最佳做法 - 管理应用程序中的 ActionScript
    10. 如何在 Animate 中使用 ActionScript
    11. 最佳做法 - 辅助功能指南
    12. Animate 工作区中的辅助功能
    13. 编写和管理脚本
    14. 启用自定义平台支持
    15. 自定义平台支持概述
    16. 创建辅助内容
    17. 使用自定义平台支持插件
    18. 调试 ActionScript 3.0
    19. 启用自定义平台支持
  8. 导出和发布
    1. 如何从 Animate CC 导出文件
    2. OAM 发布
    3. 导出 SVG 文件
    4. 使用 Animate 导出图形和视频
    5. 发布 AS3 文档
    6. 导出移动应用程序和游戏引擎的动画
    7. 导出声音
    8. 导出 QuickTime 视频文件
    9. 使用 ActionScript 控制外部视频播放
    10. 最佳做法 - 移动设备内容创建技巧
    11. 最佳做法 - 视频惯例
    12. 最佳做法 - SWF 应用程序创作指南
    13. 最佳做法 - 构造 FLA 文件
    14. 在 Animate 中优化 FLA 文件的最佳做法
    15. ActionScript 发布设置
    16. 指定 Animate 的发布设置
    17. 导出放映文件
    18. 导出图像和动画 GIF
    19. HTML 发布模板
    20. 使用 Adobe Premiere Pro 和 After Effects
    21. 快速分享和发布动画

传统补间是早期用来在 Animate 中创建动画的一种方式。这些补间类似于较新的动画补间,但创建过程更为复杂,也不够灵活。不过,传统补间所具有的某些类型的动画控制功能是动画补间所不具备的。大多数用户选择使用较新的动画补间,但有些用户仍然希望使用传统的补间。有关它们之间差异的详细信息,请参阅动画补间和传统补间之间的差异

准备事项:

在使用传统补间之前,请牢记下列要点:

  • 传统补间是早期用来在 Animate 中创建补间动画的一种方式。较新的方式是使用补间动画,补间动画的使用更加简便。请参阅补间动画

  • 无法使用传统补间来补间 3D 属性。

有关传统补间动画的范例,请参阅“Animate 范例”页,网址为 www.adobe.com/go/learn_fl_samples_cn。下列范例可用:

  • 动画投影:请下载并解压缩 Samples ZIP 文件,然后定位到 Graphics\AnimatedDropShadow 文件夹以访问范例。

  • 动画和渐变:请下载并解压缩 Samples ZIP 文件,然后定位到 Graphics\AnimationAndGradients 文件夹以访问范例。

 像 Animate 中的大部分工作一样,动画不需要任何 ActionScript。然而,如果您愿意,您可以使用 ActionScript 创建动画。

创建和编辑传统补间动画的关键帧

传统补间动画中的变化在关键帧中定义。在补间动画中,可以在动画的重要位置定义关键帧,Animate 会在关键帧之间创建内容。补间动画的插补帧显示为浅蓝色,并会在关键帧之间绘制一个箭头。Animate 文档会保存每一个关键帧中的形状,因此应只在插图中有变化的点处创建关键帧。

关键帧在时间轴中有相应的表示符号:实心圆表示该帧为有内容的关键帧,帧前的空心圆则表示该帧为空白关键帧。以后添加到同一图层的帧的内容将和关键帧相同。

在传统补间中,只有关键帧是可编辑的。可以查看补间帧,但无法直接编辑它们。若要编辑补间帧,请修改一个定义关键帧,或在起始和结束关键帧之间插入一个新的关键帧。从“库”面板中将项目拖动到舞台上,以将这些项目添加到当前关键帧中。

要一次显示和编辑多个帧,请参阅使用绘图纸外观

 本功能与为早期的传统补间创建关键帧有关。有关较新动画补间的属性关键帧的详细信息,请参阅创建补间动画

创建关键帧

  1. 请执行下列操作之一:
    • 在时间轴中选择一个帧,然后选择“插入”>“时间轴”>“关键帧”

    • 右键单击 (Windows) 或按住 Control 单击 (Macintosh) 时间轴中的一个帧,然后选择“插入关键帧”。

在时间轴中插入帧

  • 要插入新帧,请选择“插入”>“时间轴”>“帧”

  • 要创建关键帧,请选择“插入”>“时间轴”>“关键帧”,或者右键单击 (Windows) 或按 Ctrl 并单击 (Macintosh) 帧以放置关键帧。选择“插入关键帧”

  • 要创建空白关键帧,请选择“插入”>“时间轴”>“空白关键帧”,或者右键单击 (Windows) 或按 Ctrl 并单击 (Macintosh) 帧以放置关键帧。选择“插入空白关键帧”

删除或修改帧或关键帧

  • 若要删除帧、关键帧或帧序列,请选择它,然后右键单击 (Windows) 或按住 Control 单击 (Macintosh) 并选择“删除帧”。周围的帧保持不变。

  • 若要移动关键帧或帧序列及其内容,请选择它并将它拖到所需的位置。

  • 若要延长关键帧的持续时间,请在按住 Alt (Windows) 或 Option (Macintosh) 的同时单击将该关键帧拖到新序列的最后一帧。

  • 若要复制和粘贴某个帧或帧序列,请选择它,然后选择“编辑”>“时间轴”>“复制帧”。选择帧或序列,然后选择“编辑”>“时间轴”>“粘贴帧”。要粘贴并替换目标时间轴上同样数目的复制帧,可使用“粘贴并覆盖帧”选项

  • 若要将关键帧转换为帧,请选择该关键帧,然后选择“修改”>“时间轴”>“清除关键帧”,或者右键单击 (Windows) 或按住 Control 单击 (Macintosh) 该关键帧,然后选择“清除关键帧”。被清除的关键帧以及到下一个关键帧之前的所有帧都将由被清除的关键帧之前的帧内容替换。

  • 若要通过拖动来复制关键帧或帧序列,请选择它,然后按住 Alt (Windows) 或按住 Option (Macintosh) 将它拖到新位置。

  • 要更改补间序列的长度,请将开始关键帧或结束关键帧向左或向右拖动。

  • 要将库项目添加到当前关键帧中,请将该项目从“库”面板拖到舞台上。

  • 若要翻转动画序列,请选择一个或多个图层中的合适帧,然后选择“修改”>“时间轴”>“翻转帧”。关键帧必须位于序列的开头和结尾。

向实例、组或文本中添加传统补间动画

 本功能与创建早期的传统补间有关。有关创建较新动画补间的详细信息,请参阅创建补间动画

要对实例、组和类型的属性变化进行补间,您可以使用传统补间。Animate 可以对实例、组和类型的位置、大小、旋转和倾斜进行补间。此外,Animate 可以对实例和类型的颜色进行补间、创建渐变的颜色切换或使实例淡入或淡出。

若要补间组或类型的颜色,请将它们变为元件。若要使文本块中的单个字符分别动起来,请将每个字符放在独立的文本块中。

如果应用传统补间,然后更改两个关键帧之间的帧数,Animate 会再次对帧自动进行补间。或者,如果您在任何一个关键帧中移动组或元件,Animate 会再次对帧自动进行补间。

 

创建传统补间动画

  1. 若要将图层设置为活动图层,请单击图层名称并选择该图层中的空白关键帧以开始。此帧将成为传统补间的第一帧。

  2. 若要向传统补间的第一个帧添加内容,请执行下列操作之一:
    • 用钢笔、椭圆、矩形、铅笔或刷子工具创建一个图形对象,然后把它转换为一个元件。

    • 在舞台中创建一个实例、组或文本块。

    • 将元件的实例从“库”面板中拖出。

     若要创建补间,在图层中只能有一个项目。

  3. 创建第二个关键帧(即动画结束处),并且选择这个新的关键帧。
  4. 若要修改结束帧中的项目,请执行下列任意一项操作:
    • 将项目移动到新的位置。

    • 修改项目的大小、旋转或倾斜。

    • 修改项目的颜色(仅限实例或文本块)。若要补间除实例和文本块以外的元素的颜色,请使用补间形状。

  5. 若要创建传统补间,请执行下列操作之一:
    • 单击补间的帧范围中的任意帧,然后选择“插入”>“传统补间”

    • 右键单击 (Windows) 或按住 Control 并单击 (Macintosh) 补间的帧范围中的任意帧,然后从上下文菜单中选择“创建传统补间”。

    如果在步骤 2 中创建了一个图形对象,Animate 会自动将该对象转换为一个元件并将其命名为 tween1

  6. 若要对选定项目的大小进行补间,请在属性检查器的“补间”部分中选择缩放。作为先决条件,您需要在步骤 4 中修改项目的大小。

  7. 若要产生更逼真的动画效果,可对传统补间应用缓动。若要对传统补间应用缓动,请使用属性检查器的“补间”部分中的“缓动”字段。使用“自定义缓动”对话框可以更精确地控制传统补间的速度。

    若要调整补间帧之间的变化速率,请拖动“缓动”字段中的值或输入一个值。

    • 若要慢慢地开始传统补间,并朝着动画的结束方向加速补间,请输入一个介于 -1 和 -100 之间的负值。

    • 若要快速地开始传统补间,并朝着动画的结束方向减速补间,请输入一个介于 1 到 100 之间的正值。

    • 要在补间的帧间距内生成更复杂的速度变化,请单击“缓动”字段旁的“编辑”按钮。它会打开“自定义缓动”对话框。

      默认情况下,补间帧之间的变化速率是不变的。缓动可以通过逐渐调整变化速率创建更为自然的加速或减速效果。

  8. 若要在补间期间旋转选定项目,请从属性检查器的“旋转”菜单中选择一个选项:
    • 若要防止旋转,请选择“无”(默认设置)。

    • 若要在需要最少动作的方向上将对象旋转一次,请选择“自动”。

    • 若要按指示旋转对象,然后输入一个指定旋转次数的数值,请选择“顺时针”(CW) 或“逆时针”(CCW)。

     在第 8 步中的旋转和在第 4 步中应用到结束帧的任何旋转是相加在一起的。

  9. 如果要使用运动路径,请在属性检查器中选择“调整到路径”,将补间元素的基线调整到运动路径。
  10. 若要使图形元件实例的动画和主时间轴同步,请在属性检查器中选择“同步”选项。

     “同步元件”和“同步”选项都会重新计算补间的帧数,从而匹配分配给它的帧数。如果动画序列中的帧不是图形实例中帧数的偶数倍,则使用“同步”选项。

  11. 如果要使用运动路径,请选择“对齐”以通过补间元素的注册点将补间元素附加到运动路径。

使用传统补间让角色生动起来

通过传统补间让角色活过来。想让您的动画拥有生命?在本示例结尾观看教程并按照这些步骤操作:

  1. 选择对象并单击“修改”

  2. 选择“转换为元件…”并选择以下选项:

    • 名称:输入元件的名称。
    • 类型:在下拉列表中选择“图形”
  3. 单击“确定”并选择任意变形工具

  4. 拖动中心的白色圆点以倾斜对象。

  5. 右键单击该帧并选择“创建传统补间”

如何使用传统补间让您的角色更加生动

观看视频,了解如何生成动画运动。

处理另存为 XML 文件的传统补间

Animate 允许您将传统补间作为 XML 文件处理。Animate 设计为允许您对任何传统补间应用以下命令:

  • 将动画复制为 XML

  • 将动画导出为 XML

  • 将动画导入为 XML

将动画复制为 XML

允许您复制特定帧处应用到舞台上任一对象的动画属性 

  1. 创建传统补间。

  2. 选择时间轴上的任一个关键帧。

  3. 转至“命令”>“将动画复制为 XML”

运动属性将作为 XML 数据被复制到剪贴板。然后,您可以使用任何文本编辑器处理 XML 文件。

将动画导出为 XML

允许您将应用到舞台上任一对象的动画属性导出到一个可以保存的 XML 文件。

 

  1. 创建传统补间。 

  2. 转至“命令”>“将动画导出为 XML”

  3. 浏览到要保存此文件的合适位置。

  4. 提供 XML 文件的名称,然后单击“保存”

    传统补间即作为一个 XML 文件导出到指定位置。

将动画导入为 XML

允许您导入一个已定义了动画属性的现有 XML 文件。

  1. 选择舞台上的对象。

  2. 转至“命令”>“将动画导入为 XML”

  3. 浏览到特定位置,选择该 XML 文件。单击“确定”

  4. “选择性粘贴动画”对话框中,选择要对选定对象应用的属性。

  5. 单击“确定”

创建运动引导层

若要控制传统补间动画中的对象的移动,请创建运动引导层。

无法将补间动画图层或反向运动姿势图层拖动到引导层上。

  1. 将常规层拖动到引导层上。此操作会将引导层转换为运动引导层,并将常规图层链接到新的运动引导层。

     为了防止意外转换引导层,可以将所有引导层放在图层顺序的底部。

沿路径创建传统补间动画

 本功能与使用早期的传统补间有关。有关对运动路径使用较新的补间动画的详细信息,请参阅编辑补间动画的运动路径

运动引导层使您可以绘制路径,补间实例、组或文本块可以沿着这些路径运动。可以将多个层链接到一个运动引导层,使多个对象沿同一条路径运动。链接到运动引导层的常规层就成为引导层。

运动路径
本示例中,不同层上的两个对象被附加到同一条运动路径上。

为传统补间动画创建运动路径

  1. 创建有传统补间动画的动画序列。

    如果在属性检查器中选择“调整到路径”,补间元素的基线就会调整到运动路径。如果选择“对齐”,补间元素的注册点将会与运动路径对齐。

  2. 右键单击 (Windows) 或按住 Control 并单击 (Macintosh) 包含传统补间的图层的名称,然后选择“添加传统运动引导层”。

    Animate 可在传统补间图层上方添加运动引导层,并缩进传统补间图层的名称。它表示传统补间图层已绑定到该运动引导层。

     如果您在时间轴中已有引导图层,您可以将包含传统补间的图层拖到该引导层下方。此操作会将引导层转换为运动引导层,并将传统补间绑定到该引导层。

    运动引导层
    位于包含传统补间的图层上方的运动引导层。

  3. 要向该运动引导层添加路径,请选择该运动引导层,然后使用钢笔、铅笔、线条、圆形、矩形或画笔工具。

    也可以将笔触粘贴到运动引导层。

  4. 拖动要补间的对象,以将其贴紧到第一帧的开头或最后一帧的结尾。

    贴紧至引导笔触开头的图形
    贴紧至引导笔触开头的汽车图形

     通过拖动元件的变形点能获得最好的贴紧效果。

  5. 若要隐藏运动引导层和路径,请在运动引导层上的眼睛图标列中单击。如果隐藏,则在您操作时只有对象的移动是可见的。 

    当播放动画时,组或元件将沿着运动路径移动。

要了解可变宽度笔触和可变笔触颜色方面动画指南的更多信息,请参阅动画指南

  1. 请执行下列操作之一:
    • 将现有图层拖到运动引导层的下面。该图层在运动引导层下面以缩进形式显示。该图层上的所有对象自动与运动路径对齐。

    • 在运动引导层下面创建一个图层。在该图层上补间的对象自动沿着运动路径进行补间。

    • 在运动引导层下面选择一个图层。选择“修改”>“时间轴”>“图层属性”,然后选择“引导层”

  1. 若要取消链接,请选择该图层并执行下列操作之一:

    • 拖动运动引导层上面的图层。

    • 选择“修改”>“时间轴”>“图层属性”,然后选择“正常”作为图层类型。

粘贴传统补间动画属性

 本功能用于粘贴早期传统补间的属性。有关粘贴较新的动画补间的属性的详细信息,请参阅复制和粘贴动画补间属性

使用“粘贴动画”命令可复制传统补间,并且可只粘贴要应用于其他对象的特定属性。

  1. 在包含要复制的传统补间的时间轴中选择帧。所选的帧必须位于同一层上,但它们的范围不必只限于一个传统补间。可选择一个补间、若干空白帧或者两个或更多补间。
  2. 选择“编辑”>“时间轴”>“复制动画”

  3. 若要接收所复制的传统补间,请选择元件实例。

  4. 选择“编辑”>“时间轴”>“选择性粘贴动画”。选择要粘贴到该元件实例中的特定传统补间属性。传统补间属性包括:

    X 位置

    对象在 x 方向上移动的距离。

    Y 位置

    对象在 y 方向上移动的距离。

    水平缩放

    在水平方向 (X) 上对象的当前大小与其自然大小的比值。

    垂直缩放

    指定在垂直方向 (Y) 上对象的当前大小与其自然大小的比值。

    旋转和倾斜

    对象的旋转和倾斜。必须将这两个属性同时应用于对象。倾斜是旋转度量(以度为单位),同时应用旋转和倾斜时,这两个属性会相互影响。

    颜色

    所有颜色值(如“色调”、“亮度”和“Alpha”)都会应用于对象。

    滤镜

    所选间距的所有滤镜值和更改。如果对对象应用了滤镜,则会粘贴该滤镜(不改动其任何值)。并且它的状态(启用或禁用)将应用于新的对象。

    混合模式

    应用对象的混合模式。

    覆盖目标缩放属性

    如果取消选择,则指定相对于目标对象粘贴所有属性。如果选中,此选项将覆盖目标的缩放属性。

    覆盖目标的旋转和倾斜属性

    如果取消选择,则它指定相对于目标对象粘贴所有属性。如果选中,所粘贴的属性将覆盖对象的现有旋转和缩放属性。

    将插入必需的帧、补间和元件信息,以匹配所复制的原始补间。

    若要将元件的传统补间复制到“动作”面板或在其他项目中将它用作 ActionScript,请使用“将动画复制为 ActionScript 3.0 脚本”命令。

创建缓动预设

缓动预设是可以应用于舞台上某个对象的预配置缓动。

传统补间可以使用一组常用的缓动预设。您可以从缓动预设列表中选择预设,然后将其应用于选定属性。

  1. 在 Animate 时间轴中单击包含补间的图层。

  2. 要打开“补间”属性,请单击属性面板中的“补间”类别。您可以使用“缓动类型”下拉列表访问属性缓动。

    您可以对传统补间应用缓动预设属性。在“属性”面板中,提供了用于选择属性缓动的选项。您可以选择“每个属性独立”以对每个属性应用不同的缓动预设。

    property-wise 预设
    property-wise 预设

    您可为传统补间的位置、旋转、缩放、颜色和滤镜属性选择唯一的缓动预设。 

    位置为舞台上动画对象的位置指定缓动设置。

    旋转为舞台上的动画对象的旋转指定缓动设置。

    缩放为舞台上的动画对象的缩放指定缓动设置。

    颜色为应用于舞台上动画对象的颜色转变指定缓动设置。

    滤镜为应用于舞台上动画对象的滤镜指定缓动设置。

  3. 或者,如果您要在补间的所有属性中应用相同的缓动,请选择“所有属性”选项。从“缓动类型”弹出对话框中选择您选择的缓动预设,然后双击要应用的缓动预设。

    如果选择应用传统缓动,也可以通过移动滑块来增大或减小缓动强度。 

    缓动预设列表
    缓动预设列表

  4. 单击“缓动”旁边的“编辑”图标以应用自定义缓动。

如果您使用 HTML5 Canvas 文档类型,则可以优化缓动预设的 js 输出文件。创建输出时,HTML5 Canvas 使用 Tween JS 的缓动功能。 

对传统补间动画应用自定义缓动

 本功能用于向早期的传统补间添加缓动。有关向较新的补间动画添加缓动的详细信息,请参阅缓动补间动画

“自定义缓动”对话框显示一个表示运动程度随时间而变化的图形。水平轴表示帧,垂直轴表示变化的百分比。第一个关键帧表示为 0%,最后一个关键帧表示为 100%。

图形曲线的斜率表示对象的变化速率。曲线水平时(无斜率),变化速率为零;曲线垂直时,变化速率最大,一瞬间完成变化。

保存自定义缓动

通过从自定义列表中选择您的自定义缓动,您可以通过单击相应按钮并重用该自定义缓动来保存这些缓动。在进行更改后,在编辑模式下单击“保存和应用”。在以下屏幕快照中,您可以查找名为 MyEase1 的自定义缓动预设。

 您只能在相同文档类型中重用自定义缓动预设。

通过选择相应的范围和应用预设缓动,您可以在时间轴中的多个范围内使用这些预设缓动。

CustomEase 对话框中的更多控件

播放和停止按钮

您可以使用“自定义缓动”对话框中定义的所有当前速率曲线,预览舞台上的动画。

删除

删除当前的自定义缓动。 

保存并应用

保存和应用您对缓动预设所做的更改。 

“重置”按钮

允许您将速率曲线重置为默认的线性状态。

所选控制点的位置

在该对话框的右下角,一个数值显示所选控制点的关键帧和位置。如果没有选择控制点,则不显示数值。

若要在线上添加控制点,请单击对角线一次。若要实现对对象动画的精确控制,请拖动控制点的位置。

使用帧指示器(用方形手柄表示),单击要减缓或加速对象的位置。单击控制点的方形手柄,可选择该控制点,并显示其两侧的正切点。空心圆表示正切点。要放置它们,请使用鼠标或键盘上的箭头键拖动控制点或其切点。

提示:默认情况下,控制点贴紧至网格。可以通过在拖动控制点时按住 X 键来取消贴紧。

单击远离任何控制点的曲线的某个区域,并在该点向曲线添加一个控制点。此操作不会更改曲线的形状。单击曲线和控制点之外的区域,可以取消选择当前选择的控制点。

添加自定义缓动

  1. 选择时间轴中一个已应用了传统补间的图层。

  2. 在帧属性检查器中单击“缓动”滑块旁边的“编辑”按钮。
  3. 若要添加控制点,请在按住 Ctrl (Windows) 或 Command (Macintosh) 的同时单击对角线。
  4. 若要增加对象的速度,请向上拖动控制点;若要降低对象的速度,请向下拖动控制点。
  5. 若要进一步调整缓入缓出曲线,并微调补间的缓动值,请拖动顶点手柄。
  6. 要查看舞台上的动画,请单击左下角的“播放”按钮。

  7. 调整控件直到获得所需的效果。

 如果您使用“自定义缓动”对话框,则编辑字段会显示 --。如果您使用编辑或弹出滑块,则会将自定义缓动图形设置为等效曲线。此外,还会选中“对所有属性使用一种设置”复选框。

复制和粘贴缓动曲线

  • 若要复制当前缓动曲线,请按 Ctrl+C (Windows) 或 Command+C (Macintosh)。

  • 若要将已复制的曲线置于另一个缓动曲线中,请按 Ctrl+V (Windows) 或 Command+V (Macintosh)。

    您可以复制和粘贴缓动曲线。在退出 Animate 应用程序前,复制的曲线一直可用于粘贴。

不支持的缓入缓出曲线

不支持某些类型的缓入缓出曲线。图形的任何部分都不能表示非线性曲线(例如圆)。

“自定义缓入缓出”对话框会自动阻止将控制点或切线手柄移动到会呈现无效曲线的位置:

  • 所有点都必须在图形上。不能将控制点移动到图形边框之外。

  • 所有曲线的线段都必须在图形内部。曲线的形状将变平,以阻止它伸到图形边框之外。

Adobe 徽标

登录到您的帐户