用户指南 取消(C)

编写和管理脚本

  1. Adobe Animate 用户指南
  2. Animate 简介
    1. Animate 新增功能
    2. 图示术语表
    3. Animate 系统要求
    4. Animate 键盘快捷键
    5. 在 Animate 中使用多种文件类型
  3. 动画
    1. Animate 动画基础知识
    2. 如何在 Animate 中使用帧和关键帧
    3. 在 Animate 中使用逐帧动画
    4. 如何在 Animate 中使用经典补间动画
    5. 画笔工具
    6. 运动辅助线
    7. 补间动画和 ActionScript 3.0
    8. 关于运动补间动画
    9. 补间动画
    10. 创建补间动画
    11. 使用属性关键帧
    12. 用补间对位置进行动画处理
    13. 如何使用动画编辑器编辑补间动画
    14. 编辑补间动画的运动路径
    15. 处理补间动画
    16. 添加自定义缓动
    17. 创建和应用动画预设
    18. 设置动画的补间范围
    19. 处理另存为 XML 文件的补间动画
    20. 补间动画与传统补间
    21. 形状补间
    22. 在 Animate 中使用骨骼工具动画
    23. 在 Animate 中处理角色操纵
    24. 如何在 Adobe Animate 中使用遮罩层
    25. 如何在 Animate 中使用场景
  4. 交互性
    1. 如何使用 Animate 创建按钮
    2. 将 Animate 项目转换为其它文档类型格式
    3. 在 Animate 中创建和发布 HTML5 Canvas 文档
    4. 在 Animate 中通过代码片段添加交互性
    5. 创建自定义 HTML5 组件
    6. 使用 HTML5 Canvas 中的组件
    7. 创建自定义组件:示例
    8. 自定义组件的代码片段
    9. 最佳做法 - 使用 Animate 制作广告
    10. 虚拟现实创作和发布
  5. 工作区和工作流
    1. 创建和管理画笔
    2. 在 HTML5 Canvas 文档中使用 Google 字体
    3. 使用 Creative Cloud Libraries 和 Adobe Animate
    4. 使用 Animate 的舞台和工具面板
    5. Animate 工作流程和工作区
    6. 在 HTML5 Canvas 文档中使用 Web 字体
    7. 时间轴和 ActionScript
    8. 使用多个时间轴
    9. 设置首选参数
    10. 使用 Animate 创作面板
    11. 使用 Animate 创建时间轴图层
    12. 导出移动应用程序和游戏引擎的动画
    13. 移动和复制对象
    14. 模板
    15. 在 Animate 中查找和替换
    16. 撤消、重做和历史记录面板
    17. 键盘快捷键
    18. 如何在 Animate 中使用时间轴
    19. 创建 HTML 扩展
    20. 图像和动画 GIF 的优化选项
    21. 图像和 GIF 的导出设置
    22. Animate 中的资源面板
  6. 多媒体与视频
    1. 在 Animate 中变形和合并图形对象
    2. 在 Animate 中创建并使用元件实例
    3. 图像描摹
    4. 如何在 Adobe Animate 中使用声音
    5. 导出 SVG 文件
    6. 创建用于 Animate 中的视频文件
    7. 如何在 Animate 中添加视频
    8. 使用 Animate 绘制和创建对象
    9. 改变线条和形状
    10. Animate CC 中的笔触、填充和渐变
    11. 使用 Adobe Premiere Pro 和 After Effects
    12. Animate CC 中的颜色面板
    13. 使用 Animate 打开 Flash CS6 文件
    14. 在 Animate 中使用传统文本
    15. 向 Animate 中置入图稿
    16. 在 Animate 中导入的位图
    17. 3D 图形
    18. 在 Animate 中使用元件
    19. 使用 Adobe Animate 绘制线条和形状
    20. 在 Animate 中使用库
    21. 导出声音
    22. 在 Animate CC 中选择对象
    23. 在 Animate 中使用 Illustrator AI 文件
    24. 应用混合模式
    25. 排列对象
    26. 使用“命令”菜单自动处理任务
    27. 多语言文本
    28. 在 Animate 中使用摄像头
    29. 图形滤镜
    30. 声音和 ActionScript
    31. 绘制首选参数
    32. 用钢笔工具绘图
  7. 平台
    1. 将 Animate 项目转换为其它文档类型格式
    2. 自定义平台支持
    3. 在 Animate 中创建和发布 HTML5 Canvas 文档
    4. 创建和发布 WebGL 文档
    5. 如何打包 AIR for iOS 应用程序
    6. 发布 AIR for Android 应用程序
    7. 发布用于桌面的 Adobe AIR
    8. ActionScript 发布设置
    9. 最佳做法 - 管理应用程序中的 ActionScript
    10. 如何在 Animate 中使用 ActionScript
    11. Animate 工作区中的辅助功能
    12. 编写和管理脚本
    13. 启用自定义平台支持
    14. 自定义平台支持概述
    15. 使用自定义平台支持插件
    16. 调试 ActionScript 3.0
    17. 启用自定义平台支持
  8. 导出和发布
    1. 如何从 Animate CC 导出文件
    2. OAM 发布
    3. 导出 SVG 文件
    4. 使用 Animate 导出图形和视频
    5. 发布 AS3 文档
    6. 导出移动应用程序和游戏引擎的动画
    7. 导出声音
    8. 最佳做法 - 移动设备内容创建技巧
    9. 最佳做法 - 视频惯例
    10. 最佳做法 - SWF 应用程序创作指南
    11. 最佳做法 - 构造 FLA 文件
    12. 在 Animate 中优化 FLA 文件的最佳做法
    13. ActionScript 发布设置
    14. 指定 Animate 的发布设置
    15. 导出放映文件
    16. 导出图像和动画 GIF
    17. HTML 发布模板
    18. 使用 Adobe Premiere Pro 和 After Effects
    19. 快速分享和发布动画
  9. 故障排除
    1. 已修复的问题
    2. 已知问题

 

设置代码格式

可以在键入时自动设置代码格式及自动缩进代码。如果使用动态字体映射,请确保对多语言文本使用正确的字体。

设置自动套用格式选项

  1. 请执行下列操作之一:
    • 在面板菜单 (位于动作面板的右上角)中选择“首选参数”。

    • 在“脚本”窗口中选择“编辑”>“首选参数”(Windows) 或“Animate”>“首选参数”(Macintosh)。

  2. 在“首选参数”对话框中,选择“自动套用格式”。
  3. 选择任意“自动套用格式”选项。

    在设置“自动套用格式”选项后,所作设置将自动应用于您编写的代码,但不应用于现有代码;您必须手动将这些设置应用于现有代码。

按照自动套用格式设置设置代码格式

  • 在动作面板或“脚本”窗口工具栏中单击“自动套用格式”
  • 在面板菜单(位于动作面板的右上角)中选择“自动套用格式”。
  • 按下 Ctrl+Shift+F 组合键 (Windows) 或 Command+Shift+F 组合键 (Macintosh)。
  • 在“脚本”窗口中,选择“工具”>“自动套用格式”。

使用动态字体映射

  1. 若要打开或关闭动态字体映射,请在“首选参数”对话框中相应地选择或取消选择“使用动态字体映射”。

    由于动态字体映射会在进行脚本撰写时延长运行时间,默认情况下它是关闭的。 如果您正在处理多语言文本,则应该打开动态字体映射,这有助于确保使用正确的字体。

使用自动缩进

  1. 若要打开或关闭自动缩进,请在“首选参数”对话框中相应地选择或取消选择“自动缩进”。

    如果打开了自动缩进,在左小括号 “(” 或左大括号 “{” 之后键入的文本将按照 ActionScript 首选参数中的“制表符大小”设置自动缩进。

    在脚本中,选择某行并按 Tab 则可以缩进该行。 要取消缩进,请选择该行,然后按下 Shift+Tab 组合键。

对代码中的某些部分进行注释

代码注释是代码中被 ActionScript 编译器忽略的部分。 注释行可解释代码的操作,也可以暂时停用您不想删除的代码。通过在代码行的开头加上双斜杠 (//) 可对其进行注释。 编译器将忽略双斜杠后面一行的所有文本。 您还可以对较大的代码块进行注释,方法是:在代码块的开头加上一个斜杠和一个星号 (/*),并在代码块的结尾加上一个星号和一个斜杠 (*/)。

您可以手动键入这些注释标记,也可以使用动作面板或“脚本”窗口顶部的按钮来添加它们。

对代码行进行注释

  1. 将插入点置于代码行的开头或要从该处开始进行注释的字符处。
  2. 右键单击并选择“注释”。您也可以使用键盘快捷键 Ctrl + M (Windows) 或 Command + M,或者转到“编辑”>“注释所选内容”。

一个双斜杠 (//) 将会被置于插入点处。

对多行代码进行注释

  1. 选择要注释的行。 (首行和末行可以只部分选定。)
  2. 右键单击并选择“注释”。您也可以使用键盘快捷键 Ctrl + M (Windows) 或 Command + M,或者转到“编辑”>“注释所选内容”。

块注释字符将被置于所选代码块的开头 (/*) 和结尾 (*/)。

注意:

如果所选文本行之间存在注释,将会对所有选定的行应用一条行注释。

删除注释

  1. 将插入点置于含有注释的代码行中,或者选择已注释的代码块。
  2. 右键单击并选择“取消注释”。您也可以使用键盘快捷键 Ctrl + Shift + M (Windows) 或 Command + Shift + M,或者转到“编辑”>“取消注释所选内容”。

使用语法着色

在 ActionScript 中,就像在任何语言中一样,语法 是将元素组合在一起产生意义的方式。 如果使用了错误的 ActionScript 语法,脚本将不会运行。

若要加亮显示语法错误,请为脚本的各部分设置颜色代码。 例如,假设您设置了语法着色首选参数,用蓝色显示关键字。 当您键入 var 时,单词 var 显示为蓝色。 但是,如果您错误地键入了 vae,则单词 vae 将保持为黑色,使您能注意到键入的单词有误。

请执行下列操作之一:

  • 选择“编辑”>“首选参数”(Windows) 或“Animate”>“首选参数”(Macintosh),在“类别”列表中单击“代码编辑器”,然后指定“语法着色”设置。

  • 将插入点置于“脚本”窗格中,按下 Ctrl-U (Windows) 或 Command-U (Macintosh)。

注意:

当您在“动作”面板中编写脚本时,动作工具箱中将以黄色显示您的目标播放器版本不支持的命令。 例如,如果 Flash Player SWF 文件版本设置为 Flash 7,仅受 Flash Player 8 支持的 ActionScript 就在动作工具箱中显示为黄色。

在运行时使用标识符和关键字列表

Animate 在启动时,它会从资源文件中读取标识符和关键字列表,并将其放入缓存。除了从资源读取默认列表外,它还会扫描 Preference 文件夹中的其他关键字和标识符列表。可以通过在以下文件夹中添加“.txt”文件来添加额外的关键字和标识符:

  • C:\Users\<用户名>[AppData]\Roaming\Adobe\Animate\13.0[ActionscriptKeywords]\

  • C:\Users\<用户名>[AppData]\Roaming\Adobe\Animate\13.0[ActionscriptIdentifiers]\

  • C:\Users\<用户名>[AppData]\Roaming\Adobe\Animate\13.0[JavascriptKeywords]\

  • C:\Users\<用户名>[AppData]\Roaming\Adobe\Animate\13.0[JavascriptIdentifiers]\

使用行号和自动换行

编辑或修改代码时,行号可使代码的滚动和分析更加容易。 自动换行使您不用水平滚动很长的代码行(特别是在撰写环境中或屏幕分辨率较低时)。

启用或禁用行号

  • 在“脚本”窗口中,选择“查看”>“行号”。
  • 按下 Ctrl+Shift+L 组合键 (Windows) 或 Command+Shift+L 组合键 (Macintosh)。

加亮显示特定行

  • 在“脚本”窗口中,选择“编辑”>“转到行”。

启用或禁用自动换行

  • 在“脚本”窗口中,选择“查看”>“自动换行”。
  • 按下 Ctrl+Shift+W (Windows) 或 Command+Shift+W (Macintosh)。

显示隐藏字符

在 ActionScript 代码中,诸如空格、制表符和换行符这样的字符会被隐藏。 您可能需要显示这些字符;例如,必须查找并删除不属于字符串值一部分的双字节空格,因为它们会引发编译器错误。

  • 按下 Ctrl+Shift+8 (Windows) 或 Command+Shift+8 (Macintosh)。

以下符号用于显示隐藏的字符。

隐藏字符

符号

单字节空格

.

双字节空格

l

制表符

>>

换行符


在脚本中查找文本

“查找”工具允许您查找并替换脚本中的文本字符串。

注意:

若要在 Animate 文档的所有脚本中搜索文本,请使用“影片浏览器”。

查找文本

  1. 在动作面板或“脚本”窗口中,单击“查找” 或者按 Ctrl+F (Windows) 或 Command+F (Macintosh)。
  2. 输入搜索字符串。
  3. 单击“查找下一个”。

在脚本中查找并替换文本

  1. 在动作面板或“脚本”窗口中,单击“查找” 或者按 Ctrl+F (Windows) 或 Command+F (Macintosh)。
  2. 输入搜索字符串。
  3. 在“替换为”文本框中,输入新字符串。
  4. 单击“查找下一个”。
  5. 要替换该字符串,请单击“替换”;要替换该字符串的所有匹配项,请单击“全部替换”。

(Animate 中已弃用)在动作面板中重复搜索

  1. 在面板菜单 (位于动作面板的右上角)中,选择“再次查找”。

(Animate 中已弃用)在脚本窗口中重复搜索

  1. 选择“编辑”>“再次查找”。

(Animate 中已弃用)检查语法和标点

您不必发布 FLA 文件就可以快速检查 ActionScript 代码。

检查语法时,也就检查了当前的脚本。 如果当前脚本调用 ActionScript 类,则也会检查那些类。但不会检查可能位于 FLA 文件中的其他脚本。

对于 ActionScript 2.0 文件,“语法检查”通过编译器运行代码,从而生成语法错误和编辑器错误。

对于 ActionScript 3.0 文件,“语法检查”只生成语法错误。要生成编译器错误,如类型不匹配、返回值不正确以及变量或方法名拼写错误,必须使用“控制”>“测试”命令。

语法检查

要检查语法,请执行以下操作之一:

  • 在动作面板或“脚本”窗口中,单击“语法检查”
  • 单击“脚本”窗格,然后按下 Ctrl+T (Windows) 或 Command+T (Macintosh)。在“脚本”面板中单击或键入可确定其焦点。如果舞台上的对象有焦点,将打开“变形”面板。

语法错误列在“编译器错误”面板中。

注意:

在“脚本”窗口的外部 ActionScript 类文件中,全局类路径 (AS2) 或源路径 (AS3) 会影响语法检查。即便正确设置了全局类路径或源路径,也可能生成错误,因为编译器不知道该类已编译。

检查标点平衡

  1. 在脚本中的大括号 {}、中括号 [] 或小括号 () 之间单击。
  2. 在 Windows 中,按下 Ctrl+'(单引号);在 Macintosh 中,按下 Command+'(单引号)。 加亮显示大括号、中括号或小括号间的文本,您可以检查开始标点符号是否有与之对应的结束标点符号。

(Animate 中已弃用)导入和导出脚本

您可以将脚本导入动作面板或“脚本”窗口中。 您也可以将脚本从动作面板导出到外部 ActionScript 文件。 (使用“脚本”窗口时,不必进行导出,因为可以改为保存 AS 文件。)

如果在打开或导入文件时脚本中文本的外观与预期不符,请更改导入编码首选参数。

导入外部 AS 文件

  1. 在“脚本”窗格中,将插入点置于您希望外部脚本的第一行所位于的位置。
  2. 请执行下列操作之一:
    • 在“动作”面板中,从面板菜单中选择“导入脚本”,或者按下 Ctrl+Shift+I (Windows) 或 Command+Shift+I (Macintosh)。

    • 在“脚本”窗口中,选择“文件”>“导入脚本”,或者按下 Ctrl+Shift+I (Windows) 或 Command+Shift+I (Macintosh)。

从动作面板中导出脚本

  1. 选择要导出的脚本。 在“动作面板”菜单中,选择“导出脚本”,或者按下 Ctrl+Shift+X (Windows) 或 Command+Shift+X (Macintosh)。
  2. 保存该 ActionScript (AS) 文件。

设置文本编码选项

  1. 选择“编辑”>“首选参数”(Windows) 或“Animate”>“首选参数”(Macintosh),然后在“类别”列表中选择“ActionScript”。

  2. 设置以下任何选项:

    打开/导入

    选择“UTF-8 编码”以使用 Unicode 编码进行打开或导入,或者选择“默认编码”以使用系统当前所用语言的编码形式进行打开或导入。

    保存/导出

    选择“UTF-8 编码”以使用 Unicode 编码进行保存或导出,或者选择“默认编码”以使用系统当前所用语言的编码形式进行保存或导出。

关闭或打开导出编码警告

  1. 选择“编辑”>“首选参数”(Windows) 或“Animate”>“首选参数”(Macintosh),然后在“类别”列表中选择“警告”。

  2. 选择或取消选择“导出 ActionScript 文件过程中编码发生冲突时发出警告”。

(Animate 中已弃用)导入和导出脚本的编码

您可以设置 ActionScript 首选参数,以指定导入或导出的 ActionScript 文件所使用的编码类型。 “UTF-8 编码”是 8 位 Unicode 格式,允许您在文件中包括多种语言的文本;“默认编码”是系统当前使用的语言所支持的编码,也称为传统代码页

注意:

在英文系统上使用非英文应用程序时,如果 SWF 文件路径的任何部分具有不能使用多字节字符集 (MBCS) 编码方案表示的字符,则“测试影片”命令将失败。 例如,日文路径(在日文系统上可以使用)就不能在英文系统上使用。 请确保在英文系统中使用仅包含英文的路径名。 使用“测试影片”播放器的应用程序的所有方面都受到此限制的约束。

在动作面板中固定脚本

使用“固定脚本”功能可以固定脚本窗格中各个脚本的标签并相应移动它们。此功能在您还没有将 FLA 文件中的代码组织到一个集中的位置或者在使用多个脚本时非常有用。

您可以将脚本固定,以保留代码在动作面板中的打开位置,然后在各个打开着的不同脚本中切换。这在调试时特别有用。 

您还可以取消固定某个脚本或取消固定所有脚本,以便取消固定动作面板中的某个选定脚本,或者取消固定其中的所有脚本。

在下图中,与时间轴上当前位置关联的脚本位于名为“Cleanup”的图层的第 1 帧上。 (最左侧的选项卡始终在时间轴上您的位置的后面。) 该脚本还被固定,如最右侧选项卡所显示。以下两个脚本被固定:

  • 在第 1 帧(Frame 1)上
  • 在名为“Intro”的图层的第 15 帧(Frame 15)上

使用键盘快捷键或单击这些选项卡可以在各个固定的脚本之间移动。在各个固定的脚本之间移动并不更改您在时间轴上的当前位置。如果在动作脚本导航器中选中一个新的脚本,焦点将移到第一帧,即“Frame 1”。

注意:

如果“脚本”窗格中的内容未进行相应更改来反映您在时间轴上选择的位置,则“脚本”窗格可能正显示一个固定的脚本。单击“脚本”窗格左上角的当前帧选项卡可以显示与时间轴上的位置相关联的脚本。

固定的脚本

固定脚本

  1. 单击“时间轴”,使脚本出现在“动作”面板中“脚本”窗格左上角的当前帧选项卡内。

  2. 请执行下列操作之一:
    • 单击该选项卡右侧的图钉图标。
    • 选择“视图”>“固定脚本”来固定脚本。

     

取消固定所有脚本

  1. 在动作面板中选择固定的脚本。

  2. 选择“视图”>“取消固定脚本”,取消固定动作面板中选中的脚本。

  3. 选择“视图”>“取消固定所有脚本”,取消固定动作面板中的所有脚本。

取消固定选项

用于固定脚本的键盘快捷键

当插入点位于“脚本”窗格内时,请通过以下键盘快捷键来使用固定的脚本。

动作

Windows 

Macintosh

固定脚本

Control+Shift+=(等号)

Command+Shift+=

取消固定脚本

Control+Shift+-(减号)

Command+Shift+-

插入目标路径

许多脚本动作都会影响影片剪辑、按钮和其他元件实例。 在代码中,可以引用时间轴上的元件实例,方法是插入目标路径,即希望设为目标的实例地址。 可以设置绝对或相对目标路径。 绝对路径包含实例的完整地址。 相对路径仅包含与脚本在 FLA 文件中的地址不同的部分地址,如果脚本移动到另一位置,则地址将会失效。

  1. 在“动作”面板中,单击脚本中的一个动作。
  2. 单击“目标路径”
  3. 输入目标实例的路径,或从列表中选择目标。
  4. 选择绝对或相对路径选项。

使用代码提示

在“动作”面板或“脚本”窗口中工作时,软件可以检测到正在输入的动作并显示代码提示。有两种类型的代码提示:包含该动作的完整语法的工具提示和列出可能的 ActionScript 元素(如方法或属性名)的弹出菜单(有时被称为某种形式的代码完成)。

默认情况下启用代码提示。 通过设置首选参数,可以禁用代码提示或确定它们出现的速度。 如果在首选参数中禁用了代码提示,则仍可通过手动方式为特定命令显示代码提示。

注意:

如果无法为 ActionScript 2.0 中创建的变量或对象显示代码提示,但已在 ActionScript 首选参数中启用了代码提示,请确保用适当的后缀命名了变量或对象,或者严格指定了变量或对象的类型。

启用代码提示

可以通过各种方式触发代码提示。

严格指定对象的类型

在您使用 ActionScript 2.0,并严格指定基于内置类(例如 Button、Array 等)的变量的类型时,“脚本”窗格会为该变量显示代码提示。 例如,假设您输入以下两行代码:

var foo:Array = new Array(); 
foo.

输入句点 (.) 后,Animate 会在一个弹出菜单中显示可用于 Array 对象的方法和属性的列表,因为您已经将该变量的类型指定为数组。

后缀和代码提示

如果您使用的是 ActionScript 1.0,或者未严格指定对象的类型而又想显示这些对象的代码提示,请在创建每个对象时在其名称后添加一个后缀。 例如,触发 Camera 类的代码提示的后缀为 _cam。 假设您键入了以下代码: var my_array = new Array(); var my_cam = Camera.get();

如果键入 my_cam,然后键入一个句点,就会显示 Camera 对象的代码提示。

对于在舞台上出现的对象,请使用“属性”检查器的“实例名称”框中的后缀。 例如,若要显示 MovieClip 对象的代码提示,请使用属性检查器为所有 MovieClip 对象指定带有 _mc 后缀的实例名称。 然后,只要您键入实例名称然后再键入一个句点,就会显示代码提示。

var my_array = new Array(); 
var my_cam = Camera.get();
注意:

尽管在严格指定对象的类型时不需要使用后缀来触发代码提示,但一直使用后缀有助于理解代码。

下表列出了在 ActionScript 2.0 中触发代码提示的后缀:

对象类型

变量后缀

Array

_array

Button

_btn

Camera

_cam

Color

_color

ContextMenu

_cm

ContextMenuItem

_cmi

Date

_date

Error

_err

LoadVars

_lv

LocalConnection

_lc

Microphone

_mic

MovieClip

_mc

MovieClipLoader

_mcl

PrintJob

_pj

NetConnection

_nc

NetStream

_ns

SharedObject

_so

Sound

_sound

String

_str

TextField

_txt

TextFormat

_fmt

Video

_video

XML

_xml

XMLNode

_xmlnode

XMLSocket

_xmlsocket

注释和代码提示

您也可以使用 ActionScript 注释来指定对象的类以便于进行代码提示。 下面的示例中,将使用一个注释告诉 ActionScript theObject 实例的类是 Object,依此类推。

// Object theObject;// Array theArray;// MovieClip theMC;

随后,如果您输入 theMC 然后再输入一个句点,就会出现代码提示,显示 MovieClip 方法和属性的列表。 如果您输入 theArray 然后再输入一个句点,就会出现代码提示,显示 Array 方法和属性的列表,依此类推。

不过,Adobe 建议使用严格数据类型指定或使用后缀,而不建议使用此技术,因为前面的两种技术可自动启用代码提示,并且使代码更易理解。

指定自动代码提示的首选参数设置

  • 在动作面板或“脚本”窗口中,选择“编辑”>“首选参数”(Windows) 或“Animate”>“首选参数”(Macintosh),在“类别”列表中单击“代码编辑器”,然后启用或禁用“代码提示”。

(Animate 中已弃用)指定代码提示的延迟时间

  1. 在动作面板或“脚本”窗口中,选择“编辑”>“首选参数”(Windows) 或“Animate”>“首选参数”(Macintosh)。

  2. 在“类别”列表中单击“ActionScript”。
  3. 使用滑块选择延迟的时间(以秒为单位)。

使用工具提示样式的代码提示

  1. 在需要小括号的元素(诸如方法名称之后的 ifdo.. 等命令)之后键入左小括号“(”以显示代码提示。while 之类的命令之后键入一个左小括号“(”来显示代码提示。
    左小括号调用代码提示

  2. 输入参数的值。

    对于多个参数,请用逗号隔开各个值。 对于函数或语句(如 for 循环),请用分号隔开各个参数。

    gotoAndPlay()for 之类的重载命令(即可以用不同参数集调用的函数或方法)会显示一个指示器,让您选择要设置的参数。 要选择参数,请单击小箭头或者按下 Ctrl+向左箭头组合键和 Ctrl+右箭头组合键。

    一个代码提示含有多组参数

  3. 若要使代码提示消失,请执行下列操作之一:
    • 键入右小括号 “)”。

    • 单击该语句之外的地方。

    • 按下 Esc。

使用菜单样式的代码提示:

  1. 通过在变量或者对象名称后键入句点来显示代码提示。
    菜单样式的代码提示

  2. 要导航代码提示,可用向上和向下箭头键。
  3. 要选择菜单中的某项,请按下 Enter 键或 Tab 键,或者双击该项。
  4. 若要使代码提示消失,请执行下列操作之一:
    • 选择一个菜单项。

    • 单击菜单窗口的上方或下方。

    • 如果已经键入了左小括号 “(”,则键入右小括号 “)”。

    • 按下 Esc。

手动显示代码提示

  1. 在可以出现代码提示的代码位置单击,如下面的所示位置:
    • 在语句或命令之后的句点 (.) 的后面(必须在这里输入属性或方法)

    • 在方法名称中的小括号 [()] 之间

  2. 请执行下列操作之一:
    • 要手动启用代码提示,请选择“查看”>“显示代码提示”。

    • 按下 Ctrl+空格键 (Windows) 或者 Command+空格键 (Macintosh)。

自定义类的代码提示

在创建自定义 ActionScript 3.0 类时,Animate 会解析这些类并确定其中包含的对象、属性和方法。之后 Animate 便能够在您编写引用这些自定义类的代码时提供代码提示。对于您通过 import 命令链接到任何其他代码的任何类,自定义类代码都是自动完成的。

代码提示功能可以提高开发人员的工作效率,因为他们无需记住类所使用的全部对象、方法和属性。设计人员可以使用不是自己编写的类,因为他们不必掌握如何使用这些类的第一手知识。

代码提示包括:

  • 嵌套类引用的代码提示

    编写嵌套引用时,连续出现的代码提示协助很有帮助。

  • “this”的代码提示

    当在类文件中键入“this”时,您将获得该类的代码提示。

  • “new+<space>”的代码提示

    当键入“new+<space>”时,Animate 将显示可用类和包的列表。

  • “import”的代码提示

    键入“import + <space>”时,Animate 将显示所有内置包和自定义包的列表。

  • SWC 库的代码提示

    将 SWC 库添加到库路径或外部库路径时,Animate 将为该 SWC 文件中包含的所有类启用代码提示功能。

 Adobe

更快、更轻松地获得帮助

新用户?

Adobe MAX 2024

Adobe MAX
创意大会

10 月 14 日至 16 日迈阿密海滩及线上

Adobe MAX

创意大会

10 月 14 日至 16 日迈阿密海滩及线上

Adobe MAX 2024

Adobe MAX
创意大会

10 月 14 日至 16 日迈阿密海滩及线上

Adobe MAX

创意大会

10 月 14 日至 16 日迈阿密海滩及线上