关于 Adobe AIR

Adobe® AIR™ 为跨操作系统运行时,通过它可以利用现有 Web 开发技术(Adobe® Animate®、Adobe® Flex™、Adobe® Flash Builder™ HTML、JavaScript®、Ajax)生成丰富 Internet 应用程序 (RIA) 并将其部署到桌面。借助 AIR,您可以在熟悉的环境中工作,可以利用您认为用起来最舒适的工具和方法,并且由于它支持 Animate、Flex、HTML、JavaScript 和 Ajax,您可以创造满足您需要的可能的最佳体验。

用户与 AIR 应用程序交互的方式和他们与本机桌面应用程序交互的方式相同。在用户计算机上安装一次此运行时之后,即可像任何其他桌面应用程序一样安装和运行 AIR 应用程序。此运行时通过在不同桌面间确保一致的功能和交互来提供用于部署应用程序的一致性跨操作系统平台和框架,从而消除跨浏览器测试。您只需针对运行时进行开发,而不用针对特定操作系统进行开发。

AIR 在很大程度上改变了应用程序的创建、部署和使用方式。您获得了更富有创造性的控制能力,并可以将您的基于 Animate、Flex、HTML 和 Ajax 的应用程序扩展到桌面,而不需要学习传统的桌面开发技术。

有关桌面和移动 AIR 应用程序的硬件和软件要求的信息,请参阅 AIR 系统要求

有关开发 Adobe AIR™ 应用程序的完整信息,请参阅构建 Adobe AIR 应用程序

创建 Adobe AIR 文件

您可以使用 Animate“欢迎”屏幕或“文件”>“新建”命令创建 Adobe AIR Animate 文档,或者创建一个 ActionScript® 3.0 Animate 文件,然后通过“发布设置”对话框将其转换为 Adobe AIR 文件。

若要创建 Adobe AIR 文件,请执行以下操作之一:

  • 启动 Animate。“欢迎”屏幕出现。如果已经启动了 Animate,请关闭所有打开的文档以返回“欢迎”屏幕。在“欢迎”屏幕中,选择 Adobe AIR 2 (CS5) 或 AIR (CS5.5)。

    注意:如果禁用了 Animate“欢迎”屏幕,可通过选择“编辑”>“首选参数”,然后从“常规”类别的“启动时”弹出菜单中选择“欢迎屏幕”来重新显示该屏幕。

  • 从屏幕顶部的选项卡中选择“文件”>“新建”>“高级”,然后选择“Adobe AIR 2 (CS5)”或“AIR (CS5.5)”并单击“确定”。

Template_air
Template_air
  • 打开一个现有 Animate 文件,并从“发布设置”对话框(“文件”>“发布设置”)“Animate”选项卡中的“播放器”菜单选择“Adobe AIR”,从而将该文件转换为 AIR 文件。

注意:

(仅限 Flash CS5)如果您将某个 Flash CS5 AIR 文件保存为 Flash CS4 格式,请在以 Flash CS4 打开该文件时,在“发布设置”对话框中手动将 Player 版本设置为 AIR 1.5。Flash CS4 只支持发布到 AIR 1.5。

预览或发布 Adobe AIR 应用程序

您可以预览 AIR SWF 文件,显示的效果与在 AIR 应用程序窗口中一样。如果希望在不打包也不安装应用程序的情况下查看应用程序的外观,预览功能非常有用。

  1. 请确保您已在“发布设置”对话框的“Animate”选项卡上将“目标”设置设为“Adobe AIR”。

  2. 选择“控制”>“测试影片”>“测试”,或者按 Ctrl+Enter。

如果未通过“AIR - 应用程序和安装程序设置”对话框设置应用程序设置,Animate 会在写入 SWF 文件的文件夹中自动生成一个默认应用程序描述符文件 (swfname-app.xml)。如果在“AIR 应用程序和安装程序设置”对话框中设置了应用程序设置,则应用程序描述符文件会反映这些设置。

若要发布 AIR 文件,请执行以下操作之一:

  • 在“发布设置”对话框中单击“发布”按钮。

  • 在“AIR 应用程序和安装程序设置”对话框中单击“发布”按钮。

  • 选择“文件”>“发布”。

  • 选择“文件”>“发布预览”。

在发布 AIR 文件时,Animate 会创建一个 SWF 文件和 XML 应用程序描述符文件,并将两个文件的副本以及已添加到应用程序中的其他任何文件都打包到一个 AIR 安装程序文件 (swfname.air) 中。

注意:

(仅限 Windows)如果文件名包含非英文字符,则 AIR 应用程序的发布将失败。

创建 AIR 应用程序和安装程序文件

在您开发完应用程序后,请为 AIR 应用程序描述符文件以及部署该文件所需的安装程序文件指定设置。Animate 在您发布 AIR 文件时创建描述符和安装程序文件以及 SWF 文件。

您可在“AIR - 应用程序和安装程序设置”对话框中为这些文件指定设置。在创建了 AIR 文件后,就可以通过文档属性检查器,或通过“发布设置”对话框“Animate”选项卡上的“播放器”菜单中的“设置”按钮来打开此对话框。

创建 Adobe AIR 应用程序和安装程序文件

  1. 在 Animate 中,打开组成 Adobe AIR 应用程序的 FLA 文件或文件集。

  2. 在打开“AIR 设置”对话框之前,请先保存 Adobe AIR FLA 文件。

  3. 选择“文件”>“AIR 2 设置”。

  4. 完成“AIR 设置”对话框,然后单击“发布”。

    在单击“发布”按钮时,将打包下列文件:SWF 文件、应用程序描述符文件、应用程序图标文件以及“包括的文件”文本框中列出的文件。如果尚未创建数字证书,则当您单击“发布”按钮时,Animate 将显示“数字签名”对话框。

“AIR 应用程序和安装程序设置”对话框分为 4 个选项卡:“常规”、“签名”、“图标”和“高级”。有关这些设置的详细信息,请参阅以下几节中的内容。

常规设置

“AIR 应用程序和安装程序设置”对话框的“常规”选项卡包含下列选项:

输出文件

使用“发布”命令时创建的 .air 文件的名称和位置。

输出为

要创建的包的类型

  • AIR 包 — 创建标准 AIR 安装程序文件,假设在安装期间可以单独下载 AIR 运行时,或在目标设备上已安装好 AIR 运行时。
  • Mac 安装程序 — 创建一个完整的 Macintosh 安装程序文件。
  • 嵌入了运行时的应用程序 — 创建包含 AIR 运行时的 AIR 安装程序文件,因此无需再进行下载。

Windows 安装程序

选择此选项可编译特定于平台的本机 Windows 安装程序 (.exe),而不是独立于平台的 AIR 安装程序 (.air)。

名称

应用程序的主文件的名称。默认为 FLA 文件名。

版本

可选。指定应用程序的版本号。默认值为 1.0。

应用程序 ID

通过唯一的 ID 标识应用程序。如果您愿意,可以更改默认的 ID。请勿在 ID 中使用空格或特殊字符。有效的字符仅限 0-9、a-z、A-Z、.(点)和 -(连字符),长度为 1 至 212 个字符。默认为 com.adobe.example.applicationName

描述

可选。用于输入在用户安装应用程序时显示在安装程序窗口中的应用程序说明。默认为空白。

版权所有

可选。用于输入版权声明。默认为空白。

窗口样式

指定当用户在计算机上运行该应用程序时,应用程序的用户界面使用哪种窗口样式(或镶边)。您可以指定“系统镶边”(默认设置),即操作系统所使用的标准窗口视觉样式。也可以指定“自定义镶边(不透明)”或“自定义镶边(透明)”。若要在显示应用程序时不使用系统镶边,请选择“无”。系统镶边是用操作系统的标准窗口控件围绕应用程序。自定义镶边(不透明)会消除标准系统镶边,您可以为应用程序创建自己的镶边。(自定义镶边是在 FLA 文件中直接生成的。)自定义镶边(透明)类似于自定义镶边(不透明),但为页面边缘添加了透明功能。这些功能可用于非正方形或矩形的应用程序窗口。

渲染模式

允许您指定 AIR 运行时使用哪个方法来渲染图形内容。有以下选项:

  • 自动 — 自动检测并使用主机设备上最快的渲染方法。
  • CPU — 使用 CPU。
  • 直接 — 使用 Stage3D 进行渲染。这是最快的渲染方法。

有关不支持直接模式的处理器的列表,请参阅 Stage3D 不支持的芯片组、驱动程序 | Flash Player 11,AIR 3


配置文件

构建 AIR 文件时要包括的配置文件。要将 AIR 应用程序限制为特定配置文件,请取消选择不需要的配置文件。 

包括的文件

指定应用程序包中包括哪些其他文件和文件夹。单击加号 (+) 按钮可以添加文件,单击文件夹按钮可以添加文件夹。若要从列表中删除某个文件或文件夹,请选择该文件或文件夹,然后单击减号 (-) 按钮。

默认情况下,应用程序描述符文件和主 SWF 文件会自动添加到包列表中。即使尚未发布 Adobe AIR FLA 文件,包列表也会显示这些文件。包列表以平面结构显示文件和文件夹。不列出文件夹中的文件,显示文件的完整路径名(必要时会截断)。

如果您已向 ActionScript 库路径添加了任何 AIR 本机扩展文件,则这些文件也将出现在此列表中。

图标文件不包括在列表中。Animate 在打包这些文件时,会将图标文件复制到一个相对于 SWF 文件位置的临时文件夹中。打包完成后 Animate 会删除该文件夹。

签名设置

借助“AIR 应用程序和安装程序设置”对话框中的“签名”选项卡,您可以为应用程序指定代码签名证书。

有关数字签名的详细信息,请参阅对应用程序进行签名对 AIR 文件进行数字签名

图标设置

借助“AIR 应用程序和安装程序设置”对话框中的“图标”选项卡,您可以为应用程序指定图标。安装应用程序并在 Adobe AIR 运行时中运行应用程序后,即会显示该图标。可以为图标指定四种不同的大小(128、48、32 和 16 像素),以使图标显示在不同的视图中。例如,图标可显示在文件浏览器的缩略图、详细视图和平铺视图中。也可以作为桌面图标显示,或显示在 AIR 应用程序窗口的标题中以及其他位置。

如果未指定其他图标文件,则图标图像默认为范例 AIR 应用程序图标(仅限 Flash CS5)。

要指定图标,请单击“图标”选项卡顶部的一个图标大小,然后导航到您要使用该大小的文件。这些文件必须为 PNG(可移植网络图形)格式。

如果指定了一个图像,则其必须具有准确的大小(128x128、48x48、32x32 或 16x16)。如果未提供特定大小的图标图像,Adobe AIR 将对提供的图像之一进行缩放以创建缺少的图标图像。

高级设置

借助“高级”选项卡,您可以为应用程序描述符文件指定其他设置。

您可以指定 AIR 应用程序应该处理的所有关联文件类型。例如,如果希望您的应用程序作为处理 HTML 文件的主应用程序,则应在“关联的文件类型”文本框中进行指定。

也可以指定应用程序以下各方面的设置:

  • 初始窗口的大小和位置

  • 安装应用程序的文件夹

  • 放置应用程序的“程序”菜单文件夹。

该对话框具有以下选项:

关联的文件类型

用于指定 AIR 应用程序将处理的关联文件类型。单击加号 (+) 按钮可将新文件类型添加到文本框中。单击加号按钮将显示“文件类型设置”对话框。单击减号 (-) 按钮可删除文本框中的选定项。单击铅笔按钮可显示“文件类型设置”对话框,在该对话框中可以编辑文本框中的选定项。默认情况下,减号 (-) 和铅笔按钮显示为灰色。如果选中文本框中的某一项,则会启用减号 (-) 和铅笔按钮,您就可以对该项进行删除或编辑操作。文本框中的默认值为“无”。

初始窗口设置

用于指定应用程序初始窗口的大小和位置设置。

  • 宽度:指定窗口的初始宽度(以像素为单位)。默认情况下,该值为空。

  • 高度:指定窗口的初始高度(以像素为单位)。默认情况下,该值为空。

  • X:指定窗口的初始水平位置(以像素为单位)。默认情况下,该值为空。

  • Y:指定窗口的初始垂直位置(以像素为单位)。默认情况下,该值为空。

  • 最大宽度和最大高度:指定窗口的最大大小(以像素为单位)。默认情况下,这些值为空。

  • 最小宽度和最小高度:指定窗口的最小大小(以像素为单位)。默认情况下,这些值为空。

  • 可最大化:用于指定用户是否可以最大化窗口。默认情况下,此选项为选中状态(为 true)。

  • 可最小化:用于指定用户是否可以最小化窗口。默认情况下,此选项为选中状态(为 true)。

  • 可调整大小:用于指定用户是否可以调整窗口大小。如果不选中此选项,则“最大宽度”、“最大高度”、“最小宽度”、“最小高度”都显示为灰色。默认情况下,此选项为选中状态(为 true)。

  • 可见:用于指定应用程序窗口是否在开始时可见。默认情况下,此选项为选中状态(为 true)。

其他设置

用于指定有关安装的以下其他信息:

  • 安装文件夹:指定安装应用程序的文件夹。

  • 程序菜单文件夹(仅适用于 Windows):指定应用程序的程序菜单文件夹名称。

  • 使用自定义 UI 进行更新:指定当用户打开已安装的应用程序的 AIR 安装程序文件时,会出现什么情况。默认情况下,AIR 显示一个对话框,通过该对话框,用户可以用 AIR 文件中的版本来更新已安装的版本。如果希望应用程序完全控制其更新,而不允许用户决定,请选中此选项。选中此选项会覆盖默认行为,由应用程序自行进行更新。

语言设置

您可以通过“语言”窗格,为应用程序选择在应用程序商店或区域市场中要关联的语种。通过选定对应的语种,可以让使用该语种版本操作系统的用户下载您的程序。请注意,这个语种选择操作不会对您的应用程序用户界面做出任何本地化处理。

如果未选择语言,那么发布的应用程序将支持所有语言。这样就不再需要选择每种语言。列出的语言是 Adobe AIR 支持的语言。Android 可能会支持其它语言。

文件类型设置

如果在“高级”选项卡的“关联的文件类型”部分单击加号 (+) 按钮或铅笔按钮,Animate 将显示“文件类型设置”对话框,以添加或编辑 AIR 应用程序的关联文件类型。

此对话框中只有两个必填字段,即“名称”和“扩展名”。如果单击“确定”,而这两个字段之一为空,则 Animate 会显示一个错误对话框。

您可以为关联文件类型指定以下设置:

名称

文件类型的名称(例如,超文本标记语言、文本文件或示例)。

扩展名

文件扩展名(例如 html、txt 或 xmpl),最多 39 个基本字母数字字符 (A-Za-z0-9),不能以句点开头。

描述

可选。文件类型的说明(例如,Adobe 视频文件)。

内容类型

可选。为文件指定 MIME 类型。

文件类型图标设置

可选。用于指定与文件类型关联的图标。可以为图标指定四种不同大小(128x128、48x48、32x32 和 16x16 像素),以使图标显示在不同视图中。例如,图标可显示在文件浏览器的缩略图、详细视图和平铺视图中。如果指定一个图像,它必须具有指定的大小。如果不指定特定大小的文件,AIR 将使用大小最接近的图像,并对其进行缩放以适应特定情况。要指定一个图标,请单击图标大小的文件夹,选择要使用的图标文件,或在提示旁边的文本框中输入图标文件的路径和文件名。图标文件必须为 PNG 格式。创建新文件类型之后,该类型即显示在“高级设置”对话框的“文件类型”列表框中。

无法创建应用程序和安装程序文件

在以下情况下会无法创建应用程序和安装程序文件:

  • 应用程序 ID 字符串长度不正确或包含无效字符。应用程序 ID 字符串的长度可以为 1 至 212 个字符,并且可以包含以下字符:0-9、a-z、A-Z、.(点)、-(连字符)。

  • “包括的文件”列表中的文件不存在。

  • 自定义图标文件的大小不正确。

  • AIR 目标文件夹没有写访问权限。

  • 您尚未对应用程序进行签名,或者未指定该 Adobe AIRI 应用程序将在以后进行签名。

对应用程序进行签名

所有 Adobe AIR 应用程序都必须进行签名,才能安装在另一个系统上。不过,Animate 提供了一项功能,用于创建未签名 Adobe AIR 安装程序文件,使应用程序可以在以后签名。这些未签名的 Adobe AIR 安装程序文件称为 AIRI(AIR 中间)包。此功能适用于如下情况:证书在另一台计算机上,或签名操作与应用程序开发是独立进行的。

使用从根证书颁发机构预先购买的数字证书对 Adobe AIR 应用程序签名

  1. 选择“文件”>“AIR 2 设置”,然后单击“签名”选项卡。

    此选项卡包含两个单选按钮,允许您使用数字证书对 Adobe AIR 应用程序进行签名或准备 AIRI 包。如果对 AIR 应用程序进行签名,可以使用根证书颁发机构颁发的数字证书,也可以创建自签名证书。自签名证书易于创建,但不如根证书颁发机构颁发的数字证书那样可信。

  2. 从弹出菜单中选择证书文件或单击“浏览”按钮找到证书文件。

  3. 选择证书。

  4. 输入密码。

  5. 单击“确定”。

有关对 AIR 应用程序进行签名的详细信息,请参阅对 AIR 文件进行数字签名

创建自签名的数字证书

  1. 单击“创建”按钮。即会打开“自签名的数字证书”对话框。

  2. 填写“发布者名称”、“部门”、“组织名称”、“国家/地区”、“密码”和“确认密码”条目。对于“国家或地区”,您可以从菜单中选择,或输入未在菜单中显示的双字母国家/地区代码。有关有效国家/地区代码的列表,请参阅 http://www.iso.org/iso/country_codes

  3. 指定证书的类型。

    “类型”选项是指证书的安全级别:1024-RSA 使用 1024 位密钥(不太安全),2048-RSA 使用 2048 位密钥(较为安全)。默认值为 2048 RSA。 

    注意:

    在 Animate CC 中,1024 RSA 证书仅在 2017.2 版及以前版本中受支持。有关解决方法的更多信息,请单击此处

  4. 通过填写“另存为”条目,或单击“浏览”按钮浏览到文件夹位置,将信息保存到证书文件中。

  5. 单击“确定”。

  6. 在“数字签名”对话框中,输入本过程第二步中指定的密码,然后单击“确定”。

要使 Animate 记住您对此会话使用的密码,请单击“在此次会话期间记住密码”。

如果在单击“确定”时“时间戳”选项处于未选中状态,则会出现一个对话框,警告在数字证书过期时应用程序将无法安装。对此警告单击“是”将禁用时间戳。单击“否”会自动选中“时间戳”选项并启用时间戳。

有关创建自签名数字证书的详细信息,请参阅对 AIR 文件进行数字签名

不使用数字签名的情况下,也可以创建 AIR Intermediate (AIRI) 应用程序。但是,在添加数字签名之前,用户不能在桌面上安装该应用程序。

准备将在以后签名的 AIRI 包

  1. 在“签名”选项卡中,选择“准备稍后将要为其签名的 AIR 中间 (AIRI) 文件”,并单击“确定”。

    数字签名状态发生改变,指示已选择准备 AIRI 包供以后签名,而“设置”按钮变为“更改”按钮。

如果您选择在以后对应用程序进行签名,则需要使用 Animate 和 AIR SDK 附带的命令行 AIR 开发工具。有关详细信息,请参阅构建 Adobe AIR 应用程序

时间戳服务器 URL

Animate 支持最新的时间戳服务器,并且配有一个为自定义时间戳服务器添加 URL 的选项。 

timestamp-url

添加或删除 AIR SDK 版本

可以向 Animate 添加 AIR SDK 的新发行版本和自定义版本。添加后,新 SDK 将出现在“发布设置”中的播放器目标列表中。

要添加 SDK 的新版本,请执行以下操作:

  1. 下载新 AIR SDK 文件夹。
  2. 在“Animate”中,选择“帮助”>“管理 AIR SDK”。
  3. 在“管理 AIR SDK”对话框中,单击加号 (+) 按钮,然后浏览到新 AIR SDK 文件夹。单击“确定”。
  4. 单击“管理 AIR SDK”对话框中的“确定”。

此时新 SDK 将出现在“发布设置”中的“播放器目标”列表中。可接受的最低 SDK 版本应大于 Animate 中包含的版本。

要删除 SDK 版本,请执行以下操作:

  1. 在“Animate”中,选择“帮助”>“管理 AIR SDK”。
  2. 在“管理 AIR SDK”对话框中,选择要删除的 SDK。
  3. 单击减号 (-) 按钮。单击“确定”。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略