用户指南 取消(C)

撤消、重做和历史记录面板

  1. Adobe Animate 用户指南
  2. Animate 简介
    1. Animate 新增功能
    2. 图示术语表
    3. Animate 系统要求
    4. Animate 键盘快捷键
    5. 在 Animate 中使用多种文件类型
  3. 动画
    1. Animate 动画基础知识
    2. 如何在 Animate 中使用帧和关键帧
    3. 在 Animate 中使用逐帧动画
    4. 如何在 Animate 中使用传统补间动画
    5. 画笔工具
    6. 运动辅助线
    7. 补间动画和 ActionScript 3.0
    8. 关于补间动画
    9. 补间动画
    10. 创建补间动画
    11. 使用属性关键帧
    12. 用补间对位置进行动画处理
    13. 如何使用动画编辑器编辑补间动画
    14. 编辑补间动画的运动路径
    15. 处理补间动画
    16. 添加自定义缓动
    17. 创建和应用动画预设
    18. 设置动画的补间范围
    19. 处理另存为 XML 文件的补间动画
    20. 补间动画与传统补间
    21. 形状补间
    22. 在 Animate 中使用骨骼工具动画
    23. 在 Animate 中处理角色 Rig
    24. 如何在 Adobe Animate 中使用遮罩层
    25. 如何在 Animate 中使用场景
  4. 交互性
    1. 如何使用 Animate 创建按钮
    2. 将 Animate 项目转换为其它文档类型格式
    3. 在 Animate 中创建和发布 HTML5 Canvas 文档
    4. 在 Animate 中通过代码片段添加交互性
    5. 创建自定义 HTML5 组件
    6. 使用 HTML5 Canvas 中的组件
    7. 创建自定义组件:示例
    8. 自定义组件的代码片段
    9. 最佳做法 - 使用 Animate 制作广告
    10. 虚拟现实创作和发布
  5. 工作区和工作流
    1. 创建和管理画笔
    2. 在 HTML5 Canvas 文档中使用 Google 字体
    3. 使用 Creative Cloud Libraries 和 Adobe Animate
    4. 使用 Animate 的舞台和工具面板
    5. Animate 工作流程和工作区
    6. 在 HTML5 Canvas 文档中使用 Web 字体
    7. 时间轴和 ActionScript
    8. 使用多个时间轴
    9. 设置首选参数
    10. 使用 Animate 创作面板
    11. 使用 Animate 创建时间轴图层
    12. 导出移动应用程序和游戏引擎的动画
    13. 移动和复制对象
    14. 模板
    15. 在 Animate 中查找和替换
    16. 撤消、重做和历史记录面板
    17. 键盘快捷键
    18. 如何在 Animate 中使用时间轴
    19. 创建 HTML 扩展
    20. 图像和动画 GIF 的优化选项
    21. 图像和 GIF 的导出设置
    22. Animate 中的资源面板
  6. 多媒体与视频
    1. 在 Animate 中变形和合并图形对象
    2. 在 Animate 中创建并使用元件实例
    3. 图像描摹
    4. 如何在 Adobe Animate 中使用声音
    5. 导出 SVG 文件
    6. 创建用于 Animate 中的视频文件
    7. 如何在 Animate 中添加视频
    8. 使用视频提示点
    9. 使用 Animate 绘制和创建对象
    10. 改变线条和形状
    11. Animate CC 中的笔触、填充和渐变
    12. 使用 Adobe Premiere Pro 和 After Effects
    13. Animate CC 中的颜色面板
    14. 使用 Animate 打开 Flash CS6 文件
    15. 在 Animate 中使用传统文本
    16. 向 Animate 中置入图稿
    17. 在 Animate 中导入的位图
    18. 3D 图形
    19. 在 Animate 中使用元件
    20. 使用 Adobe Animate 绘制线条和形状
    21. 在 Animate 中使用库
    22. 导出声音
    23. 在 Animate CC 中选择对象
    24. 在 Animate 中使用 Illustrator AI 文件
    25. 使用喷涂刷工具应用图案
    26. 应用混合模式
    27. 排列对象
    28. 使用“命令”菜单自动处理任务
    29. 多语言文本
    30. 在 Animate 中使用摄像头
    31. 将 Animate 与 Adobe Scout 一起使用
    32. 使用 Fireworks 文件
    33. 图形滤镜
    34. 声音和 ActionScript
    35. 绘制首选参数
    36. 用钢笔工具绘图
  7. 平台
    1. 将 Animate 项目转换为其它文档类型格式
    2. 自定义平台支持
    3. 在 Animate 中创建和发布 HTML5 Canvas 文档
    4. 创建和发布 WebGL 文档
    5. 如何打包 AIR for iOS 应用程序
    6. 发布 AIR for Android 应用程序
    7. 发布用于桌面的 Adobe AIR
    8. ActionScript 发布设置
    9. 最佳做法 - 管理应用程序中的 ActionScript
    10. 如何在 Animate 中使用 ActionScript
    11. 最佳做法 - 辅助功能指南
    12. Animate 工作区中的辅助功能
    13. 编写和管理脚本
    14. 启用自定义平台支持
    15. 自定义平台支持概述
    16. 创建辅助内容
    17. 使用自定义平台支持插件
    18. 调试 ActionScript 3.0
    19. 启用自定义平台支持
  8. 导出和发布
    1. 如何从 Animate CC 导出文件
    2. OAM 发布
    3. 导出 SVG 文件
    4. 使用 Animate 导出图形和视频
    5. 发布 AS3 文档
    6. 导出移动应用程序和游戏引擎的动画
    7. 导出声音
    8. 导出 QuickTime 视频文件
    9. 使用 ActionScript 控制外部视频播放
    10. 最佳做法 - 移动设备内容创建技巧
    11. 最佳做法 - 视频惯例
    12. 最佳做法 - SWF 应用程序创作指南
    13. 最佳做法 - 构造 FLA 文件
    14. 在 Animate 中优化 FLA 文件的最佳做法
    15. ActionScript 发布设置
    16. 指定 Animate 的发布设置
    17. 导出放映文件
    18. 导出图像和动画 GIF
    19. HTML 发布模板
    20. 使用 Adobe Premiere Pro 和 After Effects
    21. 快速分享和发布动画

撤消、重做和重复命令

要在当前文档中撤消或重做对个别对象或全部对象执行的动作,请指定对象层级或文档层级的“撤消”和“重做”命令(“编辑”>“撤消”或“编辑”>“重做”)。默认行为是文档层级“撤消”和“重做”。

要选择对象级或文档级撤消选项,可执行以下操作:

  1. 在 Animate 中,选择“编辑”>“首选参数”。
  2. 在“常规”选项卡中,选择“撤消”下拉菜单中的“对象级撤消”。

请注意,使用对象级撤消时不能撤消某些动作。这些动作包括进入和退出“编辑”模式;选择、编辑和移动库项目;以及创建、删除和移动场景。

要将某个步骤重复应用于同一对象或不同对象,请使用“重复”命令。 例如,如果移动了名为 shape_A 的形状,请选择“编辑”>“重复”再次移动该形状;或者选择另一形状 shape_B,然后选择“编辑”>“重复”将第二个形状移动相同的幅度。

默认情况下,Animate 的“撤消”菜单命令支持的撤消级别数为 100。可以在 Animate 的“首选参数”中选择撤消和重做的级别数(从 2 到 300)。

默认情况下,在使用“编辑”>“撤消”或“历史记录”面板撤消步骤时,文档的文件大小不会改变(即使从文档中删除了项目)。例如,如果将视频文件导入文档,然后撤消导入,则文档的文件大小仍然包含视频文件的大小。执行“撤消”命令时从文档中删除的任何项目都将保留,以便可以使用“重做”命令恢复。

使用历史记录面板

“历史记录”面板(“窗口”>“历史记录”)显示自创建或打开某个文档以来在该活动文档中执行的步骤的列表,列表中的数目最多为指定的最大步骤数。(“历史记录”面板不显示在其他文档中执行的步骤。) “历史记录”面板中的滑块最初指向您执行的上一个步骤。

  • 要一次撤消或重做个别步骤或多个步骤,请使用“历史记录”面板。 可以将“历史记录”面板中的步骤应用于文档中的同一对象或不同对象。 但是,不能重新排列“历史记录”面板中的步骤顺序。 “历史记录”面板按步骤的执行顺序来记录步骤。

    如果撤消了一个步骤或一系列步骤,然后又在文档中执行了某些新步骤,则无法再重做“历史记录”面板中的那些步骤;它们已从面板中消失。

  • 默认情况下,Animate 的“历史记录”面板支持的撤消级别数为 100。可以在 Animate 的“首选参数”中选择撤消和重做的级别数(从 2 到 300)。

  • 要擦除当前文档的历史记录列表,请清除“历史记录”面板。 清除历史记录列表后,就无法撤消已清除的步骤。 清除历史记录列表不会撤消步骤;而是从当前文档的内存中删除那些步骤的记录。

关闭文档将会清除其历史记录。 要在关闭文档后使用该文档中的步骤,请使用“复制步骤”命令来复制步骤或将步骤保存为命令。

使用历史记录面板撤消步骤

撤消了某个步骤之后,该步骤将在“历史记录”面板中变灰。

  • 要撤消执行的上一个步骤,请将“历史记录”面板的滑块在列表中向上拖动一个步骤。

  • 要一次撤消多个步骤,请拖动滑块指向任意步骤,或在沿着滑块路径的某个步骤的左侧单击。 滑块会自动滚动到该步骤,并在滚动的同时会撤消所有后面的步骤。

滚动到某个步骤(并选择后面的步骤)与选择某个单独的步骤不同。 要滚动到某个步骤,请在该步骤的左侧单击。

 

使用历史记录面板重放步骤

在使用“历史记录”面板重放步骤时,所播放的步骤是“历史记录”面板中选定(加亮显示)的步骤,而不一定是滑块当前指向的步骤。

可以将“历史记录”面板中的步骤应用于文档中任意选定的对象。

重放一个步骤

  1. 在“历史记录”面板中,选择一个步骤,然后单击“重放”按钮。

重放一系列相邻的步骤

  1. 执行下列操作之一在“历史记录”面板中选择步骤:
    • 从一个步骤拖动到另一步骤。 (不要拖动滑块,而是从一个步骤的文本标签拖动到另一个步骤的文本标签。)

    • 选择第一个步骤,然后按住 Shift 单击最后一个步骤;或选择最后一个步骤,然后按住 Shift 单击第一个步骤。

  2. 单击“重放”。 会顺次重放这些步骤,并在“历史记录”面板中显示一个新步骤,标记为“重放步骤”。

重放不相邻的步骤

  1. 在“历史记录”面板中选择一个步骤,然后按住 Ctrl 单击 (Windows) 或按住 Command 单击 (Macintosh) 其他步骤。 要取消选择选定的步骤,请在按住 Ctrl 或 Command 的同时单击。
  2. 单击“重放”。

在文档间复制和粘贴步骤

每个打开的文档都有自己的步骤历史记录。要从一个文档中复制步骤,然后将它们粘贴到另一文档中,请使用“历史记录”面板选项菜单中的“复制步骤”命令。如果将步骤复制到文本编辑器中,这些步骤将会以 JavaScript™ 代码的形式粘贴。

  1. 在包含要重复使用的步骤的文档中,从“历史记录”面板中选择步骤。
  2. 在“历史记录”面板的选项菜单中,选择“复制步骤”。
  3. 打开要在其中粘贴步骤的文档。
  4. 选择要应用步骤的对象。
  5. 选择“编辑”>“粘贴”以粘贴步骤。 步骤会在粘贴到文档的“历史记录”面板时重放。 “历史记录”面板将这些步骤仅显示为一个步骤,称为“粘贴步骤”。
Adobe 徽标

登录到您的帐户