用户指南 取消(C)

Animate 工作流程和工作区

  1. Adobe Animate 用户指南
  2. Animate 简介
    1. Animate 新增功能
    2. 图示术语表
    3. Animate 系统要求
    4. Animate 键盘快捷键
    5. 在 Animate 中使用多种文件类型
  3. 动画
    1. Animate 动画基础知识
    2. 如何在 Animate 中使用帧和关键帧
    3. 在 Animate 中使用逐帧动画
    4. 如何在 Animate 中使用传统补间动画
    5. 画笔工具
    6. 运动辅助线
    7. 补间动画和 ActionScript 3.0
    8. 关于补间动画
    9. 补间动画
    10. 创建补间动画
    11. 使用属性关键帧
    12. 用补间对位置进行动画处理
    13. 如何使用动画编辑器编辑补间动画
    14. 编辑补间动画的运动路径
    15. 处理补间动画
    16. 添加自定义缓动
    17. 创建和应用动画预设
    18. 设置动画的补间范围
    19. 处理另存为 XML 文件的补间动画
    20. 补间动画与传统补间
    21. 形状补间
    22. 在 Animate 中使用骨骼工具动画
    23. 在 Animate 中处理角色 Rig
    24. 如何在 Adobe Animate 中使用遮罩层
    25. 如何在 Animate 中使用场景
  4. 交互性
    1. 如何使用 Animate 创建按钮
    2. 将 Animate 项目转换为其它文档类型格式
    3. 在 Animate 中创建和发布 HTML5 Canvas 文档
    4. 在 Animate 中通过代码片段添加交互性
    5. 创建自定义 HTML5 组件
    6. 使用 HTML5 Canvas 中的组件
    7. 创建自定义组件:示例
    8. 自定义组件的代码片段
    9. 最佳做法 - 使用 Animate 制作广告
    10. 虚拟现实创作和发布
  5. 工作区和工作流
    1. 创建和管理画笔
    2. 在 HTML5 Canvas 文档中使用 Google 字体
    3. 使用 Creative Cloud Libraries 和 Adobe Animate
    4. 使用 Animate 的舞台和工具面板
    5. Animate 工作流程和工作区
    6. 在 HTML5 Canvas 文档中使用 Web 字体
    7. 时间轴和 ActionScript
    8. 使用多个时间轴
    9. 设置首选参数
    10. 使用 Animate 创作面板
    11. 使用 Animate 创建时间轴图层
    12. 导出移动应用程序和游戏引擎的动画
    13. 移动和复制对象
    14. 模板
    15. 在 Animate 中查找和替换
    16. 撤消、重做和历史记录面板
    17. 键盘快捷键
    18. 如何在 Animate 中使用时间轴
    19. 创建 HTML 扩展
    20. 图像和动画 GIF 的优化选项
    21. 图像和 GIF 的导出设置
    22. Animate 中的资源面板
  6. 多媒体与视频
    1. 在 Animate 中变形和合并图形对象
    2. 在 Animate 中创建并使用元件实例
    3. 图像描摹
    4. 如何在 Adobe Animate 中使用声音
    5. 导出 SVG 文件
    6. 创建用于 Animate 中的视频文件
    7. 如何在 Animate 中添加视频
    8. 使用视频提示点
    9. 使用 Animate 绘制和创建对象
    10. 改变线条和形状
    11. Animate CC 中的笔触、填充和渐变
    12. 使用 Adobe Premiere Pro 和 After Effects
    13. Animate CC 中的颜色面板
    14. 使用 Animate 打开 Flash CS6 文件
    15. 在 Animate 中使用传统文本
    16. 向 Animate 中置入图稿
    17. 在 Animate 中导入的位图
    18. 3D 图形
    19. 在 Animate 中使用元件
    20. 使用 Adobe Animate 绘制线条和形状
    21. 在 Animate 中使用库
    22. 导出声音
    23. 在 Animate CC 中选择对象
    24. 在 Animate 中使用 Illustrator AI 文件
    25. 使用喷涂刷工具应用图案
    26. 应用混合模式
    27. 排列对象
    28. 使用“命令”菜单自动处理任务
    29. 多语言文本
    30. 在 Animate 中使用摄像头
    31. 将 Animate 与 Adobe Scout 一起使用
    32. 使用 Fireworks 文件
    33. 图形滤镜
    34. 声音和 ActionScript
    35. 绘制首选参数
    36. 用钢笔工具绘图
  7. 平台
    1. 将 Animate 项目转换为其它文档类型格式
    2. 自定义平台支持
    3. 在 Animate 中创建和发布 HTML5 Canvas 文档
    4. 创建和发布 WebGL 文档
    5. 如何打包 AIR for iOS 应用程序
    6. 发布 AIR for Android 应用程序
    7. 发布用于桌面的 Adobe AIR
    8. ActionScript 发布设置
    9. 最佳做法 - 管理应用程序中的 ActionScript
    10. 如何在 Animate 中使用 ActionScript
    11. 最佳做法 - 辅助功能指南
    12. Animate 工作区中的辅助功能
    13. 编写和管理脚本
    14. 启用自定义平台支持
    15. 自定义平台支持概述
    16. 创建辅助内容
    17. 使用自定义平台支持插件
    18. 调试 ActionScript 3.0
    19. 启用自定义平台支持
  8. 导出和发布
    1. 如何从 Animate CC 导出文件
    2. OAM 发布
    3. 导出 SVG 文件
    4. 使用 Animate 导出图形和视频
    5. 发布 AS3 文档
    6. 导出移动应用程序和游戏引擎的动画
    7. 导出声音
    8. 导出 QuickTime 视频文件
    9. 使用 ActionScript 控制外部视频播放
    10. 最佳做法 - 移动设备内容创建技巧
    11. 最佳做法 - 视频惯例
    12. 最佳做法 - SWF 应用程序创作指南
    13. 最佳做法 - 构造 FLA 文件
    14. 在 Animate 中优化 FLA 文件的最佳做法
    15. ActionScript 发布设置
    16. 指定 Animate 的发布设置
    17. 导出放映文件
    18. 导出图像和动画 GIF
    19. HTML 发布模板
    20. 使用 Adobe Premiere Pro 和 After Effects
    21. 快速分享和发布动画

Animate CC 是什么?

Adobe

常规动画工作流程

要构建 Animate CC 应用程序,通常需要执行下列基本步骤:

计划应用程序。

确定应用程序要执行哪些基本任务。

添加媒体元素。

创建并导入媒体元素,如图像、视频、声音和文本等。

排列元素。

在舞台上和时间轴中排列这些媒体元素,以定义它们在应用程序中显示的时间和显示方式。

应用特殊效果。

根据需要应用图形滤镜(如模糊、发光和斜角)、混合和其他特殊效果。

使用 ActionScript 控制行为。

编写 ActionScript® 代码以控制媒体元素的行为方式,包括这些元素对用户交互的响应方式。

测试并发布应用程序。

测试您的 FLA 文件(“控制”>“测试影片”)以验证应用程序是否按预期工作,查找并纠正所遇到的错误。在整个创建过程中应不断测试应用程序。您可以在 Animate 和 AIR Debug Launcher 中测试文件。

将 FLA 文件(“文件”>“发布”)发布为可在网页中显示并可使用 Flash® Player 播放的 SWF 文件。

根据项目和工作方式,您可以按不同的顺序使用上述步骤。

工作区概述

可以使用各种元素(如面板、栏以及窗口)来创建和处理文档和文件。这些元素的任何排列方式称为工作区。Adobe® Creative Suite® 5 中不同应用程序的工作区具有相同的外观,因此您可以在应用程序之间轻松切换。您也可以通过从多个预设工作区中进行选择或创建自己的工作区来调整各个应用程序,以适合您的工作方式。

虽然不同产品中的默认工作区布局不同,但是您对其中元素的处理方式基本相同。

  • 位于顶部的应用程序栏包含工作区切换器、菜单(仅限 Windows)和其它应用程序控件。在 Mac 操作系统中,对于某些产品,可以使用"窗口"菜单显示或隐藏应用程序栏。

  • 工具面板包含用于创建和编辑图像、图稿、页面元素等的工具。相关工具将进行分组。

  • 控制面板显示当前所选工具的选项。在 Illustrator 中,"控制"面板显示当前所选对象的选项。(在 Adobe Photoshop® 中,"控制"面板称为"选项"栏。在 Adobe Animate®、Adobe Dreamweaver® 和 Adobe Fireworks® 中,“控制”面板称为“属性检查器”,包含当前所选元素的属性。)

  • 文档窗口显示您正在处理的文件。可以将文档窗口设置为选项卡式窗口,并且在某些情况下可以进行分组和停放。

  • 面板可以帮助您监视和修改您的工作。例如,Animate 中的时间轴、Illustrator 中的“画笔”面板、Adobe Photoshop® 中的“图层”面板,以及 Dreamweaver 中的“CSS 样式”面板。可以对面板进行编组、堆叠或停放。

  • 应用程序帧 将所有工作区元素分组到一个允许将应用程序作为单个单元的单个集成窗口中。当您移动应用程序帧或其任何元素,或调整其大小时,它其中的所有元素则会彼此响应而没有重叠。切换应用程序或不小心在应用程序之外单击时,面板不会消失。如果使用两个或更多应用程序,可以将各个应用程序并排放在屏幕或多台显示器上。

    如果您使用的是 Mac,并且更偏爱传统的、自由形式的用户界面,可以关闭应用程序帧。例如,在 Adobe Illustrator® 中,选择"窗口">"应用程序帧"可将其打开或关闭。(在 Animate 中,应用程序帧对于 Mac 处于永久打开状态,Dreamweaver for Mac 不使用应用程序帧。)

 

默认 Illustrator 工作区

A. 选项卡式"文档"窗口 B. 应用程序栏 C. 工作区切换器 D. 面板标题栏 E. "控制"面板 F. “工具”面板 G. "折叠为图标"按钮 H. 垂直停放的四个面板组 

隐藏或显示所有面板

  • (Illustrator、Adobe InCopy®、Adobe InDesign®、Photoshop、Fireworks)要隐藏或显示所有面板(包括工具面板和控制面板),请按 Tab。

  • (Illustrator、InCopy、InDesign、Photoshop)若要隐藏或显示所有面板(除"工具"面板和"控制"面板之外),请按 Shift+Tab。

    提示:如果在“界面”首选项中选择“自动显示隐藏面板”,可以暂时显示隐藏的面板。在 Illustrator 中,始终处于打开状态。将指针移动到应用程序窗口边缘 (Windows®) 或显示器边缘 (Mac OS®),然后将指针悬停在出现的条带上。

  • (Animate、Dreamweaver、Fireworks)要隐藏或显示所有面板,请按 F4。

显示面板选项

  1. 单击位于面板右上角的面板菜单图标

    提示:甚至在将面板最小化时,也可以打开面板菜单。

    提示:在 Photoshop 中,您可以更改面板和工具提示中文本的字体大小。请从界面首选项中的"用户界面字体大小"菜单选取大小。

(Illustrator) 调整面板亮度

  1. 在"用户界面"首选项中,移动"亮度"滑块。此控件影响所有面板,其中包括"控制"面板。

重新配置工具面板

您可以将"工具"面板中的工具放在一栏中显示,也可以放在两栏中并排显示。(在 Fireworks 和 Animate 中,工具面板中未提供此功能。)

注意:

在 InDesign 和 InCopy 中,也可以通过设置界面首选项中的选项将单栏显示切换为双栏(或单行)显示。

  1. 单击"工具"面板顶部的双箭头。

管理窗口和面板

您可以通过移动和处理"文档"窗口和面板来创建自定义工作区。您也可以保存工作区并在它们之间进行切换。对于 Fireworks,重命名自定义工作区会导致意外行为。

注意:

下面仅以 Photoshop 为例进行演示。工作区在所有产品中的作用均相同。

重新排列、停放或浮动"文档"窗口

打开多个文件时,"文档"窗口将以选项卡方式显示。

  • 若要重新排列选项卡式"文档"窗口,请将某个窗口的选项卡拖动到组中的新位置。

  • 要从窗口组中取消停放(浮动或取消显示)某个"文档"窗口,请将该窗口的选项卡从组中拖出。

    注意:在 Photoshop 中,您还可以选择"窗口">"排列">"在窗口中浮动"以浮动单个文档窗口,或者选择"窗口">"排列">"使所有内容在窗口中浮动"以同时浮动所有文档窗口。有关详细信息,请参阅技术说明 kb405298

    注意:Dreamweaver 不支持停放和取消停放文档窗口。可以使用"文档"窗口的"最小化"按钮创建浮动窗口 (Windows),或者选择"窗口">"垂直平铺"以创建并排显示的"文档"窗口。有关本主题的详细信息,请在 Dreamweaver 帮助中搜索"垂直平铺"。Macintosh 用户的工作流程略有不同。

  • 要将某个"文档"窗口停放在单独的"文档"窗口组中,请将该窗口拖到该组中。

  • 若要创建堆叠或平铺的文档组,请将此窗口拖动到另一窗口的顶部、底部或侧边的放置区域。也可以利用应用程序栏上的"版面"按钮为文档组选择版面。

    注意:某些产品不支持此功能。但是,这些产品在"窗口"菜单中可能包含"层叠"和"平铺"命令,也可以用来帮助布置文档。

  • 若要在拖动某个选项时切换到选项卡式文档组中的其它文档,可将选项拖到该文档的选项卡上并保持一段时间。

    注意:某些产品不支持此功能。

停放和取消停放面板

停放是一组放在一起显示的面板或面板组,通常在垂直方向显示。可通过将面板移到停放中或从停放中移走来停放或取消停放面板。

  • 要停放面板,请将其标签拖移到停放中(顶部、底部或两个其它面板之间)。

  • 要停放面板组,请将其标题栏(标签上面的实心空白栏)拖移到停放中。

  • 要删除面板或面板组,请将其标签或标题栏从停放中拖走。您可以将其拖移到另一个停放中,或者使其变为自由浮动。

正在拖出到新停放中的"导航器"面板,由蓝色垂直突出显示区域表示

"导航器"面板现在位于其自己的停放中

注意:

您可以防止面板占据停放中的所有空间。向上拖动停放的底部边缘,使其不再接触工作区的边缘。

移动面板

在移动面板时,您会看到蓝色突出显示的放置区域,您可以在该区域中移动面板。例如,通过将一个面板拖移到另一个面板上面或下面的窄蓝色放置区域中,可以在停放中向上或向下移动该面板。如果拖移到的区域不是放置区域,该面板将在工作区中自由浮动。

注意:

鼠标位置(而不是面板位置)可激活放置区域,因此,如果看不到放置区域,请尝试将鼠标拖到放置区域应处于的位置。

  • 若要移动面板,请拖动其标签。

  • 若要移动面板组,请拖动其标题栏。

较窄的蓝色放置区域表示,"颜色"面板将自行停放在"图层"面板组上面。

A. 标题栏 B. 制表符 C. 放置区域 

注意:

在移动面板的同时按住 Ctrl (Windows) 或 Command (Mac OS) 可防止其停放。在移动面板时按 Esc 可取消该操作。

添加和删除面板

如果从停放中删除所有面板,该停放将会消失。您可以通过将面板移动到工作区右边缘直到出现放置区域来创建停放。

  • 若要移除面板,请右键单击 (Windows) 或按住 Control 单击 (Mac) 其选项卡,然后选择"关闭",或从"窗口"菜单中取消选择该面板。

  • 要添加面板,请从"窗口"菜单中选择该面板,然后将其停放在所需的位置。

处理面板组

  • 要将面板移到组中,请将面板标签拖到该组突出显示的放置区域中。

面板组中的面板

  • 要重新排列组中的面板,请将面板标签拖移到组中的一个新位置。

  • 要从组中删除面板以使其自由浮动,请将该面板的标签拖移到组外部。

  • 要移动组,请拖动其标题栏(选项卡上方的区域)。

堆叠浮动的面板

当您将面板拖出停放但并不将其拖入放置区域时,面板会自由浮动。您可以将浮动的面板放在工作区的任何位置。您可以将浮动的面板或面板组堆叠在一起,以便在拖动最上面的标题栏时将它们作为一个整体进行移动。

自由浮动的堆叠面板

  • 要堆叠浮动的面板,请将面板的标签拖动到另一个面板底部的放置区域中以拖动该面板。

  • 要更改堆叠顺序,请向上或向下拖移面板标签。

    注意:请确保在面板之间较窄的区域而不是标题栏中较宽的放置区域松开标签。

  • 要从堆叠中删除面板或面板组以使其自由浮动,请将其标签或标题栏拖走。

调整面板大小

  • 要将面板、面板组或面板堆叠最小化或最大化,请双击选项卡。也可以双击选项卡区域(选项卡旁边的空白区)。

  • 若要调整面板大小,请拖动面板的任意一条边。某些面板无法通过拖动来调整大小,如 Photoshop 中的"颜色"面板。

折叠和展开面板图标

您可以将面板折叠为图标以避免工作区出现混乱。在某些情况下,在默认工作区中将面板折叠为图标。

折叠为图标的面板

从图标展开的面板

  • 若要折叠或展开列中的所有面板图标,请单击停放区顶部的双箭头。

  • 若要展开单个面板图标,请单击它。

  • 若要调整面板图标大小以便仅能看到图标(看不到标签),请调整停放的宽度直到文本消失。若要再次显示图标文本,请加大停放的宽度。

  • 若要将展开的面板重新折叠为其图标,请单击其选项卡、其图标或面板标题栏中的双箭头。

    提示:在某些产品中,如果从"界面"或"用户界面选项"首选项中选择"自动折叠图标面板",在远离面板的位置单击时,将自动折叠展开的面板图标。

  • 若要将浮动面板或面板组添加到图标停放中,请将其选项卡或标题栏拖动到其中。(添加到图标停放中后,面板将自动折叠为图标。)

  • 若要移动面板图标(或面板图标组),请拖动图标。您可以在停放中向上或向下拖动面板图标,将其拖动到其它停放中(它们将采用该停放的面板样式),或者将其拖动到停放外部(它们将显示为浮动图标)。

存储和切换工作区

通过将面板的当前大小和位置存储为命名的工作区,即使移动或关闭了面板,您也可以恢复该工作区。已存储的工作区的名称出现在应用程序栏上的工作区切换器中。

存储自定工作区

  1. 对于要存储配置的工作区,请执行以下操作之一:

    • (Illustrator) 选择"窗口">"工作区">"存储工作区"。

    • (Photoshop、InDesign、InCopy)选择"窗口">"工作区">"新建工作区"。

    • (Dreamweaver) 选择"窗口">"工作区布局">"新建工作区"。

    • (Animate) 从应用程序栏上的工作区切换器选择“新建工作区”。

    • (Fireworks) 从应用程序栏上的工作区切换器中选择"保存当前"。

  2. 键入工作区的名称。

  3. (Photoshop、InDesign)在"捕捉"下,选择一个或多个选项:

    面板位置

    保存当前面板位置(仅限 InDesign)。

    键盘快捷键

    保存当前的键盘快捷键组(仅限 Photoshop)。

    菜单或菜单自定义

    存储当前的菜单组。

显示或切换工作区

  1. 从应用程序栏上的工作区切换器中选择一个工作区。

注意:

在 Photoshop 中,您可以为各个工作区指定键盘快捷键,以便在它们之间快速进行导航。

删除自定工作区

  • 从应用程序栏上的工作区切换器中选择"管理工作区",再选择工作区,然后单击"删除"。(在 Fireworks 中没有此选项。)

  • (Photoshop、InDesign、InCopy)从工作区切换器中选择"删除工作区"

  • (Illustrator) 选择"窗口">"工作区">"管理工作区",选择该工作区,然后单击"删除"图标。

  • (Photoshop、InDesign)选择"窗口">"工作区">"删除工作区",选择该工作区,然后单击"删除"。

恢复默认工作区

  1. 从应用程序栏上的工作区切换器中选择默认或基本工作区。

    注意:

    在 Dreamweaver 中,默认工作区是“设计器”。

  2. (Photoshop、InDesign 和 InCopy)选择"窗口">"工作区">"重置 [工作区名称]"。

(Photoshop) 恢复存储的工作区排列方式

在 Photoshop 中,工作区自动按上次排列的方式进行显示,但您可以恢复原来存储的面板排列方式。

  • 要恢复单个工作区,请选择"窗口">"工作区">"重置工作区名称"。

  • 要恢复随 Photoshop 一起安装的所有工作区,请在"界面"首选项中单击"恢复默认工作区"。

注意:

若要在应用程序栏中重新排列工作区的顺序,请拖动工作区。

Adobe 徽标

登录到您的帐户