Als u inhoud wilt maken die vergelijkbaar is met een diapresentatie en die in Flash Player kan worden afgespeeld, kunt u de inhoud exporteren als SWF- of FLA-bestand. Het belangrijkste verschil tussen de indelingen is dat SWF-bestanden direct kunnen worden weergegeven en niet kunnen worden bewerkt, terwijl FLA-bestanden moeten worden bewerkt in Adobe Flash Professional voordat ze in Adobe Flash Player kunnen worden weergegeven.

SWF

Een geëxporteerd SWF-bestand kan direct worden weergegeven in Adobe Flash Player en kan interactieve elementen bevatten, zoals paginaovergangen, hyperlinks, films, geluidsclips, animatie en navigatieknoppen.

FLA

Een geëxporteerd FLA-bestand kan slechts bepaalde interactieve elementen bevatten. Het FLA-bestand kan worden geopend in Flash Pro, waarin u of een Flash-ontwikkelaar geavanceerde effecten aan het bestand kunnen toevoegen alvorens het als een SWF-bestand te exporteren.

Exporteren als Flash-bestand
Exporteren als Flash-bestand

A. Direct exporteren als SWF-bestand B. Exporteren als FLA-bestand om te bewerken in Flash Professional 

Interactieve SWF-bestanden (Flash) maken voor het web

Bij het exporteren van een SWF-bestand maakt u een interactief bestand dat direct in Adobe Flash Player of in een webbrowser kan worden weergegeven. Het SWF-bestand kan knoppen, paginaovergangen, films, audiobestanden, animatie en hyperlinks bevatten die in InDesign zijn toegevoegd. Exporteren als een SWF-bestand is een goede manier om een interactieve diapresentatie of een flipboek te maken op basis van een InDesign-document.

Als u het document in Flash Pro wilt bewerken voordat u het SWF-bestand maakt, exporteert u het document niet als een SWF-bestand maar als een FLA-bestand. Zie FLA-bestanden maken voor het web.

SWF exporteren
SWF exporteren

A. Document in InDesign vóór het exporteren naar SWF B. Interactief SWF-bestand in webbrowser 
  1. Maak of bewerk het InDesign-document zodat dit kan worden geëxporteerd als een Flash-bestand. Zie Problemen met exporteren naar Flash voor uitgebreide informatie over het voorbereiden van het document voor export.

    • Voeg navigatieknoppen toe waarmee gebruikers door de pagina's van het geëxporteerde SWF-bestand kunnen bladeren. U maakt knoppen door een object te tekenen en dit om te zetten in een knop in het deelvenster Knoppen (kies Venster > Interactief > Knoppen). U kunt ook het deelvenster Voorbeeldknoppen gebruiken om voorgedefinieerde navigatieknoppen naar uw document te slepen. Zie Knoppen maken.

    • Gebruik het deelvenster Paginaovergangen (kies Venster > Interactief > Paginaovergangen) om paginaovergangen zoals sluitereffecten of verspreiden toe te voegen. Als u uw document als een SWF-bestand exporteert, kunt u ook de optie Inclusief interactief Pagina omslaan en krullen selecteren. Met deze optie kunnen lezers een paginahoek slepen om de pagina om te slaan.

    • Gebruik het deelvenster Animatie (kies Venster > Interactief > Animatie) om bewegingsvoorinstellingen toe te voegen. Zie Animatie.

  2. Kies Bestand > Exporteren om het document als een SWF-bestand te exporteren.

  3. Selecteer Gebruik de InDesign-documentnaam als de uitvoerbestandsnaam als u het geëxporteerde bestand dezelfde naam wilt geven als de naam van het document uit de volgende export.

  4. Kies Flash Player (SWF) in het menu Opslaan als type (Windows) of Opmaak (Mac OS) en klik op Opslaan.

  5. Geef in het dialoogvenster SWF exporteren de gewenste opties op en klik op OK. Zie SWF-exportopties.

Bij het exporteren van een SWF-bestand worden aparte HTML- en SWF-bestanden gemaakt. Wanneer het SWF-bestand films of geluidsfragmenten bevat, wordt eveneens een map met bronnen gemaakt. Zorg ervoor dat u alle middelen verzendt bij het versturen of uploaden van de bestanden naar het web.

SWF-exportopties

De volgende opties worden weergegeven op de tabbladen Algemeen en Geavanceerd van het dialoogvenster SWF exporteren.

Exporteren

Geef aan of u de huidige selectie, alle pagina's in het document of een paginabereik wilt exporteren. De optie Selectie is vooral handig als u het geëxporteerde SWF-bestand wilt opslaan en gebruiken in een geëxporteerd PDF-bestand. Als u Bereik selecteert, geeft u het gewenste paginabereik op, bijvoorbeeld 1-7, 9 om pagina 1 tot en met 7 en pagina 9 af te drukken. Zie Opgeven welke pagina's moeten worden afgedrukt.

HTML-bestanden genereren

Selecteer deze optie om een HTML-pagina te genereren die het SWF-bestand afspeelt. Deze optie is vooral handig om snel een voorvertoning van het SWF-bestand in uw webbrowser weer te geven.

SWF na exporteren weergeven

Selecteer deze optie om het SWF-bestand in uw standaardwebbrowser af te spelen. Deze optie is alleen beschikbaar als u een HTML-bestand genereert.

Grootte (pixels)

Geef een percentage op als het SWF-bestand wordt geschaald, geef een optie op bij Aanpassen aan of geef de grootte op door een breedte en hoogte in te voeren.

Achtergrond

Bepaal of de achtergrond van uw SWF-bestand transparant is of de huidige papierkleur uit het deelvenster Stalen heeft. Als Transparant is geselecteerd, zijn de opties Paginaovergangen en interactief Pagina omslaan en krullen niet beschikbaar.

Interactiviteit en media

Selecteer Alles opnemen als u interactieve films, geluiden, knoppen en animatie in het geëxporteerde SWF-bestand wilt opnemen. Selecteer Alleen vormgeving als u de videoposters en de normale status van knoppen als statische elementen in het bestand wilt opnemen. Als Alleen vormgeving is geselecteerd, worden animaties geëxporteerd zoals ze op het moment van het exporteren in de layout worden weergegeven. Alleen vormgeving wordt geselecteerd als u in het deelvenster Geavanceerd de optie Transparantie afvlakken inschakelt.

Paginaovergangen

Geef één paginaovergang op die bij het exporteren op alle pagina's wordt toegepast. Als u overgangen opgeeft in het deelvenster Paginaovergangen, kiest u de optie Op basis van document om de desbetreffende instellingen te gebruiken.

Inclusief interactief Pagina omslaan en krullen

Als deze optie is geselecteerd, kunnen gebruikers tijdens het afspelen van het SWF-bestand een hoek van de pagina slepen om de pagina om te slaan, net zoals ze een pagina in een echt boek kunnen omslaan.

Framesnelheid

Bij een hogere framesnelheid zijn animaties vloeiender, maar is het bestand wellicht groter. Het wijzigen van de framesnelheid heeft geen invloed op de afspeelduur.

Tekst

Geef aan hoe InDesign-tekst wordt uitgevoerd. Kies Klassieke Flash-tekst om doorzoekbare tekst uit te voeren die het kleinste bestandsformaat oplevert. Kies Omzetten in contouren om de tekst uit te voeren als een serie vloeiende rechte lijnen, zoals tekst omzetten in contouren. Kies Omzetten in pixels om de tekst uit te voeren als een bitmapafbeelding. Tekst die is omgezet in pixels kan er gekarteld uitzien wanneer hierop wordt ingezoomd.

Pagina's rasteren

Met deze optie worden alle InDesign-pagina-items naar bitmap omgezet. Als u deze optie selecteert, wordt het SWF-bestand groter en kunnen de pagina-items gekarteld verschijnen wanneer hierop wordt ingezoomd.

Transparantie afvlakken

Met deze optie wordt actieve transparantie uit het SWF-bestand verwijderd, maar blijft het transparantie-effect behouden. Alle interactiviteit wordt echter uit het geëxporteerde SWF-bestand verwijderd.

Compressie

Kies Automatisch om InDesign de beste kwaliteit voor afbeeldingen in kleur en grijswaarden te laten bepalen. Bij de meeste bestanden geeft deze optie optimale resultaten. De optie JPEG (met gegevensverlies) is geschikt voor afbeeldingen in grijswaarden of in kleur. JPEG-compressie is een techniek met verlies. Dit betekent dat er afbeeldingsgegevens worden verwijderd en dat de kwaliteit van de afbeelding kan afnemen. Er wordt echter geprobeerd zo weinig mogelijk gegevens verloren te laten gaan bij het verkleinen van het bestand. Omdat bij JPEG-compressie gegevens worden verwijderd, ontstaan hierdoor veel kleinere bestanden. Met de optie PNG (zonder gegevensverlies) wordt het bestand zonder gegevensverlies gecomprimeerd en geëxporteerd.

Opmerking:

Wanneer bij het exporteren van een SWF-bestand blijkt dat de kwaliteit van transparante afbeeldingen afneemt, kiest u PNG (zonder gegevensverlies) om de kwaliteit te verhogen.

JPEG-kwaliteit

Hiermee geeft u op hoe gedetailleerd de geëxporteerde afbeelding moet worden. Hoe hoger de kwaliteit, des te groter het bestand. Deze optie is grijs als u bij Compressie de optie PNG (zonder gegevensverlies) selecteert.

Resolutie

Hiermee bepaalt u de resolutie van bitmapafbeeldingen in het geëxporteerde SWF-bestand. Een hoge resolutie is vooral belangrijk wanneer u gebruikers wilt laten inzoomen op inhoud op basis van pixels in uw geëxporteerde SWF-bestand. Een hoge resolutie kan resulteren in zeer grote bestanden.

FLA-bestanden maken voor het web

Wanneer u het InDesign-document exporteert naar de FLA-indeling, kunt u het bestand openen in Adobe Flash® CS5 Professional om de inhoud te bewerken. De exportindeling FLA in InDesign CS5 vervangt de exportindeling XFL uit InDesign CS4. Maak gebruik van de Flash-authoringomgeving om video, audio, animatie en complexe interactiviteit te bewerken of toe te voegen.

Als u het InDesign-document wilt exporteren in een indeling die direct in een webbrowser kan worden geopend, gebruikt u de indeling SWF in plaats van FLA. Zie Interactieve SWF-bestanden (Flash) maken voor het web.

Exporteren als FLA-bestand
Exporteren als FLA-bestand

A. Document in InDesign vóór het exporteren als FLA-bestand B. FLA-bestand geopend in Flash Pro 
  1. Maak of bewerk het InDesign-document zodat dit kan worden geëxporteerd als een Flash-bestand. Zie Problemen met exporteren naar Flash voor uitgebreide informatie over het voorbereiden van het document voor export.

  2. Kies Bestand > Exporteren om het document als een FLA-bestand te exporteren. Kies Flash CS5 Professional (FLA) in het menu Opslaan als type (Windows) of opmaak (Mac OS) en klik op Opslaan.

  3. Geef in het dialoogvenster Flash CS5 Professional (FLA) exporteren de gewenste opties op en klik op OK. Zie FLA-exportopties voor informatie over exportopties.

  4. Open het geëxporteerde FLA-bestand in Flash Professional.

FLA-exportopties

Het dialoogvenster Flash CS5 Professional (FLA) exporteren bevat de volgende opties.

Exporteren

Geef aan of u de huidige selectie, alle pagina's in het document of een paginabereik wilt exporteren. Als u Bereik selecteert, geeft u het gewenste paginabereik op, bijvoorbeeld 1-7, 9 om pagina 1 tot en met 7 en pagina 9 af te drukken. Zie Opgeven welke pagina's moeten worden afgedrukt.

Pagina's rasteren

Met deze optie worden alle InDesign-pagina-items naar bitmap omgezet. Als u deze optie selecteert, wordt het FLA-bestand groter en kunnen pagina-items gekarteld worden weergegeven wanneer hierop wordt ingezoomd.

Transparantie afvlakken

Als u deze optie selecteert, worden alle objecten met transparantie afgevlakt. In Adobe Flash Pro is het misschien lastiger om van afgevlakte objecten animaties te maken.

Grootte (pixels)

Geef een percentage op als het FLA-bestand wordt geschaald, geef een optie op bij Aanpassen aan of geef de grootte op door een breedte en hoogte in te voeren.

Interactiviteit en media

Selecteer Alles opnemen als u films, geluiden, knoppen en animatie in het geëxporteerde FLA-bestand wilt opnemen. Als het document een object met meerdere statussen bevat, wordt dit omgezet in een filmclipsymbool waarin elke status in een eigen frame op de tijdbalk wordt weergegeven.

Selecteer Alleen vormgeving als u de videoposters en de normale status van knoppen als statische elementen in het bestand wilt opnemen. Als Alleen vormgeving is geselecteerd, worden animaties geëxporteerd zoals ze op het moment van het exporteren in de layout worden weergegeven. Alleen vormgeving wordt geselecteerd wanneer u Transparantie afvlakken kiest.

Tekst

Geef aan hoe InDesign-tekst wordt uitgevoerd. Kies Flash TLF-tekst als u gebruik wilt maken van de uitgebreide reeks Text Layout Framework-kenmerken van Flash Professional. Als deze optie is geselecteerd, kiest u Punten voor zachte afbreekstreepjes invoegen als u woordafbreking wilt gebruiken. Kies Klassieke Flash-tekst om doorzoekbare tekst uit te voeren in een klein bestand. Kies Omzetten in contouren om de tekst uit te voeren als een serie vloeiende rechte lijnen, zoals tekst omzetten in contouren. Kies Omzetten in pixels om de tekst uit te voeren als een bitmapafbeelding. Tekst die is omgezet in pixels kan er gekarteld uitzien wanneer hierop wordt ingezoomd.

Compressie

Kies Automatisch om InDesign de beste kwaliteit voor afbeeldingen in kleur en grijswaarden te laten bepalen. Bij de meeste bestanden geeft deze optie optimale resultaten. De optie JPEG (met gegevensverlies) is geschikt voor afbeeldingen in grijswaarden of in kleur. JPEG-compressie is een techniek met verlies. Dit betekent dat er afbeeldingsgegevens worden verwijderd en dat de kwaliteit van de afbeelding kan afnemen. Er wordt echter geprobeerd zo weinig mogelijk gegevens verloren te laten gaan bij het verkleinen van het bestand. Omdat bij JPEG-compressie gegevens worden verwijderd, ontstaan hierdoor veel kleinere bestanden. Met de optie PNG (zonder gegevensverlies) wordt het bestand zonder gegevensverlies gecomprimeerd en geëxporteerd.

JPEG-kwaliteit

Hiermee geeft u op hoe gedetailleerd de geëxporteerde afbeelding moet worden. Hoe hoger de kwaliteit, des te groter het bestand. Deze optie is grijs als u bij Compressie de optie PNG (zonder gegevensverlies) selecteert.

Resolutie

Hiermee bepaalt u de resolutie van bitmapafbeeldingen in het geëxporteerde FLA-bestand. Een hoge resolutie is vooral belangrijk wanneer u gebruikers wilt laten inzoomen op inhoud op basis van pixels. Een hoge resolutie kan resulteren in zeer grote bestanden.

Problemen met exporteren naar Flash

Houd rekening met de volgende factoren als u een InDesign-document ontwerpt dat u als SWF- of FLA-bestand wilt exporteren.

Documentinstellingen

InDesign-pagina's omzetten

Als u naar SWF of FLA exporteert, worden InDesign-spreads afzonderlijke clips in een tijdbalk, zoals dia's in een presentatie. Elke spread wordt toegewezen aan een nieuw hoofdframe. In Flash Player kunt u door de spreads van het geëxporteerde document bladeren door op de pijltoetsen te drukken of door op de interactieve knoppen te klikken.

Opmerking:

Als u een document voor het web maakt, kiest u Web in het menu Intentie van het dialoogvenster Nieuw document.

Paginaformaat

Als u een document maakt, kunt u een specifieke resolutie, zoals 800 x 600, selecteren in het menu Paginaformaat in het dialoogvenster Nieuw document. Tijdens het exporteren kunt u ook de schaal of resolutie van het te exporteren SWF- of FLA-bestand wijzigen.

Interactiviteitsfuncties

U kunt knoppen, paginaovergangen, hyperlinks, animatie en mediabestanden in geëxporteerde SWF- en FLA-bestanden opnemen.

Knoppen

De acties Volgende pagina en Vorige pagina zijn erg handig voor gebruik als knoppen in een geëxporteerd SWF- of FLA-bestand. Hiermee kan het bestand in Flash Player worden afgespeeld. Sommige acties die wel in interactieve PDF-bestanden werken, zijn echter onbruikbaar in Flash Player. Als u een actie in het deelvenster Knoppen kiest, selecteer dan geen opties in het gedeelte Alleen PDF.

Opmerking:

U kunt navigatieknoppen toevoegen die vooraf zijn voorzien van de acties Ga naar volgende pagina en Ga naar vorige pagina. Kies Voorbeeldknoppen in het menu van het deelvenster Knoppen. Zie Een knop toevoegen vanuit het deelvenster Voorbeeldknoppen.

Paginaovergangen

Alle paginaovergangen werken goed in Flash Player. Naast paginaovergangen die verschijnen wanneer u de pagina omslaat, kunt u ook een interactieve paginaomkrulling toevoegen tijdens het exporteren. Hiermee kunt u de hoeken van de pagina's omslaan door ze te slepen.

Hyperlinks

Maak koppelingen naar websites of naar andere pagina's in het document. Hyperlinks worden verbroken in FLA-bestanden.

Films en geluidsclips

Films en geluidsclips worden in een geëxporteerd SWF-bestand opgenomen als ze zijn opgeslagen in een ondersteunde indeling, zoals SWF, FLV, F4V en MP4 voor films en MP3 voor geluidsclips.

Bij het exporteren naar FLA wordt alleen de posterafbeelding in het FLA-bestand opgenomen. De ondersteunde mediabestanden worden weergegeven in een map met bronnen die op dezelfde locatie wordt opgeslagen als het geëxporteerde FLA-bestand.

Omzetten

Kleur

SWF- en FLA-bestanden maken gebruik van RGB-kleur. Als een document wordt geëxporteerd naar SWF of FLA, zet InDesign alle kleurruimten (zoals CMYK en Lab) om naar sRGB. InDesign zet steunkleuren om naar overeenkomstige RGB-proceskleuren.

Teneinde ongewenste kleurwijzigingen te voorkomen in illustraties met tekst met transparantie, kiest u Bewerken > Transparantie-overvloeiruimte > Document RGB. Als u ongewenste kleurwijzigingen in afbeeldingen met transparantie wilt voorkomen, kunt u beter geen compressie met gegevensverlies gebruiken bij het exporteren.

Tekst

Bij het exporteren in de SWF- of FLA-indeling kunt u bepalen of tekst wordt uitgevoerd als Flash-tekst of wordt omgezet in contouren of pixels. Tekst die wordt geëxporteerd als klassieke Flash-tekst, blijft volledig bewerkbaar wanneer het FLA-bestand wordt geopend in Adobe Flash CS5 Professional en kan worden doorzocht in webbrowsers wanneer de tekst wordt opgeslagen als een SWF-bestand.

Afbeeldingen

Wanneer u afbeeldingen exporteert in SWF- of FLA-indeling, kunt u de instellingen voor de afbeeldingscompressie, JPEG-kwaliteit en resolutie tijdens het exporteren wijzigen.

Wanneer u afbeeldingen exporteert als FLA-bestanden, wordt een afbeelding die meerdere malen in uw InDesign-document is geplaatst, opgeslagen als één afbeeldingsmiddel met een gedeelde locatie. Houd er rekening mee dat een groot aantal vectorafbeeldingen in het InDesign-document kan leiden tot problemen met prestaties in het geëxporteerde bestand.

Om de bestandsgrootte te verkleinen, kunt u terugkerende afbeeldingen op stramienpagina's plaatsen en het kopiëren en plakken van afbeeldingen vermijden. Als dezelfde afbeelding meerdere keren in het document is geplaatst en niet is getransformeerd of bijgesneden, wordt slechts één kopie van het bestand in het FLA-bestand geëxporteerd. Afbeeldingen die zijn gekopieerd en geplakt, worden behandeld als afzonderlijke objecten.

Standaard wordt een geplaatst Illustrator-bestand in het FLA-bestand als een enkele afbeelding behandeld terwijl bij een Illustrator-bestand dat is gekopieerd en geplakt een groot aantal afzonderlijke objecten wordt gegenereerd. De beste resultaten krijgt u als u de Illustrator-afbeelding als PDF-bestand opneemt in plaats van de afbeelding te kopiëren en plakken vanuit Illustrator. Als u kopieert en plakt, ontstaan er meerdere bewerkbare paden.

Opmerking:

U kunt voorkeursopties zodanig wijzigen dat Illustrator-objecten als één object worden geplakt in plaats van als een verzameling van kleine vectoren. Selecteer PDF in de voorkeursinstellingen voor Bestandsafhandeling en Klembordafhandeling van Illustrator en hef de selectie van AICB (geen ondersteuning van transparantie) op. Selecteer zowel PDF bij plakken als PDF naar Klembord kopiëren in de voorkeursinstellingen voor Klembordafhandeling van InDesign.

Transparantie

Controleer, voordat u naar SWF exporteert, of de transparante objecten geen interactief element zoals een knop of hyperlink overlappen. Als een object met transparantie een interactief element overlapt, gaat de interactiviteit mogelijk verloren tijdens de export. Mogelijk wilt u transparantie afvlakken voordat u gaat exporteren naar FLA.

In sommige gevallen leidt het gebruik van compressie met gegevensverlies ertoe dat de kwaliteit van afbeeldingen met transparantie afneemt. Kies in dergelijke gevallen bij het exporteren PNG (zonder gegevensverlies) voor een hogere kwaliteit.

3D-kenmerken

3D-kenmerken worden niet ondersteund in de geëxporteerde SWF- en FLA-bestanden.

Dit werk is gelicentieerd onder de Creative Commons Naamsvermelding/Niet-commercieel/Gelijk delen 3.0 Unported-licentie  De voorwaarden van Creative Commons zijn niet van toepassing op Twitter™- en Facebook-berichten.

Juridische kennisgevingen   |   Online privacybeleid