Handboek Annuleren

Gegevenssamenvoeging

  1. InDesign Handboek
  2. Kennismaken met InDesign
    1. Inleiding tot InDesign
      1. Nieuwe functies in InDesign
      2. Systeemvereisten
      3. Algemene vragen
      4. Creative Cloud Libraries gebruiken
    2. Werkruimte
      1. Basisbeginselen van de werkruimte
      2. Gereedschapsset
      3. Voorkeuren instellen
      4. Werkruimte voor aanraken
      5. Standaardsneltoetsen
      6. Document herstellen en ongedaan maken
      7. Capture-extensie
  3. Documenten maken en indelen
    1. Documenten en pagina's
      1. Documenten maken
      2. Werken met stramienpagina's
      3. Werken met documentpagina's
      4. Paginagrootte, marges en afloopgebied instellen
      5. Werken met bestanden en sjablonen
      6. Boekbestanden maken
      7. Standaardpaginanummering toevoegen
      8. Pagina's, hoofdstukken en secties nummeren
      9. QuarkXPress- en PageMaker-documenten omzetten
      10. Inhoud delen
      11. Een standaardworkflow met bestandsbeheer
      12. Documenten opslaan
    2. Rasters
      1. Rasters
      2. Rasters opmaken
    3. Hulpmiddelen voor de lay-out
      1. Linialen
  4. Inhoud toevoegen
    1. Tekst
      1. Tekst toevoegen aan kaders
      2. Tekst met verbindingen
      3. Functies voor Arabisch en Hebreeuws in InDesign
      4. Tekst op een pad maken
      5. Opsommingstekens en nummering
      6. Glyphs en speciale tekens
      7. Tekstcompositie
      8. Tekstvariabelen
      9. QR-codes genereren
      10. Tekst bewerken
      11. Tekst uitlijnen
      12. Tekst rond objecten laten lopen
      13. Verankerde objecten
      14. Gekoppelde inhoud
      15. Alinea's opmaken
      16. Tekens opmaken
      17. Zoeken/Wijzigen
      18. Spellingcontrole en taalwoordenboeken
    2. Typografie
      1. Lettertypen gebruiken in InDesign
      2. Tekst- en letterspatiëring
    3. Tekst opmaken
      1. Tekst opmaken
      2. Tabs en inspringingen
    4. Tekst controleren
      1. Wijzigingen bijhouden en beoordelen
      2. Redactionele notities toevoegen in InDesign
      3. PDF-opmerkingen importeren
    5. Referenties toevoegen
      1. Een inhoudsopgave maken
      2. Voetnoten
      3. Een index maken
      4. Eindnoten
      5. Bijschriften
    6. Stijlen
      1. Alinea- en tekenstijlen
      2. Objectstijlen
      3. Initialen en geneste stijlen
      4. Werken met stijlen
      5. Regelafstand
    7. Tabellen
      1. Tabellen opmaken
      2. Tabellen maken
      3. Tabel- en celstijlen
      4. Tabellen selecteren en bewerken
      5. Lijnen en vullingen van tabellen
    8. Interactiviteit
      1. Hyperlinks
      2. Dynamische PDF-documenten
      3. Bladwijzers
      4. Knoppen
      5. Formulieren
      6. Animatie
      7. Kruisverwijzingen
      8. Structuur geven aan PDF-bestanden
      9. Paginaovergangen
      10. Films en geluiden
      11. Formulieren
    9. Afbeeldingen
      1. Paden en vormen
      2. Tekenen met het potlood
      3. Tekenen met de pen
      4. Lijninstellingen toepassen 
      5. Samengestelde paden en vormen
      6. Paden bewerken
      7. Uitknippaden
      8. De vormgeving van hoeken wijzigen
      9. Objecten uitlijnen en verdelen
      10. Gekoppelde en ingesloten afbeeldingen
      11. AEM Assets integreren
    10. Kleur en transparantie
      1. Kleur toepassen
      2. Kleuren uit geïmporteerde afbeeldingen gebruiken
      3. Werken met stalen
      4. Inkt mengen
      5. Tinten
      6. Steun- en proceskleuren
      7. Kleuren laten overvloeien
      8. Verlopen
      9. Transparante illustraties afvlakken
      10. Transparantie-effecten toevoegen
  5. Delen
    1. Delen en samenwerken        
    2. Ter beoordeling delen
    3. Een gedeeld InDesign-document beoordelen
    4. Feedback beheren 
  6. Publiceren
    1. Exporteren en publiceren
      1. Publish Online
      2. Inhoud exporteren voor EPUB
      3. Adobe PDF-opties
      4. Inhoud exporteren naar HTML
      5. Exporteren naar Adobe PDF
      6. Exporteren naar JPEG-indeling
      7. Exporteren naar HTML
      8. Overzicht van DPS en AEM Mobile
    2. Afdrukken
      1. Boekjes afdrukken
      2. Drukkersmarkeringen en afloopgebieden
      3. Documenten afdrukken
      4. Inkten, scheiding en rasterfrequentie
      5. Overdrukken
      6. PostScript- en EPS-bestanden maken
      7. Preflight van bestanden uitvoeren voordat ze worden verzonden
      8. Miniaturen en grote documenten afdrukken
      9. PDF-bestanden voorbereiden voor serviceproviders
      10. Afdrukken van scheidingen voorbereiden
  7. InDesign uitbreiden
    1. Automatisering
      1. Gegevenssamenvoeging
      2. Plug-ins
      3. Capture-extensie in Adobe InDesign
      4. Scripting
  8. Problemen oplossen
    1. Opgeloste problemen
    2. Crashes bij starten
    3. Probleem met alleen-lezen van map Voorkeuren
    4. Problemen met bestanden oplossen
    5. Kan niet exporteren naar PDF
    6. InDesign-documenten herstellen
Opmerking:

Inclusieve taal: vanaf InDesign 2022 (versie 17.0) vervangen we niet-inclusieve taal om de kernwaarden van Adobe van inclusiviteit te weerspiegelen. Verwijzingen naar 'Master'-pagina's worden vervangen door 'Parent'-pagina's in onze Help-artikelen voor de Engelse, Deense, Hongaarse, Spaanse, Italiaanse, Braziliaanse, Portugese en Japanse landinstellingen.

Met behulp van het deelvenster Gegevenssamenvoeging in InDesign kunt u eenvoudig meerdere variaties van uw illustraties maken door een gegevensbronbestand (CSV- of XML-bestand) met een Illustrator-document samen te voegen. U kunt de functie voor gegevenssamenvoeging bijvoorbeeld gebruiken om snel en nauwkeurig honderden varianten van brieven, enveloppen, adresetiketten te maken. Gegevenssamenvoeging wordt ook wel afdruk samenvoegen genoemd.

Vereisten

U hebt alleen maar een gegevensbronbestand en een doeldocument nodig om een gegevens samen te voegen. 

  • Het gegevensbronbestand bevat de informatie die varieert per versie van het doeldocument, zoals de namen en adressen van de ontvangers van een standaardbrief. Een gegevensbronbestand bestaat uit velden en records. Velden zijn groepen met specifieke gegevens zoals bedrijfsnamen of postcodes. Met records worden rijen met volledige gegevenssets bedoeld, zoals de naam, het adres en de postcode van een bedrijf. Een gegevensbronbestand kan een door komma's (.csv), tabs (.txt) of puntkomma's gescheiden bestand zijn, dat wil zeggen een gegevensindeling waarin elk deel met gegevens wordt afgesloten door respectievelijk een komma, tab of puntkomma.
  • Het doeldocument is een InDesign-document dat de plaatsaanduidingen voor de gegevensvelden bevat, plus alle vaste gegevens, tekst en andere elementen die in elke versie van het samengevoegde document onveranderd blijven.

Het samengevoegde document is het resulterende InDesign-document met de vaste gegevens uit het doeldocument, die zo vaak als nodig is, worden herhaald voor elke record uit de gegevensbron.

Gegevenssamenvoeging

A. Gegevensbronbestand B. Doeldocument C. Samengevoegd document 

Deelvenster Gegevenssamenvoeging

Het deelvenster Gegevenssamenvoeging is toegankelijk vanuit Venster > Hulpmiddelen. De naam en het type van elk gegevensveld wordt weergegeven in het deelvenster. Als u de gegevensvelden in uw document hebt ingevoegd, worden de bijbehorende paginanummers ook weergegeven.

Deelvenster Gegevenssamenvoeging

A. Menu Gegevenssamenvoeging B. Samengevoegd document maken C. Paginanummer waar gegevensveld staat D. Voorvertoning van de laatste record E. Voorvertoning van de volgende record F. Naar record G. Voorvertoning van de vorige record H. Voorvertoning van de eerste record I. Voorvertoning van records J. Type en naam van gegevensveld K. Gegevensbron 

Basisstappen voor het samenvoegen van gegevens

1. Bepaal welke gegevensvelden u wilt gebruiken in uw bron- en doeldocumenten.

Bepaal hoe het uiteindelijke document eruit moet zien, zodat u weet welke velden nodig zijn om de gegevens samen te voegen. Als u bijvoorbeeld een brief schrijft die u aan klanten wilt sturen, kunt u de volgende gegevensvelden gebruiken:

<<Bedrijfsnaam>><<Adres>><<Postcode>><<Plaats>>, <<Provincie>>

Uw spreadsheet of database zou er als volgt uit kunnen zien:

Voorbeeld van gegevensbestand

2. Sla het gegevensbronbestand (meestal een spreadsheet of databasebestand) op als een door komma's, (.csv), tabs (.txt) of puntkomma's gescheiden bestand.

Controleer of uw gegevensbronbestand zodanig is gestructureerd, dat u de desbetreffende velden in uw doeldocument kunt opnemen. De bovenste rij van een spreadsheet kan worden gereserveerd voor de veldnamen die u in het doeldocument gaat gebruiken, dus bijvoorbeeld 'Bedrijf' en 'Adres'.

Zie Over gegevensbronbestanden voor meer informatie.

3. Maak een doeldocument met de tekst en de andere elementen die in elke versie van het doeldocument gelijk blijven.

Zie Over doeldocumenten voor meer informatie.

4. Selecteer de gegevensbron in het deelvenster Gegevenssamenvoeging.

Zie Een gegevensbron selecteren voor meer informatie.

5. Gebruik het deelvenster Gegevenssamenvoeging om velden in het doeldocument in te voegen.

U kunt gegevensvelden toevoegen aan zowel documentpagina's als stramienpagina's. Als u gegevensvelden toevoegt aan een stramienpagina, hebt u nog andere mogelijkheden.

Zie Gegevensvelden invoegen en Plaatsaanduidingen voor gegevensvelden toevoegen aan stramienpagina's voor meer informatie.

6. Open een voorvertoning van de records, zodat u zeker weet dat het doeldocument er goed uitziet.

7. Voeg het doeldocument samen met het gegevensbronbestand of exporteer het naar PDF.

Zie Records samenvoegen voor meer informatie.

Over gegevensbronbestanden

Meestal is de gegevensbron afkomstig uit een spreadsheet- of een databasetoepassing, maar u kunt uw eigen gegevensbronbestand maken in InDesign of in een tekstverwerker. Gegevensbronbestanden moeten een door komma's (.csv), tabs (.txt) of puntkomma's gescheiden tekstbestand zijn. Raadpleeg de gebruikershandleiding bij uw brontoepassing voor meer informatie over exporteren naar dergelijke indelingen.

In een door komma's, tabs of puntkomma's tekstbestand worden records van elkaar gescheiden door alinea-einden en velden door komma's, tabs of puntkomma's. Het gegevensbronbestand kan ook tekst of paden bevatten die naar afbeeldingen op een schijf verwijzen.

Voorbeeld van een door komma's gescheiden gegevensbronbestand

Naam,Bedrijfsnaam,Staat Bill Tucker,CoreVent Labs,Nevada Dat Nguyen,'Brady, Hunt, and Baxter, Inc',Delaware Maria Ruiz,'Brinquist Enterprises, Inc.',California
Opmerking:

Als u een komma of een aanhalingsteken wilt opnemen in een door komma's gescheiden bestand, plaatst u de tekst tussen aanhalingstekens, dus bijvoorbeeld 'Bart, Ted en Karel, VOF'. Als u in dergelijke gevallen geen aanhalingstekens gebruikt, wordt iedere naam als een afzonderlijk veld beschouwd.

U kunt geen regeleinde invoegen in een veld in een gegevensbronbestand. Als het nodig is om een veld in meerdere regels te splitsen, kunt u twee verschillende velden maken, bijv. <<Adres1>> en <<Adres2>>.

Wanneer u het document samenvoegt, kunt u Witregels voor lege velden verwijderen selecteren om lege regels te voorkomen. Als de regel echter tekens (waaronder spaties) bevat, wordt de regel niet verwijderd.

Afbeeldingsvelden opnemen in het gegevensbronbestand

Door afbeeldingsvelden toe te voegen aan het gegevensbronbestand kunt u ervoor zorgen dat in elke samengevoegde record een andere afbeelding wordt weergegeven. Als u bijvoorbeeld documenten samenvoegt die informatie over verschillende bedrijven bevatten, kunt u als onderdeel van de samenvoeging een afbeelding opnemen van het logo van elk bedrijf.

  1. Open het gegevensbronbestand.
  2. Typ aan het begin van de naam van het gegevensveld een 'apenstaartje' (@) om tekst of paden in te voegen die naar afbeeldingsbestanden verwijzen.

    Het @-symbool hoeft alleen in de eerste regel te worden ingevoegd. De volgende regels moeten de paden voor de afbeelding bevatten. Paden zijn hoofdlettergevoelig en moeten de naamgevingsconventies volgen van het besturingssysteem waarin ze zijn opgeslagen.

    Opmerking:

    Als er een foutbericht wordt weergegeven als u het @-symbool typt aan het begin van het veld, typt u een apostrof (') vóór het @-symbool (bijvoorbeeld '@Afbeeldingen) om de functie te valideren. In sommige toepassingen, zoals Microsoft Excel, is het @-symbool gereserveerd voor functies.

(Windows) Voorbeeld van afbeeldingsreferenties in gegevensbronbestand

Naam

Leeftijd

@Afbeeldingen

Wim Bakker

36

C:\Afbeeldingen\WimBakker.jpg

Janssens

53

C:\Mijn documenten\dat.gif

Maria Ruiz

26

C:\Afbeeldingen\Ruiz.psd

(Mac OS) Voorbeeld van afbeeldingsreferenties in gegevensbronbestand

Naam

Leeftijd

@Afbeeldingen

Wim Bakker

36

Mac HD:Afbeeldingen:WimBakker.jpg

Janssens

53

Desktop:Familie:dat.gif

Maria Ruiz

26

Mac HD:Afbeeldingen:Ruiz.jpg

Opmerking:

In InDesign kunt u het pad van een afbeelding in uw besturingssysteem weergeven. Voeg een afbeelding in in een InDesign-document en geef vervolgens de locatie van de afbeelding weer in het deelvenster Koppelingen. Zorg dat de afbeelding is geselecteerd en kies vervolgens Info kopiëren > Volledig pad kopiëren in het menu van het deelvenster Koppelingen. U dient wellicht het pad te bewerken nadat u het in uw gegevensbronbestand hebt gekopieerd. Dit is vooral handig bij afbeeldingen op een server.

Over doeldocumenten

Nadat u het gegevensbronbestand hebt gemaakt, moet u het doeldocument instellen en de velden uit het gegevensbronbestand invoegen. Het doeldocument bevat plaatsaanduidingstekst en ‑afbeeldingen voor de gegevensvelden, bijvoorbeeld voor het ontwerp dat in elke brief moet staan. Deze velden kunnen worden toegevoegd nadat u een gegevensbron hebt geselecteerd.

Het doeldocument bevat velden uit de gegevensbron met de plaatsaanduidingstekst die wordt weergegeven.

Als u gegevens samenvoegt, maakt InDesign een nieuw document waarmee u de velden vervangt door de gegevens die u in het gegevensbronbestand hebt toegewezen. U kunt gegevensvelden toevoegen aan zowel stramienpagina's als documentpagina's.

Een gegevensbron selecteren

Selecteer een gegevensbron in het deelvenster Gegevenssamenvoeging voordat u velden invoegt in uw doeldocument. Er kan slechts één gegevensbronbestand per doeldocument worden geselecteerd.

  1. Maak of open het document dat u als doeldocument wilt gebruiken.
  2. Kies Venster > Hulpmiddelen > Gegevenssamenvoeging.

  3. Kies Gegevensbron selecteren in het menu van het deelvenster Gegevenssamenvoeging.

  4. Als u opties voor tekst met scheidingstekens wilt wijzigen, selecteert u Importopties tonen.

    In InDesign wordt automatisch het type scheidingsteken en codering gedetecteerd die in het gegevensbronbestand worden gebruikt, zodat het gewoonlijk niet nodig is de importopties weer te geven. U kunt echter verschillende opties voor codering en scheidingstekens opgeven als u denkt dat deze niet correct zijn geïdentificeerd.

  5. Zoek het gegevensbronbestand op en klik op Openen.

  6. Als u Importopties tonen hebt geselecteerd, wijzigt u indien nodig de opties voor scheidingstekens en codering en klikt u op OK. De gegevensvelden staan in het deelvenster Gegevenssamenvoeging.
Opmerking:

Als in een waarschuwingsbericht wordt aangegeven dat het bestand niet kan worden geopend of als er onjuiste velden in de lijst staan, moet u wellicht het spreadsheet- of databasebestand bewerken en opslaan als een door komma', tabs of puntkomma's gescheiden bestand.

Als de gegevensbron is geselecteerd en de velden zijn geladen in het deelvenster Gegevenssamenvoeging, worden wijzigingen in de gegevensbron pas in het doeldocument doorgevoerd als u de gegevensbron bijwerkt.

Gegevensvelden invoegen

Als u de gegevensbron selecteert, verschijnt er een lijst met namen van gegevensvelden in het deelvenster Gegevenssamenvoeging. Deze namen zijn precies gelijk aan de kolomkoppen uit het gegevensbronbestand. Pictogrammen geven aan of het een tekst- of een afbeeldingsveld is. Als gegevensvelden worden toegevoegd aan uw document, worden het plaatsaanduidingen voor velden, zoals <<Bedrijf>>. U kunt deze plaatsaanduidingen op precies dezelfde manieren als andere tekst of afbeeldingen selecteren en opmaken.

U kunt een afbeeldingsveld toewijzen aan een bestaand kader om een zwevende afbeelding te maken. Ook kan, als de invoegpositie zich in een tekstkader bevindt of als tekst is geselecteerd wanneer u een afbeeldingsveld invoegt, een kleine plaatsaanduiding worden ingevoegd als inline-kader. U kunt de grootte van de samengevoegde afbeeldingen bepalen door het formaat van de plaatsaanduiding voor de afbeelding te wijzigen.

Als u een gegevensveld hebt ingevoegd, onthoudt InDesign de gegevensbron van dit veld. Eventuele fouten in de lijst met velden, zoals spelfouten, lege velden en niet gewenste veldtypen moeten in de brontoepassing worden gecorrigeerd en vervolgens worden bijgewerkt via het deelvenster Gegevenssamenvoeging.

Een tekstgegevensveld invoegen in het doeldocument

  1. Maak een tekstkader op een documentpagina of stramienpagina.

    Zie Plaatsaanduidingen voor gegevensvelden toevoegen aan stramienpagina's als u gegevensvelden aan stramienpagina's toevoegt.

  2. Plaats de invoegpositie in het tekstkader waar u de plaatsaanduiding voor velden wilt laten verschijnen of selecteer de tekst die u wilt vervangen.
  3. Voer een van de volgende handelingen uit om een plaatsaanduiding voor velden in te voegen:
    • Klik op een veld in de lijst van het deelvenster Gegevenssamenvoeging.

    • Sleep een veldnaam uit de lijst in het deelvenster Gegevenssamenvoeging naar het tekstkader om de plaatsaanduiding toe te voegen. Als u een tekstveld naar een leeg kader sleept, wordt het lege kader een tekstkader.

Plaatsaanduidingen voor tekstvelden worden in de doeltoepassing weergegeven met dubbele punthaakjes (bijvoorbeeld <<Naam>>) en met de huidige opmaakkenmerken (zoals lettertype en tekengrootte).

Opmerking:

Het is niet mogelijk een geldig veld te maken door eenvoudigweg de veldnaam te typen of een bestaand veld te bewerken. U moet het nieuwe veld invoegen via het deelvenster Gegevenssamenvoeging.

Een afbeeldingsgegevensveld invoegen in het doeldocument

  • Om een nieuwe plaatsaanduiding voor een inline-afbeelding in te voegen, sleept u een afbeeldingsbestand naar een tekstkader of plaatst u de invoegpositie in een tekstkader en klikt u op het afbeeldingsveld.
  • Om een nieuwe zwevende afbeelding in te voegen, sleept u een afbeeldingsveld naar een leeg kader of naar een bestaand afbeeldingskader. Als u een afbeeldingsveld naar een leeg kader sleept, wordt het lege kader een afbeeldingskader.
  • Om een veld in gegroepeerde items, tabelcellen of geneste items in te voegen, sleept u het afbeeldingsveld naar het doel.

    Plaatsaanduidingen voor afbeeldingsvelden worden als kaders met een veldnaam weergegeven.

QR-code toevoegen

U kunt een QR-code in het samengevoegde document integreren. De volgende typen QR-codevelden kunnen worden toegevoegd via een workflow voor gegevenssamenvoeging:

  • Onbewerkte tekst
  • Hyperlink
  • Tekstbericht
  • E-mail
  • Visitekaartje

Voor het genereren van de QR-codes hebben de gegevensitems in de TXT- of CSV-bestanden die als gegevensbron worden gebruikt, de volgende indeling:

  • Normale tekst: voer in de kolom QR-code normale tekst in.
  • Hyperlink: URL:<url> (bijvoorbeeld 'URL:http://www.google.nl')
  • Sms: SMSTO:<telefoonnummer>:<bericht> (bijvoorbeeld: 'SMSTO:9818143551:Hallo')
  • E-mail: MATMSG:\nTo:<e-mailadres> (bijvoorbeeld: 'MATMSG:\nTO:jansmit@adobe.nl\nSUB:Hallo;\nBODY:;;')
  • Visitekaartje: 'BEGIN:VCARD\nVERSION:2.1\nN:Smith;John\nFN:John Smith\nORG:Adobe\nTITLE:Engineer\nTEL;CELL:+919876543210\nTEL;WORK;VOICE:123456789\nADR;WORK:;;Street ABC;Seattle;Washington;98101;US\nEMAIL;WORK;INTERNET:abc@adobe.com\nURL:www.adobe.com\nEND:VCARD'

De gegevensitems kunnen bestaan uit een combinatie van e-mail, sms, hyperlink of normale tekst. Voer deze in in de CSV- en TXT-velden in de hiervoor genoemde indeling in met een #-teken in hun kolomnaam. U kunt als volgt QR-codes genereren:

  1. Selecteer Venster > Hulpmiddelen > Gegevens samenvoegen.

  2. Selecteer Gegevensbron selecteren in het vervolgmenu.

  3. Selecteer het gegevensbestand met de informatie voor het QR-veld. Klik op Openen.

  4. Selecteer de plaatsaanduiding in het document.

  5. Klik op het pictogram Samengevoegd document maken om een samengevoegd document te maken.

Plaatsaanduidingen voor gegevensvelden toevoegen aan stramienpagina's

Als u plaatsaanduidingen voor gegevensvelden invoegt op stramienpagina's, zijn er mogelijkheden die niet beschikbaar zijn als u plaatsaanduidingen op documentpagina's invoegt:

  • De oorspronkelijke plaatsaanduidingen staan op de stramienpagina's van het resulterende samengevoegde document, waarbij de samengevoegde resultaten als overschreven stramienpagina-items worden weergegeven op documentpagina's.

  • Het samengevoegde document behoudt een verbinding met de gegevensbron, zodat u bij wijziging van records in de gegevensbron de inhoud van het samengevoegde document kunt bijwerken door Inhoud in gegevensvelden bijwerken te kiezen. Deze optie is met name handig als u de opmaak in het samengevoegde document wijzigt en vervolgens nieuwe gegevens moet toevoegen vanuit de gegevensbron.

  • De instellingen in het dialoogvenster Samengevoegd document maken zijn gelijk aan de instellingen die worden gebruikt in het doeldocument. Hierdoor kunt u snel het huidige document opnieuw maken met dezelfde opmaak. U kunt deze gedeelde instellingen ook gebruiken om een identiek document te maken met een andere gegevensbron of om een nieuw document te maken met een enigszins gewijzigde opmaak.

Opmerking:

Als u gegevensvelden aan een stramienpagina toevoegt, dient u ervoor te zorgen dat in het tekstkader dat de gegevensvelden bevat, stramienitems kunnen worden overschreven. Selecteer het tekstkader op de stramienpagina en kies Overschrijven van stramienitems bij selectie toestaan in het menu van het deelvenster Pagina's. Als u deze optie niet selecteert, worden de gegevens niet samengevoegd. (Zie Stramienen maken.)

U kunt gegevensvelden niet op zowel stramienpagina's als documentpagina's plaatsen. Om gegevens op de juiste manier samen te voegen, moet u een stramienpagina met gegevensvelden toepassen op de eerste pagina van het document.

Opmerking:

Als een foutbericht aangeeft dat het document niet kan worden samengevoegd in InDesign omdat er geen plaatsaanduidingen aanwezig zijn, hebt u de plaatsaanduidingen mogelijk op de linkerstramienpagina van een document met één pagina geplaatst. Pagina 1 is gebaseerd op de rechterstramienpagina. U moet de plaatsaanduidingen dus op de rechterstramienpagina plaatsen.

Gegevensbronbestanden bijwerken, verwijderen of vervangen

  • Als u gegevensbronbestanden wilt bijwerken, bewerkt u het bronbestand, slaat u dat bestand als een door komma's, tabs of puntkomma's gescheiden bestand en kiest u vervolgens Gegevensbron bijwerken in het deelvenster Gegevenssamenvoeging.

    De wijzigingen worden weergegeven in het deelvenster Gegevenssamenvoeging. Als de wijzigingen na het bijwerken niet in het document zijn doorgevoerd, schakelt u Voorvertoning eerst uit en daarna weer in.

  • Als u de verbinding met het gegevensbronbestand wilt verbreken, kiest u Gegevensbron verwijderen in het menu van het deelvenster Gegevenssamenvoeging.
  • Om over te schakelen naar een nieuw gegevensbronbestand, kiest u Gegevensbron selecteren in het menu van het deelvenster Gegevenssamenvoeging en geeft u vervolgens het nieuwe gegevensbronbestand op. Sommige velden worden mogelijk niet herkend in InDesign. In dergelijke gevallen kunt u de desbetreffende plaatsaanduidingsvelden het beste verwijderen en opnieuw invoegen.
Opmerking:

Als u een samengevoegd document genereert op basis van een doeldocument waarvan de stramienpagina's gegevensvelden bevatten, kunt u de gegevensvelden in het samengevoegde document bijwerken.

Een voorvertoning openen van de records in het doeldocument

Voordat u het doeldocument en het gegevensbronbestand gaat samenvoegen, is het verstandig een voorvertoning van de records te bekijken om er zeker van te zijn dat de veldgegevens op de juiste wijze worden weergegeven wanneer de gegevens worden samengevoegd. Als u een voorvertoning van records bekijkt, worden in het deelvenster Gegevenssamenvoeging niet de plaatsaanduidingen voor de velden maar de feitelijke gegevens uit het gegevensbronbestand weergegeven. In plaats van <<Bedrijf>> staat er dan dus bijvoorbeeld Adobe . Met de navigatieknoppen in het deelvenster Gegevenssamenvoeging kunt u door de records bladeren.

Als er problemen optreden met een van de records, zoals typfouten of te veel spaties, kunt u het bronbestand het beste in de oorspronkelijke toepassing bewerken. (Zie Over gegevensbronbestanden.)

  1. Klik op Voorvertoning onder in het deelvenster Gegevenssamenvoeging of kies Voorvertoning in het menu van het deelvenster Gegevenssamenvoeging.

  2. Klik op de navigatieknoppen om de gegevens uit de records te doorlopen.
Opmerking:

Klik op de navigatieknoppen onder in het deelvenster om naar de opgegeven record te gaan. U kunt ook in het navigatievak onder in het deelvenster het nummer typen van de record waarvan u een voorvertoning wilt bekijken en vervolgens op Enter of Return drukken.

De voorvertoning in- of uitschakelen

Er kunnen problemen ontstaan als u van de ene voorvertoningsmodus naar een andere overschakelt, maar die problemen kunnen ook uit zichzelf worden opgelost. Denk hierbij aan het volgende:

  • Plaatsaanduidingen vervangen de voorvertoningsinhoud als de optie Voorvertoning record niet is geselecteerd. Als u zowel een afbeelding als het kader van deze afbeelding of een hele reeks tekst verwijdert en de optie Voorvertoning record uitschakelt, worden de plaatsaanduidingen niet weergegeven, omdat deze ook zijn verwijderd.

  • De wijzigingen worden pas doorgevoerd in het dialoogvenster Opties voor plaatsing van inhoud als u op OK klikt. Als de optie Voorvertoning record is geselecteerd, weerspiegelen de gegevens de bijgewerkte plaatsingsinstellingen pas als u deze optie hebt uitgeschakeld en opnieuw hebt geselecteerd.

  • Wanneer u het document probeert op te slaan in de modus Voorvertoning, ontvangt u een waarschuwing waarin u wordt gevraagd de modus Voorvertoning uit te schakelen voordat u uw document opslaat.

Plaatsaanduidingen voor gegevensvelden bewerken

Als u een tekstgegevensveld toevoegt aan een document, wordt de plaatsaanduidingstekst voor het veld ingevoerd met behulp van de opmaakkenmerken (zoals lettertype en formaat) die gelden bij de invoegpositie. U kunt de kenmerken van de plaatsaanduidingstekst dan bewerken en zo de vormgeving van de feitelijke gegevens bepalen.

  1. Ga op een van de volgende manieren te werk:
    • Om de kenmerken van een plaatsaanduiding te wijzigen, selecteert u de tekst van de plaatsaanduiding en wijzigt u de opmaakkenmerken net zoals u andere tekst zou wijzigen.

    • Om een plaatsaanduiding te wijzigen, selecteert u de plaatsaanduiding of de feitelijke gegevens en selecteert u een andere veldnaam in het deelvenster Gegevenssamenvoeging.

    • Om een plaatsaanduiding te verwijderen, selecteert u de plaatsaanduiding en drukt u op Backspace of Delete.

Opmerking:

In de weergave Artikeleditor worden plaatsaanduidingen voor tekst op dezelfde manier weergegeven als hyperlinks. Sommige opties in het deelvenster Gegevenssamenvoeging zijn niet beschikbaar in de weergave Artikeleditor.

Opties voor plaatsing van inhoud instellen

Gebruik het dialoogvenster Opties voor plaatsing van inhoud om de standaardinstellingen op te geven voor het huidige document of voor alle toekomstige projecten voor het samenvoegen van gegevens. U kunt opgeven hoe de afbeelding wordt geplaatst, of afbeeldingen worden gekoppeld of ingesloten en of witregels voor lege velden worden verwijderd. Bovendien kunt u het maximale aantal records voor elk samengevoegd document opgeven.

Opties voor plaatsing van inhoud

  1. Ga op een van de volgende manieren te werk:
    • Om alleen het huidige document aan te passen, opent u het doeldocument.

    • Om alle documenten aan te passen die u nog gaat maken, sluit u alle documenten.

  2. Kies Venster > Hulpmiddelen > Gegevenssamenvoeging.

  3. Kies Opties voor plaatsing van inhoud in het menu van het deelvenster Gegevenssamenvoeging.

  4. Wijzig de opties voor plaatsing van inhoud. (Zie Opties voor plaatsing van inhoud.)
  5. Klik op OK.

Records samenvoegen

Na het opmaken van het doeldocument en het invoegen van velden uit het gegevensbronbestand kunt u de gegevens uit de gegevensbron samenvoegen met het doeldocument. U kunt de records samenvoegen naar een ander InDesign-document of direct naar een PDF. Tijdens het samenvoegen wordt in InDesign op basis van het doeldocument een nieuw document of PDF-bestand gemaakt en worden de velden in het doeldocument vervangen door de bijbehorende gegevens uit het gegevensbronbestand.

Als u een document samenvoegt waar op de stramienpagina's plaatsaanduidingen voor gegevensvelden staan, worden deze stramienpagina-items gekopieerd naar de stramienpagina's in het nieuwe document.

Een of meer records samenvoegen

  1. Voer een van de volgende handelingen uit terwijl het doeldocument is geopend:
    • Kies Samengevoegd document maken in het menu van het deelvenster Gegevenssamenvoeging of klik op de knop Samengevoegd document maken .

    • Kies Exporteren naar PDF in het menu van het deelvenster Gegevenssamenvoeging.

    Samengevoegd document maken

  2. Selecteer op het tabblad Records bij Samen te voegen records de optie Alle records als u alle records in het gegevensbronbestand wilt samenvoegen. Selecteer Eén record als u een bepaalde record wilt samenvoegen of kies Bereik om een bereik met records samen te voegen.

  3. Stel bij Records per documentpagina een van de volgende opties in:

    • Kies Eén record als u wilt dat elke record boven aan de volgende pagina begint.

    • Kies Meerdere records als u meerdere records per pagina wilt maken. (Als u bijvoorbeeld adresetiketten wilt afdrukken.)

      Het is niet mogelijk meerdere records samen te voegen als de gegevensvelden worden weergegeven op een documentpagina in een document met meerdere pagina's of als er gegevensvelden op meerdere stramienpagina's staan.

  4. Selecteer Rapport overlopende tekst genereren bij maken van document om automatisch een rapport te openen waarin de tijdens het samenvoegen van de gegevens in het InDesign-document gemaakte overloopvoorwaarden worden bijgehouden. (Zie Rapporten voor overlopende tekst.)

  5. Selecteer Waarschuwing bij ontbrekende afbeeldingen als u een waarschuwing voor het ontbreken van een koppeling wilt laten weergeven als een of meer afbeeldingen niet beschikbaar zijn.

  6. Als u op het tabblad Records de optie Meerdere records hebt geselecteerd, klikt u op het tabblad Layout meerdere records en geeft u de volgende instellingen op:

    • Voer bij Marges de gewenste waarden in voor de afstand tussen de margehulplijnen en de randen van de pagina.

    • Selecteer bij Layout van records de instelling Rijen eerst of Kolommen eerst en geef vervolgens de afstand tussen de kolommen en de rijen op.

  7. Als u Meerdere records hebt geselecteerd, selecteert u Voorvertoning lay-out meerdere records om de wijzigingen te bekijken die u hebt opgegeven in het dialoogvenster Samengevoegd document maken. Gebruik de paginaknoppen om door de records te navigeren.

  8. Klik op het tabblad Opties en geef de plaatsingsopties op. (Zie Opties voor plaatsing van inhoud.)

  9. Klik op OK nadat u de gewenste opties hebt ingesteld.

  10. Als u direct naar PDF exporteert, stelt u de PDF-opties in en klikt u op Exporteren. Geef een bestandsnaam en een locatie op en klik vervolgens op Opslaan. (Zie Adobe PDF-opties.)

Als het gegevensbronbestand verwijst naar niet-ondersteunde bestandsindelingen of naar afbeeldingen die niet beschikbaar zijn, dient u het gegevensbronbestand wellicht te corrigeren zodat het naar een ondersteund bestand verwijst, de padnaam naar een ontbrekend bestand te corrigeren of het bestand gewoon naar de juiste map te verplaatsen, zodat InDesign het kan vinden en plaatsen.

Beperkingen voor het samenvoegen van meerdere records

Kies Meerdere records als u meerdere records per pagina wilt maken. Als u bijvoorbeeld adresetiketten afdrukt, zult u meerdere etiketten op een pagina willen afdrukken. De manier waarop de records in de samengevoegde publicatie worden weergegeven, hangt voornamelijk af van de lay-outopties. Hieronder staan de beperkingen waarmee u kunt worden geconfronteerd wanneer u de optie Meerdere records gebruikt:

  • Het is niet mogelijk meerdere records samen te voegen als de gegevensvelden worden weergegeven op een documentpagina in een document met meerdere pagina's of als er gegevensvelden op meerdere stramienpagina's staan.

  • Bij gegevenssamenvoeging kunnen plaatsaanduidingen maar in één grootte worden gebruikt.

  • Als u een record uit een gepubliceerde publicatie verwijdert, wordt de lege plaats niet door een andere record opgevuld.

Samenvoegen tot een PDF-bestand

Wanneer u naar een PDF-bestand samenvoegt, blijven alle opties hetzelfde als wanneer u een samengevoegd InDesign-document maakt. De resulterende PDF gebruikt PDF XObjects voor statische onderdelen van de pagina, waardoor het PDF-bestand minder groot wordt.

Gegevensvelden bijwerken

Nadat een document is samengevoegd met plaatsaanduidingen voor gegevens op stramienpagina's, kunt u de opmaak van het samengevoegde document wijzigen en nog steeds de waarden van gegevensvelden in de gegevensbron bijwerken. Gebruik Gegevensvelden bijwerken om de gegevensvelden bij te werken zonder de opmaak van het document te wijzigen. Deze optie is alleen beschikbaar in een samengevoegd document waarbij plaatsaanduidingen voor gegevens op stramienpagina's staan.

  1. Breng wijzigingen aan in het gegevensbronbestand, sla het gegevensbronbestand op en sluit het vervolgens.
  2. Kies in het samengevoegde document de optie Gegevensvelden bijwerken.

De wijzigingen die zijn aangebracht door het bijwerken van de gegevensvelden worden weergegeven in een logbestand.

Opmerking:

Deze optie werkt het beste als u records bewerkt of toevoegt in het gegevensbronbestand. Als u plaatsaanduidingen voor velden toevoegt, nieuwe velden toevoegt aan de gegevensbron of de instellingen wijzigt in het dialoogvenster Samengevoegd document maken, gebruikt u de optie Samengevoegd document maken om een nieuw samengevoegd document te genereren.

Rapporten voor overlopende tekst

De instelling Rapport overlopende tekst wordt weergegeven als de optie Rapport overlopende tekst genereren is geselecteerd in het dialoogvenster Samengevoegd document maken en als een of meer velden na het samenvoegen van de gegevens overlopende tekst bevatten.

In het rapport worden alle gevallen van overlopende tekst in een genummerde lijst weergegeven, waarin u het paginanummer van de tekst ziet, het aantal woorden/tekens dat overloopt en een fragment van de overlopende tekst.

Als het rapport verschijnt wanneer u een samengevoegd document maakt, gebruik dan het rapport om de overlopende staat te corrigeren. U wilt misschien het tekstkader groter maken, de tekengrootte kleiner maken of de tekst bewerken.

Opties voor plaatsing van inhoud

De volgende opties komen voor in het dialoogvenster Opties voor plaatsing van inhoud:

Afbeeldingen proportioneel aanpassen

Behoudt de verhoudingen van de afbeelding maar schaalt de afbeelding, zodat deze binnen het kader past (standaard).

Afbeeldingen aan kaders aanpassen

Schaalt de afbeeldingen zodanig dat de verhoudingen gelijk zijn aan de verhoudingen van het kader.

Kaders aan afbeeldingen aanpassen

Handhaaft het formaat van de afbeelding en past het formaat van het kader daaraan aan.

Formaat van kader en afbeelding behouden

Plaatst de afbeelding in het oorspronkelijke formaat en uitgelijnd op de linkerbovenhoek van het kader. De afbeelding wordt bijgesneden als deze te groot is voor het kader.

Kaders proportioneel vullen

Plaatst de afbeelding zodanig, dat het kader in hoogte en breedte wordt gevuld. De rest van de afbeelding wordt vervolgens bijgesneden.

Passend maken met behoud van inhoud

Maakt een afbeelding automatisch passend voor een kader op basis van de afbeeldingsinhoud en kadergrootte.

Bestaande gebruiken

Past de bestaande optie voor afzonderlijke kaderaanpassing toe voor afbeeldingskaders. Deze optie is handig wanneer u een bestaande aanpassing voor het doelkader wilt kiezen.

Centreren in kader

Lijnt het midden van de afbeelding uit op het midden van het kader. Deze optie is uitgeschakeld als u de optie Passend maken met behoud van inhoud hebt geselecteerd.

Afbeeldingen koppelen

Maakt een koppeling of een bestandspad naar het originele afbeeldingsbestand. Als deze optie niet is geselecteerd, worden alle afbeeldingsgegevens ingesloten in het InDesign-document.

Witregels voor lege velden verwijderen

Verwijdert alinea-einden die zijn ingevoegd voor lege velden. Dit is met name handig voor mailings waarbij een optioneel adresveld beschikbaar is. Bij deze optie worden zachte returns genegeerd. Als de regel tekens (waaronder spaties) bevat, wordt de regel niet verwijderd.

Recordlimiet per document

Geeft het maximum aantal records voor elk samengevoegd document op. Wanneer deze drempelwaarde is bereikt, wordt er een nieuw document gemaakt. Dit document bevat het aantal pagina's dat nodig is voor het resterende aantal records dat nog moet worden samengevoegd (tot aan de limiet per record). Deze optie is alleen beschikbaar als de optie Enkel record is geselecteerd.

Paginalimiet per document

Geeft het maximum aantal pagina's voor elk samengevoegd document op. Als de drempelwaarde is bereikt, wordt er een nieuw document gemaakt met het aantal pagina's dat nodig is voor het aantal records dat nog moet worden samengevoegd (tot aan de limiet per pagina). Deze optie is alleen beschikbaar als tijdens het samenvoegen de optie Meerdere records is geselecteerd in het menu Records per documentpagina.

Verwante informatie

Adobe-logo

Aanmelden bij je account