A Photoshop teljesítményének optimalizálása

Ha a Photoshop a vártnál lassabban fut a számítógépen, próbálja ki az itt leírt módszereket és technikákat.

  A Photoshop 3D-funkcióinak megszűnése

A Photoshop 3D-funkciói a jövőbeni frissítésekkel megszűnnek. A 3D-tartalmakkal dolgozó felhasználóknak javasoljuk az Adobe új Substance 3D alkalmazásait, amelyek az Adobe 3D-eszközeinek következő generációját képviselik. További részletek a Photoshop 3D-funkcióinak megszüntetéséről itt találhatók: Photoshop 3D | Gyakori kérdések a megszűnő 3D-funkciókkal kapcsolatban.

Általános lépések a teljesítmény növelése érdekében

Minden felhasználó munkakörülményei egyediek, és a technikák eltérő kombinációjára lehet szükség a Photoshop lehető leghatékonyabb teljesítményének elérése érdekében. Gondolja át, a jelen dokumentumban javasolt megoldások közül melyikeket érdemes alkalmazni az Ön számítógépes felszereltségére, az Ön által használt fájltípusokra és saját munkafolyamatára tekintettel. A Photoshopban négy fő módja van a teljesítmény javításának: a hardverbeállítás optimalizálásaaz operációs rendszer optimalizálása a Photoshophoza teljesítményhez kapcsolódó beállítások konfigurálása és a funkciók finombeállítása a teljesítmény növeléséhez.

A teljesítmény javításának legegyszerűbb, teljesen ingyenes módja az, ha a Photoshop teljesítménybeállításait úgy adja meg, és úgy végzi el a funkciók finombeállításait, hogy kihasználja a használt munkamódszer és a jellemzően használt fájltípusok előnyeit.

Leginkább úgy javíthat a teljesítményen, ha gyorsabb és nagyobb teljesítményű hardvert vásárol.A számítógépnek meg kell felelnie bizonyos minimális rendszerkövetelményeknek a Photoshop optimális futtatásához. Ha a Photoshopot túl gyenge vagy nem támogatott hardveren – például egy olyan számítógépen, amely nem kompatibilis grafikus processzorral (GPU) rendelkezik – futtatja, az teljesítményproblémákhoz vezethet. 

A teljesítményhez kapcsolódó beállítások konfigurálása

Ebből a rövid videóból megtudhatja, hogyan optimalizálhatja gyorsan a teljesítményhez kapcsolódó beállításokat a Photoshopban.

A Photoshop számos beállítást (Beállítások > Teljesítmény) tartalmaz, amelynek segítségével számítógépének erőforrásait, például a memóriát, gyorsítótárat, grafikus processzort, megjelenítőket stb. optimálisan használhatja ki. Attól függően, hogy elsődlegesen mire használja a Photoshopot, és milyen típusú dokumentumokkal dolgozik, ezen beállítások különböző kombinációi lehetnek a megfelelők az Ön számára.

A Beállítások párbeszédpanel más fülein elérhető további beállítások, például az Átmeneti tárolók, szintén hatással lehetnek a számítógép futási sebességére és stabilitására.

Teljesítmény-beállítások Photoshopban

A Photoshophoz rendelt memória módosítása

Javíthatja a teljesítményt a Photoshop számára kiosztott memória/RAM mennyiségének növelésével. A Teljesítmény beállítási párbeszédpanel (Beállítások > Teljesítmény) Memóriahasználat területe megmutatja, hogy mennyi RAM érhető el a Photoshop számára. Emellett azt is megmutatja, hogy ideálisan mekkora memóriatartomány osztandó ki a rendszerben a Photoshop számára.

Alapértelmezés szerint a Photoshop az elérhető RAM 70%-át használja.

  1. A Photoshop használatának engedélyezése mezőben látható érték változtatásával növelje a Photoshophoz rendelt RAM mennyiségét. Alternatív megoldásként állítsa be a Memóriahasználat csúszkát.
  2. Indítsa újra a Photoshopot a változtatások engedélyezéséhez.

Ahhoz, hogy megtalálja a rendszerének ideális RAM-hozzárendelést, 5%-os lépésekben módosítsa, és figyelje a teljesítményt a Hatékonysági állapot jelzőn. 

Nem javasoljuk, hogy a számítógép memóriájának több mint 85%-át a Photoshophoz rendelje. Ez rossz hatással lehet a teljesítményre, mivel így nem hagy memóriát más alapvető rendszeralkalmazások számára.

Megjegyzés:

Ha RAM-hiány vagy memóriahiány hibákat észlel a Photoshopban, próbálja megnövelni a Photoshophoz hozzárendelt RAM mennyiségét. Ha viszont túl magas (>85%) RAM-kiosztási értéket állít be a Photoshophoz, az rossz hatással lehet más futó alkalmazások teljesítményére, és instabillá teheti a rendszert. 

A probléma legjobb megoldása, ha növeli a számítógép RAM-ját. Egyeztesse a számítógép gyártójával a RAM specifikációit és kompatibilitását.

Gyorsítótárszintek módosítása

A gyorsítótár alapjai

A Photoshop munka közben kép-gyorsítótárazást alkalmaz a nagyfelbontású dokumentumok újrarajzolásának gyorsításához. A gyorsítótárba helyezett képadatok legfeljebb nyolc szintjét adhatja meg, és négy rendelkezésre álló gyorsítótármozaik-méret közül választhat.

A gyorsítótárazási szintek növelése javítja a Photoshop reakcióidejét munka közben, de a képek betöltése hosszabb ideig tarthat. A gyorsítótár mozaikmérete határozza meg a Photoshop által egyszerre feldolgozott adatmennyiséget. A nagyobb mozaikméret felgyorsítja a komplex műveletek, például élesítő szűrők végrehajtását. A kisebb módosítások, például az ecsetvonások jobban reagálnak kisebb mozaikméretek esetén.

Gyorsítótár-előbeállítások

Három gyorsítótár-előbeállítás érhető el a Teljesítménybeállítások között. Válassza ki azt, amely megfelel annak, amilyen helyzetekben/célra Ön elsődlegesen használja a Photoshopot:

  • Web/felhasználói felület tervezése: Válassza ezt az opciót, ha a Photoshopot elsősorban webes tervezéshez, alkalmazások vagy képernyők tervezéséhez használja. Ez az opció számos alacsony-közepes képpontméretű rétegből álló dokumentumokhoz a legalkalmasabb.
  • Alapértelmezett/Fotók: Válassza ezt a lehetőséget, ha a Photoshopot elsősorban közepes méretű képek retusálásához vagy szerkesztéséhez használja. Például használja ezt a beállítást, ha normál esetben a mobilról vagy digitális fényképezőgépről származó fényképeket szerkeszt a Photoshopban.
  • Hatalmas pixelméretek: Válassza ezt az opciót, ha sokat dolgozik a Photoshopban nagy méretű dokumentumokkal; például panorámákkal, festményekkel stb.

Gyorsítótárak szintje

A folyamat alaposabb kézben tartása érdekében a gyorsítótárazási szintek manuálisan is beállíthatók (az alapértelmezett érték 4).

  • Ha viszonylag kis fájlokat – durván 1 megapixeles vagy 1 280 × 1 024 pixeles fájlokat és sok réteget (50-et vagy annál többet) használ, 1-re vagy 2-re állítsa a Gyorsítótárazási szinteket. Ha 1-re állítja a Gyorsítótárazási szintet, letiltja a kép gyorsítótárazást; csak az aktuális képernyő gyorsítótárazása történik meg.
  • Ha nagyobb pixelméretű – mondjuk 50 megapixel vagy annál nagyobb – fájlokat használ, állítsa 4-nél nagyobbra a Gyorsítótárazási szinteket. A magasabb gyorsítótárazási szintek felgyorsítják az átrajzolást.
Megjegyzés:

Egyes Photoshop funkcióknál előfordulhat, hogy nem ér el kiváló minőségű eredményt, ha 1-re állítja a Gyorsítótár szinteket.

Előzményállapotok korlátozása

Átmeneti tároló helyet takaríthat meg és növelheti a teljesítményt, ha korlátozza vagy csökkenti azoknak az előzmény állapotoknak a számát, amit a Photoshop az Előzmények panelben ment. A megtakarított lemezhely attól függően változik, hogy a művelet hány pixelt változtat meg. Például a kis ecsetvonáson vagy nem romboló műveleten, így a módosító réteg létrehozásán vagy módosításán alapuló előzmény állapot kevés helyet igényel. Ugyanakkor, ha teljes képen alkalmaz szűrőt, sokkal több helyet használ fel.

A Photoshop akár 1000 előzményállapotot menthet. Az alapértelmezett szám 50.

Ennek a számnak a csökkentéséhez lépjen a Teljesítménybeállítások párbeszédablakba. Az Előzmények és gyorsítótár
részben állítsa az Előzményállapotok beállítást kisebb értékre.

Grafikus processzor (GPU) beállításainak módosítása

Legjobban úgy optimalizálhatja a GPU-gyorsítást, ami a képernyő átrajzolását gyorsítja fel, ha mindig frissíti a videoillesztő illesztőprogramját.  A videoillesztők frissítésére vonatkozó utasítások

Lásd: A grafikus illesztőprogram frissítése.

További információk arról, hogyan használja a Photoshop a grafikus processzort, a tesztelt kártyákról és a grafikus processzor és a kijelző minimális követelményeiről. 

Lásd: A GPU-ra és videokártyára vonatkozó gyakori Photoshop-kérdések.

A grafikus processzor beállításai

A Photoshop dedikált grafikusprocesszor-beállításokat biztosít a Beállítások párbeszédpanel Teljesítmény és 3D szakaszában egyaránt.

A Beállítások > Teljesítmény rész beállításai

Ha van grafikus kártya a számítógépében, a neve és a típusa megjelenik a Teljesítmény szakasz A grafikus processzor beállításai területén, az Észlelt grafikus processzor felirat alatt.

  • Ha a grafikus kártya valóban támogatott, a Grafikus processzor használata jelölőnégyzet alapértelmezés szerint engedélyezett, és be van jelölve.
  • Ha a grafikus kártya nem támogatott, a jelölőnégyzet alapértelmezés szerint ki van szürkítve, és nincs bejelölve.
  • Ha a grafikus kártya valóban támogatott, és a „Grafikus processzor használata” jelölőnégyzet nincs bejelölve, annak valószínűleg az az oka, hogy a Photoshop hibás grafikus illesztőprogram vagy konfiguráció által okozott összeomlást észlelt. Lásd: A Photoshop grafikus processzorral (GPU) és grafikus illesztőprogramokkal kapcsolatos problémáinak hibaelhárítása.

További speciális beállítások:

  • OpenCL használata: Ha az Életlenítési galéria, az Intelligens élesítés, a Fókuszterület kijelölése vagy a Képméret a részletek megtartásával funkció nem a vártnak megfelelően működik, kapcsolja ki ezt a beállítást.
  • Segédvonalak és görbék élsimítása Tiltsa le, ha a segédvonalak és a görbék túl erősek vagy túl vastagok
  • 30 bites megjelenítés: Az engedélyezésével növelheti a színhűséget a 30 bitet támogató monitorokon.
Az Open CL letiltása

Megjegyzés:

Az OpenCL bekapcsolása nagy eséllyel javítja a teljesítményt, ha ezeket a Photoshop-funkciókat használja:

  • Életlenítés galéria - Mező életlenítése, Írisz életlenítése, Tilt-Shift, Path Blur, Spin Blur (gyorsított OpenCL)
  • Smart Sharpen (Zajcsökkentés – gyorsított OpenCL)
  • Kiválasztás és maszkolás (OpenCL-gyorsítással)

A Beállítások > 3D rész beállításai

A Teljesítmény párbeszédablak 3D részében a Teljesítmény részben lévő memóriavezérlőhöz hasonló VRAM csúszka található. A csúszkával határozza meg a Photoshop 3D-motorjához elérhető video-RAM (VRAM) felső határát. A teljes érték a rendelkezésre álló teljes VRAM százalékos része. A 100%-os beállítás továbbra is fenntartja a teljes VRAM egy részét az operációs rendszer részére. A magasabb értékek jobb általános 3D-teljesítményt biztosítanak, de ez más GPU-kompatibilis alkalmazások rovására történhet.

3D: Memória-felhasználás

Munkalemezek kezelése

Megjegyzés:

Ha a Photoshop azért nem indítható el, mert a munkalemez megtelt, indítás alatt tartsa lenyomva a Cmd+Option (macOS) vagy a Ctrl + Alt (Windows) billentyűket, hogy új munkalemezt állíthasson be.

A munkalemez a Photoshop futása közben ideiglenes tárolásra használt merevlemez-meghajtó vagy SSD. A Photoshop ezen a területen tárolja a dokumentumok azon részeit és előzménypaneljeik azon állapotadatait, amelyek nem férnek el a számítógép (RAM) memóriájában. 

További tudnivalók a munkalemez beállításainak kezeléséről, az ajánlott beállításokról és a hibaelhárításról: Munkalemezek beállítása.

További tudnivalók a munkalemez hibáinak elhárításáról: Munkalemezzel kapcsolatos hibák elhárítása a Photoshopban.

A hatékonyságindikátor

A Hatékonyság jelző figyelésével követheti nyomon a teljesítményt, miközben Photoshopban dolgozik.Kattintson a lenyíló menüre a képablak alján, és válassza a lenyíló menüből a Hatékonyság lehetőséget.

Ha a jelző értéke 100% alatt van, a Photoshop az összes elérhető RAM-ot használta, és az átmeneti tárolót alkalmazza, ami lassítja a teljesítményt. Ha a hatékonyság 90%-nál kevesebb, rendeljen több RAM-ot a Photoshophoz a Teljesítmény beállításokban. Vagy adjon hozzá további RAM-ot rendszeréhez.

A hatékonyságindikátor

A Photoshop funkcióinak finombeállítása a teljesítmény növeléséhez

Vonalzók és átfedések letiltása

A látható vonalzók és az átfedések (például rácsok, szeletek és intelligens segédvonalak) lelassíthatnak bizonyos műveleteket a vásznon, például a festést, az átalakítást és a rétegek húzását.

  • A vonalzók letiltásához a Nézet menüben törölje a Vonalzók elem jelölését.
  • Az átfedések letiltásához lépjen a Nézet > Megjelenítés menühöz, válassza az Egyik sem lehetőséget, vagy tiltsa le a különféle elemeket.

Lásd: Nyomtatásban meg nem jelenő extrák megjelenítése és elrejtése.

Munkavégzés fájlméret korlátozásokon belül

A nagyon nagy fájlok gyakran okoznak teljesítményproblémákat.

A Photoshop 300 000 × 300 000 képpontos maximális fájlméretet támogat a PDF-fájlok kivételével, amelyek 30 000 × 30 000 képpontra és 200 × 200 hüvelykre korlátozottak, a Camera Raw pedig a legfeljebb 65 000 képpont hosszú vagy széles és legfeljebb 512 megapixeles képeket támogatja.

Kezelhető fájlméret Photoshopnál:

  • PSD fájlok: 2 GB
  • TIFF fájlok: 4 GB
  • PSB fájlok: 4 exabájt (4 096 petabájt vagy 4 millió terabájt)
  • PDF fájlok: 10 GB (az oldalak 200 hüvelyk maximális méretre vannak korlátozva)

Zárja be a szükségtelen dokumentum ablakokat

Ha „RAM hiány” üzenetet kap, vagy ha a Photoshop működése lassú, azt túl sok megnyitott kép okozhatja. Ha több ablak van nyitva, próbáljon meg néhányat bezárni.

Készletek számának csökkentése

A Photoshop által használt átmeneti tárolóhely csökkentéséhez csökkentse minimálisra a betöltött készletek számát. A minták és az ecsethegyek a legnagyobb készletek egyike. Mentse rögtön a nem szükséges készleteket egy fájlban, majd távolítsa el őket, és csak akkor töltse be őket, amikor szüksége van rájuk.

Ha többet szeretne megtudni a készletek kezeléséről, lásd: Készletek.

Csökkentse minimálisra vagy kapcsolja ki a panel nyomtatási nézet bélyegképeket

Valahányszor megváltoztat egy dokumentumot, a Photoshop frissíti a Rétegek és Csatornák panelekben látható összes bélyegképet. Ez a frissítés befolyásolhatja a válaszképességet, amikor gyorsan fest, helyez át vagy mozgat el finoman rétegeket. Minél több bélyegkép látható, annál nagyobb a hatás.

Ezeknek a bélyegkép nyomtatási nézeteknek a minimálisra csökkentéséhez vagy letiltásához kattintson a Panel menüre, és válassza ki a Panel opciók lehetőséget. Válasszon egy kisebb bélyegkép méretet vagy válassza az Egyik sem lehetőséget, és kattintson az OK lehetőségre.

Fájl kompatibilitási opciók változtatása

Ha nem kell PSD- és PSB-fájljaival dolgoznia a Photoshop régebbi változataiban vagy olyan alkalmazásokban, amelyek nem támogatnak rétegeket, kikapcsolhat egy fájlkompatibilitási funkciót a dokumentum mentésének felgyorsításához:

  1. A Beállítások > Fájlkezelés menüben a 16 bites és 32 bites PSD és PSB dokumentumokhoz válassza a PSD- és PSB-fájlok tömörítésének letiltása lehetőséget.

  2. A PSD és PSB fájl-kompatibilitás maximalizálása menüben válassza ki a Kérés vagy Soha lehetőségeket.

Munkavégzés 8-bites képmódban

A Photoshop számos műveletet képes elvégezni 16 bites és 32 bites képeken. Ezek a képek azonban további memóriát, átmeneti tárolóhelyet és időt igényelnek a feldolgozáshoz, mint a 8 bites képek.

Ha a képet 8 bitesre szeretné konvertálni csatornánként, válassza a Kép > Üzemmód > 8 bit/csatorna lehetőséget.

További tudnivalókért lásd: Bitmélység és beállítások.

Megjegyzés:

Ha csatornánként 8 bitre konvertál, azzal törli az adatokat a képből. Mentsen egy másolatot az eredeti 16 bites vagy 32 bites képről, mielőtt csatornánként 8 bitre konvertál.

A betűtípus nyomtatási nézetének kikapcsolása

A Photoshopban a betűkészlet-feldolgozás felgyorsításához kapcsolja ki a betűkészlet nyomtatási előnézet listát a Típus > Betűkészlet nyomtatási előnézet mérete > Egyik sem lehetőség kiválasztásával.

Képfelbontás csökkentése

Minél nagyobb a képfelbontás, annál nagyobb memóriára és lemezhelyre van szüksége a Photoshopnak a képek megjelenítéséhez, feldolgozásához és nyomtatásához. A végleges teljesítménytől függően a nagyobb képfelbontás nem szükségszerűen ad jobb végleges képminőséget, de lelassíthatja a teljesítményt, további átmeneti tárolóhelyet használhat fel, és lassíthatja a nyomtatást.A képek optimális felbontása függ attól, hogyan történik a képek megjelenítése és nyomtatása. 

A képernyőn bemutatott képekhez figyelembe kell venni a teljes pixelméreteket. A kép méreteinek csökkentéséhez válassza a Kép > Képméret lehetőséget. A Képméret párbeszédkeretben ügyeljen arra, hogy az Újraméretezés opció legyen kiválasztva. Adjon meg egy új értéket a Szélesség vagy Magasság méretekhez (ha az egyiknél ad meg értéket, mindkettő változik).

Ha nyomtatott képeknél a felbontást kb. 360 DPI-nál nagyobbra növeli, annak a legtöbb esetben kevés előnye van vagy nincs előnye. Ha sok nyomtatást készít, próbálgatással találja meg azt a felbontást, ami a legjobb eredményt adja. A képfelbontás csökkentéséhez válassza a Kép > Képméret lehetőséget. A Képméret párbeszédkeretben válassza ki az Újraméretezés lehetőséget. Módosítsa a Szélesség és Magasság értékeket a nyomtatott dokumentum fizikai méretének megfelelően. Ezután csökkentse a Felbontás értéket, és kattintson az OK lehetőségre.

Amennyiben inkább növelni szeretné a képfelbontást csökkentés helyett, egyik utolsó lépésként növelje a felbontást a kép nyomtatása előtt. Ilyen módon nem kell az összes ilyen többletinformációt kezdeti lépésekben feldolgozni.

Tiszta memória

A rendszerteljesítményt úgy javíthatja, ha nem használt memóriát és átmeneti tárolóhelyet szabadít fel a Photoshopból, hogy más programok számára elérhető legyen. Ehhez válasszon az alábbi opciók közül:

  • Szerkesztés > Végleges törlés > Összes
  • Szerkesztés > Végleges törlés > Visszavonás
  • Nyomja le az Option (macOS) vagy az Alt (Windows) gombot, és válassza A Photoshop névjegye lehetőséget

Amennyiben más programok aktívan próbálják a memóriát kiosztani vagy használni, a Photoshopban végzett memória-felszabadítás javítja a teljesítményt. Az átmeneti tárolóhely felszabadítása kedvező, ha elfogy a lemezhely. Ha jelentős memóriát vagy lemezhelyet szabadít fel, a Photoshop lassúbb lesz, amikor legközelebb nagyméretű fájlokat nyit meg, miközben a Photoshop helyet oszt ki.

Ha azt szeretné, hogy a Photoshop mindig kevesebb memóriát használjon, akkor válassza a Szerkesztés > Beállítások > Teljesítmény (Windows) vagy a Photoshop > Beállítások > Teljesítmény (macOS) lehetőséget, és a Memóriahasználat csúszkáját húzza el balra.

Lásd a Memóriahasználat módosítása részt.

Megjegyzés:

Eltarthat néhány percig, amíg a tevékenységfigyelők, feladatkezelők és lemez-segédprogramok regisztrálják a módosítást. Lényegében egyes segédprogramoknál szükség lehet a frissítés kifejezett kérésére.

A vágólap tisztítása

A vágólap tartalma gyakran nagyméretű, ha nagy dokumentumokon belül másol és illeszt be adatokat. Az ilyen tartalmaknak kevés hasznuk van, amikor végzett a beillesztéssel. A vágólapon a képadatok által használt RAM felszabadításához válassza a Szerkesztés > Tisztítás > Vágólap lehetőségeket.

Megjegyzés:

A Tisztítás parancs nem vonható vissza.

A Szűrőgaléria használata

A Szűrőgaléria egy vagy több szűrő tesztelését teszi lehetővé a képen az effektusok használata előtt, ami jelentős időt és memóriát takaríthat meg.

Lásd: Szűrőgaléria áttekintése.

Másolás és beillesztés helyett inkább húzza át a fájlokat

A rétegek vagy fájlok áthúzása hatékonyabb, mint a másolásuk és beillesztésük. Az áthúzás megkerüli a vágólapot, és közvetlenül helyezi át az adatokat. A másolás és beillesztés potenciálisan több adatátvitellel járhat, és sokkal kevésbé hatékony.

TIFF-fájlok mentése ZIP-tömörítés nélkül

Ne válasszon ki ZIP tömörítést, ha nagyobb sebességre van szüksége a TIFF fájlok exportálásakor. (Ugyanakkor a ZIP tömörítés adja a legkisebb TIFF fájlokat.)

Ne exportálja a vágólapot

A Vágólap exportálása esetén a Photoshop más programok számára teszi elérhetővé a vágólap tartalmát. Ha nagyméretű adatokat másol Photoshopban, de nem illeszti be más alkalmazásokba, ennek az opciónak a kikapcsolásával takarítson meg időt:

  1. Válassza a Photoshop > Beállítások > Általános (macOS) vagy Szerkesztés > Beállítások > Általános (Windows) lehetőséget.

  2. Törölje a Vágólap exportálása négyzet jelölését.

  3. Kattintson az OK gombra.

Tiltsa le a Könyvtárak panelt

  1. A Könyvtárak úszó menüből válassza a Bezárás lehetőséget.

  2. Indítsa újra a Photoshopot.

Tiltsa le a Generátort.

  1. Válassza a Szerkesztés > Beállítások > Bővítmények lehetőséget.

  2. Törölje a jelölést a Generátor engedélyezése jelölőnégyzetből.

  3. Kattintson az OK gombra.

Kompozitálás a Photoshopban

A kompozitálás az a folyamat, melynek során több vizuális elemet egyesítünk egyetlen képpé. A Photoshop belső kompozitora a program használata közben több ezer újraszámítást végez, hogy valós időben, egyetlen kompozitként jelenítse meg a képen végrehajtott összes változtatást.

Többszálas kompozitálás

A Photoshop 2022. áprilisi kiadásától (22.3-as verziójától) kezdve a Beállítások > Teljesítmény szakasz Többszálas kompozitálás jelölőnégyzetének bejelölésével bekapcsolható a többszálas kompozitálás. Ennek a módosításnak az érvénybe léptetéséhez nem kell újraindítani a Photoshopot. 

Többszálas kompozitálás

A korrekciós rétegek, a rétegmaszkok, a keverési módok, a szűrők, a stílusok és az effektek mind-mind bonyolultabbá teszik a dokumentum feldolgozását, ez pedig lassíthatja a feldolgozást a Photoshopban. Észreveheti például, hogy a különféle csúszkák átállításakor lassabban frissül a képernyő, mint az említett rétegek és effektek hozzáadása előtt. A többszálas kompozitálás azzal gyorsítja a processzorra és a grafikus processzorra épülő kompozitálási feladatokat, hogy párhuzamosan futtatható kisebb részekre osztja a számítási tevékenységet, és ezek a részek sok esetben gyorsabban futnak, mint amilyen gyorsan ki lehetne őket számítani egyetlen szálban.

Noha számos oka van annak, hogy a Photoshopban szerkesztésre megnyitott dokumentumok bizonyos esetekben lassabban reagálnak, a kompozitálás 100–250%-kal történő, többszálas kompozitáláson keresztüli gyorsítása jelentős mértékben hozzájárul ahhoz, hogy a Photoshop az igényeknek megfelelő gyorsasággal és zökkenőmentességgel működjön.

Ha újrarajzolási hibákat tapasztal, és azt gyanítja, hogy a többszálas kompozitálás okozza a problémát, a Beállítások > Teljesítmény szakaszban kikapcsolhatja ezt a funkciót. Amennyiben kérdést szeretne feltenni, vagy visszajelzést kíván küldeni az ezzel a beállítással kapcsolatos hibáról, várjuk jelentkezését az Adobe Photoshop-közösségben. Örülnénk a véleményének!

Megjegyzés:

A többszálas kompozitálás felváltotta a régebbi kompozitálási funkció eltávolításával kapcsolatos korábbi figyelmeztetést. Már nincs szükség a régebbi kompozitálási megoldásra, ezért el is távolítottuk.

GPU-gyorsítású kompozitálás

A Photoshop 22.3 2022. áprilisi kiadásától kezdve a Photoshopban elérhetővé vált a grafikus processzor (GPU) használatával végzett kompozitálás, amellyel javítható a dokumentumon végzett bizonyos rétegműveletek válaszideje. A grafikus processzor használatával végzett kompozitálás csak akkor lehetséges, ha a Photoshop az indításakor rendben észleli a grafikus processzort. Erről úgy tud meggyőződni, hogy a Beállítások > Teljesítmény lehetőséget választja, és ellenőrzi, hogy látja-e a grafikus processzor nevét a Grafikus processzor beállításai szakaszban, valamint hogy be van-e jelölve a Grafikus processzor használata jelölőnégyzet.

A Speciális beállítások gombra kattintva megkeresheti a grafikus processzorral végzett kompozitálást be- vagy kikapcsoló jelölőnégyzetet. 

Kompozitálás grafikus processzor (GPU) használatával

A kisebb, kevésbé összetett, kevés réteget és rétegalapú korrekciót (pl. keverési módot vagy korrekciós réteget) tartalmazó dokumentumok esetében előfordulhat, hogy nem észlel teljesítménycsökkenést a keverési módok vagy a rétegek láthatóságának be- vagy kikapcsolásakor. A dokumentumok összetettségének és méretének növekedésével azonban a Photoshop kompozitorának egyre több valós idejű feldolgozást kell végeznie, és az eredmények képernyőn való megjelenítése így hosszabb időbe telhet. A nagyon összetett dokumentumok esetében már tapasztalhatta, hogy egy réteg tartalmának mozgatása vagy az opacitás megváltoztatása esetén valamivel tovább tart a képernyő frissítése és az eredmény megjelenítése. Ha a grafikus processzor segítségével végzett kompozitálás engedélyezve van, a Photoshop a GPU számítási teljesítményének nagyobb részét használja fel a kompozitálás felgyorsítása és a gördülékenyebb szerkesztési élmény biztosítása érdekében.

Ha a rétegalapú szerkesztés során problémát tapasztal, megpróbálhatja kikapcsolni a GPU-alapú kompozitálást, hogy elhárítsa a hibát. 

Adobe logó

Bejelentkezés a fiókba