Overview

New Media Management features in both Premiere Pro and Adobe Media Encoder give you much greater control over the handling of your files during the ingest process, and allow more flexibility when working with large media files. You can set Premiere Pro to copy media to a specific location on your machine as it imports, and even begin editing immediately while your media copies in the background. If your workflow requires a transcode, you can easily set Premiere Pro or Adobe Media Encoder to handle that step for you too.

This release of Premiere Pro also brings support for more native formats than ever including 6K and 8K files from the RED Weapon camera. For times when the media you work with is more demanding on your computer system than it can manage. For example, when you want to work on a lightweight portable device, you can now generate proxies on ingest, automatically associating them with the native full-resolution media. A single click lets you toggle between full-res and proxy clips.

Ingest Settings & Media Browser

The Premiere Pro Media Browser panel allows you to ingest media automatically in the background while you begin editing. 

An ingest check box in the Media Browser panel toggles on/off the automatic ingest behavior. A settings button next to it opens the Project Settings dialog box, where you can adjust the ingest settings. A similar ingest check box in the Project Settings dialog box is kept in sync with the Media Browser panel’s setting. When toggled on, you can choose one of four following operations to begin automatically when files are imported into the project. You can continue to edit while the ingest process completes in the background.

Copy 

You can copy the media as it is to a new location. For example, this option is typically used to transfer camera footage from removable media onto your local hard drive. The transfer path is specified by the Primary Destination option available in Ingest Settings. After the media is copied, the clips in the project point to these copies of the files.

Transcode 

You can transcode the media to a new format in a new location. For example, this option is typically used to transcode original camera footage to a specific format used within a post-production facility. The file path is specified by the Primary Destination option in Settings, and the format is specified by the chosen preset. After the media has been transcoded, the clips in the project point to these transcoded copies of the files. 

Create Proxies 

Use this option to create and attach proxies to the media. For example, this option is used to create lower-resolution clips for increased performance during editing, which can be switched back to the original full resolution files for final output. The file path where the proxies are generated is specified by the Proxy Destination option in the settings, and the format is specified by the chosen preset. After proxies have been generated, they are automatically attached to the clips in the project.

Copy and Create Proxies 

This option copies media and creates proxies for them as well, as specified above. 

Import preset support

All four options come with a set of default presets, which have the file destinations set to 'Same as Project'. Alternatively, you can also choose a custom destination or your Creative Cloud Files folder, which syncs the files automatically to the cloud. You can also create your own 'Ingest' presets using Adobe Media Encoder.

Summary info

The summary gives detailed information on destination path, preset used, and preset details.

Specific tips & workflow

  • The supplied proxy presets are compatible with sources of certain standard frames sizes. Refer to the summary section of the Ingest Settings dialog box to see the compatible source frame sizes.  For sources with other frame sizes, create your own ingest preset that has evenly divisible frame dimensions. For example, with 4K 3840x2160 source clips you would have to create an ingest preset that renders to a 960x540 frame size in Adobe Media Encoder, then import that ingest preset into the Premiere Pro Ingest Settings dialog box. See the section below that describes how to create your own ingest preset. 
  • When creating an ingest preset in Adobe Media Encoder, marking the frame size and frame rate as "Match Source" is categorized as a Transcode preset. If either the frame size or the frame rate is not marked as Match Source, then the preset is categorized as a Proxy preset for generating proxies. 
  • Make sure that source camera folder structures are placed inside a uniquely named parent folder when copying these sources using ingest settings. If ingesting (copying) directly from a camera card that does not permit having a uniquely named parent folder, make sure to designate a unique destination folder for each camera card. Failing to follow these guidelines results in conflicts while copying camera folder structure media to the destination thereby causing ingest failures or overwriting files (resulting in data loss).
  • During a Copy and Create Proxies operation, the proxy files are generated from the source high-res media (not the copied media) therefore make sure to monitor the progress panel for completion of both the copy and the proxy jobs before disconnecting the source media from the system. All ingest operations are paused during playing back.

Create an Ingest Preset

You can create and use custom preset for Ingest and Proxy workflow. Ingest and Proxy works only with Ingest presets created in Adobe Media Encoder 2015.3.

How to create a new Ingest preset

1.  Launch Adobe Media Encoder and create a new Adobe Media Encoder preset with the desired output settings, such as video codec and frame size.  This step is optional and is used if you have a specific format and output settings that are not covered in the built-in Adobe Media Encoder presets.  Audio settings in Adobe Media Encoder presets are ignored when transcoding or creating proxies via ingest.

2.  In the Preset Browser in Adobe Media Encoder, click the plus sign (+) and select Create Ingest Preset, or select Preset > Create Ingest Preset.  This step opens the Ingest Preset Settings dialog box.

3. Under Preset Name, name your preset. Under Comments, add any other information you desire.

4. To copy ingested footage to a new location on disk (or move a file from external media to the local hard disk), enable the Transfer option.  Then, select a location for new files to be placed under the Destination drop-down menu.  You can choose to verify the copied file by enabling Verify and selecting the verification type in the verify dropdown menu.

NOTE:  If Copy is enabled in the ingest preset, the preset becomes available in Premiere Pro’s Ingest Settings dialog under the Copy and Copy and Create Proxies options, it is not available in the Transcode and Create Proxies options.

5. To transcode or create proxies when ingesting footage into a Premiere Pro project, enable the Transcode files to Destination option.  Then, select a location for new files to be placed under the Destination drop-down menu. You can then select the output type under the Format drop-down menu.  The list of available encoding presets appears under the Preset drop-down menu, including any custom encoder presets you have created.

NOTE:  If Transcode files to Destination is enabled in the ingest preset, the preset becomes available in Premiere Pro’s Ingest Settings dialog box under the Transcode and Create Proxies options, it is not available in the Copy and Copy and Create Proxies options.

6. When you are finished with all sections of the Ingest Presets dialog box, press OK to save it in Adobe Media Encoder.

7.  To use your newly created Ingest Preset in Premiere Pro’s Ingest Setting or Create Proxies dialog box, export the preset from Adobe Media Encoder to disk.  To do this, right click (WIN) or Ctrl-click (Mac OS) the desired preset in the Adobe Media Encoder Preset Browser, and select Export Preset. Select a location on disk for the .epr file.  You can also select a preset in the Adobe Media Encoder Preset Browser and select Preset > Export.

To use File Metadata and File Rename

You can add file metadata to files that are being transcoded or to new proxies, and you can rename files on ingest when copying or transcoding (the filename of proxies is always inherited from the source file). Rename does not work with camera format files (for example, P2 folder structures).

Adding File Metadata

1. When creating an ingest preset, enable the Add File Metadata by clicking the check box.  In the drop-down menu on the right, select New Preset. 

2. Click the + sign, and Metadata key and value pairs.  You can add more key and value pairs by clicking the plus sign (+).

3. When you are finished entering the pairs, press Save button to save the metadata preset.  A dialog box appears asking for a preset name. Enter the name and save.

The Add File Rename action

1. When creating an ingest preset, enable “Add File Rename” by clicking the check box.  In the drop-down menu on the right, select New Preset. 

2. Click the + sign, and select the type of rename action you would like to add.  You can add additional rename actions by clicking the plus (+) sign.

3. After adding rename actions, press save button to save the Raname preset.  A dialog box appears asking for a preset name, enter the name and save.

NOTE: File Metadata and File Rename are stored as presets on disk.  When moving an ingest preset to a new computer, the metadata and rename presets must be moved also. If the File Metadata and File Rename presets are not moved to the new computer, the ingest preset does not function correctly.  To do this:

a. Select the desired metadata or rename preset from the dropdown, then select the second dropdown to the right of the selection dropdown.

b. Choose the Save As command and save the File Metadata or File Rename preset to a new location on disk.

c. On the new, secondary computer, open the Ingest Preset Setting dialog, and select the File Metadata or File Rename drop-down menu and select Import Preset.

Create Proxies

You can create proxies directly from items in the project panel. Choose Create Proxis from the project panel context menu to open the Create Proxies dialog. The menu item is enabled when one or more items in the panel are selected that can be proxied. Premiere Pro can create proxies for master clip project items if they have video, have no captions, and are not growing files. The media must also be online.

In the Create Proxies dialog you can choose one of several built-in presets to use when transcoding high-resolution originals to create proxies. You can also add presets created in Adobe Media Encoder by clicking the Add Ingest Preset button. You can also choose to create proxies in a "Proxies" directory next to the original media, or in a custom location.

Create proxies
Create proxies

When you click OK in the Create Proxies dialog box, Premiere Pro presents a progress dialog box while it prepares proxy creation jobs to send to Adobe Media Encoder. If you press Cancel, the process is aborted and no changes are made to the project.

Dialog box
Dialog box

If you allow the progress dialog box to complete, a proxy job is created in Adobe Media Encoder for each of the project items chosen that can be proxied, and an offline proxy is attached to each project item. You can monitor the progress of these jobs in the Premiere Pro Progress panel, or in Adobe Media Encoder.

Proxy job in Adobe Media Encoder
Proxy job in Adobe Media Encoder

Queue
Queue

While the jobs are processed, you can continue to work with the corresponding high-resolution project items in Premiere Pro. When the proxy jobs complete, Premiere Pro automatically switches to displaying the proxy video in the Timeline if Enable Proxies is enabled in the Media preferences panel.

Premiere Pro does not need to remain open while proxy jobs are processed in Adobe Media Encoder. If you quit Premiere Pro before all jobs are complete, any proxies created while Premiere Pro is not running are attached when Premiere Pro is launched and the document is reopened.

Progress panel & dialog

Ingest and Create Proxies

When transcoding or creating proxies, the rendering in Adobe Media Encoder are displayed in the progress panel.  To see the dialog, choose Window > Progress…”  You see separate entries for Proxy job status and for Ingest job status. Status can be Waiting..., Complete, In Progress (or a progress bar), Canceled, and an error message if the job failed.

When creating proxies from existing files in the Project Panel, you can cancel the entire operation while the “Creating Proxy Jobs” dialog is open.

NOTE:  When transcoding or creating proxies in Adobe Media Encoder, you can pause and restart the render queue, without canceling the connection to Premiere Pro, allowing automatic attachment of proxies to continue to occur between Premiere Pro and Adobe Media Encoder.  If you stop the render queue in Adobe Media Encoder, any connection between proxies and original files are lost, and no automatic proxy attachment takes place.  If the queue in Adobe Media Encoder is stopped, you must recreate all transcode or proxy jobs.

Attach Proxies, Reconnect Full Resolution Media & Toggle/Enable Proxies

These two options are used for manual attachment of Proxy or Full Res media. These options are useful if you create proxy media outside of the Create Proxies workflow (for example, media created via third party software, hardware, or a combination of both) or you want to reattach Proxy or Full Res media to Offline clips. The supported workflow allows attachment of Proxies with other frame sizes & PAR (pixel aspect ratio) combinations that are divisible by the Full Res clip (for example, 1920x1080 1.0 PAR Full Res and 960x540 1.0 PAR Proxy or 1440x1080 1.33 PAR Proxy), but other parameters such as fielding, frame rate, duration, and audio channels must match. Mismatched audio channels results in warning dialogs and are not allowed, but other mismatched video parameters are not blocked and results in issues.

Media support: Attach Proxies and Full Resolution Media options are available for video-only, A/V, and Offline clips in the Project panel. Other file types (for example, audio-only, stills, image sequences) are not supported. Right-click (WIN) or Ctrl-click (Mac OS) your clips in the Project panel and choose Proxy > Attach Proxies or Reconnect Full Resolution Media. You can also assign shortcuts for each option in the Keyboard Shortcuts dialog box.

  • Attach Proxies launches the Attach Proxies dialog box that is similar to the Link Media dialog box. You can choose between Media Browser or OS dialog boxes to attach your Proxy clip to your Full Res clips in the Project panel. Attach Proxies also has an Undo command.
  • Reconnect Full Resolution Media launches the Reconnect Full Resolution Media dialog box, which is identical to the Attach Proxies dialog, except that it attaches Full Res clips. When using this option, the selected clip moves into the Proxy position and the clip you select in the Reconnect Full Resolution dialog becomes the new Full Res clip. If a Proxy was already attached to your clip, then it keeps the Proxy clip and only the Full Res portion is replaced. Reconnect Full Resolution cannot be undone, but you can use Reconnect Full Resolution Media to attach another clip.

Note: Attach Proxies and Reconnect Full Res Media options is always be enabled for supported clips. If you decide you want to change the Full Res or Proxy of a clip, you can choose either option again and attach a different clip.

Enable/Toggle Proxies: To view Proxy or Full Res, simply use the Toggle Proxies button in the Source Monitor or Program Monitor. This button is available in the Button Editor (the plus sign (+) in the lower right of either Monitor), that you can add in the transport controls area. This setting is a global machine Preference, so it can also be set via Preferences > Media > Enable proxies. These buttons and Preference are linked, so setting it one place sets it in the others. The Toggle/Enable Proxies preference applies to all Projects created on that system. If you move the Project to another system, the preference is determined by what was set on that system, not the Project. When set, the button turns blue which indicates that you are viewing Proxy in the Source and Program Monitors. You can also set a shortcut for Toggle Proxies in Keyboard Shortcuts.

Note: Other panels do not automatically update thumbnails based upon the Toggle/Enable Proxies state. This can result in thumbnails not following the Toggle/Enable Proxies setting, but that does alleviate certain performance issues.

Proxy column: In the Project and Metadata Panels, there is an option in Metadata Display > Premiere Pro Project Metadata for Proxy column. Click the check box and a Proxy column is added to the panel in List View. The column is blank if no Proxy is attached, it lists as Attached if a Proxy is attached to a clip, and it lists as Offline for an attached Proxy that is missing or Offline.

Note: The Metadata panel and Project panel columns only reports information for the Full Res clip. There are two places where you can view information of the Proxy clip: Properties and Info Panel.

Properties: When you get Properties on a clip with Proxy attached, the top portion contains information for the Full Res clip and below that lists information for the Proxy clip.

Info Panel: When Proxy is attached to an A/V clip, the Info panel lists the basic video and audio information below the Full Res clip info. The info panel does not report Proxy information for video only clips, though.

Note: All other areas of Premiere Pro only reports Full Res information.

Offline and relink/reattach: The Link Media dialog has not been updated to restrict functionality for Proxy. In the Link Media dialog, make sure to only relink to same files and avoid unsupported formats, and so on (the Attach dialog box restricts your choices to only supported formats). Depending on if Full Res or Proxy are Offline, you have slightly different options to relink or reattach.

  • Full Res: (clips went Offline while Project was closed) In process of opening the Project, you automatically receive the Link Media dialog which you use for relinking to Full Res clips. If you prefer to use the Reconnect Full Resolution Media dialog or keep Full Res Offline, you may click Offline All or Cancel. Once the Project is opened, you have options for Link Media and Reconnect Full Resolution Media in the context menu. If the Full Res clip goes offline while you are working in a Project, you are presented with the Link Media dialog box.
  • Proxy: (clips went Offline while Project was closed) In process of opening the Project, you automatically receive the Link Media dialog which you can use to relink your Proxy clips. If you prefer to use the Attach Proxies dialog or keep Proxies Offline, click Offline All or Cancel. If you want the option to Link Media upon opening the Project again, use the Cancel button. This is important because if you choose Offline or Offline All and Save your Project, the Link Media dialog box does not appear upon closing and reopening the Project. Once the Project is opened, you have an option for Attach Proxies only in a context menu (Link Media is dimmed for clips with only Proxies Offline). If a Proxy clip goes Offline while you are working in a Project, you are Link Media dialog box does not open. If you close and then reopen the Project, the Link Media dialog box launches. Note that the Link Media dialog box only presents the File Name and File Path column information for Proxies.

Note: If Proxies and Full Res are both Offline, when you are presented with the automatic Link Media dialog in process of opening a Project and you want to only relink certain clips, you can Shift or Command/Control click the desired clips in the Link Media dialog.

Known items & tips

• To easily monitor the Offline/Online status of clips, set the Project panel to List View and enable the Proxy column, moving it next to the existing Status column (reports status of Full Res). See screenshot below for an example.

• When you render Previews, Export Media or use certain Analysis effects (Warp Stabilizer, Rolling Shutter Repair, Morph Cut), Premiere Pro always uses and displays Full Res, regardless of the Toggle/Enable Proxies setting. The only exception is when you have Offline Full Res, but Proxy is Online, then Proxy is used.

• Note that certain combinations of resolutions and codecs may be of good enough quality to make it difficult to discern any visual differences between Proxy and Full Res clips. One tip is to create a custom preset with a watermark or some other visual indication. When you create your Adobe Media Encoder preset, choose the Effects tab and select from options such as Lumetri Look/LUT, Image Overlay or Name Overlay. This has an added benefit of helping protect your media.

• If you encounter any issues with Toggle/Enable Proxies not working or tool tips do not work, quit Premiere Pro and delete Preferences. You can also delete Preferences by pressing Shift + Option/Alt keys while launching Premiere Pro.

• The recommended Proxy workflow includes appending "_Proxy" to the name of your Proxy clips (for example, scene01_Proxy.mxf) and placing Proxy clips (on disk) in a folder named "Proxies" that is placed right next to the Full Res clips. This helps with reattachment of clips. The Create Proxies dialog's default destination setting takes care of both of these conditions. If you happen to set a custom destination, then you should add the Proxies folder to the destination. By default, any Create Proxies action automatically appends "_Proxies" to the clip name. 

• Full Res or Proxy clips with the same name (for example, C0001.mxf, C0001.mxf, C0001.mxf) or multiple versions of same name with appended number (for example, MyClip_Proxy.mxf, MyClip_1_Proxy.mxf, MyClip_2_Proxy.mxf) can cause some confusion with the Attach and Link Media dialogs when they are set to Relink others automatically. This can result in automatic attach or relink to the wrong clips. To avoid issues, you can deselect this option and attach or relink the affected clips one by one.

• The Proxy workflow is not supported for interchange options such as Project Manager, Render and Replace, AAF, Final Cut Pro XML, EDL, OMF, and so on. You lose Proxy attachment for these functions. After Effects and Audition interoperability functions are also not currently supported with the Proxy workflow.

• Modify > Audio Channels and Interpret Footage are also not supported for Proxy Workflows.

• Formats with Master Clip Effects Source Settings (for example, R3D, ARRI, DPX, and so on) are supported for Full Res clips. Master Clip Effects Source Settings formats are not supported to be used as Proxy clips, however. for example: R3D Full Res and H.264 Proxy is supported. R3D Full Res and DPX Proxy is not supported.

ProxyScreenshot5

1) Toggle Proxies button

2) Info Panel with Proxy video and audio information for the selected clip

3) Status column for Full Res status

4) Proxy column for Proxy status


This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy