An important post-production task is locating and managing your media clips and assets.

Premiere Pro provides several search options to help find you media files easily even in complex projects, making you spend less time on searching and more time on editing.

Search options in Premiere Pro

Find dialog

You can use the Find dialog in Premiere Pro to search for items in a project. You can specify the search criteria to be a single property or a combination of properties.

You cannot, however, save the searches that you perform using the Find dialog. That is, once you clear the search criteria, you lose the search results.

Search Bins

Premiere Pro provides Search Bins that offer powerful metadata searching capabilities. When you search for items in the Project Panel, you can associate a Search Bin with your search query. The search results stay up to date with items that meet the search criteria.

Search in Timeline

Timeline Search is an invaluable time saver that lets you manage complex Timelines more easily. You can find and select clips within a sequence based on specific search criteria.

Find assets using the Find dialog

The FInd dialog lets you perform both simple and detailed searches. You can locate any assets in your project that meet criteria you specify. For example, you can search for a video clip that has a certain word in its Name column and a phrase in its Comment column.

  1. Do one of the following:
    • Click the Find icon (magnifying glass) at the bottom of the Project panel.
    • Select the Project panel, and press Ctrl + F (Windows), or Command + F (Mac OS).
  2. In the Find dialog box, select the name of the columns to search from the menus under Column.
  3. Select the appropriate operators from the menus under Operator.
  4. Type in the characters you want to find in the specified columns in their respective Find What fields.
  5. If you’re searching for two criteria simultaneously, do one of the following:
    • To find assets that match both criteria, select All from the Match menu.
    • To find assets that match either criteria, select Any from the Match menu.

    Note:

    Select the Case Sensitive check box to perform a case-sensitive search.

  6. Click Find.

Find assets using Search Bins

You can create a Search Bin that displays a collection of project items matching your search criteria. Search Bins are updated automatically when importing assets, deleting assets, or modifying asset metadata.

Search Bins appear in the Project panel like other regular bins, and are denoted by the Search Bin icon .

Note:

Search Bins display aliases of the original project items and not copied media, so no media duplication occurs.

Create a Search Bin

  1. Do one of the following:

    • Select New Search Bin from the Project panel's pop-up menu or context menu.
    • Select File > New > Search Bin.
  2. In the Search Bin dialog, enter the search criteria in the Find field.

  3. In the Search Bin dialog, you can search across all the metadata used in your project or restrict your search to specific metadata properties.

Important notes about Search Bins

  • If a project item appearing in a Search Bin is deleted from the project. Or, if metadata is changed that causes an item to no longer match the Search Bin's search criteria, the item is removed from the Search Bin.
  • When you specify a single metadata property, the search is restricted only to clip metadata. When you select the following metadata properties, you can search across both clip and file metadata.
    • Name
    • Tape Name
    • Description
    • Comment
    • Log Note
    • Scene
    • Shot
    • Client

Save a search query as a Search Bin

To create a Search Bin from a search query, follow these steps.

  1. Enter your search query in the Search field of the project panel.

    Note:

    As you type each new letter in the search query, the search results update dynamically.

  2. Click the Search Bin icon next to the Search field.

The name of the Search Bin that is created matches the entered search query.

Searching in the Project panel
A. Type search query B. Click to create Search Bin from query C. Search Bin displaying assets matching search criteria 

Rename a Search Bin

To rename a Search Bin, right-click (Win) or Ctrl-click (Mac) the Search Bin, and select Rename. The new name that you enter does not change the search criteria of the Search Bin.

Revise the contents of a Search Bin

You cannot modify the contents of a Search Bin like other regular bins in the Project panel. You need to revise the search criteria of a Search Bin to change its contents.

  1. In the Project panel, select Edit Search Bin from the context menu of the Search Bin.
  2. In the Edit Search Bin dialog, revise the search criteria as required.
  3. Click OK after specifying the revised search criteria.

Delete a Search Bin

To delete a Search Bin, select the Search Bin to delete, and select Clear from the context menu. You can drag the Search Bin to the Trash icon , or simply press Delete on your keyboard.

Note:

Deleting a Search Bin deletes only the aliases of the project items and not the original project items.

Find assets using Timeline Search

Timeline Search provides you advanced search options that let you easily find and manage clips in complex Timelines.

With a Timeline panel active, select Edit > Find. Or use the keyboard shortcut Ctrl+F (Windows), or Command+F (Mac).

The Find dialog that appears is similar to the Project panel's Find dialog. You can find and select clips within a sequence based on a a single property, like clip name, marker name, or use a combination of properties.

  1. In the Find dialog box, select the name of the columns to search from and the appropriate operators.

  2. Type in the characters you want to find in the specified columns in their respective Find fields.

    Note:

    Select the Case Sensitive check box to perform a case-sensitive search.

  3. Click Find or press Enter on the keyboard. Premiere Pro selects and moves the playhead to the clip on the Timeline and closes the Find dialog.

  4. To find the next instance of clip matching the search criteria, select Edit > Find Next. The playhead moves to next clip in the Timeline matching the search criteria and selects it.

Find and select all clips in a sequence matching search criteria

  1. With the Timeline panel active for a selected sequence, select Edit > Find. Or use the keyboard shortcut Ctrl+F (Windows), or Command+F (Mac).
  2. Enter the search criteria.
  3. Press Find All.

Premiere Pro closes the Find Dialog, moves the playhead to the first matching clip, and selects all matching clips.

Find a sequence marker with text matching search criteria

  1. With the Timeline panel active for a selected sequence, select Edit > Find. Or use the keyboard shortcut Ctrl+F (Windows), or Command+F (Mac).
  2. Select Markers from the Search pop-up menu, and enter the search criteria in the Find field.
  3. Click Find or press Enter on the keyboard. Premiere Pro closes the Find dialog and moves the playhead to the first marker matching the search criteria.
  4. Select Edit > Find Next to move the playhead to the next marker matching the search criteria.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy