Productions offers you tools for organizing multi-project workflows, sharing assets between projects, and keeping everything streamlined and efficient, whether you’re working on your own or collaborating with a team.
Hero-Image

What is Productions?

Download

Productions provides a flexible, scalable framework for organizing multi-project workflows. With Productions, large complex workflows can be divided into manageable projects, for overall efficiency and collaboration using shared local storage. Assets can be shared between projects within a Production, without creating duplicate files. 

Individual editors can group related projects for improved organization and efficiency. Large projects (documentaries, films, TV) can be broken into reels or episodes where multiple editors collaborate according to their preferred workflow using shared storage network.

The established Premiere Pro project format forms the basic building block of Productions. Productions add an additional layer, linking the projects and assets within them. A project within a Production retain all the attributes of a .pproj file. You can add existing Premiere Pro projects into a Production. If needed, you can remove them to use as self-standing Premiere Pro projects.

What are the benefits of Productions?

Breaking-up-large-Projects

Manage multi-project workflows

When you have large or complex workflows, Productions allows you to divide them into smaller pieces, based on the existing Premiere Pro project format. Productions connects the projects, making them into components of the larger workflow, helping you to keep projects and assets organized and efficient.

Reuse-Files

Keep everything organized and synchronized

Media referencing across projects means you can reuse assets within your production without creating duplicates. This helps you keep individual projects light and fast.

The new Production panel in Premiere Pro provides a command center for managing multi-project workflows. Any projects you add to the Productions folder become part of the production. Whether you are working on macOS or Windows, any changes you make on disk are reflected in Premiere Pro; changes in Premiere Pro are applied on disk. Productions keeps everything in sync.

Collaboration

Designed for collaboration

Using shared local storage, multiple editors can work on different projects in the same production. Project Locking ensures that no one overwrites your work: your colleagues can still access your project and copy content from it, but they can’t make changes until you’ve completed your edit.

All projects in a Production share the same settings, including scratch disks. This means that preview files rendered by one editor can be available for all editors who use that project, ensuring smooth playback and time-saving for the whole team.

Avoid-Duplication

Security: you control your media

With Productions, you have full control of your content. Your projects and assets can live entirely on your local storage. Nothing is on the cloud unless you put it there. If needed, you can do all your work without an internet connection.

How to get started using productions

Before you get started using productions, consider the following points.

Decide your storage strategy

If you are an individual editor, you can save your project files anywhere, even on your local disk. 

If you plan to work with a team of editors, you need shared storage. Follow these best practices when configuring shared storage for productions. 

Set up your preferences

Set up the following preferences in the Edit > Preferences (Windows) or Premiere Pro > Preferences (macOS) dialog box.

  • In Preferences > Media, deselect the following options:
    • Write XMP ID to files on import
    • Write clip markers to XMP
    • Enable clip and XMP metadata linking
  • In Preferences > Collaboration:
    • Make sure that Enable project locking is checked
    • Enter a User Name that others will see when you open a project
  • Choose Window > Workspaces and deselect Import Workspaces from Projects.
    This avoids having your workspace change when opening projects used by other editors.

Choose your Production settings

The settings you choose for a Production apply to every project in the Productions folder. When collaborating inside a production, every editor sees the same shared settings for the production. To configure production settings, choose File > Production Settings.  Read on to understand what each setting means for a production. For general information on these settings, see Review project settings.

The renderer setting applies to all systems that are working in the production. For situations where a particular system cannot  match the exact renderer specified in the production settings, Premiere Pro choose the closest renderer available.

The default value for all the scratch disks settings is Same as Production. It means that the folder that contains your production folder also contains your scratch disk folders. For editorial teams collaborating on shared storage, it is important that the scratch disk folders be set to a shared location that all edit systems can see.

 Media referenced using Motion Graphics Templates or Creative Cloud Libraries is only available to all edit systems if the scratch disk setting is set to a shared location.

Note:

If you must recover a file from Auto Save, navigate to the scratch disk location for Auto Save. Locate the project file that matches the name of the project you are looking for. There will always be one copy of the project with no user name or timestamp in the filename. This will always be the most recent Auto Save. Older copies of the project will have a timestamp and the user name appended in the format ProjectName-YYYY-MM-DD_HH-MM-SS-UserName.prproj.

Ingest settings are disabled for productions. Proxy files can still be created by selecting clips and choosing Proxy > Create Proxies or Attach Proxies from the context menu. 

Set up a production

Create a production

  1. Choose File > New > Production.
  2. Type in a name for your production. This will also be the name of the folder on disk.
  3. Click the blue path text to select a location to save the production folder. For collaboration, make sure to save the production on your shared storage.
  4. Click Create.
Create a production
Create a production

Open a production

Do one of the following steps:

  • From the Welcome screen or with a stand-alone project open choose File > Open Production.
  • Select a recently used production from the drop-down list.
  • Click Open or click Browse and navigate to an existing production folder and choose it.

 Unlike stand-alone project files, you can open only one production at a time.

Open a production
Open a production

Build out a production

You can build out your production in multiple ways. You can choose to create files or folders, add new projects within a production, and move or rename projects and folders.

Create projects in a production

  1. Click the New Project button or choose New Project from the context menu.
  2. Give the project a name and click OK.
Create a new project in a production
Create a new project in a production

Add existing projects to a production

You can add existing Premiere Pro projects to a Production.

Right-click in the Production panel or use the Production panel menu to choose Add Project to Production and then choose a project on disk.

Premiere Pro makes a copy of the project inside the production. Premiere Pro also upgrades the project version if necessary and checks to ensure there are no duplicate projects in the production.

 You can add project files to your production using Windows Explorer or Finder. However, avoid doing so unless you are certain the project comes from the same version of Premiere Pro. Make sure it is not a duplicate of an existing project in your production.

 Productions replace the existing Shared Projects workflow, however there are many differences between them. Adobe recommends that you finish any existing projects using Shared Projects rather than attempt to migrate them into a production.

Add an existing project to a production
Add an existing project to a production

Create folders in a production

  1. Click New Folder or choose New Folder from the context menu.
  2. Give the folder a name and click OK.
Create a new folder in a production
Create a new folder in a production

Move and rename projects and folders

You can move or rename projects if you have them open in read/write mode (green pen icon) or if they are closed with no red lock.

You can move and rename folders only if all the projects inside the folder are in Open read/write mode or closed with no red lock.

Production panel interface

After a production is set up, you can see all your files and folders within the Production panel. Here is a sample production panel interface.

Production panel interface
Production panel interface

A. Search for projects and folders 

B. Green pen indicates you can edit the project 

C. Outlined icon means the project is closed on your system 

D. Red lock indicates someone else is editing the project 

E. Solid icon means the project is open on your system 

F. Zoom slider adjusts the size of the text and icons in the panel 

G. Buttons for New Project, New Folder, and Trash 

H. Name shows who is editing the project 

Change project lock status

Projects displayed in the Production panel can be in one of three states:

Open, Read/Write

Projects in this state have a solid icon with a green pen   indicating that only you are able to edit the project. Other editors can open your project but they can only view it, not make changes. The user name you enter in Preferences > Collaboration is shown next to this project in the Project Locked column. You can move or rename this project in the Production Panel.

Open, Read Only

Projects in this state have a solid icon and may also have a  red lock. In either case you are not able to modify the project, only view it. If a red lock is present it means another editor has the project open Read/Write and their name will appear next to the project. Any open Timeline or Project panels from these projects will have a lock icon in the panel tab. You cannot move or rename projects in this state. Holding Cmd/Ctrl while double clicking a project will open it in Read Only mode.

Closed

Projects in this state have an outlined icon  and may also have a  red lock. In either case, the project is closed on your system and not using any memory or processing power. If a red lock is present the name of the editor working in the project appears next to the project. You can move or rename closed projects only if they do not have a red lock icon.

To change a project lock status:

  • Click the green pencil icon or red lock icon in the Project panel, or
  • Right-click the project in the Production panel and select Read/Write Mode or Read/Only Mode.
Change project lock status
Change project lock status

Even if a project is locked by another editor and is in a read-only state, you can open it to do the following tasks:

  • Load clips and sequences into the Source Monitor
  • Set In/Out points and perform edits from the Source Monitor
  • Play sequences in the Timeline and Program Monitor
  • Export media, XML, AAF, EDL, etc.
  • Copy project items into a project that is open Read/Write

Yes. If you are working in a Read-Only project, if the user who is editing the project saves new changes Premiere Pro shows you a notification.

  • In the Production panel, the name of the project appears in italics.
  • In the Project panel, a yellow triangle appears next to the project.

These notifications indicate that you are no longer looking at the most current version of the project. 

Indications that a project has been changed by someone else
Indications that a project has been changed by someone else

To see the new changes:

  • Right-click the project in the Production panel and select Refresh.
  • To refresh all projects in a production, select File > Refresh All Projects.

Frequently asked questions

No. Every user with Premiere Pro can take advantage of productions. Collaborating with multiple editors requires a networked shared storage solution.

While solo editors can use productions and benefit from some of the features, it is up to each editor whether they prefer to work in a single project file, a production, or a Team Project.

No. A Team Project can be saved as a stand-alone project file and then added to a production, but not the other way around.

Productions replace Shared Projects, but the Shared Project functionality remains in Premiere Pro with the concept of a Project Shortcut. With a Project panel active, choose File > New > Project Shortcut. Project Shortcuts can be useful for editors working in a single project but still wanting to link to commonly used projects. Project Shortcuts can be created inside projects in a production. Although most workflows would benefit more from using the Add Project command to bring the project inside the production.

No. Individual editors can use productions while storing them anywhere they would normally keep a single project file. A networked shared storage solution is only required for collaborating with other editors in the same production.

At a basic level, no. Project files created inside a production have the same .prproj extension and are fully complete Premiere Pro project files. They can be moved outside of a production and opened as a stand-alone project.

 If clips in a sequence link to master clips in a different project, you cannot see those master clips when the project is opened outside of the production. Use the Generate Master Clips command if you want the project to exist as a stand-alone project.

Yes. Use the Add Project command to add your project file to your production. During this process Premiere Pro updates the project file if required.

Yes. In the same way that a stand-alone project file can be opened on either macOS or Windows, productions support both systems at the same time. The first time opening a production on a new platform you may be asked to confirm the scratch disk location. Make sure to set it to the same location on the server and Premiere Pro handles the translation of drive mounting between the two operating systems.

If the Renderer chosen in File > Production Settings > General is not available on one of the systems, Premiere Pro chooses the next best renderer automatically. For example, if a production is created on Windows with the CUDA renderer chosen, when it is opened on macOS Metal is used automatically.

Only one production can be open at a time, but there is no limit to the number of productions you can create or use. Choose File > Open Production to see a drop-down list of recently opened productions or select recent productions from the list of recent items on the Welcome screen.

This file is used by Premiere Pro to store production settings and other information. Do not move or modify this file.

Ingest settings are disabled in the Production Settings dialog because they are designed to apply to a single computer at a time. To use Ingest Settings, first close your production and create a stand-alone project that is saved outside of the production folder. Set your desired Ingest Settings and import your media. After all ingest operations have finished, save your project and close it. Open your production and use the Add Project command to bring the project file into your production. You can now use the ingested clips normally.

Do not store any other files or media inside your production folder. The Production panel only shows folders and project files, however, Premiere Pro scans all files placed in the production folder and so there could be performance issues.

Adobe recommends that you do organizational work inside the Production panel. Operations done on disk (moving files, renaming, etc.) are reflected in the Production panel, doing those operations inside Premiere Pro is the best option. For example Finder or Explorer may let you rename a project file that another editor is working on, whereas Premiere Pro would not allow it. Always avoid duplicating project files in Finder or Explorer.