若要建立能在 Flash Player 中以幻燈片型式播放的內容,您可以轉存為 SWF 或 FLA。主要的差異在於 SWF 檔案隨即可檢視但不可編輯,而 FLA 檔案必須在 Adobe Flash Professional 中編輯,才能在 Adobe Flash Player 中檢視。

SWF

轉存的 SWF 檔案隨即可在 Adobe Flash Player 中檢視,而且可能包含互動元素,例如頁面切換效果、超連結、影片、聲音剪輯、動畫及導覽按鈕。

FLA

轉存的 FLA 檔案僅包含一些互動元素。FLA 檔案可在 Flash Pro 中開啟,您或 Flash 開發人員就可在此處先加入進階效果,再轉存為 SWF。

轉存為 Flash
轉存為 Flash

A. 直接轉存為 SWF B. 轉存為 FLA 以便在 Flash Professional 進行編輯 

建立網站的互動式 SWF (Flash) 檔案

轉存為 SWF 時,建立的互動式檔案就可以隨即在 Adobe Flash Player 或網頁瀏覽器中檢視。SWF 檔案可以包含在 InDesign 中新增的按鈕、頁面切換效果、影片與音訊檔案、動畫及超連結。基於 InDesign 文件時,轉存為 SWF 是建立互動式幻燈片或手翻書的好方法。

如果您要在建立 SWF 檔案之前編輯 Flash Pro 中的文件,請轉存為 FLA,而不是 SWF。請參閱建立網站的 FLA 檔案

SWF 轉存
SWF 轉存

A. 在進行 SWF 轉存前的 InDesign 文件 B. 網頁瀏覽器中的互動式 SWF 檔案 
  1. 建立或編輯 InDesign 文件,準備進行 Flash 轉存。如需有關文件轉存設定的詳細資訊,請參閱 Flash 轉存問題

    • 新增導覽按鈕可讓使用者在轉存的 SWF 檔案頁面間移動。您可以透過繪製物件並使用「按鈕」面板 (選擇「視窗 > 互動 > 按鈕」) 轉換為按鈕的方式,建立按鈕。您也可以使用「樣本按鈕」面板將預先定義的導覽按鈕拖移到您的文件。請參閱建立按鈕

    • 使用「頁面切換效果」面板 (選擇「視窗 > 互動 > 頁面切換效果」) 加入頁面切換效果,例如划出或溶解。轉存為 SWF 時,您也可以選取「包含互動式頁面捲曲」選項,讓檢視者在拖移頁面角落時翻頁。

    • 使用「動畫」面板 (選擇「視窗 > 互動 > 動畫」) 加入移動預設集。請參閱動畫

  2. 若要將文件轉存為 SWF 格式,請選擇「檔案 > 轉存」。從「存檔類型」(Windows) 或「格式」(Mac OS) 選單中,選擇 Flash Player (SWF),然後按一下「儲存」。

  3. 在「轉存 SWF」對話框中,指定選項,然後按一下「確定」。請參閱 SWF 轉存選項

轉存 SWF 檔案時,會建立單獨的 HTML 和 SWF 檔案。如果 SWF 檔案包含影片或聲音剪輯,還會建立「資源」檔案夾。若要將檔案提交或上載到網頁,請確保傳送的是所有資產。

SWF 轉存選項

在「轉存 SWF」對話框的「一般」和「進階」索引標籤會出現下列選項。

轉存

指出是否包含目前選取範圍、文件中的所有頁面,或是頁面範圍。如果您要儲存轉存的 SWF 檔案,以便用於轉存的 PDF 檔案時,選擇「選取範圍」特別有用。如果您選取「範圍」,請指定頁面範圍,例如指定 1-7, 9 即可列印第 1 到 7 頁和第 9 頁。請參閱指定要列印的頁面

產生 HTML 檔

選取這個選項可以產生 HTML 頁面來播放 SWF 檔。這個選項特別適合用於在網路瀏覽器中快速預視 SWF 檔的時候。

轉存後檢視 SWF

選取這個選項可以在預設網路瀏覽器中播放 SWF 檔。必須先產生 HTML 檔,才能使用這個選項。

大小 (像素)

指定是否要以百分比調整 SWF 檔案的比例、符合指定的螢幕大小,或是根據指定的寬度和高度來調整大小。

背景

指定您的 SWF 背景是否是透明的,或者是否使用「色票」面板目前的「紙張」顏色。選取「透明」會關閉「頁面切換效果」和「互動式頁面捲曲」選項。

互動性與媒體

選取「全部包含」,可讓影片、聲音、按鈕及動畫在轉存的 SWF 檔案中互動。選取「僅限外觀」,將正常狀態的按鈕與影片海報包含成為靜態元素。如果選取「僅限外觀」,轉存的動畫會以轉存時的版面出現。如果在「進階」面板中選擇「透明度平面化」,也會選取「僅限外觀」。

頁面切換效果

指定一種頁面切換效果,即可在轉存期間套用至所有頁面。如果您使用「頁面切換效果」面板來指定切換效果,請選擇「從文件」選項以使用這些設定。

包含互動式頁面捲曲

如果選取此選項,使用者在播放 SWF 檔時便可拖移頁面角落來翻轉頁面,營造出真實書冊翻頁時的模樣。

影格速率

較高的影格速率可使動畫更流暢,但可能會增加檔案大小。變更影格速率並不會影響播放的持續時間。

文字

指定如何輸出 InDesign 文字。選擇「Flash 傳統文字」可以輸出可搜尋的文字,使檔案大小縮到最小。選擇「轉換為外框」可以將文字輸出為一系列的平滑直線,就像將文字轉換為外框一樣。選擇「轉換為像素」可以將文字以點陣圖影像輸出。放大時,轉換為像素的文字可能會呈現鋸齒狀。

點陣化頁面

這個選項會將所有的 InDesign 頁面項目轉換為點陣圖。選取這個選項可以放大 SWF 檔,但頁面項目可能會在開啟放大顯示功能時呈現鋸齒狀。

透明度平面化

此選項會移除 SWF 的即時透明度,並保留透明度的外觀。不過,如果選取此選項,會從轉存的 SWF 檔案中移除所有互動性。

壓縮

選擇「自動」可讓 InDesign 為彩色和灰階影像決定最佳品質。對大部分檔案而言,此選項皆可產生令人滿意的結果。灰階或彩色影像適合選擇「JPEG (失真)」。JPEG 壓縮會損失資料,也就是說它會移除影像資料且可能會降低影像品質。儘管如此,它會以流失最少資訊的方式來降低檔案大小。由於 JPEG 壓縮會刪除資料,所以壓縮出來的檔案大小會變小許多。選擇「PNG (不失真)」可以在不造成失真的壓縮動作下轉存檔案。

註解:

在轉存為 SWF 時,如果您發現透明影像的影像品質失真,請選擇「PNG (不失真)」來改善品質。

JPEG 品質

指定轉存影像中的精細度。品質越高,檔案越大 如果您在「壓縮」中選擇「PNG (不失真)」,此選項就會變暗。

解析度

在轉存的 SWF 中指定點陣圖影像的解析度。在轉存的 SWF 中讓檢視者放大以像素為主的內容時,選擇高解析度特別重要。選擇高解析度會大幅增加檔案大小。

建立網站的 FLA 檔案

將 InDesign 文件轉存為 FLA 檔案格式之後,可以使用 Adobe Flash® CS5 Professional 開啟檔案來編輯內容。以 InDesign CS5 格式轉存為 FLA 會取代 InDesign CS4 中的 XFL 轉存。使用 Flash 編寫環境可編輯或新增視訊、音訊、動畫及複雜的互動。

如果您要將 InDesign 文件直接轉存為可在網頁瀏覽器直接開啟的格式,請使用 SWF 格式,而不是 FLA。請參閱建立網站的 SWF (Flash) 檔案

FLA 轉存
FLA 轉存

A. 在進行 FLA 轉存前的 InDesign 文件 B. 在 Flash Pro 中開啟的 FLA 檔案 
  1. 建立或編輯 InDesign 文件,準備進行 Flash 轉存。如需有關文件轉存設定的詳細資訊,請參閱 Flash 轉存問題

  2. 若要將文件轉存為 FLA 格式,請選擇「檔案 > 轉存」。從「存檔類型」(Windows) 或「格式」(Mac OS) 選單中,選擇「Flash CS5 Professional (FLA)」,然後按一下「儲存」。

  3. 在「轉存 Flash CS5 Professional (FLA)」對話框中,指定選項,然後按一下「確定」。如需轉存選項的詳細資訊,請參閱 FLA 轉存選項

  4. Flash Professional 中開啟轉存的 FLA 檔案。

FLA 轉存選項

「轉存 Flash CS5 Professional (FLA)」對話框中會出現下列選項。

轉存

指出是否包含目前選取範圍、文件中的所有頁面,或是頁面範圍。如果您選取「範圍」,請指定頁面範圍,例如指定 1-7, 9 即可列印第 1 到 7 頁和第 9 頁。請參閱指定要列印的頁面

點陣化頁面

這個選項會將所有的 InDesign 頁面項目轉換為點陣圖。選取此選項可以放大 FLA 檔,但頁面項目會在放大時呈現鋸齒狀。

透明度平面化

選取這個選項會使具有透明度的所有物件平面化。平面化物件可能難以在 Adobe Flash Pro 中製成動畫。

大小 (像素)

指定是否要將 FLA 檔案大小按比例縮放、符合指定的螢幕大小,或是根據指定的寬度和高度來調整大小。

互動性與媒體

選取「全部包含」,可讓影片、聲音、按鈕及動畫包含在轉存的 FLA 檔案中。如果文件包含多狀態物件,會轉換成影片剪輯符號,在此各狀態會以本身的影格呈現在時間軸上。

選取「僅限外觀」,將正常狀態的按鈕與影片海報包含成為靜態元素。如果選取「僅限外觀」,轉存的動畫會以轉存時的版面出現。如果您選擇「透明度平面化」,也會選取「僅限外觀」。

文字

指定如何輸出 InDesign 文字。選擇「Flash TLF 文字」,可善加利用 Flash Professional 中豐富的「文字版面架構」屬性集。如果選取此選項,請選取「插入字典連字點」以允許連字。選擇「Flash 傳統文字」可以輸出可搜尋的文字,使檔案大小縮小。選擇「轉換為外框」可以將文字輸出為一系列的平滑直線,就像將文字轉換為外框一樣。選擇「轉換為像素」可以將文字以點陣圖影像輸出。放大時,轉換為像素的文字可能會呈現鋸齒狀。

壓縮

選擇「自動」可讓 InDesign 為彩色和灰階影像決定最佳品質。對大部分檔案而言,此選項皆可產生令人滿意的結果。灰階或彩色影像適合選擇「JPEG (失真)」。JPEG 壓縮會損失資料,也就是說它會移除影像資料且可能會降低影像品質。儘管如此,它會以流失最少資訊的方式來降低檔案大小。由於 JPEG 壓縮會刪除資料,所以壓縮出來的檔案大小會變小許多。選擇「PNG (不失真)」可以在不造成失真的壓縮動作下轉存檔案。

JPEG 品質

指定轉存影像中的精細度。品質越高,檔案越大 如果您在「壓縮」中選擇「PNG (不失真)」,此選項就會變暗。

解析度

在轉存的 FLA 檔案中指定點陣圖影像的解析度。讓檢視者放大以像素為主的內容時,選擇高解析度特別重要。選擇高解析度會大幅增加檔案大小。

Flash 轉存問題

設計適用於 SWF 或 FLA 輸出的 InDesign 文件時,要考慮下列因素。

文件設定問題

InDesign 頁面的轉換方式

當您轉存為 SWF 或 FLA 時,InDesign 跨頁會變成採用時間軸的個別剪輯,就像幻燈片播放中的幻燈片一樣。每個跨頁都會對應到新的主要畫格。在 Flash Player 中,您可以藉由按方向鍵或按一下互動式按鈕來瀏覽轉存的文件跨頁。

註解:

建立適用於網頁的文件時,請從「新增文件」對話框的「方式」選單中選擇「網頁」。

頁面大小

建立文件之後,您可以從「新增文件」對話框的「頁面大小」選單中選擇類似 800 x 600 的特定解析度。在轉存期間,您也可以調整已轉存 SWF 或 FLA 檔的縮放比例或解析度。

互動功能

轉存的 SWF 和 FLA 檔案可以包含按鈕、頁面切換效果、超連結、動畫及媒體檔案。

按鈕

就已轉存 SWF 或 FLA 檔案的按鈕而言,若要在 Flash Player 中播放,「下一頁」和「上一頁」這兩個動作是特別有用的控制項。不過,某些在互動式 PDF 檔中有作用的動作在 Flash Player 中卻無效。在「按鈕」面板中選擇一個動作時,請不要從「僅 PDF」區段中選取選項。

註解:

您可以新增預先格式化為「跳至下一頁」和「跳至上一頁」動作的導覽按鈕。從「按鈕」面板選單中選擇「樣本按鈕」。請參閱從「樣本按鈕」面板新增按鈕。

頁面切換效果

所有的頁面切換效果在 Flash Player 中都能運作良好。除了翻頁時出現的頁面切換效果以外,您也可以在轉存期間加入互動式頁面捲曲,在拖移頁面角落時翻頁。

超連結

建立網站連結或文件中其他頁面的連結。FLA 檔案中的超連結已中斷。

影片和聲音剪輯

轉存的 SWF 檔案若為支援的格式,例如 SWF、FLV、F4V、影片適用的 MP4及聲音剪輯的 MP3,就會包含影片和聲音剪輯。

轉存為 FLA 後,FLA 檔案僅包含海報影像。支援的媒體檔案會出現在資源檔案夾中,此檔案夾的儲存位置與已轉存 FLA 檔案的位置相同。

轉換問題

顏色

SWF 和 FLA 檔會使用 RGB 色彩。將文件轉存為 SWF 或 FLA 時,InDesign 會將所有色域 (例如 CMYK 和 LAB) 轉換為 sRGB。InDesign 會將特別色轉換為同等的 RGB 印刷色。

若要避免在文字具有透明度的圖稿中發生色彩走樣的問題,請選擇「編輯 > 透明度混合色域 > 文件 RGB」。若要避免具有透明度的影像發生色彩走樣的問題,在轉存期間請不要使用造成失真的壓縮動作。

文字

轉存為 SWF 或 FLA 時,您可以決定是否要將文字輸出為 Flash 文字或轉換為外框或像素。在 Adobe Flash CS5 Professional 中開啟 FLA 檔案時,轉存為 Flash 傳統文字的文字仍舊是完全可編輯的,而且可以在儲存為 SWF 檔時在網頁瀏覽器中搜尋這些文字。

影像

將影像轉存為 SWF 或 FLA 時,您可以在轉存期間變更影像壓縮、JPEG 品質及解析度設定。

將影像轉存為 FLA 時,在 InDesign 文件中多次置入的影像,會儲存成位置共用的單一影像資產。請注意,如果 InDesign 文件中有大量的向量影像,可能就會造成轉存之檔案的效能出現問題。

若要縮減檔案大小,請將重複的影像置於主版頁面,並避免拷貝和貼上影像。如果將相同影像多次置於文件中,而且未將其變形或裁切,則只會在 FLA 檔中轉存一份檔案。拷貝和貼上的影像會視為個別物件來處理。

根據預設,置入的 Illustrator 檔案會在 FLA 檔中視為單一影像處理,但是拷貝和貼上的 Illustrator 檔案則會產生許多個別物件。為求最佳結果,請將 Illustrator 影像置入為 PDF 檔,而不要從 Illustrator 拷貝和貼上。拷貝和貼上會產生多個可編輯的路徑。

註解:

您可以變更偏好設定選項,確定將 Illustrator 物件貼為單一物件,而不是小型向量的集合。在 Illustrator 的「檔案處理和剪貼簿」偏好設定中,選取「PDF」並取消選取「AICB (不支援透明特性)」。在 InDesign 的「剪貼簿處理」偏好設定中,同時選取「盡量以 PDF 格式貼上」和「將 PDF 拷貝至剪貼簿中」。

透明度

在轉存為 SWF 之前,請確定透明物件未與類似按鈕或超連結的任何互動元素重疊。如果具有透明度的物件與互動元素重疊,轉存時可能會失去互動性。您可能會想要在轉存為 FLA 之前進行透明度平面化。

在某些情況下,選擇失真的壓縮動作會降低具有透明度影像的品質。轉存時,請選擇「PNG (不失真)」來改善品質。

3D 屬性

轉存的 SWF 和 FLA 檔案不支援 3D 屬性。

此産品由 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 授權  Creative Commons 條款未涵蓋 Twitter™ 與 Facebook 文章。

法律說明   |   線上隱私權政策