Leer hoe u beschadigde Adobe InDesign-bestanden kunt herstellen.

Een InDesign-document kan alleen beschadigd raken wanneer u aan het document werkt en er zich een fout of onverwacht gedrag voordoet. InDesign heeft een automatische herstelfunctie voor documenten die schade als gevolg van systeemcrashes of stroomstoringen kan voorkomen. De functie kan echter geen andere problemen op systeemniveau voorkomen die worden veroorzaakt door bijvoorbeeld softwareconflicten, onvoldoende schijfruimte of virussen. Deze handleiding voor probleemoplossing kan helpen bij het isoleren en oplossen van beschadigingen in InDesign-documenten. Daarnaast kan deze handleiding u helpen met het isoleren en oplossen van problemen op systeemniveau die overeenkomsten vertonen met documentbeschadigingen maar verband houden met andere oorzaken.

Controleren op problemen op systeemniveau

Problemen op systeemniveau kunnen fouten of ander onverwacht gedrag veroorzaken. Zorg ervoor dat het systeem nagenoeg geen problemen kent, voordat u veronderstelt dat het document beschadigd is. U kunt bijvoorbeeld een hulpprogramma voor schijfreparatie uitvoeren en het document opnieuw openen om te controleren of het hersteld is, voordat u de probleemoplossingstaken voor beschadigde documenten hieronder doorloopt.

Windows: zie Uw harde schijf op fouten controleren.

Mac OS: zie Opstartproblemen oplossen en schijfonderhoud uitvoeren.

Problemen met beschadigde documenten oplossen

Voer vervolgens de onderstaande taken in de aangegeven volgorde uit. Stop wanneer u het probleem hebt vastgesteld. 

Opmerking:

Na voltooiing van elke probleemoplossingstaak start u InDesign opnieuw en opent u het document om te zien of het probleem is opgelost. Open het document als volgt:

Kies Bestand > Openen, kies uw document en vervolgens Kopiëren. Sla uw document met een nieuwe naam op en controleer of het hersteld is.

1. Maak een back-up van uw document.

Maak voordat u begint met het oplossen van problemen een back-up van uw beschadigde document. Voor sommige taken moet u informatie in het document wijzigen of verwijderen. Met een back-up van het document kunt u informatie eenvoudig herstellen. Als het document zich op een netwerkvolume of verwisselbaar medium (bijv. een cd of jumpdrive) bevindt, verplaatst u de back-up naar een lokale vaste schijf.

2. Installeer de nieuwste InDesign-update.

  • Kies Help > Updates in InDesign.

-of-

-of-

3. Maak uw bestand met voorkeuren opnieuw.

InDesign slaat informatie over plug-ins, functies en de app zelf op in voorkeursbestanden: het InDesign SavedData-bestand en het InDesign Defaults-bestand. Een beschadigd InDesign-voorkeursbestand kan ervoor zorgen dat een InDesign-document onverwacht gedrag vertoont. U kunt gemakkelijk vaststellen of het probleem verband houdt met de voorkeursbestanden door deze bestanden opnieuw te maken.

Opmerking:

Als u de InDesign-voorkeursbestanden opnieuw maakt, worden de standaardwaarden van de bijbehorende instellingen hersteld. Aangepaste instellingen uit de oude voorkeursbestanden gaan dus verloren. Als u deze aangepaste instellingen wilt behouden, wijzigt u de naam van de oude voorkeursbestanden.

De InDesign-voorkeursbestanden opnieuw maken:

  1. Sluit InDesign af.

  2. Start InDesign opnieuw en houd de juiste toetsen ingedrukt voor uw besturingssysteem:

    • Mac OS X: Control + Option + Command + Shift
    • Windows: Control + Alt + Shift
  3. Wanneer u wordt gevraagd om uw voorkeursbestanden voor InDesign te verwijderen, klikt u op Ja. InDesign wordt gestart met standaardwaarden en opnieuw gegenereerde voorkeursbestanden.

    Opmerking:

    Als u niet wordt gevraagd of u de voorkeursbestanden wilt verwijderen, kunt u uw voorkeuren handmatig verwijderen.

  4. Open het document en controleer of het hersteld is. Als het probleem zich blijft voordoen, gaat u naar taak 4 hieronder.

    Uw voorkeursbestanden handmatig verwijderen of hernoemen

    U kunt ook:

    • Uw voorkeursbestanden handmatig verwijderen (bijvoorbeeld als u automatisch wordt gevraagd voorkeursbestanden te verwijderen tijdens het starten van InDesign, zoals in de vorige procedure)

    -of-

    • De namen van uw voorkeursbestanden handmatig wijzigen (bijvoorbeeld als u aangepaste instellingen hebt die zijn gekoppeld aan oude voorkeursbestanden die u wilt behouden)

    Zoek uw besturingssysteem op in de volgende tabel om te zien waar deze bestanden zich bevinden.

    Besturingssysteem Locaties van voorkeursbestanden
    Mac OS X

    InDesign Defaults

    Users/[gebruiker]/Library/Preferences/Adobe InDesign/Version [versie]/[taal]/InDesign Defaults

    InDesign SavedData

    Users/[gebruiker]/Library/Caches/Adobe InDesign/Version [versie]/InDesign SavedData

    Windows XP

    InDesign Defaults

    C:\Documents and Settings\[gebruiker]\Application Data\Adobe\InDesign\Version [versie]\InDesign Defaults

    Is standaard verborgen. Leer hoe u verborgen bestanden kunt weergeven.

    InDesign SavedData

    C:\Documents and Settings\[gebruiker]\Local Settings\Application Data\Adobe\InDesign\Version[version]\Caches\InDesign SavedData

    Windows 7/8

    InDesign Defaults

    C:\Users\[gebruiker]\AppData\Adobe\InDesign\Version[versie]\[taal]\InDesign Defaults

    Is standaard verborgen. Leer hoe u verborgen bestanden kunt weergeven.

    InDesign SavedData

    C:\Users\[gebruiker]\AppData\Local\Adobe\InDesign\Version[versie]\[taal]\Caches\InDesign SavedData

    Nadat u het verwijderen of hernoemen hebt voltooid, start u InDesign opnieuw om uw voorkeursbestanden opnieuw te maken. Open vervolgens het document om te controleren of het hersteld is.

    Als het probleem zich blijft voordoen, kunt u de oorspronkelijke voorkeuren herstellen door de nieuwe bestanden te verwijderen en de oude voorkeursbestanden weer hun oorspronkelijke naam te geven.

4. Sla het document op in de indeling IDML (InDesign CS4 en later) of INX (InDesign CS3 en vroeger).

  1. Open het bestand in InDesign.

  2. Kies Bestand > Exporteren.

  3. Kies in het menu Opslaan als type de optie InDesign Markup (CS4 en later) of InDesign Interchange (CS3 en eerder).

  4. Kies een bestandsnaam en locatie en klik op Opslaan.

  5. Open het geëxporteerde IDML- of INX-bestand weer in InDesign.

    Als het probleem is verholpen, kunt u nu verder werken met het IDML of INX-bestand als vervanging van het oorspronkelijke document. Als het probleem zich blijft voordoen, gaat u door naar de volgende stap.

5. Los problemen met een geconverteerd document op in de bijbehorende brontoepassing.

Als het document is geconverteerd van Adobe PageMaker, QuarkXPress of een eerdere versie van InDesign, kunt u proberen het document opnieuw te converteren. Als het probleem zich nogmaals voordoet, kunt u de problemen met beschadigingen in het oorspronkelijke document oplossen in de bijbehorende bronapp voordat u het document opnieuw converteert. Een beschadigd PageMaker- of QuarkXPress-document blijft waarschijnlijk beschadigd na conversie.

6. Verwijder teken- en alineastijlen.

Stijlen die u in InDesign hebt gemaakt of geïmporteerd met bestanden die zijn gemaakt in andere apps, kunnen beschadigd zijn. Als u wilt nagaan of dit het geval is, verwijdert u de stijlen en slaat u uw document opnieuw op.

Tekenstijlen verwijderen:

  1. Open het document in InDesign en kies Type > Tekenstijlen.

  2. Selecteer alle stijlen in het deelvenster Tekenstijlen uitgezonderd [Geen tekenstijl]. Als u meerdere stijlen wilt selecteren, drukt u op Ctrl (Windows) of Command (Mac OS) terwijl u de stijlen selecteert.

  3. Kies Stijlen verwijderen in het menu Tekenstijlen.

  4. Sla uw document op en controleer of het hersteld is. Als het probleem zich blijft voordoen, kunt u proberen om alineastijlen te verwijderen.

Alineastijlen verwijderen:

  1. Open het document in InDesign en kies Type > Alineastijlen.

  2. Selecteer alle stijlen in het deelvenster Alineastijlen uitgezonderd [Geen alineastijl]. Als u meerdere stijlen wilt selecteren, drukt u op Ctrl (Windows) of Command (Mac OS) terwijl u de stijlen selecteert.

  3. Kies Stijlen verwijderen in het menu Alineastijlen.

  4. Sla uw document op en controleer of het hersteld is. Als het probleem zich blijft voordoen, gaat u naar taak 7 hieronder.

7. Controleer op lettertypebeschadigingen.

U kunt bepalen of het probleem verband houdt met een beschadigd lettertype door alle lettertypen in het document te vervangen door een standaardlettertype, zoals Arial of Times New Roman.

Als het probleem zich blijft voordoen nadat u de lettertypen hebt gewijzigd, heeft het probleem niet met het lettertype te maken. Als het probleem zich niet opnieuw voordoet, kunnen een of meer van de oorspronkelijke lettertypen beschadigd of verouderd zijn. Probeer de oorspronkelijke lettertypen opnieuw te installeren of probeer bijgewerkte versies te verkrijgen bij de leverancier van de lettertypen.

8. Controleer objecten en afbeeldingen op beschadigingen.

Probeer te bepalen of een specifiek element op een hoofdpagina of een documentpagina het probleem veroorzaakt. Als u elementen wilt isoleren, verwijdert u eerst lege pagina's en onnodige elementen, zoals de elementen op een plakbord of in een verborgen laag.

Pagina's verwijderen:

  1. Open het document in InDesign en kies Windows > Pagina's.

  2. Kies in het deelvenster Pagina's het selectiegereedschap om de pagina's te selecteren die u wilt verwijderen. Druk op Ctrl (Windows) of Command (Mac OS) om meerdere pagina's te selecteren of druk op de Shift-toets om een aaneengesloten bereik van pagina's te selecteren.

    Pagina's verwijderen
    Selecteer de pagina's in het Deelvenster pagina's wilt verwijderen.

  3. Klik op het verwijderpictogram in het deelvenster Pagina's.

  4. Klik op OK om het verwijderen te bevestigen.

Als het probleem zich opnieuw voordoet nadat u enkele pagina's hebt verwijderd, verwijdert u de helft van de resterende pagina's en slaat u het document op met een nieuwe naam. Probeer het probleem vervolgens te reproduceren.

  • Als het probleem zich opnieuw voordoet, dan bevat een van de resterende pagina's mogelijk een beschadigd element. Blijf pagina's verwijderen totdat u hebt vastgesteld welke pagina het probleem veroorzaakt.
  • Doet het probleem zich niet opnieuw voor, dan bevat een van de verwijderende pagina's mogelijk een beschadigd element. Vervang de verwijderde pagina's totdat u hebt vastgesteld welke pagina het probleem veroorzaakt.

Als u hebt vastgesteld welke pagina het probleem veroorzaakt, verwijdert en vervangt u elementen op deze pagina, met inbegrip van geïmporteerde afbeeldingen, in InDesign getekende objecten en tekstkaders op de pagina.

9. Kopieer pagina-elementen naar een nieuw document.

Als u pagina-elementen kopieert naar een nieuw document, blijven de structurele (interne) beschadigingen achter. Als het probleem zich opnieuw voordoet nadat u pagina-elementen naar een nieuw document hebt gekopieerd, verwijdert u elementen één voor één om te zien welk element het probleem veroorzaakt.

Pagina-elementen kopiëren naar een nieuw document:

  1. Open het oorspronkelijke document in InDesign.

  2. Kies Bestand > Nieuw en klik op OK in het dialoogvenster Nieuw document.

  3. Kies Venster > Naast elkaar om beide documenten weer te geven.

  4. Klik op het oorspronkelijke document om het te activeren.

  5. Kies Venster > Pagina's om het deelvenster Pagina's te activeren.

  6. Versleep een pagina of spread naar het nieuwe documentvenster. InDesign kopieert de pagina of spread naar het nieuwe document en voegt indien nodig pagina's toe.

  7. Sla het nieuwe document naar een nieuwe naam (anders dan de naam van het oorspronkelijke document) en probeer het probleem te reproduceren.

    • Als het probleem zich opnieuw voordoet, zijn de beschadigingen niet structureel (bijvoorbeeld op stramien- of documentpagina's). Verwijder elementen één voor één om te zien welk element het probleem veroorzaakt.
    • Treedt het probleem niet opnieuw op, dan is de schade waarschijnlijk structureel. Herhaal stap 4 t/m 7 voor elke resterende pagina of spread.

10. Vraag een ander exemplaar van het document op.

Als u het document hebt ontvangen via e-mail, FTP of verwisselbaar medium (zoals een cd), kunt u proberen het document op een andere manier te verkrijgen. U kunt het document ook opnieuw laten verzenden. Documentbeschadigingen kunnen ontstaan door beschadigingen aan media of problemen tijdens de e-mailoverdracht. Als het document wordt verzonden via e-mail, laat de afzender het bestand dan eerst comprimeren (bijvoorbeeld met WinZip of StuffIt van Smith Micro) om de gegevens te beschermen.

Andere suggesties

Nog steeds problemen? Probeer deze oplossingen.

Verwijder plug-ins van derden.

Overweeg om plug-ins van derden uit InDesign te verwijderen. Plug-ins kunnen soms beschadiging aan bestanden veroorzaken. Zie Problemen met InDesign-plug-ins van derden oplossen.

Gebruik een ander wachtwoord om het document te openen.

Door van systeemomgeving te veranderen, elimineert u mogelijk factoren die het probleem veroorzaken.

Bezoek de Adobe-gebruikersforums.

U staat er niet alleen voor! Mogelijk hebben andere gebruikers soortgelijke problemen gehad met een document en hebben ze een oplossing gemeld. Zie de InDesign-forums.

Maak het document opnieuw.

Werkt geen enkele oplossing, maak het document dan opnieuw. Maak regelmatig een back-up van het document en test het document regelmatig om te controleren of geïmporteerde elementen geen problemen veroorzaken.

Dit werk is gelicentieerd onder de Creative Commons Naamsvermelding/Niet-commercieel/Gelijk delen 3.0 Unported-licentie  De voorwaarden van Creative Commons zijn niet van toepassing op Twitter™- en Facebook-berichten.

Juridische kennisgevingen   |   Online privacybeleid