Suivi du visage

  1. Guide de lʼutilisateur dʼAfter Effects
  2. Versions Beta
    1. Présentation du programme Beta
    2. Accueil After Effects Beta
  3. Prise en main
    1. Prise en main dʼAfter Effects
    2. Nouveautés dʼAfter Effects
    3. Notes de mise à jour | After Effects
    4. Configuration requise pour After Effects
    5. Raccourcis clavier dans After Effects
    6. Formats de fichier pris en charge | After Effects
    7. Recommandations matérielles
    8. Planification et configuration
    9. Configuration et installation
  4. Espaces de travail
    1. Eléments généraux de lʼinterface utilisateur
    2. Familiarisation avec lʼinterface dʼAfter Effects
    3. Workflows
    4. Espaces de travail, panneaux et visualiseurs
  5. Projets et compositions
    1. Projets
    2. Notions de base relatives aux compositions
    3. Précomposition, imbrication et prérendu
    4. Affichage dʼinformations détaillées sur les performances avec le Profileur de composition
    5. Moteur de rendu de composition CINEMA 4D
  6. Importation de métrage
    1. Préparation et importation dʼimages fixes
    2. Importation à partir dʼAfter Effects et dʼAdobe Premiere Pro
    3. Importation et interprétation vidéo et audio
    4. Préparation et importation de fichiers images 3D
    5. Importation et interprétation de métrages
    6. Utilisation des métrages
    7. Métadonnées XMP
  7. Travailler avec du texte et des images
    1. Texte
      1. Mise en forme des caractères et panneau Caractère
      2. Effets de texte
      3. Création et modification des calques de texte
      4. Mise en forme des paragraphes et panneau Paragraphe
      5. Extrusion de calques de texte et de forme
      6. Animation de texte
      7. Exemples et ressources dʼanimation de texte
      8. Modèles Live Text
    2. Animations graphiques
      1. Utilisation de modèles dʼanimations graphiques dans After Effects
      2. Utilisation des expressions pour créer des listes déroulantes dans les modèles dʼanimations graphiques
      3. Utilisation des propriétés essentielles pour créer des modèles dʼanimations graphiques
      4. Remplacement d’images et de vidéos dans les modèles dʼanimations graphiques et les propriétés essentielles
  8. Dessin, peinture et tracés
    1. Présentation des calques de forme, des tracés et des images vectorielles
    2. Outils de peinture : Pinceau, Cloner et Gomme
    3. Comment effiler les contours de forme
    4. Attributs de forme, opérations de peinture et opérations de tracé pour les calques de forme
    5. Utilisation de lʼeffet de forme Décaler les tracés pour modifier des formes
    6. Création de formes
    7. Création de masques
    8. Suppression dʼobjets de vos vidéos avec le panneau Remplissage dʼaprès le contenu
    9. Roto-pinceau et Améliorer le cache
  9. Utilisation de calques
    1. Sélection et disposition de calques
    2. Modes de fusion et styles de calques
    3. Calques 3D
    4. Propriétés du calque
    5. Création de calques
    6. Gestion des calques
    7. Repères de calque et repères de composition
    8. Caméras, lumières et points ciblés
  10. Animation, images clés, suivi de cible et incrustations
    1. Animation
      1. Principes de base de l’animation
      2. Animation avec les outils Marionnette
      3. Gestion et animation de tracés de forme et de masques
      4. Animation de formes Sketch et Capture à lʼaide dʼAfter Effects
      5. Outils dʼanimation divers
      6. Utilisation dʼanimations orientées données
    2. Image clé
      1. Interpolation des images clés
      2. Définition, sélection et suppression dʼimages clés
      3. Modification, déplacement et copie dʼimages clés
    3. Suivi de cible
      1. Suivi et stabilisation du mouvement
      2. Suivi du visage
      3. Suivi de masque
      4. Référence de masque
      5. Vitesse
      6. Extension temporelle et remappage temporel
      7. Code temporel et unités temporelles
    4. Masquage
      1. Incrustations
      2. Effets de masquage
  11. Transparence et montage
    1. Présentation et ressources du montage et de la transparence
    2. Couches alpha, masques et caches
  12. Réglage de la couleur
    1. Principes de base de la couleur
    2. Utilisation de lʼextension Thèmes Adobe Color
    3. Gestion des couleurs
    4. Effets de correction colorimétrique
  13. Effets et animations prédéfinis
    1. Présentation des effets et animations prédéfinies
    2. Liste dʼeffets
    3. Effets de simulation
    4. Effets esthétiques
    5. Effets audio
    6. Effets de déformation
    7. Effets de perspective
    8. Effets de couches
    9. Effets de rendu
    10. Effets de transition
    11. Effet Réparation dʼobturateur déroulant
    12. Effets de flou et de netteté
    13. Effets de couches 3D
    14. Effets Utilité
    15. Effets de cache
    16. Effets de bruit et de grain
    17. Effet Conservation des détails-Amélioration
    18. Effets obsolètes
  14. Expressions et automatisation
    1. Expression
      1. Principes de base des expressions
      2. Compréhension du langage dʼexpression
      3. Utilisation des options pour expressions
      4. Différences de syntaxe entre le moteur dʼexpressions JavaScript et lʼancien moteur dʼexpressions ExtendScript
      5. Modification des expressions
      6. Erreurs dans les expressions
      7. Utilisation de lʼéditeur dʼexpressions
      8. Utilisation d’expressions pour accéder aux propriétés du texte et les modifier
      9. Référence au langage dʼexpression
      10. Exemples dʼexpressions
    2. Automatisation
      1. Automatisation
      2. Scripts
  15. Vidéo immersive, VR et 3D
    1. Création dʼenvironnements VR dans After Effects
    2. Application d’effets de vidéo immersive
    3. Outils de composition pour les vidéos VR/360
    4. Suivi du mouvement de la caméra 3D
    5. Utilisation de lʼespace de conception 3D
    6. Aperçu des modifications apportées aux conceptions 3D en temps réel avec le moteur en temps réel
    7. Ajout de Responsive Design à vos images
  16. Vues et prévisualisations
    1. Prévisualisation
    2. Prévisualisation vidéo à lʼaide de Mercury Transmit
    3. Modification et utilisation des vues
  17. Rendu et exportation
    1. Notions de base relatives au rendu et à lʼexportation
    2. Exportation dʼun projet After Effects en tant que projet Adobe Premiere Pro
    3. Conversion de films
    4. Rendu multi-images
    5. Rendu automatisé et rendu en réseau
    6. Rendu et exportation dʼimages fixes et de séquences dʼimages fixes
    7. Utilisation du codec GoPro CineForm dans After Effects
  18. Utilisation dʼautres applications
    1. Dynamic Link et After Effects
    2. Utilisation dʼAfter Effects et dʼautres applications
    3. Synchronisation des paramètres dans After Effects
    4. Travail en collaboration avec les Team Projects
    5. Partage et gestion des modifications avec les collaborateurs du Team Projects
    6. Bibliothèques Creative Cloud dans After Effects
    7. Plug-ins
    8. CINEMA 4D et Cineware
  19. Mémoire, stockage et performances
    1. Mémoire et stockage
    2. Amélioration des performances
    3. Préférences
    4. Configuration requise du GPU et du pilote GPU pour After Effects

Présentation de la fonction Suivi du visage

Le suivi du visage permet de détecter et de suivre précisément les visages humains. Le suivi de masque simple vous permet d’appliquer rapidement des effets affectant uniquement le visage, par exemple une correction de couleur sélective, le floutage du visage d’une personne, etc.

Par ailleurs, avec la fonction Suivi du visage, vous pouvez effectuer le suivi de points précis du visage, tels que les pupilles, la bouche et le nez, ce qui vous permet d’isoler ces traits et de les traiter de manière plus détaillée. Vous pouvez, par exemple, changer la couleur des yeux ou exagérer les mouvements de la bouche sans effectuer de réglages image par image.

After Effects vous permet également de mesurer les traits du visage. Le suivi des mesures du visage vous fournit des informations telles que le degré d’ouverture de la bouche et des yeux. Chaque point de données est isolé, ce qui vous permet d’affiner le contenu autant que vous le souhaitez. En outre, vous pouvez également exporter des données de suivi détaillées dans Adobe Character Animator pour procéder à une animation des personnages basée sur l’interprétation d’un acteur.

Le suivi du visage fonctionne, en grande partie, automatiquement. Vous pouvez toutefois obtenir des résultats encore meilleurs en commençant l’analyse sur une image représentant un visage droit, de face. Un éclairage approprié du visage peut améliorer la précision de la détection des visages.

Le panneau Suivi contient deux options de suivi de visage :

  • Suivi de visage (contour uniquement) : sélectionnez cette option si vous souhaitez suivre uniquement le contour du visage.
  • Suivi du visage (traits détaillés) : utilisez cette option si vous souhaitez détecter les emplacements des yeux (y compris les sourcils et les pupilles), du nez et de la bouche, et extraire éventuellement les mesures des divers traits. Cette option est obligatoire si vous souhaitez utiliser les données de suivi dans Character Animator.

    Si vous utilisez l’option Traits détaillés, un effet de points de suivi du visage est appliqué au calque. Cet effet contient plusieurs points de contrôle d’effet 2D avec des images clés, chacun étant lié aux traits détectés (par exemple, les coins des yeux et de la bouche, les emplacements des pupilles ou le bout du nez).

Suivi du contour d’un visage

  1. Dans After Effects, sélectionnez Fichier > Importer > Fichier. Accédez à l'emplacement du métrage, puis ajoutez-le au projet.

    Panneau Projet

  2. Faites glisser le métrage du panneau Projet vers une composition pour ajouter un calque.

    Ajout d’un calque à une composition

  3. Placez le repère d’instant présent sur une image présentant une vue de face du visage à suivre.

    Remarque :

    La détection des visages est améliorée si l'image initiale à suivre contient un visage droit et de face.

    Détection des visages

  4. Dessinez un masque fermé autour du visage, en englobant les yeux et la bouche. Le masque définit la zone de recherche pour localiser les traits du visage. Si plusieurs masques sont sélectionnés, le masque au premier plan est utilisé.

    Dessiner un masque

  5. Le masque étant sélectionné, choisissez Fenêtre > Suivi pour ouvrir le panneau Suivi. Définissez la méthode de suivi sur Suivi du visage (contour uniquement).

    Sélection d’une méthode de suivi

  6. Dans le panneau Suivi, effectuez le suivi vers l’avant ou vers l’arrière d’une image à la fois pour vous assurer que l’option fonctionne correctement, puis cliquez sur le bouton afin de commencer l’analyse de toutes les images.

  7. Une fois l’analyse terminée, les données de suivi du visage sont disponibles au sein de la composition.

Suivi des traits détaillés et extraction des mesures du visage

  1. Dans After Effects, sélectionnez Fichier > Importer > Fichier. Accédez à l'emplacement du métrage, puis ajoutez-le au projet.

  2. Faites glisser le métrage du panneau Projet vers une composition pour ajouter un calque.

  3. Placez le repère d'instant présent sur une image présentant une vue de face du visage à suivre.

    Remarque :

    La détection des visages est améliorée si l'image initiale à suivre contient un visage droit et de face.

  4. Dessinez un masque fermé autour du visage, en englobant les yeux et la bouche. Le masque définit la zone de recherche pour localiser les traits du visage. Si plusieurs masques sont sélectionnés, le masque au premier plan est utilisé.

  5. Le masque étant sélectionné, choisissez Fenêtre > Suivi pour ouvrir le panneau Suivi. Définissez la méthode de suivi sur Suivi du visage (traits détaillés).

  6. Dans le panneau Suivi, effectuez le suivi vers l’avant ou vers l’arrière d’une image à la fois pour vous assurer que l’option fonctionne correctement, puis cliquez sur le bouton pour commencer l’analyse de toutes les images.

  7. Une fois l’analyse terminée, les données de suivi sont accessibles dans un nouvel effet appelé Points de suivi du visage. Vous pouvez choisir d’accéder aux données de suivi du visage directement dans la composition ou via le panneau Effets (Fenêtre > Options d’effet).

    Options d’effet Points de suivi du visage

  8. Déplacez l’indicateur d’instant présent sur une image représentant une expression neutre du visage (pose « à l’arrêt »). Les mesures du visage sur d’autres images s’effectuent par rapport à la pose à l’arrêt. Dans le panneau Suivi, cliquez sur Définir la pose à l’arrêt.

  9. Dans le panneau Suivi, cliquez sur Extraire et copier les mesures du visage. Un effet Mesures du visage est ajouté au calque. Des images clés sont alors créées selon les calculs effectués à partir des données d'image clé de points de suivi du visage. Les données d'image clé de mesures du visage sont copiées dans le Presse-papiers du système en vue de leur utilisation dans Character Animator.

    Remarque :

    Les images clés des mesures du visage sont générées en fonction des données d’image clé des points de suivi du visage, par rapport à la pose à l’arrêt (voir étape 8).

    Options d’effet Mesures du visage

Référence des données de suivi du visage

Points de suivi du visage

L’effet Suivi du visage crée des points de contrôle d’effet pour plusieurs traits du visage, que vous pouvez visualiser dans le panneau Montage.

Mesures du visage

Si vous avez utilisé l’option Traits détaillés, vous pouvez extraire encore plus d’informations sous forme de mesures paramétriques des traits du visage, appelées Mesures du visage. Toutes les mesures affichées pour le visage dont vous avez effectué le suivi sont relatives à l’image de pose à l’arrêt.

Décalage du visage

Indique la position du visage, avec un décalage par rapport à la pose à l’arrêt qui est fixée à 0 %. Les points de données suivants sont relevés à partir des valeurs de décalage sur les axes x, y et z :

  • Décalage X
  • Décalage Y
  • Décalage Z

Orientation du visage

Indique les orientations du visage en 3D. L’orientation est mesurée en utilisant les points de données suivants, d’après les axes x, y, et z :

  • Orientation X
  • Orientation Y
  • Orientation Z

Œil gauche

Indique les différents points de mesure de l’œil gauche, et inclut les points de données suivants :

  • Distance du sourcil gauche
  • Ouverture de la paupière gauche
  • Regard X gauche
  • Regard Y gauche

Œil droit

Indique les différents points de mesure de l’œil droit, et inclut les points de données suivants :

  • Distance du sourcil droit
  • Ouverture de la paupière droite
  • Regard X droit
  • Regard Y droit

Bouche

Indique les différents points de mesure de la bouche, et inclut les points de données suivants :

  • Décalage X de la bouche
  • Décalage Y de la bouche
  • Largeur d’échelle de la bouche
  • Hauteur d’échelle de la bouche
Logo Adobe

Accéder à votre compte